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Maximizer System Requirements
The hardware and software requirements for each type of Maximizer 
installation are listed in the following tables. Please refer to the 
Maximizer website at www.maximizer.com for updated information.

These are the minimum system requirements for Maximizer, and 
your operating system may have higher requirements for some 
components, such as processor speed and RAM. 

Because Web Access (part of the Maximizer components for 
Microsoft IIS) may have to handle larger amounts of processing (as 
the number of concurrent Web Access clients increase), we 
recommend that you install Web Access on a server with dual or 
quad processors and more RAM than the minimum requirements. In 
addition, it is recommend that customers that are planning a 
deployment of Web Access on a server machine that potentially will 
have physical memory demands in excess of four gigabytes of 
physical RAM deploy on a 64-bit operating system.

Maximizer CRM Enterprise Edition System Requirements

The following table lists the system requirements for Maximizer CRM 
Enterprise Edition server. For the latest list of supported software, go 
to www.maximizer.com. 

Server

Minimum Processor Speeda 1.6 GHz (minimum)
Quad Core 2.0 GHz or faster processor 
per server (recommended)

Available RAMa 4 GB (minimum)
8 GB (recommended)

Available hard disk space 10 GB or more

Minimum video resolution SVGA (1024x768) or higher-resolution 
video adapter and monitor

Operating system Microsoft Windows Server 2008, 2008 R2, 
2012, 2012 R2, or 2016 (32-bit and 64-bit 
editions)
* It is recommended to update to the 
latest service packs.

Database software Microsoft SQL Server 2008, 2008 R2, 2012, 
2014, or 2016 (updated to their latest 
service packs) with full-text search 
enabled
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Reporting services Microsoft SQL Server Reporting Servicesb 
with Microsoft SQL Server 2008 R2 Service 
Pack 1 or later, SQL Server 2012, 2014, or 
2016

Email system 32-bit MAPI-compliant, or
SMTP (Email Service)

Software on the server where 
Maximizer components for 
Microsoft IIS are installed

Microsoft Internet Information Server 7.0 
(Windows Server 2008), 7.5 (Windows 
Server 2008 R2), 8.0 (Windows Server 
2012), 8.5 (Windows Server 2012 R2), or 
10 (Windows Server 2016)

Internet speed 1.5 Mbps (minimum)
2.5 Mbps or higher (recommended)
* For a large number of users you will 
want to increase Internet speed.

a. Because Web Access (Maximizer components for Microsoft IIS) may have 
to handle larger amounts of processing (as the number of concurrent 
Web Access clients increase), we recommend that you install Web Access 
on a server with dual or quad processors and more RAM than the 
minimum requirements. In addition, it is recommend that customers that 
are planning a deployment of Web Access on a server machine that 
potentially will have physical memory demands in excess of four 
gigabytes of physical RAM deploy on a 64-bit operating system.

b. It’s recommended that the Maximizer CRM SQL Reporting Services 
Integration runs on its own instance of Microsoft SQL Server Reporting 
Services.

Server
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Maximizer CRM Modules and Components
• Maximizer CRM is a robust contact, campaign, opportunity, 

and order management tool. It provides invaluable assistance in 
tracking customer interaction and purchase history, planning 
and management of sales opportunities using customizable sales 
strategies and automatically calculating the probability of close 
at every stage. With the creation of meaningful graphs and 
charts, companies benefit from complete, detailed intelligence 
to fully understand their audience and evaluate the 
performance of their business.

• Administrator is used by a system administrator or IT staff to 
configure the entire Maximizer system and manage users and 
security. From Administrator, you can create and manage 
Maximizer databases (called “Address Books”), back up your 
data, import and export Address Book information, produce 
system reports, and perform other administrative tasks.

Modules and Components

• Customer Access is a browser-based application providing a 
two-way flow of information between your organization and its 
customers. 

• Dashboards are a component of Maximizer Web Access that 
can be used for monitoring activities in your company. The 
information you see in dashboards is generated in real-time, so 
you have an up-to-date view of the activities taking place in 
Sales and Marketing. Information, such as how many 
opportunities are in the funnel and your daily revenue from 
online purchases, are accessible instantaneously.

• Maximizer Web Access is a browser-based application 
providing your organization’s employees with the functionality 
of Maximizer from anywhere in the world.

• Mobile Access provides access to Maximizer through mobile 
web browsers. When users go to Start > Programs > Maximizer 
CRM > Web Access > Mobile Access, a URL displays. They can 
enter this URL into a mobile device to access Mobile Access.

• Partner Access is a browser-based application providing two-
way flow of information between your organization and its 
business partners. A multi-tier distribution group can effectively 
distribute sales opportunities and keep all involved parties 
informed about the latest discussion topics and customer service 
cases.
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Sample Address Books
Maximizer includes sample Address Books to help you learn the 
program.

A typical server installation of Maximizer installs a complete sample 
Address Book called “Escona Tutorial”, which is used throughout the 
Maximizer documentation. You can use the Escona Tutorial Address 
Book while you are learning to use Maximizer. 

Maximizer also installs several other sample Address Books for a 
variety of industries. You can use a sample Address Book appropriate 
to your industry as a starter Address Book.

You can access the sample Address Book for all components of 
Maximizer with the following user ID: 

User ID: MASTER

Password: control

Use the sample Address Books for learning and testing purposes only, 
and create a new Address Book for your organization’s data. The 
sample Address Books are overwritten if you re-install, so you don’t 
want to store your organization’s data in those Address Books.
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Network Configuration
The following diagram is an example of how Maximizer CRM can be 
deployed. This example demonstrates the use of multiple servers, 
firewalls, intranet, and Internet connections.

In this example, remote employees, partners, and customers can 
connect through the Internet using Maximizer Web Access or a 
mobile device with Mobile Access. Employees can also connect 
through your intranet. The Maximizer database and Microsoft SQL 
Server Reporting Services (SSRS) can reside on a single server or on 
different servers.

Your network setup will depend on the configuration and the 
components you choose to install.
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Related Documentation
This guide is one source of documentation included with Maximizer, 
and the following additional resources are available:

• Online Help (Help > Online Help) provides additional 
information about using Maximizer and Administrator.

• The Maximizer CRM Web Access User’s Guide is your 
reference guide to using Maximizer. This guide is available in 
PDF format from the Help menu in Maximizer Web Access.

• The Maximizer CRM Customization Suite includes additional 
guides for integrators. When the Customization Suite is 
installed, these guides are available in PDF format from the 
Maximizer Customization Suite folder in the Windows Start 
menu. The Customization Suite enables customers and business 
partners to customize the Maximizer interface and to integrate 
with other front-office and back-office solutions.

• The Maximizer website (www.maximizer.com) provides the 
latest product information. It also includes a searchable 
Knowledge Base at www.maximizer.com/knowledgebase.
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C H A P T E R22Setting Up
Microsoft SQL Server

In this chapter...

“Planning the Installation” on page 10

“Installing Microsoft SQL Server” on page 10

“Full-Text Search Component of SQL Server” on page 13
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Planning the Installation
This chapter describes how to install Microsoft SQL Server 2008 for 
use with Maximizer. If you are using a different version of Microsoft 
SQL server, the procedure may differ. For more information about 
Microsoft SQL server, refer to the documentation from Microsoft.

Before installing SQL Server software, ensure the server computer 
meets the minimum system requirements as specified in your 
operating system documentation, SQL Server documentation, and 
“Maximizer System Requirements” on page 2. You must also 
consider the following two issues:

• How will the Microsoft SQL Server service log in?

• Should the client use per-seat or per-processor licensing for the 
connection to Microsoft SQL Server?

Both of these issues are addressed below.

Installing Microsoft SQL Server
For more information 

regarding Microsoft SQL 
Server, consult the Microsoft 
SQL Server website at 
http://www.microsoft.com/sql.

Once you have determined how Microsoft SQL Server will log in and 
which licensing to use, you can install the software. There are several 
SQL Server components to install, depending on which features of 
Maximizer you plan to use:

• SQL Server Database Server – This is the main component and 
is required. For detailed installation instructions, refer to 
“Installing a Database Server” on page 11.

After installing Microsoft SQL Server, you must install the most 
recent Service Pack. 

• SQL Server Reporting Services – This component for SQL 
Server is required for the Maximizer integration with SQL Server 
Reporting Services.

For more information on SQL 
Server Reporting Services, see 
“About Microsoft SQL Server 
Reporting Services” on 
page 268.

If you plan on integrating SQL Server Reporting Services with 
Maximizer Web Access, you must SQL Server 2008 R2 Service Pack 
1 or later. If you are using an earlier version of SQL Server, you 
should install a separate instance of SQL Server for the 
integration with Maximizer.
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Installing a Database Server

When installing Microsoft SQL Server Database Server, you may 
install it as a service and include the Full-Text Search component. 

The following procedures provide detailed instructions for installing 
the standard editions of Microsoft SQL Server 2008 Database Server. 
If you are using a different version of Microsoft SQL Server, the 
procedure may differ. For more information about Microsoft SQL 
Server, refer to the documentation from Microsoft.

➤ To install Microsoft SQL Server 2008 Standard 
Edition

� Insert the installation disc.

� Start the SQL Server 2008 Standard Edition installation.

� Accept the licensing terms and conditions, and click Next.

The wizard notifies you if any additional components are 
required.

� Click Install to install prerequisite components. You may need 
to restart your computer to completely install the components.

When the prerequisite component installation is complete, the 
SQL Server Installation Center appears.

� Click Installation.

� Click New SQL Server stand-alone installation or add 
features to an existing installation.

The SQL Server 2008 Setup starts. The installation wizard checks 
the setup support rules.

� Click OK.

	 Enter the product key, and click Next.


 Accept the license terms, and click Next. 

��Click Install to install the setup support.

The installation wizard runs the setup support rules.

��Click Next.

��Select all the desired features, and click Next.
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��Specify whether to use a Default or Named instance, and 
click Next.

If you are uncertain, select Default instance. For information 
about default and named instances, refer to the Microsoft SQL 
Server 2008 documentation.

��Review the disk space requirements, and click Next.

��Choose a domain user account, and assign it to each SQL 
service. Enter the Username, Password, and Domain for each 
service, and click Next.

��Select Mixed Mode or Windows Authentication Mode 
(depending on your requirements). Create and enter a password 
for the sa logon account. Also provide at least one SQL Server 
administrator account, and click Next.

��If you selected to install Analysis Services, provide at least one 
SQL Server administrator account, and click Next. 

�	Select the Reporting Services configuration option, and click 
Next.

�
Select any error and usage report settings, as desired, and click 
Next.

The installation wizard checks the installation rules. 

��Click Next.

��Review the installation settings, and click Install to begin.

��When the installation is complete, click Next.

��Review the supplemental information, and click Close.

Microsoft SQL Server 2008 is now installed.
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Full-Text Search Component of SQL Server
The Full-Text Search component of Microsoft SQL Server applies to 
Search by Notes, Search by Documents, and Knowledge Base searches 
in Maximizer. The Microsoft SQL Server Full-Text Search component 
must be installed to use the full-text search functionality in 
Maximizer.

Full-Text Search is available in the Standard and Enterprise editions 
of Microsoft SQL Server. This component is installed by default, but if 
you need to install it after installing Microsoft SQL Server, 
instructions are included in this section. If Full-Text Search is installed, 
but you prefer not to use it, you can disable the Microsoft Search 
service though the Windows Control Panel on the SQL server.

To learn more about Full-Text Search in Microsoft SQL Server, refer to 
your Microsoft SQL Server documentation.

The following sections contain information on the full-text search 
component in SQL Server:

• “Using Full-Text Search in Maximizer” on page 13

• “File Types Available for Full-Text Search” on page 14

• “Enabling Full-Text Search in Existing Address Books” on 
page 15

• “Removing Full-Text Search Catalogs from Address Books” on 
page 17

Using Full-Text Search in Maximizer

The full-text search option is enabled if the Microsoft Search service 
is running and the full-text search indexes have been created. 
Otherwise, the option is disabled. Full-text search indexes are created 
during database creation or upgrade. However, you can also force 
creation of the indexes by executing the EnableFTIndexes.sql script.

When you run a search using full-text searching in Maximizer, the 
search returns only entries containing full words specified in the 
search text. If users search for text that is included in part of a word, 
the search does not return entries that contain that word. For 
example, if you search for “hedge”, only entries containing the word 
“hedge” are returned. Entries containing the word “hedgehog” are 
not returned.

Full-Text Search for Documents and Notes

The Search by Documents and Search by Notes functions in 
Maximizer include an option to “Perform search using Full-Text 
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Indexing”. This option performs queries using the “contains” 
keyword.

Note that when using full-text search to search by notes or 
documents, the search returns all notes or documents associated with 
the entry containing the matching note or document. The search 
does not return only the note or document matching the search text. 

For more information about full-text search, refer to the Microsoft 
SQL Server documentation.

Full-Text Search in the Knowledge Base

Full-text search is required for full-text searches in the Maximizer 
Knowledge Base. If full-text search is not enabled, the option for full-
text searching in the Knowledge Base is inaccessible. 

File Types Available for Full-Text Search

Full-text search results are 
dependent on the full-text 
search filter for the document 
type. For specific information 
about the full-text search 
behavior, refer to the full-text 
search filter provider’s 
documentation.

Using full-text search when searching by documents enables you to 
conduct full-text searches on the following file types: .DOC, .XLS, 
.PPT, .TXT, and .HTM.

Full-text searching does not search through Maximizer documents 
(.ETF files) and email messages saved as documents.

You can also download and install additional full-text search filters 
to enable full-text searching of other document types, such as .XML, 
.RTF, and .PDF:
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Information about third-party 
filters is included here for your 
information only. Maximizer 
cannot guarantee the 
functionality of third-party 
filters.

• Filters for .XML and .RTF files are available from Microsoft. For 
more information, visit the Microsoft website 
(www.microsoft.com), and search for “xml iFilter” or “rtf iFilter”. 

You could use the .RTF IFilter for full-text searching of Maximizer 
Word Processor documents. In the Maximizer Word Processor, 
save the your documents as .RTF files to search for the files using 
the .RTF IFilter.

• A filter for .PDF files is available from Adobe. For more 
information, visit the Adobe website (www.adobe.com), and 
search for “pdf iFilter”.

To use full-text search, the document being searched must be less 
than 16 MB in size, and it must not contain more than 256 KB of 
filtered text.

Enabling Full-Text Search in Existing Address Books

If you create the Address Book before you install the Full-Text Search 
SQL component, the Address Book will not have the full-text search 
feature enabled. 

By default, the Escona Tutorial sample Address Book does not have 
full-text search enabled. This is to keep the Address Book compatible 
with SQL installations that do not have the Full-Text Search 
component.

These procedures apply only to 
SQL Servers where Maximizer 
has already been installed.

➤ To enable full-text search in an existing Address 
Book in SQL 2005/2008

� Open the SQL Server Management Studio (Start > Programs > 
Microsoft SQL Server 2005/2008 > SQL Server Management 
Studio).

If the Connect to SQL Server 
dialog box doesn’t open 
automatically, select File > 
Connect to Object Browser.

� Select the SQL Server where the Address Book resides.

� Log in to the server, and click OK

.

� Select New Query.
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� Change the database to the database that you want to enable 
full-text searching on in the drop down.

� Navigate to the SQL script file to run (these script files are 
located in C:\Program Files\Maximizer\DbScripts\SqlServer):

This step shows the default 
installation path for Maximizer 
program files. Your Maximizer 
program files may be installed 
somewhere else.

• To enable full-text search for notes, documents, and the 
Knowledge Base, run the EnableFTindexes.sql script.

� Select Execute

.

When the script is complete, the Full-Text Search component will 
be enabled in the Address Book.

➤ To verify that full-text search is enabled in an 
Address Book

This procedure applies only to 
SQL Servers where Maximizer 
has already been installed.

� Open SQL Server Management Studio.

� Expand the Console Root tree until you can see the Address 
Book (inside the Databases folder).

� Expand the Address Book node, and select Full-Text Catalogs.

If Full-Text Search is enabled, the following Full-Text Catalogs 
appear in the list.

Notes, documents, and Knowledge Base full-text catalogs:

• DocumentsCatalog

• KnowledgeBaseCatalog

• NotesCatalog
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Removing Full-Text Search Catalogs from Address Books

If you have problems with full-text searching, you can remove the 
full-text search catalogs from your Address Books. This procedure 
may fix problems that arise after moving an Address Book to a 
different server. After removing a full-text search catalog, you can re-
enable full-text search to regenerate the catalog for the Address 
Book.

➤ To disable full-text search in an Address Book

• Use SQL Server Query Analyzer to run the 
Drop_FTS_Indexes_script.sql script file on the Address Book. 
The script is located in the ...Maximizer\DBScripts\SqlServer 
folder.

For details on running script files on Address Books, refer to the 
procedure in “Enabling Full-Text Search in Existing Address 
Books” on page 15.
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Maximizer Components Requiring Microsoft IIS
Microsoft Internet Information Services (IIS) is required for the 
following Maximizer components:

• Maximizer Web Access sites

To support downloading 
emails that were saved to 
Documents from Maximizer 
Web Access, Extended MAPI 
must be installed on the IIS 
server. Installing Microsoft 
Outlook on the IIS server in 
Corporate or Workgroup mode 
satisfies this requirement.

• Automated campaigns, for statistics in email activities

IIS is included with all versions of Windows supported by Maximizer 
CRM.

Virtual Directories
The content and script/executable directories that IIS makes available 
to web clients are known as virtual directories.

When you create a new Address Book, virtual directories are created 
automatically for the various Maximizer components.

Maximizer Components Virtual Directory Name

Maximizer Web Access MaximizerWebAccess

Maximizer Web Access 
Administrator

MaximizerAdmin

Mobile Access MaximizerMobileAccess

Partner Access MaximizerPartner

Customer Access MaximizerCustomer

Automated campaigns Campaigns

Maximizer.Web.Data MaximizerWebData
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Web Server Permissions
If both Web server and NTFS 

permissions are set, 
permissions that deny access 
take precedence over those 
that grant access. 

Web server permissions affect all users accessing the site, ranging 
from the Anonymous user account to a user who is a member of the 
Administrators or Domain Admins group. Regardless of an account’s 
group membership, all accounts will be denied access equally. 
Therefore, when access to virtual directories is created for 
IUSR_ServerName, the exact same virtual directory restrictions will be 
placed on the IWAM_ServerName account.

Changing the Anonymous Web Access Account
To change the anonymous web access account, first create a new 
user account, then enable anonymous access for the account.

➤ To create an anonymous web access account

� Start Windows User Manager.

� Select the local domain by selecting Users > Select Domain.

� Create a new user account.

� Make the account a member of the Guests group.

� Confirm that the Guests group only has the right to log on 
locally by performing the procedure outlined in “Standalone 
Servers” on page 25.

➤ To configure the anonymous web access account in 
Windows Server 2008

� Start Internet Services Manager (available through Windows 
Administrative Tools).

� Select the default website or another website if more than one is 
available.

Web browsers enable the 
anonymous access option by 
default. It is recommended 
that you manually enter the 
Anonymous user account 
password, and that you disable 
the “Enable Automatic 
Password Synchronization” 
checkbox. Be sure that the 
password that you enter is 
identical to the existing 
password for the local 
Anonymous user account. 

� Double-click Authentication.

� Select Anonymous Access and click enable.

� Click edit.

The Edit Anonymous Authentication Credentials dialog box 
opens.

� Click Set and type the Username and Password for the 
account you created above. Click OK when you are finished.
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Setting Up the Maximizer IIS Production Environment
Maximizer is designed to meet the real-world infrastructure 
requirements of IT departments, including support for load 
balancing and demilitarized zones.

Maximizer uses the IIS Default 
Web Site on port 80. Other 
web sites running on the 
server must use different ports.

Maximizer Web Access makes use of Microsoft’s ASP.NET technology. 
If your company has implemented other web pages or solutions, it is 
strongly recommended that these pages are hosted on a separate IIS 
Server from the Maximizer Web Access sites.

The following sections contain information on IIS production 
environments:

• “Load Balancing” on page 22

• “Demilitarized Zone (DMZ)” on page 24

Load Balancing

In some deployments of Maximizer Web Access with a large number 
of users, more than one IIS server may be needed to handle the load. 
Network load balancing works with Maximizer Web Access to 
achieve this.

It may be advantageous to deploy network load balancing in a 
situation that includes the following:

• A single IIS server is running at high CPU usage levels and 
performance of Maximizer Web Access is poor only when many 
users are using the system.

• The SQL server serving the Maximizer Address Books is not 
running at high CPU usage levels.

• A set of servers of similar capacity are available to deploy 
Maximizer Web Access.

• The available IIS servers are all running Windows Server 2008 or 
later or a hardware load balancer is available.

Configuring Load Balancing

For Maximizer Web Access, network load balancing is configured in 
one of the following ways:

• Install multiple servers with the Maximizer IIS components and 
install the Network Load Balancing service in Windows on each 
server. See the Network Load Balancing documentation for 
information.

• Install and configure a hardware network load balancer in the 
network.
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Network load balancing must be configured with client affinity 
enabled meaning that each client has all IIS requests served by the 
same server and that the client's IP address is used to determine 
which server will serve the requests.

Each Maximizer IIS server must be configured identically and must 
have the same version of the Maximizer IIS components installed. 
When upgrading to a new version of Maximizer Web Access, 
upgrade each server to the new version before the new version goes 
online, and apply any customizations to all servers.

Benefits of Load Balancing

The main benefit of load balancing is that multiple IIS servers can be 
used to divide the IIS load transparently to users with very low 
performance overhead. It may be more economical to install many IIS 
servers of lower capacity than one high-capacity IIS server. If one IIS 
server loses connectivity or is taken offline for maintenance, users 
may experience a session timeout as the load is rebalanced. But users 
will be able to log in again immediately and continue to use the 
system.

Drawbacks of Load Balancing

Network load balancing has the following drawbacks:

• The system is scaled to a larger number of users only if the SQL 
server can handle the load.

• Multiple IIS servers must be maintained with the same settings 
and version of the software. Otherwise, some users may be able 
to use the system while other users are not able to use the 
system. 

In some cases, users may access the system from an Internet service 
provider that frequently changes the client IP address as it appears to 
the server. This may cause frequent session timeouts when logged in 
to Maximizer Web Access.
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Demilitarized Zone (DMZ)

Security is the biggest priority for IT departments in most 
corporations. Demilitarized zone (DMZ) is the term used to describe 
the network area between the external router, which talks to the 
Internet, and the corporate firewall, which protects internal 
computers from Internet security breaches.

Maximizer has been designed to support network DMZs by enabling 
corporations to separate their database servers (usually located 
inside the firewall) from the IIS web machine (located in the DMZ). 
Communication between the database servers and the web server is 
handled by private ports configured by IT administrators. 
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Microsoft IIS Account Configuration
Most Windows servers are installed in network environments in 
which they provide services to client workstations. In such a 
configuration, the security considerations are often built around 
physical access issues. When Microsoft IIS’s World Wide Web 
Publishing Service is enabled, the server is suddenly placed in an 
environment that is accessible by external users who can be located 
virtually anywhere in the world. This situation requires that you 
exercise much more care in ensuring that the server is secure from 
unauthorized access.

The following section contains information on one type of IIS 
configuration:

• “Standalone Servers” on page 25

Standalone Servers

When IIS is installed on a standalone server (a server without 
membership in a Windows domain), the IUSR_ServerName account is 
made a member of the “Guests” local group. In most server 
environments, this configuration works well. 

➤ To configure the Guest local group in Windows Server 
2008

� Open Local Security Policy (available through Windows 
Administrative Tools).

For further information, refer 
to your Windows operating 
system documentation.

� Expand the Local Policies branch, and select User Rights 
Assignment.

� Right-click Allow log on locally, and select Properties from 
the shortcut menu.

� Add the <server_name>\Guest account to the list of allowed 
users. Click OK.

� Right-click Deny log on locally, and select Properties from the 
shortcut menu.

� Add the <server_name>\Guest account to the list of denied 
users. Click OK.
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Microsoft IIS on Windows Server 2008 or 2012
If your Microsoft IIS server is a Windows Server 2008 or 2012 
computer, you may need to perform the following steps before 
installing the Maximizer components for IIS:

• Enable the .NET framework.

• Install the required role services.

These procedures are written 
for Windows Server 2008. 
Steps may vary on Windows 
Server 2012 computers.

➤ To enable the .NET framework

� Open Server Manager.

� Select Features, and select Add Features.

� Select Microsoft .NET Framework.

The following features are required:

• On Windows 2008, under .NET Framework 3.0 Features, 
.NET Framework 3.0 and WCF Activation.

• On Windows 2008 R2, under .NET Framework 3.5.1 
Features, .NET Framework 3.5.1 and WCF Activation.

• On Windows 2012, under .NET Framework 3.5 
Features,.NET Framework 3.5, and under .NET 
Framework 4.5 Features, all items.

� Click OK.

➤ To install the required role services

� Open Server Manager.

� Click Roles.

The Maximizer components for 
IIS require that the Web Server 
(IIS) role be installed. If it is not 
already installed, use the Add 
Role wizard to install it.

� Under Web Server (IIS), select Add Role Services.

The Add Role Services dialog box opens. The following role 
services are required:

• Under Common HTTP Features, Static Content.

• Under Application Development, ASP.NET and .NET 
Extensibility.

• Under Security, Basic Authentication and Windows 
Authentication.

• Under Management Tools, all items.

� Click Next.

� If you are prompted, include additional components.
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� Click Install.

� When the installation is finished, click Close to close Server 
Manager.
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Microsoft IIS on 64-Bit Operating Systems
Maximizer requires the 32-bit version of ASP.NET 4.0 in order to run 
on a 64-bit operating system. To run the Maximizer components that 
require Microsoft Internet Information Services (IIS), you must enable 
32-bit applications in IIS. The procedures vary depending on the 
operating system running IIS.

Enabling 32-Bit Applications in Windows Server 2008 or 2012

In Windows Server 2008 or 2012, the Maximizer web applications 
should run under an application pool that has 32-bit applications 
enabled and that uses ASP.NET v4.0. If you do not need to run other 
applications on a 64-bit web server, you can specify these settings for 
the default application pool. 

If you need to use a 64-bit web server, you can add a new application 
pool with these settings and run the Maximizer applications under 
this application pool.

This procedure is written for 
Windows Server 2008. Steps 
may vary on Windows Server 
2012 computers.

➤ To enable 32-bit applications for the ASP.NET v4.0 
application pool

� In IIS Manager, select Application Pools.

� Select the ASP .NET v4.0 application pool.

� Click Advanced Settings.

� Next to Enable 32-bit Applications, select True.

� Click OK.
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Microsoft IIS for Windows Authentication
If you want to use Windows Authentication in the components that 
require Microsoft IIS, you must configure IIS for Windows 
Authentication.

IIS for Windows Authentication in Windows Server 2008 or 2012

To enable certain functionality 
in Maximizer Web Access and 
Maximizer Web Access 
Administrator such as the 
Auditing tab and System Audit 
Report, you must  set up 
Maximizer.Web.Data for 
Windows Authentication.

In Windows Server 2008 or 2012, you must set the authentication 
method for the Maximizer Web Access, Maximizer Web Access 
Administrator, Mobile Access, Maximizer.Web.Data, or Dashboard 
virtual directory or for the Admin subfolder of the Customer Access 
or Partner Access virtual directory. 

This procedure is written for 
Windows Server 2008. Steps 
may vary on Windows Server 
2012 computers.

➤ To set the authentication method for a virtual 
directory in Windows Server 2008

� In IIS Manager, select the virtual directory for the web access site.

– or –

To set up Windows Authentication for Customer Access or 
Partner Access, select the Admin subfolder of the virtual 
directory.

� Double-click Authentication. 

� Set the authentication settings depending on the following 
scenarios:

Scenario 1: SQL server is on the same machine as IIS, or 
Delegation is set up between IIS and SQL.

• Enable Windows Authentication and ASP.NET 
Impersonation. All other options must be disabled.

Scenario 2: All other configurations.

• Enable Basic Authentication and ASP.NET 
Impersonation. In this situation, SSL should always be set up 
in a production environment to protect the users' passwords 
since Basic Authentication is not encrypted.

• Right-click on Basic Authentication and select Edit to 
change the basic authentication settings.

• Set the Default domain so that users can type username 
instead of domain\username when logging in. 

• Set the Realm to describe the location of the server.

If the necessary options are not available, you can turn them on. 
Go to Control Panel > Programs and Features. Select Turn 
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Windows features on or off. Expand Roles and select Web Server 
(IIS). Click Add Role Services and enable Windows Authentication 
or Basic Authentication. When you go back into IIS Manager, the 
required features should be available.
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Setting File and Directory Permissions
The virtual directory system for IIS comprises only half of the 
directory security system. To complement the virtual directory 
security, file and directory permissions for all of the physical 
directories that virtual directories reference must also be made more 
secure. In a default Windows Server installation, the “Everyone” 
group is given full Directory and File permissions for almost all 
directories on the server. Although this is a convenient feature for a 
newly installed server, it provides very poor security. 

During the installation, the Maximizer setup creates the following 
folders on the server:

• ...\All Users\Application Data\Maximizer\AddrBks

• ...\All Users\Application Data\Maximizer\SvrShare

By default, these folders have full access rights. You may change the 
security rights to provide access to only specific users and/or groups.

➤ To remove the “Everyone” group

� Start Windows Explorer and browse to the ...\Inetpub\scripts 
directory (typically, C:\InetPub\scripts).

� Select the scripts directory, and select File > Properties.

� Select the Security tab.

� Highlight the Everyone group in the Name list box, and click  
Remove. 

The Everyone group is removed from the list.

� Click Add.

The Select Users, Computers, or Groups dialog box opens.

� Select the Guest or Domain Guest group, and click Add.

� Click OK.

	 In the Permissions list box, select the Read checkbox from the 
Allow column.


 Click OK.



Maximizer CRM
Administrator’s Guide

32

Adding Support for File Types
Some Maximizer features may require you to add support for 
different file types to the Default Web Site on your IIS server. You 
can use IIS Manager to register additional Multipurpose Internet Mail 
Extensions (MIME) types for your server. 

You may be required to register MIME types in the following 
situations:

• To add to the list of supported document types in Maximizer 
Web Access.

The procedure for registering MIME types varies depending on the 
version of Windows you are using.

➤ To register MIME types in Windows Server 2008

� On the Maximizer IIS server machine, open the IIS Manager.

� Open the Default Web Site.

� Double-click the MIME Types icon.

� Click Add.

� Enter the file extension and MIME type to be supported.

� Click OK to add the specified MIME type.
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Installation Checklist
Although the process of installing Maximizer CRM is straightforward, 
a successful installation requires planning and attention to detail. In 
its simplest arrangement, all Maximizer CRM components may be 
installed on a single Windows machine. However, for large 
installations, it is optimal to designate a single machine for each 
component. 

Depending on the network 
configuration, you may have 
more than one of each 
component machine. However, 
there is only one Maximizer 
Application Server.

• Step 1: Identify the Key Server(s)

• Step 2: Ensure the Servers Meet System Requirements

• Step 3: Verify SQL and Network Connectivity

• Step 4: Install Maximizer

• Step 5: Install Additional User Licenses

• Step 6: Activate the Software

The following sections outline the steps for a large installation in 
which each Maximizer component—such as SQL Server, IIS Server, 
Maximizer Server—is isolated on a separate machine.

Step 1: Identify the Key Server(s)

Identify the Maximizer Application Server, SQL Server, and IIS Server. 
Other additional key servers are the and Email Server. For 
information on the role of each server, see “Servers Required for 
Maximizer Installations” on page 35.

Step 2: Ensure the Servers Meet System Requirements

After identifying the key servers, you should ensure that they meet 
the minimum system requirements. See “Maximizer System 
Requirements” on page 2.

Step 3: Verify SQL and Network Connectivity

Verify that connectivity exists between the SQL Server and all key 
network servers (IIS Server, SMTP Mail Server, Maximizer Server, etc.). 
For more information see “Verifying SQL Connectivity” on page 37 
and “Verifying Network Connectivity” on page 39.

Step 4: Install Maximizer

Install Maximizer components on all applicable computers.

For more information see the following sections:

• “Installation Order of Maximizer Components” on page 46
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• “Installing Maximizer CRM Server” on page 47

• “Installing Maximizer Companion Applications” on page 58

Step 5: Install Additional User Licenses

Install licenses for any additional Maximizer users. This step is 
required only if you are installing Maximizer in a multiple-user 
environment. For more information, see “Installing Licenses” on 
page 66.

Step 6: Activate the Software

Activate your Maximizer licenses. You can use Maximizer for a 
limited period of time before activating the software. Once this 
grace period is over, you will be unable to log in to Maximizer or 
administrator until you activate the software.

You are prompted to activate the software when you first log in. You 
can also activate the software from the Install Multi-user Licenses 
dialog box.

If you install additional licenses after activating Maximizer, you must 
activate the multi-user licenses in order to use them.

Servers Required for Maximizer Installations

• Maximizer Application Server: The Maximizer Application 
Server is the machine where the Maximizer CRM Server 
application is installed, and it acts as a file server. Additionally, 
the Maximizer Server machine contains the Maximizer Email 
Service and Maximizer Print/Fax Service. The Maximizer Server 
machine must be capable of sharing folders. These folders store 
template and configuration information specific for each 
Address Book as well as global information for all Address Books. 
It is advisable to back up the Maximizer Server on a consistent 
basis.

• SQL Server: The SQL Server machine is typically a designated 
machine running only SQL Server. It should not have other 
applications installed on it, including Maximizer CRM.

• SQL Server Reporting Services Server: The SQL Server 
Reporting Services machine can be the same computer running 
SQL Server or it can be running on a different computer. If you 
plan to use SQL Server Reporting Services for any purposes other 
than integrating with Maximizer Web Access, you should install 
a dedicated instance of SQL Server for the integration.

• IIS Server: The IIS Server hosts the web server components, 
including web access sites. To run these components, the IIS 
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Server must have SQL connectivity with the SQL Server machine. 
Typically, the web server is separated from the rest of the 
network by a firewall. Even if a firewall exists between the IIS 
Server and SQL Server, SQL connectivity must exist to run 
Maximizer Web Access.

• Email Server: The Email Server supports marketing campaigns, 
appointment reminders, and customer service case notifications. 
It must be capable of sending SMTP. 
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Verifying SQL Connectivity

➤ To verify SQL Connectivity

� Open Data Sources (ODBC).

Select Start > Control Panel > Administrative Tools > Data 
Sources (ODBC).

� Click the System DSN tab.

� Click Add.

� In the Create New Data Source dialog box, select SQL Server 
from the scroll list, and click Finish.

� Enter a Name and Description, select the Server from the 
drop-down list, and click Next.
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� Select the authentication options as specified by your system 
administrator, and click Next.

If you have a reason to use a 
database other than master as 
the default, you can select the 
Change the default database 
to checkbox, and select an 
alternate database.

� Leave master as the default database, and click Next.

	 Leave the default options selected on the final screen (although 
you can change them if you have reason to), and click Finish.
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 Review the settings, and click Test Data Source.

If the connectivity test is successful, it returns the message 
“TESTS COMPLETED SUCCESSFULLY!”

��Click OK to close this dialog box, and then click OK again to 
close the ODBC Microsoft SQL Server Setup dialog box.

Verifying Network Connectivity

➤ To verify network connectivity using the ping 
command

� At the designated Maximizer Server computer, click Start > Run.

� Type command, and press Enter.

A Windows command prompt window opens.
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� At the command prompt, type ping <IP address>, and press 
Enter.

<IP address> is the IP address of the computer you are trying to 
connect to over the network.

� Read the messages returned by the ping command and note 
whether the ping was successful.

• “Reply from ...” = success

• “Request timed out” = failure

� View the ping statistics to determine the quality of the network 
connection.

� If the ping command failed, or if the ping statistics reveal a poor 
quality connection, then troubleshoot the network connection 
to correct the problem.

� Repeat these steps to ping the rest of the computers in the 
network.

➤ To determine a computer’s IP address

� At the computer whose IP address you want to determine, click 
Start > Run.

� Type command, and press Enter.

A Windows command prompt window opens.

� At the command prompt type ipconfig. 

The window displays the computer’s IP address, subnet mask, 
and default gateway, as well as additional network information.

� Write down the computer’s name and IP address for reference.
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Third-Party Components Installed with Maximizer
The Maximizer CRM installation includes the following third-party 
products:

• Microsoft SQL Server Express Database Engine

• Microsoft .NET Framework

• Microsoft SQL Server Reporting

The type of Maximizer installation determines which of these 
components are installed. 

Microsoft SQL Server Express Database Engine

Microsoft SQL Server Express is not included in the typical installation 
of Maximizer. But you can run a custom installation to install it.

If you are upgrading from 
Maximizer CRM 10.x, you 
must uninstall the Maximizer 
instance of SQL Server 2005 
Express before installing the 
Maximizer instance of SQL 
Server 2014 Express. Refer to 
the Maximizer knowledge 
base for detailed information.

The following Maximizer operations require the SQL Server Express 
database engine:

• email transfer

The following Maximizer operations require the Pervasive.SQL 
database engine, which must be installed from the disc of a previous 
version of Maximizer or downloaded from the Pervasive website:

• upgrading an existing Pervasive or Btrieve Address Book

Microsoft SQL Server Management Studio Express

Microsoft SQL Server Management Studio is a tool you use to 
manage your database. It is not included in the typical installation of 
Maximizer. But you can run a custom installation to install it. 

If you require SQL Server Management Studio Express to be installed 
on a drive other than the default Maximizer program folder drive, 
you can run the installation from the Maximizer CRM disc. The setup 
is found in the following location:

• MaxCRM\3RDPARTY\SQLExpr

Microsoft .NET Framework

The Microsoft .NET Framework installs automatically with the “Install 
Maximizer Components for Microsoft IIS” option.
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Windows Login Account Rights Required for Installation
To install Maximizer CRM, you must be logged in to Windows using 
an account with Windows Administrator privileges. During 
installation, you may be required to reboot the computer, and then 
you must log in to Windows using an account with Windows 
Administrator privileges again so the installation can continue.



Chapter 4
Installing Maximizer

43

Shared Folders and Permissions
For information about the 

virtual directories created 
during installation and their 
permissions, refer to “Virtual 
Directories” on page 368.

When installing Maximizer CRM Server, the following shared folders 
are created in the ...\Documents and Settings\All Users\Application 
Data\Maximizer\ folder on the server:

Folder name Shared name Description

AddrBks MxData Contains Address Books and Sample 
Address Books.

Share Permissions of Everyone with 
Change and Read (not Full Control).

SvrShare MxServer Share Permissions of Everyone with 
Change and Read (not Full Control).
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Upgrading from a Previous Version of Maximizer
ALWAYS back up the Address 

Book before upgrading 
Maximizer. For instructions on 
backing up, refer to “Backing 
Up and Restoring Address 
Book Data” on page 284. If 
you have customized the 
dictionary, also back up that 
file separately before 
upgrading.

If you are currently running an earlier version of Maximizer and want 
to upgrade, it is strongly recommended that you uninstall the 
previous version before proceeding with the upgrade.

Note that the Wireless Access site from previous releases is now 
renamed Mobile Access. The name of the default virtual directory 
and URL have also changed. In previous releases the name of the 
virtual directory was "MaximizerWireless". You can specify a 
different name for the virtual directory while installing Maximizer. If 
you keep the default virtual directory, you may need to update the 
Mobile Access URL specified in Administrator. Mobile Access users 
should also update bookmarks so they reflect the new URL.

➤ To upgrade to the new version of Maximizer

� Back up your Maximizer Address Book. Refer to “Backing Up and 
Restoring Address Book Data” on page 284 for instructions.

� If you have customized the dictionary, also back up that file 
separately before upgrading. For instructions, refer to “Backing 
Up the Dictionary File” on page 284.

� Uninstall Maximizer CRM, and any additional Maximizer 
components on all computers.

For instructions on uninstalling Maximizer, see “Removing 
Maximizer” on page 44.

� Install the new version of Maximizer.

� If you use Maximizer in a multiple-user environment, install 
additional user licenses.

For more information, see “Installing Licenses” on page 66.

� Activate the software.

You can activate the software and all installed licenses when you 
open Maximizer or Administrator and when you install multi-
user licenses.

� Upgrade your Maximizer Address Book database to the new 
version, as described in “Upgrading or Converting an Address 
Book” on page 83.

Removing Maximizer

You can uninstall Maximizer to remove it from your computer. When 
you uninstall Maximizer CRM, you have the option of removing or 
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keeping registry settings and program files. If you want to 
completely remove the program, you should select this option. If you 
want to reinstall Maximizer, you may want to keep these settings. 
Any settings stored in the database are not removed when you 
uninstall Maximizer.

➤ To uninstall Maximizer

Uninstalling Maximizer does 
not uninstall your Address 
Book data. However, you 
should always back up your 
Address Book before 
uninstalling.

� Click Start > Settings > Control Panel > Add/Remove 
Programs.

� In the list of currently installed programs, select Maximizer 
CRM.

� Click Change/Remove.

If you are uninstalling Maximizer CRM, you have the option to 
remove all related files and registry settings from the computer. 
If you plan on reinstalling Maximizer, it’s recommended that you 
do not select this option to preserve Maximizer settings on the 
computer.

� To remove all Maximizer files and settings from the computer, 
select Remove all related files, folders, and registry 
settings.

� Click Yes to confirm.

The Remove Programs From Your Computer dialog box displays 
the uninstall progress.

� If the Remove Shared File? dialog box opens, click No To All.

� When the uninstall is complete, click OK to close the dialog box.

	 Reboot the computer.
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Installation Order of Maximizer Components
Once the key servers (SQL Server, IIS, and Email) are ready, you 
should install and configure the Maximizer components in the 
following order:

� Maximizer Server – Refer to “Installing Maximizer CRM 
Server” on page 47.

� Maximizer Components for Microsoft IIS – Refer to 
“Installing Maximizer Components for Microsoft IIS” on page 54.



Chapter 4
Installing Maximizer

47

Installing Maximizer CRM Server
You must be logged in to 

Windows as an administrator 
to install Maximizer. After 
installation, you may be 
prompted to restart the 
computer, and then you must 
log in as an administrator 
again to complete the 
installation.

An installation wizard steps you through the process of installing the 
software on the server. The instructions in this section complement 
the wizard to provide additional information.

Note that Maximizer Web Access, Customer Access, Partner Access, 
and Mobile Access are installed automatically with Maximizer CRM 
Server when the Maximizer Components for Microsoft IIS option is 
selected. You can enable the sites while installing Maximizer CRM 
Server or later. For information on enabling sites, see “Enabling Web 
Access Sites” on page 189. 

IMPORTANT NOTE FOR CONFIGURATIONS RUNNING THE 
MAXIMIZER APPLICATION SERVER AND MICROSOFT IIS SERVER 
ON THE SAME MACHINE: 

In a typical Maximizer CRM environment, the Maximizer application 
server and Microsoft IIS server are on two separate machines, and 
you must run the Maximizer CRM Server setup once on each 
machine:

• First install Maximizer Server on the Maximizer application 
server machine, using the Maximizer CRM Server disc.

• Then install Maximizer Components for Microsoft IIS on the 
Microsoft IIS server machine, using the Maximizer CRM Server 
disc.

However, if your Maximizer application server and Microsoft IIS 
server are running on the SAME machine, do not attempt to run the 
Maximizer CRM Server installation twice on the same machine. 
Instead, select both options in step 7 of the following procedure.

➤ To install Maximizer

� Close all programs running on the computer.

� Insert the Maximizer CRM disc.

The setup starts automatically.

If the setup doesn’t start 
automatically, you can start it 
manually by running setup.exe 
from the MaxEnt folder of the 
disc (e.g., \MaxEnt\setup.exe).

� Select Install Maximizer CRM Server.

The InstallShield Wizard starts.

� Click Next to begin the installation.

� Read the license agreement, and click Yes to continue.

� Enter your Customer Number, Product Serial Number, and 
your contact information, and click Next.
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� Select Maximizer Server, and click Next.

NOTE: If you are installing Maximizer Server on the machine that 
is also your IIS Server, you must select both Maximizer Server 
and Maximizer Components for Microsoft IIS now to install 
them both on the machine. 

To install Maximizer components for IIS, select Maximizer 
Components for Microsoft IIS.

	 Click Next to install Maximizer Server components to the default 
location.

– or –

Click Browse, select a destination folder, and click Next.

Do not change any default 
share names, file names, file 
locations, folder names, or 
folder locations after installing 
Maximizer. If you want to use 
names and locations other 
than the defaults, change 
them during the installation.


 Click Next to use the default folder for shared configuration 
information.

– or –
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Click Browse, select a local shared folder, and click Next.

Maximizer creates the 
“Maximizer” folder on the 
drive where the Windows 
operating system is installed. If 
your Windows operating 
system is not on the C drive, 
the path will have a different 
drive letter.

By default, Maximizer setup creates the folder ...\All Users\
Application Data\Maximizer on the server, and it creates two 
shared subfolders called AddrBks and SvrShare. These folders 
must be shared on the network so other PCs can access to 
resources installed to this location. The default Share name of 
AddrBks is “MxData”, and the default Share name of SvrShare is 
“MxServer”.

��Select a setup type, and click Next.

• Typical – installs a default set of server software, such as 
Windows services, server-side software, and drivers. It also 
installs a default set of Maximizer user applications on the 
server. Maximizer recommends that you select the Typical 
installation, unless you have a specific reason not to.

• Custom – enables you to select specific Maximizer modules 
to install. You can select virtually any combination of server 
software and user applications you want. Select this option 
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only if you have a specific reason to alter the default 
Maximizer installation provided by the Typical installation.

��(This step applies only to Typical installations) Select 
which sample Address Books to install.

��(This step applies to Custom Installations only.) Select 
which features to install on the server, and click Next.

If you would like to select additional components, click the + to 
expand the selection.

��Enter or select the SQL Server name, and choose to use SQL 
Server authentication or Windows Authentication.
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If you are using SQL Server Authentication, enter the SQL 
administrator User name and Password, and click Next.

This step prompts the installation to create the MaConfig 
database on the SQL Server that Maximizer CRM uses for its 
configuration settings.

If you are using Windows Authentication, enter or select the SQL 
Server name. You must also enter the Windows domain and 
the user credentials for a Windows account that has access to 
both the Maximizer server computer and the SQL Server. The 
Maximizer Email Service and the Maximizer Print/Fax Service will 
run using these credentials. 

��(The next 3 steps apply only if you selected Maximizer 
Components for Microsoft IIS in step 7.) The installation 



Maximizer CRM
Administrator’s Guide

52

prompts you to enter the name of your HTTP Server. Enter the 
name, and click Next.

��Specify the Website for the Maximizer Components for 
Microsoft IIS settings, and click Next.

If you choose to use an existing website, select the website from 
the drop down. Its identities are displayed in the website 
identities area.

If you choose to create a new website, enter the description, TCP 
port, IP address, and Host Header value.
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��Specify the name of the virtual directory for each of the web 
access sites, select Enabled for each site you want to enable, and 
click Next.

.

��Specify your SMTP Server settings, and click Next.

The SMTP Server is used by the 
Maximizer Email Service.

If your ISP requires authentication, you must select the 
Outgoing mail server requires authentication checkbox and 
enter the User name and Password of a valid account.

�	Select any of the following options, and then click Next:
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• Create Maximizer Start Menu shortcut – This option 
creates a shortcut to Maximizer on the Windows Start menu.

�
Review the installation settings, and click Next.

��(This step applies if the Database Components option is 
selected.) Select a location to install the database components 
or use the default location, and click Next.

��The wizard displays an installation progress indicator. After 
the installation is complete, click OK to close the message box.

The installation may prompt you to restart your computer. 

��Click Finish to close the wizard and restart the computer (if 
necessary).

��If your computer needed to restart, log in to Windows using 
an administrator account. This step is required to complete the 
installation.

If you are installing Maximizer CRM Server, and your Microsoft 
IIS server is on a different machine, install Maximizer 
Components for Microsoft IIS on your Microsoft IIS machine, 
from the Maximizer CRM Server disc, as described in the 
following section.

Installing Maximizer Components for Microsoft IIS

You must be logged into 
Windows as an administrator 
to install Maximizer. After 
installation, it prompts you to 
restart the computer, and then 
you must log in as an 
administrator again to 
complete the installation.

The Maximizer Components for Microsoft IIS installation is required 
to install the web access sites. Microsoft IIS must already be installed. 
To install Dashboard components for IIS, you must complete a custom 
installation of the Maximizer server and select the Dashboard 
Components for IIS option in the Select Features screen. For 
information on installing Maximizer server, see “Installing Maximizer 
CRM Server” on page 47.
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NOTE: The following procedure is to install Maximizer Components 
for Microsoft IIS only on a machine that is not the Maximizer 
application server. To add the Maximizer Components for Microsoft 
IIS to an existing Maximizer application server, ensure the installation 
media is accessible from the application server. For example, if you 
installed the Maximizer application server from the disc, the disc 
must be in the drive. If you installed the Maximizer application server 
from another machine on the network, the other machine must be 
accessible. Then, modify the Maximizer installation via the Add/
Remove Programs module in the Control Panel, and enable the 
Maximizer Components for Microsoft IIS option.

➤ To install Maximizer Components for Microsoft IIS

� Close all programs running on the server.

� Insert the Maximizer CRM Server disc. (The server and 
workstation versions are on separate discs.)

The setup starts automatically.

If the setup doesn’t start 
automatically, you can start it 
manually by running setup.exe 
in the MaxEnt folder of the disc 
(e.g., D:\MaxEnt\setup.exe).

� Select Install Maximizer CRM Server.

The InstallShield Wizard starts.

� Click Next to begin the installation.

� Read the license agreement, and click Yes to continue.

� Enter your Product Serial Number, First name, and Last 
name into the required fields, and click Next.

� Select Maximizer Components for Microsoft IIS, and click 
Next.

Maximizer Components for Microsoft IIS must be installed on 
one of your network servers. Select only this option if you are 
installing on the IIS Server and the Maximizer Server is on a 
different machine.

	 Click Next to install to the default location.

– or –

Click Browse, select a destination folder to install Maximizer 
CRM, and click Next.


 Click Browse, and select the same SQL Server that you selected 
for the Maximizer Server installation. 

��Enter the SQL administrator User name and Password, and 
click Next.
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If the setup is unable to stop 
the IIS Server, select Start > 
Settings > Control Panel > 
Administrative Tools > 
Services and stop the IIS 
Admin Service.

��Enter the name of the HTTP Server, and click Next.

The IIS Server can be identified to the web by a fully qualified 
domain name (e.g., “www.yourcompany.com”), by its IP address, 
or by its computer name. The most common choice is to use a 
fully qualified domain name. The other choices are provided for 
flexibility in the event that a fully qualified domain name is not 
available at the time of installation.

��Specify the Website for the Maximizer Components for 
Microsoft IIS settings, and click Next. 

If you choose to use an existing website, select the website from 
the drop-down list. Its identities are displayed in the website 
identities area.

If you choose to create a new website, enter the description, TCP 
port, IP address, and Host Header value.

��Specify the name of the virtual directory for each of the web 
access sites, select Enabled for each site you want to enable, and 
click Next.

��Review the installation settings, and click Next to begin 
installing.

The wizard displays an installation progress indicator.

When the installation is complete, the final step of the wizard 
appears, as shown below.

��Click Finish to close the wizard.

��After the computer restarts, log in to Windows using an 
administrator account. This step is required to complete the 
installation.

Maximizer Components for Microsoft IIS are now installed.

Setting Full Permissions to the Maximizer Web Access Temp Folder

After installing Maximizer and setting more secure permissions on 
the Maximizer directory (as described in “Setting File and Directory 
Permissions” on page 31), give the IIS/ASP.NET account full 
permissions to the following folder to allow documents to be 
downloaded from the Maximizer Web Access:

...\Program Files\Maximizer\Portals\Employee\Temp
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➤ To set full permissions to the Maximizer Web Access 
Temp folder

� On the IIS server, locate the following folder:

...\Program Files Maximizer\Portal\Employee\Temp

� Open the Security Properties for the Temp folder.

Right-click the Temp folder and select Security. Click 
Properties, then select the Security tab. Click Edit.

� Click Add.

� Click Locations

� Select the local machine.

� Enter IIS_USRS and click OK.

� Check Full Control.

	 Click OK.
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Installing Maximizer Companion Applications
The following table explains how to install each of the Maximizer 
companion applications. For information about each of these 
applications, refer to “Maximizer CRM Modules and Components” 
on page 4.

Installing Microsoft Office Integration for Maximizer Web Access

You can install Microsoft Word and Microsoft Outlook Integration 
for Maximizer Web Access on server and workstation computers. 
Each integration installs a Maximizer Web Access toolbar menu in 
Word or Outlook. These integrations are different from the 
Microsoft Office integrations that are available while installing 
Maximizer.

You can also install Word and Outlook integration directly in 
Maximizer Web Access. The procedure involves downloading ActiveX 
controls, which may be disallowed on some networks. For more 
information, see the Maximizer CRM User’s Guide.

➤ To install Word or Outlook integration for 
Maximizer Web Access

� Insert the Maximizer CRM Server disc.

The setup starts automatically.

� Select Browse this Disc.

� Open the Office_Integration folder.

� Double-click one of the following files:

• MSWordInt.msi to install Word integration.

• OutlookInt.msi to install Outlook integration

The InstallShield Wizard starts.

� Follow the steps outlined in the wizard to install the files.

Application Installation Instructions

Workflow Automation 
Powered by 
KnowledgeSync

On the Maximizer CRM Server Setup disc, 
select Install Workflow Automation 
Powered by KnowledgeSync and follow the 
on-screen instructions.

SQL Reporting Services 
Integration

Refer to “Installing SQL Reporting Services 
Integration” on page 269.
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Adding and Removing Maximizer CRM Components
Maximizer enables you to add and remove specific components of 
the software without having to reinstall Maximizer itself.

➤ To add or remove Maximizer CRM components

� Close all programs running on the computer

� Insert the Maximizer disc.

� On the Setup disc Autorun screen, select Install Maximizer 
CRM Server.

If the setup doesn’t start automatically, you can start it manually 
by running setup.exe from the MaxEnt folder of the disc (e.g., \
MaxEnt\setup.exe).

� Select Modify, and click Next.

Checkboxes are automatically selected for any currently installed 
components.

Expand the branches to add or 
remove sub-components.

� Select the checkbox beside any components to add.

� Clear the checkbox beside any components to remove.

If a component is already installed, and you want to keep it, do 
not clear the checkbox beside that component.

� Click Next.

Maximizer begins the update.
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Full-Text Search Component of SQL Server
The Full-Text Search component of Microsoft SQL Server applies to 
Search by Notes, Search by Documents, and Knowledge Base searches 
in Maximizer. The Microsoft SQL Server Full-Text Search component 
must be installed to use the full-text search functionality in 
Maximizer.

Full-Text Search is available in the Standard and Enterprise editions 
of Microsoft SQL Server. This component is installed by default, but if 
you need to install it after installing Microsoft SQL Server, 
instructions are included in this section. If Full-Text Search is installed, 
but you prefer not to use it, you can disable the Microsoft Search 
service though the Windows Control Panel on the SQL server.

To learn more about Full-Text Search in Microsoft SQL Server, refer to 
your Microsoft SQL Server documentation.

The following sections contain information on the full-text search 
component in SQL Server:

• “Using Full-Text Search in Maximizer” on page 60

• “File Types Available for Full-Text Search” on page 61

• “Enabling Full-Text Search in Existing Address Books” on 
page 62

• “Removing Full-Text Search Catalogs from Address Books” on 
page 64

Using Full-Text Search in Maximizer

The full-text search option is enabled if the Microsoft Search service 
is running and the full-text search indexes have been created. 
Otherwise, the option is disabled. Full-text search indexes are created 
during database creation or upgrade. However, you can also force 
creation of the indexes by executing the EnableFTIndexes.sql script.

When you run a search using full-text searching in Maximizer, the 
search returns only entries containing full words specified in the 
search text. If users search for text that is included in part of a word, 
the search does not return entries that contain that word. For 
example, if you search for “hedge”, only entries containing the word 
“hedge” are returned. Entries containing the word “hedgehog” are 
not returned.

Full-Text Search for Documents and Notes

The Search by Documents and Search by Notes functions in 
Maximizer include an option to “Perform search using Full-Text 



Chapter 4
Installing Maximizer

61

Indexing”. This option performs queries using the “contains” 
keyword.

Note that when using full-text search to search by notes or 
documents, the search returns all notes or documents associated with 
the entry containing the matching note or document. The search 
does not return only the note or document matching the search text. 

For more information about full-text search, refer to the Microsoft 
SQL Server documentation.

Full-Text Search in the Knowledge Base

Full-text search is required for full-text searches in the Maximizer 
Knowledge Base. If full-text search is not enabled, the option for full-
text searching in the Knowledge Base is inaccessible. 

File Types Available for Full-Text Search

Full-text search results are 
dependent on the full-text 
search filter for the document 
type. For specific information 
about the full-text search 
behavior, refer to the full-text 
search filter provider’s 
documentation.

Using full-text search when searching by documents enables you to 
conduct full-text searches on the following file types: .DOC, .XLS, 
.PPT, .TXT, and .HTM.

Full-text searching does not search through Maximizer documents 
(.ETF files) and email messages saved as documents.

You can also download and install additional full-text search filters 
to enable full-text searching of other document types, such as .XML, 
.RTF, and .PDF:
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Information about third-party 
filters is included here for your 
information only. Maximizer 
cannot guarantee the 
functionality of third-party 
filters.

• Filters for .XML and .RTF files are available from Microsoft. For 
more information, visit the Microsoft website 
(www.microsoft.com), and search for “xml iFilter” or “rtf iFilter”. 

You could use the .RTF IFilter for full-text searching of Maximizer 
Word Processor documents. In the Maximizer Word Processor, 
save the your documents as .RTF files to search for the files using 
the .RTF IFilter.

• A filter for .PDF files is available from Adobe. For more 
information, visit the Adobe website (www.adobe.com), and 
search for “pdf iFilter”.

To use full-text search, the document being searched must be less 
than 16 MB in size, and it must not contain more than 256 KB of 
filtered text.

Starting the Full-Text Search Service

Full-Text Search uses the SQL Full-text Filter Daemon Launcher 
service. This service is installed with the Maximizer instance of SQL 
Server Express. You should check that the service is started and if 
necessary start the service for the Maximizer instance of SQL server.

➤ To start the Full-Text Search service

� Open the Windows Services snap-in.

Select Start > Administrative Tools > Services or Start > 
Control Panel > Administrative Tools > Services.

� Locate the SQL Full-text Filter Daemon Launcher 
(MAXIMIZER) service.

In the Status column, you can see if the service is started or not. 

� If necessary, right-click and select Start to start the service.

Enabling Full-Text Search in Existing Address Books

If you create the Address Book before installing the Full-Text Search 
SQL component, the Address Book will not have the full-text search 
feature enabled.

By default, the Escona Tutorial sample Address Book does not have 
full-text search enabled. This is to keep the Address Book compatible 
with SQL installations that do not have the Full-Text Search 
component.
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These procedures apply only to 
SQL Servers where Maximizer 
has already been installed.

➤ To enable full-text search in an existing Address 
Book in SQL 2005/2008

� Open the SQL Server Management Studio (Start > Programs > 
Microsoft SQL Server 2005/2008> SQL Server Management 
Studio).

If the Connect to SQL Server 
dialog box doesn’t open 
automatically, select File > 
Connect to Object Browser.

� Select the SQL Server where the Address Book resides.

� Log in to the server, and click OK

.

� Select New Query.

� Change the database to the database that you want to enable 
full-text searching on in the drop down.

� Navigate to the SQL script file to run (these script files are 
located in C:\Program Files\Maximizer\DbScripts\SqlServer):

This step shows the default 
installation path for Maximizer 
program files. Your Maximizer 
program files may be installed 
somewhere else.

• To enable full-text search for notes, documents, and the 
Knowledge Base, run the EnableFTindexes.sql script.



Maximizer CRM
Administrator’s Guide

64

� Select Execute

.

When the script is complete, the Full-Text Search component will 
be enabled in the Address Book.

➤ To verify that full-text search is enabled in an 
Address Book

This procedure applies only to 
SQL Servers where Maximizer 
has already been installed.

� Open SQL Server Management Studio.

� Expand the Console Root tree until you can see the Address 
Book (inside the Databases folder).

� Expand the Address Book node, and select Full-Text Catalogs.

If Full-Text Search is enabled, the following Full-Text Catalogs 
appear in the list.

Notes, documents, and Knowledge Base full-text catalogs:

• DocumentsCatalog

• KnowledgeBaseCatalog

• NotesCatalog

Removing Full-Text Search Catalogs from Address Books

If you have problems with full-text searching, you can remove the 
full-text search catalogs from your Address Books. This procedure 
may fix problems that arise after moving an Address Book to a 
different server. After removing a full-text search catalog, you can re-
enable full-text search to regenerate the catalog for the Address 
Book.
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➤ To disable full-text search in an Address Book

• Use SQL Server Query Analyzer to run the 
Drop_FTS_Indexes_script.sql script file on the Address Book. 
The script is located in the ...Maximizer\DBScripts\SqlServer 
folder.

For details on running script files on Address Books, refer to the 
procedure in “Enabling Full-Text Search in Existing Address 
Books” on page 62.
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Installing Licenses
You must have enough licenses for the total number of enabled 
users across all installed Maximizer products, including Maximizer 
and Maximizer Web Access. When you purchase licenses from 
Maximizer Software, you receive a Product License Number (PLN), 
which includes licenses for a specified number of users. Once 
installed, licenses must be activated before they can be used. In order 
to activate your licenses you must have a current maintenance 
account.

Maximizer licenses are stackable. For example, if you have 14 licenses 
and want to upgrade to 32, you just need a new PLN for 18 users, and 
you can apply it in addition to the original 14-user PLN.

Note that the Maximizer system login accounts (EMAILUSER and 
WEBUSER) are always enabled and do not consume any Maximizer 
licenses. Also, the MASTER user account is always enabled, and it 
consumes a license only if you are logged in to Maximizer using the 
MASTER user account.

The following sections contain information on installing Maximizer 
licenses:

• “Installing a License” on page 66

• “Applying a License” on page 67

• “Viewing Applied and In-Use Licenses” on page 67

Installing a License

After you install Maximizer or purchase additional licenses, you must 
install the Product License Numbers (PLN). The following procedure 
applies to all Maximizer CRM products.

If you install additional multi-user licenses after activating 
Maximizer, you must activate the licenses before using them. In order 
to activate your licenses you must have a current maintenance 
account.

➤ To install a product license number (PLN)

� Run Administrator.

� Select Utilities > Install Multi-User License.

� Enter the PLN.

� Click Install License. 

� Repeat steps 3 and 4 to install any additional licenses.
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� To activate the licenses, click Activate. And in the Activation 
dialog box, click Activate again.

� Click Close.

Administrator closes automatically.

The next step is to apply the PLN(s) to the Address Books.

Applying a License

After you have installed a PLN, you must apply it to the Maximizer 
Address Book(s).

➤ To apply a product license number (PLN)

� After installing a PLN, start Administrator.

� Open and close each Address Book that you are applying licenses 
to.

The license has now been applied to the Address Book(s).

Viewing Applied and In-Use Licenses

➤ To view the number of applied and in-use licenses

• In Administrator, select Reports > Current Users.
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Activating Maximizer
In order to use your Maximizer software and licenses you must 
activate them. After installing Maximizer for the first time, you can 
use the software for a limited period of time before you are required 
to activate the software. Once this grace period is over, you will be 
unable to log in to any of your Maximizer products until you activate 
the software.

• You are prompted to activate the software when you first log in. 
You can also activate the software from the Install Multi-user 
Licenses dialog box in Administrator.

• If you install additional multi-user licenses after activating 
Maximizer, you must activate the licenses before you can use 
them to create new users.

• In order to activate your software and licenses, you must have a 
current maintenance account.

• If you upgrade from a version of Maximizer that has already 
been activated, there will be no grace period and you will need 
to activate the Maximizer software immediately before you can 
use it.

➤ To activate your software and licenses

� Run Administrator.

� Select Utilities > Install Multi-User License.

� Click Activate.

� Click Install License. 

� Verify that your Customer No. and Product serial number 
(PSN) are correct, and click Activate.

The software will attempt to contact Maximizer servers to verify 
your Customer Number and Product Serial Number and 
maintenance status. Once your information has been verified, a 
confirmation dialog is displayed to let you know that activation 
was successful.

If the Internet activation is unsuccessful, you are given the 
option to contact a Maximizer customer support representative 
to obtain an Activation Code that you can use to activate the 
software.

� Click OK to close the confirmation dialog. Your Maximizer 
software and all licenses are now activated.
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Where to Go from Here...
• Create a new Address Book or upgrade an existing Address Book 

to the latest version of Maximizer, as described in chapter 5 
“Creating or Upgrading Address Books” on page 71.

• Create login accounts for Maximizer users and assign users to 
security groups and sales and marketing teams, as described in 
chapter 6 “Setting Up Users, Groups, and Teams” on page 90.

• Configure Address Book preferences, including duplicate 
Address Book entry handling, user-defined fields, key fields, 
customer service and opportunity email notification templates, 
and event notification, as described in chapter 7 “Configuring an 
Address Book” on page 141.

• Configure the Address Book for access through Maximizer Web 
Access

Maximizer Web Access permit users to access the Maximizer 
Address Book data from any Internet-connected computer using 
a browser such as Internet Explorer. You can enable Maximizer 
Web Access by making certain modifications to the Address 
Book. See “Configuring Web Access” on page 185.

• For more information on converting a database, please refer to 
chapter 13 “Managing Address Book Data” on page 283.
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C H A P T E R55Creating or Upgrading
Address Books

In this chapter...

“What is Administrator?” on page 72

“Creating Address Books” on page 74

“Deleting Address Books” on page 77

“Maximizer System Login Accounts” on page 79

“Changing the MASTER User Password” on page 80

“Employing an Existing Address Book” on page 82

“Upgrading or Converting an Address Book” on page 83

“Time Zone Alignment” on page 87

“Importing Vertical Templates” on page 88
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What is Administrator?
Administrator is the administrative center of Maximizer. Use it to 
complete the following tasks:

• Create and configure Address Books.

• Set up user-defined fields for different types of entries.

• Manage Maximizer application settings.

• Customize Maximizer fields and settings.

• Manage users, sales/marketing teams, and security groups.

Once Administrator is running, you can open any Address Book and 
perform administrative tasks. There will be no database conflicts if 
you open an Address Book while it is in use by another user. 
(However, you should ensure all users have logged out before 
backing up or restoring the Address Book.)

➤ To log in to Administrator

� Click Start > Programs > Maximizer CRM > Administrator.

� Select an Address Book, and click Open.

The default MASTER user 
password is “control”, unless 
it has already been changed to 
another password in any 
Maximizer Address Book on 
the server.

� Enter the User ID and password of an administrator, and click 
OK.

 

The Address Book opens in Administrator.

�

�
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➤ To open an Address Book

� In Administrator, select File > Open Address Book.

� Select an Address Book, and click Open.

� Enter the User ID and password of an administrator, and click 
OK.
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Creating Address Books
Sample Address Books are 

installed with Maximizer and 
demonstrate how a company 
would use Maximizer. Do not 
use the sample Address Book 
for your own data.

Once you have familiarized yourself with Maximizer by using a 
sample Address Book, such as Escona Tutorial, your first 
administrative task is to set up a new Address Book.

Administrator makes it easy to create your Address Book in a few 
steps, and even enables you to create it using some of the settings 
from an existing Address Book, such as preferences, templates, user-
defined fields, and macros.

For information about 
transferring Address Book 
information, refer to 
“Importing Address Book Data 
from MXI or XML Files” on 
page 290.

Once you’ve created the Address Book, set up user accounts and 
configure security and preferences. If you need to add entries from 
another Address Book, Maximizer can transfer those entries to the 
new Address Book. Any user can transfer Address Book information, 
provided that they have sufficient security privileges in their account.

The following sections contain information on creating Address 
Books in Maximizer:

• “Checklist: Setting Up an Address Book” on page 74

• “Creating an Address Book” on page 75

Checklist: Setting Up an Address Book

Use this list to help you set up a new Maximizer Address Book. 
Perform these steps in the order shown here. 

� Create the new Address Book. Refer to “Creating an Address 
Book” on page 75.

� Change the MASTER user password. Refer to “Changing the 
MASTER User Password” on page 80.

� Add users to the Address Book. When a new Address Book is 
created, it contains only the MASTER, EMAILUSER and WEBUSER 
user accounts. Create an account for each Maximizer user. Refer 
to “Adding a User to an Address Book” on page 91.

� Set up security for users and security groups. You may 
want some users to have more access to your Address Book data 
than other users. Administrator lets you restrict access to specific 
users and groups of users. Refer to “User and Group Security” on 
page 99.

� Test the Address Book. In Maximizer, log in to the Address 
Book with one or more of the new user accounts.
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Creating an Address Book

Use Administrator to create new Address Books. Because a 
Maximizer Address Book is located on the Microsoft SQL Server, 
Administrator creates a new SQL database for Maximizer and sets up 
the required Data Source Names (DSNs) for the Address Book. 

➤ To create a new Address Book

� Select File > New Address Book to open the New Address Book 
Wizard.

� Select the Database system type from the drop-down list.

� Select the Database server from the drop-down list, and click 
Next.

The Login dialog box opens.

� Choose to use Windows or SQL Server authentication. If you 
choose to use SQL authentication, enter your User ID and 
password. You must have sufficient rights to create a SQL 
database. Click OK.

� Select the target action Create a new Maximizer database.

� In the Address Book name field, type a name for the Address 
Book. Do not exceed 25 characters.

The Address Book name may contain any keyboard characters, 
including spaces. As you type the Address Book name, Maximizer 
automatically adds the corresponding Database name, without 
spaces or invalid characters.

In the Database name field, type a name for the database. The 
database name cannot exceed 25 characters and cannot include 
spaces or special characters.

The Database name applies to the database server. The Address 
Book name applies to the Maximizer Address Book.

�
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� If necessary, from the Database collation drop-down list, select a 
different database collation.

The database collation 
determines how SQL interprets 
character data.

The default Database Collation for Maximizer is 
SQL_Latin1_General_CP1_Ci_AS, which is the standard American 
database collation. If your SQL Server is from another region, 
you may need to use another database collation.

	 Click Next.


 Click Start and monitor the creation of the database.

�

�

	
�
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Deleting Address Books
You can delete Address Books using Administrator. You can remove 
the Address Book from Address Book lists keeping the data in the 
database. You can also delete the entire Maximizer database.

The following sections contain information on deleting Address 
Books:

• “Removing an Address Book” on page 77

• “Deleting a Maximizer Database” on page 77

Removing an Address Book

You can remove any existing Address Books from Address Book lists. 
When you remove the Address Book, the data remains in the 
database. You can later employ the database to log in to the Address 
Book again.

➤ To remove an Address Book

� Select File > Open Address Book.

� Select the Address Book, and click Remove.

� At the prompt, click OK.

� Enter the user ID and password of an administrator for the 
Address Book.

� Click OK.

Deleting a Maximizer Database

You can delete a Maximizer database in Administrator, removing the 
Address Book data from the SQL Server. To preserve your Address 
Book data, you should perform a backup of the database before 
deleting it.

➤ To delete a Maximizer Database

� In Administrator, select File > New Address Book.

� Select the database server, and click Next.

� Enter the login credentials for the SQL server, and click OK.

� Under Target action, select Delete an existing Maximizer 
database.
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� From the Database name drop-down list, select the database.

� At the prompt, click Yes to confirm that you want to delete the 
database.

� At the next prompt, click Yes again.

If you want to remove the Address Book from Maximizer and 
keep the actual database files, click No.

	 Click Start.
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Maximizer System Login Accounts
When a new Maximizer Address Book is created, the following login 
accounts are created automatically:

• MASTER is required to log in to the Administrator module of 
Maximizer. This account consumes a license only if it’s used to 
log in to Maximizer.

• EMAILUSER gives Maximizer access to Address Book data when 
it performs automated email activities such as automated 
campaigns. This account does not consume a Maximizer license. 

• WEBUSER is required for Customer Access and Partner Access. 
This account does not consume a Maximizer license.

• COMPANY is used for the company calendar, which displays 
company events in the Maximizer calendar. Company calendar 
events are created under the COMPANY user account. This user 
account provides read-only access of its calendar to all users. This 
account is disabled by default. However, if the account is 
enabled and used to log in to Maximizer, it consumes a 
Maximizer license. 

• maximizer_default is a system login created in the Maximizer 
instance of Microsoft SQL. It is used only by Maximizer and 
cannot be used to log in to Maximizer or Microsoft SQL. If this 
user is missing see “Recreating the Maximizer_Default User” on 
page 336.

It is important to leave the MASTER, EMAILUSER, and WEBUSER 
accounts enabled. Maximizer requires these accounts in order to 
function correctly.

Passwords

It is important to change the password for the system login accounts 
from the default immediately after creating an Address Book. For 
instructions on changing the account passwords, refer to “Changing 
the MASTER User Password” on page 80.

User passwords may expire periodically, according to the domain 
password policy or local password policy configured by the system 
administrator. When your password expires, Maximizer prompts you 
to change it. Depending on the password policy configuration, new 
passwords may be required to be of sufficient complexity. For 
example, it may have requirements for minimum length, 
alphanumeric or special characters, etc. However, passwords for the 
MASTER, EMAILUSER, and WEBUSER and sample user accounts, such 
as JNAPOLI, will not expire, regardless of the password policy 
configuration.
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Changing the MASTER User Password
If the MASTER password for an 

existing Address Book has 
been changed, and then you 
create a new Address Book, 
the new Address Book will 
have the same password as 
the existing Address Book, and 
not “control”.

The default password for the MASTER user is control. For security 
reasons, you should change this password immediately after creating 
a new Address Book. Maximizer also creates the WEBUSER and 
EMAILUSER system user accounts, and it’s important to change the 
passwords for these accounts as well.

All Address Books on the same SQL Server must have the same 
MASTER user password.

➤ To change the MASTER user password

� In Administrator, log in to the Address Book as MASTER.

� Select File > Manage Users.

� Select MASTER from the user list and click Password.

� In the Old password field, type control (or the current 
password if you have changed the MASTER password before).

�



Chapter 5
Creating or Upgrading Address Books

81

� In the New password and Confirm password fields, type the 
new MASTER user password, and click OK.

Maximizer prompts you to change the password for all Address 
Books on this SQL Server. The MASTER user must have the same 
password for every Address Book on the same SQL Server.

� Click Yes to proceed.

The MASTER user password is updated.

� Repeat this procedure to change the passwords for the 
WEBUSER and EMAILUSER accounts as well.

�

�
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Employing an Existing Address Book
To add an existing Address Book to a Maximizer Server’s Address 
Book list, you must employ the Address Book.

➤ To employ an Address Book

� Select File > New Address Book to run the New Address Book 
wizard.

� Select the Database server where the target Address Book is 
stored, and click Next.

� When prompted, enter the SA Password, and click OK.

� Select the Employ an existing Maximizer database option.

� From the Database name drop-down list, select an existing 
database, and click Next.

� Click Start.

� When the process is finished, click Close.

The Address Book is now ready to use and appears in the Open 
Address Book list.
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Upgrading or Converting an Address Book
You can upgrade an Address Book by opening it in Administrator. 
Administrator also has a built-in utility to convert existing Maximizer 
databases from older versions to the current version, and to convert 
Maximizer Pervasive databases to Maximizer SQL databases.

You should always back up the Address Book before upgrading. For 
instructions on backing up, refer to “Backing Up and Restoring 
Address Book Data” on page 284. For older databases, refer to the 
User’s Guide for your previous version of the software. If you have 
customized the dictionary, also back up that file separately before 
upgrading.

After upgrading a database, you should always perform an Address 
Book validation and recovery. For further information, refer to 
“Verifying and Recovering Address Book Data” on page 287.

If you are upgrading 
Maximizer Pervasive 
databases, do not uninstall 
Pervasive until you have 
successfully upgraded all of 
the Pervasive databases.

If you have created any of your own database triggers, stored 
procedures, or views, follow the steps below.

➤ To upgrade a database that uses custom database 
triggers, stored procedures, or views

� Upgrade the Address Book database, as described in this section.

� Drop all triggers, stored procedures, and views.

� Recreate any triggers, stored procedures, and views.

For information about dropping and creating triggers, stored 
procedures, and views, refer to your SQL Server documentation.

Upgrading a Maximizer Enterprise SQL Database

Use the upgrade utility to upgrade a Maximizer Enterprise 10.x, 11, 
12, 2015, or 2016 SQL database.

➤ To upgrade a Maximizer Enterprise SQL database

� Ensure Maximizer is closed before proceeding with the upgrade. 
If you have an Address Book open in Administrator, select File > 
Close Address Book.

� Select Utilities > Upgrade Maximizer Enterprise 10.x / 11 / 
12 / 2015 / 2016 SQL Database.

� Select the Maximizer SQL database to upgrade.

� Log in with the MASTER password or as a user with a Maximizer 
Administrator role.
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� Select Yes at the backup request prompt. 

This step saves a .BAK file (backup copy) of the SQL database on 
the server (typically in the “\MSSQL\BACKUP” directory).

Maximizer tells you when the conversion is complete. You can 
check the conversion details in a log file called ADMN_##.LOG in 
the Maximizer\Logs directory (## is the two-digit day of the 
month) on the machine running Administrator.
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Converting a Maximizer Pervasive (Btrieve) Database to SQL

➤ To convert a Maximizer Pervasive Database

� Ensure Maximizer is closed before proceeding with the upgrade. 
If you have an Address Book open in Administrator, select File > 
Close Address Book.

� Select Utilities > Upgrade Maximizer / Maximizer Enterprise 
Btrieve Database.

� The New Address Book wizard guides you through the process of 
creating a new SQL database that contains the converted 
Maximizer data. See “Creating Address Books” on page 74. 

After you’ve created the new Address Book, it prompts you for 
the file locations.

� Specify the location of the database you’re converting, and a 
backup location.
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Pervasive database files have a 
.MAX extension, and Pervasive 
backup files have a .SAV 
extension.

� In the Select Maximizer Files to convert dialog box, select All 
Files and then click Convert.

Maximizer tells you when the conversion is complete. You can 
check the conversion details in a log file called ADMN_##.LOG in 
the Maximizer\Logs directory (## is the 2-digit day of the month).

After converting a Pervasive Address Book to SQL, you must 
synchronize user passwords in the Address Book with the SQL 
Server.

➤ To synchronize user passwords after conversion

If you don’t do this password 
synchronization process after 
upgrading the database, you 
will get an ODBC driver error 
message.

� In Administrator, select Utilities > System Configurations.

� Click the Synchronize button.

The users’ SQL login passwords will now be the same as their 
Maximizer Address Book passwords. 

If users in the converted Address Book exist in any other 
Maximizer Address Books on the SQL Server, change their 
passwords in the other Address Books to match their password in 
the converted Address Book. Refer to “Changing User 
Passwords” on page 97.
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Time Zone Alignment
After upgrading your database, use the Time Zone Alignment utility 
to align users’ appointment, Hotlist task, and opportunity activity 
times with the time zone in which these records were created. This 
step is necessary only for users that have created appointments, 
Hotlist tasks, or opportunity activities from a time zone that is 
different than the Maximizer CRM Server.

Users can only be aligned 
once.

➤ To align time zones

� Select Utilities > Time Zone Alignment.

� Select all users that belong to a specific time zone.

� From the Time Zone drop-down list, select the time zone of the 
users.

� Select the Adjust for daylight saving time option if the 
selected users are in a time zone or region that observes daylight 
saving time.

� Click Align.

� Repeat steps 2 to 5, as necessary, for all applicable users and time 
zones.
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Importing Vertical Templates
Maximizer provides vertical templates for several industries. You can 
import any of these vertical templates into your Address Book. A 
vertical template creates industry-specific user-defined fields, action 
plans, search catalogs, column setups, document templates, etc. in 
your Maximizer Address Book.

➤ To import a vertical template

� Log in to the Address Book in Administrator or Maximizer.

You must be logged in as MASTER to import a vertical template.

� In Administrator, select File > Import > Vertical Templates > 
[industry].

– or –

In Maximizer, in the top-left corner of the window, click the 
Maximizer button, and select Import/Export/Transfer. Then, 
under Import, select Vertical Templates > [industry].

The Import [industry] Vertical Template dialog box opens, 
displaying the items included in the template.

� Click Import. 

Items in the list are highlighted as the import process advances.

When the import process is complete, an Import Summary 
displays the number of items imported with the vertical 
template.
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C H A P T E R66Setting Up Users,
Groups, and Teams

In this chapter...

“Adding a User to an Address Book” on page 91

“User Administration” on page 96

“Changing User Passwords” on page 97

“User and Group Security” on page 99

“Security Groups” on page 106

“Record Ownership” on page 112

“Sales and Marketing Teams” on page 113

“Linking Maximizer Users to Windows Logins” on page 116

“User Preferences” on page 120
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Adding a User to an Address Book
As the Address Book administrator, you already have a user ID 
(MASTER) set up for you. Log in as an administrative user in 
Administrator to perform setup or administrative tasks. The default 
password for MASTER is “control”, but it may be different if it has 
already been changed in any Address Book. To use Maximizer, you 
should create a personal user ID for yourself.

Before a user can log in to Maximizer, you must assign that person a 
Maximizer user ID. All security in Maximizer is based on user IDs and 
the rights you assign to them. You should also assign a user Display 
Name, which easily identifies the user throughout Maximizer. When 
you fill in the First name and Last name fields in the Add User dialog 
box, the Display name field is completed automatically to include the 
user’s first and last name together. You can change this display 
name.

The user’s name and contact 
information can be inserted as 
merge fields in the word 
processor.

Use the User Properties dialog box to enter a user’s name and contact 
information, assign user-defined fields, specify access rights, and add 
a user to security groups and sales/marketing teams. Note that you 
can also add users to security groups and sales/marketing teams using 
the Groups/Teams module.

➤ To add a new user to the Address Book

� Select File > Manage Users.

The Manage Users dialog box opens.

� Click Add.

The Copy Selected User’s Settings dialog box opens.

�
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� Click Yes to copy the settings from the selected user, or No to 
start with the default settings.  

The Add User dialog box opens.

� In the General tab, fill in the basic information for this user.

• In the User ID field, enter unique identification for the user.

The user must specify the User ID to log in to Maximizer.

• The Display name field fills in automatically with the user's 
first and last names. You can change the display name.

• The Dept and Division fields affect where the user is 
displayed in user-selection lists (for example, in the Add 
Appointment dialog box).

• In the Email field, enter an email address for the user.

The user must have an email address specified to send email 
from Maximizer.

• Under Module login, ensure Enabled is selected next to 
Windows Access or Web access.

Users enabled for Web Access can log in to Maximizer Web 
Access and Mobile Access. You must have an available user 
license to enable the user.
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� In the User-Defined Fields tab, select the values of any user-
defined fields, as appropriate.

You can set up these custom fields in the File > Set Up User-
Defined Fields dialog box. Refer to “Setting Up User-Defined 
Fields for an Address Book” on page 152 for more information.

� Select the Access Rights tab.

� Click Modify User Access Settings, and set up the access 
settings for the user.

�
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For an explanation of the relationship between user access 
rights, user access settings, and group access settings, refer to 
“User and Group Security” on page 99.

For an explanation of each of the access settings, refer to “User 
Access Rights and User/Group Access Settings” on page 100.

	 Click OK to save the changes to the access settings.


 In the Groups/Teams tab, select any security groups and sales/
marketing teams to which the user should belong.

(To add groups and teams, use the File > Security Groups and 
Teams dialog box.)

��Click OK.

The default user password is maximizer. Ensure that you or the 
user create a new password from the Manage Users dialog box. 

The new User ID and its associated information now appear in 
the User list.

Enabled and Disabled Users

You can create any number of users in your Address Book. However, 
you must have licenses for all enabled users. The total number of 
users across all products cannot exceed the number of available 
licenses. Any additional users must be disabled. Disabled users cannot 

�

�
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log in to Maximizer. But other users can add disabled users to 
appointments and can specify disabled users as opportunity and 
customer service case monitors.

You cannot enable a user when you are at your limit of licensed 
users. You must first disable an existing enabled user, and then 
enable the user.
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User Administration
In Maximizer and Administrator, you can manage all settings for a 
user from a central location. In Administrator, select File > Manage 
Users, select a user, and click Administer User to open the Administer 
User dialog box. You can change properties, preferences, and other 
default settings for the user. Click the links in the navigation pane on 
the left to display information in the main content pane on the right. 
In the content pane, you can access links to a number of user settings. 

Navigation pane 
option Allows you to...

User Properties View and edit general information, user-
defined fields, access rights, groups/teams, or 
linked Windows login for the selected user in 
the Properties dialog box.
For more information, see “User and Group 
Security” on page 99.

User Preferences View and edit preferences for the current user 
in the Preferences dialog box.
For more information, see the Maximizer CRM 
User’s Guide.

Password Change the password for the selected user in 
the Password dialog box.
For more information, see “Changing User 
Passwords” on page 97.

Default Entries Modify the Address Book, opportunity, and 
customer service default entries for the selected 
user.
For more information on default entries, see the 
Maximizer CRM User’s Guide.

Default Notes Change the Address Book, opportunity, 
customer service, and campaign default note 
for the selected user.
For more information on default notes, see the 
Maximizer CRM User’s Guide.

Security Groups and 
Teams

Configure security groups and sales and 
marketing teams in the Security Groups and 
Teams dialog box.
For more information see “Security Groups” on 
page 106 and “Sales and Marketing Teams” on 
page 113.
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Changing User Passwords
The following procedure explains how to change user passwords in 
Administrator. However, users can also change their own passwords 
in Maximizer by selecting Manage Users from the User Management 
group on the Setup tab.  

If the user exists in more than one Address Book, and you change the 
user’s password for one Address Book through Maximizer or 
Administrator, it prompts you to change the password in all Address 
Books on the server. Always click Yes to change the user’s password 
in all Maximizer Address Books. (Otherwise, the user will encounter 
error messages when trying to log into another Address Book.) The 
user’s password in all Maximizer Address Books on that SQL Server, 
and the SQL login password, will then be the same.

Note that Internet Information Server (IIS) must be restarted after 
changing user passwords in Administrator, if applicable. Otherwise, 
if the affected users are connected when the password is changed, 
both the old and new passwords are valid.

If your Maximizer CRM database server is running on a Windows 
Server 2008 machine or later with Microsoft SQL Server 2008 or later, 
user passwords may expire periodically, according to the domain 
password policy or local password policy configured by the system 
administrator. When your password expires, Maximizer prompts you 
to change it. Depending on the password policy configuration, new 
passwords may be required to be of sufficient complexity. For 
example, it may have requirements for minimum length, 
alphanumeric or special characters, etc. However, passwords for the 
MASTER, EMAILUSER, WEBUSER, COMPANY, and sample user 
accounts, such as JNAPOLI, will not expire, regardless of the password 
policy configuration.

It is strongly recommended 
that users working in more 
than one Address Book on the 
same SQL Server use the same 
password for every Address 
Book.

➤ To set and change a user’s password in 
Administrator

� In Administrator, select File > Manage Users. 

The Manage Users dialog box opens.
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� Select the Maximizer user, and click Password.

The default password for a 
new user is “maximizer”.

The Password dialog box opens.

� Type the new password, then retype it on the next line to 
confirm it.

� Click OK to save the new password.

If the user exists in more than one Address Book on the SQL 
Server, Maximizer then prompts you to change the user’s 
password in all Address Books.

� Click Yes to change the user’s password in all Maximizer Address 
Books.

�

�

�



Chapter 6
Setting Up Users, Groups, and Teams

99

User and Group Security
As the Administrator, you can restrict each user’s access rights to 
types of entries, essentially providing per-module security. User 
access rights are accessible by going to the Access Rights tab of a 
user’s properties (see “Modifying User Access Settings” on page 104). 
These user access rights consist of the access settings (security 
settings) of the user account as well as the access settings of any 
security groups the user is a member of. For example, if the 
Opportunity Delete permission is not set in the user’s access settings, 
but is granted in the access settings of a group the user is a member 
of, then the user is granted Delete permissions to Opportunity 
entries.

Each checkbox contains one of the following potential values:

The following table illustrates user access rights derived from user 
and group access settings. 

If the user belongs to more than one group, the conflict illustrated 
below results in the user not being granted the access right.

Checkbox State Access Setting Access Right

 Granted Granted

 Denied n/a

 Not set Not granted

User Access Setting + Group Access Setting = User Access Right

  
  
  
  
  
  
  
  
  

User or Group 
Access Setting

+ User or Group 
Access Setting

+ User or Group 
Access Setting

= User 
Access Right

   
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User Access Rights and User/Group Access Settings

The following tables describe each of the user access rights and user 
or group access settings. 

If a Read permission is denied 
(X), then the Insert, Modify, 
and Delete permissions are 
automatically disabled. A user 
cannot have Insert, Modify, or 
Delete permissions without 
having Read permission.

Permissions

Permissions
Controls the selected user's or group's right to 
view, add, change, or remove . . .

Address Book Entries in the Address Book window

User-defined fields Values in user-defined fields

User-defined field 
setup

User-defined field definitions

Notes Notes attached to entries
Users must have the Delete checkbox selected to 
be able to use the File > Purge > Notes function.

Documents Documents attached to entries
Users must have the Delete checkbox selected to 
be able to use the File > Purge > Documents 
function.

Mailing Address Mailing addresses of Address Book entries

Company Library Files and folders in the Company Library

OrderDesk Entries in the OrderDesk window.
This access right applies only to earlier versions 
of Maximizer.

Opportunities Entries in the Opportunities window

Strategy Library Strategy Library information for opportunities

Campaigns Entries in the Campaigns window

Customer Service Entries in the Customer Service window

Knowledge base Articles in the Knowledge Base window

User/Group setup Users and Security Groups
• If the user does not have any User/Group 

Setup rights, other users' or groups' 
properties are not accessible. 

• If the user has read rights only, the related 
tabs are visible, but information cannot be 
modified.

• Insert, Modify, and Delete rights provide the 
corresponding access rights to all user and 
group properties.
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Privileges

Accounting Accounting transactions.
This access right applies only to earlier versions 
of Maximizer.

Action Plan Library Action plan templates in the Action Plan Library

Quotas Entries in the Quotas window

Dashboards Dashboard entries

Privilege Grants authorization to . . .

Allow Global Edit Perform global edits of Address Book entries in 
Maximizer. Consider advising users with this 
privilege to back up the Address Book before 
making significant changes with Global Edit.

Allow private entries Add entries that are not visible to other users. 
The user can use the Owner, Full Access, or Read 
Access fields to create private entries or restrict 
entries to a group or a user.

Allow public entries Add entries that are visible to all other users in 
the Address Book.
Note that the Allow private entries and Allow 
public entries options cannot be denied at the 
same time. If both of these options are denied 
in two different groups a user belongs to (i.e., 
the checkboxes contain an x), the user is 
granted the Allow private entries right by 
default.

Allow transfer Transfer Address Book entries between 
Maximizer Address Books. If you do not select 
this option, the menu items for transferring are 
disabled.
This privilege applies only to earlier versions of 
Maximizer. 

Allow import Import Address Book entries between 
Maximizer Address Books or from external 
applications. If you do not select this option, the 
commands for importing are disabled. 

Permissions
Controls the selected user's or group's right to 
view, add, change, or remove . . .
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Allow export Export Address Book entries between 
Maximizer Address Books, and export 
information to Microsoft Excel. If you do not 
select this option, the commands for exporting 
are disabled.

Allow sync contacts 
with external clients

Synchronize Address Book entries using Outlook 
Integration. However, users can still synchronize 
calendar appointments or Hotlist tasks without 
this access right. 

Modify system 
tables

Add, modify, or delete available values (items) 
of system fields, such as City and Category in 
Address Book entries. See “System Table Fields” 
on page 104 for more information.

Modify note 
properties

Change the values of the date, time, and creator 
fields in notes.

Modify email 
templates

Create and modify email templates.

Modify/delete other 
owners’ notes

Change and delete other users’ notes. However, 
to be able to view other users’ private notes, the 
user must have the “Modify other users’ private 
entries” privilege enabled.

Modify other users’ 
private entries

View and modify entries marked as private that 
belong to other users.
This security privilege will override any other 
security settings for entries, including any 
settings based on security groups, so if a user 
has this privilege enabled, the user has full read 
and modify access to all entries, regardless of 
the entry’s Full Access, Read Access, or Owner 
settings. This security privilege is very powerful 
and should be granted with caution.

Modify other users’ 
general information

Change information in the General and User-
Defined Fields tabs of the user properties for 
other users.
Modifying a user’s general information, such as 
Last Name, First Name, Company, and Phone 
Number, does not have to be restricted to the 
MASTER user. In many cases, an administrative 
assistant or a receptionist can be granted the 
rights to modify user’s general information 
without compromising the security of 
Maximizer. This privilege allows the user to 
have access to all Maximizer users’ general 
information without giving them full security 
rights to the Address Book.

Privilege Grants authorization to . . .
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User’s Roles

Allow printing to these destinations

These settings apply only to earlier versions of Maximizer.

Allow manage 
currencies

Access the Currency Library in Maximizer, and 
add, edit, or delete entry currencies

Read audit log View the audit log for entries.

User Role Grants authorization to . . .

Administrator Log in to Administrator and perform tasks 
based on the user’s security settings.

Customer Service 
Manager

Have customer service cases assigned or 
escalated to the user. It also allows the user to 
change the value of the Case owner field.
This role also contains all functions of the 
Customer Service Representative role.

Customer Service 
Representative

Have customer service cases assigned to the 
user.

Knowledge Base 
Approver

Approve Knowledge Base articles. A newly 
created article is assigned a draft status until it is 
opened and assigned a different status by an 
approver.

Sales Manager Re-assign the Account Manager field to a 
different user, use territory alignment, and 
create or modify quota templates.
This role also contains all functions of the Sales 
Representative role.

Sales Representative Be assigned to the Account Manager field. A 
Sales Representative can assign the Account 
Manager field to other Sales Representatives 
only if the Account Manager field is already 
assigned to the user or it is empty and not 
assigned to another user.

Destination Grants authorization to . . .

Printer Print to the default printer.

File
(Rich Text Format)

Print to a .RTF file.

File (PDF Format) Print to a .PDF file.

Privilege Grants authorization to . . .
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System Table Fields

Items (available values) for the following fields can be added, 
modified, or deleted for users who are granted the Modify system 
tables privilege.

Modifying User Access Settings

For an explanation of the relationship between user access rights, 
user access settings, and group access settings, refer to “User and 
Group Security” on page 99.

For an explanation of each of the access settings, refer to “User 
Access Rights and User/Group Access Settings” on page 100.

➤ To modify access settings of an existing user

� Select File > Manage Users.

� Select the Maximizer user, and click Properties.

Email Attach the report to an email message, usually 
in a .RTF file.

HTML Format Print to a .HTM file.

Preview Display a preview of the print output on the 
screen.

Destination Grants authorization to . . .

Field Description

Address Book Entry Fields Mr/Mrs, Position, Salutation, Company, Department, 
Division, City, St/Prov, Country, Email Description, Phone 
Description, Do Not Solicit By, Category, Lead Source, and 
Related Address Book Entry Relationship Type

Phone Fields Subject and Phone Call Result

Hotlist Task and Appointment Fields Activity and Priority

Campaign Fields Traditional Campaign Objective, Traditional Campaign 
Activity, Traditional Campaign Template Activity 
Description, Automated Campaign Products/Services, and 
Automated Campaign Categories

Customer Service Fields Products/Services, Categories, and Subject

Opportunity Fields Products/Services, Categories, Objective, and Next Action



Chapter 6
Setting Up Users, Groups, and Teams

105

� Select the Access Rights tab.

� Click Modify User Access Settings.

� Modify any of these settings as appropriate.

� Click OK to close the Access Settings.

� Click OK to save the changes.

�

�
�

�
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Security Groups 
A security group is a group of users, usually belonging to a functional 
group such as a Finance department, who have access to entries 
related to their group and have specific security access settings. A 
user may be a member of more than one security group.

It is important to note that 
groups have access settings, 
but they do not have access 
rights that users do. 

The properties, access settings, and group members are specified in 
the Group dialog box.

Group Name and ID

Every security group has a name and an ID that identify the group. 
Changing the name has no effect on the group functionality. 
However, you cannot change the group ID. If you ever need to 
recreate these security groups, it is imperative that you use the 
correct security group IDs. (The group name is irrelevant.)

Group Access Settings

A security group has Access Settings that affect the level of access its 
members have within the Address Book. It is important to note that 
granting an Access Setting to a group does not necessarily mean that 
all members of the group will have that Access Right. The level of 
access each individual user has to the Address Book is controlled by 
the Access Settings of the user account and the Access Settings of any 
groups the user belongs to. For more information about user and 
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group Access Settings, refer to “User and Group Security” on 
page 99.

Group Members

You can add or remove users from the group in the Members tab of 
the Group dialog box. 

You can also add or remove a user from any groups on the Groups/
Teams tab of the User properties.

Default Security Groups in all New Address Books

Every new Address Book contains several security groups, described 
in the following table. Only the MASTER user belongs to these 
groups by default, but you can add additional users to each group.

Security Group 
Name Group ID Enables group members to...

Accounting ACCTNG Restrict accounting transaction notes 
to members of this group. This security 
group applies only to previous versions 
of Maximizer.

Company 
Announcement 
Authors

A_CAA Access the Company Announcements 
folder in Company Library, where 
group members can add 
announcements that appear in the 
Company Announcements box on the 
My Work Day page in Maximizer and 
Maximizer Web Access.

Crystal Reports 
Users

R_CRU Generate new reports from the Crystal 
Reports option in the Reports tab in 
Maximizer. This security group applies 
only to previous versions of Maximizer.

Customer Access 
Admin Users

C_ADM Access the News Manager section of 
the Customer Access Administrator.
In Address Books that have been 
upgraded from a previous version, this 
group may be called “Customer Portal 
Administration Users”.

Customer Access 
Config Users

C_CFG Access the Configuration Manager 
section of Customer Access 
Administrator.
In Address Books that have been 
upgraded from a previous version, this 
group may be called “Customer Portal 
Configuration Users”.
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Maximizer Web 
Access Admin 
Users

EMPADM Access the Edit section of the 
Maximizer Web Access, where the user 
can update external links.
In Address Books that have been 
upgraded from a previous version, this 
group may be called “Employee Portal 
Administration Users”.

Partner Access 
Admin Users

P_ADM Access the News Manager section of 
the Partner Access Administrator.
In Address Books that have been 
upgraded from a previous version, this 
group may be called “Partner Portal 
Administration Users”.

Partner Access 
Config Users

P_CFG Access the Configuration Manager 
section of Partner Access 
Administrator.
In Address Books that have been 
upgraded from a previous version, this 
group may be called “Partner Portal 
Configuration Users”.

SSRS Report 
Management

R_SSRS Add and edit SQL Server Reporting 
Services reports in Maximizer Web 
Access.
You must specify the login credentials 
for a member of this group when you 
enable SQL Server Reporting Services.

Security Group 
Name Group ID Enables group members to...
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Creating a New Security Group

For an explanation of the relationship between user access rights, 
user access settings, and group access settings, refer to “User and 
Group Security” on page 99.

For an explanation of each of the access settings, refer to “User 
Access Rights and User/Group Access Settings” on page 100.

➤ To create a new security group and assign members

� Select File > Security Groups and Teams.

The Security Groups and 
Teams command is also 
available in Maximizer if the 
logged-in user has Insert rights 
for User/Group setup. On the 
Setup tab, select Security 
Groups or Teams from the User 
Management group.

� Click Add.

� Enter a Group Name. 

� Enter a unique Group ID (up to 6 characters). The first character 
of the Group ID must be a letter.

� Assign Access Settings to the group. 

Access Settings for the group affect the Access Rights of all users 
who are members of the group.

�
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� Select the Members tab.

� From the Available Users list, select a user to add to the 
security group, and click Add. Repeat to add additional users.

To remove a user, select the 
user from the Members list, 
and click Remove.

	 Click OK to save the new security group.

�

�

�

�
�

	

�
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Modifying Group Access Settings

For an explanation of the relationship between user access rights, 
user access settings, and group access settings, refer to “User and 
Group Security” on page 99.

For an explanation of each of the access settings, refer to “User 
Access Rights and User/Group Access Settings” on page 100.

➤ To modify access settings of an existing group

� Select File > Security Groups and Teams.

� Select the group name.

� Click Properties.

� Select the appropriate settings for the group, and click OK.
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Record Ownership
In Maximizer, many entries have an Owner field, or Full Access and 
Read Access fields. These fields control who can view or edit the 
entry. Users can access their own private records, all publicly owned 
records, and private records owned by their group. For example, the 
user “Alice” of the “Finance” group can view all of her own records, 
all records owned by the “Finance” group, and all Public records.

Sometimes it’s important to allow users to have private entries 
because some entries aren’t meant to be shared with your entire 
organization. In Maximizer, it’s possible to specify Full Access and 
Read Access to specific users or groups for each entry in the Address 
Book. In addition to Address Book entries, you can specify ownership 
of notes, documents, and other types of entries.

When a user creates a new Address Book entry, he or she can 
designate access for that entry. Full Access or Read Access can be 
granted to specific users or groups, or it can be Public.

To be able to use the Owner, Full Access, or Read Access fields, the 
user must have the “Allow private entries” access right enabled. 

Field Value Description

Owner Public All users can view and modify the entry, 
regardless of their user or group security 
settings. 

User Only the specified user can view or modify the 
entry.

Group Only members of the specified group can view 
or modify the entry, regardless of their user or 
group security settings.

Full Access Public All users can modify the entry, regardless of 
their user or group security settings. 
Note that the Read Access field becomes 
disabled if Full Access is set to Public.

User Only the specified user can modify the entry.

Group Only members of the specified group can 
modify the entry, regardless of their user or 
group security settings.

Read Access Public All users can view the entry.

User Only the specified user can view the entry.

Group Only members of the specified group can view 
the entry.
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Sales and Marketing Teams
If your company or organization is using opportunity or campaign 
management, you can set up sales and marketing teams. Sales teams 
are used for sales opportunities in Maximizer, and marketing teams 
are used for traditional marketing campaigns.Teams help leaders 
delegate and manage opportunities and traditional campaigns in 
Maximizer. Team leaders can delegate tasks in an opportunity or a 
traditional campaign to team members.A team is composed of a 
team leader and team members:

• Team Leader: In a team, one person is designated as a team 
leader who has the right to make changes to the opportunity or 
traditional campaign, as well as to the opportunity’s or 
traditional campaign’s team.

• Team Member: A regular team member does not have the right 
to change the traditional campaign/opportunity or the team. 
The member’s role is to perform the tasks the team leader 
assigns.

A team member has either edit, audit, or standard rights, as 
described below. The team leader always has edit rights.

If you have someone in mind 
as a team member with edit 
rights, it saves time to assign 
rights in Administrator rather 
than on a per-campaign or per-
opportunity basis.

• Edit: Allows a member full access to all campaigns and 
opportunities assigned to the team. Members with this type of 
access have full team leader rights and may modify the status of 
an opportunity or campaign and may also reassign tasks.

• Audit: Allows a member to view all campaigns and 
opportunities assigned to him/her.

• Standard: Allows for basic rights to “work” (apply steps) 
opportunities and campaigns. These rights do not allow the 
member to change a status of an opportunity or campaign.

Security, or access rights, cannot be assigned to sales or marketing 
teams. Therefore, to control the security of more than one user, you 
must set up a security group for the team members.
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➤ To create a new sales or marketing team

� Select File > Security Groups and Teams.

� Select the Teams tab, and click Add.

� On the General tab, enter a team name.

� Select Sales or Marketing from the Type drop-down list.

� Select the Members tab.

� From the Available Users list, select a user to add to the team, 
and click Add. Repeat to add additional users to the team.

To remove a user, select the user from the Members list, and click 
Remove.

�

�

�
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� In the Members list, select a member to assign as the Leader, 
and select Leader from the Status drop-down list.

There can be only one leader in the team.

	 For each member other than the Leader, select the appropriate 
member right from the Rights drop-down list.


 Click OK to save the new team.

�

�

�
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Linking Maximizer Users to Windows Logins
Linking Maximizer users with Windows logins enables them to access 
Maximizer Address Books without specifying a user name and 
password. This provides a “single sign-on” configuration for 
Maximizer users—they won’t need to log into the network with one 
user name and password and log into Maximizer with another.

If Windows Authentication is specified as the means of user 
authentication during the installation, and users are not mapped in 
the Windows Authentication tab, Maximizer will prompt users for 
their Maximizer user name and password.

➤ To enable Maximizer users to log in to Maximizer 
automatically using single sign-on

� Select File > Manage Users.

� Select the Maximizer user, and click Properties.

The Properties dialog box opens.

Each user entered in this 
dialog box must be added as a 
Windows user for SQL on the 
SQL Server. These users must 
also be given database access 
with the database role set to 
CRMGroup. 

� Select the Windows Authentication tab.

� Click Add.

� Enter the qualified name of the user that corresponds to the 
Maximizer user (e.g., DOMAIN-NAME\user_name).

� Select the Enabled checkbox, and click OK.

You can assign multiple network users to a Maximizer user.

�
�

�
�
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➤ To create Maximizer user groups in Windows

This procedure is written for 
network and database 
administrators. For more 
information, refer to the 
Windows operating system 
documentation.

� On the domain server, create a new user group called Maximizer 
Global.

� Add the user accounts of all Maximizer users to the Maximizer 
Global group.

� On the SQL Server computer, create a new user group called 
Maximizer Local.

� Add the Maximizer Global group as a member of the Maximizer 
Local group.

➤ To grant database access to the users

� In SQL Server Management Studio navigate to the Logins 
branch.

� Right-click and select New Login from the shortcut menu.
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� Create a new SQL login account and assign the Maximizer 
Local as the name.

� In the User Mapping page, select the databases that Maximizer 
Local should be able to access. 

� For each database, select the public and CRMGroup database 
roles.
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� For the MaConfig database, select the db_datareader and 
db_datawriter database roles.
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User Preferences
The Address Book administrator is responsible for setting up initial 
user preferences in Administrator. However, users can change many 
of their user preferences in Maximizer.

➤ To set Address Book user preferences

� Select File > Manage Users.

� Select the Maximizer user, and click Preferences.

See the Maximizer CRM User’s 
Guide for more information on 
user-related preferences.

� Set the user-related preferences on each of the tabs.
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In this chapter... 

“Address Book Preferences” on page 122

“System Fields” on page 125

“User-Defined Fields” on page 127

“Mandatory Fields” on page 137

“Writing Formulas and Mandatory Rules” on page 141

“Key Fields Lists” on page 155

“Preventing Duplicate Entries” on page 158

“Email Notification for Opportunities/Customer Service Cases” on page 162

“Event Notification” on page 170

“Recording Holidays in the Holiday Editor” on page 173
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Address Book Preferences
You can set Address Book preferences in Administrator. The 
following table outlines the settings available in each section of the 
Preferences.

In this section You can set the following preferences:

Address Book • Values available in the Category field for 
Address Book entries.

• Fields to check for duplication of Address 
Book entries.

Auditing Auditing preferences for Address Book entries.

Automated Services Automated email and print/fax service 
preferences and initialization.

If you are using automated campaigns, ensure you have 
the “Activate services for the currently open Address 
Book” checkbox selected in the Automated Services tab.

Campaigns • Campaign completion reasons.
• Settings for campaign monitoring.

Customer Service • Customizable values for the Billing type, 
Subject, Case origin, Case queue, Case reason, 
Status, and Case Type fields.

• Default case response time and case status.

• Settings to disallow direct changes to case 
fields.

• Default case monitoring lists.
• Assign or unassign email templates for user 

and customer notification.

Dashboards • Configure dashboards from the server.
• Add or modify SQL metrics for dashboard 

indicators.

Diagnostic Log file settings for Maximizer modules. Note 
that users can also set Diagnostic preferences in 
Maximizer.

Key Fields Key field lists available for Address Book entries, 
opportunities, campaigns, and customer service 
cases.

Locations and 
Resources

Locations and resources available in 
appointments.

Mandatory Fields Mandatory and optional data entry 
requirements for system fields in Address Book 
entries, opportunities, campaigns, and customer 
service cases.
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Opportunities • Opportunity processes, stages, and 
probabilities of close.

• Opportunity confidence rating schemes.
• Opportunity completion reasons.
• Opportunity monitoring lists.

• Email notification templates for 
opportunities.

Security Account lockout and Mobile Access security 
options.

System Fields • Add, modify, and delete note and document 
categories.

• Add, modify, and delete values of the 
products/services and categories (in 
opportunities, campaigns, customer service 
cases, and appointments) and Do Not Solicit 
By (in Address Book entries) fields.

System Options • Global server.
• Address Book nameand ID.

• System-assigned Address Book entry IDs, 
campaign IDs, customer service case IDs, 
and opportunity IDs.

• Overview page caption.
• Default settings for Maximum entries field in 

Maximizer search dialog boxes.

• Partner notification of assigned Address Book 
entries or opportunities.

• User/group setting which determines if lists of 
users/groups display only groups to which the 
current user belongs and other users in the 
groups in fields such as Read Access and Full 
Access.

• Event notification.

• Live Update options.
• Multi-currency.
• SQL Server Reporting Services integration 

with Maximizer

• Start of the fiscal year.
• Opportunity and campaign synchronization.

In this section You can set the following preferences:
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Set Address Book Preferences

� Select File > Preferences.

� Set the Address Book preferences on each of the tabs.



Chapter 7 125

System Fields
You can set up custom values for system fields in the following 
sections in the preferences:

• System Fields – The Category fields in notes and documents, 
the Do not solicit by field in Address Book entries, and the 
Products/Services and Categories fields in opportunities, 
campaigns, customer service cases, and appointments.

• Locations/Resources – The Location and Resources fields in 
appointments.

• Customer Service – The Billing Type, Case or Article Subject, 
Origin, Queue, Reason, Status, and Type fields in customer 
service cases.

• Opportunity – The Process, Stage, Confidence Rating, and 
Completion Reason fields in opportunities.

• Campaigns – The Completion Reason field in automated 
campaigns.

• Address Book – The Category field in Address Book entries.

Add Custom Items to System Fields

You can use Administrator to add custom items to system fields. The 
steps may differ slightly depending on the field.

� In Administrator, select File > Preferences.

� Select the tab that contains the system field.

You can modify system fields in the System Fields, Locations/
Resources, Customer Service, Opportunity, Campaign, and 
Address Book preferences.

� In the left pane, under Preferences, select the section that 
contains the system field.

You can modify system fields in the System Fields, Locations/
Resources, Customer Service, Opportunity, Campaign, and 
Address Book preferences.

� If you are working in the System Fields, Customer Service, or 
Locations/Resources tabs, select the field In the list on the left..

The current list of values for the field are displayed on the right.

In the other tabs, the current list of values is displayed under the 
field name.

� To the right of the list, click Add.
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� Enter the name of the item.

� If necessary, enter other properties of the item.

• For most fields, specify the user who requested the item.

• For the Status field in customer service cases, select the 
actions (assign, escalate, or resolve) for which you want to 
apply the item.

• For the Process field in opportunities, click Add Stage to 
add one or more stages to the process.

• For the Stage field in opportunity processes, specify the 
probability of close and target age for the stage.

• For the Completion reason field in opportunities and 
campaigns, specify the completion status the item applies to.

	 Click OK to finish adding the item.


 Click OK to save the changes to the preferences.

Modifying System Table Fields in Maximizer

End users can modify values of some system table fields directly in 
Maximizer. Users must have the Modify system table fields privilege 
to change the values. The following fields can by changed:

• Address Book entry fields – Mr/Mrs, Position, Salutation, 
Company, Department, Division, City, St/Prov, Country, Email 
Description, Phone Description, Do Not Solicit By, Category, Lead 
Source, and Related Address Book Entry Relationship Type

• Phone fields – Subject and Phone Call Result

• Task and appointment fields – Activity and priority

• Campaign fields – Traditional Campaign Objective, Traditional 
Campaign Activity, Traditional Campaign Template Activity 
Description, Automated Campaign Products/Services, and 
Automated Campaign Categories

• Customer service fields – Products/Services, Categories, and 
Subject

• Opportunity fields – Products/Services, Categories, Objective, 
and Next Action
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User-Defined Fields
User-defined fields are custom fields used to record additional 
information on Maximizer entries. You can set up different user-
defined fields for the different types of entries in Maximizer. Each 
user-defined field can be associated with only one type of entry. You 
can create user-defined fields for the following types of entries:

• Address Book – Classifies Address Book entries. You can view 
these fields in the Address Book window or in an open Address 
Book entry.

• Opportunities – Classifies opportunities. You can view these 
fields in the Opportunities window or in an open opportunity.

• Campaigns – Classifies campaigns. You can view these fields in 
the Campaigns window or in an open campaign.

• Customer Service – Classifies customer service cases. You can 
view these fields in the Customer Service window or in an open 
customer service case.

• Users – Classifies Maximizer users. You can view these fields in 
the User Properties dialog box.

You can include user-defined fields in Key Fields lists in the Basic 
Information tab of open Address Book entries, opportunities, 
customer service cases, and campaigns.

Types of User-Defined Fields

You can create different types of user-defined fields depending on 
the types of values required for the field. Maximizer defines the 
following types of user-defined fields:

• Alphanumeric user-defined fields – These fields record any 
alphanumeric text (letters and numbers) up to a specified 
maximum number of characters. You can encrypt alphanumeric 
fields for security protection. Note that you cannot disable or 
enable encryption once you have created the field.

Encrypted user-defined fields 
cannot be transferred, 
imported, or exported. They 
are also not searchable.

You can use alphanumeric user-defined fields to record URLs for 
entries. The fields are displayed as hyperlinks in Key Fields lists 
and in the User-Defined Fields following window.

• Date user-defined fields – These fields store a specific date or 
an annually recurring date.

• Duration user-defined fields – These fields calculate the 
duration between another date basic or user-defined field and 
the current date. Because they are calculated from values of 
other fields, values for duration fields can be viewed in entries 
but cannot be set manually.
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• Formula user-defined fields – These fields calculate values 
based on other basic or user-defined fields. Formula user-
defined fields can return alphanumeric, date, or numeric values. 
Because they are calculated from values of other fields, values 
for formulas fields can be viewed in entries but cannot be set 
manually.

• Numeric user-defined fields –  These fields record numeric 
values. You can specify a number of decimal places. For example, 
specify two decimal places to use this type of field for monetary 
values. You can also specify that currency symbols are displayed 
with the field.

• Table user-defined fields – These fields enable you to select a 
value or values from a list. This type of field is very useful for 
multiple choice or multiple value fields. If you create a table 
user-defined field with the “single value only” attribute, only 
one value can be selected from the list.

• Yes/no user-defined fields – These fields record either yes or 
no values. Since the fields must contain one of these values, 
these user-defined fields are always mandatory.

Access Rights for User-Defined Fields

The Maximizer adminstrator user can create user-defined fields at 
any time in Administrator. You can also give any user the ability to 
create, change, or delete user-defined fields in Maximizer by 
enabling the following access rights in Administrator:

• The User-defined fields access right enables the user to assign 
values to user-defined fields, but not create fields.

• The User-defined field setup access right enables the user to 
create new user-defined fields.

You can also restrict user access to a specific user-defined field. The 
user-defined field properties has options for Full Access (read and 
write) and Read Access (read-only) permissions.

The Full Access and Read Access fields contain a drop-down list of 
users, groups, and Public. Select which user(s) the Full Access or Read 
Access permission applies to:

• Public – Assigns the user-defined field access permission to all 
users.

• [user] – Assigns the user-defined field access permission to an 
individual user.

• [security group] – Assigns the user-defined field access 
permission to all members of a security group.
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Setting Up User-Defined Fields

User-defined fields are created and modified in the Set Up User-
Defined Fields dialog box in Maximizer and the User-Defined Fields 
page in Administrator. The fields and folder are organized in a tree 
view. There can be multiple levels of folders, each containing other 
folders or user-defined fields. The folder structure allows a maximum 
of three folder levels.

You can set up different lists of user-defined fields for each type of 
entry. The user-defined field structure can be multi-tiered with 
multiple levels of user-defined field folders, each of which may 
contain other folders or user-defined fields. The folder structure may 
contain a maximum of three folder levels.

The following sections contain information on setting up user-
defined fields:

• “Sorting User-Defined Fields” on page 129

• “Create a Folder for User-Defined Fields” on page 130

• “Create a User-Defined Field” on page 131

• “Add Items to a Table User-Defined Field” on page 132

Sorting User-Defined Fields

The order that user-defined fields display in the Set Up User-Defined 
Fields dialog boxUser-Defined Fields page determines the order that 
user-defined fields display for users.

Click the Move Up and Move Down buttons to move a field or folder 
up or down in the list. These buttons move fields only within their 
current folder level. You cannot use them to move items in or out of 
folders. To select a field, click on the blank space on a field row.
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Use the Reset Order button to sort items in alphabetical order. All 
user-defined fields and folders in the selected folder are resorted.

You can also use the mouse to drag and drop a field or a folder to a 
different position in the list. Dragging it onto a field places it 
immediately below that field. Dragging it onto a folder places it at 
the top of the list inside that folder. Holding the mouse on a folder 
for about a second expands the folder, and then you can continue 
dragging the item to a specific position in that folder.

Create a Folder for User-Defined Fields

You can group similar user-defined fields into folders and subfolders 
to a maximum folder depth of three levels. Grouping user-defined 
fields into folders is particularly useful if you have a large number of 
user-defined fields. Grouping them makes them easier to find and 
reduces the amount of scrolling needed to find the one you are 
looking for.

� Select the tab for the category of user-defined fields you want to 
work with.

� To create a top-level folder, select the Address Book name at the 
top of the list. 

– or –

To create a folder within an existing folder, select the existing 
folder.

� Click Add Folder.

� Enter a name for the new folder, and click OK.

User-defined field and folder 
names cannot contain forward 
slash or backward slash 
characters ( / \ ).

The new folder now appears in the user-defined fields list.

If you set the folder to hidden, 
it is not displayed on the User-
Defined Fields tab when you 
clear the Show hidden fields 
option.

� Move the new folder to a different position in the list, if desired.
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Create a User-Defined Field

To complete this procedure, you must have Insert permission for 
user-defined field setup.

You can create user-defined fields for Address Book entries, 
opportunities, campaigns, customer service cases, and user accounts 
in the Set Up User-Defined Fields dialog box. This dialog box is 
available from the Setup tab in Maximizer or the File menu in 
Administrator. 

� Select the tab for the category of user-defined fields you want to 
work with.

� Select an existing folder, inside which you want to create a new 
field.

– or –

Select a user-defined field to create the new field at the same 
level as the selected field.

� Click Add Field.

� In the Field Name field, type a name for the user-defined field.

User-defined field and folder 
names cannot contain forward 
slash or backward slash 
characters ( / \ ).

� From the Type drop-down list, select the type of user-defined 
field you want to add.

Duration user-defined fields 
can only be created in 
Maximizer Web Access or Web 
Access Administrator.

� If you are adding a formula user-defined field, select the type of 
value the formula should return from the Return type drop-
down list.

� Specify the properties of the user-defined field.

For formula user-defined fields, click the ellipsis button next to 
the Formula field to specify the formula. Then, click Insert 
Field to add basic or user-defined fields to the formula.

You cannot insert other 
formula user-defined fields 
into the formula.

	 Click OK.
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The user-defined field is added to the list.

Add Items to a Table User-Defined Field

Table user-defined fields contain a list of similar items from which a 
user may select one or more items. As part of the process of creating 
a new user-defined field of this type, you should add the items to the 
table.

� Select the table user-defined field, and click Items.

– or –

Double-click the table user-defined field.

The list of existing items for the table user-defined field is 
displayed.

� Click Add.
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� Type a name for the item, and specify the other properties of the 
item.

If you set the item to hidden, 
you can hide it from the 
Available Values list by 
clearing the Show hidden 
items option.

� Click OK.

� Repeat steps 2 to 4 to add any additional items to the table user-
defined field.

Formula User-Defined Fields

Formula user-defined fields calculate values based on other basic or 
user-defined fields. Because they are calculated from values of other 
fields, values for formulas fields can be viewed in entries but cannot 
be set manually.

When you create a new or modify an existing formula user-defined 
field, you can click the ellipsis button next to the Formula field to 
specify the formula for the user-defined field. You can write the 
formula using existing basic and user-defined fields. Click the Insert 
Field button to select fields to add to the formula.

Formula user-defined fields can return alphanumeric, date, or 
numeric values. You specify the type of return value while creating 
the user-defined field. The functions available depend on the types 
of fields that you want to manipulate.

You can add arithmetic expressions to your formulas. You can also 
add functions and conditional expressions to create more complex 
formulas.
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The following sections contain information on writing formulas for 
user-defined fields:

• “Arithmetic Expressions” on page 141

• “Alphanumeric Functions” on page 142

• “Date Functions” on page 148

• “Numeric Functions” on page 151

• “Conditional Expressions for Formulas” on page 134

Conditional Expressions for Formulas

You can create conditional expressions in your formula user-defined 
fields. Conditional expressions use the If expression to evaluate 
comparison statements and return values based on the results of the 
statements.

Conditional expressions use the following syntax:

If (Comparison Statement, True Value, False Value)

• Comparison Statement – Uses comparison operators to 
compare two values. Comparison statements can use the 
following operators:

• == to check that two values are equal to each other.

• != to check that two values are not equal to each other.

• > to check that the first value is greater than the second 
value.

• < to check that the first value is less than the second value.

• >= to check that the first value is greater than or equal to the 
second value.

• <= to check that the first value is less than or equal to the 
second value.

Comparison statements can be combined with logical operators:

• Or – Combines two comparison statements where either one 
of the statements is true.

• And – Combines two comparison statements where both of 
the statements is true.

• Not – Negates a comparison statement.

• True Value – The value of the expression when the comparison 
statement is true. It can also be combined with other 
expressions.

• False Value – The value of the expression when the comparison 
statement is false. You can include other conditional statements 
to supply different answers for different values.
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Examples of Conditional Expressions

The following examples illustrate complex formula user-defined 
fields using conditional expressions.

Example 1

If ([Creation Date] > Date(2009, 7, 9), "New", "Old")

This example compares a date field with a constant date, using the 
Date function to format the date properly. The formula returns an 
alphanumeric value. If the date is later than the supplied date, the 
field has a value of “New”. If the date is earlier than the supplied 
date, the field has a value of “Old”.

Example 2

If(Not(Search("Canada",[Country])>0 Or Search("USA",[Country])>0 Or 
Search(“Mexico”,[Country])>0),"Other","North America")

This example inspects the Country field of an Address Book entry to 
determine if the entry is located in North America or not. It uses the 
alphanumeric Search function to look for the countries “Canada”, 
“USA”, or “Mexico”. If none of those strings are found in the entry’s 
Country field, the formula evaluates to “Other”, but if one of those 
strings is found it outputs “North America”.

Example 3

If (Dayofweek([Creation Date]) == 1, "Sunday",  
If (Dayofweek([Creation Date]) == 2, "Monday",  
If (Dayofweek([Creation Date]) == 3, "Tuesday", 
If (Dayofweek([Creation Date]) == 4, "Wednesday",  
If (Dayofweek([Creation Date]) == 5, "Thursday", 
If (Dayofweek([Creation Date]) == 6, "Friday",  
If (Dayofweek([Creation Date]) == 7, "Saturday", " ")))))))

This example uses the Dayofweek function to get the day of the 
week expressed as an integer value for a date field. It compares the 
value with integer values and outputs a string representing the day 
of the week in. If it does not have a value, it outputs an empty string.
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Transfer User-Defined Fields Between Address Books

� In Maximizer, select the Maximizer button and select Import/
Export/Transfer > User-Defined Fields.

� In the Transfer User-Defined Fields dialog box, select the user-
defined fields to transfer. 

Encrypted user-defined fields 
cannot be transferred between 
Address Books.

� Click Transfer.

� To copy the data into a target Address Book that is accessible 
from the computer, select the Direct Address Book access 
transfer method.

Accessible Address Books are listed in Available target Address 
Books.

– or –

If the target Address Book is not listed, select the Email transfer 
method.

The data is compressed into a .MET file and attached to an email 
message.

� If you selected Direct Address Book access, select the target 
Address Book, click OK, and log on to the Address Book.

Maximizer transfers the user-defined fields and notifies you 
when the transfer is complete.

– or –

If you selected Email, click OK. 

Maximizer creates an email message with the user-defined fields 
attached in a .MET file. Type an email address in the To field, and 
click Send.
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Mandatory Fields
You can specify that system fields and user-defined fields are 
mandatory. System fields are set as mandatory in Administrator. 
User-defined fields are set as mandatory when creating the user-
defined fields in Administrator or in the Set Up User-Defined Fields 
dialog box.

Mandatory fields are denoted with an asterisk displayed after the 
field type.

When you create or modify entries, Maximizer checks that all 
mandatory fields have values. If any mandatory fields are empty, you 
are prompted to enter a value for the field. 

Set a System Field as Mandatory

You can set up different lists of mandatory fields for Companies, 
Individuals, Contacts, customer service cases, opportunities, 
automated campaigns, and traditional campaigns.

Some system fields, such as Company name and Full access, are 
mandatory by default. In the Mandatory Fields preferences, they are 
displayed as “Always Mandatory”. The other fields are optional by 
default, but you can specify that any of the fields must be 
mandatory.

Use this procedure to set a system field as mandatory or optional.

� In Administrator, select File > Preferences.

� Select the Mandatory Fields tab.

� From the Show mandatory entries for drop-down list, select 
the type of entry that the field applies to.

The list of system fields for the entry is displayed with the fields’ 
current status: Optional, Always Mandatory, or Mandatory.

� Select the field.

� Click Mandatory or Optional.

The status of the field is changed to Mandatory or to Optional.

� Click OK to save the changes.
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Set a User-Defined Field as Mandatory

To complete this procedure, you must have Modify permission for 
user-defined field setup.

Use this procedure to set an existing user-defined field as always 
mandatory.

� Select the user-defined field and click Properties.

– or –

Double-click the alphanumeric, date, or numeric user-defined 
field.

� From the Mandatory drop-down list, select Always 
mandatory.

� Click OK to save the changes.

Rules for Mandatory User-Defined Fields

When you work with Address Book entries, opportunities, or 
customer service cases, you can specify that user-defined fields are 
mandatory if a rule is matched. For example, you can write a rule 
that makes a user-defined field mandatory only when the category 
for an Address Book entry is set to “Partner”. When users set the 
value of the Category field to Partner, they are prompted to set a 
value for the user-defined field when they save the entry.

A mandatory rule consists of a comparison statement. It may 
compare a field with a value or with another field. Or it may compare 
formulas using the same syntax as formula user-defined fields.

You can create comparison statements with the following symbols.

• == to check that two values are equal to each other.

• != to check that two values are not equal to each other.

• > to check that the first value is greater than the second value.

• < to check that the first value is less than the second value.

• >= to check that the first value is greater than or equal to the 
second value.

• <= to check that the first value is less than or equal to the second 
value.

Comparison statements are often combined with logical operators to 
add multiple statements together.

• Or – Combines two comparison statements where either one of 
the statements is true.
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• And – Combines two comparison statements where both of the 
statements is true.

• Not – Negates a comparison statement.

While the comparison statements may be simple, say to compare a 
field with a value or with another field, you can also write more 
complex rules. Within the comparison statements, you can include 
arithmetic operators (+, -, * /) and alphanumeric, date, and numeric 
functions to create complex formulas.

Set a User-Defined Field as Mandatory Given Conditions

To complete this procedure, you must have Modify permission for 
user-defined field setup.

Use this procedure to set a user-defined field as mandatory when a 
specified rule is matched. This procedure applies only to user-defined 
fields for Address Book entries or opportunities.

� Select the user-defined field and click Properties.

– or –

Double-click the alphanumeric, date, or numeric user-defined 
field.

� From the Mandatory drop-down list, select Mandatory based 
on rule.

� To the right of the Rule field, click the ellipsis button.

� Enter the rule, and click OK.

Click Insert Field to add basic or user-defined fields to the rule.

� Click OK to save the changes.

Mandatory Rules Using Table Fields

When you create mandatory rules that compare table fields, the 
values in the fields are treated like alphanumeric fields.

To compare a table field that contains multiple values, the 
comparison statement must include the same text that’s displayed in 
the Maximizer interface, including all values for the field. For 
example, the statement [Category] == "Partner" will be true only if 
the only value set in the Category field is "Partner". If the Category 
field includes the "Distributor" value as well, the rule would validate 
with the following statement: Category == "Distributor, Partner". 
You can use the Search function to locate text in multiple-value table 
fields.
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To check that one of multiple values are set in a table field, use the 
OR operator in the rule. To check that two (or more) values are set in 
a table field, use the AND operator in the rule.

Example: Mandatory rule for table field using OR

The following rule validates if either the Distributor or Partner value 
is set in the Category field:

(Search(“Partner”,[Category]) > 0) OR (Search(“Distributor”,[Category]) > 0)

Example: Mandatory rule for table field using AND

The following rule validates if both "Distributor" and "Partner" are 
set in the Category field:

(Search(“Partner”,[Category]) > 0) AND (Search(“Distributor”,[Category]) > 0) 
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Writing Formulas and Mandatory Rules
You cannot insert other 

formula user-defined fields 
into the formula.

Formula user-defined fields calculate values based on other basic or 
user-defined fields. You can write formulas consisting of arithmetic 
expressions, alphanumeric, date and numeric functions, as well as 
conditional expressions.

When you work with Address Book entries, opportunities, or 
customer service cases, you can specify that user-defined fields are 
mandatory if a rule is matched. Rules for mandatory user-defined 
fields are similar to the formulas in formula user-defined fields. A 
mandatory rule consists of a comparison statement. It may compare a 
field with a value or with another field. Or it may compare formulas 
using the same syntax as formula user-defined fields. Comparison 
statements can contain any of the elements included in formulas, 
including alphanumeric, date, and numeric functions.

Arithmetic Expressions

Using the basic arithmetic symbols, you can include arithmetic 
expressions in formula user-defined fields and in rules for mandatory 
user-defined fields. Combine multiple expressions to create 
complicated arithmetic formulas.

Formula user-defined fields and rules for mandatory user-defined 
fields can use the following symbols:

• + for addition.

Add any numeric values to each other, add integers to date 
values, and add alphanumeric fields or strings separated with 
quotation marks to each other.

• - for subtraction.

Subtract any numeric values from each other, and subtract date 
values from each other. Date values return integers representing 
the number of days between the dates.

• * for multiplication.

Multiply numeric values together.

• / for division.

Divide numeric values by other numeric values.

• ( ) for nested operations.

Use parentheses to create more complex operations on several 
numeric values or to combine multiple comparison statements.
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Example: Numeric Values

Formula: ([Numeric field] + [Numeric field]) * [Numeric field]
Return value: Numeric

Example: Date Values

Formula: [Date 1] - [Date 2]
Return value: Numeric, the number of days between the two dates.

Example: Date and Numeric Values

Formula: [Date 1] + [Numeric field]
Return value: Date

Example: Alphanumeric Values

Formula: [FirstName] + " " + [LastName]
Return value: Alphanumeric, the two words listed together, separated by a 
space (FirstName LastName).

Alphanumeric Functions

Use alphanumeric functions to manipulate alphanumeric fields in 
formula user-defined fields and in rules for mandatory user-defined 
fields. When you use alphanumeric functions, you can insert 
alphanumeric fields as the parameters for the function or you can 
use any text strings. When you insert strings into functions, enclose 
the text of the string in quotation marks.

You can add the following functions to formulas using alphanumeric 
user-defined fields.

• Len – Returns the number of characters in a text string.

• Lowercase – Converts a string to lower-case characters.

• Mid – Returns a specific number of characters from the text 
string starting at the position you specify.

• Search – Searches for text in a string and returns the position of 
the text.

• Substitute – Substitutes existing text with specified text.

• Text – Changes a numeric value to an alphanumeric text string. 
You can manipulate the returned string using any of the other 
alphanumeric functions.
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• Uppercase – Converts a string to upper-case characters.

• Value – Converts an alphanumeric value to a numeric value. 
Alphanumeric values beginning with alphabetical characters 
return a value of 0. You can manipulate the string using any of 
the numeric functions.

Len

Returns the length of a string.

Syntax

Len(Alphanumeric)

Parameters

Example

Len([Company]) 

This example returns the number of characters in the company’s 
name.

Lowercase

Converts a string to lower-case characters. Use this function or the 
Uppercase function with the Search function and with equal (==) 
statements to compare alphanumeric values when you do not care 
about the case of the string.

Syntax

Lowercase(Alphanumeric)

Parameters

Parameter Data Type Description

Alphanumeric String The string to return the length of.

Parameter Data Type Description

Alphanumeric String The string to convert to lower case.
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Example

Lowercase([City])=="vancouver"

This example of a mandatory rule checks for the value "Vancouver" 
in the City field. The rule validates if an entry has the values 
"Vancouver", "vancouver", or "VANCOUVER" in the City field.

Mid

Returns a specific number of characters from a text string starting at 
a specified position.

Syntax

Mid(Alphanumeric, StartInt, LengthInt)

Parameters

Example

Mid("First Last", 7)

This example returns the text starting at the 7th position in the field. 
In this case, it returns “Last”.

Search

Searches a string for text and returns the position of the text in the 
string. This function is case sensitive.

Syntax

Search(SearchString, Alphanumeric, StartInt)

Parameter Data Type Description

Alphanumeric String The string that you want to search 
through. Normally, this would be a 
merge field.

StartInt Integer The position of the first character 
in the string you want to return.

LengthInt Integer (Optional) The length of the string 
you want to return.
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Parameters

Examples

Search("Wine", [Company_Name])

This example searches for the text “Wine” in the company name and 
returns the place in the name where the text starts as an integer.

Search("Partner", [Category]) > 0

This example of a mandatory rule searches for the value "Partner" in 
the Category field. This rule validates if an entry has the category set 
to "Partner" even if the there are other values set in the Category 
field as well.

Search("wine", Lowercase([Company_Name])) > 0

This example of a mandatory rule searches for the text “wine” in the 
company name ignoring the case. This rule validates if the Company 
Name field includes the text "Wine", "wine", or "WINE".

Substitute

Substitutes existing text with specified text. This function returns the 
entire string containing the new text.

Syntax

Substitute(Alphanumeric, OldText, NewText)

Parameters

Parameter Data Type Description

SearchString String The text to search for in the string.

Alphanumeric String The string to search through. To 
ignore the case of the string, 
include the Lowercase or 
Uppercase function in this 
parameter.

StartInt Integer (Optional) The starting character 
to search.

Parameter Data Type Description

Alphanumeric String The string containing the text you 
want to change.
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Example

Substitute([Address], "St", "Street")

This example returns the address with the abbreviation “St” 
substituted with the text “Street”.

Text

Converts a numeric value to a string. You can then use the other 
alphanumeric functions to manipulate the returned string.

Syntax

Text(Number, DecPlace)

Parameters

Example

Text([Revenue], 2)

This example returns the revenue as an alphanumeric string with two 
decimal places. If revenue, a numeric field, is 50000, the Text function 
in the above example returns 50000.00 as an alphanumeric value.

Uppercase

Converts a string to upper-case characters. Use this function or the 
Lowercase function with the Search function and with equal (==) 
statements to compare alphanumeric values when you do not care 
about the case of the string.

OldText String The text you want to change.

NewText String The text substituted into the 
string.

Parameter Data Type Description

Parameter Data Type Description

Number Decimal The numeric value that you want 
to convert.

DecPlace Integer (Optional) The number of decimal 
places to return.
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Syntax

Uppercase(Alphanumeric)

Parameters

Example

Uppercase([City])=="VANCOUVER"

This example of a mandatory rule checks for the value "Vancouver" 
in the City field. The rule validates if an entry has the value 
"Vancouver", "vancouver", or "VANCOUVER" in the City field.

Value

Converts an alphanumeric value to a numeric value. If the value 
contains alphabetic characters, it returns 0. You can then manipulate 
the numeric value using any numeric functions.

Syntax

Value(Alphanumeric)

Parameters

Example

Value([Contract Number])

This example returns the alphanumeric user-defined field, Contract 
Number, as a numeric value. If the field contains an alphabetical 
character, it returns 0.

Parameter Data Type Description

Alphanumeric String The string to convert to upper 
case.

Parameter Data Type Description

Alphanumeric String The alphanumeric string to 
convert.
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Date Functions

Use date functions to manipulate date fields in formula user-defined 
fields and in rules for mandatory user-defined fields. When you use 
date functions, you can use date fields as the parameters for the 
function or you can supply date values for the functions. When you 
supply date values, use the Date function to format the values as 
dates.

You can add the following functions to formulas using date fields.

• Date – Converts integers to date values.

• Day – Returns the day of the month as an integer from a date 
value.

• Dayofweek – Returns the day of the week expressed as an 
integer.

• Month – Returns the month as an integer from a date value.

• Year – Returns the year as an integer from a date value.

Date

Any formula that supplies an 
invalid date to the Date 
function will result in a blank 
value. For example, the 
function “Date (2012, 4, 31)” 
is invalid since the month of 
April does not have 31 days. If 
this function is part of a larger 
compound expression, the 
entire expression will evaluate 
to blank.

Converts integers to date values.

Syntax

Date(Year, Month, Day)

Parameters

Example

Date(2009, 7, 9)

This example returns July 9, 2009 as the date value.

Day

Returns the day of the month as an integer from a date value.

Parameter Data Type Description

Year Integer The four-digit year.

Month Integer The one- or two-digit month.

Day Integer The one- or two-digit day.
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Syntax

Day(Date)

Parameters

Examples

Day(Date(2009, 7, 9))

This example returns 9 as the day of the month in the date value.

Day([Creation Date])

This example returns the day of the month that an entry was created.

Dayofweek

Returns the day of the week expressed as an integer for a specified 
date value, with 1 = Sunday, 2 = Monday, 3 = Tuesday, and so on.

Syntax

Dayofweek(Date)

Parameters

Examples

Dayofweek(Date(2009, 7, 9)

This example returns 5, for Thursday, as the day of the week for the 
given date.

Dayofweek([Creation Date])

This example returns the day of the week that an entry was created.

Month

Returns the month as an integer from a date value.

Parameter Data Type Description

Date Date The date to return the day for.

Parameter Data Type Description

Date Date The date value for which to return 
the day of the week.
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Syntax

Month(Date)

Parameters

Examples

Month(Date(2009, 7, 9))

This example returns 7, for July, as the month in the date value.

Month([Creation Date])

This example returns the month that an entry was created.

Year

Returns the year as an integer from a date value.

Syntax

Year(Date)

Parameters

Examples

Year(Date(2009, 7, 9))

This example returns 2009 as the year for the date value.

Year([Creation Date])

This example returns the year that an entry was created.

Parameter Data Type Description

Date Date The date from which to return the 
month.

Parameter Data Type Description

Date Date Date value for which to return the 
year.



Chapter 7 151

Numeric Functions

Use numeric functions to manipulate numeric values in formula user-
defined fields and in rules for mandatory fields. You can add the 
following functions to formulas using numeric fields.

• Ceiling – Rounds a number up to the nearest integer or up to a 
specified number of decimal points.

• Floor – Rounds a number down to the nearest integer or down 
to a specified number of decimal points.

• Round – Rounds a number to the nearest integer or to a 
specified number of decimal points.

Ceiling

Rounds a number up to the nearest integer or up to a specified 
number of decimal points.

Syntax

Ceiling(Number, DecPlace)

Parameters

Example

Ceiling(2.32, 1)

This example returns 2.4.

Floor

Rounds a number down to the nearest integer or down to a specified 
number of decimal points.

Syntax

Floor(Number, DecPlace)

Parameter Data Type Description

Number Decimal The numeric value to round.

DecPlace Integer (Optional) The number of decimal 
places to round up to.
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Parameters

Example

Floor(2.36, 1)

This example returns 2.3

Round

Rounds a number to the nearest integer or to a specified number of 
decimal points.

Syntax

Round(Number, DecPlace)

Parameters

Example

Round(2.45687, 2)

This example returns 2.46.

Parameter Data Type Description

Number Decimal The numeric value to round.

DecPlace Integer (Optional) The number of decimal 
places to round down to.

Parameter Data Type Description

Number Decimal The numeric value to round.

DecPlace Integer (Optional) The number of decimal 
places to round to.
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Comparison Statements in Formulas and Mandatory Rules

Rules for mandatory user-defined fields consist of comparison 
statements. Formula user-defined fields may also include comparison 
statements if the formulas include conditional expressions, using “If” 
statements. 

You can create comparison statements with the following symbols.

• == to check that two values are equal to each other.

For example, [Category] == “Partner” verifies that the 
Category field is set to “Partner”.

• != to check that two values are not equal to each other.

For example, [Category] != “” verifies that the Category field is 
not empty, i.e. it has a value.

• > to check that the first value is greater than the second value.

For example, [Annual Sales] > 20000 verifies that the Annual 
Sales user-defined field has a value greater than 20,000.

• < to check that the first value is less than the second value.

For example, [Contract Expiry Date] < [Last Service Date] 
verifies that the Contract Expiry Date field is earlier than the Last 
Service Date field.

• >= to check that the first value is greater than or equal to the 
second value.

• <= to check that the first value is less than or equal to the second 
value.

Comparison statements are often combined with logical operators to 
add multiple statements together.

You can compare any values including alphanumeric, date, and 
numeric values. Alphanumeric values are compared by checking the 
alphabetical order of the string. When you compare values from 
table fields, they are treated as alphanumeric values. 

Comparison statements are case sensitive. If you want to ignore the 
case of fields, include the Lowercase or Uppercase function in the 
statement. For example, [City] == "Vancouver" is true only if the 
value of the City field is set to "Vancouver". However, 
Lowercase([City]) == "vancouver" is true if the value of the City field 
is set to "Vancouver", "vancouver", or "VANCOUVER".

To compare a table field that contains multiple values, the 
comparison statement must include the same text that’s displayed in 
the Maximizer interface, including all values for the field. For 
example, the statement [Category] == "Partner" will be true only if 
the only value set in the Category field is "Partner". If the Category 
field includes the "Distributor" value as well, the rule would validate 
with the following statement: Category == "Distributor, Partner". 
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You can use the Search function to locate text in multiple-value table 
fields.

Logical Operators for Formulas and Mandatory Rules

You can use logical operators to build more complex comparison 
statements in formula user-defined fields and in rules for mandatory 
fields.

You can use the following logical operators:

• Or – Combines two comparison statements where either one of 
the statements is true.

For example, [Category] == “Partner” OR [Category] == 
“Distributor, Partner” is true if the Category field has either 
the “Partner” value alone or has both the "Partner" and the 
“Distributor” values.

• And – Combines two comparison statements where both of the 
statements is true.

For example, [Category] == “Partner” AND [Annual Sales] > 
20000 is true if the Category field has the “Partner” value and if 
the Annual Sales field is greater than 20,000.

• Not – Negates a comparison statement.

For example, NOT ([Category] == “Partner” AND [Annual 
Sales] > 20000) is true in all cases where the previous example is 
false.
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Key Fields Lists
Key Fields are important user-defined fields and system fields that 
are highlighted on the Details tab for Address Book entries, 
opportunities, and customer service cases, and on the Basic 
Information tab in campaigns, making them more readily accessible.

You can choose any user-defined fields and some system fields to 
include in the Key Fields lists. You may want to select mandatory 
fields as Key Fields, so users don’t miss them when creating new 
records. You may also select frequently used fields, making it easier 
for users to quickly enter these values. And you may select fields 
important to a particular group of users because different Key Field 
lists can be defined for specific users and groups, or for all users.

Key Fields for Different Types of Entries

Each Key Fields list contains different sets of fields for each type of 
entry. For example, you can create a new Key Fields list and add 
different sets of fields for Companies and Opportunities. When you 
add new fields to the list for opportunities, you can add only 
opportunity basic fields and user-defined fields. When you view the 
Details tab for an opportunity in Maximizer, only the fields added to 
the opportunities list will be displayed.

When you work with Address Book entries, you can set up separate 
lists of Key Fields for Companies, Individuals, and Contacts. As well, 
each type of Address Book entry has different lists for sales leads and 
for regular entries. For example, Individual - Lead Key Fields appear 
only in Individual Address Book entries that are marked as sales 
leads.

Add fields to the Key Fields list for only the types of entries that you 
want to make the Key Fields list available to. If the Key Fields list 
contains no fields for a specific type of entry, the list will not be 
available when you view that type of entry.

Each Key Fields list can contain separate lists for the following types 
of entries:

• Company Lead – For Companies marked as sales leads.

• Company – For Companies that are not marked as sales leads.

• Individual Lead – For Individuals marked as sales leads.

• Individual – For Individuals that are not marked as sales leads.

• Contact Lead – For Contacts that are marked as sales leads.

• Contact – For Contacts that are not marked as sales leads.

• Opportunity – For opportunities.
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• Campaign – For campaigns

• Customer Service – For customer service cases.

Restricting Access to Key Fields

The Key Fields lists in the Details tab or in the Basic Information tab 
are visible only to the users or groups specified as having Read Access 
to the Key Fields lists. However, other users may still be able to access 
the fields in the list through the User-Defined Fields tab or through 
other Key Fields lists. Assigning a field to a Key Fields list does not 
determine who can access the field. The field is available as a Key 
Field only to users with access to both the user-defined field and to 
the Key Fields list.

Create a Key Fields List

� In Administrator, select File > Preferences.

� Select the Key Fields tab.

� Click Add.

� Enter the properties for the Key Fields list.

• In the List name field, enter a name for the Key Fields list.

• In the Description field, enter a description for the Key 
Fields list.



Chapter 7 157

• From the Owner drop-down list, select the user or security 
group with access to the Key Field list, or leave it as Public.

• If necessary, from the Requested by field, select the user 
who requested the Key Fields list.

� Select the Key Fields tab and from the Show key fields for 
drop-down list, select the type of Maximizer entry to assign Key 
Fields to.

� Add user-defined fields and system fields to the list.

• Click Add, select Key Field, select a system or user-defined 
field, and click Insert.

• To insert a separator, click Add, and select Separator.

Separators are used to group the Key Fields into visible 
groups.

If you add a separator at the 
top or bottom of the list, or if 
you add two separators in a 
row, the separators will be 
suppressed when the entry is 
viewed in Maximizer.

• Use the Move buttons to reposition the selected field or 
separator in the list.

� If necessary, from the Show Key Fields for drop-down list, 
select a different type of entry, and add fields to the list for that 
type of entry.

	 Click OK to save the Key Fields list.
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Preventing Duplicate Entries
When more than one Address Book entry exists for the same person 
or organization, the entries are considered duplicates. These 
duplicates may occur when users create a new Address Book entry 
without determining whether an entry already exists for the person 
or organization. They can also occur when entries are created 
automatically by operations such as importing. Duplicate entries are 
undesirable because information related to the person or 
organization becomes fragmented. You can prevent most duplicate 
entries by using Maximizer’s duplicate Address Book entry checking 
options.

You can configure duplicate checking in the Address Book 
preferences in Administrator.

You can prevent most duplicate Address Book entries by specifying 
up to three combinations of fields that must be unique to each entry. 
If a user attempts to create a new Address Book entry, and the values 
of any of those field combinations match an existing entry, 
Maximizer does not allow the duplicate entry to be created.

A combination of fields that must be unique to each entry is called a 
“duplicate check list”. You can create up to three duplicate check 
lists, using up to three fields in each list. 

Maximizer considers an entry to be a duplicate if the values of all 
fields from List 1, or all fields from List 2, or all fields from List 3 
match an existing entry.
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The default duplicate check lists, described below, effectively prevent 
most duplicate entries:

The “Full Name/Company 
Name” matching field checks 
the Full Name of Individual or 
Contact entries and checks the 
Company field of Company 
entries. The “Company for 
Individual” matching field 
checks the Company field of 
Individual entries.

When a user creates a new Address Book entry in Maximizer, and 
Maximizer detects it as a potential duplicate Address Book entry, the 
user is presented with the following list of options:

• Merge with selected entry – The newly created or modified 
Address Book entry merges with, and overwrites, the existing 
(selected) entry. If a duplicate entry is private, this option is 
unavailable.

• Edit selected entry – The existing (selected) Address Book 
entry opens, allowing it to be edited by the user. Any 
information entered in the newly created entry that was 
detected as a duplicate must be re-entered. If a duplicate entry is 
private, this option is unavailable.

• Add the new entry – This option adds the new entry. It is 
available only under certain circumstances. If a user or group has 
permission to create duplicate entries (“Duplicates may be 
entered by” field in the Address Book tab), he or she has the 
option to create duplicate entries. This option is also available if 
partial matching is enabled and Maximizer finds a partial match. 
If a duplicate entry is private, only users with the ability to enter 
duplicates can create the duplicate entry.

Partial Matching

Partial matching identifies an entry as a possible duplicate even if not 
all fields in any of the duplicate check lists are the same in both the 
new entry and an existing entry.

With partial matching, the order of the fields (1st, 2nd, 3rd) in the 
duplicate check lists is important, as described in the following 
scenarios:

Check List Fields

Duplicate Check List 1: 1. Full Name/Company Name
2. All Phone Numbers
3. None

Duplicate Check List 2: 1. Full Name/Company Name
2. Zip/Postal
3. None

Duplicate Check List 3: 1. None
2. None
3. None
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If the first field only is defined 
in the list (the second and third 
fields are set to None), partial 
matching doesn’t apply 
because matching one field is 
a complete match.

• If the first and second fields only are defined in the list (the third 
field is set to None), an entry is considered a possible duplicate if 
only the first field matches.

• If all three fields are defined in the list, an entry is considered a 
possible duplicate if only the first field matches, or if both the 
first and second field match.

If the first field doesn’t match, an entry is never considered a possible 
match, even if the second and/or third field matches.

Maximizer displays the list of possible duplicates in order of number 
of fields matched.

By default, partial matching is disabled. To turn partial matching on, 
select the “Allow partial match” checkbox.

If the Address Book has been 
upgraded from a previous 
version of Maximizer, and 
duplicate checking was 
enabled, partial matching is 
enabled after upgrading the 
Address Book to the new 
version.

The “Allow partial match” checkbox applies to all Duplicate Check 
Lists. You cannot allow partial matches for some lists and not for 
others.

Partial matching is relevant only if no exact matches exist. If all the 
fields in any of the duplicate check lists match an existing entry, it is 
considered a duplicate entry, and partial matching does not apply. 
However, if Maximizer finds no exact matches, it returns a list of 
entries matching any of the fields from the duplicate check lists.

Permission to Create Duplicate Entries

If some users or groups require the ability to create duplicate Address 
Book entries, you can select a user or group from the “Duplicates 
may be entered by” drop-down list. If more than one user requires 
this ability, add those users to a new security group and then select 
that group from this drop-down list.

Retrieving Private Entries with Duplicate Checking

When a private entry is found by duplicate checking, the name of the 
entry is displayed, but the details of the entry are not. Also, when this 
type of entry is found, the merge entry and open entry functionality 
is disabled.

Configure Duplicate Checking for Address Book Entries

� In Administrator, select File > Preferences.

� Select the Address Book tab.

� Select Check for duplicates when adding Address Book 
entries.
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� From the Duplicate check list drop-down list, select one of the 
Duplicate Check Lists.

� In the Fields to match for the selected list box, select the 
first, second, and third fields to match.

You can select up to three fields, but selecting all three fields is 
not required.

� Repeat the previous two steps to configure any of the other 
Duplicate Check Lists.

� To enable partial matching, select Allow partial match.

	 If you want any users or groups to be able to create duplicate 
entries, select the name of the user or group from the 
Duplicates may be entered by drop-down list.
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Email Notification for Opportunities/Customer Service Cases
If you are using case or 

opportunity notification in 
Maximizer Web Access, you 
must specify an email address 
for WEBUSER. Go to File > 
Manage Users, select 
WEBUSER from the list of 
users, and click Properties. 
Enter an email address on the 
General tab of the Properties 
dialog box.

Maximizer can send email to customers, partners, and users when the 
status of customer service cases or opportunities changes.

Maximizer includes default notification messages that are sent to 
users. You can also create custom email notification templates in 
Administrator. You can assign email templates for each action such 
as when you create a customer service case or when you win an 
opportunity. Each action can also have separate templates sent to 
customers/partners and to users.

When writing the email templates, remember that each template 
applies to all customer service cases or opportunities of that 
notification event type. They should be specific to the action they are 
assigned to but generic enough to apply to all cases or opportunities 
with that action. Use merge fields to personalize emails based on 
generic templates.

You can also create default case and opportunity monitoring lists in 
Administrator. Email messages are sent to users when cases or 
opportunities are modified. Users can specify what changes to 
receive notification for in their preferences. Users can also assign 
monitors to specific cases and opportunities.

Email Notification for Customer Service Cases

Maximizer sends email messages to customers, partners, and users 
when you create, assign, escalate, or resolve customer service cases. 
You can configure the email notifications in the Notification tab of 
the Customer Service preferences in Administrator.

You can choose to send notification automatically to Address Book 
entries when cases are first created. For the other customer 
notification templates, users have the option to send the notification 
while performing the specified actions in Maximizer. You also have 
the option to send a copy of the email message to the partners when 
notifying customers. User notification email messages are sent to the 
users identified in the Owner and Assigned To fields for the case.

Email Notification for Opportunities

Maximizer can automatically send email to users and partners when 
opportunities are created, abandoned, lost, suspended, or won. You 
can configure the email notifications in the Opportunities 
preferences in Administrator.

When partner or user templates are assigned to the various actions, 
the email messages are automatically sent to the assigned partner or 
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users when the actions are performed. You can choose to send a copy 
of email messages sent to partners to the associated Account 
Manager as well. You can also notify sales leaders automatically 
whenever the leader field is changed. User notification email is sent 
to users identified as monitors for the opportunities.

Merge Fields in Email Notification Templates

Merge fields in the email template personalize the message for each 
recipient by replacing the merge field syntax with the actual field 
value for the Address Book entry. For example, including the 
{First_Name?} merge field in an email template replaces the syntax 
with each email recipient’s actual first name.

The question mark in a merge 
field is used to alert users to 
not leave a space if no value is 
assigned to the related 
Address Book entry for the 
merge field.

Commonly used customer service and opportunity merge fields are 
described below. For a complete list of merge fields to include in the 
email templates, see the Insert Merge Field dialog box in the 
Maximizer Word Processor. Press F1 when a field is selected to view 
its description.

You can create templates in either .ETF (Maximizer Word Processor) 
or .HTML format. When you create templates in the Maximizer Word 
Processor, click the Merge Field button and select the merge field to 
insert into your email template. When you create HTML templates in 
an HTML or text editor, you must enter the merge field syntax 
manually or copy the syntax from the Maximizer Word Processor.

Customer Service Case Merge Fields

The following table lists the basic customer service case merge fields 
to include in email templates.

• {My_Name?} – Full name of the logged-in user (first name, 
initial, and last name).

• {My_Company?} – Name of the logged-in user’s company.

• {CS.Case_Number?} – Case number.

• {CS.Client_Name?} – Name of the associated Address Book 
entry (Company or Individual).

• {CS.Contact_Name?} – Name of the Contact associated with 
the case.

Because this field is not mandatory in customer service cases, a 
value may not display in case notification emails.

• {CS.Subject?} – Case subject.

• {CS.Assigned_To?} – Name of the user who the case is assigned 
to.

Applies to case assignment or escalation emails only.
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• {CS.Resolved_By?} – Name of the user who resolved the case.

Applies to case resolution emails only.

• {CS.Resolved_Date?} – Date when the case was resolved.

Applies to case resolution emails only.

• {CS.Resolved_Time?} – Time when the case was resolved.

Applies to case resolution emails only.

• {Case_Solution?} – Knowledge base article number associated 
with the case resolution.

Applies to case resolution emails only.

• {Case_Solution_Note?} – Notes from the Solution Notes field 
in the Solution Information & Billing tab of the Case dialog box.

Applies to case resolution emails only.

Opportunity Merge Fields

The following table lists the basic opportunity merge fields to include 
in email templates.

• {My_Name?} – Full name of the logged-in user (first name, 
initial, and last name).

• {My_Company?} – Name of the logged-in user’s company.

• {Opportunity.Client_Name?} – Name of the associated 
Address Book entry (Company or Individual).

• {Opportunity.Opportunity_Contact_Name?} – Name of the 
Contact associated with the opportunity.

Because this field is not mandatory in customer service cases, a 
value may not display in case notification emails.

• {Opportunity.Objective?} – The objective of the opportunity.

• {Opportunity.Categories?} – The category of the opportunity.

• {Opportunity.Products_Services?} – The products/services of 
the opportunity.

• {Opportunity.Description?} – The opportunity’s description.

• {Opportunity.Stage?} – The stage the opportunity is at.

• {Opportunity.Confidence_Rating?} – The current confidence 
rating of the opportunity.

• {Opportunity.Status?} – The current status of the opportunity.

• {Opportunity.Start_Date?} – The start date of the 
opportunity.

• {Opportunity.Close_Date?} – The close date of the 
opportunity.

• {Opportunity.Next_Action?} – The opportunity’s next action.
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• {Opportunity.Revenue?} – The opportunity’s projected 
revenue.

• {Opportunity.Cost?} – The opportunity’s cost.

• {Opportunity.Team_Name?} – The name of the team 
associated with the opportunity.

• {Opportunity.Opportunity_Leader?} – The leader of the 
opportunity.

Create an Email Notification Template

� In Administrator, select File > Preferences.

� Select the Customer Service or Opportunity tab depending 
on the module you are working with.

� Click Notification.

� Click Assign. 

• For customer service case email notification, select Customer 
Template or User Template.

• For opportunity email notification, select Partner Template 
or User Template.

The Email Notification Template Library opens.

� Click New.

� Select Maximizer Message Body (Maximizer Word Processor 
.ETF template) or HTML Message Body (HTML template).

The Message Body Name dialog box opens.

� Type a name to identify the template and click OK.

It’s a good idea to include the 
action (Create, Assign, 
Escalate, or Resolve) and the 
recipient type (Customer or 
User) in the template name, so 
the template is easier to 
identify.

	 Write the content of the email template, including customer 
service case or opportunity merge fields.
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To insert merge fields in the Maximizer Word Processor, click the 
Merge Field button. 

To use merge fields in HTML email templates, you must type the 
merge field syntax manually. To simplify the process, you might 
choose to create the template with its merge field syntax in the 
Maximizer Word Processor, and then copy and paste the text 
into the HTML document.


 Save the template and close the editor.
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Assign Email Notification Templates

Use this procedure to assign email notification templates for 
customer service cases. The templates must already be created in the 
desktop version of Administrator.

� In Administrator, select File > Preferences.

� Select the Customer Service or Opportunity tab depending 
on the module you are working with.

� Click Notification.

� Under Email templates for notification, select an action 
name.

� Click Assign. 

• For customer service case email notification, select Customer 
Template or User Template.

• For opportunity email notification, select Partner Template 
or User Template.

The Email Notification Template Library opens.

� Select an existing template from the list and click OK.

The template is now associated with the action name for 
customers or users.

� Specify the remaining notification settings.

• For customer service email notifications, to email the 
associated partner when notifying a customer, select Carbon 
Copy the associated Partner when notifying 
Customers.

• For opportunity email notifications, to email the associated 
account manager when notifying a partner, select Carbon 
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Copy the Associated Account Manager when notifying 
the Partner.

	 Click OK to save the changes.

Turn Off Email Notification

Use this procedure to remove a notification template from a 
customer service or opportunities action. You can remove a user 
template to stop sending notification to Maximizer users, a customer 
template to stop sending notification to customers (customer service 
cases only), or a partner template to stop sending notification to 
partners (opportunities only).

� In Administrator, select File > Preferences.

� Select the Customer Service or Opportunity tab depending 
on the module you are working with.

� Click Notification.

� In the Email templates for notification group, select an 
action name.

� Click Unassign, and select the type of template you want to 
remove.

• For customer service case email notification, select Customer 
Template or User Template.

• For opportunity email notification, select Partner Template 
or User Template.
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Set Default Opportunity/Case Monitors

You can set up default opportunity and customer service case 
monitoring lists in Administrator. Users can assign the default list of 
monitors to opportunities and cases in Maximizer. Users can also 
specify custom lists of opportunity and case monitors in specific 
entries.

� In Administrator, select File > Preferences.

� Select the Customer Service or Opportunity tab depending 
on the module you are working with.

� Click Monitoring.

The current list of users assigned for monitoring is displayed.

� Add or remove users from the list.

• To add a user to the list, click Add, select a user, and click OK.

• To remove a user from the list, select the user, and click 
Delete.

� Click OK to save the changes.
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Event Notification
Maximizer enables you to send email notifications to a definable list 
of recipients when specific Maximizer events occur and to log these 
events to a file. 

Most often these events are significant error conditions requiring 
human intervention, such as a severe Email Server error during an 
email marketing campaign. They may also be notifications of 
irregularities in business process, such as a remote user who has not 
synchronized in a threshold number of days.

Event notification email messages and log files contain the following 
information about events:

• Date and time when the event occurred

• Type of event

• Address Book in which the event occurred

• Action resulting from the event (for example, activity suspended 
due to fatal error)

• Additional information about the event, such as error codes, 
suggested resolutions, etc. 

The following table describes the events for which notification is 
available, as well as probable causes and suggested resolutions for 
each.

Event 
description Module Cause Resolution

Print/Fax 
service fatal 
error

AutoPrintF
ax

The connection to 
the printer or fax 
software has failed.

Check the 
connection with the 
printer or fax 
software.

Email service 
fatal error

AutoEmail The connection to 
the SMTP Email 
Server has failed or 
the SMTP 
authentication 
username and/or 
password is 
incorrect.

Check the SMTP 
server name, check 
the network 
connection, and 
check the 
authentication 
username and 
password on the 
Automated Services 
tab (available in 
Administrator from 
the File > 
Preferences menu).
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Enable Event Notification

� In Administrator, select File > Preferences.

� On the System Options tab, click Event Notification.

� Select Enable event notification.

� In the Events list, select an event, and click Properties.

� Specify the notification options to enable for this event.

� If you selected Via email as one of the notification options, click 
Add to specify names and email addresses of notification 
recipients.

� Click OK to close the Event Notification Properties.
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	 Repeat steps 4 through 7 for each event for which you want to 
enable notification or logging.


 Complete the SMTP server settings fields as they apply to your 
SMTP server, and click OK.

View Event Notification

Use this procedure to view the event notification log file in a text 
editor.

� In Administrator, select File > Preferences.

� On the System Options tab, click Event Notification.

� On the Events Notification dialog box, click View Log File.

Open Windows Event Viewer

Use this procedure to open Windows Event Viewer where you can 
view Maximizer event notifications.

� Select Start > Programs > Administrative Tools > Event 
Viewer.

� In the left pane, select Application Log.

Maximizer event notifications appear in the right pane of the 
Event Viewer.



Chapter 7 173

Recording Holidays in the Holiday Editor
The Holiday Editor is a utility you can use to add or edit holidays in 
the Maximizer calendar. By default, the Holiday Editor contains many 
North American holidays. The holidays listed in the Holiday Editor 
also appear in the Calendar page in Maximizer. You can use 
Administrator to modify or delete existing holidays, or add new 
holidays.

If you wish to add personal holidays or events to your calendar, such 
as “Alice's birthday”, you must create a yearly recurring appointment 
using the Calendar page in Maximizer.

The Holiday Editor's data file—Mxzhol.nam—is inserted in the 
Maximizer program folder when you install Maximizer. In this 
location, you use Administrator’s Holiday Editor to manage one set 
of holidays for your installation of Maximizer.

Add a Holiday

Use this procedure to add a holiday to your calendar using the 
Holiday Editor.

� In Administrator, select Utilities > Holiday Editor.

� Click Add.

� Enter the details of the new holiday.

� Click OK to close the Add Holiday dialog box.
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C H A P T E R88Configuring Email

In this chapter...

“Configuring Email” on page 176

“Configuring the Maximizer Print/Fax Service” on page 182
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Configuring Email
The Maximizer Email Service sends email messages as part of 
automated campaigns, opportunity and case email notification, and 
appointment reminders. You must configure the Maximizer Email 
Service to use these features properly.

Automated campaigns track various statistics for email activities, 
including the number of bounces and replies generated from email 
activities. To track these statistics, you must specify the email 
accounts to monitor.

The following sections contain information on configuring email:

• “Configuring the Maximizer Email Service” on page 176

• “Configuring Email Accounts for Campaign Monitoring” on 
page 178

Configuring the Maximizer Email Service

The Maximizer Email Service is installed automatically with 
Maximizer, and it works with the following operations in Maximizer:

• Automated campaign email activities

• Opportunity and customer service email notifications

• Appointment notification using iCalendar attachments and 
appointment reminders

• Email messages sent through Maximizer Web Access or Mobile 
Access

The Maximizer Email Service must be running for these operations to 
function. 

By default, Maximizer will delete any email messages queued by the 
email service that are older than 14 days. Messages are queued when 
the email service is stopped. To change the maximum age of unsent 
email messages, modify the value of the EMGR_MSG_AGE_LIMIT key 
in the MaConfig table. To disable email message age limits, set this 
value to 0.

Ensure that users have an email address entered in their user 
properties, so they can receive customer service case email 
notifications and appointment reminders by email. Users should also 
set their email appointment notification option in Maximizer (In the 
Setup tab, select Preferences. In the Preferences dialog, select the 
Calendar/Hotlist tab).

For more information about the properties in the Automated 
Services tab, click inside the tab and press F1.
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➤ To configure the Maximizer Email Service

� In Administrator, select File > Preferences.

� Select the Automated Services tab.

� Select Email from the Preferences for Activity type drop-
down list.

� Set the Service cycle time check.

The service cycle time check controls how often the Maximizer 
Email Service processes the email activities in automated 
campaigns. By default, this option is set to 1 minute. 

� To send large quantities of email messages, select the Enable 
sending in batch mode option, and set the Batch size.

If you are using an ISP, it’s important to control the email batch 
settings.

� Enter a URL in the URL of Campaign Manager Statistics field. 

This URL specifies the URL of the script that redirects the email 
recipients to the Landing page URL (as specified in the Add Email 
Activity dialog box), which is included in automated email 
activities. This option applies to automated email activities only, 
and it is available only if Maximizer Components for Microsoft IIS 
is installed.

� Choose a character set from the Character set used by email 
service drop-down list. This is the friendly name for the 
character set. The actual name of the character set is shown in 
the field on the right of the drop-down list. 

This character set is used for all outgoing email sent by the 
Maximizer Email Service. 

If the character set does not appear in the list, you can enter the 
name of the character set in the field on the right. The field on 
the left is then displayed as a blank value. 

	 Select the Activate services for the currently open Address 
Book option.

This checkbox must be enabled to use automated email 
campaigns, customer service case email notifications, and 
appointment reminders by email.


 Enter the Service computer and SMTP server names and the 
SMTP port number.

The SMTP server is specified 
during the Maximizer 
installation and the port 
number is set to 25 by default.

��If the SMTP server requires authentication, select the 
checkbox and enter the account name and password.
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The authentication settings are 
specified during Maximizer 
installation.

��Click OK.

Maximizer is now configured to use the Maximizer Email Service 
for automated email campaign activities, customer service case 
email notifications, and appointment reminders by email.

Configuring Email Accounts for Campaign Monitoring

To track some statistics for email campaigns, you must specify the 
settings for the IMAP server and email accounts used for monitoring 
bounces and replies for campaign email activities. Maximizer tracks 
the number of email messages sent to these accounts and generates 
statistics for each campaign. 

You must specify settings for the same email accounts that are 
specified as the “From” and “ReplyTo” addresses in the Email 
Addresses tab of a campaign email activity.

➤ To configure campaign monitoring email accounts

� In Administrator, select File > Preferences.

� Select the Campaign tab.

� Under Campaign monitoring options, click Monitoring.

The Campaign Monitoring Settings dialog box opens.

�

� �

	



�
�
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� Under Server settings, specify settings for the IMAP email 
server.

• In the IMAP Server field, enter the URL for the IMAP server.

• In the Port field, enter the port number for the IMAP server.

• Select SSL if Secure Sockets Layer (SSL) is enabled on the 
IMAP server.

� Under Campaign “From” account, specify the name and 
password for the email account that appears as the “From” 
address in campaign messages.

This account must match the email address specified as the 
“From” address in the Email Addresses tab of campaign email 
activities.

� Under Campaign “Reply To” account, specify the name and 
password for the email account to which to send replies.

This account must match the email address specified as the 
“ReplyTo” address in the Email Addresses tab of campaign email 
activities.

If the From and Reply To accounts are the same, you need to 
specify the credentials only once, in either section. The specified 
email account is monitored for both replies and bounces.

� Click OK to close the Campaign Monitoring Settings dialog box.

	 Click OK to save the changes to the preferences.
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User Account for SQL Server Reporting Services Integration

In order to enable the SQL Server Reporting Services Integration, you 
must specify a user account to connect with the Maximizer database. 
The user account must match the following criteria:

• The user is a member of the SSRS Report Management security 
group in Maximizer. For information on security groups, see 
“Security Groups” on page 106.

• The login for the user has the sysadmin server role on the SQL 
Server hosting the Maximizer database. For information on user 
logins in Microsoft SQL Server, see the SQL Server 
documentation.

The MASTER user automatically meets these criteria. 

Enabling SQL Server Reporting Services

You can enable SQL Server Reporting Services in the System Options 
preferences in Maximizer Web Access Administrator. When you 
enable SQL Server Reporting Services, a number of default reports 
are automatically created on the SQL Server Reporting Services 
server.

➤ To enable SQL Server Reporting Services

� Log in to Maximizer Web Access Administrator.

� In the left pane, under Preferences, click System Options.

� Select the SQL Server Reporting Services Settings tab.

� Click Modify Options.

� Select Enable SQL Server Reporting Services Integration.

The URL to the Reporting Services server and the path to the 
current Address Book are automatically filled in.
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� Under Database Account, enter the username and password 
for the user account used to connect to the Maximizer database.

If you are using Windows Authentication, you must specify the 
Windows domain and user account in the Account field.

Whenever the password changes, you must specify the new 
password in this page.

� Click Save.

	 The SQL Server Reporting Services settings are saved on the 
report server. You may need to wait a moment for the settings 
to save.
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Configuring the Maximizer Print/Fax Service
Much like the Maximizer Email Service, the Maximizer Print/Fax 
Service enables you to create automated campaigns for fax and 
printing. The Maximizer Print/Fax Service is part of the Maximizer 
installation. However, you must configure it in Administrator before 
you can use it for automated campaigns.

You must already have a fax modem and fax software installed and 
functioning before you can integrate these services with Maximizer.

Note that for Windows XP Professional, the Maximizer Print/Fax 
Service must run as an application, not as a service.

For more information about the properties in the Automated 
Services tab, click inside the tab and press F1.

➤ To configure the Maximizer Print/Fax Service

� In Administrator, select File > Preferences.

� Select the Automated Services tab.

� Select Print/Fax from the Preferences for Activity type drop-
down list.

� Set the Service cycle time check.

The service cycle time check controls how often the Maximizer 
Print/Fax Service processes the Print/Fax activities in automated 
campaigns. By default, this option is set to 1 minute.

� To send large quantities of faxes or print jobs, select the Enable 
sending in batch mode option, and set the Batch size.

� Select the Activate services for the currently open Address 
Book option.

This checkbox must be enabled to use automated fax or print 
campaigns.

� Enter the Service computer name.

	 Click the Initialize Print/Fax Service button to update the list 
of available printers and faxes in the “Add or Modify Print/Fax 
Campaign Activity” dialog box. 

Note that the Initialize Print/
Fax button is available on the 
Maximizer server only; it is 
disabled for workstations. 

Each time you add or remove a printer or fax application on the 
service computer, or when you install or re-install Maximizer, 
you must initialize the Print/Fax Service. 



Chapter 8
Configuring Email

183


 Click OK.

Maximizer is now configured to use the Maximizer Print/Fax Service 
for automated fax or print campaigns.

��

�
�

�
�
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C H A P T E R99Configuring Web Access

In this chapter...

“Introduction to Web Access” on page 186

“Enabling Web Access Sites” on page 189

“Escona Tutorial Sample Sites” on page 190

“Application Settings for Web Access Sites” on page 197

“Setting Up Windows Authentication for Web Access” on page 205

“Web Access Users and Security Groups” on page 209

“Maximizer Web Access” on page 213

“Maximizer Web Access Administrator” on page 216

“Mobile Access” on page 217

“Customer Access and Partner Access” on page 220

“Advanced Site Configurations” on page 228
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Introduction to Web Access
The Maximizer CRM Server 

setup program installs and 
registers several machine-level 
COM DLLs and sets up some 
machine-level registry settings. 
If you are moving Maximizer 
Web Access to a different 
server, ensure you run the 
setup program again.

Maximizer Web Access, Customer Access, Partner Access, and Mobile 
Access are installed automatically with Maximizer CRM Server. The 
Maximizer web access sites provide web browser access to a 
Maximizer Address Book from any Internet-connected computer or 
mobile device.

The Maximizer CRM Server installation provides the option to install 
Start Menu shortcuts to the sites. These links are intended to connect 
to Maximizer Web Access Administrator for the convenience of 
internal users. Only one instance of a Partner Access and one instance 
of a Customer Access can be set up for this quick access for each 
Address Book. To set it up, log into the Address Book you want to set 
up in Maximizer Administrator, select File > Web Access > Shortcuts, 
and enter the URL to be accessed on the relevant line. Both the 
Partner Access URL and the Customer Access URL can be specified 
here.

Site Types

There are several site types, each with a different purpose and 
functionality. The site types are described below.

Maximizer Web Access

Maximizer Web Access is a browser-based application providing the 
functionality of Maximizer over the Internet. Employees can work 
with Address Book entry information, notes, calendar appointments, 
Hotlist tasks, user-defined fields, and opportunities, as well as view 
company documents and other pertinent information.

• Local path: C:\Program Files\Maximizer\Portals\Employee

• Virtual folder: http://<server name>/MaximizerWebAccess

• Main login URL: http://<server name>/MaximizerWebAccess/
Default.aspx

Mobile Access

Mobile Access provides access to Maximizer through mobile web 
browsers. When users open Mobile Access from the Windows Start 
menu, a URL displays. Users enter this URL into a mobile browser to 
access Mobile Access.

• Local path: C:\Program Files\Maximizer\Portals\Wireless

• Virtual folder: http://<server name>/MaximizerMobileAccess

• Main login URL: http://<server name>/MaximizerMobileAccess/
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Partner Access

Partner Access is a browser-based application providing a two-way 
flow of information between your organization and its business 
partners. This medium allows for a multi-tier distribution group to 
effectively distribute sales opportunities and keep all involved parties 
informed.

All aspects of the site are administered with a separate web access 
administrator application.

• Local path: C:\Program Files\Maximizer\Portals\Partner

• Virtual folder: http://<server name>/MaximizerPartner

• Main login URL: http://<server name>/MaximizerPartner/
Default.aspx

• Administrator login URL: http://<server name>/
MaximizerPartner/Admin/Default.aspx

The following third-party applications are installed with Customer 
and Partner Access, and are available from the Windows Start menu:

• Excentrics World Components

• Microsoft Internet Explorer WebControls

Customer Access

Customer Access is similar to Partner Access. It’s a browser-based 
application providing a two-way flow of information between your 
organization and its customers. Customers have access to news and 
events.

Like Partner Access, the site is administered with a web access 
administrator application. This is separate from the main site.

• Local path: C:\Program Files\Maximizer\Portals\Customer

• Virtual folder: http://<server name>/MaximizerCustomer

• Main login URL: http://<server name>/MaximizerCustomer/
Default.aspx

• Administrator login URL: http://<server name>/
MaximizerCustomer/Admin/Default.aspx

The following third-party applications are installed with Customer 
and Partner Access, and are available from the Windows Start menu:

• Excentrics World Components

• Microsoft Internet Explorer WebControls
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Supported File Types in Company Library and Documents

The following document types are supported in the Company Library 
and Document window of the web access sites:

• .DOC and .RTF (Microsoft Word)

• .XLS (Microsoft Excel)

• .PPT (Microsoft PowerPoint)

• .HTM and .HTML

• .BMP (bitmaps)

• .TXT (text files and Company Library notes)

• .JPG, .GIF, and .TIF (graphics files)

• .PDF (Adobe Portable Document Format)

You can add support for other file types using Microsoft Internet 
Information Services (IIS) Manager. For more information, see 
“Adding Support for File Types” on page 32.
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Enabling Web Access Sites
By default, all Maximizer web access sites are disabled. Enabling a 
site is a simple process, which must be completed before anybody can 
access them. You can activate them during installation, or modify the 
Web.Config file for each site you want to enable. To enable a site 
during installation, see “Installing Maximizer CRM Server” on 
page 47.

➤ To enable a site via the Web.Config file

� Open the site’s Web.Config file in a text editor, such as 
Notepad. 

The Web.Config file is located on the Maximizer server at the 
following path:

C:\Program Files\Maximizer\Portals\<site>\Web.Config

If Maximizer was installed in a folder other than the default 
location of C:\Program Files\, replace that portion of the path 
with the folder where Maximizer was installed.

� In the appSettings section, locate the Enabled key, which is 
shown below:

<add key=”Enabled” value=”false” />

� Change the value to true, as show below:

<add key=”Enabled” value=”true” />

� Save the Web.Config file.

Note that if you are using Windows 2008 or 2012, you must also 
select the “Detailed errors” option in IIS. This setting is found under 
Error Pages > Edit Feature Settings.
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Escona Tutorial Sample Sites
The IIS Server must be started 

for the sites to function.
The Escona Tutorial Address Book includes sample web access sites. 
The sample sites, Maximizer Web Access, Customer Access, and 
Partner Access, require no configuration and are accessible from the 
Maximizer folder on the Windows Start menu. These sample sites are 
installed on the Maximizer IIS Server as part of the Maximizer 
Components for Microsoft IIS installation. 

You can access the sample sites using the following user IDs and 
passwords.

This section steps you through the following procedures with the 
Escona Tutorial sample sites:

• “To start the Default Web Site” on page 191

• “To change a site to an application” on page 191

• “To access Escona Tutorial Customer or Partner Access 
Administrator” on page 195

• “To enable Address Book entries to access the site” on page 224

• “To access Escona Tutorial Customer or Partner Access” on 
page 196

Many of these procedures also apply to your own sites.

Sample Site User ID Password

Maximizer Web Access Administrator master control

Maximizer Web Access jnapoli maximizer

Customer Access Administrator jnapoli maximizer

Partner Access Administrator jnapoli maximizer

Customer Access mary password

Partner Access paul password

Mobile Access jnapoli maximizer
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➤ To start the Default Web Site

Before accessing the sample 
sites, ensure that the Default 
Web Site is started.

� On the Maximizer IIS Server, select Start > Programs > Control 
Panel > Administrative Tools > Internet Information 
Services Manager.

� Select Default Web Site, and click the Start item button.

When the Start item button becomes dimmed, the Default Web 
Site is started, and you can access the sites.

➤ To change a site to an application

Do not use this procedure 
unless you received a “Server 
Error in “/” Application” error 
when you opened the site.

� On the Maximizer IIS Server, select Start > Programs > Control 
Panel > Administrative Tools > Internet Information 
Services Manager.

� Open the Default Web Site branch.

�

�
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� Right-click MaximizerWebAccess, and click Properties.

� Click Create.

Maximizer Web Access has now been converted to an 
application.

� Click OK and then close Internet Information Services.

�

�

�
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Escona Tutorial Maximizer Web Access Administrator

➤ To access Escona Tutorial Maximizer Web Access 
Administrator

� Select Start > Programs > Maximizer CRM > Web Access > 
Maximizer Web Access Administrator.

You can access Maximizer 
Web Access Administrator 
from Maximizer Web Access. 
In the left navigation pane, 
hover your mouse over 
Administration and select 
Administrator from the pop-up 
window.

The Maximizer Web Access Administrator login page opens.

� Log into the site using the following login information:

User ID = MASTER

Password = control
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Escona Tutorial Maximizer Web Access

➤ To access Escona Tutorial Maximizer Web Access

� Select Start > Programs > Maximizer CRM > Web Access > 
Maximizer Web Access.

The Maximizer Web Access login page opens.

If the Maximizer Web Access 
login page does not open, and 
you see a “Server Error in “/” 
Application” error message, 
then you need to change the 
site to an application. See “To 
change a site to an 
application” on page 191.

� Log into the site using the following login information:

User ID = JNAPOLI

Password = maximizer

Escona Tutorial Mobile Access

➤ To access Escona Tutorial Mobile Access

� On your mobile device, open a web browser.

� In the Address bar, enter the Mobile Access URL.

The default, the URL is in the form: http://<server name>/
MaximizerMobileAccess

� Log into the site using the following login information:

User ID = JNAPOLI

Password = maximizer
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Escona Tutorial Customer and Partner Access Administrator

➤ To access Escona Tutorial Customer or Partner 
Access Administrator

� On the server, select Start > Programs > Maximizer CRM > 
Web Access > Customer Access or Partner Access. 

The Maximizer Customer or Partner Access Viewer opens.

� Select Escona Tutorial, and click View.

The Customer/Access Partner Administrator login page opens.

� Log into Customer/Partner Access Administrator:

User ID = JNAPOLI

Password = maximizer

Customer/Partner Access Administrator opens, with either or 
both of the News Manager and Configuration Manager links 
available, depending on which web access security groups you 
belong to. 

The News Manager link is 
available only if you are logged 
in with a User ID belonging to 
the Customer or Partner 
Access Administration Users 
security group. The 
Configuration Manager link is 
available only if you are logged 
in with a User ID belonging to 
the Customer or Partner 
Access Configuration Users 
security group.

For information about web access security groups, refer to “Web 
Access Security Groups” on page 209.

➤ To create a site PIN for the sample sites

• Refer to “Assigning Site Login PINs to Contacts and Individuals” 
on page 225 for an explanation of how to create a site PIN for 
yourself. When you are creating the PIN for the Escona Tutorial 
sample sites, modify the email address and category of one of 
the Address Book entries, so you can use that Individual or 
Contact as your site user account:

• Email Address: When you are creating a customer and/or 
Partner Access login account for the Escona Tutorial sample 
sites, enter your own email address into a sample Contact or 
Individual’s Address Book entry. Then, when you send a site 
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PIN email, it sends the PIN to your email address instead of to 
the fictional email address in the sample database. 

• Category: Select both the Customer and Partner categories 
in the Address Book entry.

Escona Tutorial Customer and Partner Access

➤ To access Escona Tutorial Customer or Partner 
Access

� Select Start > Programs > Maximizer CRM > Web Access > 
Customer Access or Partner Access. 

The Maximizer Customer or Partner Access Viewer opens.

� Select Escona Tutorial, and click View.

The login page opens.

� Click the View Customer/Partner Access Site link.

� Log in to the site.

To log into the sample Partner Access site, use the sample 
Address Book contact, Paul Samson of Samson Consulting:

• User ID = paul

• Password = password

To log into the sample Customer Access site, use the sample 
Address Book contact, Mary Smart of Acme Tool Co.:

• User ID = mary

• Password = password

Customer or Partner Access opens.
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Application Settings for Web Access Sites 
The XML-formatted Web.config file, stored in the ...\Program 
Files\Maximizer\Portals\<site> folder, is the key to configuring the 
sites and any other ASP.NET web application.

You can edit this file using Windows Notepad or another text editor. 
For Windows 2008 Server or later, you can also edit the settings in 
Internet Information Services (IIS) Manager on the ASP.NET tab of 
the site’s properties. 

The settings that control the Outlook integration options for Web 
Access are located in a Web.config file in the services folder 
(...\Program Files\Maximizer\Portals\Employee\Services\). The only 
settings that apply to the Web Access Outlook integration are the 
maximum request length and timeout settings in the “httpRuntime” 
element.

The Partner Access and Customer Access sites are configured to 
connect to a single Address Book each. Which Address Book the site 
connects to is defined in a file called Web.config, which is located in 
the root folder of the Partner and Customer folders (which are 
located in ...\Program Files\Maximizer\Portals\). Initially, the 
Web.config file is configured to connect to the Escona Tutorial 
sample Address Book. Before you deploy Partner Access or Customer 
Access, you must update the Web.config file for your Address Book. 

After you have deployed Maximizer Web Access, Mobile Access, 
Customer Access, or Partner Access for your Address Book, you can 
make further changes to the Web.config file at any time. You are not 
required to restart the IIS service for changes to take effect.

➤ To configure the external site application settings 

� Browse to the Web Access folder where you have installed 
Maximizer Components for Microsoft IIS (...\Program 
Files\Maximizer\Portals\<site>\).

� Open the Web.config file in the Employee, Customer, Partner, or 
Wireless folder. Note that the following application settings do 
not apply to all web access sites.
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Site Application Settings <appSettings>

It is optional to change these 
application settings with the 
exception of the Enabled 
setting. This value must be set 
to true in order make the site 
accessible.

You can update any of the site application settings values if they 
appear under the appSettings parent node. The settings that appear 
in the Web.config file are dependent on the Web Access application 
that it is associated with.

Child Description

<add key="AddressBook" 
value="name" />

The name is the true name of the 
Address Book. See ‘AddressBook” 
on page 203.

<add key= 
”AddressBookColumnSetup” 
value=”user/Address Book 
window column setup name” />

Specifies a specific column setup 
to be used for the Address Book 
page in Mobile Access.
Only the first two columns of a 
column setup can be displayed 
(from left to right). The user 
specified in this setting is the 
creator of the column setup. This 
setting is optional. 

<add key=“AlarmCheckPeriod_
Seconds” value=“x”>

The site will check for alarms every 
x seconds.

<add 
key=“EmailAttachmentLimitSize
InKB” value=“x”>

Sets the largest allowable email 
attachment size to be x KiloBytes.
Note that if you increase this limit, 
you must also increase the 
“maxRequestLength” setting on 
the “httpRuntime” element by a 
corresponding amount.

<add 
key=“MaxFileUploadLimitSizeIn
KB” value=“x”>

Sets the largest allowable 
document size that can be 
uploaded in the Documents 
following tab and Company 
Library to be x KiloBytes.
Note that if you increase this limit, 
you must also increase the 
“maxRequestLength” setting on 
the “httpRuntime” element by a 
corresponding amount.

<add 
key=“MaxNumberOfFilesUpload
” value=“x”>

Sets the maximum number of files 
that can be uploaded at one time 
in the Documents following tab.
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<add 
key=”AllowUnsupportedBrowse
rsWithWarning” value=”True”>

This setting allows users to log in 
to Maximizer Web Access with 
unsupported web browsers, such 
as Apple Safari. Users are 
prompted with a warning 
message when they first log in to 
Maximizer Web Access with 
unsupported browsers. You can 
change the value to “False” to 
block users from accessing 
Maximizer Web Access with 
unsupported web browsers.
Note that Maximizer Software 
recommends that users access 
Maximizer Web Access only with 
supported web browsers. You can 
access the current list of 
supported browsers on our 
website.

<add key= 
“AlternateRequiredCategory” 
value=“”>

By default, to access Partner 
Access or Customer Access, an 
entry must have a category of 
Partner or Customer, respectively. 
This setting specifies an 
alternative category. See 
‘AlternateRequiredCategory” on 
page 203

<add key=“Context” 
value=”MA_PARTNER”>

The only difference between the 
default Partner Access site and the 
default Customer Access site is the 
value in the Context key. See 
‘Context” on page 202.

<add key= 
"CSCaseColumnSetup" 
value="user/Customer Service 
window column setup name" />

Specifies a specific column setup 
to be used for customer service 
cases. Only the first two columns 
of a column setup can be 
displayed (from left to right). The 
user specified in this setting is the 
creator of the column setup. This 
setting is optional.

<add key= 
“DefaultAddressBook” 
value=“name” />

The name is the true Address Book 
name, rather than the “friendly” 
name, meaning it does not 
contain spaces or special 
characters.

Child Description
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<add key=”Enabled” 
value=“true”>

By default, sites are disabled, and 
you must change the Enabled 
setting to “true” before you can 
use the sites. 
Setting Enabled to “false” 
instantly stops new visitors to the 
site from being allowed to log in, 
while allowing already-logged-in 
visitors to continue with their 
session.

<add key= 
"EnableDBMgrInLogin" 
value="1"/>

By default, users can create new 
Address Books directly from the 
Maximizer Web Access 
Administrator Log In page.
Change the value to “0” to disable 
this feature.
This setting applies only to 
Maximizer Web Access 
Administrator.

<add key= 
"EnableOutlookIntegration" 
value="true" /> 

The value must be set to true to 
enable Microsoft Outlook 
integration with Maximizer Web 
Access. Note that this integration 
applies to Outlook 2003 and 
higher.
See ‘EnableWordIntegration/
EnableOutlookIntegration” on 
page 203

<add key= 
"EnableRecordLocking" 
value="true" /> 

Enables record locking for Address 
Book entries in Maximizer Web 
Access to prevent two or more 
people from modifying an entry 
at the same time. Change the 
value to “false” to disable record 
locking.

<add key= 
"EnableWordIntegration" 
value="true" /> 

The value must be set to true to 
enable Microsoft Word 
integration with Maximizer Web 
Access. Note that this integration 
applies to Word 2003 and higher. 
See ‘EnableWordIntegration/
EnableOutlookIntegration” on 
page 203

Child Description
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<add 
key=”JavaMaxRecToRetrieve” 
value=”200”>

The maximum number of records 
(Address Book entries, 
opportunities, customer service 
cases, notes, or documents) to 
retrieve in a list in Mobile Access.
The default value is 200, but you 
can change this setting to display 
more or fewer entries in a list.

<add 
key="MaximizerMobileRedirect
URL" value=""/>

Redirects mobile device users to 
the specified URL.

<add key="MobileUserAgent" 
value=""/>

Lists the HTTP user agent values 
for mobile web browsers. Users 
who visit the site from these web 
browsers are automatically 
redirected to the Mobile Access 
URL specified in the 
MaximizerMobileRedirectURL key.

<add key= 
NotificationCheckPeriod_ 
Seconds” value=“x”>

The site will check for 
notifications every x seconds.

<add key= 
“OpportunityColumnSetup” 
value=”user/Opportunity 
window column setup name” />

Specifies a specific column setup 
to be used for Opportunities in 
Mobile Access.
Only the first two columns of a 
column setup can be displayed 
(from left to right). The user 
specified in this setting is the 
creator of the column setup. This 
setting is optional.

<add key= 
”ShowAllPhoneNumberAndEma
il”value=”false” />

This setting can be set to true and 
it is an optional setting. All phone 
numbers and email addresses are 
displayed in the appointment 
dialog box if this is set to true.

<add key=“SubContext” value= 
“name”>

The SubContext key is provided to 
implement more than one of a 
certain type (context) of site. See 
‘SubContext” on page 202.

Child Description
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Context

The only difference between the default Partner Access site and the 
default Customer Access site is the value in the Context key. The two 
possible values for this key are MA_PARTNER and MA_CUSTOMER. 
This key determines the following settings:

• The default graphic for the main login page can be replaced 
with a custom graphic. For more information, see “Customizing 
the Graphic on the Site Main Page” on page 228. 

• The groups controlling access to the administration-side of the 
sites (Customer Access Administration Users / Partner Access 
Administration Users and Customer Access Configuration Users / 
Partner Access Configuration Users)

• The default name of the site —“Partner Access” and “Customer 
Access”. These names can be overridden with the Name setting 
under General Settings in the Configuration Manager.

• The default name of the type of user accessing the site. For 
example, when logged into Partner Access, Paul Samson could 
expect to see “Partner: Paul Samson” at the top of the screen. 
This name may be overridden with the Name setting under 
General Settings in the Configuration Manager.

SubContext

The SubContext key is provided to implement more than one of a 
certain type (context) of site. Application settings within an external 
site’s Configuration Manager are stored in the Address Book (in the 
ADMN_Config table) referencing the site’s Context and SubContext 
keys.

<add 
key="DaysToStartDisplayMainte
nanceExpire" value="45" />

Displays a reminder message on 
the Web Access login page about 
upcoming maintenance contract 
expiry the specified number of 
days prior to the maintenance 
expiry date. By default, this 
message is displayed 45 days prior 
to maintenance contract expiry.

<add 
key="URLtoRenewMaintenance
" value="https://
www.maximizer.com/url/
maxcrm/
maxcrm_maintenanceexpiry.ht
ml" />

The URL to use in the renewal link 
that is displayed in the 
maintenance expiry reminder 
message on the Web Access login 
page.

Child Description
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If you would like two Customer Access sites, each with their own 
application settings, you would give both instances a Context value 
of MA_CUSTOMER, but make sure each instance has a different 
value for SubContext. For example, give one a value of WINE and 
one a value of BEER if you were in the business of selling both 
products but wanted a different site for each customer base.

If, however, you were setting up the application across two servers in 
a load-balancing scenario, you would give each version of the 
application the same value for SubContext because you’d want 
each instance to share one set of application settings.

AddressBook

The AddressBook key must be set with the database name of the 
Address Book to use for this site. Note that this is not the friendly 
name for the Address Book set in Administrator to reference the 
Address Book but the actual SQL database name. It makes a specific 
Address Book accessible for customers and partners and it must be 
set to enable the sites for access. 

AlternateRequiredCategory

In Maximizer CRM, membership in a segment of the Address Book is 
specified using an Address Book entry’s Category field. By default, 
Partner Access requires accessing visitors to have a Category of 
Partner, and Customer Access requires accessing visitors to have a 
Category of Customer. These defaults may be overwritten, however, 
by setting a different value in the AlternateRequiredCategory key. 
The company implementing Beer Customer Access and Wine 
Customer Access would add items for each site to the Category field 
in Maximizer, and then reference the required item’s name in the 
AlternateRequiredCategory key for each site.

EnableWordIntegration/EnableOutlookIntegration

If the Word or Outlook integration is enabled, users can set up the 
integration directly from Maximizer Web Access. The setup involves 
downloading Active X controls, which may be disallowed on some 
networks. To disable Word or Outlook integration, change the value 
to “false”.
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Session State Storage Options <sessionState>

By default, the web access sites are configured to store session 
identifiers in a cookie and to use a timeout value of 20 minutes. 
Maximizer ships Mobile Access, Customer Access, and Partner Access 
with a sessionState element containing default values. You can 
modify the value of the “timeout” attribute to set a different 
timeout value, in minutes, for the site.

Maximum Request Length and Timeout Options <httpRuntime>

The maximum request length and timeout options on the 
“httpRuntime” element control the maximum size and duration of 
requests that will be accepted by the IIS server. These settings take 
precedence over any application settings related to upload file sizes, 
and must be increased by a corresponding amount when increasing 
the value of other settings like the maximum email attachment size, 
for example.

Option Description

maxRequestLength The value following 
maxRequestLength is the size, in 
kilobytes, of the largest email 
(including the size of all 
attachments) that can be saved. It 
is advisable to set this number to 
twice the desired maximum size, 
since temporary encoding can 
require a larger request size. For 
example, if your email system 
allows attachments up to 20 MB in 
size, set maxRequestLength to 
"40000" to allow the largest 
emails to be saved.

executionTimeout The value following 
executionTimeout is the maximum 
number of seconds a request to 
save an email is allowed to take 
before an error occurs. The 
default is 10 minutes (600 
seconds).
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Setting Up Windows Authentication for Web Access
In addition to specifying Windows Authentication as the means of 
user authentication during the installation, you must follow 
additional steps to set up Windows Authentication for web access.

The following sections contain information on setting up Windows 
Authentication for web access sites:

• “Setting Up Windows Authentication for Web Access in SQL” on 
page 205

• “Configuring the Web.config files for Windows Authentication 
for Web Access” on page 205

• “Downloading Documents” on page 207

• “Configuring IIS for Windows Authentication for Web Access” 
on page 207

• ‘Windows Authentication for Partner Access, Customer Access, 
and Campaign Statistics” on page 207

Setting Up Windows Authentication for Web Access in SQL

➤ To set up Windows Authentication for Web Access 
in SQL

� In SQL Server Management Studio, on the Security tab of the 
SQL server properties, select Windows Only as the type of 
authentication. 

� Set the USE_NT_AUTHENTICATION key to YES in the MaConfig 
table for each Address Book.

Configuring the Web.config files for Windows Authentication for Web Access

To enable certain functionality 
in Maximizer Web Access and 
Maximizer Web Access 
Administrator such as the 
Auditing tab and System Audit 
Report, you must  set up 
Maximizer.Web.Data for 
Windows Authentication.

You must configure the Web.config file in the web access sites to use 
Windows Authentication. The procedure is different depending on 
which web access site you are configuring.

➤ To configure the Maximizer Web Access, Maximizer 
Web Access Administrator, Maximizer.Web.Data, or 
Mobile Access Web.config file for Windows 
Authentication

• Set the authentication setting to true as follows:

<authentication mode="Windows"/> <identity 
impersonate="true"> 
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➤ To configure the Microsoft Outlook Integration 
Synchronization Service Web.config file for 
Windows Authentication

� Comment-out the default anonymous authentication service 
binding as follows:

<!-- Anonymous authenticaton - HTTP - default 

<basicHttpBinding>

  <binding>

    <security mode="None"/>

  </binding>

</basicHttpBinding>

-->

� Un-comment the service binding that is appropriate for your 
environment. For example, to enable integrated Windows 
Authentication over HTTP, un-comment the following section:

<!-- Windows authentication - HTTP -->

<basicHttpBinding>

  <binding>

    <security mode="TransportCredentialOnly">

      <transport clientCredentialType="Windows" />

    </security>

  </binding>

</basicHttpBinding>

The file contains comments to help you identify the correct 
binding that is appropriate for your environment. Note that only 
one binding may be enabled at a time.

The Web.config file for the Microsoft Outlook Integration 
Synchronization Service is located in the following sub-folder of 
the Maximizer Web Access application folder:

Services\OutlookSync 

➤ To configure the Customer Access, Partner Access, 
or Campaign Statistics Web.config file for Windows 
Authentication

� Set the authentication setting to true as follows:

<identity impersonate="true"> 

� Append the authentication setting with the IUSR machine name 
and password as follows:
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<identity impersonate="true" 
userName="IUSR_MachineName" 
password="IUSR_password"> 

The username and password are for a user to run under the 
external site login. This user needs SQL permission equal to 
WEBUSER, and file permissions equal to NETWORK SERVICE. File 
permissions apply to the portal (web access site) folder, and to 
the following folder:

C:\WINDOWS\Microsoft.Net\Framework\v4.0.30319\Temporary 
ASP.NET Files.

Downloading Documents

To allow users to download documents, users must be able to access 
the Microsoft Internet Information Services (IIS) metabase and other 
directories used by ASP.NET.

➤ To set up access the IIS metabase and other 
directories used by ASP.NET. 

� Create a group on the IIS machine.

� Add the domain users or domain groups to the group on the IIS 
machine.

� Run the following command in the command line. The command 
is located in the 
c:\Windows\Microsoft.NET\Framework\v4.0.30319\ folder. 
Replace group_name with the name of the group you created.

aspnet_regiis -ga “group_name”

Configuring IIS for Windows Authentication for Web Access

The procedure for configuring Microsoft Internet Information 
Services (IIS) for Windows Authentication is different depending on 
the version of Windows Server you are using. For detailed 
information on configuring Microsoft IIS for Windows 
Authentication, see “Microsoft IIS for Windows Authentication” on 
page 29.

Windows Authentication for Partner Access, Customer Access, and Campaign 
Statistics

In some scenarios, you must complete an additional step to configure 
Partner Access, Customer Access, and Campaign Statistics for 
Windows Authentication. The IUSR_MACHINENAME user on the 
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Microsoft Internet Information Services (IIS) server must be 
duplicated on the SQL Server. The user must have the same username 
and password on both computers. This step is necessary only if your 
SQL Server is on a different computer than your IIS server and 
Delegation is not set up between IIS and SQL Server.
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Web Access Users and Security Groups
The following sections describe how to configure users in Maximizer 
to access web access sites:

• “Web Access Security Groups” on page 209

• “Web Access Users” on page 212

Web Access Security Groups

Every Address Book contains several web-access-related security 
groups, which are described in the following table. The MASTER user 
belongs to these groups by default, but you can add additional users 
to each group as required.

The Company Announcements 
Authors security group does 
not apply to sites.

Every security group has a name and an ID. Changing the name has 
no effect on the group functionality. However, you cannot change 
the group ID. If you ever need to recreate these security groups, it is 
imperative that you use the correct security group IDs (the group 
name is irrelevant).

To be able to access Customer or Partner Access Administrator, a user 
must belong to at least one of the Administration Users or 
Configuration Users security groups for that site. 

Security Group Name Group ID
Enables group members to 
access the...

Customer Access Admin 
Users

C_ADM News Manager section of 
Customer Access 
Administrator

Customer Access Config 
Users

C_CFG Configuration Manager 
section of Customer Access 
Administrator

Maximizer Web Access 
Admin Users

EMPADM Edit section of Maximizer 
Web Access, where the user 
can update external links

Partner Access Admin 
Users

P_ADM News Manager section of 
Partner Access 
Administrator

Partner Access Config 
Users

P_CFG Configuration Manager 
section of Partner Access 
Administrator
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➤ To add a user to a site security group

� In Administrator, select File > Security Groups and Teams.

� Select the security group, and click Properties.

� Set the appropriate Access Settings for the group members.

� Click the Members tab.
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� Select a member to add to the group, and click Add. Repeat this 
process for all members to add to the group.

– or –

Click Add All to add all users to the group.

� Click OK to close dialog boxes.

� Repeat this procedure to add users to the other site security 
groups.

The selected users can now log into the site and access the 
functions available to their security group(s).
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Web Access Users

Address Book users are enabled to access the web access sites by 
default. However, you can change user access to sites in the user’s 
general properties if required. The “Web Access” access right in User 
Properties applies to all sites.

➤ To set web access rights

� In Administrator, select File > Manage Users.

� Select the Maximizer user, and click Properties. 

� In the Module Login section (bottom right), select Web 
Access.

� From the drop-down list, select Enabled or Disabled. 
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Maximizer Web Access
Maximizer Web Access is functional automatically for all Address 
Books. Anybody with a user account for that Address Book can access 
it immediately, provided that the IIS Server is running and the “Web 
Access Login” right has not been disabled in the user’s account. (For 
more information about the “Web Access Login” right, refer to 
“Web Access Users” on page 212.)

Maximizer Web Access 
settings follow the Maximizer 
Address Book settings in 
Administrator.

On the IIS Server, you can access the sites from the Windows Start 
menu (Start > Programs > Maximizer CRM > Web Access). Other 
computers can access Maximizer Web Access with the following URL 
(unless it has been changed from the default):

http://<IIS_Server_Name>/MaximizerWebAccess/Default.aspx

The following sections contain information specific to Maximizer 
Web Access:

• “Creating External Links in Maximizer Web Access” on page 213

• “Passing a Search String Parameter to the Login Page” on 
page 214

• “ActiveX Controls in Maximizer Web Access” on page 215 

Creating External Links in Maximizer Web Access

To customize external links available on Maximizer Web Access, you 
must log into the site as the MASTER user, or as a user who belongs 
to the Maximizer Web Access Administration Users security group. 
(For information on this security group and how to add users to it, 
refer to “Web Access Security Groups” on page 209.)

➤ To create external links on Maximizer Web Access

� Log into Maximizer Web Access as MASTER or as a user who 
belongs to the Maximizer Web Access Admin Users security 
group.

� In the left navigation pane, hover your mouse over Links, and 
select Edit from the pop-up window.
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In Maximizer Web Access, an 
external link must be a URL.

� Add, edit, or remove any groups or links as desired.

� Click Close to finish.

The External Links section of the Maximizer Web Access main 
page now reflect the changes you just made.

Passing a Search String Parameter to the Login Page

You can pass a search string parameter to the login page to display a 
search after logging in to Maximizer Web Access. The Address Book 
page is opened directly after successfully logging in—the My Work 
Day page and the Choose Address Book List dialog box is bypassed. 

➤ To add a search string parameter to the Login Page

Append the Maximizer Web Access URL with the search string 
parameter. Note that the search string must be URL encoded. 
Following are some examples of the search string that you can use in 
the URL:

• To retrieve a Favorite List from the Address Book

http://[server name]/MaximizerWebAccess/
default.aspx?ss=FLIST%28[Favorite list key]%29

e.g., http://[server name]/MaximizerWebAccess/
default.aspx?ss=FLIST%288cFOcdn15sZIuP9HO7lucIrMRGl892Gp
%29 

The above search retrieves the “All entries in Escona” Favorite 
List in the Escona Tutorial Address Book.

• To retrieve a particular company and its associated 
contacts from the Address Book
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http://[server name]/MaximizerWebAccess/
default.aspx?ss=EQ%28ClientID%2c[Identification]%29

Note that the [Identification] can be found in Properties of the 
ABEntry > Identification.

e.g. http://[server name]/
MaximizerWebAccess?ss=EQ%28ClientID%2c37266200083%29

A simple way to build your search string is by copying the search 
source code from Maximizer Web Access directly following a search 
performed in the Address Book page. 

➤ To use source code from Maximizer Web Access

� Perform a search in Maximizer Web Access.

� Immediately following the search, right-click in Internet 
Explorer, and choose View Source.

� Copy the first line of source code shown at the top of the 
window prefixed by http://[server name]/
MaximizerWebAccess?ss= as shown above in the examples. 

For more information on Maximizer search string language, refer to 
“Search String Language” on page 390.

ActiveX Controls in Maximizer Web Access

Maximizer Web Access uses an ActiveX control for its integrations 
with Microsoft Office products, including Microsoft Word, Microsoft 
Excel, and Microsoft Outlook. These integrations are supported only 
in Microsoft Internet Explorer.

If your web server configuration includes a firewall, you may need to 
configure the firewall to allow the MaThinIEActiveX.ocx file to be 
downloaded from the server. The MaThinIEActiveX.ocx file is an 
ActiveX control used to run the Export to Excel command and to 
install the Word and Outlook integrations in Maximizer Web Access.
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Maximizer Web Access Administrator
For login information, go to 

“Escona Tutorial Maximizer 
Web Access Administrator” on 
page 208.

Use Maximizer Web Access Administrator for the following tasks: 

• Create and configure Address Books

• Manage users, sales/marketing teams, and security groups

• Manage Maximizer application settings

You can access Maximizer Web Access Administrator from Maximizer 
Web Access. You can also enter the Maximizer Web Access 
Administrator URL directly in a web browser. Only administrators can 
log in to Maximizer Web Access Administrator.

➤ To log in to Maximizer Web Access Administrator

� Enter the Maximizer Web Access URL in a web browser:

By default, the URL is in the form: [server]/
MaximizerAdministrator.

– or –

From Maximizer Web Access, in the left pane, hover your mouse 
over Administration, and select Administrator from the pop-up.

� If necessary, select the Address Book, enter the User ID and 
password of an administrator, and click Log In.

If you are access Maximizer Web Access Administrator from 
Maximizer Web Access, you are automatically logged in to the 
Address Book.
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Mobile Access
As with the other sites, Mobile Access is installed automatically when 
you select the Maximizer Components for IIS option in the Server 
Components screen of the Maximizer installation. You must then 
enable the site as described in “Enabling Web Access Sites” on 
page 189. To access the site, enter the Mobile Access URL into your 
browser. By default, the Mobile Access URL is in the following form:

<Server Name>/MaximizerMobileAccess

e.g., http://mobile.maximizer.com/MaximizerMobileAccess

The following sections contain information specific to Mobile Access:

• “Supported Browsers for Mobile Access” on page 217

• “Configuring Automatic Redirection to Mobile Access” on 
page 217

• “Limiting the Number of Entries Displayed in Mobile Access” on 
page 218

• “Specifying the Mobile Access URL for Integration” on page 219

Supported Browsers for Mobile Access

The following web browsers are compatible with Mobile Access:

• BlackBerry web browser

• Apple Safari

• Android web browser

Visit Maximizer’s website at www.maximizer.com for the most up to 
date list of supported browsers.

To use the full functionality in Mobile Access, users may need to 
configure their browsers in the following ways:

• Enable JavaScript.

• Enable browser cookies.

Configuring Automatic Redirection to Mobile Access

You can set up automatic redirection from Maximizer Web Access to 
Mobile Access. When users access Maximizer Web Access from a 
mobile web browser associated with a specified mobile user agent, 
they are redirected to the Mobile Access URL.
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➤ To configure automatic redirection for mobile users

� Open the web.config file for Maximizer Web Access.

The file is stored in the following folder: 

...\Program Files\Maximizer\Portals\Employee

� In the <appSettings> section, locate the 
MaximizerMobileRedirectURL key.

� Next to value, enter the Mobile Access URL between the 
quotation marks.

� Locate the MobileUserAgent key.

� If necessary, next to value, modify the list of user agents that are 
redirected to Mobile Access.

The major mobile browsers are included in the list by default.

� Save the changes to the web.config file.

Limiting the Number of Entries Displayed in Mobile Access

In the Mobile Access web.config file, you can specify the maximum 
number of entries retrieved in lists. The default value is 200, but you 
can change this setting to display more or fewer entries in a list. The 
setting affects lists of Address Book entries, opportunities, customer 
service cases, notes, and documents.

➤ To change the maximum number of entries 
displayed in lists

� Open the Mobile Access web.config file.

The file is stored in the following folder: 

...\Program Files\Maximizer\Portals\Wireless

� In the <appSettings> section, locate the 
JavaMaxRecToRetrieve key.

� Next to value, enter the maximum number of entries between 
the quotation marks.

� Save the changes to the web.config file.
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Specifying the Mobile Access URL for Integration

You can specify the Mobile Access URL in Administrator to ensure the 
site is available for integration with other programs. As well, 
Maximizer users can access the Mobile Access URL from the Start 
menu.

You must specify the URL in every Address Book that uses Mobile 
Access.

Note that in previous versions of Maximizer, Mobile Access was 
named Wireless Access. The default name of the Mobile Access 
virtual directory and the default URL have also changed. If you are 
upgrading from a previous version of Maximizer and you keep the 
default virtual directory, you should update the Mobile Access URL 
specified in Administrator.

➤ To specify the Mobile Access URL in Administrator

� Open Administrator and log in to the Address Book.

� Select File > Web Access.

� Next to Mobile Access URL, enter the URL.

By default the URL is in the form http://[server]/
MaximizerMobileAccess.

� Click OK.

� If necessary, repeat this procedure for any other Address Books 
that use Mobile Access.
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Customer Access and Partner Access
Unlike Maximizer Web Access, you must enable Customer Access and 
Partner Access yourself. 

➤ To enable and configure Customer Access or Partner 
Access

� Add administrators to the appropriate Security Groups in 
Administrator, as described in “Adding Users to Site Security 
Groups” on page 221.

� Ensure the Web Access Login right is enabled for any users 
who will access the site. (This right is enabled by default. For 
further information, refer to “Web Access Users” on page 212.)

� Customize the Web.config file for the site, as described in 
“Application Settings for Web Access Sites” on page 197.

� Customize the graphic on the main site page. Typically, you 
would replace it with your company’s logo. For instructions on 
changing this graphic, refer to “Customizing the Graphic on the 
Site Main Page” on page 228.

� Assign a URL to the site, as described in “Determining External 
Site URLs” on page 221.

� Enable any site configuration options as desired, as described 
in “Configuring Site Options” on page 223.

� Assign Contacts and/or Individuals the status of Customer or 
Partner in the Category field as part of the entry’s basic 
information, as described in “Setting Up Business Partners and 
Customers” on page 224.

	 Give business partners and customers access using the External 
Site PIN merge field, as described in “Assigning Site Login PINs 
to Contacts and Individuals” on page 225.

Introduction to Customer and Partner Access Administrator

Consisting of both the News Manager and the Configuration 
Manager, Customer/Partner Access Administrator is part of each 
instance of a Partner or Customer Access site and provides a way for 
administrators to complete the following tasks:

• turn site sections on and off

• specify the properties of generated emails

• specify the name of the site
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• add and modify news items

The options available in Customer and Partner Access are primarily 
the same.

The main page of Customer/Partner Access Administrator contains 
one or both of the following links, depending on which site security 
groups you belong to:

• News Manager – This link is available if you are a member of 
the Customer Access Administration Users or Partner Access 
Administration Users security group for the selected site type.

• Configuration Manager – This link is available if you are a 
member of the Customer Access Configuration Users or Partner 
Access Configuration Users security group for the selected site 
type.

You can also click the View Customer/Partner Access Site link in 
the upper-right corner of the screen to view the site itself, rather 
than the administrator.

For more specific information about Customer/Partner Access 
Administrator, open it and click Help.

Adding Users to Site Security Groups

The default configuration for Customer and Partner Access allows 
any Maximizer user to access Customer/Partner Access Administrator 
if they have rights to the section granted through Security Groups. 
Use the File > Security Groups and Teams dialog box in Administrator 
to control user access. Site security groups function in the same way 
as general Maximizer security groups. For more detailed information 
about site security groups, refer to “Web Access Security Groups” on 
page 209.

Determining External Site URLs

You must configure the 
external sites before these 
URLs are enabled for the 
Address Book as described in 
the previous section. 

Once you have configured the database and enabled both Partner 
Access and Customer Access for an Address Book, the sites are 
available for use through the URLs. Maximizer Web Access requires 
no additional configuration for use with an Address Book. 

The default URLs are listed below, although you can change them as 
necessary. To determine the URL for a site, substitute your IIS Server 
name for [YourServerName].

• Maximizer Web Access URL

http://[YourServerName]/MaximizerWebAccess/Default.aspx

• Customer Access URL

http://[YourServerName]/MaximizerCustomer/Default.aspx



Maximizer CRM
Administrator’s Guide

222

• Partner Access URL

http://[YourServerName]/MaximizerPartner/Default.aspx

• Customer Access Administrator

http://[YourServerName]/MaximizerCustomer/Admin/
Default.aspx

• Partner Access Administrator

http://[YourServerName]/MaximizerPartner/Admin/Default.aspx

Accessing Sites from the Start Menu

To access your sites through the Maximizer CRM program Start 
menu, enter your URLs in the Sites dialog box in Administrator.

➤ To set up access for the sites from the Windows 
Start menu

� In Administrator, select File > Web Access. 

� Enter the URLs for sites in the corresponding fields. 

For example, for Partner Access Administrator, you would enter 
the following in the Partner Access URL field:

http://[YourServerName]/MaximizerPartner/Admin.aspx

�
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Configuring Site Options

Use the Configuration Manager to set preferences for the sites such 
as Address Book, calendar of events, customer service, forgotten 
credentials recovery, general settings, help, knowledge base, leads, 
links, news, opportunities, personalization, and quick info. 

To access the Configuration Manager, you must be a member of the 
Customer or Partner Access Configuration Users security group. 
When you log into Customer/Partner Access Administrator, you will 
see a Configuration Manager link.

For information about each of the configuration options, open 
Customer/Partner Access Administrator and click Help.
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Setting Up Business Partners and Customers

Start Maximizer and create Address Book entries for all the business 
partners and customers who need to access the sites. Each customer 
and partner must be set up as follows:

• Be a Contact or Individual in Maximizer

• Have an assigned email address in Maximizer

• Have “Partner” and “Customer” as the assigned value in the 
Category field

• Have at least one entry in the Partner Interests or Customer 
Interests user-defined field if you would like only certain new 
items to appear by default

Set up a test account for yourself so you can log into the site as a 
business customer and partner and confirm that everything is 
working correctly. Do this by creating an Individual record with your 
name, email address, and the selected values of Customer and 
Partner for the Category field on the entry’s Details tab.

➤ To enable Address Book entries to access the site

� In the Address Book page, select the Address Book entry for the 
Contact or Individual for whom to create a site login account.

� Click the Edit icon in the Details tab to edit the entry.

� Ensure that the Contact or Individual’s correct email address is 
entered in the Email address field.

� Click the button beside the Category field.

� In the Category drop-down, select the checkbox beside either 
the Customer or Partner category.

If you select Customer, the Contact or Individual will be able to 
log into Customer Access. 

If you select Partner, the Contact or Individual will be able to log 
into Partner Access.

� Click Save.

� Repeat this procedure to enable any other Address Book entries 
to access the sites.

After you have completed this procedure, you must provide the 
customer or partner with a site PIN, which enables them to 
register and log into the site.
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Assigning Site Login PINs to Contacts and Individuals

You provide each business customer and partner with a PIN. The PIN 
works only once. Each customer or partner can set up only one web 
account. Site PINs and logins are shared for both Partner Access and 
Customer Access.

Login PINs are created by a Maximizer merge field called External 
Site PIN. The values of the External Site PIN merge field are 
generated when you do a merge to email or when you generate an 
automated activity for an automated campaign. 

➤ To send Site PINs by email

� Select the Address Book entry or entries for whom you want to 
generate a PIN.

� Select Actions > Write an Email.

– or –

Right-click and select Write an Email.

The Send Email dialog box opens.

You can generate PINs for a 
whole list of entries or just the 
current entry. 

� Choose how to use the current list, and click OK.

You can send the message to only the current entry, to all 
selected entries, or to all entries in the list.

� If you are sending the email message to multiple Address Book 
entries, choose the Separately option from the Send as drop-
down list.

You can include any content in 
the merge document such as 
the URL for the site.

� Enter a subject and the text of the email message.

You must include the External Site PIN merge field to send it to 
customers or partners, so they can create their login accounts.

� To save the email template for re-use later, click the Template 
icon in the editing toolbar and save the email as a template.

� Click Send.

An assigned PIN appears in each merged email that is sent.

➤ To activate a site login PIN through an automated 
campaign activity

For more information on 
creating automated campaign 
templates, refer to the 
Maximizer CRM User’s Guide 
and online help files. 

• When setting up your automated campaign template, use the 
External Site PIN merge field in one of the automated 
campaign activities. 
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➤ To open the main site for Partner Access or 
Customer Access

� Set up a site PIN for yourself and activate a login.

� Log into either Partner Access Administrator or Customer Access 
Administrator.

� Click the View Partner/Customer Access Site link to see the 
main web access sites.
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Activating a Login Account

The following procedure explains the steps for the business customer 
or partner to activate a login account with the provided PIN.

➤ To activate a login account

� Open Customer Access or Partner Access using the provided URL. 

See “Determining External Site 
URLs” on page 221 for more 
information on the site URLs. 

� At the Login screen, click the Register now link. 

The registration page opens.

� Enter your last name, email address, PIN, user ID, and password. 

The Customer or Partner Access page displays.

Removing Web Access

To block access to Customer or Partner Access for a business customer 
or partner who currently has access, start Maximizer, locate the 
Address Book entry, and remove the Customer or Partner value from 
the Category field.

Retrieving a Forgotten Password

For this feature to work, the 
Forgotten Credentials 
Recovery configuration must 
have been set up previously in 
Customer/Partner Access 
Administrator.

A customer or partner who forgets a password can use the 
“Forgotten Login Credentials” link to load a page that asks for an 
email address and last name or user ID. The customer or partner then 
receives the password by email.

Changing a Password

Partners or customers can change their password from inside the site 
any time they want (if you enable that feature through the 
Personalization link in Configuration Manager). All passwords are 
encrypted; your Maximizer users do not have access to passwords.
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Advanced Site Configurations
This section describes the following additional site customizations:

• “Customizing the Graphic on the Site Main Page” on page 228

• “The sections.xml File” on page 229

• “The followingWindowSets.xml File” on page 230

• “Displaying Custom System Messages” on page 231

• “Adding Custom Actions to the CustomActions.xml File” on 
page 233

• “Creating Custom Links to External Websites” on page 235

• “Specifying the Address Book on the Site Login Screen” on 
page 237

• “Globalization of Sites” on page 238

• “Configuring Multiple IIS Servers to Connect to a Single 
Maximizer CRM Server” on page 239

• “Moving a Site” on page 239

• “Installing Sites to Non-Default Folders” on page 239

• “Setting Up Multiple Customer or Partner Sites” on page 241

• “Creating a Custom Case Wizard for Partner Access” on page 246

Customizing the Graphic on the Site Main Page

With the exception of the 
contents of the 
\CustomGraphics folder, you 
should not modify application 
files, including graphics. 

You can replace the default graphic on the site main page with your 
own custom graphic. This procedure applies to all sites. 

➤ To customize the graphic on the site main page

� Create a graphic that is 280 pixels wide by 130 pixels in height 
and save it as LoginCorporate.gif.

� Copy the graphic file to the appropriate folder:

...\Program Files\Maximizer\Portals\<site>\CustomGraphics\
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The sections.xml File

The sections.xml file contains information on modules that are 
available to users in Maximizer Web Access and the other web access 
sites such as Partner Access. By editing the sections.xml file, you can 
add, disable, or change the default order that the modules appear.

The sections.xml file is located on the machine where the Maximizer 
Components for IIS are installed, at the following path:

\\Program Files\Maximizer\Portals\<site>\Config\sections.xml

Disabling Modules in Sites

You can disable specific modules in the web access sites. The 
sections.xml file determines what modules are displayed in the site.

The easiest way to disable a module is to comment out the shortcut 
element for that module in the sections.xml file. The shortcut 
element will remain in the file, but it will be enclosed between XML 
comment tags and ignored by Maximizer.

➤ To disable a module in a site

Always back up the 
sections.xml file before making 
any changes.

� Open the site’s sections.xml file in a text editor such as 
Notepad.

� Locate the shortcut element containing the module.

The name of the module, as it appears in Maximizer, is displayed 
between the title tags in the shortcut element.

�  Add an opening comment tag, <!--, before the shortcut opening 
tag, <shortcut>.

� Add a closing comment tag, --!>, after the shortcut closing tag, 
</shortcut>.

� Save the file.

The following example shows comment tags around the 
opportunities shortcut element. In this example, the opportunities 
module would be disabled on the site.

<!--

<shortcuts>

<id>opp</id>

<title>Opportunities</title>

<image>opportunity</image>

<module_id>0<module_id>

<url>/Content/Opportunities.aspx</url>
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<external>No</external>

<has_grid>Yes</has_grid>

</shortcuts>

-->

Changing the Order of Modules in the Icon Bar

In Maximizer Web Access, you can define the icons and the default 
order that they appear in the icon bar by modifying the sections.xml 
file. Users will only see the icons for the modules that they have the 
rights to view.

The easiest way of doing this is copying the module section of the 
module you want to move (the code surrounded by the <shortcut> 
tags) and pasting it between other module sections.

If the order of the icons has been changed by a user in the Icon Bar 
Properties dialog box (in Maximizer Web Access, from the top right 
corner, select preferences), the new order is saved in the 
ADMN_Config table where the TaskCode = the user’s ID and the 
KeyCode = IconBarButtonOrder. If modules are hidden in the Icon 
Bar Properties, references to the hidden modules are saved in the 
ADMN_Config table where the TaskCode = the user’s ID and the 
KeyCode = IconBarButtonHide. 

See “ADMN_Config Table (Address Book Configuration)” on 
page 364 for more information on the ADMN_Config table.

The followingWindowSets.xml File

The followingWindowSets.xml file contains information on 
following windows that are available to users in Maximizer Web 
Access and the other web access sites such as Partner Access. By 
editing the followingWindowSets.xml file, you can change the name 
(title) of a following window or disable a following window entirely.

The followingWindowSets.xml file is located on the computer where 
the Maximizer Components for IIS are installed, at the following 
path:

\\Maximizer\Portals\<site>\Config\followingWindowSets.xml

Renaming or Disabling Following Windows in Sites

You can rename or disable specific following windows in the web 
access sites. 
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➤ To rename or disable a following window

Always back up the 
followingWindowSets.xml file 
before making any changes.

� Open the site’s followingWindowSets.xml file in a text editor 
such as Notepad.

� Locate the following window element.

The name of the following window, as it appears in Maximizer, 
is displayed between the title tag.

�  Adjust the tags as necessary to rename or disable a following 
window, as follows:

<title> - contains the name of the following window

<url> - contains the ASPX file that is displayed when a user 
selects this following window

<visible> - the value of yes is specified to display the following 
window and the value no is specified to disable or hide the 
following window

� Save the file.

In the following example, the Contacts following window is renamed 
to People. 

    <tab id="contacts">

        <title>People</title>

        <url>fwContacts.aspx</url>

        <visible>Yes</visible>

    </tab>

Displaying Custom System Messages

You can create custom system messages that are broadcast to all 
Maximizer Web Access users. System messages display across the top 
of web access pages. They can include two lines of text and a 
hyperlink. The properties of a message are specified in the 
SystemMessages.xml file. The file specifies the content of the 
message, the appearance of the message, and the start and end date/
time that the message is displayed.

➤ To display a custom system message

� Open the site’s SystemMessages.xml file in a text editor such 
as Notepad.

The file is located on the Maximizer server at the following path:

C:\Program Files\Maximizer\Portals\Employee\Config\
SystemMessages.xml
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� Use the XML tags in the bottom part of the SystemMessages.xml 
file to specify the properties of the system message. The top part 
of the file explains the role of each set of tags. The bottom part 
of the file contains the actual tags that are used.

For descriptions and examples of each element, see “Elements in 
SystemMessages.xml File” and “Example SystemMessages.xml 
File” below.

� Between the Enabled tags, replace False with True. The line in 
the file should be <Enabled>True</Enabled>.

� Save the file.

Elements in SystemMessages.xml File

The SystemMessages.xml file contains one <SystemMessages> 
element, which in turn contains one <SystemMessage> element. This 
element determines the properties of the message.

The following table describes each of the sub-elements in the 
<SystemMessage> element.  

Element Description

<HeaderLine1> Bolded text at the beginning of the first line

<TextLine1> Plain text placed at the end of the first line.

<TextLine2> Plain text placed at the beginning of the second line.

<Hyperlink
Text>

Text for a hyperlink placed at the end of the second 
line.

<HyperlinkUrl> The URL for the hyperlink.

<Background
Color1>

The background color of the message.

<StartDate> The start date and time in the format yyyy-mm-dd 
hh:mm. If specified, the message is displayed only 
after this date and time.

<EndDate> The end date and time in the format yyyy-mm-dd 
hh:mm. If specified, the message is displayed only 
before this date and time.

<Enabled> True means the system message will display if at 
least one text element has a value and the current 
date/time is within the start and end date/time 
values.
False means the system message will not display 
regardless of the other elements.
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Example SystemMessages.xml File

The following example shows the content of the <SystemMessages> 
element:

<SystemMessages>

  <SystemMessage>

<HeaderLine1>Notice</HeaderLine1>

<TextLine1>Maintenance to phone lines</TextLine1>

<TextLine2>The phone lines will be out of service 
between 4:00 and 5:00 pm this evening.</TextLine2>

<HyperlinkText>More info.</HyperlinkText>

<HyperlinkUrl>http://Server/Maintenance</HyperlinkUrl>

<BackgroundColor1>Yellow</BackgroundColor1>

<StartDate>2011-11-10</StartDate>

<ExpiryDate>2011-11-10 17:30</ExpiryDate>

<Enabled>True</Enabled>

  </SystemMessage>

</SystemMessages>

The example displays a message alerting Maximizer Web Access users 
that phone lines are out of service. The message is displayed only on 
the specified day until 5:30 pm.

Adding Custom Actions to the CustomActions.xml File

The Address Book, Customer Service, and Opportunities pages, along 
with the Details tab in the Address Book following pane and the 
read-only Address Book dialog in Maximizer Web Access each 
contain an Actions menu, and you can add custom action commands 
to those menus. Clicking on a custom action in the menu will open a 
custom dialog box created by you, in which you can display 
information about the current record, selected records, or all records 
in the list. You can add as many custom actions as you want to the 
Actions menu.

To enable Maximizer Web Access to register and recognize your 
custom actions, you must add information to the CustomActions.xml 
file. The file identifes which custom actions are enabled and defines 
specifics about the dialog box. The file is located in the 
<portal_root>\Config\ folder.
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The file contains four sections, one for each page (Address Book, 
Campaigns, Customer Service, and Opportunities). Each section 
contains the following XML elements.

The following table describes each of the sub-elements in the 
<CustomAction> element. 

Example of the CustomActions.xml File

<?xml version="1.0" encoding="utf-8" ?> 

<!-- 

 ConfigActions.xml  

Element Tag Description

<id> Identifies which page the custom action is for (ab = Address Book, 
cam = Campaigns, cs = Customer Service, and opp = 
Opportunities). Do not change the value of this element.

<CustomAction> Defines what page should be called when a user clicks a the 
custom action in the Actions menu.

Element Tag Description

<ID> Unique ID of the menu command.
Can be any value, but must be unique within the <Page> element.

<Title> Menu command title as it will appear in the Actions menu.

<Url> Name of the file that will appear in the pop-up dialog box after 
the command is called by a user. This file must reside in 
<portal_root>\Dialogs\CustomDialogs\.

<MergeURL> Custom URL containing a merge field from Maximizer.

<Width> Width of the pop-up dialog box, in pixels.

<Height> Height of the pop-up dialog box, in pixels.

<DisabledIfNo
Records>

Defines whether the custom Action menu command will be 
disabled when there are no entries displayed in the grid on the 
page. Must have a Yes or No value.

<Resizable> Determines if the custom window can be resized. Must have a Yes 
or No value.

<Scrollable> Determines if the custom window can be scrolled. Must have a Yes 
or No value.

<ShowLocation> Determines if the custom action URL should be opened in a new 
browser window/tab or not. Must have a No or blank value. If the 
value is No, the URL will be opened in a pop-up window. If the 
value is blank, the URL will be opened in a separate browser 
window or tab.
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===================

This file manages custom actions.

Sample:

=======

<CustomAction>

<ID>CA_id</ID>  : Must be unique 

<Title>Custom Action...</Title>: As it will 
appear in the Actions menu 

<Url>c.aspx</Url>  : Must exist in 
<EmployeePortalRoot>\Dialogs\CustomDialogs\ folder 

<MergeUrl>No</MergeUrl> : Must be Yes or No

<Width>800</Width>  : Must be a number 
(width in pixels) 

<Height>200</Height> : Must be a number (height 
in pixels) 

<DisabledIfNoRecords>Yes</DisabledIfNoRecords>: 
Must be Yes or No

<Resizable>No</Resizable>: Must be Yes or No

<Scrollable>No</Scrollable>: Must be Yes or No

<ShowLocation>No</ShowLocation>: Must be No or 
blank

</CustomAction>

Creating Custom Links to External Websites

You can create custom links in the CustomActions.xml file to external 
websites that include merge fields from Maximizer. The custom URLs 
are then accessible from the Actions menu in Maximizer Web Access. 
This allows a user to link to a web page based on the contents of the 
current record. For example, you could include the “city” merge field 
as part of the external link URL and based on the city contained in 
the record, information related to the associated city would be 
shown in the web page.

Note the URLs must be encoded. Different types of encryption are 
supported for passing parameters to URLs. 

To create a custom link with a merge field, add the custom link 
information to the CustomActions.xml file. See the following 
example of a CustomActions.xml file for more information.

Example of an Integration with a Wikipedia Search

<CustomAction>

    <ID>CA_id</ID>  

    <Title> Wikipedia...</Title>
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<Url>http://en.wikipedia.org/wiki/
[EncodingStartSpaceAsUnderscore] [C.CompanyName]  
[EncodingEnd]</Url>  

<MergeUrl>yes</MergeUrl>

<Width>700</Width>  

<Height>400</Height>

<DisabledIfNoRecords>No</DisabledIfNoRecords>

<Resizable>Yes</Resizable>

<Scrollable>Yes</Scrollable>

</CustomAction>  

Example of an Integration with a Google Search

<CustomAction>

<ID>CA_id2</ID>  

<Title>Google Search...</Title>

<Url>http://www.google.ca/
search?q=[EncodingStartSpaceAsPlus][C.CompanyName][EncodingE
nd]</Url>

<MergeUrl>Yes</MergeUrl>

<Width>700</Width>

<Height>400</Height>

<DisabledIfNoRecords>No</DisabledIfNoRecords>

<Resizable>Yes</Resizable>

<Scrollable>Yes</Scrollable>

</CustomAction>

Example of an Integration with Google Maps

<CustomAction>

<ID>CA_id3</ID>

<Title>Google Map...</Title>

<Url>http://maps.google.ca/
maps?q=[EncodingStartSpaceAsPlus][C.AddressLine1]%2c[C.City]
%2c[C.StateProvince][EncodingEnd]</Url>

<MergeUrl>Yes</MergeUrl>

<Width>1100</Width>

<Height>800</Height>

<DisabledIfNoRecords>Yes</DisabledIfNoRecords>

<Resizable>Yes</Resizable>

<Scrollable>Yes</Scrollable>

</CustomAction>
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Specifying the Address Book on the Site Login Screen

There are several methods of controlling which Address Books are 
available through the login screens of Maximizer Web Access and 
Mobile Access: 

• Users enter the site URL, and the resulting login page displays a 
drop-down list of available Address Books

• Users enter the site URL, appended by the “ab” parameter, and 
the resulting login page displays the specified Address Book 
name as a static field

• You enter a value in the AddressBook key of the site’s 
Web.config file, and when users enter the site URL, the resulting 
login page displays the specified Address Book name as a static 
field

Displaying a Drop-down List of Available Address Books

You can provide access to any Address Book through Maximizer Web 
Access or Mobile Access. By default, when a user enters the site URL 
in a browser, the resulting login screen includes a drop-down list of 
available Address Books.

Specifying the Address Book in the URL

You can also specify the Address Book in the URL. By specifying the 
new parameter called “ab” in the URL, you can provide a direct 
shortcut to the Address Book in Maximizer Web Access or Mobile 
Access.

• Maximizer Web Access: http://SERVERNAME/
MaximizerWebAccess/default.aspx?ab=EsconaTutorial

• Mobile Access: http://SERVERNAME/MobileAccess/
default.aspx?ab=EsconaTutorial

The value of the ab parameter must be the Address Book’s SQL 
database name, not the user-definable Address Book name set in 
Administrator (File > Preferences > System Options tab).

Enabling Access to a Single Address Book Only

You can also restrict an instance of Maximizer Web Access or Mobile 
Access to be able to access a single Address Book only, rather than 
showing the Address Book drop-down list or specifying the Address 
Book in the URL. Specify the “AddressBook” property in the 
appSettings section of the site’s Web.config file, as shown in the 
following example:

<add key=”AddressBook” value=”EsconaTutorial” />
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The value of the AddressBook key must be the Address Book’s SQL 
database name, not the user-definable Address Book name set in 
Administrator (File > Preferences > System Options tab). 

If the value of the AddressBook key does not correspond to a valid 
Address Book, the login page displays the Address Book list.

Similarly, you can display a default Address Book. This is also 
specified in the appSettings section of the site’s Web.config file, as 
shown in the following example:

<add key=”DefaultAddressBook” value=”EsconaTutorial” />

Globalization of Sites

The Globalization element in the web.config file enables you to 
change the site’s regional display settings such as numbers and dates. 
The Globalization element is optional. If it or any of its attributes are 
not added to the Web.config file, US English is used by default.

In Maximizer Web Access, users can also choose a locale in the user 
preferences. The user’s locale setting takes precedence over the 
globalization element in the web.config file.

To change the globalization settings of a site, you must add the 
section below as a child to the system.web element

<globalization 

requestEncoding="utf-8" 

responseEncoding="utf-8"

culture="en-US"

uiCulture="en"

/>

The regional settings are defined in the culture and uiCulture 
attributes. To use display settings other than US English, replace the 
values of the culture and uiCulture attributes in the Globalization 
element. The following list includes some of the possible values:

Country, Language culture uiCulture

United States, English en-US en

Britain, English en-GB en

Canada, English en-CA en

France, French fr-FR fr

Canada, French fr-CA fr

Belgium, French fr-BE fr

Germany, German de-DE de

China, Chinese zh-CN zh
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The country codes are defined in the ISO 3166 standard, which is 
available at the following URL:

http://www.iso.org/iso/country_codes.htm

The concept of combining these country codes with language is 
defined in RFC 3066, which is available at the following URL:

http://www.faqs.org/rfcs/rfc3066.html

Configuring Multiple IIS Servers to Connect to a Single Maximizer CRM Server

You can use the procedure described below to configure multiple 
Address Books on multiple IIS servers to connect to a single 
Maximizer CRM server.

➤ To configure multiple IIS servers to connect to a 
single Maximizer CRM Server

� On each IIS server, install Maximizer Components for 
Microsoft IIS from the Maximizer CRM Server disc and during 
setup, select your Maximizer CRM Server machine.

� On each IIS server, change the AddressBook key of the 
Web.config file for Customer and Partner Access to point to the 
appropriate Address Book.

Moving a Site

Web access sites are ASP.NET web applications, which implies a level 
of portability. If you choose, you can rename the virtual folder 
holding the application and therefore its URL. You may even change 
the physical path of the application by copying the application 
someplace else on the IIS machine’s hard drive. When doing this, be 
sure to move the entire folder.

Installing Sites to Non-Default Folders

The Maximizer installation creates an XML file called 
PortalLocations.xml (unless the file already exists on the machine, in 
which case it does not overwrite the existing file). The 
PortalLocations.xml file is located in the folder where the sites are 
installed. The default site installation folder is ...\Program 
Files\Maximizer\Portals. There is only one PortalLocations.xml file for 
each Maximizer CRM Server.

The PortalLocations.xml file describes the folder location of each site. 
If you install any sites to a non-default location, you can optionally 
add their location to the PortalLocations.xml file. Any sites identified 
in this file will be updated by the Maximizer installation for any 
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upgrades or updates such as service releases. Any sites installed to 
non-default locations will not be updated unless they are added to 
the PortalLocations.xml file.

By default, the PortalLocations.xml file contains location information 
for the four default sites.

<Portals>

<Portal ID="DefCustomerPortal">

<Location>C:\Program 
Files\Maximizer\Portals\Customer</Location>

<Context>MA_CUSTOMER</Context>

<Description>Maximizer Default Customer Portal</
Description>

</Portal>

<Portal ID="DefPartnerPortal">

<Location>C:\Program 
Files\Maximizer\Portals\Partner</Location>

<Context>MA_PARTNER</Context>

<Description>Maximizer Default Partner Portal</
Description>

</Portal>

<Portal ID="DefEmployeePortal">

<Location>C:\Program 
Files\Maximizer\Portals\Employee</Location>

<Context>MA_EMPLOYEE</Context>

<Description>Maximizer Default Employee Portal</
Description>

</Portal>

<Portal ID="DefWirelessPortal">

<Location>C:\Program 
Files\Maximizer\Portals\Wireless</Location>

<Context>MA_WIRELESS</Context>

<Description>Maximizer Default Wireless Portal</
Description>

</Portal>

</Portals>
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The XML file contains a site ID, location, context, and description for 
each site. These elements are described in the following table.

Setting Up Multiple Customer or Partner Sites

If you want the sites to be 
updated by the Maximizer 
installation, refer to “Installing 
Sites to Non-Default Folders” 
on page 239.

To this point, the chapter has explained how to set up a single 
Partner Access site and a single Customer Access site. However, you 
can create additional Partner and Customer Access sites for one or 
more Address Books. For example, you might want to create a Media 
Site for your Address Book, or you might want to create a Customer 
or Partner Access site for a second Address Book. 

The major steps involved in creating additional Partner or Customer 
Access sites is as follows:

• Assign a Category field value to Address Book entries. The 
Category field of an Address Book entry controls which sites(s) 
an Address Book entry can access. Therefore, you must assign a 
Category field value to all Address Book entries that should be 
granted access to the new site. You can create a new field value, 
or you can assign one of the existing field values.

• Create the new site. The process of creating a new site is very 
simple. Essentially, you duplicate an existing Customer or Partner 
Access site folder, rename it, and edit the Web.config file for the 
new site.

• Configure the new site. At this point, the site is functional. The 
only remaining task is to configure the new site using Customer/
Partner Access Administrator and provide access PINs to those 
Individuals and Contacts who you want to be able to log into it.

Each of these procedures are described in detail below.

Element Description

<Site/Portal> This element has an ID attribute, which must be 
unique for each site. This ID will not be displayed in 
the site itself.

<Location> Installation location of the site.

<Context> Identifies the type of site. Must be one of the 
following values:
• MA_Employee
• MA_Customer

• MA_Partner
• MA_Wireless

<Description> Description of the site. 
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➤ To create a new Category field value

� Run Maximizer and log into the Address Book.

� Open an Address Book entry to grant access to the new site.

� If the Address Book entry is in View mode, click Edit to switch to 
Edit mode.

� Click the ellipsis button beside the Category field.

� If a new field value is required, click New Value and add an item 
to the list.

� Select the checkbox beside the field value that enables the 
Address Book entry to access the new site, and click OK.

For example, if you are creating a Media Access site, you would 
probably select Media as the required Category field value. If 

�
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you were creating an Investor Access site, you would create a 
new Category field value of Investor.

� Repeat this process to assign the Category to any other Address 
Book entries which should have access to the new site.

➤ To create the new site

� Open Windows Explorer, and navigate to the sites directory. (In a 
default installation, this folder is located at 
C:\Program Files\Maximizer\Portals.)

� Create a copy of the Customer or Partner folder inside the 
Portals folder.

Make sure you copy the entire Customer or Partner folder, 
including all subfolders and files.

�

�
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� Rename the folder with the new site name.

� Right-click the new folder, and select Properties from the 
shortcut menu.

� Select the Web Sharing tab.

Do not use spaces in the virtual 
folder name.

� Select Default Web Site from the Share on drop-down list, 
and select the Share this folder option.

The Edit Alias dialog box opens.

� Enter an alternate Alias if desired, select the Read access 
permission, select the Scripts application permissions, and click 
OK.

	 Click OK to close the Properties dialog box.
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 In the new folder, select the Web.config file and open it in a 
text editor, such as Windows Notepad.

��Assign a meaningful value to the SubContext key.

The sites have a Context value and a SubContext value. The 
Context value is MA_PARTNER for a Partner Access site and 
MA_CUSTOMER for a Customer Access site. The Context value 
for the new site is already defined because you copied it from an 
existing site, so you just need to assign a SubContext value, 
which differentiates this new site from the original.

For example, if you are creating a Media site, you would 
probably choose to assign a SubContext value of “Media”.

��Enter the Category field value (from the previous procedure) 
as the AlternateRequiredCategory value.

If you used the “Media” Category field value, you would assign 
“Media” as the AlternateRequiredCategory value.

��Save the Web.config file.

Do not change the name or location of this file.
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➤ To configure the new site

� Open a web browser and enter the URL of the new site. The 
default site URL is

http://<web_server_name>/<site_alias>/Admin.aspx

In the case of the example site, the URL is http://test-server/
MaximizerMedia/Admin.aspx.

Customer/Partner Access Administrator opens. The login page 
appears as the Partner Access Administrator or Customer Access 
Administrator login page, depending on which site you copied 
the new one from.

� Log into Customer /Partner Access Administrator.

� Configure the site as desired. Refer to the previous sections of 
this chapter for more information.

Include setting the site name as part of the configuration. You 
can set the name in the General Settings page of the 
Configuration Manager.

� Assign a site PIN to all Individuals and Contacts who should have 
site access, as described in “Assigning Site Login PINs to Contacts 
and Individuals” on page 225.

Creating a Custom Case Wizard for Partner Access

Partner Access includes a wizard for creating new customer service 
cases. It is available from the Edit > Create a Customer Service Case 
menu item on the Customer Service page of the site. You can also 
create your own custom customer service case wizards and make 
them accessible from the Edit menu. 

Create your own case wizards by describing them in an XML file, 
naming the file CustomCSCaseWizards.xml, and placing it in the 
Config folder of Partner Access. The XML elements that your 
CustomCSCaseWizards.xml file may contain are described below, 
along with a sample XML file. When you create multiple case 
wizards, they must all be described in the same XML file, with each 
wizard set apart by the <CSCaseWizard> element.

Note that if the XML is not well-formed, the custom wizards will not 
appear in the Edit menu, and no error messages will appear.



Chapter 9
Configuring Web Access

247

➤ To create a custom customer service case wizard

� Create an xml file describing the contents of each screen of the 
wizard.

For more information, refer to the custom wizard example and 
the table describing the XML tags, which are provided in this 
section.

� Name the xml file CustomCSCaseWizards.xml.

� Place the xml file in the following folder:

...\Maximizer\Portals\Partner\Config

This folder is typically located in the C:\Program FIles\ folder.

Custom Wizard Example

Below are the contents of an example CustomCSCaseWizards.xml 
file.

<CustomCSCaseWizards>

<CSCaseWizard>

<Id>SuggestionWizard</Id>

<MenuOption>Enter a Suggestion</MenuOption>

<HeaderStep1>Categorize your suggestion</HeaderStep1>

<ShowOrigin>true</ShowOrigin>

<OriginPrompt>Suggestion origin</OriginPrompt>

<DefaultOrigin>Website</DefaultOrigin>

<MandatoryOrigin>true</MandatoryOrigin>

<ShowType>true</ShowType>

<TypePrompt>Suggestion type</TypePrompt>

<DefaultType>Suggestion</DefaultType>

<MandatoryType>true</MandatoryType>

<ShowProduct>true</ShowProduct>

<ProductPrompt>Product or service</ProductPrompt>

<DefaultProduct>Accessories</DefaultProduct>

<MandatoryProduct>true</MandatoryProduct>

<ShowCategory>true</ShowCategory>

<CategoryPrompt>Category</CategoryPrompt>
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<DefaultCategory>Other</DefaultCategory>

<MandatoryCategory>true</MandatoryCategory>

<ShowPriority>true</ShowPriority>

<PriorityPrompt>Priority</PriorityPrompt>

<DefaultPriority>Medium</DefaultPriority>

<ShowSeverity>true</ShowSeverity>

<SeverityPrompt>Severity</SeverityPrompt>

<DefaultSeverity>Medium</DefaultSeverity>

<DefaultAssignedTo>JNAPOLI</DefaultAssignedTo>

<DefaultOwner>JNAPOLI</DefaultOwner>

<DefaultQueue>Standard</DefaultQueue>

<udfPrompt1>Send acknowledgement email</udfPrompt1>

<udfTypeId1>107</udfTypeId1>

<MandatoryUdf1>true</MandatoryUdf1>

<DefaultUdf1>No</DefaultUdf1>

<HeaderStep2>Provide details</HeaderStep2>

<SubjectPrompt>Short description</SubjectPrompt>

<DescriptionPrompt1>Details</DescriptionPrompt1>

<DescriptionPrompt2>More details</DescriptionPrompt2>

<HeaderStep3>Review your suggestion</HeaderStep3>

</CSCaseWizard>

<CSCaseWizard>...(Second custom wizard)...</CSCaseWizard>

<CSCaseWizard>...(Third custom wizard)...</CSCaseWizard>

</CustomCSCaseWizards>

The first screen of the example custom wizard displays the following 
fields: Suggestion origin, Suggestion type, Product or service, 
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Category, Priority, Severity, and Send acknowledgement email. All of 
the fields have default values.

The second screen of the example custom wizard contains three 
fields: Short description, Details, and More details. 



Maximizer CRM
Administrator’s Guide

250

The third screen in the example custom wizard displays a summary of 
the values entered in the previous screens.
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XML Tags in the CustomCSCaseWizards.xml File

The following table lists each of the XML tags in the 
CustomCSCaseWizards.xml file, as well as their data type and a 
description. 

All XML tags are case-sensitive.

XML Tag Data Type Description

CSCaseWizard Contains all other tags describing 
a single wizard. Each custom case 
wizard must be set apart by its 
own set of CSCaseWizard tags 
inside the file.

Id string Mandatory.
Unique identification of the 
wizard.

MenuOption string Mandatory.
Menu item text as it will appear in 
the Edit menu of the Customer 
Service page.

HeaderStep1 string Header text that appears at the 
top of each page of the wizard. 
Header text is automatically 
prefixed by “Step 1 - “, “Step 2 - “, 
or “Step 3 - “.
If these tags are not included, the 
wizard will use the default header 
text, as it appears in the default 
Customer Service Case Wizard.

HeaderStep2 string

HeaderStep3 string

ShowOrigin boolean Specifies whether to display the 
Case origin, Case type, Products/
Services, Categories, Priority, and 
Severity fields:
• If “true”, the field(s) appear 

on the first page of the 
wizard.

• If “false”, the field(s) do not 
appear in the wizard.

• If you omit the XML tag, all of 
these fields, except “Origin” 
appear in the wizard by 
default.

ShowType boolean

ShowProduct boolean

ShowCategory boolean

ShowPriority boolean

ShowSeverity boolean
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DefaultOrigin string Specifies the default value of the 
Case origin, Case type, Products/
Services, Categories, Priority, and 
Severity fields.
The value of the XML element 
must be a valid value of the 
related field in the Address Book.
The values of the 
DefaultAssignedTo, 
DefaultOwner, and DefaultQueue 
fields are not visible in the wizard 
because there is no related 
“Show...” XML tag. Therefore, site 
users cannot change the value of 
these fields through the wizard.
The DefaultAssignedTo tag does not 

check whether the specified user has the 
“Customer Service Representative” or 
“Customer Service Manager” access 
right. It is up to you to verify that the 
user identified in the DefaultAssignedTo 
tag has the appropriate access rights.

DefaultType string

DefaultProduct string

DefaultCategory string

DefaultPriority string

DefaultSeverity string

DefaultAssignedTo string

DefaultOwner string

DefaultQueue string

OriginPrompt string Specifies the text that appears 
beside the field in the wizard.
If you omit an XML tag, the 
wizard uses the default prompt, as 
it appears in the “Create a 
Customer Service Case” wizard.

TypePrompt string

ProductPrompt string

CategoryPrompt string

PriorityPrompt string

SeverityPrompt string

SubjectPrompt string

DescriptionPrompt1 string Specifies the text that appears 
above the last two fields on the 
second page of the wizard.
If you omit an XML tag, the 
wizard uses the default prompt, as 
it appears in the “Create a 
Customer Service Case” wizard.

DescriptionPrompt2 string

XML Tag Data Type Description
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MandatoryOrigin boolean Specifies whether site user must 
provide a value for the Case 
origin, Case type, Products/
Services, or Categories field in the 
wizard:

• If “true”, the site user must 
select a value for the field 
before proceeding to the next 
page in the wizard.

• If “false”, the site user may 
leave the field blank.

• If you omit the XML tag, the 
fields are not mandatory.

MandatoryType boolean

MandatoryProduct boolean

MandatoryCategory boolean

udfTypeId1 ... 
udfTypeId7

integer Specifies the user-defined field to 
include on the first page of the 
wizard. Specify the Type_Id of the 
user-defined field as the value of 
this XML tag.
You can include up to seven user-
defined fields. The wizard can 
display only table user-defined 
fields defined for customer service 
cases.

udfPrompt1 ... 
udfPrompt7

string Specifies the text that appears 
beside each user-defined field 
included in the wizard. 

MandatoryUdf1 ... 
MandatoryUdf7

boolean Specifies whether the site user 
must provide a value for each 
user-defined field included in the 
wizard.

DefaultUdf1 ... 
DefaultUdf7

string Specifies the default value of each 
user-defined field included in the 
wizard.

XML Tag Data Type Description
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C H A P T E R1010Live Update

In this chapter...

“Introduction to Maximizer Live Update” on page 256

“Installing Live Update Manager” on page 257

“Configuring Live Update Manager” on page 259

“Downloading Updates from Maximizer with Live Update” on page 260

“Approving Updates” on page 261

“Copying the Update and XML Files to the Web Server” on page 263

“Configuring the Maximizer Live Update Service” on page 264

“Updating Maximizer with Live Update” on page 265
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Introduction to Maximizer Live Update
The Live Update service checks for and downloads appropriate 
Maximizer CRM software updates for your local Maximizer CRM 
installation. The Live Update service can be configured to point to 
either the Maximizer Software update server (which is the default 
setting) or to your organization’s own Live Update server. The Live 
Update service is installed and enabled automatically as part of the 
regular Maximizer CRM installation. However, to use your own Live 
Update server, you must install and configure Live Update Manager 
separately, as described in this chapter.

Live Update Manager is an optional component of the Maximizer 
Live Update service and is available on the Maximizer CRM Server 
disc. Live Update Manager is a standalone component that enables 
you to control the timing and distribution of software updates, as 
well as to test them before releasing Maximizer software updates to 
your users. 
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Installing Live Update Manager
Before you install Live Update Manager, you will need to create a 
virtual directory on your web server. The following sections describe 
how to install LIve Update Manager:

• “Creating a Virtual Directory for Live Update on your Web 
Server” on page 257

• “Installing Maximizer Live Update Manager” on page 257

Creating a Virtual Directory for Live Update on your Web Server

For instructions on creating a 
virtual directory, refer to your 
web server software 
documentation.

Designate a machine as your Live Update server, which will serve 
updates to the Live Update service on Maximizer machines in your 
organization. It can be a web server outside the firewall if Internet 
access is required (for example to support remote offices) or a web 
server available locally only. In either case, it must be an IIS server. 

Create a virtual directory for Live Update on your web server. You 
will be prompted for the URL of your Live Update server during the 
Live Update Manager installation.

You will also be prompted for the location to save updates that Live 
Update Manager downloads from Maximizer Software. If possible, 
use the same location as the physical location of the virtual directory 
of your Live Update server. However, in some situations (such as 
when the URL is of a web server outside the firewall) this 
configuration is not the most secure and you should specify a 
different location.

Installing Maximizer Live Update Manager

Live Update Manager is the program that enables you to check for, 
download, and manage updates for Maximizer CRM installations. 
The Live Update Manager installation is available on the Maximizer 
CRM Server disc. Live Update Manager does not need to be co-
located with a Maximizer CRM Server, but it can be if desired. The 
installation location of the Live Update Manager (by default 
C:\Program Files\Maximizer Live Update) must have network access 
to the physical folder that will be used to store Maximizer CRM 
product updates downloaded from the Maximizer Software update 
server.

➤ To install Maximizer Live Update Manager

� Close all programs running on the machine.

� Insert the Maximizer CRM Server disc.
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� On the Autorun screen, click Install Maximizer Live Update 
Manager.

If the setup doesn’t start 
automatically, you can start it 
manually by running setup.exe 
from the disc.

� On the Welcome screen, click Next.

� On the Customer Information screen, enter your User Name, 
Company Name, and select whether to install the application 
for all users of the computer or only for the current user.

� On the Choose Destination Location screen, click Next to install 
the application to the default folder.

– or –

Click Browse, select an alternative location, and click Next.

� On the Corporate Update Server properties screen, enter the 
URL for the Live Update virtual directory you created previously 
(e.g., http://www.escona.com/liveupdate).

You can modify the URL and 
Download settings through 
Live Update Manager after it is 
installed.

– or –

Enter the UNC network path of the Live Update folder on your 
Live Update web server (e.g., \\LiveUpdateServer\liveupdate).

The Download field specifies the folder that updates from 
Maximizer will download to. You can change this path if 
needed.

Click Next.

	 On the Start Copying Files screen, review your installation 
settings and click Next to begin the installation.


 When the installation is complete, click Finish.

Live Update Manager is now accessible from the Start menu. 
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Configuring Live Update Manager
Once you have installed Live Update Manager, configure it and enter 
the PSNs for your Maximizer products.

➤ To configure Live Update Manager

� Run Live Update Manager. It is available from Start > Programs 
> Maximizer Live Update > Live Update Manager.

� Click the Settings tab.

� Ensure that the URL of your corporate update server field 
contains the URL (e.g., www.escona.com/liveupdate) or the UNC 
network path (e.g., \\LiveUpdateServer\liveupdate) of the Live 
Update virtual folder on your Live Update web server.

The Base URL of the update 
server field may already be 
completed if you provided the 
information during the Live 
Update Manager installation.

� In the Product list, ensure the checkboxes are selected for all 
Maximizer Software Inc. products installed in your organization. 
De-select the checkboxes for any products not installed.

� For each installed product, select the product, click Edit, enter 
your PSN(s) for that product, and click OK. If you have more 
than one PSN for a product, separate the PSNs with commas.

� You can optionally change any of the settings on the 
Preferences tab. For information about each of these options, 
select the Preferences tab and press F1.

� Click Apply to save your changes.

� �

�

�

�

�

�
�
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Downloading Updates from Maximizer with Live Update
The Live Update Wizard in the Live Update Manager connects to the 
Maximizer Live Update Server and downloads available updates from 
Maximizer Software Inc.

➤ To start the Live Update Wizard

• If the Enable automatic Maximizer Live Update 
notification option is selected on the Preferences tab, a 
message box notifies you when new updates are available. Click 
OK to start the Live Update Wizard.

– or –

• In Live Update Manager, click the Check for updates button on 
the Updates tab, which opens the Live Update Wizard.

➤ To download software updates from Maximizer

� Start the Live Update Wizard as described above.

If you started the Live Update Wizard from the automatic 
notification message box, it takes you directly to the Available 
Updates screen. Skip to step 3.

� Click Next on the welcome screen.

The Live Update Wizard connects to the Maximizer Live Update 
Server to check for any available updates. 

� Select the update(s) to download.

� Click Next to download the selected updates.

� Click Finish to close the wizard.

The update files are now located in the updates download 
folder. The default location of this folder is C:\Documents and 
Settings\All Users\Application Data\Maximizer\Live 
Update Manager. 

The updates download folder 
path is specified in the 
Preferences tab of Live Update 
Manager.

If your Live Update Manager configuration does not use the 
default location, this folder may be in a different location.
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Approving Updates
Once you have downloaded any available updates with the Live 
Update Wizard, they appear in the Available Updates list of the 
Updates tab in Live Update Manager. You must approve these 
updates before copying them (and the MaxUpdates.xml file) to your 
Live Update server.

Use the Approve button on the Updates tab to approve and 
disapprove updates. Approving an update modifies the 
MaxUpdates.xml file, which keeps track of approved updates. Once 
an update is approved, it is available to any Maximizer CRM servers 
that check for updates.

The following sections contain more information on approving 
updates for Maximize users:

• “Testing Updates Before Approval” on page 261

• “Approving Updates for Download” on page 261

Testing Updates Before Approval

Between receiving an update from Maximizer Software and 
releasing it to your organization, you should test the update in a test 
environment and once satisfied should deploy it to all Maximizer 
CRM servers that host Address Books. Assuming that you have 
already deployed a production Live Update Manager deployment, 
the two ways to set up testing are as follows:

• Install a test deployment of Live Update Manager on another 
machine, with its own testing Live Update server URL. The 
download location could be the same as for the production Live 
Update Manager. One or more Maximizer CRM servers should be 
configured for testing and to download updates from the test 
Live Update server. Once these updates are verified, you can 
return to the production Live Update Manager and approve the 
updates. 

• Alternatively, rather than using a test Live Update Manager to 
manage updates, simply copy the downloaded updates to the 
test Maximizer CRM server(s) and run the update(s) manually on 
the test machines (i.e., distribute the updates for testing 
manually rather than using Live Update Manager to distribute 
the updates). Following testing, return to the production Live 
Update Manager and approve the updates.

Approving Updates for Download

After testing the updates, you can use Live Update Manager to 
approve updates. After approving the updates, you must copy the 
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update files and MaxUpdates.xml file to your Live Update server 
before users can download the updates from Administrator or 
Maximizer.

➤ To approve software updates for download

� In the Updates tab of Live Update Manager, select one or more 
downloaded update(s).

� Click the Approve button.

The values of the Approved column changes from “No” to 
“Yes”.

� Click Apply to save your changes.

� Repeat these steps to approve any other updates, as needed.
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Copying the Update and XML Files to the Web Server
After you have downloaded and approved any updates, you must 
copy the files and the MaxUpdates.xml file to the virtual directory on 
your Live Update server. The location of the files on the server must 
match the URL specified in the updates properties.

Once you have copied the files to your Live Update server, you can 
verify the URLs for each update using Live Update Manager. The 
Verify URLs button checks that the approved update file(s) and 
updated MaxUpdates.xml file actually exist at the location specified 
by the Live Update server URL.

➤ To copy the update files to the Live Update server

• Copy the following files to the virtual directory on your Live 
Update server.

➤ To verify update URLs

• On the Updates tab of Live Update Manager, click Verify URLs.

Live Update Manager verifies all approved updates. If the 
verification succeeds, your Maximizer server(s) can download the 
updates from your Live Update server.

If the verification fails, ensure that the update files and current 
MaxUpdates.xml file have been copied to the correct location on 
the Live Update server, that the URL defined for the update is 
correct, and that your web server settings are correct.

File(s) to copy Location to copy file(s) from

Downloaded update 
file(s)

Updates download folder, specified on the 
Preferences tab of Live Update Manager.
The default updates download folder is 
C:\Documents and Settings\All 
Users\Application Data\Maximizer\Live 
Update Manager

MaxUpdates.xml Live Update Manager program folder 
(usually C:\Program Files\Maximizer Live 
Update).
This file contains information about 
downloaded updates and gets updated 
every time you download an update. 
You have to copy the most recent version 
of this file to your web server each time 
you approve a new update.



Maximizer CRM
Administrator’s Guide

264

Configuring the Maximizer Live Update Service
The default configuration for Maximizer CRM servers is with the Live 
Update service enabled and using the URL for the Maximizer 
Software update server. Change the URL in Administrator 
Preferences to point to your own Live Update server to enable all 
Maximizer CRM servers to use the Live Update service through your 
Live Update server.

➤ To configure the Live Update Service

� In Administrator, select File > Preferences.

� On the System Options tab, click Live Update.

� The Enabled Maximizer Live Update checkbox is selected by 
default. If it has been cleared, make sure to select it.

� By default, the URL of update server field contains the URL of 
the Maximizer Software Live Update server. Change it to the 
URL (e.g., www.escona.com/liveupdate) or the UNC network 
path (e.g., \\LiveUpdateServer\liveupdate) of the Live Update 
folder on your web server.

� By default, Enable automatic Maximizer Live Update 
notification is turned on. When enabled, Live Update displays a 
message on the Maximizer server(s) and workstations when a 
new update becomes available on the Live Update server. If you 
turn automatic notification off, users must manually check for 
updates on each machine.

� By default, Live Update automatically checks for updates every 
14 days. You can optionally change the Interval to check for 
updates.

� Click OK to save your changes and close the dialog box.

�

�
�

�
�
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Updating Maximizer with Live Update
The Maximizer Live Update Service is installed automatically with 
Maximizer CRM server. It enables servers to download updates such 
as hot fixes and service releases, and you can configure Live Update 
to provide automatic notification of available updates.

The Live Update Wizard on Maximizer servers connects to your Live 
Update Server and downloads any available updates.

After downloading the software updates, the downloaded 
executable file should launch immediately to start the installation. If 
you need to locate the downloaded file, it is in the user’s Application 
Data folder (typically C:\Documents and 
Settings\<CurrentUser>\Application Data\Maximizer\Live Update).

The updates download folder 
path is specified in the 
Preferences tab of Live Update 
Manager.

If the Enable automatic Maximizer Live Update notification option is 
selected in the Live Update options in Administrator, a message box 
you when new updates are available. You can also check for updates 
at any time from Maximizer or Administrator.

Live Update options iare 
accessible through the Live 
Update button on the System 
Options preferences in 
Administrator. (Select File > 
Preferences.)

➤ To download software updates from the server

� If you are notified that new updates are available, click OK in the 
message box to start the Live Update Wizard.

– or –

In Administrator, select Help > Maximizer Live Update.

� Click Next.

The Live Update Wizard connects to the Live Update Server to 
check for any available updates.

� Select the update(s) to download.

� Click Next to download the selected updates.

� Click Finish to close the wizard.
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C H A P T E R1111SQL Server Reporting
Services

In this chapter...

“About Microsoft SQL Server Reporting Services” on page 268

“Integrating SQL Server Reporting Services with Maximizer Web Access” on 
page 269
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About Microsoft SQL Server Reporting Services
Microsoft SQL Server Reporting Services is a server-based reporting 
system that’s included with most editions of Microsoft SQL Server. 

Maximizer and Maximizer Web Access can integrate with SQL Server 
Reporting Services. You can create custom reports that point to 
Maximizer data, and host the reports in SQL Server Reporting 
Services. Then, you can access the reports from Maximizer or 
Maximizer Web Access, depending on the integration you use.

The Maximizer Web Access integration with SQL Server Reporting 
Services works only with SQL Server 2008 R2 Service Pack 1 or later. 
This integration creates a number of default reports that users can 
access from the Reports page in Maximizer Web Access. Users can 
also create new reports using Microsoft SQL Server Report Builder.
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Integrating SQL Server Reporting Services with Maximizer 
Web Access

You can integrate Microsoft SQL Server Reporting Services with 
Maximizer Web Access. This Integration is available only on Microsoft 
SQL Server 2008 R2 Service Pack 1 or later. If you have an earlier 
version of SQL Server 2008 R2, you should first upgrade SQL Server to 
the latest service pack. The integration is installed automatically 
when you install Maximizer CRM Server. To use the integration, you 
must complete the following steps:

• Install SQL Reporting Services Integration from the Maximizer 
CRM Server disc. For information, see “Installing SQL Reporting 
Services Integration” on page 269.

• Set up a user account for the integration. For information, see 
“User Account for SQL Server Reporting Services Integration” on 
page 271

• Enable SQL Server Reporting Services in Maximizer Web Access 
Administrator. For information, see “Enabling SQL Server 
Reporting Services” on page 271.

If you use Windows Authentication or you run Maximizer Web Access 
on HTTPS, you must also follow additional steps to configure SQL 
Server Reporting Services. For information, see “Configuring SQL 
Server Reporting Services for Windows Authentication” on page 272 
and “SQL Server Reporting Services with Maximizer Web Access on 
HTTPS” on page 273.

Installing SQL Reporting Services Integration

SQL Reporting Services Integration integrates Microsoft SQL Server 
Reporting Services with Maximizer Web Access. You should install 
SQL Reporting Services Integration on the same computer where SQL 
Server Reporting Services is installed. This computer may be a 
different computer than the one where Maximizer CRM Server is 
installed. 

If you plan to use SQL Server Reporting Services for any purposes 
other than integrating with Maximizer Web Access, you should 
install a dedicated instance of SQL Server for the integration. When 
you install SQL Reporting Services Integration, the security settings 
on the selected instance of SQL Server Reporting Services are 
replaced with security settings appropriate for integrating with 
Maximizer.
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➤ To install SQL Reporting Services Integration

� On the computer running SQL Server Reporting Services, close all 
programs.

� Insert the Maximizer CRM Server disc.

� Select Install SQL Reporting Services Integration.

The Maximizer CRM SQL Reporting Services Integration 
installation wizard opens.

� Click Next.

� Read the license agreement, select I accept the terms of the 
license agreement, and click Next.

� From the SQL Reporting Service instance drop-down list, 
select an existing instance of SQL Server Reporting Service.

The security settings of the selected instance will be replaced 
with security extensions for Maximizer. You should select a 
dedicated instance of SQL Server Reporting Services for 
integration with Maximizer.

� In the Maximizer Web Access URL field, enter the URL for 
Maximizer Web Access, and click Next.

	 Click Install to begin the installation.
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User Account for SQL Server Reporting Services Integration

In order to enable the SQL Server Reporting Services Integration, you 
must specify a user account to connect with the Maximizer database. 
The user account must match the following criteria:

• The user is a member of the SSRS Report Management security 
group in Maximizer. For information on security groups, see 
“Security Groups” on page 106.

• The login for the user has the sysadmin server role on the SQL 
Server hosting the Maximizer database. For information on user 
logins in Microsoft SQL Server, see the SQL Server 
documentation.

The MASTER user automatically meets these criteria. 

Enabling SQL Server Reporting Services

You can enable SQL Server Reporting Services in the System Options 
preferences in Maximizer Web Access Administrator. When you 
enable SQL Server Reporting Services, a number of default reports 
are automatically created on the SQL Server Reporting Services 
server.

➤ To enable SQL Server Reporting Services

� Log in to Maximizer Web Access Administrator.

� In the left pane, under Preferences, click System Options.

� Select the SQL Server Reporting Services Settings tab.

� Click Modify Options.

� Select Enable SQL Server Reporting Services Integration.

The URL to the Reporting Services server and the path to the 
current Address Book are automatically filled in.

� Under Database Account, enter the username and password 
for the user account used to connect to the Maximizer database.

If you are using Windows Authentication, you must specify the 
Windows domain and user account in the Account field.

Whenever the password changes, you must specify the new 
password in this page.
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� Click Save.

	 The SQL Server Reporting Services settings are saved on the 
report server. You may need to wait a moment for the settings 
to save.

Configuring SQL Server Reporting Services for Windows Authentication

If you are using Windows Authentication, you must perform 
additional steps to configure SQL Server Reporting Services. After 
configuring Windows Authentication, you must continue to specify 
the Maximizer username and password when you log in to SQL 
Server Reporting Services to configure the report server or to create 
reports using SQL Server Report Builder.

When you enable SQL Server Reporting Services Integration in 
Maximizer Web Access Administrator, you must specify the Windows 
domain and user account in the name of the database account. For 
information on enabling SQL Server Reporting Services, see 
“Enabling SQL Server Reporting Services” on page 271. If your 
domain enforces password changes at regular intervals, you may 
want to create a user account where the password never changes for 
this purpose.

In Reporting Services Configuration Manager, you must specify the 
Local System as the service account.

➤ To specify the service account for SQL Server 
Reporting Services

� On the computer hosting SQL Server Reporting Services, open 
Reporting Services Configuration Manager (Start > All 
Programs > Microsoft SQL Server 2008 R2 > Configuration 
Tools > Reporting Services Configuration Manager).
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� Specify the name and instance of the report server, and click 
Connect.

� In the left pane, select Service Account.

� Select Use built-in account.

� From the drop-down list, select Local System.

� Click Apply.

SQL Server Reporting Services with Maximizer Web Access on HTTPS

If you run Maximizer Web Access using HTTP Secure (HTTPS), you 
must configure SQL Server Reporting Services to connect with 
Maximizer Web Access under HTTPS.

➤ To configure SQL Server Reporting Services for 
HTTPS

� On the computer hosting SQL Server Reporting Services, open 
the Report Manager web.config file.

The file is stored in the following location:

[SQL Server Installation Folder]\Reporting Services\
ReportManager\web.config

� In the <appSettings> element, locate the 
MaxAuthWebServicesURL key.

� Next to value, change http to https.

� Save the file.

� Open the rsreportserver.config file.

The file is stored in the following location:

[SQL Server Installation Folder]Reporting Service\
ReportServer\rsreportserver.config

� Locate all lines containing the <MaxAuthWebServicesURL> 
element.

The element is located in the <Security> and 
<Authentication> elements.

� In the URL for each <MaxAuthWebServicesURL> element, 
change http to https.

	 Save the file.
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C H A P T E R1212Customizing Dashboards

In this chapter...

“Working with Dashboards” on page 276

“SQL Metrics for Indicators” on page 277
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Working with Dashboards
Dashboards are graphical display of quantitative Address Book 
information. They includes a variety of indicators that display 
information about Address Book entries, opportunities, campaigns, 
customer service cases, quotas, and activities. Dashboards are 
accessible from the My Work Day window in Maximizer. Users can 
also view dashboards from mobile devices using Mobile Access.

Users must have the rights to be able to view and modify dashboards. 
For more information, see “User Access Rights and User/Group Access 
Settings” on page 100.

In Administrator, you can delete or view the properties of 
dashboards and create SQL metrics for dashboard indicators. In 
Maximizer, you can create and modify dashboards and dashboard 
indicators. For information on setting up dashboards and dashboard 
indicators, see the Maximizer CRM User’s Guide.

Dashboard Indicators

Indicators display the information in dashboards. Each dashboard 
can contain multiple indicators.

You can set up indicators to access information in the Address Books 
in the following ways:

• Searches – Users can link indicators with existing searches in the 
search catalog. The indicator reports either the number of 
entries returned in the search or a calculation based on fields in 
the entries.

• SQL metrics – In Administrator, you can set up SQL queries that 
report on any information in your Address Book. While they are 
defined in Administrator, users can add any of these metrics to 
dashboard indicators in Maximizer.

Users can choose from a number of indicator controls to display the 
data. These controls format your Address Book data in charts, lists, 
and gauges.
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SQL Metrics for Indicators
Dashboard indicators display numeric values returned by catalog 
searches or by custom SQL queries. You can define your own SQL 
metrics in Administrators to display custom data in dashboard 
indicators. The SQL metrics consist of custom SQL queries and the 
click-through URL for the indicator. 

Users can associate indicators with SQL metrics in Maximizer. Users 
can also link indicators with catalog searches.

The following sections contain information on setting up SQL metrics 
for dashboard indicators:

• “Queries for SQL Metrics” on page 277

• “SQL Queries Across Databases” on page 277

• “Creating or Modifying Custom SQL Metrics” on page 278

• “Click Through URLs for SQL Metrics” on page 279

Queries for SQL Metrics

A SQL query used in a SQL metric must return a single numeric value 
(real). Otherwise, the indicator will display a 0. You must have a good 
understanding of SQL syntax and the database structure to create 
SQL queries.

SQL queries are run for the current logged in user. A dashboard 
indicator using a SQL metric may display different results to different 
Maximizer users.

SQL queries must select data from database views, and not from 
tables. For example, to query data in AMGR_CSCases_Tbl, you should 
write the query for the AMGR_CSCases view.

SQL Queries Across Databases

SQL queries for dashboard indicators are not restricted to the current 
Maximizer Address Book database. You can define SQL metrics that 
query another database on the same SQL server.

To create a cross-database SQL query, use the following syntax:

Select * from <database name>.<db owner>.<table name>

The following example shows a cross-database SQL query:

Select SUM (Revenue) from Accounting.dbo.Purchases
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Requirements for Cross-Database Queries

To successfully use cross-database SQL queries in dashboard 
indicators, the following conditions must be met:

• Database(s) referenced in the SQL query must all reside on the 
same SQL Server as the Maximizer Address Book where the 
dashboard indicators are being created.

• The Maximizer user running the SQL queries must be granted 
Select access (read access) to the views in database(s) being 
queried.

Alternatively, in the Maximizer Address Book, you can create 
views that reference an external database and grant users access 
to these views. This method may require enabling the “Cross 
database ownership chaining” option on the SQL server, which is 
not recommended for security reasons. 

Creating or Modifying Custom SQL Metrics

Use the procedure below to create a new SQL metric. You can also 
follow these instructions to modify an existing SQL metric. Instead of 
clicking Add, select the indicator to change and click Properties.

➤ To create a custom SQL metric

� In Administrator, select File > Preferences.

� Click the Dashboard tab.

� Click Add.

� Enter a Name and Description for the SQL metric.

� To link the SQL metric to a report or to a search, enter the click-
through URL for the metric in the Click Through URL field.

For information on the syntax for Click Through URLs, see “Click 
Through URLs for SQL Metrics” on page 279.

� Enter the SQL Query.

SQL metrics query only values 
that the logged in user can 
access.

The SQL query must return a single numeric value (real). 
Otherwise it displays a 0 in the dashboard.

� Click Test Query to test the SQL query.
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	 Click OK to save the new SQL metric.

 Click Through URLs for SQL Metrics

You can link SQL metrics to reports that display in SQL Server 
Reporting Services or to searches by defining a Click Through URL. If 
you link a metric to a report, the report opens in the Reports page 
when the indicator is clicked. SQL Server Reporting Services reports 
are available only in Maximizer Web Access. If you link a metric to a 
search, the entries that the search returns are displayed in Maximizer 
Web Access when the indicator is clicked.

Syntax for Click Through URLs to Reports

Click Through URLs to reports use the URL of the report. To get the 
URL, open the report from the Reports page, and copy the URL from 
the title bar in the web browser.

Syntax for Click Through URLs to Searches

Click Through URLs to searches use the following (all in one line):

http://[web server name]/MaximizerWebAccess/
Redirector.aspx?mdl=Module_Name&ss=Search_
String&cs=Column_Setup

• Module_Name – Value indicating the module to search. It 
can take the following values:

AbEntry – Address Book

Opportunity – Opportunities

CsCase – Customer Service

Campaign – Campaigns

�

�

�
�
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Hotlist – Hotlist tasks

Quota – Quota

• Search_String – Search string used to retrieve values from 
the specified module. For Quota and Hotlist tasks, only the 
LIST operator is supported.

For information on search string syntax in Maximizer.Data, 
see “Search String Language” on page 390.

• Column_Setups – The column setup to display for the 
entries. If a valid key is not provided, the column setup 
remains unchanged from the last time the user was in that 
window.

The following examples show search string syntax for different 
Maximizer windows.

Examples: Address Book Window

http://[web server name]/MaximizerWebAccess/
Redirector.aspx?mdl=abentry&ss=EQ(OwnerUserId,MASTER)

http://[web server name]/MaximizerWebAccess/
Redirector.aspx?mdl=abentry&ss=OR(EQ(ReadAccessUserId,MASTER),EQ(Own
erUserId,MASTER))

http://[web server name]/MaximizerWebAccess/
Redirector.aspx?mdl=abentry&ss=AND(NEQ(ModifiedByUserId,MASTER),NEQ(
ModifiedByUserId,JNAPOLI))

http://[web server name]/MaximizerWebAccess/
Redirector.aspx?mdl=ABentry&ss=OR(LIKE(city,vanco%),EQ(city,"NEW 
YORK"))

http://[web server name]/MaximizerWebAccess/
Redirector.aspx?mdl=ABentry&ss=RANGE(LastModifyDate, "2009-01-01", 
"2009-06-30")

http://[web server name]/MaximizerWebAccess/
Redirector.aspx?mdl=ABentry&ss=WNOTE("Hi ","2009-07-07","2009-07-
07")

Examples: Opportunities Window

http://[web server name]/MaximizerWebAccess/
Redirector.aspx?mdl=opportunity&ss=EQ(CreatorUserId,MASTER)

http://[web server name]/MaximizerWebAccess/
Redirector.aspx?mdl=opportunity&ss=AND(NEQ(ModifiedByUserId,MASTER),N
EQ(ModifiedByUserId,JNAPOLI))

http://[web server name]/MaximizerWebAccess/
Redirector.aspx?mdl=opportunity&ss=AND(NEQ(TeamLeaderUserId,MASTER),
NEQ(TeamLeaderUserId,jnapoli))
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http://[web server name]/MaximizerWebAccess/
Redirector.aspx?mdl=opportunity&ss=RANGE(CloseDate,"2008-01-
19","2009-01-19")

Examples: Customer Service Window

http://[web server name]/MaximizerWebAccess/
Redirector.aspx?mdl=cscase&ss=EQ(CaseOwnerUserId,MASTER)

http://[web server name]/MaximizerWebAccess/
Redirector.aspx?mdl=cscase&ss=WNOTE("[search text]","2009-01-
01","2009-07-07")

http://[web server name]/MaximizerWebAccess/
Redirector.aspx?mdl=cscase&ss=RANGE(DeadlineDate,"2009-01-01","2009-
07-07")

Example: Campaigns Window

http://[web server name]/MaximizerWebAccess/
Redirector.aspx?mdl=campaign&ss=EQ(CreatorUserId,MASTER)
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C H A P T E R1313Managing
Address Book Data

In this chapter...

“Backing Up and Restoring Address Book Data” on page 284

“Converting Embedded Documents to Linked Documents” on page 285

“Verifying and Recovering Address Book Data” on page 287

“Importing Address Book Data from MXI or XML Files” on page 290

“Importing Data from Other File Formats” on page 293

“Moving an Address Book to a Different Server” on page 313

“Purging Outdated Notes and Documents” on page 328

“Using Log Files for Diagnosis” on page 330

“System Reports” on page 332



Maximizer CRM
Administrator’s Guide

284

Backing Up and Restoring Address Book Data
This section explains how to back up Maximizer Address Book 
database files, which contain the majority of your Maximizer data, 
including Address Book entries, opportunities, customer service 
cases, campaigns, etc. However, if your Address Book uses a custom 
dictionary or holidays, you must back up those files separately.

The following sections contain information on backing up Address 
Book data in Maximizer:

• “Backing Up and Restoring an Address Book” on page 284

• “Backing Up the Dictionary File” on page 284

Backing Up and Restoring an Address Book

Back up your Address Book on a regular basis. If a problem occurs 
and you have to restore your data, you will have to re-enter all of the 
information since the last backup. While one backup copy is often 
enough, you may want to keep two or three copies on a rotating 
basis. You can store your backup files on a network or on removable 
media such as a backup tape. You may want to have one backup at 
an off-site location.

Because a Maximizer Address Book resides on a SQL Server, you use 
Microsoft SQL Server Management Studio or SQL Server Enterprise 
Manager to create a backup and restore your Address Book data. See 
your SQL Server documentation for more information.

Backing Up the Dictionary File

The Maximizer dictionary file is not backed up as part of the Address 
Book backup procedure described previously. Therefore, if you have 
customized the dictionary, you need to back up that file separately, 
especially before upgrading or re-installing Maximizer.

To back up the dictionary file, copy it from the following location 
and paste it to another location, preferably the same location where 
your Address Book is backed up.

By default, the Maximizer 
program folder is C:\Program 
Files\Maximizer. If Maximizer 
was installed in a different 
folder, then change the path 
accordingly.

User Dictionary File Location:

...\Program Files\Maximizer\MaData6\Userdict.lex
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Converting Embedded Documents to Linked Documents
Maximizer has a built-in utility in Administrator for converting 
embedded documents to linked documents. This allows you to 
manage the size of your Address Book. 

Note that a converted Address 
Book size cannot exceed 10 
GB.

Converting embedded documents to linked documents causes the 
documents to be unavailable to Web Access, Mobile Access, Partner 
Access, and Customer Access users. 

If necessary, you can move your linked documents from one location 
to another. 

➤ To convert embedded documents to linked 
documents

� In Administrator, select File > Document Administration > 
Convert Embedded Documents.

� Select the Convert embedded documents checkbox.

� Specify the document size and age limits. If these values are left 
as zeros, all embedded documents regardless of size/age are 
converted to linked documents.

� Optionally, select the Shrink database when completed 
checkbox. This reduces the size of the Address Book once the 
conversion is complete. If you haven’t chosen to convert your 
embedded documents, this reduces the size of the Address Book 
by removing any unused space. 

� Specify the folder in which linked documents will be stored in 
the Link Folder field. 

You should use the full UNC path as the location. For example, 
enter \\[computer name]\Linked Documents\. To ensure the 
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correct UNC path is used, browse to computer and folder where 
the linked documents are to be stored. 

� Click the Recalculate button after revising the conversion 
settings to estimate the size of the Address Book with the 
revised settings.

➤ To modify the location of linked documents

� In Administrator, select File > Document Administration > 
Move Linked Documents.

� Specify the folder where the linked documents were previously 
stored in the From folder. 

� Specify the new folder where the linked documents will be 
stored in the To folder.

You should use the full UNC path for both folders. 
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Verifying and Recovering Address Book Data
You can verify and recover only 

one Address Book at a time.
Address Book verification enables you to quickly identify and resolve 
invalid and orphan items in your Address Book. You should always 
run Address Book verification and recovery after upgrading or 
restoring an Address Book. Also, if database views have not been 
created for any user-defined fields and are needed for generating 
reports, use Address Book verification and recovery to create the 
missing database views.

Address Book verification and recovery identifies the following 
Address Book items.

Address Book Item Description

Orphan Contacts Contacts that are not associated with a 
Company record.

Orphan alternate 
addresses

Addresses that are not associated with an 
Address Book record.

Orphan notes Notes that are not associated with an Address 
Book entry, campaign, customer service case, or 
opportunity.

Opportunity records 
with invalid 
Start_Date field 
value

Opportunities whose start date does not match 
the earliest Sales Step start date (applies only to 
opportunities with an assigned strategy).

Notes with 
undefined Entity 
Type

Notes that do not have an entity type value 
(Address Book entry, opportunity, campaign, 
customer service case, or user) assigned to the 
record.

Orphan Link Records Opportunities that do not have a related 
Address Book entry.

Broken Company 
Library links

Company Library links that try to connect to a 
missing document (link exists but the document 
is missing).

Orphan Company 
Library links

Company Library links that link to a missing 
Company Library folder (document exists, link 
exists, but the Company Library folder is 
missing).

Orphan Company 
Library documents

Company Library documents not listed in the 
Company Library folders (document exists but 
the link is missing).

Misplaced 
Document records

Documents whose Owner field contains an 
incorrect value.
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To see recovered entries, you 
must log in as MASTER or have 
rights to open other users’ 
entries.

When you choose to recover the Address Book, Maximizer transfers 
recovered Address Book entries into a single entry called “Recovered 
on [date of recovery]”, and it transfers recovered Company Library 
documents into a single folder called “Recovered on [date of 
recovery]”. You can then view the recovered entries and either 
delete or move them as needed.

➤ To verify an Address Book

� In Administrator open the Address Book. 

� Select File > Address Book Verification.

� Choose either the Verify Only or Verify and Recover option, 
and click OK.

If you select Verify Only and 
Maximizer detects invalid 
records, it prompts you to 
recover them.

Maximizer runs the Address Book verification process, as well as 
the recovery process if you selected the second option. When it is 
complete, you see the Address Book Verification and Recovery 
Information dialog box, which contains a summary of each 
verification performed and the results of the verification.

� If you selected the Verify and Recover option, open the 
Address Book in Maximizer, and view the Recovered on [date] 

User-defined fields 
that do not have 
associated database 
Views

User-defined fields for which a database view 
has not been created.

Invalid Table UDF 
Item records

Table user-defined field items that have the 
wrong type (Company, Individual, Contact, etc.).

Invalid/orphan Table 
UDF values

Table user-defined field values that reference 
non-existent table items.

Address Book Item Description
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Address Book entry. You can then delete or move the recovered 
entries.
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Importing Address Book Data from MXI or XML Files
You can use Administrator to import Address Book entries, customer 
service cases, knowledge base articles, and other data from MXI 
(Maximizer XML Interface) or XML Files. These MXI and XML files 
may have been created by exporting from a previous version of 
Maximizer or by exporting the information from another source and 
converting it to XML using the Maximizer XML schema. For more 
information about the Maximizer XML Schema, refer to “” on 
page 371.

After importing Address Book entries into Maximizer, a list of 
imported Address Book entries is stored in a favorite list named 
according to the file format and import date and time.

The following sections contain additional information on importing 
data from MXI and XML files:

• “Importing MXI or XML Files Using Advanced Import” on 
page 290

• “Unattended Import of MXI or XML Files” on page 292

Importing MXI or XML Files Using Advanced Import

For more control over importing MXI files, or to import XML files, use 
the Advanced Import method described below, which enables you to 
specify a number of preferences about how to import the file.

Note that customer service cases are always imported as separate 
records and are never merged with existing cases. Formula user-
defined fields are imported as formulas as values.

➤ To import from an MXI or XML file

Always back up the Address 
Book before importing.

� In Administrator, select File > Import > Advanced Import.

� For the File name field, click Browse and locate the .XML or 
.MXI file to import.

Once you have selected the file to import, Maximizer fills in the 
Log File field automatically.

� To change the default Log File, click Browse and provide an 
alternate log file location and/or name.

� Select a Log Level from the drop-down list.

� Specify any additional import options in the other group boxes, 
or just use the default values.
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� Click OK to begin the import.

Maximizer imports the data and then displays the number of 
records inserted, updated, and failed for each record type.

� Click OK to close the message box.

�

�

�
�

�
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Unattended Import of MXI or XML Files

To import an MXI or XML file 
using OLE automation, refer to 
the ImportXMLFile function 
documentation in the 
Customization Suite 
documentation.

An alternative to Advanced Import is an unattended import, which 
you can initiate by double-clicking the MXI or XML file or by passing 
parameters to the Maxwin executable (MaxWin.exe) through a 
command-line interface. When using unattended import, you may 
choose to specify some of the import preferences within the MXI or 
XML file itself. For more information about MXI and XML files, refer 
to “” on page 371.

Importing MXI or XML Files by Double-Clicking

➤ To import an MXI or XML file by double-clicking

� Locate the MXI file on the computer.

� Double-click the file.

� Select the Address Book to import into, and click Open.

� Enter your User ID and Password in the Login dialog box, and 
click OK.

Maximizer imports the data, and then displays a message 
identifying the number of records inserted, updated, and failed 
for each record type.

� Click OK.

Maximizer displays a message with the name of the Favorite List, 
which lists the imported Address Book entries. 

� Click OK to view the Favorite List.

Importing MXI or XML Files from the Command Line

To import an MXI or XML file from a command line, call Maxwin.exe 
with the following command-line syntax:

The command-line syntax 
shown here uses sample 
parameter values.

Maxwin.exe /DATABASE "EsconaTutorial" /USERID "JNAPOLI" 
/PASSWORD "maximizer" /FILE="d:\ABentries051013.mxi"

Keep the following points in mind:

• Only one space is allowed after the DATABASE, USERID, and 
PASSWORD keywords.

• Values must be surrounded by double quotation marks.

• The equal sign (=) after the FILE keywords must NOT have space 
before or after it.

• The FILE parameter must be the last parameter.
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Importing Data from Other File Formats
You can use Administrator to import Address Book information from 
other sources, such as ACT!, GoldMine, or Outlook. 

After importing Address Book entries into Maximizer, a list of 
imported Address Book entries is stored in a favorite list named 
according to the file format and import date and time.

Administrator provides the following methods of importing data. 
The best import method depends on the type of data you are 
importing.

• Address Book Entries: This method imports entries from a CSV 
(comma-separated values) or tab-delimited text file that is 
created when you export from Maximizer or another 
application. Outlook, for example, can export its address book to 
a text file. When you import from a text file, you must choose to 
import all the entries as Companies/Individuals or as Contacts, or 
you can do a two-tier import to import Companies/Individuals 
first and then import the associated Contacts. For more 
information, refer to “Two-Tier Import” on page 295.

• ACT! or GoldMine Database: Importing an ACT! or GoldMine 
database is straightforward because Maximizer can detect the 
ACT! or GoldMine database version and map the fields 
automatically. Refer to “Importing Data from ACT! and 
GoldMine” on page 301.

• Other Contact Manager Database: This option enables you to 
import a variety of data file formats, including Organizer, 
Clipper, dBASE, FoxBase, and FoxPro, among others. For more 
information, refer to “Importing from Other Contact Managers” 
on page 298.
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Use the following table to determine which import method to use.

File Type
Import Method(s)
(File > Import > ...)

ACT! 1.x, 2.x, 3.x, 4.x, 2000, 6.x 
(*.dbf)

ACT! 6.0 or 2004 or earlier

ACT! 2005–2012 or ACT! Premium 
for Workgroups 2005–2012

ACT! 2005–2012 and ACT! 
Premium for Workgroups 2005–
2012

GoldMine 2.x, 3.x, 4.x, 5.x, 6.x 
(*.dbf)

GoldMine 6.7 or earlier

GoldMine 6.7 Corporate Edition 
(MSSQL)

GoldMine 6.7 Corporate Edition 
or earlier

GoldMine 8.x Premium Edition 
(Firebird SQL, MSSQL)

GoldMine Premium Edition 8.x

Organizer 1.x (*.org) Other Contact Manager Database

Delimited (*.txt, *.prn) Other Contact Manager Database

Comma Delimited (*.csv) 
Tab Delimited (*.txt)

Address Book Entries

Clipper Summer '87 (*.dbf) Other Contact Manager Database

Clipper 5.x (*.dbf) Other Contact Manager Database

dBase III, III+, IV (*.dbf) Address Book Entries

dBase V (*.dbf) Other Contact Manager Database

Visual dBase 5.x (*.dbf) Other Contact Manager Database

FoxBase/FoxBASE+ (*.dbf) Other Contact Manager Database

FoxPro 1.x, 2.x (*.dbf) Other Contact Manager Database

Visual FoxPro 3.x (*.dbf) Other Contact Manager Database
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Field Mapping

When you import from a 
recognized database type, 
such as GoldMine or ACT!, 
Maximizer automatically maps 
the fields for you.

When importing some types of data files, you need to map (create an 
association between) the fields in the source file and the fields in 
Maximizer. Keep in mind that different applications name their fields 
differently. For example, the field for a company name is called 
“Company” in Outlook and “Company or Individual” in Maximizer.

When you are importing a file type that requires you to map fields 
Field Mapping dialog box opens where you can map Maximizer fields 
to fields in the source file. For each field in the source file, select one 
of the available Maximizer fields, and click Add to map the fields. 
Select a corresponding Maximizer field for every field in the source 
file. If there is no corresponding field, select <Skip Field> from the list 
of Maximizer fields. When you have finished mapping the fields, the 
Order of Import (middle column) displays the corresponding 
Maximizer field beside each field in the Fields from File column.

Two-Tier Import

If you import a Company 
record, and an existing 
Company record in the 
database has an identical 
“Company” field, then the 
records are considered 
duplicates, and Maximizer will 
not import the duplicate 
Company record. However, 
Maximizer will import 
duplicate Individual and 
Contact records.

Many contact management programs keep two types of address 
book entries:

• Companies

• Contacts for Companies

Maximizer keeps its Address Book entries organized in a similar way: 

• Companies/Individuals

• Contacts (associated with a Company or Individual)

The Import Address Book Entries function enables you to perform a 
two-tier import. In a two-tier import, you first import Company 
entries as Companies/Individuals Address Book entries, and then you 
import the people as Contacts.
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Two-tier importing is only applicable to comma-separated value files, 
tab-delimited files, dBase III, III+, or IV, or XML files using the File > 
Import > Address Book Entries command.

➤ To import Address Book entries (two-tier import)

Always back up the Address 
Book before importing.

� From the File menu, select Import > Address Book Entries.

The Import Address Book Entries dialog box opens.

� Click Browse and locate the file to import.

User-defined fields containing 
more than one available item 
are not supported in a CSV 
(comma-separated values) 
import. Use the Advanced 
Import feature or MTI 
(Maximizer Transfer Interface) 
as an alternative.

� Select the Companies / Individuals option to import all records 
in the source file as Company or Individual Address Book entries.

(After you complete this procedure, repeat it a second time to 
import the Contacts. If you choose not to do a two-tier import, 
just select either Companies / Individuals or Contacts.)

� In the Lead handling box, select the appropriate option for 
importing records as lead or non-lead Address Book entries.

� Click OK.

The Select Fields for Import dialog box opens.

� In the Available Maximizer fields column, select the field that 
best corresponds to the first field in the Fields from file 
<filename> column, and click Add. 

Repeat this step until you have mapped all the fields from the 
source file to Maximizer fields.

To exclude a field from being 
imported into Maximizer, add 
<Skip Field> to the middle 
column for that field position.

For example, if the first field in the right column is First Name, 
select First Name from the Available Maximizer fields.

For fields that contain more than one value such as non-single 
valued table user-defined fields, and full/read access fields, each 

�

�
�

�
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value must be its own column in the file and the same field must 
be mapped to each of those items.

The fields listed in the Available Maximizer Fields column is 
slightly different, depending on whether you selected 
Companies / Individuals or Contacts as the Type of Import in 
step 3.

� To convert text that is in capital letters (uppercase) into mixed 
case, select the Convert to name case checkbox.

	 Many comma-delimited data files use the first line as a column 
header. To exclude the first line from being imported, select the 
Do not import first record; it is a header checkbox.

You can save the field 
mapping for reuse by clicking 
the Catalog button.


 Click Import.

The data from the source file now imports into Maximizer. 

��Repeat this procedure a second time to import the second tier, 
except select Contacts instead of Companies / Individuals as 
the Type of Import in step 3.

�

� 	 
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Importing from Other Contact Managers

The instructions below describe importing data from a contact 
manager other than ACT! or GoldMine. For information about 
importing from ACT! or GoldMine, refer to “Importing Data from 
ACT! and GoldMine” on page 301.

➤ To Import Contacts from another type of contact 
management database

Always back up the Address 
Book before importing.

� Select File > Import > Other Contact Manager Database.

The Import Databases dialog box opens.

� From the List files of type drop-down list, select the file format 
of the database you are importing.

� Locate the file you are importing. If the file is a network file, click 
the Network button or use the Drives drop-down list to access 
the network drive.

� In the Import Options group box, select the options you want 
to include. Depending on the type of database you are 
importing, some of these options may not be available.

� If you are importing a character delimited text file, you must 
specify a Date Format.

To do so, click the Date Format button, select the date format 
used in the source file, and click OK.

� If you are importing a .txt or .prn file, you must also specify the 
character used as the field Delimiter in the import file. 

Click the Delimiter button, select the delimiter type, and click 
OK.
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� In the Duplicate handling group box, select one of the options 
to specify what Maximizer should do when it encounters 
duplicate Address Book entries, and click OK.

The Select Fields for Import dialog box opens.

	 In the Contact fields or Address Book entries fields lists, 
select the field that best corresponds to the first field in the 
Fields from file <filename> column, and click Add. Repeat 
this step until you have mapped all the fields from the source file 
to Maximizer fields.

To exclude a field from being 
imported into Maximizer, add 
<Skip Field> to the middle 
column for that field position.

For example, if the first field in the right column is First Name, 
select First Name from the Contact fields or Address Book entries 
fields list.

Use Contact fields to create Contacts for Companies or 
Individuals.

Use Address Book entries fields to create Company or 
Individual Address Book entries.

�

�

�
�

�

�
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 Click Import to begin the import process.

Once Maximizer imports the data from the import file, the 
Conversion Completed or Import Completed message box 
displays the number of fields read, imported, skipped, failed, 
merged and the number of records with associated import 
warnings.

The Error Log appears next displaying the location of the import 
error message file. If you want to view this file, make a note of 
where it is located. Unless the import utility reports that all 
records were imported successfully, carefully review the 
ERRORLOG.TXT file to identify and resolve import problems. 
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Importing Data from ACT! and GoldMine

Duplicate Contacts are created 
on the second Import of the 
same ACT! or GoldMine 
database.

This section describes the procedure for importing data from ACT! or 
GoldMine, as well as the field mapping for data imported into 
Maximizer.

Importing Contacts from ACT! 6.0, 2004, or Earlier, or from GoldMine 6.5 or Earlier

➤ To import contacts from ACT! 6.0, 2004, or earlier, or 
from GoldMine 6.5 or earlier

Always back up your 
Maximizer Address Book 
before importing data.

� From the File menu, select Import > ACT! 6.0 or 2004 or 
earlier. 

– or –

Select Import > GoldMine 6.5 or earlier.

When importing GoldMine 
Contacts, GoldMine must be 
installed on the same machine 
as Maximizer; the Borland 
database engine is required 
during the import.

The Import Databases dialog box opens. The file type is selected 
for you automatically.

� Locate the file you are importing. If the file is a network file, click 
the Network button or use the Drives field drop-down list to 
access the folder.

� In the Import Options group box, select the Log Errors to File 
checkbox if you want to log any errors that occur during the 
import process to a text file. 

All other options in the Import Options group box are handled 
automatically by Maximizer.

� Specify how you want duplicate records handled, and click OK. 

If duplicate records are found in the data, the option you select 
here determines whether or not duplicate records are combined. 
They will be added to the Address Book.

Maximizer requires that each Address Book entry be assigned a 
unique Address Book entry ID. If the import record contains an 
Address Book entry ID that is the same as an existing Maximizer 
Address Book entry or Contact, the Address Book entry ID of the 
imported entry is automatically changed when that entry is 
added to Maximizer and this action is recorded in the import 
error message file.



Maximizer CRM
Administrator’s Guide

302

� Click OK to begin the Import process.

During the import process, a status indicator appears on the 
screen. Click Cancel if you want to halt the import process.

The Errorlog.txt file appears in 
the same folder as the import 
file. Unless the import utility 
reports that all records were 
imported successfully, carefully 
review the ERRORLOG.TXT file 
to identify and resolve import 
problems.

� Once the data is imported, the Conversion Completed or Import 
Completed message box displays the number of fields read, 
imported, skipped, failed, or merged, and the number of records 
with associated import warnings. Click OK to close the message 
box.

Importing from ACT! 2005–2012 or ACT! Premium for Workgroups 2005–2012

There are two methods of importing from an ACT! 2005–2012 
database. The first method explains how to import from ACT! when 
both ACT! and Administrator are installed on the same machine. The 
second method explains how to import from ACT! when ACT! and 
Administrator are on separate machines. 

➤ To import from ACT! 2005–2012 or ACT! Premium 
for Workgroups 2005–2012 – Primary Method

� Make sure you are logged into Windows as an administrator on 
the SQL Server machine. Also ensure no users are logged into the 
ACT! database.

� In Administrator, log into the Address Book where you want to 
import the ACT! database.

� In Administrator, select File > Import > ACT! 2005-2012 and 
ACT! Premium for Workgroups 2005-2012.

�

� �

�
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The Reattaching ACT! databases process may take several 
minutes.

� Select the ACT! database to import from the drop-down list, and 
click OK.

Maximizer imports the database. When the import is complete, 
it displays the Import Statistics dialog box.

� Click OK to close the dialog box.

The import is complete.

➤ To import from ACT! 2005–2012 or ACT! Premium 
for Workgroups 2005–2012 – Secondary Method

Always back up your 
Maximizer Address Book 
before importing data.

� Back up your ACT! database in ACT!.

The Backup is typically saved to C:\Documents and Settings\<User 
Name>\My Documents\ACT\ACT for Win 7\Databases\

� In the Backup folder, there should be a zip file. Open this zip file 
and extract the .BAK file that contains the name of your ACT! 
database in the filename.

� The extracted file is a SQL backup. Restore this backup to a 
normal SQL 2005 (or later) server.

See your SQL Server documentation for details on how to restore 
backups.

� Once the backup is restored, create a DSN to point to the 
database on the SQL Server. For instructions on creating a DSN, 
refer to the procedure below.

� Start Administrator.

� Open the Address Book to import the data into.

� Select File > Import > ACT! 2005-2012 and ACT! Premium 
for Workgroups 2005-2012.

	 Click OK on the message box.


 Click the Machine Data Source tab, select the DSN you created 
in step 4, and click OK.

You will be prompted for your sa password.

��Enter the sa password, and click OK.

Maximizer begins importing the data.
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➤ To create a DSN to point to the database on the SQL 
Server

� Open Control Panel > Administrative Tools > Data Sources 
(ODBC).

� Click the System DSN tab, and click the Add button.

� Select SQL Server, and click Finish.

� Give a meaningful name and description, select the SQL server 
where you placed the restored backup, and click Next.

� Select the With SQL Server authentication option, fill in the 
Login ID as sa, enter the sa password, and click Next.

� Select Change the default database to, select the restored 
ACT! database from the drop-down list, and click Next.

� Click Finish.

	 Click the Test Data Source button to make sure the DSN was 
configured correctly. 


 Click OK and then OK again to save the DSN.

Importing from GoldMine 6.7 Corporate Edition (or Earlier) SQL Databases

➤ To import from a GoldMine 6.7 Corporate Edition 
(or earlier) SQL database

Always back up your 
Maximizer Address Book 
before importing data.

� Start Administrator.

� Select File > Import > GoldMine 6.7 Corporate Edition or 
earlier.

� Click OK on the message box.

� Click the Machine Data Source tab, select the GoldMine DSN, 
and click OK.

You will be prompted for your sa password.

� Enter the sa password, and click OK.

Maximizer begins importing the data.
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Importing from GoldMine 8.x Premium Edition SQL Databases

Maximizer supports importing data from GoldMine 8.x Premium 
Edition with MSSQL or Firebird SQL.

➤ To import from a GoldMine 8.x Premium Edition SQL 
database

Always back up your 
Maximizer Address Book 
before importing data.

� If you are importing from GoldMine 8.x with Firebird SQL, 
convert the Firebird SQL database to MSSQL. You can convert 
the database in GoldMine 8.02 or later. (In GoldMine, select 
Tools > Database > New Databases.) For more information, 
see the GoldMine documentation.

� In Administrator, select File > Import > GoldMine Premium 
Edition 8.x.

� Click OK in the message box.

� Click the Machine Data Source tab, and select GoldMine DSN. 
Click OK.

You will be prompted for your sa password.

� Enter the sa password, and click OK.

Maximizer begins importing the data.

Setting User Passwords and Properties After Import

Note that if a user name contains spaces, the spaces are replaced 
with underscores, and the user names are shortened to 9 characters if 
necessary. After importing data, synchronize user passwords before 
imported users can log into Maximizer.

➤ To synchronize user passwords after import

� In Administrator, select Utilities > System Configurations.

� Click the Synchronize button. When synchronization is 
complete, all user passwords are “maximizer”.

➤ To set user passwords, preferences, and properties 
after import

� In Administrator, select File > Manage Users.

� Select the Maximizer user, and click Administer User.

The Administer User dialog box opens.
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� In the Administer User dialog box, set the user properties, 
preferences, password, and other settings.

For more information on these settings, see “User 
Administration” on page 96.

ACT! Data Conversion

The following table describes field mapping between ACT! and 
Maximizer. Before importing data into Maximizer, export the data 
from ACT! to a DBF file and use the DBF file for the import.

ACT! 2000 (5.0), 6.0, 
or 2004–2012 Maximizer Imported? Comments

Company Company Yes

Contact First Name & Last 
Name

Yes ACT! Contacts are imported as Contacts in 
Maximizer and the basic information about 
each Contact such as email address are 
imported into the Basic Info tab in the 
Address Book entry dialog box. If any of the 
information associated with the Contact 
cannot be mapped to a Maximizer field in 
this tab, the information is imported as 
user-defined fields. In ACT!, First and Last 
Name belong to the same single field. The 
correct names may not be properly 
imported into Maximizer. For example, a 
Contact ‘Toni Spooner (female)’ in ACT! is 
imported into Maximizer as “Toni 
Spooner” in the First name field and 
“(female)” in the Last name field. 

Title Position Yes

Department Department, 
Position

Yes In Maximizer, Department is populated 
with the Department information of the 
first Contact and the rest in the Position 
field separated by comma.

Phone Phone 1 Yes Adds “Business” to the Phone Description 
field in Maximizer.

Fax Phone 2 Yes Adds FAX to Extension field in Maximizer.

Toll-Free Phone 3 Yes Adds “Toll-Free” to the Phone Description 
field in Maximizer.

Mobile Phone 4 Yes Adds CELL to Extension field in Maximizer.

Alt Phone No

Ticker UDF Ticker Symbol Yes Adds UDF to Company.
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ID/Status Category Yes

Address Address Yes First address line in ACT! is imported as 
Address 1 in Maximizer. Second line goes to 
Address 2. Address comes from one of the 
Contacts for this Company and if there is no 
address, it may end up empty. Alternate 
addresses are added to Maximizer from 
different Contacts of the Company and 
alternate addresses are named by that 
Contact. The same address is not added but 
renamed by the other Contact. For some 
Contacts, the appropriate alternate address 
may not be selected. 

Address Division Division in Maximizer may be populated by 
the address line in ACT!.

City City/Town Yes Imported correctly to main and alternate 
addresses.

State St/Co/Prov Yes Imported correctly to main and alternate 
addresses.

Zip Zip/Postcode Yes Imported correctly to main and alternate 
addresses.

Country Country Yes Imported correctly to main and alternate 
addresses.

Salutation Salutation Yes

Referred By UDF Referred By Yes Adds UDF to Company.

Web Site Website Yes Imported into the Company’s website field.

E-mail Address Email Yes Imported into the Contact’s email field.

Last Result Creates Table UDF 
named “Result”

Yes Adds Company Table UDF with 
corresponding items selected for each 
Contact.

Assistant No

Asst. Title No

Asst. Phone No

User fields for 
Contacts and 
Companies
(ACT! 2005–2012 & 
ACT! 2005–2012 
Premium only)

Creates UDFs for 
Contacts and 
Companies with the 
same name as in the 
source database

Yes These fields can be renamed and can be 
changed to different field types. Any fields 
that are of MEMO type or are more than 
120 Characters are converted to Notes in 
Maximizer.

ACT! 2000 (5.0), 6.0, 
or 2004–2012 Maximizer Imported? Comments
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GoldMine Data Conversion

The following table describes field mapping between GoldMine and 
Maximizer.

User 1...User 15
(ACT! 2000 (5.0), 6.0, 
or 2004 only)

Creates UDFs named 
“Details Field 1”… 
“Details Field 15”

Yes Adds UDFs to Company. Some UDFs that 
belong to some different Contacts in ACT! 
may be lost.

Users Users Yes ACT! users are imported into Maximizer as 
users. Passwords are set to “maximizer” if 
the import was done using a DBF file. Users 
are displayed in the Administrator’s 
Manage Users dialog box which may be 
accessed by selecting File > Manage Users. 
If a user name contains spaces, the spaces 
are replaced with underscores, and the user 
names are shortened to 9 characters if 
necessary.
Password synchronization from Utilities > 
System Configurations menu is necessary 
before any imported user is able to log into 
Maximizer. Passwords are then set to 
“maximizer”.

Notes Notes Yes

Schedule Call
Schedule To-do
Schedule 
Appointment
Schedule Personal 
Activitiy

Hotlist Task Yes The Company name of some conflicting 
tasks may not be preserved.
The Duration information in ACT! is not 
imported to Maximizer.

Schedule Meeting Appointments Yes Recurring appointments are not imported.

Notes Attachments Notes Attachments No

Document Document No

Groups Groups No

Sales/
Opportunities

Opportunities No

History
(ACT! 2005-2012 & 
ACT! 2005-2012 
Premium only)

Notes Yes Each entry from the History tab in ACT! 
becomes a Note in Maximizer. 

ACT! 2000 (5.0), 6.0, 
or 2004–2012 Maximizer Imported? Comments
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Note that Action, Call, and Appointment notes in GoldMine 6.x and 
8.x may be in HTML format. When you import these notes into 
Maximizer, they contain HTML tags. 

GoldMine 5.x, 
6.x, & 8.x Maximizer Imported? Comments

Company Company Yes

Contact
First Name Initial 
Last Name

First Name Initial 
Last Name

Yes GoldMine’s Contact field contains (First Name) 
(Initial) (Last Name) separated by spaces. In 
Maximizer, appropriate fields are populated 
accordingly. 

Title Position Yes

Dept Dept. Yes In Maximizer, Dept. is populated with the 
department of the main Company’s Contact.

Asst Assistant (UDF) Yes Adds UDF to Contact record.

Source Contact type (UDF) Yes Adds UDF to Contact record.

Address Address1 & Address2 Yes Address from the main Contact becomes the 
main Company address. The first line in the 
Address field from GoldMine goes to Address1 
in Maximizer. The second line goes to 
Address2. The third line from GoldMine is NOT 
imported.
Alternate Addresses in Maximizer are created 
from the addresses of the Contact from the 
Contacts tab in GoldMine. Appropriate 
Alternate Addresses are selected for imported 
Contacts.

City City/ Town Yes Imported correctly to main and alternate 
addresses.

State St/Co/Prov Yes Imported correctly to main and alternate 
addresses.

Zip Zip Yes Imported correctly to main and alternate 
addresses.

Country Country Yes Imported correctly to main and alternate 
addresses.

Phone 1-3 Phone 1-3 Yes Appropriate extensions are imported.

Fax Phone 4 Yes Adds FAX to Extension field in Maximizer.

E-mail Email Yes Email address of the main Contact is imported.
Email addresses of Contacts from the Contacts 
tab in GoldMine are also imported.

Web Site Website Yes Imported to main Contact record.

Contact Type Contact Type Yes Adds UDF to Contact record.



Maximizer CRM
Administrator’s Guide

310

Business Business Yes Adds UDF to Contact record.

Interest Interest Yes Adds UDF to Contact record.

Accnt Mngr Accnt Mngr Yes Adds UDF to Contact record.

Open Open Yes Adds UDF to Contact record.

Summary Note Yes A note containing details from the Summary 
tab is created for the Company.

Role
Status
Account Type
Account Size
No. of Users
Key Interest
Competitor
Platform

User role
Purchase Status
Account Type
Account Size
Users
Key Interest
Competitor
Platform

Yes Appropriate UDFs are created in Maximizer 
and populated with proper values.

Notes Note Yes A note is created for the Contact in Maximizer 
and contains all the notes from the Notes tab in 
GoldMine.

Documents Document No

Users Users Yes GoldMine’s users are imported into Maximizer 
as users. Users are displayed in the 
Administrator’s Manage Users dialog box, 
which is accessible through the 
File > Manage Users menu. 
If spaces are included in a user name, the 
spaces are replaced with underscores, and the 
user names are shortened to 9 characters if 
necessary.
After import, users’ Windows Access, Web 
Access, and Mobile Access are disabled in 
Maximizer and must be enabled by the 
administrator.
Password synchronization from Utilities menu > 
System Configurations is necessary before any 
imported user is able to log into Maximizer. 
Passwords are then set to “maximizer”.

Details Notes Yes For every detail, a note is created. Details are 
referred to as Profiles in the notes.

Pending Hotlist Task Yes Each entry from the Pending tab in GoldMine is 
imported as Hotlist task in Maximizer.

Calendar Hotlist Tasks Yes Calls and Activities from GoldMine’s Calendar 
are imported as Hotlist tasks in Maximizer.

GoldMine 5.x, 
6.x, & 8.x Maximizer Imported? Comments
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Field Mapping for Outlook

The following table describes the field mapping that is used in 
Outlook Synchronization.

Referrals Notes Yes A note is created for every Referral. Referrals 
are called References.

History Notes Yes Each entry from the History tab in GoldMine 
becomes a Note in Maximizer. 

Members  No

Tracks No

Links No

Opptys No

Projects No

Partner Notes Yes Limited information is imported.

Email text (email) Documents Yes Imports email as documents in the Documents 
window. This feature is supported for 
GoldMine 8 only.

GoldMine 5.x, 
6.x, & 8.x Maximizer Imported? Comments

Microsoft Outlook Maximizer

Appointments

Subject Subject

Start and End time date Date

Start time Start time

End time End time

Reminder Alarm time

Toggle alarm Toggle alarm

Importance Priority

Private Private

Location Location

Note (text box) Note (text box)

Tasks

Due date Date



Maximizer CRM
Administrator’s Guide

312

Alarm time Time

Subject Activity

End time End time

Reminder set Alarm set

Priority Priority

Private Private

Microsoft Outlook Maximizer
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Moving an Address Book to a Different Server
This section explains how to move a Maximizer Address Book from 
one SQL Server computer to another. These instructions assume you 
already have knowledge in administering SQL Server. These 
instructions are written for SQL Server 2005. The instructions are 
similar for other versions of SQL Server.

The following sections describe how to move an Address Book to a 
different server:

• “Step 1: Back Up the Address Book” on page 313

• “Step 2: Restore the Address Book on the New Server” on 
page 316

• “Step 3: Create the MaConfig Table” on page 321

• “Step 4: Connect to the Address Book in Administrator” on 
page 322

• “Step 5: Delete Existing Users from the Address Book” on 
page 323

• “Step 6: Grant the MASTER User Access to the Database” on 
page 326

• “Step 7: Synchronize Maximizer Users with SQL Server” on 
page 327

• “Step 8: Apply Maximizer Licenses” on page 327

Step 1: Back Up the Address Book

➤ To back up the database on the source server using 
SQL Server Management Studio

� Start SQL Server Management Studio (Start > Programs > 
Microsoft SQL Server 2005 > SQL Server Management 
Studio) on the source server.

� Navigate to the Databases folder:

� Right-click the Maximizer database to move, and select Tasks > 
Back Up from the shortcut menu.

The Maximizer database has 
the same name as your 
Address Book.

The Back Up Database dialog box opens.

� In the Backup type drop-down box, select Full.

� In the Backup component area, select Database.
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� Click Remove until the Destination box is cleared. Then, click 
Add.

The Select Backup Destination dialog box opens.

� Leave the File name option selected and click the ellipsis.

The Locate Database Files dialog box opens 

	 Use the default location, or browse to an alternate location to 
save the backup file.

�

�
�

�
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 Enter a File name for the backup file, and click OK.

��Click OK to close the Select Backup Destination dialog box.

��Click Options.

��Select the Back up to the existing media set option, then 
select the Overwrite all existing backup sets option.
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��Click OK.

The backup process begins.

Step 2: Restore the Address Book on the New Server

➤ To restore the database to the destination server 
using SQL Server Management Studio

� Copy the backup file from the source server to the destination 
server.

� Start SQL Server Management Studio (Start > Programs > 
Microsoft SQL Server 2005 > SQL Server Management 
Studio) on the destination server.

� Navigate to the Databases folder:

� Right-click the Databases folder and select New Database.

��

��

��
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� Enter the Name of the database, and click OK.

The database can use the same name as the Address Book on the 
source server, or it can use a different name. The extra step for 
changing the database name is explained in step 15.

� Right-click the new database and select Tasks > Restore > 
Database.

The Restore Database dialog box opens.

�

�
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� Select the From device option, and click the ellipsis button.

The Specify Backup dialog box opens.

	 Click Add.

The Locate Backup File dialog box opens.


 Browse to the folder where you saved the backup and select the 
file. If necessary, select All Files in the Files of type drop-down 
list.

� �
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��Click OK.

��Click OK to close the Specify Backup dialog box.

The backup file is added to the list of backup sets.




��
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��Select the checkbox beside the name of the new backup file.

��Click Options.

��Select the Overwrite the existing database option.

NOTE: SQL Server databases consist of a primary data file and a 
transaction log file. For example, if a database is named 
“Maximizer”, the data file will be named Maximizer_Data.MDF. 
This file contains the startup information and data for the 
database. The corresponding log file will be named 
“Maximizer_Log.LDF”. This file logs all transaction information 
since the last backup and is used to recover the database. There 
must be at least one log file for each database.

It is strongly recommended that the transaction log be stored on 
a separate drive from the primary data file.

��If the database from the source server and the database on 
the destination server have the same name and have been 
installed in the same physical path, skip to the next step.

– or –

If the name of the new database is different from the original, 
change the database name in the Restore As fields: 

• OriginalName_Data.mdf to NewName_Data.mdf

• OriginalName_Log.mdf to NewName_Log.ldf

��
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Do not change the original file 
names.

Example:
If the name of the Address Book on your old server was 
“EsconaTutorial”, the “Restore As” column shows as 
[BackupFileLocation]\EsconaTutorial_Data.MDF for the primary 
data file and [BackupFileLocation]\EsconaTutorial_Log.LDF for 
the transaction log file. If you renamed the database to 
“EsconaBackup” on your new server, then the “Restore As” 
column must be changed to 
[BackupFileLocation]EsconaBackup_Data.MDF and 
[BackupFileLocation]EsconaBackup_Log.LDF.

��Click OK.

The Restore process begins.

Step 3: Create the MaConfig Table

This process must be 
completed to successfully 
transfer the database to a new 
server. 

Install the Maximizer server on one machine to create the MaConfig 
table. For instructions, refer to “Installing Maximizer CRM Server” on 
page 47.

You must install Maximizer CRM Server to create the MaConfig 
(Address Book configuration) table. However, you do not have to 
install it on the new server. You can install it on any machine in your 
network. 

During the Maximizer CRM installation process, you will see the 
Microsoft SQL Server Name screen, which prompts you to select the 

��

��

��

��
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SQL Server that Maximizer will use to host its system configuration 
database (MaConfig). By selecting the SQL server where you just 
restored the Address Book database, you will cause the installation 
to create the MaConfig database on that server. 

After the installation completes, you can verify that the MaConfig 
table was created by launching SQL Sever Management Studio and 
navigating to the Databases folder. You should see the MaConfig 
database listed there.

Step 4: Connect to the Address Book in Administrator

At this point, the SQL database is located on the new server, but it is 
not yet connected to Maximizer as an Address Book.

➤ To connect Maximizer to the newly restored 
Database

� Open Administrator (Start > Programs > Maximizer CRM > 
Administrator).

� Select File > New Address Book.

� Select the SQL Server from the Database server drop-down list, 
and click Next.

� Enter the SQL Server administrator login credentials, and click 
OK.

� Select the Employ an existing Maximizer database option.

�
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� Select the restored SQL database from the Database name 
drop-down list, and click Next.

� Click Start.

	 If prompted for the MASTER user’s password, click Cancel.

Maximizer begins connecting to the restored database. This 
process may take a few minutes. When the process is complete, 
the Start button changes to Close.


 Click Close.

Step 5: Delete Existing Users from the Address Book

This procedure removes any existing user accounts from the database 
that may conflict with user accounts in the Maximizer Address Book.

�

�

�
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➤ To delete existing users from the restored Address 
Book

� In SQL Server Management Studio, navigate to the Console 
Root.

� Right-click the SQL Server and select Properties.

� Click Security.

� Select the Allow direct updates to system tables option, and 
click OK.

� Navigate to the Databases folder.

� Right-click the new database, and select New Query.

A new tab opens for your query.

�

�



Chapter 13
Managing Address Book Data

325

� Enter the following SQL query into the Query Window (replace 
[yourDatabase] with the name of your SQL database):

DECLARE @NM AS varchar(40), @CMD AS varchar(200), @DB 
varchar(40)

SET @DB = '[yourDatabase]'

DECLARE SCHEM CURSOR GLOBAL SCROLL STATIC READ_ONLY

FOR SELECT [name] FROM sys.schemas

WHERE principal_id IN (SELECT principal_id FROM 
sys.database_principals

WHERE [type] = 'S' AND principal_id > 4)

OPEN SCHEM

FETCH FIRST FROM SCHEM INTO @NM

WHILE @@Fetch_Status = 0 BEGIN

SET @CMD = 'USE ' + @DB + ' DROP SCHEMA ' + @NM
EXEC (@CMD)

FETCH NEXT FROM SCHEM INTO @NM

END

CLOSE SCHEM
DEALLOCATE SCHEM

DECLARE PRINCIP CURSOR GLOBAL SCROLL STATIC READ_ONLY
FOR SELECT [name] FROM sys.database_principals
WHERE [type] = 'S' AND principal_id > 4

OPEN PRINCIP

FETCH FIRST FROM PRINCIP INTO @NM
WHILE @@Fetch_Status = 0 BEGIN
SET @CMD = 'USE ' + @DB + ' DROP USER ' + @NM
EXEC (@CMD)

FETCH NEXT FROM PRINCIP INTO @NM
END

CLOSE PRINCIP
DEALLOCATE PRINCIP

	 Click the Execute button on the toolbar

The query executes against your database.


 Close the SQL Query tab.
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Step 6: Grant the MASTER User Access to the Database

➤ To grant the MASTER user access to the database

� In SQL Server Management Studio, navigate to the Security > 
Logins folder.

� Right-click MASTER, and click Properties.

When you install Maximizer, the MASTER password is set to 
control. You must change the password so that it matches the 
MASTER password on the original server.

� In the Password field, enter the MASTER password on the 
original server. In the Confirm password field, re-enter the 
password.

� From the Default Database drop-down list, select the restored 
Address Book.

� Click User Mapping.

� Select the checkbox beside the new database name to give 
MASTER access to it.

� In the Database role membership section, verify that public 
and db_owner are selected for the database, and click OK.

�

�

�
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Step 7: Synchronize Maximizer Users with SQL Server

This step recreates the Maximizer users in the SQL database. Any 
Maximizer users who did not previously exist in the new SQL 
database will be created in the SQL database. However, if the users 
already exist in the SQL database, their passwords in the Maximizer 
Address Book being synchronized will overwrite their existing SQL 
database passwords. As a result, when those users subsequently log 
into a pre-existing Address Book on that SQL Server, their SQL 
passwords will not match their Maximizer Address Book passwords, 
and they will be prompted to provide both passwords. Those users 
should then change their passwords in the other Maximizer Address 
Books to match their new SQL database password.

➤ To synchronize Maximizer users with SQL Server

� Log in to the new Address Book in Administrator. 

� Select Utilities > System Configurations.

� Click Synchronize.

� When synchronization is complete, click Close.

� Verify that the users were synchronized to SQL Server by 
opening SQL Server Management Studio and navigating to the 
Security > Users folder for the database.

You should now see the users of your restored database. If not, 
press F5 to refresh the screen.

Step 8: Apply Maximizer Licenses

Apply Maximizer licenses. For instructions, refer to “Installing 
Licenses” on page 66.
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Purging Outdated Notes and Documents
After a long period of activity, you may want to delete outdated 
notes and documents using Administrator’s purge feature.

When you purge notes, you must specify the note types to delete.

The purge command deletes all notes, with the exception of other 
user’s private notes (unless the user purging the notes has rights to 
delete other users’ notes), in the specified date range for all Address 

Note Type Creation Method

Accounting Created from accounting transactions. Applicable 
only to previous versions of Maximizer.

Customer 
Service

Notes created in the Address Book window when 
you add a case.

Email Notes created in the Address Book window when 
you send an email to one or more Address Book 
entries. Email notes are also created when you 
launch a campaign.

History Created when opportunities cases, or campaigns are 
added or changed. History notes can be printed or 
searched only from these windows.

Incoming call Created when you receive a phone call.

Mail-out Created when users print labels, envelopes, or letters 
using the Maximizer Word Processor's merge 
feature. Mail-out notes are also created when users 
send an email to more than one Address Book entry.

Manual Added manually to the Notes window.

Opportunity Created in the Address Book window when 
opportunities are added or changed. Opportunity 
notes can be printed or searched only from the 
Address Book window.

Other Third-party or custom notes created by the 
administrator. 

Outgoing call Created when phone an Address Book entry.

Tasks Created when appointments or Hotlist tasks are 
scheduled or completed.

Timed notes Created when the Timer is used while writing a note.

Transfer log Notes logged when Address Book entries are 
transferred between Address Books. Applicable only 
to previous versions of Maximizer.
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Book entries in the open Address Book. You should back up the 
Address Book before purging notes.

➤ To purge notes

� In Administrator, open the Address Book you want to clean up.

� Select File > Purge > Notes.

� Specify a date range. 

Maximizer deletes notes dated between the specified dates.

� Select the type(s) of notes to delete, and click OK.

➤ To purge documents

� In Administrator, open the Address Book you want to clean up.

� Select File > Purge > Documents.

� Specify a date range. 

Maximizer deletes documents dated between the specified 
dates.

� If you want to purge private documents belonging to other 
users, select the Delete other users’ private documents 
option.

� Click OK.
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Using Log Files for Diagnosis
One of the most powerful tools in diagnosing a Maximizer 
installation is the automated logging feature. Maximizer supports 
logging for a number of server and client components.

You can control the amount of detail that is logged for various 
modules. The range of logging levels is 0 through 7:

• 0 = logging disabled

• 1 = least detailed

• 7 = most detailed

You can also control the frequency in which the log files are purged 
and if the information is sent to the Windows event log. 

Logs are written into the default folder “\Program 
Files\Maximizer\Logs”. You can define logging preferences in 
Administrator and Maximizer. These preferences control the 
following registry keys.

➤ To set logging preference values

� In Maximizer, click the Setup tab and select Preferences. In 
Administrator, select File > Preferences.

� Select the Diagnostic tab.

If you want logs for all modules saved in one specific location, 
specify a default folder where your log files will be saved. If you 
don’t specify a location in this field or a location per module, 

Email Service 
(CMGR-
Email)

HKEY_LOCAL_MACHINE\SO
FTWARE\
Maximizer 
Software\Maximizer\
Modules\AutoProgService\E
mail

CMGR-
Email_yyyymmdd.log
CMGR-
Service_yyyymmdd.log

PrintFax 
Service 
(CMGR-
PrintFax)

HKEY_LOCAL_MACHINE\SO
FTWARE\
Maximizer 
Software\Maximizer\
Modules\AutoProgService\P
rintFax

CMGR-
PrintFax_yyyymmdd.log
CMGR-Print-
Service_yyyymmdd.log

MaAccess 
(MACC)

HKEY_LOCAL_MACHINE\SO
FTWARE\
Maximizer 
Software\Maximizer\
Modules\MACC\EVENTLOGS
ETTINGS

MACC_yyyymmdd.log
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logs are saved in the Logs folder where Maximizer is installed 
(e.g., Program Files\Maximizer\Logs). 

� Select a module from the Preferences for this module drop-
down list.

� If you want logs related to a module saved in a specific location, 
specify a folder in the Module log folder field. 

� Select a logging detail level from the Maximizer log level 
drop-down list.

� Set your other logging preference values such as the frequency 
logs are purged. By default, logs are purged after 5 days. 

� Repeat the previous steps to configure logging for any other 
module(s).

	 Click OK.


 If you changed the log settings for the Email Service (CMGR-
Email) or PrintFax Service (CMGR-PrintFax), you must restart 
the service(s) for the changes to take effect.

Restart these services from Windows Control Panel > Services.

For samples and explanations of Maximizer Email Service log files, 
see “Maximizer Email Service Log Files” on page 352.



Maximizer CRM
Administrator’s Guide

332

System Reports
HTML reports can be opened 

easily in Microsoft Excel, 
where you can edit the data as 
required.

The Reports menu in Administrator enables you to quickly create a 
number of reports about the open Address Book, as described below.

Report Information Reported

User ID List • Total number of users in the Address 
Book

• Total number of security groups in the 
Address Book

For each user in the Address Book:

• User ID
• Display Name

• First and Last Name
• Phone number
• Email Address

• Maximizer Login Enabled/Disabled status
• User’s Roles (Access Rights)
For each security group in the Address Book:

• Group Name
• Group ID
• Group members

User-Defined Fields • Folder (if applicable) and field name

• Type of entry the field is applicable to 
(Company, Individual, Contact, 
Opportunity, Campaign, Case, or User)

• Full Access and Read Access
• Type (Table, Date, Alphanumeric, 

Numeric, Formula, Yes/No)

• Creator
• Requested by
• Description

• Attributes
• Items in table user-defined fields
• Usage count (only if Show Usage Count 

checkbox selected in Print Report dialog 
box)
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Address Book Summary Total number of each of the following types 
of entries in the current Address Book:

• Users
• Security groups
• Companies and Individuals

• Lowest, highest, average, and total 
number of contacts per Company and 
Individual

• Opportunities (total and per status)
• Automated campaigns (total and per 

status)

• Traditional campaigns (total and per 
status)

• User-defined fields (total and per type)
• User-defined field entries (total and per 

type)

• Notes
• Documents
• Knowledge base articles (total and per 

status)

• Customer service cases (total and per 
status)

Sales/Marketing Teams Details about teams and team members, 
sorted by Team Type (Sales or Marketing)
• Team name
• Member user ID

• Member name
• Member status (member or team leader)

Report Information Reported
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Installed Workstations Details about any Maximizer workstation 
that has connected to the current Address 
Book on the current server:

• Name of the Maximizer workstation 
machine

• Module used to connect to the server 
(Administrator, Maximizer, etc.)

• Date and time when the module 
connected to the server

• Maximizer version, series, and build of 
the module

This report applies only to previous versions of 
Maximizer.

Current Users • Number of licenses in use
For each user currently logged into the 
Address Book:

• User name
• Computer name
• Date and time logged in

• Maximizer module connected
Licenses installed:
• Product license number (PLN)

• Computer name
• Product
• User count

• Description
• Total number of applied licenses
This report displays on-screen rather than printing. To 

print the report, press Alt and Print Screen to capture 
the report window to the Windows clipboard, and then 
paste it into a word processor or graphics program.

Report Information Reported
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Recreating the Maximizer_Default User
The maximizer_default security login is created during the initial 
installation of Maximizer.

The following are steps to recreate the Maximizer_Default user if it is 
not in the list of security logins in SQL.

➤ To create the maximizer_default security login

• Select Utilities > Repair Database.

Resolving Issues with SQL Server
All of the data required for Maximizer is stored in a Microsoft SQL 
Server database. Many of the problems encountered in Maximizer 
environments are related to the inability to access and authenticate 
the SQL Server. The following are some of the methods and tools 
that can be used to troubleshoot potential issues with SQL Server.

The following sections contain information on troubleshooting 
issues with SQL Server:

• “Testing the SQL Server Connection” on page 336

• “Confirming the Validity of the SQL Server Account” on 
page 338

• “Windows Authentication with Maximizer and SQL Server” on 
page 339

• “Connecting Maximizer Services to SQL Server” on page 339

• “Running DBCC on a Maximizer Database” on page 340

• “Missing Users” on page 340

• “Using Non-Default Database Collations” on page 341

Testing the SQL Server Connection

All Maximizer components connect to a Maximizer Address Book 
that is hosted by Microsoft SQL Server. When using the TCP/IP port 
for SQL Server, the connection(s) are established on TCP port #1433. 
If any component is unable to connect to this server, it will not 
operate correctly. There are some simple procedures that can be used 
to confirm that the connection can be established.
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Using the Telnet Utility to Access the SQL Port

The Telnet client utility is installed by all Windows operating systems. 
This utility is typically used to enable remote access to a host server. 
This tool, however, can be used as a quick means to test any TCP port 
that can be connected to remotely.

The following are the steps required to test the connection to the 
SQL Server port:

➤ To test the connection to the SQL Server port using 
the Telnet utility

You can combine these steps 
into a single command in the 
Run dialog box: telnet <IP 
address> 1433.

� From the Start menu select Run.

� Type telnet in the Run dialog box, and press Enter. Windows 
Telnet opens.

� Select Connect > Remote System.

The Connect dialog box opens.

� Enter the host name or IP address of the Windows Server that is 
running SQL Server.

� In the Port box, enter port number 1433, and click Connect.

If the connection to the SQL Server is successful, the Disconnect 
command will be enabled on the Connect menu. If the 
connection is unsuccessful, Telnet displays a “Connect Failed” 
message.

Using NETSTAT to Confirm Connections

From a command prompt, issue the following command:

NETSTAT -N

The following information should be returned:

Proto    Local Address       Foreign Address       State

TCP      xxx.xxx.xxx.xxx:xxxx     xxx.xxx.xxx.xxx:xxxx      
ESTABLISHED

It's likely that more than one 
connection on this port will be 
reported.

If the state is only reported as “TIME_WAIT” and never as 
“ESTABLISHED”, the connection is not being successfully made.
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Confirming the Validity of the SQL Server Account

The server components of Maximizer connect to the Maximizer SQL 
Address Book through two accounts, WEBUSER and EMAILUSER, that 
use standalone security. If the account listed in this file can't be 
authenticated by the SQL Server, the server components fail. There is 
a simple procedure that can be used to confirm the validity of a SQL 
user account.

➤ To confirm the validity of a SQL user account

� In the Windows Control Panel, open ODBC Data Sources.

� In the ODBC Data Sources Administrator dialog box, click the 
System DSN tab.

� Locate the MA_SQL_<SERVER_NAME>_<Address 
Book_NAME> entry, and click the Configure button. The 
Microsoft SQL Server DSN Configuration wizard starts.

� Ensure that the correct Windows server name is displayed in the 
Server box, and click Next.

� Select the With SQL Server authentication using a login ID 
and password entered by the user option.

� Enable the checkbox Connect to SQL Server to obtain 
default setting for the additional configuration options.

� In the Login ID field, enter the account name.

	 In the Password field, enter the account password, and click 
Next.

If any of the account information is incorrect, a “connection 
failed” warning is shown; otherwise, the next screen is displayed.


 Click Next to advance to the next screen, and click Finish.

��In the final screen, click the Test Data Source button to test 
the connection.

If the test is successful, the following information is displayed:

Running connectivity test…

Attempting connection
Connection established
Verifying option settings
Disconnecting from the server

TEST COMPLETED SUCCESSFULLY!
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Windows Authentication with Maximizer and SQL Server

When Windows Authentication is specified as the means of user 
authentication during the installation, all new Address Books created 
use Windows Authentication. You can modify this setting on a per 
Address Book basis in the MaConfig table. You can also modify the 
global setting for Windows Authentication. In addition, you must 
change the Windows Authentication registry key in the Windows 
Registry on the computer where SQL Server is installed.

➤ To modify the Windows Authentication MaConfig 
setting for an Address Book

� In SQL Server Management Studio, open the MaConfig table.

� For the Address Book, change the USE_NT_AUTHENTICATION 
key to Yes to use Windows Authentication and Null or No if you 
want to use SQL Server Authentication.

➤ To modify the Windows Authentication MaConfig 
setting globally

� In SQL Server Management Studio, open the MaConfig table.

� Change the global USE_NT_AUTHENTICATION key to Yes to use 
Windows Authentication and Null or No if you want to use SQL 
Server Authentication.

➤ To modify the Windows Authentication registry key

� Click Start > Run.

� Type regedit and click OK.

� Navigate to HKEY_LOCAL_MACHINE/SOFTWARE/Maximizer 
Software/Maximizer/Common/Sys.

� Double-click Windows Authentication.

� Enter 1 to use Windows Authentication, or enter 0 to use SQL 
Server Authentication. Click OK.

� Close the Registry Editor.

Connecting Maximizer Services to SQL Server

The Maximizer Email Service and the Maximizer Print/Fax Service 
must be able to log in to the SQL Server. If Windows Authentication 
is used to log in to SQL Server, a Windows account that has access to 
the SQL Server must be provided to the Maximizer Email Service and 
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the Maximizer Print/Fax Service. The Windows Authentication option 
and the user credentials are specified during installation. If necessary, 
you can modify the user credentials for a Maximizer service after 
installation.

➤ To modify user credentials for a Maximizer service

� On the Windows Control Panel, select Administrative Tools > 
Services.

� Right-click on Maximizer Email Service or Maximizer Print/
Fax Service, and select Properties.

� In the Properties dialog box, select the Log On tab.

� Select This account.

� Enter the Windows domain and the user credentials for a 
Windows account that has access to both the Maximizer server 
computer and the SQL Server. Click OK to save the changes.

� Restart the service.

Running DBCC on a Maximizer Database

Running DBCC on a Maximizer SQL Server database may fail with the 
following error message:

DBCC failed because the following SET options have incorrect 
settings: 'QUOTED_IDENTIFIER, ARITHABORT'.

This error message may occur when you run DBCC explicitly, or when 
DBCC runs as part of a maintenance plan created using the SQL 
Database Maintenance Plan Wizard.

This error message occurs because Maximizer databases have indexes 
on computed columns. However, this error message is not the result 
of a problem with Maximizer. This behavior is by design in SQL 
Server.

For information about working around this issue, refer to Microsoft 
Knowledge Base Article 301292, which is available at the following 
URL:

http://support.microsoft.com/kb/301292

Missing Users 

In most situations, if you have missing users the SQL database, it is 
due to incorrectly moving a SQL database. Refer to “Moving an 
Address Book to a Different Server” on page 313 for more 
information.
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Using Non-Default Database Collations

If you experience problems using a database collation other than the 
default SQL_Latin1_General_CP1_Ci_AS, ensure the Auto Translate 
setting is turned off on the SQL Server with the database.

➤ To turn off Auto Translate

� Log in to the SQL server as a user with rights to Insert records in 
the MaConfig database.

� Run the following query:

insert into MaConfig (eFile,eSection,eKey,eValue) values 
('','Global Settings','AUTO_TRANSLATE','no'), 
('','DatabaseName','AUTO_TRANSLATE','no')

Note: DatabaseName is the name of the Maximizer database.
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Troubleshooting Issues with Automated Campaigns
Use this section to troubleshoot potential issues with automated 
campaigns.

The following sections contain information on troubleshooting 
issues with automated campaigns:

• “Dropped SQL Server Connection” on page 342

• “SMTP Time-out Error” on page 342

• “Email Messages Use Wrong Character Set” on page 343

• “Campaigns Remain “In Progress” without Activity” on page 343

Dropped SQL Server Connection

The issue describes how to troubleshoot a dropped SQL Server 
connection for automated campaigns. 

SMTP Time-out Error

This issue describes SMTP time-out errors in automated campaigns. 

Problem The connection to the SQL Server is lost.

Symptom The Maximizer Email Service stops.

Resolution Re-establish a connection to the SQL Server and start 
the Maximizer Email Service manually from the 
Services window in the Windows Control Panel.

Problem For some subscribers, an automated campaign fails 
due to Time_out, and you are sure the subscriber's 
email address is valid.

Symptom A Time_out message displays in the notes of the 
affected campaign and Address Book entry.

Resolution Verify that the subscriber’s email address is valid. If it 
is valid, then increase the SMTP_TIMEOUT value. You 
can find the SMTP_TIMEOUT value in the MaConfig 
table Global Settings section. The default value for 
SMTP_TIMEOUT is 100 (seconds). You can increase it 
to 500, 1000...n.
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Email Messages Use Wrong Character Set

This issue affects email messages sent by automated campaigns using 
the wrong character set    

Campaigns Remain “In Progress” without Activity

This issue is a problem with campaigns remaining “In Progress” 
without any activity.

➤ To change the EMAILUSER password

� In Administrator, select File > Manage Users.

� Select EMAILUSER, and click Password.

� Type EMAILSYSTEM in the New Password and Confirm 
Password fields, and click OK.

Maximizer prompts you to apply the new password across all 
databases.

� Click Yes to synchronize passwords.

Problem Email messages sent by Maximizer Email Service use 
the wrong character set, ignoring the regional 
settings on a user’s computer.

Symptom Email messages sent by automated campaigns are 
illegible.

Resolution In Administrator, configure the Maximizer Email 
Service to use the correct character set. For more 
information, see “Configuring Email” on page 176.

Problem If the password for EMAILUSER is not synchronized, 
automated campaigns do not function properly.

Symptom A campaign’s status is “In Progress” but it is inactive 
and does not send out emails, faxes, or print jobs.

Resolution Change the EMAILUSER password to EMAILSYSTEM 
(which is the default), synchronize passwords, and 
restart the Maximizer Email Service and Print/Fax 
Service.
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➤ To restart the Maximizer Email and Print/Fax 
Services

� Select Start > Programs > Administrative Tools > Services to 
open the Services window.

� Double-click Maximizer Email Service.

� Click Stop.

� Click Start to restart the service.

� Double-click Maximizer PrintFax Service.

� Click Stop.

� Click Start to restart the service.

	 Click OK.
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Resolving Issues with Microsoft IIS
The following sections contain information on troubleshooting 
potential issues with Microsoft IIS:

• “Configuring Maximizer Web Access on a 64-bit Operating 
System” on page 345

• “Maximizer Components for IIS and Windows Server 2008 or 
2012” on page 345

• “Resolving DSN Creation Problems on a Maximizer Web Server” 
on page 347

Configuring Maximizer Web Access on a 64-bit Operating System

This issue affects computers running Maximizer Web Access on a 64-
bit Operating System.

Maximizer Components for IIS and Windows Server 2008 or 2012

If you are using Windows Server 2008 or 2012, you may need to 
perform additional steps before installing Maximizer components for 
IIS. For more information, see “Microsoft IIS on Windows Server 2008 
or 2012” on page 26. 

If you continue to have problems, you may need to install additional 
roles for Web Server (IIS). In particular, ensure the following roles are 
installed:

• Under Common HTTP Features, Static Content.

• Under Application Development, ASP.NET and .NET 
Extensibility.

• Under Security, Basic Authentication and Windows 
Authentication.

Problem Maximizer Web Access requires the 32-bit version of 
ASP.NET 4.0 in order to run on a 64-bit operating 
system.

Symptoms Maximizer Web Access does not work when installed 
on a 64-bit operating system.

Resolution Enable the 32-bit version of IIS on the machine that 
Maximizer Web Access is installed on. For more 
information, see “Microsoft IIS on 64-Bit Operating 
Systems” on page 28.
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• Under Management Tools, all roles.
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Resolving DSN Creation Problems on a Maximizer Web Server

This issue is a problem creating the Data Source Name (DSN) on a 
Maximizer web server.

Problem Running Microsoft IIS and SQL Server on different 
computers. 

Symptom Maximizer Web Access sites do not work.

Resolution Run Maximizer on the same server as Microsoft IIS to 
automatically create the DSN (Data Source Name) 
for the project and open the database in 
Administrator.
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Troubleshooting Web Access Sites
The following sections contain information on troubleshooting 
potential issues with web access sites:

• “Maximizer Web Access Templates” on page 348

• “User-Defined Field Visibility” on page 348

• “Site Tree Control” on page 349

• “Blocked Files in Maximizer Web Access” on page 350

Maximizer Web Access Templates

When the Sites (File > Web Access) dialog box is opened in 
Administrator (File > Web Access), a “master list” of templates is 
compared with the template list stored for the Address Book. If any 
of the templates differ, you are prompted to overwrite the Address 
Book templates with the master templates. If you have customized 
any of the templates used for Maximizer Web Access, you may wish 
to keep a backup copy or mark the templates as read-only so the files 
are not inadvertently overwritten. 

The “master list” of templates is the list of files stored under:

\MxServer\Thinclients on the Maximizer application server

The list of templates available for publishing for an Address Book is 
stored under:

\MxData\<Address Book Name>\Html on the application server

If you have problems with an Address Book’s site templates, delete 
the “Html” folder under MxData and open the Sites dialog box in 
Administrator—the Address Book’s templates folder. The template 
files then regenerate from the master template list. Other files in the 
folder—such as the online site Help files—are also regenerated.

User-Defined Field Visibility

Visibility of user-defined fields for Web visitors (external web access 
users) is based on what WEBUSER has security rights to view. To allow 
external visibility for a user-defined field, ensure WEBUSER has access 
to the field; if the user-defined fields belongs to a group, WEBUSER 
must be part of that group.
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Site Tree Control

This issue affects the tree view control in web access sites.

➤ To resolve the site tree control display issue

� Open the IIS Manager.

� Right-click on the Default Web Site, or other web site to which 
you may have moved the sites, and click Properties.

� Click the Home Directory tab.

� Take note of the path in the Local Path field. This is the folder 
that you will copy the C:\INETPUB\wwwroot\webctrl_client 
folder and its contents to.

� Close the Default Web Site Properties dialog box.

� Open Windows Explorer.

Problem The sites use the Microsoft Internet Explorer 
TreeView WebControl to display tree structures. 
Maximizer CRM Server installs the graphical 
components of this tree control in the 
C:\INETPUB\wwwroot folder in a subfolder called 
webctrl_client. Since C:\INETPUB\wwwroot is the 
default location of the Internet Information Services 
(IIS) root folder, the control is assumed to be 
available from the root. However, if the location of 
the root folder (Default Web Site or other web site 
to which you may have moved the sites) has been 
changed, the graphical components of this control 
are no longer available and the control displays as 
simple text.

Symptom The tree view control in Maximizer Web Access, 
Partner Access, and Customer Access may display 
External Links, UDFs when in tree mode, and 
Company Library data as long strings of text rather 
than the expected graphical tree structure 
representation. No interaction is available.

Resolution To correct this issue, copy the 
C:\INETPUB\wwwroot\webctrl_client folder, and all 
its contents, to the new root folder designated as 
the Local Path of the new root under Properties for 
the Default Web Site in the IIS Manager. Detailed 
steps for this procedure are provided below.
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� Copy the C:\INETPUB\wwwroot\webctrl_client folder and its 
contents to the Local Path identified in step 4 above.

The site tree structures should now display correctly.

Blocked Files in Maximizer Web Access

This issue affects users after first logging in to Maximizer Web Access. 

Problem The web server configuration includes a firewall or 
other software that is blocking the 
MaThinIEActiveX.ocx file.

Symptom When a user logs in to Maximizer Web Access, the 
web browser displays a message that the 
MaThinIEActiveX.ocx file is blocked.

Resolution Configure the firewall to allow this file to be 
downloaded from the server. For more information, 
see “ActiveX Controls in Maximizer Web Access” on 
page 215.
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Restoring the Escona Tutorial Sample Address Book
If the installation of the Escona Tutorial sample Address Book fails, 
you can restore the sample database using the EsconaTutorial.bak 
backup file located on the Maximizer application server. The file is 
located in the following shared folder:

\All Users\Application Data\Maximizer\AddrBks\EsconaTutorial\

If you are accessing the shared folder from a workstation, the path is 
as follows:

\\<server_name>\MxData\EsconaTutorial

After you have restored the Address Book from the backup file, you 
must employ it before anybody can open it in Maximizer. For 
instructions on employing an Address Book, refer to “Employing an 
Existing Address Book” on page 82.
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Maximizer Email Service Log Files
The Maximizer Email Service log files store the following codes:

• 1 = Initialization or database connection problem

• 2 = Not used

• 3 = Exception (other error code)

Samples and explanations of both Maximizer Email Service log files 
are included below. For more information on log files, see “Using 
Log Files for Diagnosis” on page 330.

Sample CMGR-Email_yyyymmdd.log File

Line numbers are not written 
into an actual log and are 
provided here for convenience.

17:50:14  ================ OPENING LOG ================

CURRENT DATE:2010/05/16

1. 17:50:14  INFO    [Line 1506]  [ini] 
COMMON_SERVER_SETTING = 

2. 17:50:14  INFO    [Line 1516]  [ini] COMMON_Address 
BookS = Escona

3. 17:50:14  INFO    [Line 1534]  [***] current Address 
Book = Escona

4. 17:50:14  INFO    [Line 1552]  [ini] AUTO_EMAIL_RUN = 1

5. 17:50:14  INFO    [Line 1570]  [ini] SQL_DB_NAME = 
Escona

6. 17:50:14  INFO    [Line 1579]  [ini] SQL_SERVER = 
Servername

7. 17:50:14  INFO    [Line 1588]  [ini] SERVICE_USERID = 
EMAILUSER

8. 17:50:14  INFO    [Line 1607]  [ini] SERVICE_Address 
Book_PATH = DSN:MA_SQL_ESCONA

9. 17:50:14  INFO    [Line 1637]  [ini] 
AUTO_EMAIL_TEMPLATES = C:\Program 
Files\Maximizer\ServerShared\Email Templates\

10. 17:50:14  INFO    [Line 1646]  [ini] 
AUTO_EMAIL_SMTP_SERVER = mail.maximizer.com

11. 17:50:15  WARNING [Line 512]   email to 
'devsupport@maximizer.com' failed (Reason: Load template

    '.etf' failed)

The test environment that 
produced this log had an 
invalid path for the email 
template directory, resulting in 
a detailed error in line 11.

12. 17:50:17  WARNING [Line 396]   0 email messages were 
sent successfully, 1 email messages failed

17:50:17  ================ CLOSING LOG ================
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Description of Sample CMGR-Email_yyyymmdd.log File

The following table describes some of the numbered lines from the 
previous example.

Sample CMGR-Service_yyyymmdd.log File

Line numbers are not written 
into an actual log and are 
provided here for convenience.

CURRENT DATE:2010/05/16

1. 17:49:12  INFO    [Line 64]    email service started

2. 17:49:12  INFO    [Line 402]   [ini] 
AUTO_EMAIL_CYCLE_TIME = 1

3. 17:49:12  INFO    [Line 410]   [ini] 
AUTO_EMAIL_TIME_UNIT = 0

4. 17:50:13  INFO    [Line 402]   [ini] 
AUTO_EMAIL_CYCLE_TIME = 1

5. 17:50:13  INFO    [Line 410]   [ini] 
AUTO_EMAIL_TIME_UNIT = 0

The error code #2 in line 6 
identifies a problem locating 
the email template.

6. 17:50:17  INFO    [Line 256]   email service finished 
cycle with error code 2

Line # Description

1 Confirmation as to whether the Common Server setting 
parameter is enabled in the MaConfig table.
NOTE: This setting controls whether passwords are 
encrypted or not encrypted.

2 A list of all of the Maximizer Address Books—read from the 
MaConfig table.

3 The current Address Book that the service is using.

4 Whether the Email Service is active or not. 
1 = active; 0 = inactive

5 The name of the SQL database that the service is accessing.

6 The name of the SQL Server that hosts the database.

7 The name of the SQL Server account that will be used to log 
in to the database.

9 The location of the email templates directory.

10 The name of the SMTP Server that the service will send 
email through.

11 Explanation why the email failed.

12 Count of successful and unsuccessful emails sent.
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The warning in line 7 confirms 
that the email message was 
not sent.

7. 17:50:17  WARNING [Line 396]   0 email messages were 
sent successfully, 1 email messages failed

Description of the Sample CMGR-Service_yyyymmdd.log File

The following table describes some of the numbered lines from the 
previous example. Due to the error in the configuration as stated 
above, the send attempt failed. 

Line # Description

1 Launching of the send application.

2 The setting for the email send cycle; stated in minutes.

6 The status of the last send attempt.

7 Count of successful and unsuccessful emails sent.
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MaConfig Table (Server and Address Book Configuration)
Maximizer uses a special SQL database called MaConfig to store the 
settings for the Address Books, global settings, and some IIS settings. 
During a Workstation installation, the Maximizer Workstation Setup 
program reads from the server’s MaConfig table in the MaConfig 
database to obtain the correct registry settings for the workstation.

The following sections contain information on the MaConfig table:

• “Editing the MaConfig Settings” on page 356

• “Four-letter Module Codes” on page 356

• “MaConfig Table: Entries and their Meanings” on page 347

Editing the MaConfig Settings

If you need to edit the MaConfig table directly, you can access it 
through Microsoft SQL Enterprise Manager.

➤ To edit the Maximizer configuration settings in the 
MaConfig table using Microsoft SQL Enterprise 
Manager

� Open Microsoft SQL Enterprise Manager.

� Browse to the SQL Server, and select the MaConfig database.

� Under Tables locate and select the MaConfig table.

� Right-click the table, and select Open Table > Return All Rows.

Enterprise Manager displays the entire MaConfig table.

� Edit the entries as needed, and close the table.

Four-letter Module Codes

Entries in the MaConfig table often contain a four-letter code to 
identify which component uses that particular entry.

Code Module

ADMN Administrator

AMGR Maximizer

AUTO Maximizer Automated Services

CMGR Campaign Manager

DSGN Portals (not used)
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MaConfig Table: Entries and their Meanings

The MaConfig table contains information about a set of Maximizer 
Address Books. The MaConfig table is stored in the MaConfig 
database in SQL Server. Some of the entries in the table may not 
apply depending on the edition of Maximizer you are using.

The following tables describe the keys in the MaConfig table.          

EMPP Maximizer Web Access

EXTP Partner Access and Customer Access

EXCH MaxExchange

Code Module

Table 1 Address Book Configuration Settings in the MaConfig Table

Section Key Value

<Address Book> AUTO_EMAIL_TEMPLATES Path to the automated campaign email 
template files (*.etf).

<Address Book> DASHBOARD_DISABLED Determines if dashboards are disabled for the 
current Address Book:
yes = Dashboards are disabled
This key is not included by default in the 
MaConfig table. You must manually add a 
new entry to the table with this key for the 
specific Address Book.

<Address Book> Dashboard_URL URL of dashboards.

<Address Book> DB_NAME Actual name of the Maximizer database. It can 
be different from display name.

<Address Book> DB_SERVER Network machine name of the computer that 
hosts the Maximizer configuration table 
(MaConfig table).

<Address Book> DB_SYS_TYPE Type of database used for the Maximizer 
Address Book.

<Address Book> DB_USERFRIENDLY_NAME Display name of Maximizer database in 
Address Book list.

<Address Book> DSGN_ISAPI_CUSTOMER URL of Customer Access.

<Address Book> DSGN_ISAPI_PARTNER URL of Partner Access.

<Address Book> DSGN_SSL_ISAPI

<Address Book> EADV_MASRCH_FILE

<Address Book> EADV_MASRCH_Update_URL
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<Address Book> HTML_TEMPLATES_PATH Path of the root HTML folder on the 
Maximizer Application Server. 
(Maximizer\Address 
Books\<AddressBook>\Html).

<Address Book> HTML_TEMPLATES_URL

<Address Book> IN_MEMORY_RESPONSE_TABLE

<Address Book> LIST_LIMIT Controls the maximum value of the Maximum 
entries field in the Search dialog boxes that 
can be carried forward to the next session. 
The value of the Maximum entries field in any 
of the Search dialog boxes will always be less 
than or equal to the LIST_LIMIT value the next 
time the Search dialog box is opened. If the 
user selects a value less than LIST_LIMIT, that 
value will be selected automatically the next 
time they open the dialog box. If the user 
selects a value greater than LIST_LIMIT, the 
value will be reset to LIST_LIMIT the next time 
they open the dialog box. This control helps 
avoid overloading the SQL server. 
By default, the value of LIST_LIMIT is 1000. 
Setting LIST_LIMIT to 0 allows the “All” option 
to be saved for the next session.

<Address Book> Refresh ISAPI Details

<Address Book> RPTR_START_FINANCIAL_DAY Day of the month (specified in 
“RPTR_START_FINANCIAL_ MONTH”) in which 
the fiscal year begins.

<Address Book> RPTR_START_FINANCIAL_
MONTH

Month (i.e., 1–12) in which the fiscal year 
begins.

<Address Book> SERVICE_CMGR_PASSWORD Default email service password for automated 
campaigns (emailsystem).

<Address Book> SERVICE_CMGR_USERID Default User ID for email service login user. 
(EMAILUSER).

<Address Book> SERVICE_DSGN_PASSWORD Default WEBUSER password. (websystem).

<Address Book> SERVICE_DSGN_USERID Default User ID for ISAPI login user. 
(WEBUSER).

<Address Book> SERVICE_PASSWORD

<Address Book> SERVICE_SMTP_SERVER

<Address Book> SERVICE_USERID

Table 1 Address Book Configuration Settings in the MaConfig Table

Section Key Value
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<Address Book> SERVICE_WORKSPACE_PATH DSN of the Address Book.

<Address Book> PUBLISHED_PROJECTS

<Address Book> AUTO_TRANSLATE This key must be created manually.
Create this key when a workstation that uses 
non-English regional settings must access a 
database that uses an English database 
collation. It affects the “Perform translation 
for character data” flag in the database DSN.
Set the value of this key to 0 or 1.
0 = Turn “Perform translation for character 
data” flag OFF
1 = Turn “Perform translation for character 
data” flag ON
If you use a database collation other than the 
default, SQL_Latin1_General_CP1_Ci_AS, set 
the value to 0.
This Key must also be added to the Global 
Settings section.

Table 2 Global Address Book Server Configuration Settings in the MaConfig Table

Section Key Value

Global Settings AcntQB

Global Settings AcntQB0

Global Settings AcntQBDesc0

Global Settings AUTO_EMAIL_BATCH_CYCLE

Global Settings AUTO_EMAIL_BATCH_SIZE Number of emails sent in the specified interval 
of time for the batch.

Global Settings AUTO_EMAIL_CYCLE_TIME Number of polls in the time unit specified under 
“AUTO_EMAIL_TIME_UNIT” in which the SQL 
Server is checked for outgoing automated 
emails.

Global Settings AUTO_EMAIL_JOB_PER_
THREAD

Length of prepared messages sent to queue per 
thread. The default is 20.

Global Settings AUTO_EMAIL_REDIRECT_URL_
BASE

Specifies the URL of the script that redirects the 
email recipients to the Landing page URL in 
automated email campaign activities. 

Table 1 Address Book Configuration Settings in the MaConfig Table

Section Key Value
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Global Settings AUTO_EMAIL_REQUIRES_AUTH Specifies if SMTP server requires authentication:
0 = Authentication not required
1 = Authentication required

Global Settings AUTO_EMAIL_SERVICE Default server that hosts the Email Service.

Global Settings AUTO_EMAIL_SMTP_PORT Port number of the SMTP server. The default is 
25.

Global Settings AUTO_EMAIL_THREAD_COUNT Number of email threads. This value cannot be 
higher than 31 and the default is 20.

Global Settings AUTO_EMAIL_TIME_UNIT Time unit used for AUTO_EMAIL_CYCLE_TIME:
0 = Minutes
1 = Hours
2 = Days
3 = Months

Global Settings AUTO_PRINTFAX_BATCH_CYCLE

Global Settings AUTO_PRINTFAX_BATCH_SIZE Number of print jobs for each batch.

Global Settings AUTO_PRINTFAX_CYCLE_TIME Number of polls in the time unit specified in 
AUTO_PRINTFAX_TIME_UNIT, in which the SQL 
Server is checked for outgoing automated print 
jobs and faxes.

Global Settings AUTO_PRINTFAX_TIME_UNIT Time unit used for 
AUTO_PRINTFAX_CYCLE_TIME:
0 = Minutes
1 = Hours
2 = Days
3 = Months

Global Settings BTI_PATH Defines the UNC location of the 
“Maximizer\Address Books” folder on the 
Maximizer Main Server. The “Address Books” 
folder is usually shared as “EAddress Books”, so 
that in a typical installation the UNC path would 
be “\\<servername>\ EAddress Books”.

Global Settings CAMPAIGN_PRINTFAX_DEVICES List of printers and fax software used by the 
Maximizer Print/Fax Service.

Table 2 Global Address Book Server Configuration Settings in the MaConfig Table

Section Key Value
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Global Settings COMMON_WORKSPACES Defines the Maximizer Address Books that are 
to appear in the Address Books list when you 
open an Address Book. The Address Book names 
should be separated by a comma, as in 
“COMMON_ Address BookS=Address 
Book1,Address Book2,Address Book3”. Each 
Address Book listed here should have a 
corresponding section in the MaConfig table. 
For example “Address Book1” would have a 
“[Address Book1]” section.

Global Settings Dashboard_URL URL of dashboards.

Global Settings DB_SERVER Name of database server.

Global Settings DB_SYS_TYPE Type of database (SQL).

Global Settings EMPLOYEE_PORTAL_URL URL of Maximizer Web Access.

Global Settings ENCRYPTION_TYPE Type of encryption:
0 = Standard
1 = No encyption
2 = BLOWFISH40

Global Settings IIS Name of the IIS Server.

Global Settings IIS External Server Network machine name of the IIS Server that 
you have set up for external Internet access.

Global Settings IIS Internal Server Network machine name of the IIS Server that 
you have set up for internal access.

Global Settings Install Path Local path of the Maximizer program folder on 
the Maximizer Application Server.

Global Settings License_MAXIMIZER Number of installed Maximizer PLNs (Product 
License Numbers).

Global Settings License_MAXIMIZER_DESCn Description of nth Maximizer PLN.

Global Settings License_MAXIMIZERn nth Maximizer PLN.

Global Settings License_PORTAL Number of installed Web Access Site PLNs 
(Product License Numbers).

Global Settings License_PORTAL_DESCn Description of nth Web Access Site PLN.

Global Settings License_PORTALn nth Web Access Site PLN.

Global Settings Maximizer Server Network machine name of the Maximizer 
Server.

Global Settings Maximizer Server Setup Maximizer series number installed on the 
Maximizer Application Server. This value is set 
by the installation program.

Table 2 Global Address Book Server Configuration Settings in the MaConfig Table

Section Key Value
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Global Settings NONTESTED_COLLATION_LIST

Global Settings ONETOONE_REQUIRES_AUTH

Global Settings ONETOONE_SMTP_SERVER

Global Settings ONETOONE_SMTP_SERVER_
PORT

Global Settings Server Path UNC Refers to the UNC path of the “Maximizer\ 
ServerShared” folder. The “ServerShared” 
folder is shared as “MaximizerServer” during a 
Maximizer installation. For example, a typical 
installation would have the entry “Server Path 
UNC=\\<servername>\ MaximizerServer”.

Global Settings SMTP Server Specifies the name of the outgoing mail server 
used for automated campaigns.

Global Settings SMTP_TIMEOUT Duration that the email service waits for the 
SMTP server’s response for each email. The unit 
of measurement is in seconds.

Global Settings SQL_SERVER

Global Settings <IIS Server>_Domain Name HTTP server name.

Global Settings TESTED_COLLATION_LIST Comma-delimited list of SQL database collations 
supported by Maximizer.

Global Settings Thin_Clients_Installation

Global Settings USE_UNIFIED_LOGIN “Trusted Connection” login security:
0 = Disabled
1 = Enabled

Global Settings AUTO_TRANSLATE This key must be created manually.
Create this key when a workstation that uses 
non-English regional settings must access a 
database that uses an English database 
collation. It affects the “Perform translation for 
character data” flag in the database DSN.
Set the value of this key to 0 or 1.
0 = Turn “Perform translation for character 
data” flag OFF
1 = Turn “Perform translation for character 
data” flag ON
If you use a database collation other than the 
default, SQL_Latin1_General_CP1_Ci_AS, set the 
value to 0. 
This Key must also be added for the Address 
Book with the non-default database collation.

Table 2 Global Address Book Server Configuration Settings in the MaConfig Table

Section Key Value
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Global Settings WEBAPI_URL This key contains the full URL of the 
Maximizer.Web.Data API, including the 
protocol (http or https).

Global Settings WEBAUTHENTICATION_URL This key contains the full URL of the Maximizer 
Authentication service, including the protocol 
(http or https).

Table 3 ISS Server Configuration Settings in the MaConfig Table

Section Key Value

IIS_<IIS Server> BASE_HREF

IIS_<IIS Server> IIS_URL Virtual directory path of the “Scrptpub.dll”.

IIS_<IIS Server> WORKSPACE

IIS_<IIS Server> WORKSPACE_PATH Installation path of the Address Books folder.

Table 4 Live Update Configuration Settings in the MaConfig Table

Section Key Value

Live Update Enable

Live Update Enable Auto

Live Update Server Base URL

Table 5 Workstation Configuration Settings in the MaConfig Table

Section Key Value

Workstation_
<Server>

Installed_Series

Workstation_
<Server>

Setup_Completion_Date

Table 2 Global Address Book Server Configuration Settings in the MaConfig Table

Section Key Value
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ADMN_Config Table (Address Book Configuration)
The ADMN_Config table in your Maximizer Address Book database contains Address Book-specific 
settings.

AppCode KeyCode SubKeyCode Comment

ALLOW_COPY_
CLIENTS_TO_
OUTLOOK

Controls Address Book synchronization 
between Maximizer and Outlook.
0 = Disable (default)
1 = Enable

AUTO_EMAIL_
PASSWORD

Maximizer Email Service outgoing 
SMTP server account password

AUTO_EMAIL_
REQUIRES_AUTH

Enable/disable Maximizer Email Service 
outgoing SMTP server authentication
0 = Disable
1 = Enable

AUTO_EMAIL_RUN Automated services activation
0 = Inactive
1 = Active (but not yet used by any 

automated services)
 2 = Active

AUTO_EMAIL_
SERVICE

The name of server which hosts the 
automated services

AUTO_EMAIL_SMTP
_PORT

Maximizer Email Service outgoing 
SMTP server port number

AUTO_EMAIL_SMTP
_SERVER

Maximizer Email Service outgoing 
SMTP server name

AUTO_EMAIL_
TEMPLATES

Automated services templates path

AUTO_EMAIL_
USERNAME

Maximizer Email Service outgoing 
SMTP server account name

ClientUdfInfo CustomerService

ClientUdfInfo EssentialUDFs Essential UDFs

ClientUdfInfo EssentialUDFs_
Caption

Essential UDFs group box caption

Mandatory Basic 
Fields

Company, Contact 
or Individual

Marks basic field as mandatory for 
specific entry type

NotifyAction
("CustomerNotify")

CustomerService Notify Address Book entry when a 
customer service case is created for 
them
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ResponseTime CustomerService Default case response time

Address Format 0 Custom address format, accessible 
from Preferences > Format

MyWorkDay MyWorkDayCaption Caption text for Overview page, set in 
Administrator preferences

Calendar Appt_iCal_Attachme
nt

Preference for including an iCal 
attachment in an appointment 
notification email.

Calendar CarryForward CarryForward for Hotlist in Calendar 
window

Calendar HideLegend Hide/Show user and location/resources 
legend

Calendar HideTask Hide/Show Hotlist tasks in Calendar

Calendar Legend Users, resources, and locations visible 
in legend

EMAIL_DEFAULT
_TEMPLATE

0 DataMachineID,
SequenceNumber of the email 
template in the AMGR_Letters table.

RecentEntries 0 Client_id of a recent entry

RecentEntries bVisible Hide/Show recent entries on Icon bar

DefaultAbTab

Format(User) ShowDisabled Show/Hide disabled users

Format(User) Name User format 

RecentEntries NumToShow Number of recent entries to show

LastCatalogSearches

MWD_LAYOUT What is shown in MWD

MWD_STARTUP Whether or not MWD opens on 
startup

PRINTER<n> NAME Printer name or UNC path

Printing Rights Rights Allow printing to specified output

Quick Access Entries bVisible Show/Hide quick access list on Icon bar

Quick Access Entries Selected Commands Action listed in quick access

User_Colors Resource Resource colors

User_Colors User User Colors

AppCode KeyCode SubKeyCode Comment
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Column Setup Address Book 
Campaigns

Column Setup Campaigns

IconBarButtonOrder The order of the buttons in the icon 
bar.

IconBarButtonHide The icons that are hidden on the icon 
bar.

NOTIFICATION AutoEmail EVENT_MAX_AUTO
_EMAIL_FATAL

Event notification for Maximizer Email 
Service fatal error

NOTIFICATION AutoPrintFax EVENT_MAX_AUTO
_PRINTFAX_FATAL

Event notification for Maximizer Print/
Fax Service fatal error 

NOTIFICATION NOTIFICATION_
SETTING

Notification CFG 
Version

Event notification version number. 
Used to synchronize the 
EventNotification.cfg file with these 
table entries.

NOTIFICATION NOTIFICATION_
SETTING

NOTIFICATION_
ENABLE

Event notification activation
0 = Inactive
1 = Active

NOTIFICATION NOTIFICATION_
SETTING

NOTIFICATION_
REQUIRE_AUTH

Enable/disable events notification 
outgoing SMTP server authentication
0 = Disable
1 = Enable

NOTIFICATION NOTIFICATION_
SETTING

NOTIFICATION_
SENDER_ADDRESS

Event notification sender email 
address

NOTIFICATION NOTIFICATION_
SETTING

NOTIFICATION_
SENDER_NAME

Event notification sender name (email)

NOTIFICATION NOTIFICATION_
SETTING

NOTIFICATION_
SMTP_AUTH_NAME

Event notification outgoing SMTP 
server account name

NOTIFICATION NOTIFICATION_
SETTING

NOTIFICATION_
SMTP_AUTH_
PASSWORD

Event notification outgoing SMTP 
server account password

NOTIFICATION NOTIFICATION_
SETTING

NOTIFICATION_
SMTP_PORT

Event notification outgoing SMTP 
server port number

NOTIFICATION NOTIFICATION_
SETTING

NOTIFICATION_
SMTP_SERVER

Event notification outgoing SMTP 
server name

AppCode KeyCode SubKeyCode Comment
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Maximizer File Types
The following table lists the extensions of file types created in the 
registry during the Maximizer installation.

The following table lists the extensions of file types used by 
Maximizer. These file types have no association in the registry.

The following table lists the extensions of file types created in the 
registry during the MaxExchange installation in previous versions.

The following table lists the extensions of file types used by 
MaxExchange in previous versions. These file types have no 
association in the registry.

Extension Application Comment

.MDE MaxWin.exe Maximizer Data Exchange file used by 
email transfer (prior to version 7 – now 
.MET)

.MEC ecMecIm.exe OrderDesk’s order data file

.MET MaxWin.exe Maximizer Email Transfer files (version 
7 and higher) 

.MXD MaxWord.ter Maximizer Document extension

.MXI MaxWin.exe Maximizer XML format data file

.MTI MaxWin.exe Maximizer Transfer Interface (CSV 
format data file – elaborate or skip CSV 
altogether; manual says EDI, flags, etc.)

Extension Application Comment

.ETF MaxWord.ter Template files used for automated 
campaigns, customer service emails, 
and by MaxWord

Extension Application Comment

.MEX MaxExchange lock file

Extension Application Comment

.HDR Packet header file

.ATT Data packet file

.MA Internally used by MaxExchange to 
store information about email data 
packets (as in Dld_q.ma)
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Adding a Microsoft IIS machine
You can add a Microsoft IIS machine through Administrator. A 
Maximizer Web Server (IIS machine) is set up by installing the IIS 
components of a Maximizer Server installation. To enable an 
“installed” Maximizer Web Server to work with an Address Book, see 
the Sites dialog box in Administrator (File > Web Access). 

Virtual Directories
The following table describes the virtual directories created by the 
Maximizer installation.

By default, [Install Directory] is C:\Program Files\Maximizer\.

Virtual Directory Description Directory

MaximizerWebAccess Maximizer Web 
Access

[Install Directory]\
Portals\Employee

MaximizerMobileAcce
ss

Mobile Access [Install Directory]\
Portals\Wireless

MaximizerPartner Partner Access [Install Directory]\
Portals\Partner

MaximizerCustomer Customer Access [Install Directory]\
Portals\Customer

Dashboard Dashboards [Install Directory]\
Portals\Dashboard

Campaigns Statistics for email 
campaigns

[Install Directory]\
Campaign Manager\
Statistics
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Virtual Directory Permissions

The following sections list the default permissions for the virtual 
directories created by the Maximizer installation.

Maximizer Web Access, Partner Access, and Customer Access Virtual Directories

The following table lists the default permissions for the 
MaximizerWebAccess, MaximizerPartner, and MaximizerCustomer 
virtual directories:

Campaigns Virtual Directory

The following table lists the default permissions on the Campaigns 
virtual directory:

Permission Setting

Read Access True

Write Access False

Script Source Access False

Directory Browsing False

Indexing True

Log Visits True

Default Document Default.aspx

Delete During Uninstall True

Execute Permissions Scripts Only

Application Protection Medium

Application Mappings Default mappings

Session Timeout 20

ASP Script Timeout 90

Authentication Methods Anonymous + Integrated Windows

Permission Setting

Read Access True

Write Access False

Script Source Access False

Directory Browsing False
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Dashboard Virtual Directory

The following table lists the default permissions for the Dashboard 
virtual directory:

Indexing True

Log Visits True

Default Document Default.asp

Delete During Uninstall True

Execute Permissions Scripts Only

Application Protection Medium

Application Mappings Default mappings

Session Timeout 20

ASP Script Timeout 90

Authentication Methods Anonymous + Integrated Windows

Permission Setting

Permission Setting

Read Access True

Write Access False

Script Source Access False

Directory Browsing False

Indexing True

Log Visits True

Default Document Default.asp

Delete During Uninstall True

Execute Permissions Scripts and Executables

Application Protection High

Application Mappings Default mappings

Session Timeout 20

ASP Script Timeout 90

Authentication Methods Anonymous + Integrated Windows
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Database Views for User-Defined Fields     

When you create a user-defined field, a database view for that user-
defined field is also created. You can use these views to report on 
user-defined fields in Crystal Reports. For example, when a new 
Address Book user-defined field called “Salary” is created, a new 
view named “A_Salary” is dynamically created. Based on the type of 
user-defined field, the view name is prefixed by a designated letter. 
The following table identifies the table or view name prefixes for 
each type of user-defined field.

Maximizer uses the Microsoft SQL database driver (MAS_ DSN).

Microsoft SQL View Prefixes

The Microsoft SQL driver creates database views for user-defined 
fields, using the following prefixes.

Prefix Type of user-defined field

A_ Address Book 

BP_ Third-Party Integration 

C_ Campaign 

CS_ Customer Service 

O_ Opportunity 

U_ Users 

S_ System 
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Maximizer XML Interface (MXI)
Maximizer enables you to import Address Book entries, customer 
service cases, and knowledge base articles from Maximizer or other 
applications using XML. If the records were exported from Maximizer 
in MXI (Maximizer XML Interface) or XML format, you can import 
them back into Maximizer directly. However, to import records from 
other applications in XML format, you must ensure that the XML file 
conforms to the Maximizer XML schema. 

After you have converted your data to XML format, you can use the 
Import command to import this data into an Address Book. 

The names of and relationships between the elements in the 
Maximizer XML schema correspond to the Maximizer Address Book 
fields, with a few exceptions. Several elements are named “Detail...”. 
These elements correspond to user-defined fields:

• DetailDef – Definition of a user-defined field.

• DetailDate – Date user-defined field.

• DetailNumber – Numeric user-defined field.

• DetailString – Alphanumeric user-defined field.

• DetailList – Single-value table user-defined field.

• DetailListMulti – Multiple-value table user-defined field.

• DetailFormula – Formula user-defined field.

• DetailBoolean – Yes/no user-defined field.

The following sections outline the tree-structure hierarchy of 
Maximizer XML elements. The first section outlines just the top-level 
elements, and the following sections outline the elements below the 
top-level. Mandatory elements are shown in bold, and are 
mandatory only if their parent element is used.

Top-Level Elements

The <AllData> element is the root element, which contains the 
following elements, which contain all other elements. For specific 
information about each of the elements, refer to the appropriate 
section.

<AllData>

<ImportOptions>

See ImportOptions Element.

</ImportOptions>

<DetailDef>

See DetailDef Element for sub-elements.
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</DetailDef>

<Individual>

See Individual Element for sub-elements.

</Individual>

<Company>

See Company Element for sub-elements.

</Company>

<KnowledgeBaseArticle>

See KnowledgeBaseArticle Element for sub-elements.

</KnowledgeBaseArticle>

<Case>

See Case Element for sub-elements.

</Case>

</AllData>

ImportOptions Element

The <ImportOptions> element and its sub-elements describe how 
Address Book entries and customer service cases should be imported.

<ImportOptions>

<LeadHandling></LeadHandling>

<ClientIdGeneration></ClientIdGeneration>

<LogFile></LogFile>

<LogLevel></LogLevel>

<ClientOptions>

<MatchMode></MatchMode>

<MatchDetail></MatchDetail>

</ClientOptions>

<ContactOptions>

<MatchMode></MatchMode>

<MatchDetail></MatchDetail>

</ContactOptions>

</ImportOptions>

The following table describes the values of each of the 
<ImportOptions> elements. The valid values for each element are 
listed in the Value column. The Equivalent Field column identifies the 
field in the import dialog boxes that sets the same import option.
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Element Name Valid Values
Equivalent Field(s) in 
Maximizer Description

LeadHandling Lead Import all entries as 
leads

Imports all Address Book entries in the 
import file as sales leads, regardless of 
any sales lead values specified in the file.

Normal Import all entries as 
non-leads

Imports all Address Book entries in the 
import file as non-sales leads, regardless 
of any sales lead values specified in the 
file.

File Use values from the 
import file

Imports Address Book entries as either 
sales leads or non-sales leads, as 
specified in the values of the import file. 
This is the default option.
If the file was exported from Maximizer, 
the sales lead status of each Address 
Book entry was automatically included 
in the exported file. This option simply 
carries those values forward to the 
imported records.

ClientIdGeneration Setting n/a If the imported Address Book entry 
contains a Client ID, it uses the Client ID 
of the imported entry.
If the imported Address Book entry does 
not contain a Client ID, it creates a new 
Client ID for the imported Address Book 
entry.

System n/a Creates a new Client ID for each 
imported Address Book entry.

File n/a Uses the Client IDs of the Address Book 
entries being imported.

LogFile n/a Path and filename where the log file 
should be saved (e.g., c:\folder\file.log).

LogLevel 0 n/a Do not log (leaving this element value 
blank has same result).

1 n/a Log errors only.

5 n/a Log record additions and field changes.

7 n/a Record all details (very large log file 
size).

ClientOptions n/a n/a Client Options apply to Company and 
Individual Address Book entries; Contact 
Options apply to Contact Address Book 
entries. Client Options and Contact 
Options are defined in the nested 
<MatchMode> and <MatchDetail> 
elements.

ContactOptions n/a n/a
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DetailDef Element

The <DetailDef> element and its sub-elements describe the user-
defined field definitions. If the user-defined field includes a 
description, it appears in the <Description> element. If it is a table 
user-defined field, the table items each appear in the <ListItem> 
elements.

<DetailDef Name=”” Type=””>

<Description></Description>

<ListItem></ListItem>

</DetailDef>

Much of the information about the user-defined field is stored in the 
element’s attributes, which are described in the following table.

MatchMode AlwaysInsert n/a Inserts all Company, Individual, and 
Contact records from the import file and 
does not match imported records to 
existing records. Duplicate entries may 
result.

Id n/a Uses Address Book identification values 
as the criteria for matching records. For 
Company and Individual records, this 
option uses the Client ID field to match 
entries. For Contact records, this option 
uses the Client ID and Contact Number 
fields to match entries.

Name n/a Company records will use the Company 
field, and Individual and Contact records 
will use the Last Name field as the 
criteria for matching records.

Detail n/a Specifies an alphanumeric user-defined 
field to use as the criterion for matching 
records. Only Address Book entry user-
defined fields that apply to the 
applicable record type appear in this list.

MatchDetail n/a Name of the alphanumeric user-defined 
field to use to match entries when 
MatchMode is set to Detail.

Element Name Valid Values
Equivalent Field(s) in 
Maximizer Description
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Individual Element

The <Individual> element describes an Address Book entry for an 
Individual. Mandatory sub-elements are shown in bold. 

<Individual>

<ContactNo></ContactNo>

<FirstName></FirstName>

<LastName></LastName>

<Initial></Initial>

Attribute Data Type Valid Values Description

Name string Name of the user-defined field.

Type string Multiple
Single
Date
String
Number

Indicates the type of user-defined field:

• Multiple = Table user-defined field that allows selection 
of multiple items.

• Single = Table user-defined field that allows selection of 
single item only.

• Date = Date user-defined field.

• String = Alphanumeric user-defined field.
• Number = Numeric user-defined field.
• Formula = Formula user-defined field.

• Boolean = Yes/No user-defined field.
This attribute also applies to the <Detail> elements within 
other elements.
The maximum length of the Type attribute is 80 characters.

Cases string No
Yes

Indicates whether the user-defined field can be assigned to 
Cases.

Companies string No
Yes

Indicates whether the user-defined field can be assigned to 
Company, Individual, or Contact Address Book entries.

Individuals string No
Yes

Contacts string No
Yes

DateAnnual string Yes Applies to Date user-defined fields only.
Yes = Annually recurring event.

RetainYear string Yes Applies to Annually Recurring Date user-defined fields only.
Yes = Retain year in annually recurring dates.

Hotlist integer 1 Applies to Date user-defined fields only.
1 = Create Hotlist task.

Length integer Applies to Alphanumeric user-defined fields only.
Indicates the maximum length of the field value.
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<MrMs></MrMs>

<Title></Title>

<Salutation></Salutation>

<Phone>

<Number></Number>

<Extension></Extension>

<Description></Description>

</Phone>

<Email>

<Address></Address>

<Description></Description>

</Email>

<Department></Department>

<Division></Division>

<ReportsTo></ReportsTo>

<AssignedTo></AssignedTo>

<Category></Category>

<DoNotSolicitBy></DoNotSolicitBy>

<Website></Website>

<Created></Created>

<LastModified></LastModified>

<SalesLead></SalesLead>

<Address>

See Address Element.

</Address>

<DetailDate Name=””></DetailDate>

<DetailNumber Name=””></DetailNumber>

<DetailString Name=””></DetailString>

<DetailList Name=””></DetailList>

<DetailListMulti Name=””>

<Value></Value>

</DetailListMulti>

<Note>

See Note Element.

</Note>

<Document>



Maximizer CRM
Administrator’s Guide

378

See Document Element.

</Document>

<Id></Id>

<Firm></Firm>

<Contact>

See Contact Element.

</Contact>

</Individual>

Company Element

The <Company> element describes an Address Book entry for a 
Company. Mandatory sub-elements are shown in bold.

<Company>

<Id></Id>

<Name></Name>

<Department></Department>

<Division></Division>

<Phone>

<Number></Number>

<Extension></Extension>

<Description></Description>

</Phone>

<Email>

<Address></Address>

<Description></Description>

</Email>

<Website></Website>

<AssignedTo></AssignedTo>

<Category></Category>

<DoNotSolicitBy></DoNotSolicitBy>

<Created></Created>

<LastModified></LastModified>

<SalesLead></SalesLead>

<Address>

See Address Element.

</Address>
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<DetailDate Name=””></DetailDate>

<DetailNumber Name=””></DetailNumber>

<DetailString Name=””></DetailString>

<DetailList Name=””></DetailList>

<DetailListMulti Name=””>

<Value></Value>

</DetailListMulti>

<Note>

See Note Element.

</Note>

<Document>

See Document Element.

</Document>

<Contact>

See Contact Element.

</Contact>

</Company>

KnowledgeBaseArticle Element

The <KnowledgeBaseArticle> element describes a Knowledge Base 
Article. The contents of the article itself are stored in the <Data> sub-
element.

Note: To import your own knowledge base articles that were not 
exported from Maximizer, you must encode the text in Base64 for 
the Data field in the MXI/XML file.

<KnowledgeBaseArticle>

<Machine></Machine>

<Sequence></Sequence>

<Status></Status>

<Creator></Creator>

<Owner></Owner>

<LastModified></LastModified>

<Created></Created>

<FileName></FileName>

<FileExt></FileExt>

<Title></Title>

<KeyWords></KeyWords>
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<Product></Product>

<Category></Category>

<Data></Data>

</KnowledgeBaseArticle>

Case Element

The <Case> element describes a Customer Service Case. Mandatory 
sub-elements are shown in bold.

<Case>

<CaseNumber></CaseNumber>

<CaseId></CaseId>

<Subject></Subject>

<CaseCompanyIndividual>

<Id></Id>

<ContactNo></ContactNo>

</CaseCompanyIndividual>

<CaseContact>

<Id></Id>

<ContactNo></ContactNo>

</CaseContact>

<Solution>

<Id></Id>

<ContactNo></ContactNo>

</Solution>

<ArticleId></ArticleId>

<Priority></Priority>

<Severity></Severity>

<Fee></Fee>

<BillRate></BillRate>

<BillableTime></BillableTime>

<Owner></Owner>

<AssignedTo></AssignedTo>

<CreatedBy></CreatedBy>

<ModifiedBy></ModifiedBy>

<ResolvedBy></ResolvedBy>

<CaseOwner></CaseOwner>
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<Type></Type>

<Reason></Reason>

<Origin></Origin>

<Category></Category>

<BillingType></BillingType>

<Queue></Queue>

<Status></Status>

<ModifyDate></ModifyDate>

<DeadlineDate></DeadlineDate>

<CreateDate></CreateDate>

<ResolveDate></ResolveDate>

<Description></Description>

<DetailDate Name=””></DetailDate>

<DetailNumber Name=””></DetailNumber>

<DetailString Name=””></DetailString>

<DetailList Name=””></DetailList>

<DetailListMulti Name=””>

<Value></Value>

</DetailListMulti>

<Note>

See Note Element.

</Note>

<Document>

See Document Element.

</Document>

</Case>

Contact Element

The <Contact> element describes an Address Book entry for a 
Contact. This element is nested within the <Individual> and 
<Company> elements. Mandatory sub-elements are shown in bold.

<Contact>

<ContactNo></ContactNo>

<FirstName></FirstName>

<LastName></LastName>

<Initial></Initial>
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<MrMs></MrMs>

<Title></Title>

<Salutation></Salutation>

<Phone>

<Number></Number>

<Extension></Extension>

<Description></Description>

</Phone>

<Email>

<Address></Address>

<Description></Description>

</Email>

<Department></Department>

<Division></Division>

<ReportsTo></ReportsTo>

<AssignedTo></AssignedTo>

<Category></Category>

<DoNotSolicitBy></DoNotSolicitBy>

<Website></Website>

<Created></Created>

<LastModified></LastModified>

<SalesLead></SalesLead>

<Address>

See Address Element.

</Address>

<DetailDate Name=””></DetailDate>

<DetailNumber Name=””></DetailNumber>

<DetailString Name=””></DetailString>

<DetailList Name=””></DetailList>

<DetailListMulti Name=””>

<Value></Value>

</DetailListMulti>

<Note>

See Note Element.

</Note>

<Document>
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See Document Element.

</Document>

</Contact>

Address Element

The <Address> element describes the address of an Address Book 
entry. This element is nested within the <Individual>, <Company>, 
and <Contact> elements.

<Address>

<Description></Description>

<AddressLine1></AddressLine1>

<AddressLine2></AddressLine2>

<City></City>

<StateProvince></StateProvince>

<Country></Country>

<ZipCode></ZipCode>

</Address>

Note Element

The <Note> element describes any notes for Address Book entries or 
customer service cases. This element is nested within the 
<Individual>, <Company>, and <Contact>, and <Case> elements. 
Mandatory sub-elements are shown in bold. The body of the note is 
stored in the <Text> element.

<Note>

<Date></Date>

<Creator></Creator>

<Owner></Owner>

<Type></Type>

<Text></Text>

</Note>

Document Element

The <Document> element describes any Documents for Address Book 
entries or customer service cases. This element is nested within the 
<Individual>, <Company>, and <Contact>, and <Case> elements. 
Mandatory sub-elements are shown in bold. The body of the 
document is stored in the <DocData> element in Base64 format.
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<Document>

<DocumentId></DocumentId>

<Name></Name>

<Date></Date>

<Creator></Creator>

<Owner></Owner>

<Extension></Extension>

<DocData></DocData>

</Document>

Element Details

The following table lists all the elements in the Maximizer XML 
schema in alphabetical order and describes the following properties 
of each:

• Element Name – The name of the XML element. An element 
name may be listed more than once if it has different properties 
depending on its parent element. Most of the element names 
correspond to Maximizer field names.

• Parent Element(s) – The name of the XML element(s) within 
which the element is nested. If an element with the same name 
and same properties may exist within more than one parent 
element, all parent elements are listed.

• Min. Occur. – The minimum number of times the element must 
occur within its parent element. A value of 1 indicates that the 
element is mandatory, and a value of 0 indicates it is not.

• Max. Occur. – The maximum number of times the element may 
occur within its parent element.

• Data Type – The type of data that may be stored in the element.

• Max. Length – The maximum length of the element contents. If 
this value is blank, there is no maximum length.

Element Name Parent Element(s) Min. Occur. Max. Occur. Data Type Max. Length

Addressa Email 1 1 string 120

Addressa Individual
Company
Contact

0 1 noneb

AddressLine1 Address 0 1 string 80

AddressLine2 Address 0 1 string 80

AllData none 1 1 noneb

ArticleId Case 0 1 string 80
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AssignedTo Individual
Company
Contact
Case

0 1 string 11

BillableTime Case 0 1 double

BillingType Case 0 1 string 80

BillRate Case 0 1 double

Case AllData 0 noneb

CaseCompanyIndividual Case 0 1 noneb

CaseContact Case 0 1 noneb

CaseId Case 0 1 string 80

CaseNumber Case 0 1 string 80

CaseOwner Case 0 1 string 80

Categorya Individual
Company
Contact

0 1 string

Categorya KnowledgeBaseArticle
Case

0 1 string 80

City Address 0 1 string 80

ClientIdGeneration ImportOptions 0 1 string

ClientOptions ImportOptions 0 1 noneb

Company AllData 0 unlimited noneb

Contact Individual
Company

0 unlimited noneb

ContactNoa Individual
Contact

0 1 integer

ContactNoa CaseCompanyIndividual
CaseContact
Solution

1 1 integer

ContactOptions ImportOptions 0 1 noneb

Country Address 0 1 string 80

Created Individual
Company
Contact
KnowledgeBaseArticle

0 1 dateTime

CreateDate Case 0 1 dateTime

CreatedBy Case 0 1 string 80

Element Name Parent Element(s) Min. Occur. Max. Occur. Data Type Max. Length
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Creator Note
Document
KnowledgeBaseArticle

0 1 string 80

Datac KnowledgeBaseArticle 0 1 string

Date Note
Document

1 1 dateTime

DeadlineDate Case 0 1 dateTime

Department Individual
Company
Contact

0 1 string 80

Descriptiona Phone
Email

0 1 string 22

Descriptiona Address 0 1 string 80

Descriptiona DetailDef
Case

0 1 string

DetailDate Individual
Company
Contact
Case

0 unlimited date

DetailDef AllData 0 unlimited noneb

DetailList Individual
Company
Contact
Case

0 unlimited string 80

DetailListMulti Individual
Company
Contact
Case

0 unlimited noneb

DetailNumber Individual
Company
Contact
Case

0 unlimited double

DetailString Individual
Company
Contact
Case

0 unlimited string 120

Division Individual
Contact
Company

0 1 string 80

DocData Document 0 1 string

Element Name Parent Element(s) Min. Occur. Max. Occur. Data Type Max. Length
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Document Individual
Company
Contact
Case

0 unlimited noneb

DocumentId Document 0 1 integer

DoNotSolicitBy Individual
Company
Contact

0 1 string

Email Individual
Company
Contact

0 3 noneb

Extension Phone
Document

0 1 string 22

Fee Case 0 1 double

FileExt KnowledgeBaseArticle 0 1 string 22

FileName KnowledgeBaseArticle 0 1 string 120

Firm Individual 0 1 string 80

FirstName Individual
Contact

0 1 string 80

Id Individual
Company
CaseCompanyIndividual
CaseContact
Solution

1 1 string 23

ImportOptions AllData 0 1 noneb

Individual AllData 0 unlimited noneb

Initial Individual
Contact

0 1 string 80

KeyWords KnowledgeBaseArticle 0 1 string 120

KnowledgeBaseArticle AllData 0 unlimited noneb

LastModified Individual
Company
Contact
KnowledgeBaseArticle

0 1 dateTime

LastName Individual
Contact

1 1 string 80

LeadHandling ImportOptions 0 1 string

ListItem DetailDef 0 unlimited string 80

LogFile ImportOptions 0 1 string

LogLevel ImportOptions 0 1 integer

Element Name Parent Element(s) Min. Occur. Max. Occur. Data Type Max. Length
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Machine KnowledgeBaseArticle 0 1 integer

MatchDetail ClientOptions
ContactOptions

0 1 string

MatchMode ClientOptions
ContactOptions

1 1 string

ModifiedBy Case 0 1 string 80

ModifyDate Case 0 1 dateTime

MrMs Individual
Contact

0 1 string 80

Name Company
Document

1 1 string 80

Note Individual
Company
Contact
Case

0 unlimited noneb

Number Phone 1 1 string 22

Origin Case 0 1 string 80

Owner Note
Document
KnowledgeBaseArticle
Case

0 1 string 80

Phone Individual
Company
Contact

0 4 noneb

Priority Case 0 1 string 80

Product KnowledgeBaseArticle 0 1 string 80

Queue Case 0 1 string 80

Reason Case 0 1 string 80

ReportsTo Individual
Contact

0 1 string 80

ResolveDate Case 0 1 dateTime

ResolvedBy Case 0 1 string 80

SalesLead Individual
Company
Contact

0 1 boolean

Salutation Individual
Contact

0 1 string 80

Sequence KnowledgeBaseArticle 0 1 integer

Severity Case 0 1 string 80

Element Name Parent Element(s) Min. Occur. Max. Occur. Data Type Max. Length



Appendix A
Administrator’s Reference

389

Solution Case 0 1 noneb

StateProvince Address 0 1 string 80

Statusa KnowledgeBaseArticle 0 1 integer

Statusa Case 0 1 string 80

Subject Case 0 1 string

Text Note 1 1 string

Titlea Individual
Contact

0 1 string 80

Titlea KnowledgeBaseArticle 0 1 string 120

Type Note
Case

0 1 string 80

Value DetailListMulti 1 unlimited string 80

Website Individual
Company
Contact

0 1 string 120

ZipCode Address 0 1 string 80

a. This element is listed more than once because of differing properties depending on which element is the 
parent element.

b. This element cannot contain a value. It can contain only other elements.
c. To import your own knowledge base articles that were not exported from Maximizer, you must encode the 

text in Base64 for the Data field in the MXI/XML file.

Element Name Parent Element(s) Min. Occur. Max. Occur. Data Type Max. Length
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Search String Language
Each access object in Maximizer.Data has a method called ReadList() 
which returns a .NET collection of the associated objects. This method 
may be called with no parameters to return everything in the 
Address Book or with a search string.

The ReadList() method generally searches fields contained within the 
calling object. However, Address Book entry fields and methods are 
also available for searching in the Opportunity and CSCase access 
objects. To call an Address Book field from the Opportunity or 
CSCase access object, add “ABENTRY_” before the field name. For 
example, to call the City field for an Address Book entry in the 
Opportunity object, the syntax for the field search should be 
“ABENTRY_City”.

Search Syntax

The syntax for the search string is a functional or prefix operator 
notation. Expressions are of the form 
<Operator>([“]<Parameter1>[“]{,[“]<Parameter>[“]}). This 
syntax was chosen because it’s well suited to a search tree interface. 
Double-quotes are always optional, although, you need them if a 
search parameter includes commas, spaces, or parentheses. In most 
programming languages, you should ensure you escape double-
quote characters when specifying them as a string.

Example

AND(EQ(City,Vancouver), OR(LIKE(Phone1,604%), 
LIKE(Phone2,604%)))

Result

This search string would return all Address Book entries where the 
city is Vancouver and at least one of the first two phone numbers 
starts with 604.

Search Operators

Each object supports a subset of the total search string syntax, and 
each operator supported by the object supports its use on a subset of 
the object’s fields. Deviation from what is supported will result in an 
exception being thrown as described later. As a minimum, the KEY 
operator is supported by every object as a means of selecting a single 
record in the set.
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The following tables describe the operators available to the search 
string language.

Object-level Search Operators

The following search operators apply to the object. The 
documentation of each object lists which search operators are 
available for that object. However, the KEY operator is available for 
all objects.

Operator Description Parameters

AND All sub-expressions must evaluate 
to true to return an object in the 
result set.

Each parameter is a sub-
expression to be AND/OR 
together. A minimum of one 
parameter is required.

OR At least one sub-expression must 
evaluate to true to return an 
object in the result set.

KEY An object must have the given 
key or derive from a supported 
foreign key for it to be returned 
in the result set.

The parameter is a supported key 
for this object. Exactly one 
parameter is required. 
IMPORTANT NOTE: 
Maximizer.Data keys are 
encrypted. A key may include 
letters, numbers and special 
printable characters, but will 
NEVER include double quote 
characters. It is recommended 
that when using this operator, 
you surround your key with 
double quotes.
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The following search operators apply to the AbEntryAccess object 
only.

Operator Description Parameters

WNOTE An object must have an 
associated note as described to 
be returned in the result set.

Up to eight parameters may be 
specified. Only the first 
parameter is mandatory, and 
those left unspecified will not be 
included in the search. The first 
parameter is the search text. The 
search text may occur anywhere 
in a note. “_” is a single character 
wildcard. The second and third 
parameters are the start and end 
dates expressed as YYYY-MM-
DD. The fourth parameter is the 
set of note types to return (e.g. 
“1,2,4”). The fifth parameter is 
the Creator. The sixth parameter 
is the Owner. If you want to 
return only public notes, put 
“PUBLIC” here. The seventh 
parameter is the note category. 
The eighth parameter is the 
option to use full text search. If 
you want to use the full text 
search, put “FULLTEXT” here.

NWNOTE An object cannot have an 
associated note as described to 
be returned in the result set.

FLIST An object (generally an Address 
Book entry) must be in the 
favorite list to be returned in the 
result set.

The only parameter is the 
FavoriteList key. Exactly 1 
parameter is supported. Ensure 
to enclose the keys in double 
quotes. 

LIST An object (generally an Address 
Book entry) must be explicitly 
listed to be returned in the result 
set. 

List the AbEntry keys 
corresponding to the objects you 
want to return. Any number of 
parameters is supported. Ensure 
to enclose the key in double 
quotes. 
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Field-level Search Operators

The following search operators apply to the fields within each object. 
The documentation of each field lists which operators are available 
for each field.

WDOC An object must have an 
associated document as 
described to be returned in the 
result set.

Up to eight parameters may be 
specified. Only the first 
parameter is mandatory, and 
those left unspecified will not be 
included in the search. The first 
parameter is the search text. The 
search text may occur anywhere 
in a document. “_” is a single 
character wildcard. The second 
and third parameters are the 
start and end dates expressed as 
YYYY-MM-DD. The fourth 
parameter is the document 
name. The fifth parameter is the 
minimum size of the document. 
The sixth parameter is the 
Creator. The seventh parameter 
is the Owner of the document. 
The eighth parameter is the 
document category.

NWDOC An object cannot have an 
associated document as 
described to be returned in the 
result set.

Operator Description Parameters

Operator Description Parameters

EQ A given field must be equal to 
the search criteria to return an 
object in the result set.

The first parameter is the field 
name. The second parameter is 
the search criteria. No wildcards 
are supported. See LIKE/NLIKE. 
Exactly two parameters are 
required.

NEQ A given field cannot be equal to 
the search criteria to return an 
object in the result set.

LIKE A given field must be similar to 
the search criteria to return an 
object in the result set.

The first parameter is the field 
name. The second parameter is 
the search criteria. Standard SQL 
wildcards “_” and “%” are 
supported. Exactly two 
parameters are required.

NLIKE A given field cannot be similar to 
the search criteria to return an 
object in the result set.
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Exceptions

Syntax errors in supplied search strings are reported with the 
throwing of an exception from the ReadList() method. All exceptions 
thrown from the Maximizer.Data assembly are derived from 
MxException, so they may be caught and handled collectively. 

Example (C#)

try

{

oAbEntryAccess.ReadList(“EQ(City,Vancouver)”);

}

catch 
(Maximizer.Data.MxSupportedKeywordSearchStringException 
exKeyword)

{

// A custom message for this particular error type.

MessageBox.Show(“AbEntry doesn’t support “ + 
exKeyword.ErrorDetail);

}

catch (Maximizer.Data.MxException exGeneric)

{

// Generically pop-up a message box explaining the 
error.

MessageBox.Show(exGeneric.ToString());

}

The following table contains the exceptions that may be thrown 
when parsing a search string. It also contains the error message that 
is displayed for each exception if you use the ToString() function.   

RANGE A given folder must be in the 
range provided to return an 
object in the result set.

The first parameter is the field 
name. The second and third 
parameters define the range. 
Exactly 3 parameters are 
required. NRANGE A given field cannot be in the 

range provided to return an 
object in the result set.

Operator Description Parameters
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Exception Error Message

MxPreProcessSearchStringException Unable to pre-process the given search string. It 
may be missing or have extraneous parentheses or 
double quotes.

MxProcessSearchStringException Unable to process the given search string. It 
contains an unsupported operator.

MxListSearchStringException Unable to process the given search string. The LIST 
expression should take at least one parameter.

MxFlistSearchStringException Unable to process the given search string. The 
FLIST expression should take exactly one 
parameter. The parameter should be the key of 
the desired favorite list to retrieve.

MxEqSearchStringException Unable to process the given search string. The EQ 
expression should take exactly two parameters.

MxNeqSearchStringException Unable to process the given search string. The 
NEQ expression should take exactly two 
parameters.

MxLikeSearchStringException Unable to process the given search string. The LIKE 
expression should take exactly two parameters.

MxRangeSearchStringException Unable to process the given search string. The 
RANGE expression should take exactly three 
parameters.

MxNrangeSearchStringException Unable to process the given search string. The 
NRANGE expression should take exactly three 
parameters.

MxNlikeSearchStringException Unable to process the given search string. The 
NLIKE expression should take exactly two 
parameters.

MxWnoteSearchStringException Unable to process the given search string. The 
WNOTE expression should take between one and 
six parameters.

MxWdocSearchStringException Unable to process the given search string. The 
WDOC expression should take between one and 
six parameters.

MxNwnoteSearchStringException Unable to process the given search string. The 
NWNOTE expression should take between one 
and six parameters.

MxNwdocSearchStringException Unable to process the given search string. The 
NWDOC expression should take between one and 
six parameters.

MxKeySearchStringException Unable to process the given search string. The KEY 
expression should take exactly one parameter.
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MxVerifyFieldSearchStringException Unable to process the given search string. The 
field specified is not supported with the given 
operator for this object.

MxSupportedKeywordSearchString
Exception

Unable to process the given search string. It 
includes a keyword unsupported by this object.

MxDateTimeOrderSearchStringException Unable to process the given search string. When 
searching by a date range the start date must be 
earlier than the end date. 

Exception Error Message
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Maximizer and Administrator Terminology
.NET – See Microsoft .NET Framework. 

access rights – Security settings for users. Access rights control each 
user’s permissions to read, insert, modify, or delete various types of 
Maximizer entries. They also control general Maximizer privileges, 
user roles, and allowed printing destinations. Access rights 
determined by the user’s access settings and the access settings of 
any security groups the user belongs to. For more information about 
access rights, refer to “User and Group Security” on page 99.

access settings – There are two types of access settings: user access 
settings and group access settings. Combined user and group access 
settings determine a user’s access rights. For more information about 
access settings, refer to refer to “User and Group Security” on 
page 99.

Address Book – A Maximizer database.

Address Book entry – A Company, Individual, or Contact in the 
Maximizer Address Book.

Administrator – A Maximizer module in which the Address Book 
administrator can perform configuration and maintenance of the 
Maximizer system and Address Books.

advanced import – Importing an MXI or XML file into an Address 
Book. For more information about advanced import, refer to 
“Importing Address Book Data from MXI or XML Files” on page 290.

Application Server – See Maximizer Application Server.

automated campaign – A series of automated emails, faxes, or 
printed documents that Maximizer sends on a predefined schedule. 
An automated campaign is based on an automated campaign 
template. 

automated services – Maximizer Email Service and Maximizer 
Print/Fax Service. Used for automated campaigns, customer service 
case email notifications, and appointment reminders by email.

Calendar – A Maximizer page where you can manage your 
appointments.

Campaign Manager Statistics – A Maximizer component that 
tracks the number of emails opened by the recipients, the number of 
recipients who clicked web links within the email, and the number of 
recipients who chose to unsubscribe from future campaigns.

campaign template – A pre-defined strategy used by email and 
traditional marketing campaigns. See automated campaign and 
traditional campaign.

Company – An Address Book entry used to record information for a 
company or organization.
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Company Library – A shared library of company literature.

COMPANY user – A Maximizer system user account used for the 
company calendar to display company events in the Maximizer 
calendar.

Contact – An Address Book entry used to record information for an 
individual person associated with a Company or Individual type of 
Address Book entry.

Customization Suite – A Maximizer add-on enabling you to 
customize Maximizer’s functionality and interface and to integrate it 
with other applications. For more information, refer to the 
Maximizer web site.

Dashboards – Component of Maximizer Web Access that display 
real-time information on your company using dashboard-style 
instrumentation.

default entry – An Address Book entry containing field values that 
are propagated to new Address Book entries by default.

demilitarized zone (DMZ) – A network area between the external 
router, which talks to the Internet, and the corporate firewall, which 
protects internal computers from Internet security breaches

DSN – A Data Source Name providing connectivity to a database 
through an ODBC driver.

EMAILUSER – A Maximizer system user account that gives Maximizer 
access to Address Book data when it performs automated email 
activities such as automated campaigns.

Escona Tutorial – The Escona Tutorial Address Book is a sample 
Address Book included with a typical installation of Maximizer. Using 
the example of a fictitious vintner in the Sonoma Valley, this Address 
Book demonstrates many of Maximizer’s possibilities.

event notification – Automatic email notification and logging 
when specific Maximizer events occur.

Global Edit – A Maximizer operation that enables you to apply the 
same change to multiple Maximizer entries simultaneously.

group – See security group.

Holiday Editor – A tool in Administrator for adding holidays to the 
Maximizer Calendar window.

Hotlist – A page in Maximizer used to display tasks and 
appointments in a specific date range.

IIS – See Microsoft Internet Information Server.

IP address – A number used to uniquely identify a specific computer 
on the Internet. Every Internet-connected computer has an IP 
address. In Maximizer, you use the IIS server’s IP address when you 
preview or publish your online catalog.
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Key Fields – Important user-defined fields that are highlighted on 
the Basic Information tab of Maximizer entries. For more 
information, refer to “Creating Key Fields Lists” on page 170.

Knowledge base – A database containing articles pertaining to 
solutions for customer service and/or technical issues.

lead – An Address Book entry (Company, Individual, or Contact) that 
has been flagged as a potential client or customer.

list – A listing of entries in Maximizer. You can create a list using a 
search or by selecting specific entries and reducing the list to the 
selection. Most activities are performed for the current list or the 
current entry.

load balancing – When a web server is running at capacity, new 
connections are to another web server for processing.

mandatory field – Fields in Maximizer entries that must contain a 
value. Mandatory fields are designated through File > Preferences > 
Mandatory Fields in Administrator.

mandatory user-defined field – User-defined fields in Maximizer 
entries that must contain a value. Mandatory user-defined fields are 
designated through File > Set Up User-Defined Fields in 
Administrator or Maximizer.

marketing team – A group of users to support team-based work on 
marketing campaigns in Maximizer.

MASTER user – The Address Book administrator’s user ID. This user 
ID permits access to Administrator.

MaxAlarm – A discontinued Maximizer companion application that 
automatically monitors appointments for one or more people in any 
number of Address Books and notifies them of appointments.

MaxExchange – A discontinued Maximizer program that was used 
to synchronize an Address Book between a central server and remote 
distribution sites via FTP, email, or a direct network connection.

Maximizer – A Maximizer CRM module in which you can perform 
contact management and sales force automation activities.

Maximizer Application Server – The principal Windows Server 
where Maximizer CRM Server is installed.

Maximizer Email Service – A Maximizer automated service that 
provides automated email campaign activities, customer service case 
email notifications, and appointment reminders by email.

Maximizer Print/Fax Service – A Maximizer automated service that 
enables automated campaigns by fax and printer.

Maximizer XML Interface (MXI) – An XML file format for 
importing entries into a Maximizer Address Book.

MDAC – Microsoft Data Access Components. Provides ActiveX Data 
Objects (ADO), OLE DB, and Open Database Connectivity (ODBC) 
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components for Maximizer to integrate information from multiple 
sources.

merge field – Text inserted into a document or template that is 
replaced by Address Book information during a mail merge. For 
example, a merge field can be a Contact’s name, so you can 
customize a letter’s salutation with the recipient’s name.

Microsoft .NET Framework – A Microsoft operating system 
platform required for Maximizer Web Access, and Maximizer 
Campaign Manager Statistics.

MaxSync for Microsoft Exchange – A discontinued Maximizer 
add-on for synchronizing some Maximizer entries, such as Address 
Book entries, between Maximizer and a Microsoft Exchange Server.

Microsoft Internet Information Server (IIS) – Microsoft web 
server software. Internet Information Server, or IIS, is used for many 
of the Maximizer components.

Microsoft SQL Server – A database server used by Maximizer for 
the Address Book data.

MXI – See Maximizer XML Interface.

note – A text document attached to Address Book entries, Contacts, 
opportunities, and campaigns. 

OLE – Object linking and embedding (OLE) is a technology that 
allows you to insert files, portions of files, and links to files into a 
document or application. You can insert files in the Documents 
window and the Company Library. Double-clicking the file opens it in 
the associated (and installed) application.

opportunity – An entry in Maximizer used to record an opportunity 
to make a sale. Opportunities can organize a sales team using a 
structured sales strategy.

PLN – Product License Number. A Maximizer license. For more 
information, refer to “Installing Licenses” on page 66.

preferences – A collection of program options that allow users to 
customize how Maximizer functions. Some preferences are set in 
Administrator

PSN – Product Serial Number. Entered during product installation.

registry key – Configuration information stored in the Windows 
operating system. 

related entries – An entry that records a relationship between two 
Address Book entries. For example, one Address Book entry might be 
an accountant for another Address Book entry, which could be 
recorded as a related entry in Maximizer.

sales team – A group of users to support team-based work on sales 
opportunities in Maximizer.
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sites – Web-based interfaces (Maximizer Web Access) for Maximizer 
Address Books. This includes Maximizer Web Access, Customer 
Access, Partner Access, and Mobile Access.

script file – A file containing commands that can be executed 
without user interaction. 

security group – A set of access settings for a subset of Maximizer 
users. For more information, refer to “User and Group Security” on 
page 99.

SMTP – An SMTP server is a server used for outgoing Internet email.

SQL – See Microsoft SQL Server.

strategy – A structured, team-based approach to pursuing sales 
opportunities. Strategies define the steps, activities, and roles 
involved in successfully completing a sale.

system field – All Maximizer fields that are not user-defined fields 
are system fields. A few system fields have customizable value-
selection lists, which can be defined through File > Preferences > 
System Fields in Administrator. 

system-defined field – User-defined fields created by Maximizer 
rather than by users. Users can modify some properties of these fields 
but cannot delete them. In the Set Up User-Defined Fields dialog box, 
system-defined fields are displayed in bold. 

team – See sales team or marketing team.

template – A file that outlines the design for a document, email, or 
web page. Maximizer uses templates for word processor documents, 
and for automated activities that belong to automated campaigns. 
Templates can contain merge fields for bulk mailings. Also, see 
campaign template.

thin-client applications – Allow you to remotely access Maximizer 
Address Book data using the web. “Maximizer on the Web” consists 
of Maximizer Web Access, Mobile Access, Partner Access, and 
Customer Access. 

traditional campaign – Used to organize a marketing effort, 
including a marketing team’s steps, activities, and roles.

two-tier import – A procedure for importing Address Book entries 
where Companies are imported first followed by Contacts.

UDF – See user-defined field.

UNC – Universal Naming Convention. A kind of network path used to 
locate files and folders. An example of a UNC path is 
“\\Escona\MxServer\”.

user ID – A name that uniquely identifies a Maximizer user. Users 
must enter their user ID and password to gain access to a Maximizer 
Address Book.
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user-defined field – A custom field used to record additional “user-
defined” information for Address Book entries, opportunities, 
campaigns, and users.

virtual directory – An IIS folder that points to a physical folder on 
the computer. The contents of the physical folder that the virtual 
directory refers to is accessible to the Internet or intranet via the IIS 
server.

Web Access – Web access allows you to remotely access Maximizer 
Address Book data using the web. “Maximizer on the Web” consists 
of Maximizer Web Access, Mobile Access, Partner Access, and 
Customer Access. 

web.config – A configuration file for .NET applications. Each of the 
applications has its own web.config file.

WEBUSER – A Maximizer system user account required for Customer 
Access and Partner Access.

workflow automation – A tool that monitors your business systems 
and automatically assigns the appropriate people to take action.

XML – Extensible Markup Language. A file format that can be 
displayed is XML-enabled web browsers. 
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subtraction, in user-defined fields 141
SvrShare folder 43
synchronization

passwords 343
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