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Welcome to MaxMobile Wireless Server

Introduction
MaxMobile Wireless Server is a MaxMobile add-on that supports 
the wireless connectivity of Address Book information. 

MaxMobile Wireless Server is installed and configured on a 
Microsoft Internet Information Services (IIS) computer. 

System Requirements
Maximizer CRM 12 Enterprise or Group Edition (Workstation 
or Server)

Processor Speed -  1.6 GHz (minimum) and 3 GHz 
(recommended)

Available RAM - 1 GB (minimum) and 2 GB (recommended)

Operating system - Microsoft Windows 2003, 2003 R2, 2008, 
2008 R2 (updated to their latest service packs) with Microsoft 
Internet Information Server

Installing MaxMobile Wireless Server
You can install MaxMobile Wireless Server on a Maximizer 
workstation or a server. Typically, the software would be 
installed on a workstation. 

To install MaxMobile Wireless Server

Close any Maximizer applications running on the computer.

If you have a previous version of MaxMobile Wireless Server 
installed, it is important to uninstall it before proceeding 
with the installation.

Insert the MaxMobile Wireless Server installation CD into the 
computer’s CD drive.

The setup starts automatically. If it doesn’t start, browse to 
your CD drive and double-click the Autorun.exe file.
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Click Install MaxMobile Wireless Server.

Follow the installation wizard on-screen instructions.

During the installation, you are prompted to specify the 
website for the MaxMobile Wireless Server. You can click 
Next to accept the default configuration.

If you choose to use an existing website, select the website 
from the drop-down list.

If you choose to create a new website, enter the description, 
TCP port, IP address, and Host Header value.

Applying Licensing
In Administrator, choose Utilities > Install Multi-User 
License, enter the Product License number, and click the 
Install License button. Open the Address Books to which 
you are applying licensing.

This applies your licensing for MaxMobile Wireless Server. By 
default, a single license is available for use with MaxMobile 
Wireless Server, so this step is necessary only if you are enabling 
the software for more than one user.  

MaxMobile Interface Customizations
You can customize components of MaxMobile such as menu item 
names and field labels through a utility in the Maximizer CRM 
Customization Suite. Interface customizations can then be 
synchronized to the device.

For more information on how to set up customizations for 
MaxMobile, refer to the Maximizer CRM Customization Suite 
documentation. If you do not have the product, you can find 
out more by clicking the Maximizer button and selecting 
Help > Other Maximizer Products in Maximizer or by visiting the 
Maximizer web site at www.maximizer.com.
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Configuring MaxMobile Wireless Server
Once you have installed the software, you must configure your 
wireless server.

Note that when specifying the server name in the following 
steps, you can alternatively use a local computer name (if you 
are using BES or Wi-Fi in an internal domain), a qualified domain 
name, or an IP address (e.g., an external static IP). Contact your 
Internet Service Provider for more information.

The port number is necessary in the following steps only if you 
are using a port other than the default ports of 80 for http or 
443 for https. You can also use the IP address in place of the 
server name.

To configure the wireless server

After installing MaxMobile Wireless Server, if you have 
not yet opened the Address Book you will be accessing, 
do so in Maximizer or Administrator. Opening the Address 
Book creates the Data Source Name (DSN) for accessing the 
database on the SQL server by IIS. 

If the MaxMobile Wireless Server or the Maximizer database 
server is behind a firewall, allow access through the firewall.

On the MaxMobile Wireless Server computer, add an 
exception for the MaxMobile Wireless Server port (port 80 
for http and 443 for https by default).

If MaxMobile Wireless Server and the Maximizer database 
are on different computers, create an exception on the 
Maximizer database computer to give the computer running 
MaxMobile Wireless Server access to the database computer 
through port 1433. Depending on its configuration, you may 
need to perform additional steps to configure the firewall:

Open port 1434 to expose the SQL Server Browser service.

Create an exception for sqlservr.exe and sqlbrowser.exe to 
allow the MAXIMIZER instance of SQL Server access through 
the firewall.
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If the MaxMobile Wireless Server is behind a router, 
configure the router to direct to the MaxMobile Wireless 
Server computer.

4. If the SQL server is running under Windows Authentication, 
you must set up the MaxMobile Wireless Server as described 
in this step. 

Note that users must enter the network domain followed by 
the User ID to log in to MaxMobile. For example,  
network_domain\jnapoli.

Scenario I - This configuration applies when MaxMobile 
Wireless Server and Microsoft SQL Server are installed on the 
same computer. 

In SQL Server, add a Network Service user to Security Logins 
and grant the Public and dbowner rights on the MaConfig 
database. 

In addition, grant each MaxMobile user Public and  
CRM Group rights on the Maximizer database, as well as 
Public and dbowner rights on the MaConfig database.

Scenario II - This configuration applies when MaxMobile 
Wireless Server and Microsoft SQL Server are installed on 
different computers.

In SQL Server, grant each MaxMobile user Public and  
CRM Group rights on the Maximizer database, as well as 
Public and dbowner rights on the MaConfig database.

In addition, set the Windows Authentication application 
setting in the web.config file to true as follows:

<add key =”WindowsAuthenticationRequired” value=”true” />

Note that the web.config file is stored in the following 
folder:

...\Maximizer\WebServices\MaxMobileServer

3.
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5. If the server is a Windows 2003/2003 R2 server, ensure .NET 
v4.0.xxx is allowed in IIS Web Service Extensions. 

6. If the server is a Windows 2008/2008 R2 server, enable the  
.NET Framework and activate the WCF (Windows 
Communication Foundation) component by doing the 
following:

In the Control Panel, open Programs and Features and 
click on the Turn Windows features on or off option. 

Click on Features, click Add Features, and select the 
Microsoft .NET Framework feature. 

In the WCF Activation section, select the HTTP Activation 
and Non-HTTP Activation options.

Click OK.

If the server is running Windows 2003, this step is done 
automatically by the installation and you can move to step 7.

7. If you are installing MaxMobile on a 64-bit operating system, 
you must perform some additional steps. Refer to the 
Maximizer CRM Administrator’s Guide for more information. 

8. Ensure MaxMobile Wireless Server is configured properly by 
going to the following URL:

http://[server_name]:[port_number]/MaxMobileService/
mobile.svc

https://[server_name]:[port_number]/MaxMobileService/
mobile.svc

Note that the following message appears at the top of the 
web page:

Metadata publishing for this service is disabled.

This message can be ignored—it does not indicate a 
configuration error.
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9. In Administrator, open the Address Book to use with 
MaxMobile, and select File > MaxMobile Administration. 
Note that you can also access this dialog box from Maximizer 
if you have administrative privileges as a Maximizer user. 

10. Enter the URL of MaxMobile Wireless Server. The URL should 
be in the following format:

http://[server_name]:[port_number]/maxmobileservice

https://[server_name]:[port_number]/maxmobileservice

If you are using a secure connection, you must also 
uncomment the security mode setting in the MaxMobile 
Wireless Server’s web.config file as follows:

 <security mode=”Transport”/>

Note that the web.config file is stored in the following 
folder:

...\Maximizer\WebServices\MaxMobileServer 

11. If you are using Dashboards or Company Library in 
MaxMobile, ensure the Mobile Access URL is specified in 
Administrator. Once the URL is specified, the Dashboards and 
Company Library icons are accessible from the MaxMobile 
home screen. See the Maximizer CRM Administrator’s Guide 
for more information.



MaxMobile Wireless Server 12�

12. For each user, department, division, security group, 
and team who will use MaxMobile, select the name from 
the MaxMobile users list and click Add to move the item 
to the Users selected for deployment list. This enables 
MaxMobile for these users. Use the Remove button to 
remove an item from this list.

Note that you can also enable MaxMobile for users in the 
General tab of the Properties dialog box for a user.
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Configuring MaxMobile for Deployment
Before you deploy MaxMobile, IIS must be configured properly. 
Although the MaxMobile Wireless Server installation 
should do this automatically, these settings may be verified 
for installing/downloading MaxMobile. 

To configure IIS

Open IIS.

If you are using Windows Server 2003/2003 R2, open the 
properties for the MaxMobile Wireless Server website 
(Default Web Site, by default) and on the HTTP Headers 
tab, click on the File/MIME Types button.

If you are using Windows Server 2008/2008 R2, open the 
MaxMobile Wireless Server website (Default Web Site, by 
default), double-click on MIME Types, and click Add.

Add the following registered file extension types:

Extension: cod 
MIME type: application/vnd.rim.cod

Extension: jad 
MIME type: text/vnd.sun.j2me.app-descriptor

➣
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Deploying the MaxMobile Installation
You can deploy MaxMobile by email or through the web.

It is important to note that if a previous version of 
MaxMobile was installed on the BlackBerry through a USB 
connection, you must uninstall it before installing this 
version of the software. Refer to the Uninstalling MaxMobile 
section in the MaxMobile Getting Started Guide. 

Deploying MaxMobile by Email
The Maximizer Email Service must be set up and running to 
deploy MaxMobile by email. Refer to the Maximizer CRM 
Administrator’s Guide for more information on setting up the 
Maximizer Email Service.

To deploy the MaxMobile installation by email

For each MaxMobile user, select the user in the MaxMobile 
Administration dialog box in Administrator, enable the 
checkbox beside the user’s name, and click the Initiate 
MaxMobile Wireless Deployment button. 

This sends out an email to each of the selected users that 
includes instructions on how to install MaxMobile. You can 
send an email to more than one user at a time. 

To customize the email, you must modify the 
MaxMobileOTADeploymentTemplate.txt file found in the 
MaData6 folder where you installed Maximizer. If you are 
using Maximizer Web Access Administrator, the file is in the 
\Maximizer\Portals\MaximizerAdmin\App_Data folder.

2. Ensure users install MaxMobile by following the instructions 
sent in the email. After receiving the email, users must 
click on the link to the MaxMobile installation, download 
the software, and grant the necessary permissions for 
MaxMobile. See the Granting Permissions for MaxMobile 
section in this manual for more information.

➣
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Deploying MaxMobile Through a Web Browser
If you are not using the Maximizer Email Service, MaxMobile 
users can install MaxMobile through a web browser. After 
installing MaxMobile, users must enter the URL of the 
MaxMobile Wireless Server, as specified in the MaxMobile 
Administration dialog box, to launch MaxMobile.

Note that the port number is necessary in the following steps 
only if you are using a port other than the default ports of 80 
for http or 443 for https.

To deploy MaxMobile through a web browser

On the device web browser, browse to the following URL:

http://[server_name]:[port_number]/MaxMobileService/
bb.aspx

https://[server_name]:[port_number]/
MaxMobileService/bb.aspx

Select Download and click the trackball.

Launch MaxMobile.

You are prompted for the URL of the MaxMobile Wireless 
Server.

Enter the URL of the MaxMobile Wireless Server. The URL 
should be in the following format:

http://[server_name]:[port_number]/maxmobileservice

https://[server_name]:[port_number]/maxmobileservice

5. Grant the necessary permissions for MaxMobile. See the 
Granting Permissions for MaxMobile section in this 
manual for more information.

➣
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Granting Permissions for MaxMobile
After downloading and installing MaxMobile, users must grant 
the necessary permissions for MaxMobile as follows:

If users are prompted with a Yes/No message when granting 
permissions, they should choose Yes. If they receive a 
message asking them to view the permission details, they 
should click the View button, select the Menu key, and click 
Save.

Connecting to the MaxMobile Wireless Server
Depending on the connection methods enabled on the device, 
MaxMobile uses Wi-Fi or the Mobile Network to connect to the 
MaxMobile Wireless Server. If both connection methods are 
enabled and available, MaxMobile uses Wi-Fi.

For Mobile Network connections, MaxMobile first attempts to 
connect to BES (BlackBerry Enterprise Server), followed by BIS-B 
(BlackBerry Internet Service Browsing), then Direct TCP, and 
lastly, WAP2. MaxMobile users may need to specify additional 
settings on their devices for Direct TCP. These settings are 
specified in Options > Advanced Options > TCP (or TCP/IP). 
Contact your BlackBerry service provider for information on 
the required settings. Users can also specify a custom order 
of the connection type to be used in the Server dialog box in 
MaxMobile. See the Maximizer CRM Administrator’s Guide for 
more information.

•
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Application Settings for MaxMobile
After you have deployed MaxMobile Wireless Server, you can 
customize your application settings in the web.config file. The 
web.config file is stored in the following folder:

...\Maximizer\WebServices\MaxMobileServer

Following is a list of the application settings and their 
descriptions:

<add key =”WindowsAuthenticationRequired” 
value=”false” /> determines if the connection allowed from the 
SQL server is Windows Authentication. By default, this is set to 
false; to use Windows Authentication the value must be set to 
true.

<add key=”SessionTimeoutMinutes” value=”125” /> 
determines the length of time each session is available while 
activity is idle.

<add key=”MaximumRecords” value=”2000” /> determines 
the maximum number of records a search returns.

<add key=”LogFile” value=”” /> determines the location 
and file name for the log information - i.e., <add key=”LogFile” 
value=”c:\temp\MaxMobile.log” />.

<add key=”LogLevel” value=”0” /> determines the level of 
logging— the value of 0 sets it to no logging and the value of 5 
sets it to full logging. 

<add key=”culture” value=”fr-BE” /> determines the display 
settings for a culture other than English. The example shown 
above is for Belgium - French. To use a different cultural setting, 
replace the value of the culture.

<webHttpBinding> determines the size of documents that 
you can download and upload. The default value is just under 4 
MB (4096000 bytes). To change this value you must modify the 
following attributes:

maxBufferSize, maxReceivedMessageSize, 
MaxStringContentLength
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Additionally, note that in order to use HTTPS, you must 
uncomment the following line in this section:

<security mode=”Transport”/> 
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Product names mentioned in this document may be trademarks 
or registered trademarks of Maximizer Software Inc. or other 
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