




Notice of Copyright

Published by Maximizer Software Inc.
Copyright ©1988-2012
All rights reserved.

Registered Trademarks and Proprietary Names

Product names mentioned in this document may be trademarks or registered trademarks of 
Maximizer Software Inc. or other hardware, software, or service providers and are used 
herein for identification purposes only.

Applicability

This document applies to MaxExchange Synchronization Server 12 Winter 2012 software.



Maximizer Software Address Information

Corporate Headquarters
Americas

Maximizer Software Inc.
208 West 1st Avenue
Vancouver, BC, Canada V5Y 3T2

+1 604 601 8000 phone
+1 604 601 8001 fax
+1 888 745 4645 support

info@maximizer.com
www.maximizer.com
Knowledge Base: www.maximizer.com/knowledgebase

Europe, Middle East, and Africa

Maximizer Software Ltd
2nd Floor, Apex House, London Road
Bracknell, Berkshire
RG12 2XH United Kingdom

+44 (0) 845 555 99 55 phone
+44 (0) 845 555 99 66 fax

info@max.co.uk
www.max.co.uk

Asia 

Maximizer Asia Limited
17/F, Regent Centre
88 Queen's Road
Central, Hong Kong

+(852) 2598 2888 phone
+(852) 2598 2000 fax

info@maximizer.com.hk
www.maximizer.com.hk

Australia/New Zealand

Maximizer Software Solutions Pty. Ltd.
Level 10, 815 Pacific Highway
Chatswood, New South Wales
2067, Australia

+61 (0)2 9957 2011 phone
+61 (0)2 9957 2711 fax

info@maximizer.com.au
www.maximizer.com.au



1

Contents

Chapter 1 Introduction ............................................................................1
About MaxExchange.....................................................................................2
How MaxExchange Programs Work Together.............................................2

MaxExchange Synchronization Server ..................................................2
MaxExchange Remote Synchronization Server ....................................3
MaxExchange Server Manager..............................................................4
MaxExchange Remote ...........................................................................4
MaxExchange Site Manager..................................................................4

Glossary..........................................................................................................5
Related Information......................................................................................7

Chapter 2 Installing MaxExchange .........................................................9
System Requirements..................................................................................10
Transport Method Requirements ...............................................................11
Installing MaxExchange Synchronization Server.......................................13
Installing MaxExchange Remote Synchronization Server.........................19
Installing MaxExchange Site Manager.......................................................25
Installing MaxExchange Remote ................................................................25
Upgrading from Previous Versions of MaxExchange................................26

Chapter 3 MaxExchange Process Flow .................................................29
Central Address Book..................................................................................30
What Data is Synchronized?.......................................................................30

Synchronizing Third-Party Data ..........................................................31
Synchronizing Opportunities and Campaigns....................................31
Microsoft Outlook Synchronization and MaxExchange 
Synchronization ...................................................................................32

Process Flow.................................................................................................32
MaxExchange Basic Synchronization Cycle.........................................33
Key MaxExchange Files and Folders ...................................................34

Transport Method Details ...........................................................................37
FTP Transport Process Flow Example...................................................38

Chapter 4 Setting Up MaxExchange .....................................................43
Configuring MaxExchange .........................................................................44
Enabling Synchronization for an Address Book........................................46



MaxExchange Synchronization Server 12
Administrator’s Guide

2

Creating the MaxExchange Distribution System Field .......................46
Creating Distribution Groups ..............................................................47

Setting Up the Central Address Book.........................................................49
Assigning Address Book Entries to Distribution Groups....................49
Enabling Transaction Journaling.........................................................51

Quick Start – Setting Up a MaxExchange Server and Remote..................51

Chapter 5 MaxExchange Site Manager ................................................55
Role of MaxExchange Site Manager ..........................................................56
Starting MaxExchange Site Manager.........................................................57
Configuration Settings................................................................................58
Setting Up Synchronization with MaxExchange Site Manager ................65

Setting the Initial Transport Method ..................................................66
Configuring Server Settings........................................................................67
Adding Synchronized Address Books.........................................................70
Setting Up Distribution Sites ......................................................................72

Adding Remotes...................................................................................73
Adding Remote Servers .......................................................................77
Assigning Distribution Groups to Distribution Sites ..........................79
Assigning Users to Distribution Sites ..................................................80
Restricting What Distribution Sites Can Do........................................82
Setting and Viewing the Distribution Preferences for a Remote......83
Completing the Remote Setup............................................................86
Changing the Active Transport Method for a Remote ......................87
Sending a Remote Refresh ..................................................................87
Changing a Remote’s Email Address...................................................89
Suspending Synchronization with a Remote......................................90
Removing a Remote.............................................................................91

Sales and Marketing Teams ........................................................................92
Adding a Team .....................................................................................92
Adding New Team Members ...............................................................93
Renaming a Team.................................................................................94
Removing a Team or a Team Member ................................................95
Modifying Information about a Team Member .................................95
Reassigning Opportunity or Campaign Tasks .....................................96

MaxExchange Notifications ........................................................................97
Address Book Diagnostic Tools .................................................................100
MaxExchange Site Manager Reports........................................................104

Chapter 6 MaxExchange Synchronization Server..............................107
The Role of MaxExchange Server and Remote Server ............................108

Server Database Rights ......................................................................108
Setting Up MaxExchange Server ..............................................................109

How MaxExchange Server Works......................................................109
Starting and Exiting MaxExchange Server ...............................................110



3

Processing Updates from the Server ........................................................111
Processing Immediate Updates .........................................................111
Setting Automatic Processing Timing Preferences...........................112
Pausing and Resuming Processing Sessions......................................113
Automatic Processing Interruptions .................................................114
Importing Data Packets from a Remote or Remote Server .............115
Using the Import List Initial Distribution Functionality ...................116
Processing Refreshes Only for Remotes............................................117

Setting Your MaxExchange Server Preferences.......................................119
Setting Timing Preferences................................................................119
Setting Email Preferences..................................................................119
Logging Preferences ..........................................................................120

Maintaining MaxExchange.......................................................................122
Viewing Synchronized Address Books ..............................................122
Changing the HTTP or FTP Password on a Remote Server ..............122
Address Book Maintenance...............................................................123
Verifying and Recovering an Address Book .....................................124

Chapter 7 Maintenance and Troubleshooting ...................................127
Maximizer Email Transfer Issues ...............................................................128
Date and Time ...........................................................................................128
Converting Embedded Documents to Linked Documents......................129
Transport methods ....................................................................................129
Distribution Groups...................................................................................130
SQL Server Database Rights......................................................................130
Database for Packet Processing................................................................131
Transaction Journaling..............................................................................131
Removal of Records from Synchronization Cycle ....................................131
Routine Maintenance ...............................................................................131
Verifying and Recovering an Address Book ............................................132
Changes in Employees and Remote Sites ................................................132

Reassigning of Opportunities............................................................132
Removal of a Distribution Site in MaxExchange Site Manager.......132

FTP Password Change ...............................................................................132
FTP Address................................................................................................133
Log Files .....................................................................................................133
HTTP Transport and Microsoft IIS .............................................................134
Password Expiration Under Microsoft SQL Server 2005 or Later............135
Queuing Up for Processing Message .......................................................136
Running Only MaxExchange Server Manager.........................................137

Index ....................................................................................139



MaxExchange Synchronization Server 12
Administrator’s Guide

4



C H A P T E R
11Introduction

Introducing MaxExchange

In this chapter...

“About MaxExchange” on page 2

“How MaxExchange Programs Work Together” on page 2

“Glossary” on page 5

“Related Information” on page 7
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About MaxExchange
Welcome to MaxExchange—a tool that keeps Maximizer Address 
Books synchronized between a server and remote offices or remote 
users. MaxExchange allows you to transfer data between the server 
and remotes using HTTP, FTP, folder-to-folder network direct 
transport, email, or by transferring files on disk. Now your mobile 
sales force can keep current with the latest changes to your entire 
central Address Book or a subset of the Address Book, and your 
home office can benefit from the latest data from the field, quickly, 
easily, and automatically.

How MaxExchange Programs Work Together
Throughout this document, the 

MaxExchange Synchronization 
Server is referred to as the 
MaxExchange Server or server. 
The MaxExchange Remote 
Synchronization Server is 
referred to as the 
MaxExchange Remote Server 
or remote server.

MaxExchange consists of the following applications: 

• MaxExchange Synchronization Server 

• MaxExchange Remote Synchronization Server

• MaxExchange Server Manager

• MaxExchange Remote

• MaxExchange Site Manager

MaxExchange Synchronization Server

One person is usually in charge of setting up and administering the 
central Address Book. This MASTER user, or a user with Maximizer 
Administrator privileges, acts as an administrator for the 
MaxExchange Server, designates a Maximizer Address Book as the 
central Address Book—or central Address Books if you are using 
multiple databases—and schedules updates. 

There is only one server for any given Address Book, but one server 
can have many remotes. These sites are either remote servers or 
remotes, which can be connected by LAN, WAN, dial-up access, or 
through the Internet. The central Address Book is maintained on the 
MaxExchange server, while the remote computers have different 
replications of the central Address Book.

MaxExchange Server can also be installed as a service on Windows 
Server 2003, Windows XP, and Windows Server 2008. The service runs 
in the background, as any other Windows service, and typical 
processing is done automatically. Manual control of processing or 
any other server tasks are then done through the MaxExchange 
Server Manager from another machine or on the server. 



Chapter 1
Introduction

3

MaxExchange Remote Synchronization Server

MaxExchange Remote Synchronization Server acts as a middle tier in 
a multi-tiered synchronization tree. Remotes run MaxExchange 
Remote Synchronization Server to synchronize their remote changes 
with those on the site’s parent server, which is either the 
MaxExchange Synchronization Server or a MaxExchange Remote 
Synchronization Server.

MaxExchange Remote Synchronization Server has the following two 
basic functions:

• It synchronizes changes from its remotes with the server and 
receives updates from the server.

• It generates and sends its own updates to its remotes.

MaxExchange Remote Server acts in the capacity of a server and as a 
remote. It may be installed as an application and service or as a 
service only. For information on server tasks, refer to “MaxExchange 
Synchronization Server” on page 107. For information on remote 
tasks, refer to the Using MaxExchange Remote chapter in the 
Maximizer CRM User’s Guide.

N-tier Synchronization

An n-tier configuration is an 
unlimited number of remotes 
and/or remote servers.

The n-tier configuration distributes much of the processing load to 
the remote servers, which dramatically decreases synchronization 
time across the entire tree structure. This decentralized approach to 
synchronization allows for a much greater total number of remotes 
and faster synchronization.

Server

Remote 
Server

Remote

Remote 
Server

Remote

Remote

Remote

Remote

N-tier Configuration
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MaxExchange Server Manager

MaxExchange Server Manager is a utility used to access the server 
from another computer. When you install MaxExchange Server as a 
service, this utility is used to perform manual tasks on the server. 

MaxExchange Remote

MaxExchange Remote users synchronize the entire image or a subset 
image of the central Address Book on their remote computers. 
Remote users also update the central Address Book with changes 
made on the remotes. 

For detailed instructions on using MaxExchange Remote, refer to the 
Maximizer CRM User’s Guide. 

MaxExchange Site Manager

To determine which portions of the central Address Book go to each 
remote, using MaxExchange Site Manager, the MASTER user, or a 
user with Maximizer Administrator privileges, defines remotes/
remote servers and the distribution groups to which the remote sites 
belong. Other important functions of Site Manager are to perform 
Address Book maintenance on remotes, send refreshes to remotes, 
set up event notifications, and generate reports. Site Manager is also 
used to set up teams for campaign and opportunity synchronization. 
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Glossary
Use this list of terms to help familiarize yourself with the terminology 
of MaxExchange.

Central Address Book – A Maximizer Address Book that you specify 
for the MaxExchange server to synchronize with its distribution sites. 
The server maintains the central, master image of this Address Book 
(often at the head office of a company), while the remote computers 
maintain either partial or complete images of the same Address Book 
on the distribution sites. Note that you can synchronize more than 
one central Address Book at a time and multiple Address Books can 
be hosted on one server. 

Although different images of the Address Book are kept on separate 
computers, together, the server and its remotes effectively work on a 
single central Address Book, which is periodically updated by the 
MaxExchange synchronization process.

Distribution Group – A Distribution Group comprises several 
distribution sites that maintain a particular image of the central 
Address Book. The MASTER user of the central Address Book, or a 
user with Maximizer Administrator privileges, uses the MaxExchange 
Site Manager program to determine which distribution sites belong 
to each distribution group. 

The MaxExchange Distribution user-defined field, which you create 
in Administrator, determines which companies and individuals in 
your central Address Book are distributed to the various remotes. The 
field is created in Administrator’s System Options preferences by 
clicking the associated button. This field then appears within your 
User-Defined Fields list and you add values for your distribution 
groups as necessary. 

Distribution Site – A computer where MaxExchange Remote or 
Remote Synchronization Server is installed. See the Remote and 
Remote Server definitions for more information. 

DRB Table – A file table that is used by MaxExchange to track the 
distribution list of Address Book entries and opportunities for each 
distribution site. This list is created based on the Distribution Group 
value associated with an Address Book entry for the MaxExchange 
Distribution field. 

Remote – A computer where a MaxExchange Remote is installed, 
and on which a partial or complete image of the central Address 
Book is stored. Remotes are set up and maintained by the MASTER 
user, or a user with Maximizer Administrator privileges, using the 
MaxExchange Site Manager program. 

Typically, several distribution sites belong to a distribution group. 
These distribution groups are associated with Address Book entries. 
You assign default distribution groups to Address Book entries based 
on the creator of the entry; each user can be assigned a set of 
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distribution groups and when the user creates an entry, the default 
distribution groups are automatically assigned. User setup for 
distribution groups is done in the Access Rights tab of user properties 
in Administrator (File > Users) or Maximizer (in the Setup tab, select 
Manage Users from the User Management group).

Remote Server – A distribution site that also acts as a MaxExchange 
server for other distributions sites in an n-tier configuration. The 
remote server synchronizes with the server (or with another remote 
server) and passes along data packets to other remotes on the 
distribution tier below it.

MASTER User – The MASTER user is the owner or the administrator 
of a Maximizer Address Book. For MaxExchange, the MASTER user 
administers the central Address Book from the server. The MASTER 
user grants users access to the Address Book and, if required, restricts 
their ability to view, add, or delete data or to perform certain 
functions. The MASTER user is also the only user authorized to use 
the MaxExchange Site Manager application to set up remotes and 
distribution groups or use MaxExchange Server Manager. Note that 
you can have users with Maximizer Administrator privileges 
equivalent to the MASTER user. 

Transaction Journaling – Transaction Journaling is the process by 
which Maximizer maintains a record of changes made by users to an 
Address Book. 

Transaction Journaling is enabled in Administrator in the System 
Options preferences. This functionality should not be enabled until 
you are ready to process data so that unnecessary transactions do not 
occur.

User-defined field – User-defined fields (UDFs) are customizable 
fields in Maximizer that you can use to categorize the Address Book 
entries and opportunities in your Address Books. You can use UDFs to 
group Companies, Individuals, Contacts, and opportunities in many 
different ways such as by occupation, hobby, income level, revenue, 
or any other criteria you want to use.
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Related Information
The MaxExchange Administrator’s Guide is part of a suite of 
documents (paper and online) for Maximizer products, including the 
following:

• Online help with indexed and context-sensitive help for 
MaxExchange tasks, commands, and dialog boxes. Online help is 
available in all MaxExchange applications.

• The Maximizer CRM Administrator’s Guide and Administrator 
online help include information about setting up and 
maintaining Address Books. 

• The Maximizer CRM User’s Guide and Maximizer CRM online 
help include information on managing Address Book entries, 
working with sales opportunities and campaigns, and managing 
teams and strategies.

• Information about the latest product updates and releases can 
be obtained by visiting www.maximizer.com. You can also access 
our knowledge base by going to www.maximizer.com/
knowledgebase. 
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“Transport Method Requirements” on page 11

“Installing MaxExchange Synchronization Server” on page 13

“Installing MaxExchange Remote Synchronization Server” on page 19

“Installing MaxExchange Site Manager” on page 25

“Installing MaxExchange Remote” on page 25

“Installing MaxExchange Licenses” on page 25

“Upgrading from Previous Versions of MaxExchange” on page 26
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System Requirements
To run MaxExchange, 

Windows users must be given 
the rights of a “Power User”.

Please ensure that you have met the following minimum system 
requirements before installing MaxExchange.

Note that the Microsoft SQL Native Client is required by 
MaxExchange and is installed with Maximizer on both the server and 
the remote.

a If you want to install Maximizer on a FAT32 file system, you should 
first convert the drive to an NTFS file system. For information on 
installing Maximizer on a FAT32 file system, visit the Maximizer 
Knowledge Base at www.maximizer.com/knowledgebase.

MaxExchange 
Synchronization Server MaxExchange Remote

Minimum Processor Speed 1.6 GHz (minimum)
3 GHz or faster processor 
(recommended)

1 GHz (minimum)
2.0 GHz or faster processor 
(recommended)

Available RAM 1 GB (minimum)
2 GB (recommended)
4 to 1 ratio of virtual memory to 
physical memory.

1 GB (minimum)
2 GB (recommended)
4 to 1 ratio of virtual memory to 
physical memory.

Available hard disk space 4 GB (minimum)
6 to 8 GB (recommended)

2 GB (minimum)
4 to 6 GB (recommended)

Operating system Microsoft Windows XP
Microsoft Windows Server 2003
Microsoft Windows Server 2008
Microsoft Windows Server 2008 R2
(updated to their latest service packs)

Microsoft Windows XP
Microsoft Windows Vista
Microsoft Windows 7
Microsoft Windows Server 2003
Microsoft Windows Server 2008
Microsoft Windows Server 2008 R2
(updated to their latest service packs)

Hard disk formata NTFS-formatted file system
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Transport Method Requirements
Depending on the selected transport method, both the server and 
remote computers must have the required software and hardware 
requirements. Following is a description of those requirements for 
each available transport method. 

HTTP Transport

• An ISP (Internet Service Provider) to facilitate the physical 
transport of MaxExchange data packets.

• TCP/IP networking must be enabled on all MaxExchange 
computers.

• A designated web server.

FTP Transport

• An ISP (Internet Service Provider) to facilitate the physical 
transport of MaxExchange data packets.

MaxExchange FTP will also work without the use of the Internet 
should remote users want to direct dial to the MaxExchange FTP 
server.

• TCP/IP networking must be enabled on all MaxExchange 
computers.

Network Direct Transport

• A 10 MB per second or better Network Interface Card.

• A dial-up telephone connection with modem(s) as required.

While a dial-up WAN configuration will work with MaxExchange, we 
recommend an ADSL line service.

Email Transport

• A MAPI (Messaging Application Programming Interface) email 
system for both the server and remote computers. Refer to the 
Maximizer website for product and version-specific information.

• If you are using Microsoft Outlook, the Collaboration Data 
Objects component is installed with the email application on the 
computer running MaxExchange Server.

If you are using Outlook 2007, you must download Collaboration 
Data Objects from the Microsoft website.
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If you are using a previous version of Outlook, you can install the 
component from your email application’s disk.

• If you are running MaxExchange as a service, the service is 
logged in as the user who is configured for the email client, and 
the user has administrator rights.

• If you are using Outlook Express for email transport, the 
following security option is set: Go to Tools > Options in Outlook 
Express, click the Security tab, and clear the “Warn me when 
other applications try to send mail as me” option.
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Installing MaxExchange Synchronization Server
There are two ways to install MaxExchange Synchronization Server—
as a service or as a desktop application. In either case, the 
MaxExchange server is always manually controlled and configured 
through the MaxExchange Server Manager. If you install 
MaxExchange on one computer, it can be controlled by another 
computer by installing the MaxExchange Server Manager 
application. 

You have the option of choosing to use individual MaxExchange 
servers for each Address Book or you can host multiple Address 
Books on one server. This decision should be made based on some of 
the same factors such as performance, scheduling flexibility, and the 
complexity of your installation.

An installation wizard steps you through the process of installing the 
software on your server. The instructions in this section complement 
the wizard to provide additional information.

➤ To install MaxExchange Synchronization Server

You must be logged in as an 
administrator to install 
MaxExchange. After 
installation, you will be 
prompted to restart the 
computer, and then you must 
log in as an administrator 
again to complete the 
installation.

� Close all programs running on the server.

� Insert the MaxExchange Synchronization Server disk in the 
server’s disk drive. (The server and remote versions are on 
separate disks.). The setup starts automatically.

� Select Install MaxExchange Synchronization Server. 

The installation wizard starts.



MaxExchange Synchronization Server 12
Administrator’s Guide

14
� Click Next to begin the installation.

� Read the license agreement and click Next to continue. 

� Select a setup type:

• Server and Server Manager installs both MaxExchange 
Server and MaxExchange Server Manager. Select this option 
if this machine will be used as a MaxExchange Server.

For more information on the 
“Server Manager only” setup, 
see “Running Only 
MaxExchange Server 
Manager” on page 137.

• Server Manager only installs MaxExchange Server Manager 
only, not MaxExchange Server. Select this option if this 
machine will not be used as a MaxExchange Server. Note that 
for this option to be a valid choice, “Server and Server 
Manager” must be installed already on another machine.

If you selected “Server Manager only”, go on to step 11.

IIS Admin Service is Microsoft 
Internet Information Services 
(IIS) administrative service. For 
more information about 
Microsoft IIS, refer to the 
Maximizer CRM 
Administrator’s Guide.

� (This step applies to the “Server and Server Manager” setup type 
only.) If the “IIS Admin Service” or “World Wide Web Publishing 
Service” are not installed, or if they are disabled, you are 
prompted by a message. Take one of the following actions:
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• If you will not be using the HTTP transport method, click 
Ignore and continue with the rest of the installation.

• If you will be using the HTTP transport method, and 
Microsoft IIS is already installed on this machine but the IIS 
Admin Service or World Wide Web Publishing Service are 
currently disabled, go to Windows Services (available 
through the Windows Control Panel), and enable both 
services. Then, click Retry.

• If you will be using the HTTP transport method, and 
Microsoft IIS is not installed, click Abort. Install Microsoft IIS 
before installing MaxExchange Server. For more information 
about Microsoft IIS in a Maximizer environment, refer to the 
Maximizer CRM Administrator’s Guide.

	 (This step applies to the “Server and Server Manager” setup type 
only.) Select Yes to install MaxExchange Synchronization Server 
as a Windows service, or select No to install it as an application. If 
you are unsure, select Yes. 

If you install it as a service, you can use the MaxExchange Server 
Manager on the server, or from another machine running 
MaxExchange Server Manager, to control processing and other 
server tasks.

The user configured to run the 
MaxExchange service must 
have the proper rights for 
Microsoft SQL Server. For more 
information, see “Server 
Database Rights” on 
page 108.


 (This step applies to installing MaxExchange Server as a 
service only.) Specify which type of Windows account to use for 
MaxExchange transport:

• Select Local system account if you will be using either the 
HTTP transport method or FTP transport method for 
synchronization. 
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• Select I will specify user account if you will be using either 
the network direct transport method or email transport 
method for synchronization.

��Select the Maximizer Address Book to synchronize, and click 
Next.
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��(This step applies to the “Server Manager only” setup type.) If 
you selected the “Server Manager only” option in step 6, the 
installation wizard prompts you to identify the MaxExchange 
Server computer to connect to. Browse to the MaxExchange 
Server computer to select it, and then click Next to continue.

��MaxExchange Site Manager is also installed with the server 
software. Select the corresponding options to create desktop 
icons for MaxExchange Site Manager and MaxExchange Server 
Manager.
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��The installation provides you with a summary of your settings. 
Review the settings and click Next to begin installing the 
software.

When the installation is complete, it prompts you to restart the 
computer. 

��Click Finish to close the wizard and restart the computer.

��After the computer restarts, log into Windows using an 
administrator account. This step is required to complete the 
installation.

MaxExchange Synchronization Server is now installed.
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Installing MaxExchange Remote Synchronization Server
The installation of a remote server is similar to a server installation.

An installation wizard steps you through the process of installing the 
software on your server. The instructions in this section complement 
the wizard to provide additional information.

➤ To install MaxExchange Remote Synchronization 
Server

You must be logged in as an 
administrator to install 
MaxExchange. After 
installation, you will be 
prompted to restart the 
computer, and then you must 
log in as an administrator 
again to complete the 
installation.

� Close all programs running on the remote server.

� Insert the MaxExchange Synchronization Server disk in the 
server’s disk drive. (The server and remote versions are on 
separate disks.). The setup starts automatically.

� Select Install MaxExchange Remote Synchronization 
Server. 

The installation wizard starts.
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� Click Next to begin the installation.

� Read the license agreement and click Next to continue. 

� Select a setup type:

• Server and Server Manager installs both MaxExchange 
Server and MaxExchange Remote Server Manager. Select this 
option if this machine will be used as a MaxExchange Remote 
Server.

For more information on the 
“Server Manager only” setup, 
see “Running Only 
MaxExchange Server 
Manager” on page 137.

• Server Manager only installs MaxExchange Remote Server 
Manager only, not MaxExchange Server. Select this option if 
this machine will not be used as a MaxExchange Remote 
Server. Note that for this option to be a valid choice, “Server 
and Server Manager” must be installed already on another 
machine.

If you selected “Server Manager only”, go on to step 11.
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IIS Admin Service is Microsoft 
Internet Information Services 
(IIS) administrative service. For 
more information about 
Microsoft IIS, refer to the 
Maximizer CRM 
Administrator’s Guide.

� (This step applies to the “Server and Server Manager” setup type 
only.) If the “IIS Admin Service” or “World Wide Web Publishing 
Service” are not installed, or if they are disabled, you will be 
prompted by a message. Take one of the following actions:

• If you will not be using the HTTP transport method, click 
Ignore and continue with the rest of the installation.

• If you will be using the HTTP transport method, and 
Microsoft IIS is already installed on this machine but the IIS 
Admin Service or World Wide Web Publishing Service are 
currently disabled, go to Windows Services (available 
through the Windows Control Panel), and enable both 
services. Then, click Retry.

• If you will be using the HTTP transport method, and 
Microsoft IIS is not installed, click Abort. Install Microsoft IIS 
before installing MaxExchange Remote Server. For more 
information about Microsoft IIS in a Maximizer environment, 
refer to the Maximizer CRM Administrator’s Guide.

	 (This step applies to the “Server and Server Manager” setup type 
only.) Select Yes to install MaxExchange Remote Synchronization 
Server as a Windows service, or select No to install it as an 
application. If you are unsure, select Yes. 

If you install it as a service, you can use the MaxExchange 
Remote Server Manager on the server, or from another machine 
running MaxExchange Server Manager, to control processing 
and other server tasks.


 (This step applies to installing MaxExchange Server as a 
service only.) Specify which type of Windows account to use for 
MaxExchange transport:

• Select Local system account if you will be using either the 
HTTP transport method or FTP transport method for 
synchronization. 
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• Select I will specify user account if you will be using either 
the network direct transport method or email transport 
method for synchronization. 

��(Select the Maximizer Address Book to synchronize, and click 
Next.

��(This step applies to the “Server Manager only” setup 
type.) If you selected the “Server Manager only” option in step 
6, the installation wizard prompts you to identify the 
MaxExchange Server computer to connect to. Browse to the 
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MaxExchange Server computer to select it, and then click Next 
to continue. 

��MaxExchange Site Manager is also installed with the remote 
server software. Select the corresponding options to create 
desktop icons for MaxExchange Site Manager and MaxExchange 
Remote Server Manager.
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��The installation provides you with a summary of your settings. 
Review the settings and click Next to begin installing the 
software. 

When the installation is complete, it prompts you to restart the 
computer. 

��Click Finish to close the wizard and restart the computer.

��After the computer restarts, log into Windows using an 
administrator account. This step is required to complete the 
installation.

MaxExchange Remote Synchronization Server is now installed.
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Installing MaxExchange Site Manager
MaxExchange Site Manager is automatically installed with both 
MaxExchange Synchronization Server and MaxExchange Remote 
Synchronization Server. When prompted during the installation of 
both of these server applications, you can choose to create a desktop 
icon for the utility. MaxExchange Site Manager is available through 
the icon and also through the Utilities menu in Administrator when 
either of the server applications are installed. 

Installing MaxExchange Remote
A mobile sales force can use MaxExchange to synchronize their 
computers with the central Maximizer Address Book(s). Remote 
offices can also keep their Maximizer Address Book up to date with a 
central office.

To perform a MaxExchange Remote installation, follow the 
instructions in the Maximizer CRM Administrator’s Guide for 
Installing Maximizer Workstation making sure you choose “Yes” 
when asked if you are using the computer as a Remote Workstation. 
To install MaxExchange Remote on a Maximizer server, refer to 
Installing Maximizer Server. During the Maximizer server installation 
process, select Custom installation and select the MaxExchange 
Remote as an installation option.
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Upgrading from Previous Versions of MaxExchange
Older versions of 

MaxExchange should be 
uninstalled before installing 
the new version. 

When upgrading from a previous version of MaxExchange, take 
special note of these critical issues:

• Process packets in the MaxExchange server before upgrading. 
Any transactions remaining from the previous version will not be 
processed by the upgraded version.

• The MaxExchange server must be upgraded first, after which the 
remotes may be upgraded gradually (mixed-mode environment). 
Synchronization will continue operating even though some 
remotes are running Maximizer CRM 10 or Maximizer CRM 10.5. 
We recommend that the time frame between the upgrade of the 
server and all remotes not be longer than 2 weeks. If you do not 
upgrade a distribution site immediately, synchronization with 
Outlook and Maximizer and synchronization with MaxSync and 
Maximizer could cause duplicates. 

• The processing in a mixed-mode environment is done by the 
server creating packets and saving them in a folder called 
Upgrade (under the Outbox>[HEX Address Book ID] folder). Only 
updates and deletions from a remote that hasn’t upgraded are 
processed by the server; additions are discarded. When the 
remote upgrades, a packet is sent to the server and the server 
detects the upgrade. The server then sends the data packets in 
the upgrade folder, which is then deleted from the server, and 
also sends a special packet asking for all data that was added 
from the time the server (not upgraded yet) last processed a 
packet with the distribution site until the time the distribution 
site creates its first packet after upgrading. The remote then 
sends the added data packets, which is distributed to all other 
remotes. 

• If you are running multiple servers, you have the option of 
migrating all Address Books to one server or keeping the existing 
setup. When evaluating what option is most suitable, keep the 
following points in mind:

 - multiple servers may process faster unless you are using one 
server that is equivalent to multiple machines in terms of 
hardware.

 - you can schedule only one automated processing schedule per 
MaxExchange server so if you need different scheduled 
processing times, you must have separate MaxExchange servers.

• If you are upgrading from a previous version, the email address 
must be re-entered in the Server Settings dialog box in 
MaxExchange Site Manager after you install the new version. 
Other transport method settings are maintained.

• If you are upgrading Maximizer Enterprise 7.5 or earlier, you 
must perform Address Book Maintenance with the “Do not 
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create maintenance packets” option enabled (in MaxExchange 
Server Manager or MaxExchange Remote Server, select File > 
Address Book Maintenance).

• Address Book entries with no assigned MaxExchange 
distribution groups will not be synchronized between the server 
and the remote. After running Address Book Maintenance, and 
a remote is sent a refresh, Address Book entries without 
distribution groups assigned to them are removed from the 
remote. It is recommended that distribution groups are assigned 
to all Address Book entries on a server before performing 
Address Book Maintenance. 

• If you are upgrading to Maximizer CRM from Maximizer 
Enterprise 6 - Pervasive or earlier, the Upgrade utility in 
Maximizer Administrator does not upgrade the MaxExchange 
distribution groups. To perform the upgrade, choose File > 
Upgrade Distribution Groups in MaxExchange Site Manager. 
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In this chapter...

“Central Address Book” on page 30

“What Data is Synchronized?” on page 30

“Process Flow” on page 32

“Transport Method Details” on page 37
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Central Address Book
When using MaxExchange, the Address Book has the following basic 
forms:

• a single, master image of the central Address Book(s) on the 
server

• subset images of the same Address Book(s) stored on computers 
at remotes

What Data is Synchronized?
MaxExchange synchronizes all data in an Address Book with the 
exception of the following:

• Automated campaigns (traditional campaigns are synchronized)

• Email templates for automated campaigns

• Journals

• Expenses

• Graphs

• Import catalogues

• Linked documents

• Printer settings

• Window layouts

• Email settings

• Windows authentication settings

• External third-party tables (non-Maximizer)

• Dashboard settings

• Holiday Editor information
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Synchronizing Third-Party Data

There are two custom tables available through the use of the 
Maximizer Customization Suite (listed below) that allow you to 
integrate third-party data. The data contained in these tables is 
synchronized by MaxExchange as follows:

For both the 
Custom_Independent and 
Custom_Child tables, the 
Custom_ID and 
Custom_Number fields 
(whether generated 
automatically or manually 
entered) on the server and 
each remote must be unique in 
a MaxExchange environment. 
This is to prevent duplicate ID 
issues from occurring.

• Custom_Independent is a top-level data storage table, similar 
to the Clients table. It is created at database-creation time and 
contains a number of pre-defined columns. It is always 
synchronized by MaxExchange, and it synchronizes associated 
notes, documents, and user-defined fields.

• Custom_Child is a mid-level data storage table and is a child of 
a Custom_Independent record, an Address Book entry, an 
Opportunity, etc. It is created at database-creation time and 
contains a number of pre-defined columns, including Client_Id/
Client_Number of the parent record. It is always synchronized by 
MaxExchange, except on a refresh, in which case child records 
are synchronized only when the parent record is synchronized. It 
also synchronizes associated notes, documents, and user-defined 
fields when the parent record is synchronized.

For more information on using custom third-party tables, refer to the 
Customization Suite documentation. 

Synchronizing Opportunities and Campaigns

Address Book entries with opportunities assigned to sales team 
members are synchronized to remotes, even when corresponding 
companies are not normally synchronized to those particular remotes 
(i.e., the Address Book entries are not assigned to the corresponding 
distribution group). Synchronization of Address Book entries also 
occurs when a competitor or partner of an opportunity is assigned to 
a Address Book entry other than the Address Book entry with which 
the opportunity is associated.

When a Contact is assigned to an opportunity (on the Basic 
Information tab of an opportunity), the Contact is not synchronized 
unless the Contact’s Company or Individual entry is assigned to a 
distribution group. 

Single-user opportunities are synchronized with only the remotes 
that created the opportunities. For example, if Remote A creates a 
single-user opportunity, it is synchronized with only Remote A. The 
opportunity will not be synchronized with Remote B. Single-user 
opportunities created on the server are not synchronized. 

This works the same way for traditional campaigns in that traditional 
campaigns associated with a member of a marketing team, are also 
synchronized. Automated campaigns are not synchronized to any 
distribution sites.
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Microsoft Outlook Synchronization and MaxExchange Synchronization

In a MaxExchange environment with Microsoft Outlook 
Synchronization enabled, Maximizer can synchronize with Outlook 
on a single server or remote only. Otherwise, duplication of entries 
may occur.

When MaxExchange is installed, and at least one MaxExchange 
remote has been added as a distribution site, a MaxExchange 
Location button appears at the bottom of the Outlook 
Synchronization tab. Clicking this button opens a dialog box 
containing a drop-down list of MaxExchange servers and remotes for 
the current Address Book. Select the MaxExchange server or remote 
where Maximizer will synchronize entries with an Outlook profile for 
the selected user.

Process Flow 
The following diagram illustrates the basic process flow between a 
MaxExchange server and a remote. Note that a MaxExchange 
Remote Synchronization Server configuration is very similar. It can 
include multiple tiers of remote servers and remotes as well as the 
parent server.
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MaxExchange Basic Synchronization Cycle

The following steps describe the basic process that takes place during 
a synchronization cycle between a MaxExchange server and a 
remote.

� A central Address Book is created on the designated 
MaxExchange parent server. 

� Address Book entries are marked for synchronization by 
assigning a Distribution Group value for the MaxExchange 
Distribution system field (defined in Administrator preferences). 

� In MaxExchange Site Manager, remotes and remote servers are 
created for the entire distribution chain. During the creation 
process, distribution groups are assigned to remotes and remote 
servers. 

You can add a remote or 
remote server to the 
distribution chain at any time. 

� For each remote and remote server created in Site Manager, the 
MaxExchange server generates a refresh transaction. When the 
server processes, a refresh packet is built for each site. The 
refresh includes all data that is marked to be distributed to each 
individual site. When using the FTP method of transport, the 
remote/remote server pulls the refresh packet from the server. 
With email and network direct transport, the server sends the 
refresh packet.

� After the MaxExchange server processes the data, its transaction 
table is cleared and the server is ready for the next 
synchronization cycle. 

� Changes from remotes and remote servers are written to a 
transaction file/table. These changes are processed by each site 
according to the site’s designated synchronization cycle and 
transport method. 

� The server receives updates from the remotes and remote servers 
and the central Address Book is updated with the changes. The 
next synchronization cycle is ready to take place. 
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Key MaxExchange Files and Folders 

Following is a list of the key files and folders on the MaxExchange 
Server or Remote Server.

Reference in 
documentation File/folder name File or folder description

DRB file/table EXCH_DistributionList 
table

Used by MaxExchange to 
track the distribution list of 
Address Book entries and 
opportunities for each 
remote. This list is created 
based on the Distribution 
Group value associated 
with an Address Book entry 
for the MaxExchange 
Distribution system field. 

Transaction 
file

EXCH_Transactions Used by MaxExchange to 
track changes to the 
central Address Book and 
Address Books on the 
remotes. There are 5 
transaction tables.

Distribution 
list file

EXCH_Sites A list of assigned transport 
methods for all remotes. 
MaxExchange identifies 
each distribution site with 
a unique ID. 

Inbox Inbox Contains all incoming 
packets for remotes. 
Packets include all changes 
in the form of transactions 
and are stored—before 
processing—in the TRNSP 
folder under the remote’s 
folder identified with a 
HEX ID number.
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Outbox Outbox Contains all outgoing 
packets for remotes. 
Packets include all changes 
from the central Address 
Book in the form of 
transactions and are 
stored—after processing 
incoming packets—in the 
TRNSP folder under the 
remote’s folder identified 
with a HEX ID number. A 
copy of these transactions 
are stored in a BACKUP 
subfolder for each remote.

.HDR file .HDR file .HDR files (ASCII text files) 
contain the database ID 
and server ID information 
for the remote. 

.ATT file .ATT file .ATT files (compressed 
binary files) contain 
Address Book entry and 
opportunity data. A typical 
file name format is 
edi0000XX.ATT. 

.MEX file .MEX file .MEX files are used to lock 
the .HDR and .ATT files 
when MaxExchange is 
processing or performing 
specific operations.

Reference in 
documentation File/folder name File or folder description
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Following is a list of the key files and folders on the MaxExchange 
Remote.

Reference in 
documentation SQL file/folder name File or folder description

REM file MXZREM.BIN Contains information from 
incoming .HDR files 
including the database ID, 
the MaxExchange server’s 
address, the transport 
method, local database 
location, and a reference to 
the current packet count. 

Inbox Inbox Contains all incoming 
packets from the server. 
Packets include all changes 
from the server in the form 
of transactions and are 
stored in the TRNSP folder 
under the remote’s folder 
identified with a HEX ID 
number. 

Outbox Outbox Contains all outgoing 
packets for the server. 
Packets include all changes 
from the remote’s Address 
Book in the form of 
transactions and are stored 
in the TRNSP folder under 
the remote’s folder 
identified with a HEX ID 
number. A copy of these 
transactions are stored in a 
BACKUP subfolder for each 
remote.
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Transport Method Details
MaxExchange works with various types of transport mechanisms—
email, network direct, FTP, and HTTP. Each remote and remote server 
can be configured to use any of the transport mechanisms 
independently of the other sites. 

The following table outlines the basic differences between the 
various transport methods.

Transport 
method

Server 
requirements

Remote 
requirements

Supported 
protocols

Server 
identifier

Remote 
identifier

HTTP/HTTPS Web service MaxExchange 
Remote 
connection to 
MaxExchange 
Server

TCP/IP URL of the 
MaxExchange 
web service

Not applicable 
– the remote 
always initiates 
the connection 
to the server

FTP Internet 
security router/
firewall server

MaxExchange 
Remote 
connection to 
MaxExchange 
Server

TCP/IP IP address or 
fully qualified 
domain name 
of the 
MaxExchange 
Server

Not applicable 
– the remote 
always initiates 
the connection 
to the server

Network direct Dial-up server 
or WAN 
gateway 
server/router

WAN gateway 
server/router 
(office to office 
WAN 
configuration 
only)

TCP/IP
IPX
SPX
NetBEUI

Name of the 
MaxExchange 
shared 
program folder 
in UNC format

UNC or bindery 
listing for the 
shared 
MaxExchange 
network folder

Email MAPI-
compliant 
email program

MAPI-
compliant 
email client

Any protocol 
supported by 
the email 
program

Address of the 
MaxExchange 
Server’s email 
account

Address of the 
MaxExchange 
Remote’s email 
account
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FTP Transport Process Flow Example

With FTP, data packets are exchanged through the Internet using File 
Transfer Protocol.

The following diagram represents a MaxExchange Internet FTP 
configuration using both a security router and a firewall server.

If remotes and/or remote 
servers are connecting to the 
server at the same time, you 
need to open a port for each 
concurrent connection. 

If a firewall or security router is used in a MaxExchange configuration 
and the MaxExchange Server is placed inside the firewall or security 
router, a port must remain open for each remote or remote site that 
is connecting concurrently to the server. The values for inbound and 
outbound ports are as follows:

Inbound: 21 is the default value—this may be changed to any other 
available value with the exception of the values within the range 
of 
10035 – 11315; these values are used for MaxExchange file transfer

Outbound: 21 is the default value—this may be changed to any 
other available value with the exception of the values within the 
range of 10035 – 11315; these values are used for MaxExchange file 
transfer

• An alternative to opening ports is to place the MaxExchange 
Server on the Internet side of the firewall. This computer could 
be a multi-homed system containing two network cards. One 
network card would have a static external IP address connecting 
to the Internet and the other network card would have an 
internal IP address (specified as the primary FTP address and the 
secondary FTP address). 

When you are using FTP, the connection between the server and 
remote is always initiated from the remote computer. This can be 
done through a LAN or a dial-up connection. If a remote is not 
connected to a LAN, a Windows Dial-up Connection dialog box 
appears when a processing session is initiated. This includes when a 
processing session is automated. 
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Typical FTP Setup and Process

The following diagrams illustrate a typical FTP setup.
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Setting Up MaxExchange and Configuring the
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In this chapter...

“Configuring MaxExchange” on page 44

“Enabling Synchronization for an Address Book” on page 46

“Setting Up the Central Address Book” on page 49

“Quick Start – Setting Up a MaxExchange Server and Remote” on page 51
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Configuring MaxExchange
Configuring MaxExchange for the first time is a highly order-
dependent process that can prove to be time-consuming if steps are 
not followed in a particular order. 

The following section provides a high-level description of the steps 
required to configure MaxExchange. Each of these steps is explained 
in detail in the references sections.

➤ To configure MaxExchange

� Prepare the computers. Make sure all computers have 
Maximizer and MaxExchange installed. See “Installing 
MaxExchange Synchronization Server” on page 13 for more 
information.

� Enable synchronization options. At the Maximizer 
application server, enable the synchronization options and set 
up distribution groups in Administrator. See “Enabling 
Synchronization for an Address Book” on page 46.

� Prepare the Address Book(s). Assign Address Book entries to 
distribution groups on any computer with access to the 
database. See “Setting Up the Central Address Book” on 
page 49. Note that you can synchronize multiple Address Books 
on a MaxExchange server.

� Set up transport and distribution options. Using 
MaxExchange Site Manager, specify your chosen transport 
method and distribution options. See “MaxExchange 
Site Manager” on page 55. This utility is available in 
MaxExchange Server Manager or can be accessed from the 
Utilities menu in Administrator on the Maximizer application 
server. If you have chosen to create an application icon during 
installation, you can also access it through the icon. 

� Set up remotes. Remotes are set up in MaxExchange Site 
Manager. See “Adding Synchronized Address Books” on 
page 70. Part of setting up remotes involves setting site 
restrictions. See “Restricting What Distribution Sites Can Do” on 
page 82.
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� Assign groups to remotes. After Address Book entries are 
assigned to distribution groups and your remotes are created, 
you then need to assign the distribution groups to the remotes. 
This controls which entries go to which sites. See “Assigning 
Distribution Groups to Distribution Sites” on page 79.

� Set the MaxExchange server, remote server, and remote 
preferences. You can now set up your MaxExchange server(s) 
and remote preferences. These include options for MaxExchange 
logging and notification events. See “MaxExchange 
Synchronization Server” on page 107 and the Maximizer CRM 
User’s Guide for more information. 

	 Send the initial data packet. To properly configure the 
MaxExchange server, you should initiate a processing session 
when the data packet will contain the remote’s initialization 
information. This completes the configuration of the server and 
sends the necessary settings to the remote. At the MaxExchange 
server, run MaxExchange Server Manager and process the data 
packets. See “Processing Updates from the Server” on page 111.

If you are setting up an n-tier 
configuration (as described 
under “MaxExchange 
Synchronization Server” on 
page 2), you should repeat 
step 8 for each remote server 
and step 9 for each remote.


 Receive the initial data packet. To complete the 
configuration between the MaxExchange server and its remotes, 
you should receive the initial data packet that was sent in the 
above step on one remote. At the remote, run MaxExchange and 
receive the initial data packet from the server.

Your next step is to complete the configuration all of your remotes 
and remote servers with the server.

Maximizer Setup Tips

• Before you may start synchronization, you need to turn on 
transaction journaling in Administrator on the System Options 
preferences tab (File > Preferences). Turning on transaction 
journaling before you are ready to start synchronizing will result 
in unnecessary transactions synchronized with your remotes.

• A MaxExchange distribution group should not be confused with 
a Maximizer security group. A distribution group is set up using 
the “MaxExchange Distribution” system field and represents a 
group of Address Book entries that can be sent to a remote.

• When you are using Microsoft SQL Express, you are limited to a 
10 GB packet size. Typically, SQL Express is used for MaxExchange 
Remotes, but the software can be used for a MaxExchange server 
in a workgroup environment. If a remote or server is to receive 
larger packets, you must upgrade to Microsoft SQL Server. 

• You can synchronize multiple Address Books with a single 
MaxExchange server. Each Address Book must be added to the 
Distribution Sites screen in MaxExchange Site Manager. Each 
synchronized Address Book has its own remotes/remote servers.
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Enabling Synchronization for an Address Book
You must be the MASTER user, 

or a user with Maximizer 
Administrator privileges, in 
order to set it up as the central 
Address Book for 
MaxExchange. The MASTER 
user’s default password is 
“control”. 

When you install MaxExchange Site Manager and MaxExchange 
Server, you must choose an Address Book that is accessible from the 
server to become the central Address Book. The following section 
outlines the procedures involved in enabling your Address Book for 
synchronization:

• “Creating the MaxExchange Distribution System Field” on 
page 46

• “Creating Distribution Groups” on page 47

Creating the MaxExchange Distribution System Field

You can make the 
MaxExchange Distribution 
field mandatory for Companies 
and Individuals. If the field is 
made mandatory, each time a 
Company or an Individual is 
created, the value for 
MaxExchange Distribution 
field must be set.

The MaxExchange Distribution system field determines which 
companies and individuals in your central Address Book are 
distributed to the various remotes. Once created in Administrator, 
the field then appears within the System Fields preferences tab in 
Administrator and you add values for your distribution groups as 
necessary. 

➤ To create the MaxExchange distribution field

� In Administrator, select File > Preferences. 

� In the MaxExchange section of the System Options tab, click 
Create MaxExchange Distribution.

When you are ready to start 
synchronizing, you must go 
back to this dialog and select 
the Enable Transaction 
Journaling checkbox. Selecting 
the option before you are 
ready to synchronize data 
creates unnecessary 
transactions.

Maximizer creates a system field called “MaxExchange 
Distribution”.

The items you create for this system field are your distribution 
groups.
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� Click OK to save your settings and close the Preferences dialog 
box.

Creating Distribution Groups

Now that you’ve created the MaxExchange Distribution system field, 
you create distribution groups by adding new items to the field.

A Distribution Group is a collection of one or more remotes that are 
designated to send and receive updates to specific Address Book 
entries. The MaxExchange Distribution system field value determines 
which Address Book entries synchronize with a distribution group.

For example, you could have functional groups such as Inside Sales, 
Channel Sales, and Marketing. Or, for example, you could have 
regional groups such as East Coast, North, South, or Australia.

If an Address Book entry for ABC Wine Shop Inc. is assigned to four 
distribution groups—East Coast, North, South, and Australia, the 
entry synchronizes with remotes belonging to any of those four 
distribution groups.

➤ To create Distribution Groups

� After you’ve created the MaxExchange Distribution field (as 
outlined in the previous procedure), in Administrator, select 
File > Preferences and click on the System Fields tab.

� Select the MaxExchange Distribution system field and click 
the Add button.

�
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To ensure Address Book 
entries are marked with the 
proper distribution group 
when entries are created, set 
up a default entry for users 
with the appropriate 
distribution group assignment. 
You can also make the 
MaxExchange Distribution 
field mandatory on the 
Mandatory Fields tab in the 
Administrator preferences. 

� In the Add Item dialog box, type the name of your first 
distribution group (e.g., Western) and choose the user who 
requested that the distribution group be added if necessary. 
Click OK.

Repeat the procedure for each distribution group you need. You 
can always add groups later. The next step is to assign Address 
Book entries to the distribution groups. 

�

�

�
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Setting Up the Central Address Book
You can maintain your central Address Books on any computer that 
has access to the MaxExchange server via MaxExchange Server 
Manager. Entries in Address Books are assigned to distribution 
groups, which in turn, are assigned to remotes. These steps must be 
performed for each synchronized Address Book.

The following sections contain information on setting up the central 
Address Book:

• “Assigning Address Book Entries to Distribution Groups” on 
page 49

• “Enabling Transaction Journaling” on page 51

Assigning Address Book Entries to Distribution Groups

Once you have created the “MaxExchange Distribution” system field, 
you need to assign your Address Book entries to the values (items) of 
this field, which are distribution groups. This process determines 
which Companies, Individuals, and Contacts are sent to each remote.

In the example below, there are three distribution groups—Eastern, 
Central, and Western and each of these groups has an assigned 
Address Book entry.

Contacts

Company A

Contacts

Company B

Contacts

Company C

Eastern

Central

Western

Eastern

Western Central

Distribution Groups – this example
shows how three Address Book

entries are assigned to different
distribution groups. Each group is an

item for the “MaxExchange
Distribution” system field.

Company A will be 
distributed to sites 
belonging to the Eastern, 
Central, or Western 
groups.

Company B will be 
distributed to sites 
belonging to the Eastern 
and Western groups.

Company C will be 
distributed to sites 
belonging to only the 
Central group.
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There are different ways to assign a distribution group to an Address 
Book entry. They are described as follows:

• Distribution groups are assigned to Address Book entries on the 
Basic Information tab as the entries are created. 

• Default distribution groups are assigned to users as part of the 
user security properties (Access Rights tab) so that each time a 
particular user creates an Address Book entry, the specified 
distribution groups are automatically assigned. 

• Default entries can be set up for users specifying distribution 
groups. 

• Global edits can be performed on a selected group of Address 
Book entries. 

See the Maximizer 
documentation for more 
information on default entries 
and global edits.

➤ To assign Address Book entries to groups

� When you are creating a Company or an Individual, select the 
Basic Information tab.

You can assign distribution 
groups to only Companies and 
Individuals. Associated 
Contacts automatically belong 
to the same groups.

� Double-click on the MaxExchange Distribution field in the 
Details area of the tab and select the distribution groups to 
which you would like this entry to be synchronized. 

� Click OK to close the Address Book entry.

The entry is now assigned to the group(s) you selected. 

➤ To assign distribution groups to users

� In Administrator, select File > Users. To create a new user, click 
Add. To modify a user’s properties, select the user and click 
Properties. 

� Select the Access Rights tab and click the Default 
MaxExchange Distribution button.

� Choose the groups for the selected user and click OK. 

Each time the affected user creates a Company or an Individual, 
these distribution groups are assigned to the entry. 

The next step is create your remotes in MaxExchange Site Manager. 
Refer to “MaxExchange Site Manager” on page 55 for detailed 
instructions.
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Enabling Transaction Journaling

You must turn on transaction journaling so that MaxExchange can 
track the changes that are made to the central Address Book(s).

Although it doesn’t cause any specific problems, you may want to 
turn this option on after you’re completely configured MaxExchange 
for synchronization. Tracking changes in the database too early 
results in an unnecessary backlog of transactions that MaxExchange 
will synchronize with your remotes. However, if you are following 
the steps in this guide in order, turning this option on now will not 
result in any transactions since you have not yet created your 
remotes.

➤ To enable transaction journaling in the Address 
Book

� From Administrator, select File > Preferences.

� In the System Options tab, select the Enable Transaction 
Journaling checkbox. Click OK to close the Preferences dialog 
box.

Quick Start – Setting Up a MaxExchange Server and Remote
Accordingly, the steps outlined below are intended for experienced 
Windows users with sufficient knowledge in networking as well as 
MaxExchange data transport methods.

The Quick Start steps below set up synchronization using the FTP 
transport method. Because of the variety of transport methods 
MaxExchange offers, your configuration may vary depending on the 
transport method employed.

You can begin your MaxExchange implementation with 
synchronizing only two computers—the server and one remote. Once 
successful synchronization occurs to and from each of these 
computers, you can use the remote machine as a template to set up 
additional remotes. Accordingly, the process described below will use 
the above-mentioned, two-machine implementation case.
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Step 1 – Prepare the Computers

Before you can install MaxExchange, you need to prepare two 
computers.

� Have two computers ready. Prepare a computer for the 
MaxExchange server and another machine a remote. Make sure 
the computers match or exceed the system requirements.

� Verify the server’s FTP address. Determine if the network/
Internet connection is functioning correctly by choosing File > 
FTP Test on the remote or by “pinging” the server (i.e., at the 
command prompt, type “ping” followed by the computer’s IP 
address or qualified domain name).

You can quickly test your 
server’s FTP address by using 
the File > FTP Test option on 
the remote. 

� Install MaxExchange. Install MaxExchange server on one 
machine and MaxExchange remote on the other. Note that 
MaxExchange remote is part of the Maximizer CRM installation.

Step 2 – Prepare the Address Book

Maximizer and MaxExchange are now installed, and the FTP 
transport method should be working correctly. In this step, you will 
prepare your Maximizer Address Book.

� At the MaxExchange server decide which Address Book will 
be designated as the synchronized, central Address Book.

� Open the Address Book in Administrator and enable 
Transaction Journaling and create the “MaxExchange 
Distribution” system field. These options are available in File > 
Preferences > System Options tab.

� Prepare the Address Book (i.e., set up “MaxExchange 
Distribution” system field items, group/user security, etc.). See 
“Assigning Address Book Entries to Distribution Groups” on 
page 49.

Step 3 – Start MaxExchange Server

Now that your Address Book is prepared, you can start MaxExchange 
Server for the first time.

� Start MaxExchange Server Manager
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Step 4 – Configure MaxExchange Site Manager

In this step, you use MaxExchange Site Manager to set up the 
transport method and add the remote as a remote.

� At the MaxExchange server, start the MaxExchange Site 
Manager. Take note of the Address Book it opens by default. If 
the Address Book does not appear in the list, select File > Open 
Address Book in Administrator and choose the Address Book you 
prepared above.

� Specify the server transport method. Select View > Server 
Settings. See “Setting Up Synchronization with MaxExchange 
Site Manager” on page 65.

For FTP transport, you must enter a static IP address or a fully 
qualified domain name and the port number for the 
MaxExchange server. 

You must also enter FTP Passwords. FTP remote users will login 
using the MAXEXCHANGE password. A secondary GUEST 
password is also required.

� Add the remote. Add the second computer as a remote. See 
“Setting Up Distribution Sites” on page 72.

Make a note of the remote’s ID 
displayed in the remotes list. 
You will need it later.

When the site has been added correctly, a message is shown 
indicating that a refresh will be sent to the Site. Click OK.

Step 5 – Send Initial Data

Now that your remote is set up as a remote in MaxExchange Site 
Manager, you can use MaxExchange server to send the first data 
packet.

� At the server, send the first data packet. Start MaxExchange 
Server and select File > Process Data Packets.

� Check to see if the data packet was transported. Evidence 
of this will vary for each transport Method.

The “hexadecimal” folder is a 
folder labelled by a 
hexadecimal number that 
corresponds to the Address 
Folder ID. This ID is displayed 
in the Distribution List dialog 
box in MaxExchange Site 
Manager.

For FTP transport, the data packet files should be in the 
“MaxExchange\Outbox\<hexadecimal number>” folder, 
awaiting pickup from the remote computer.
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Step 6 – Receive an Initial Refresh Packet at the Remote

� Start MaxExchange Remote on the second computer.

� Initiate a communication session with the server. Select 
File > Connect New FTP Server. Enter the server IP address or fully 
qualified domain name, FTP port number, password (the 
MAXEXCHANGE password entered at the server), and Address 
Book ID for this remote. Click OK when finished.

You can also provide values for 
a secondary IP address and 
port number. 

MaxExchange initiates an FTP session with the server and 
transports the refresh data packet from the server.

 If selecting an existing 
Address Book from the drop-
down list, verify that it is not 
the central Address Book.

� Select an Address Book. MaxExchange asks for the Address 
Book you want to designate as your synchronized MaxExchange 
folder. You may select an existing Address Book from the drop-
down list or create a new Address Book.

� Process the data packet. Select File > Process Packet. 
MaxExchange will only process data packets if there is sufficient 
disk space remaining on your hard drive.

� Following the previous instructions, the refresh you receive at 
the remote should contain no Address Book data. 

� Check the Address Book in Maximizer. When packet 
processing has ended, open the synchronized Address Book in 
Maximizer. No Address Book data should exist. Compare other 
data structures such as user-defined fields and document 
templates with the server Address Book to verify that the 
synchronization was successful.

You have now successfully synchronized a MaxExchange data packet. 
The next step will be to associate the MaxExchange Distribution 
system field items to the Address Book entries you want to send out 
to the remotes and then associate the MaxExchange Distribution 
items to remotes in the MaxExchange Site Manager. This will result in 
Address Book records being assigned to the next data packet for the 
later transport to the remote.

Once you have synchronized all data successfully between both 
computers, you can repeat these procedures to roll out other remote 
computers using your original MaxExchange server.
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In this chapter...

“Role of MaxExchange Site Manager” on page 56

“Starting MaxExchange Site Manager” on page 57

“Configuration Settings” on page 58

“Setting Up Synchronization with MaxExchange Site Manager” on page 65

“Configuring Server Settings” on page 67

“Adding Synchronized Address Books” on page 70

“Setting Up Distribution Sites” on page 72

“Sales and Marketing Teams” on page 91

“MaxExchange Notifications” on page 96

“Address Book Diagnostic Tools” on page 99

“MaxExchange Site Manager Reports” on page 103
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Role of MaxExchange Site Manager
MaxExchange Site Manager coordinates the communication 
between the server and its remotes. Use MaxExchange Site Manager 
for the following tasks:

• define and maintain remotes and the transport addresses of 
users who are responsible for them

• assign remotes to distribution groups

• create and maintain sales and marketing teams and their 
members (if applicable)

• limit a remote’s image of the central Address Book by permitting 
the selective distribution (partial image) of specific types of 
Address Book entries only

• assign users to remotes

• set up distribution preferences for each remote

• set up remote distribution filters

• perform Address Book diagnostics

• define server settings 

• add or remove synchronized Address Books (the central 
database)
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Starting MaxExchange Site Manager
To access MaxExchange Site Manager, you must have installed 
MaxExchange Server or Remote Server on the computer where you 
are accessing the utility. You must also have access to the central 
Address Book as the MASTER user, or a user with Maximizer 
Administrator privileges.

Note that if you are using Windows authentication for Maximizer, 
you are not prompted for a Maximizer user name and password 
when you start MaxExchange Site Manager. You must map the 
Maximizer user to your Windows account before starting 
MaxExchange Site Manager. For more information on setting up 
Windows authentication for Maximizer, see the Maximizer CRM 
Administrator’s Guide. 

➤ To start MaxExchange Site Manager

• Double-click the MaxExchange Site Manager icon on the 
desktop. 

– or –

• Select MaxExchange Site Manager from the Utilities menu in 
Administrator.

In order for the MaxExchange 
Site Manager menu item to 
appear on the Utilities menu, 
you must have first installed 
MaxExchange Server.

The Site Manager window opens. The first view allows you to set 
up your remotes. To set up teams and additional server 
properties, click the associated icon.
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Configuration Settings
The following tables provide an overview of the various 
configuration settings available in Site Manager. Step-by-step 
configuration instructions are provided in the subsequent section.

“Distribution Site” is another 
term for a remote.

Distribution Sites Screen

Field, Option, or 
Button Purpose and Use

Show Tree View You can view the remotes either in tree view or 
in column view, depending on whether this 
checkbox is selected. 

You must be in Tree View to add the first remote to a 
server.

Remote Sites Displays the synchronized Address Book(s), 
remote server(s), and remote(s). 
• Tree view displays the names and Address 

Book IDs in a hierarchical format. 
• Column view displays additional 

configuration information about the 
remote.
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Add Adds a remote or a remote server. See “Setting 
Up Distribution Sites” on page 72.

Save Enables you to save information about remotes 
to a tab-delimited text file. The text file 
contains the following columns:

• Name: Name of the remote
• DBID: Address Book ID of the remote
• LSP: ID of the last packet sent to the remote

• LRP: ID of the last packet received from the 
remote

• Date: Date when the last packet was 
received from the remote

• Time: Time when the last packet was 
received from the remote

• Last Packet Sent: Date and time when the 
last packet was sent to the remote

Refresh Site See “Sending a Remote Refresh” on page 86.

Delete Removes the selected distribution site from the 
Remote Sites list. See “Removing a Remote” on 
page 90

Delete Partial 
Packets

Deletes incomplete packets (ATT files without 
headers) from all remotes in the current 
Address Book.

Delete Lock Files Deletes lock files (MEX files) that are created 
during processing sessions for all remotes in 
the current Address Book. MaxExchange 
typically deletes this file automatically. 
However, there may be instances, such as if a 
machine is inadvertently shut down, that this 
file is not deleted.

Properties Opens the Properties dialog box for the 
selected server or remote. You can also open 
the Properties dialog box by double-clicking on 
the server or remote in the tree or column 
view.

Field, Option, or 
Button Purpose and Use
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Teams Screen

Field, Option, or 
Button Purpose and Use

Teams Displays a list of sales (Opportunities) and 
marketing (Campaigns) teams for the current 
Address Book. The right column displays the 
members of the currently selected team. You 
can create new teams and change settings for 
existing teams using the Add and Modify 
buttons.
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Members of the 
selected team

Displays the members of the sales or marketing 
team selected in the Teams column. You can 
add new team members or modify settings for 
existing members using the Add and Modify 
buttons.
Properties for team members include the 
following settings:
• Name: Team member’s name.
• User ID: Team member’s Address Book user 

ID.

• Status: Indicator whether the member is a 
team leader. A team may have only one 
leader. 

• Campaign/Opportunity rights: Indicates 
whether the member has read-only (audit), 
read/write (edit), or partial read/write 
(standard) rights. 

• Reassign Campaign/Opportunity (modify 
dialog box only): Enables you to assign the 
selected member’s Opportunity or 
Campaign item(s) to another member of the 
team.

• Current distribution sites: Identifies the 
Name and Address Book ID of the remote(s) 
to which the selected team member 
belongs.

Field, Option, or 
Button Purpose and Use
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Server Settings Screen

Field, Option, or 
Button Purpose and Use

Primary FTP 
address/
Secondary FTP 
address

Contains the FTP address of the server, which 
must be a static IP address or a fully qualified 
domain name. If you are using a NAT-enabled 
firewall and an IP address, it must be the 
externally assigned IP address. You can specify 
a second FTP address if necessary.

Password Sets the FTP passwords. There are two 
passwords:

• MaxExchange password: Password for 
synchronization using FTP transport 
method. This password must be entered at 
the remote for the FTP connection to occur.

• Guest password: Second password that 
has the same function as the MaxExchange 
password. Use this password when a remote 
needs to connect using FTP, but you don’t 
want to give out the main MaxExchange 
password. This password is typically used in 
testing and troubleshooting situations.
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Port Displays the server’s listening port used for FTP 
transport. You can adjust this setting if 
necessary. By default, port 21 is selected. You 
must also open other ports equal to the 
number of remotes that are connected 
concurrently. These additional ports must be 
within the range of 10035 – 11315 and are 
used for data transfer.

URL If you are using HTTP, this field displays the 
URL of the server. Note the URL must be 
entered in one of the following formats:

http://[server name]:[port number]/
MaxExchangeTransport

https://[server name]:[port number]/
MaxExchangeTransport

Password Sets the HTTP password.
• MaxExchange password: Password for 

synchronization using HTTP transport 
method. This password must be entered at 
the remote for the HTTP connection to 
occur.

Network address Use this field for the Network Direct transport 
method. The MaxExchange spdm.exe program 
folder (e.g., C:\Program 
Files\Maximizer\MaxExchange) on the server 
must be shared with full access (Full Control/
Change/Read) to use Network Direct. Specify 
the UNC address of the MaxExchange program 
folder (e.g., \\TEST-SERVER\MaxExchange). The 
application looks for the presence of the 
spdm.exe file and does not allow itself to be 
mapped to any other folder.

Browse Enables you to navigate to the shared 
MaxExchange program folder on the server.

Email address Email address that the email client on the 
server is configured to use.

Address Book Opens the list of contacts for the local email 
client.

Enable remote 
warnings

Alerts the server to flag remotes that have not 
synchronized over the specified number of 
days.

Field, Option, or 
Button Purpose and Use



MaxExchange Synchronization Server 12
Administrator’s Guide

64
Display the 
warning icon if 
no packets 
received in n 
day(s)

Available only if Enable remote warnings 
option is selected. Specify how many days a 
remote may go without synchronizing before 
sending an alert message.

Display the 
Distribution Site 
message warning

Displays a warning message each time you start 
MaxExchange Site Manager if you have sites 
that have no assigned users. This checkbox is 
enabled by default.

Enable partial 
rebuilds

Rebuilds only a portion of the DRB file 
pertaining to the site being refreshed (remaps 
Address Book entries to that particular site). 
Unlike the Address Book Maintenance 
function, which rebuilds the entire Address 
Book folder, this option allows for Address 
Book distribution information to be rebuilt for 
individual remotes. 

Missing packets Indicates which action to take when a packet is 
missing. This setting applies when 
MaxExchange is running as an application and 
the dialog box prompting action on a missing 
packet has passed the two-minute time-out 
period. The following actions are available:
• Wait (default)

• Resend
• Process

Previous packets Indicates which action to take when a packet is 
received that should have been received 
earlier. For example, when packet 13 arrives 
after packet 15. The following actions are 
available:

• Delete
• Process
• Wait (default)

Fatal errors Indicates which action to take when a fatal 
error occurs.
• Ignore

• Recover (default)

Field, Option, or 
Button Purpose and Use
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Setting Up Synchronization with MaxExchange Site Manager
The MASTER user, or a user with Maximizer Administrator privileges, 
uses Site Manager to set up and maintain remotes for a particular 
Address Book. Each remote belongs to one or more distribution 
groups.

Only the MASTER user, or a 
user with Maximizer 
Administrator privileges, can 
log in to MaxExchange Site 
Manager.

The first time you run Site Manager, you must specify the server’s 
initial transport method. This is the transport method that will be 
most commonly used by remotes. You must set up at least one of the 
following transport methods:

• HTTP

• FTP

• network direct

• email

HTTP Transport

To use HTTP transport, all MaxExchange computers must have TCP/IP 
networking enabled. The HTTP address is the URL of the server. By 
default, HTTP transport uses port 80. If you change this port, you 
must specify the port number as part of the URL. 

You must specify a password for HTTP transport. 

FTP Transport

To use FTP transport, all MaxExchange computers must have TCP/IP 
networking enabled. The FTP address is the IP address or fully 
qualified domain name of the MaxExchange server. If your network 
uses a NAT-enabled firewall and an IP address, it must be the 
externally assigned IP. By default, FTP transport uses port 21. You 
must also open other ports equal to the number of remotes that are 
connected concurrently. These additional ports must be within the 
range of 10035 – 11315.

When you set up FTP transport, you must enter two passwords—one 
for MaxExchange, and one for Guest. 

Network Direct Transport

To use Network Direct transport, MaxExchange must be installed on 
all remote computers before adding them as remotes in Site 
Manager. As well, the remote’s MaxExchange folder (..\Program 
Files\Maximizer\MaxExchange) must be shared on the network with 
full access rights for the server to access it. 
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Email Transport

To use email transport, remotes must have a functioning MAPI-
compliant email client. 

Setting the Initial Transport Method

For more information on the 
requirements for each 
transport method, see 
“Transport Method 
Requirements” on page 11.

When you first run Site Manager at the server, you must choose and 
set up the initial transport method, which determines how remotes 
communicate with the server.

➤ To set the initial transport method

� If you plan to use email data transport, start your email program, 
and minimize it so that it is running in the background.

� Open MaxExchange Site Manager.

� Select View > Server Settings or click the Server Settings 
icon. Choose a transport method and specify the server address 
for each method you plan to use for synchronization:

• HTTP – Enter the server’s URL. The URL must be entered in 
one of the following formats:

http://[server name]:[port number]/MaxExchangeTransport

https://[server name]:[port number]/MaxExchangeTransport

Note that the port number 
must be part of the URL only if 
you are using a port number 
other than the default port 
number of 80.

Also, enter a password for the MaxExchange user. 

• FTP – Type the server’s FTP address (IP address or fully 
qualified domain name) and port number. When prompted, 
supply a password for the MaxExchange and Guest users. 
Make a note of these passwords, as they will be needed at 
the remotes.

• Network Direct – Enter or browse for the network path to 
the server’s “MaxExchange” program folder. This path must 
be a UNC path (e.g., “\\<server name>\MaxExchange”) and 
accessible from the remotes over the network.

To locate the Network Direct 
folder under Network 
Neighborhood, share the 
folder, then click the Address 
button.

• Email – Type the server’s email address or click the Address 
Book button to select the address from a list.

� If you previously used MaxExchange with email transport and 
are now switching to the FTP or Network Direct transport mode, 
select the MaxExchange has previously been run... option. 
This option ensures you will still receive any data packets sent by 
email. 

� Click OK to confirm your Initial Server Setup settings.
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Configuring Server Settings

➤ To configure MaxExchange server settings

� Start MaxExchange Site Manager.

� Click the Server Settings icon.

� In the Server settings group, enter the address for any 
transport methods supported by this server. 

If you make a change to the 
server settings such as a 
change to the FTP address, the 
MaxExchange Server and the 
MaxExchange Service must be 
restarted before the change 
will take effect. Note that 
server settings apply to all 
Address Books. 

• Primary FTP address/Secondary FTP address – Enter the 
network IP addresses or the fully qualified domain name of 
the server. You must also enter the main password used for 
FTP synchronization and a guest password to be used by the 
remote in the case where you do not want to give out the 
main password.

If required, change the port number. By default, it is set to 
21. This port is the server’s listening port. 

You can enter a second FTP address for the server if 
necessary. This allows remotes to connect to an internal IP 
address when inside the network and an external IP address 
when outside of the network. By default, the remote 
connection is first attempted through the primary IP address. 
If this connection fails, the remote is connected through the 
secondary IP address. 

• URL – The URL must be entered in one of the following 
formats:

http://[server name]:[port number]/MaxExchangeTransport

https://[server name]:[port number]/MaxExchangeTransport

Note that the port number 
must be part of the URL only if 
you are using a port number 
other than the default port 
number of 80.

Also, enter a password for HTTP synchronization. 

• Network address – Enter the UNC network path to the 
MaxExchange program folder on the server. (e.g., \\TEST-
SERVER\MaxExchange)

The MaxExchange program 
folder on the server must be 
shared on the network.

• Email address – Enter the email address that the email 
client on the server is configured to use or click the Address 
Book button to select an address.
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� Select the Enable remote warnings option to display a 
warning when remotes haven’t received packets. Also specify 
the number of days to wait before applying the warning 
functionality (Display the warning icon if no packets received in 
[x] day(s) option).

The Display the Distribution Site message box warning 
displays a warning message each time you start MaxExchange 
Site Manager if you have sites that have no assigned users. This 
checkbox is enabled by default.

� Select the Enable partial rebuilds option to check the 
MaxExchange DRB file for a remote to see if there are missing 
files to be sent out. This functionality only partially rebuilds a 
database, unlike the Address Book Maintenance feature, which 
rebuilds the entire database. The option applies to Refreshes 
only.

� Select the default behavior options for synchronization issues.

� If you want to distribute any interface customizations to remotes 
and remote servers, select the Distribute Interface 
Customizations to Remotes and Remote Servers option.

�

�

	

�

�




�
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	 If applicable, click the Other Options button and set the 
Microsoft SQL Express database size restrictions. This 
option applies only if you are using SQL Server Express for 
remote sites. The limit of this type of Address Book is 10 GB. Note 
that if you are enforcing size restrictions, you must set up the 
corresponding notifications for these events in Administrator or 
Site Manager.

• Select the Minimize memory usage checkbox to limit the 
number of records that are loaded into memory during a 
processing session. This option applies to all remotes and the 
server.

Note that the Minimize 
memory usage checkbox may 
cause performance 
degradation. This option 
should be used only when the 
affected computers can 
process a limited number of 
records due to memory 
restrictions.

• Select the Enable Reverse Refresh checkbox to expose the 
Reverse Refresh option when sending a refresh.


 Click Apply. 

The server now supports synchronization using the configured 
transport methods.
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Adding Synchronized Address Books
MaxExchange Server allows you to synchronize multiple Address 
Books, which are added in MaxExchange Site Manager. 

In order to manage synchronized Address Books, you must have 
Maximizer Administrator privileges. Only the Address Books to which 
you have access rights are displayed in MaxExchange Site Manager. 

➤ To add a synchronized Address Book

� In MaxExchange Site Manager, select File > Add Synchronized 
Address Book. The Select Synchronized Address Book 
dialog box opens. 

� Select the Address Book for synchronization and click OK. 

The Synchronized Address Book Properties dialog box opens 
displaying the name of the Address Book and the MaxExchange 
synchronization server.

� Click OK. The Address Book appears in the Distribution Sites tree 
view. You can now add remotes and remote servers to 
synchronize with each Address Book.

� Restart MaxExchange Server Manager and the MaxExchange 
Service if applicable.
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The new Address Book will not be synchronized until the 
MaxExchange Server Manager and MaxExchange Service (if 
applicable) have been restarted.
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Setting Up Distribution Sites
Distribution sites are computers where MaxExchange Remote or 
MaxExchange Remote Synchronization Server is installed. You can 
keep track of your distribution sites in MaxExchange Site Manager. 

When you create distribution sites, a wizard takes you through the 
following steps:

� Set up the remote’s general properties, including the initial 
transport method, and the server the remote connects with—the 
MaxExchange synchronization Server or a Remote 
Synchronization Server. For more information, see “Adding 
Remotes” on page 73 and “Adding Remote Servers” on page 76.

Remote Synchronization 
Servers are used only in n-tier 
situations. A Remote 
Synchronization Server is a 
remote with more remotes 
attached to it.

� Specify the distribution groups that apply to the remote. For 
more information, see “Assigning Distribution Groups to 
Distribution Sites” on page 78.

� Assign users to the remotes. For more information, see 
“Assigning Users to Distribution Sites” on page 79.

� Specify the remote’s redistribution filters. For more information, 
see “Restricting What Distribution Sites Can Do” on page 81.

� Set the remote’s distribution restrictions. For more information, 
see “Setting and Viewing the Distribution Preferences for a 
Remote” on page 82.

� Complete the setup. For more information, see “Completing the 
Remote Setup” on page 85.

The following sections contain additional information on setting up 
distribution sites:

• “Changing the Active Transport Method for a Remote” on 
page 86

• “Sending a Remote Refresh” on page 86

• “Changing a Remote’s Email Address” on page 88

• “Suspending Synchronization with a Remote” on page 89

• “Removing a Remote” on page 90
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Adding Remotes

You can synchronize more than one Address Book on a single 
MaxExchange server. Before adding your distribution site, ensure 
you select the correct Address Book.

➤ To add a remote

� Open MaxExchange Site Manager.

Note that only those Address 
Books for which you have 
Maximizer Administrator 
privileges appear in 
MaxExchange Site Manager.

� If you are synchronizing multiple Address Books, select the 
Address Book.

� In the “Distribution sites” tree view, select the server that the 
new remote should connect to if you are using an n-tier 
configuration. 

� Click Add to add a remote. In the Remote type dialog box, 
select Remote and click OK.

� Enter a descriptive name in the Name field (e.g., “New York 
Office”).

� If the remote connects directly to the server, select the server 
from the Parent drop-down list.

– or –

If the remote connects to a remote server, select the name of the 
remote server from the Parent drop-down list.
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� To synchronize all Address Book entries and opportunities to this 
site, select Address Book Mirror.

– or –

To synchronize only entries associated with specific distribution 
groups, clear the Address Book Mirror checkbox.

To avoid excessive transaction 
volumes at remote sites, 
Address Book Mirror sites are 
best suited for central Address 
Books under 10 GB. If you 
want to set up an Address 
Book Mirror for a larger 
database, you can exclude 
large documents and old 
entries from synchronization in 
the Address Book Mirror 
Properties.

The settings for Address Book Mirror sites are found in View > 
Address Book Mirror Properties.

	 Select Include site log files with synchronization to 
synchronize the remote’s packet summary log and remote 
activity log back to the server. For more information on log files, 
see “Log Files” on page 133. 


 Choose a transport method for this remote and specify the 
remote address. 

• FTP/HTTP – No address is necessary for a distribution site if 
you select FTP/HTTP. You are prompted to specify the server's 
address settings if you have not done this in the Server 
Setting dialog box. 

• Network Direct – Enter or browse for the network path to 
the remote’s “MaxExchange” program folder. This path must 
be a UNC path (e.g., \\<computer name>\MaxExchange) and 
accessible with read/write access from the server over the 
network.

• Email – Type the remote’s email address or click the Address 
button to select the address from a list.

��Specify the synchronization characteristics. These settings 
control how the packet transmission is initiated between this 
remote and its parent server and how synchronization is 
processed. 

• Synchronize clock with server – Uses the server’s time 
settings for the remote. This setting works with FTP and HTTP 
only. Note that this adjustment does change the time on the 
affected computer.

• Remote initially performs FTP active connections – If 
enabled, the remote initiates synchronization sessions using 
Active mode. If the connection is unsuccessful, the remote 
attempts connection again using Passive mode. This is useful 
for situations when the server may be restricted by a firewall.

• Save to Disk – This option enables data packets to be saved 
on removable media (such as a diskette or Zip disk), or to a 
hard disk directory. This option is useful when physical 
transport of data packets is either halted or impractical for 
some reason. For instance, due to poor telephone line 
integrity in some parts of the world, large initial refresh 
packets might be sent more reliably by disk. After this refresh 
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data packet is loaded on the remote computer, all further 
data packets can be sent using the typical transport method.

When you want packets sent again by the typical transport 
method, clear this checkbox.

• Do not refresh previous version – This field is used only 
when upgrading remotes. It enables an administrator to 
upgrade all machines before any processing takes place. 
Once all remotes are upgraded, the selection should be 
unchecked.

• Default behaviour for missing packets – Determines how 
the remote handles missing packets after the 2-minute time-
out period has elapsed.

This setting applies to the 
selected remote only. The 
value for the maximum packet 
size must be entered in 
megabytes.

• Maximum Uncompressed Packet Size – Controls outgoing 
packet size. If you leave this value as 0, no packet size limits 
are applied. The minimum value for packet size is 300 KB 
(enter this value as .3 MB) and the maximum value is 2 GB 
(enter this value as 2000 MB).

��Click Next or Finish depending on the type of site you are 
adding.

If the remote is an Address Book Mirror, the setup is complete. To 
specify distribution preferences for Address Book Mirror sites, select 
View > Address Book Mirror Properties.

�
�




��

� 	
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Otherwise, you next assign the appropriate distribution groups and 
users to the remote. For more information, see “Assigning 
Distribution Groups to Distribution Sites” on page 78.

Distribution Groups are created by adding a new table item to the 
MaxExchange Distribution system field. See “Creating 
Distribution Groups” on page 47.

Adding Remote Servers

See “MaxExchange 
Synchronization Server” on 
page 2 for more information 
on the use of remote servers 
for distributed packet 
processing. 

You can add remote servers the same way that you add remotes. 
After specifying the general properties of the remote server, you 
must specify the transport method that the remote server uses to 
connect with its remotes.

➤ To add a remote server

� Follow the procedure for adding a remote with the following 
exception:

• In the Remote type dialog box, select Remote Server. 

See Steps 1 through 11 in “Adding Remotes” on page 73.

The Transport Methods dialog box opens.

� Specify properties for the transport methods that the remote 
server will use to connect to its remotes.

• Primary FTP address/Secondary FTP address – Specify a 
primary and secondary (if necessary) IP address or domain 
name for remotes using FTP transport method.

• URL – Specify the URL of the Web Server where 
MaxExchange Web Service is installed for remotes using HTTP 
transport method.

• Network Address – Specify the path to the shared 
MaxExchange program folder for remotes using network 
direct transport method.

• Email Address – Specify the email address through which 
remotes connect using email transport method. 
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� Click Next or Finish depending on the type of site you are 
adding.

If the remote server is an Address Book Mirror, the setup is complete. 
To specify distribution preferences for Address Book Mirror sites, 
select View > Address Book Mirror Properties.

Otherwise, you next assign the appropriate distribution groups and 
users to the remote server. For more information, see “Assigning 
Distribution Groups to Distribution Sites”.
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Assigning Distribution Groups to Distribution Sites

When you set up your Address Book for synchronization, you put the 
Address Book entries into Distribution Groups. You now assign these 
groups of entries to each distribution site. This procedure determines 
which entries go to which sites.

A distribution site can only receive distribution groups that are 
available at the parent server. In an n-tier configuration, a remote 
server’s distribution groups must also include the distribution groups 
for the related site. For example, if a remote requires distribution 
groups A and B, the remote server must also be set up with groups A 
and B, as well as any other groups required by remotes attached to 
the remote server; otherwise, the remote will not receive group A or 
B Address Book entries.

All Address Book entries and 
opportunities from the parent 
server or remote server are 
synchronized to a remote site 
that is designated as an 
Address Book Mirror.

Group distribution is based on the MaxExchange Distribution system 
field items. This field is created automatically when you click the 
“Create MaxExchange Distribution” button in the System Options 
preferences tab in Administrator. You then create the items for the 
field in the System Fields preferences tab, which become 
“distribution allocations” for specific users. Values of the 
MaxExchange Distribution field are assigned to users on the Access 
Rights security tab. Each time the user creates an Address Book entry, 
the information is synchronized to the user’s assigned distribution 
groups. 

Server
All Groups

Remote Server
Groups A, B, C

Remote
Groups A, B

Remote Server
Groups A, C

Remote
Group A

Remote
Group A, C

Remotes

This example of a distribution list illustrates 
how the remotes only receive groups that are 
distributed to their parent remote server. The 
remotes in the bottom right cannot be 
assigned distribution group B because their 
remote server does not receive that group.
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Important note - If a 
Company or an Individual is 
created on the remote and no 
distribution group is assigned 
to it, it is synchronized to the 
server. However, it is removed 
from the distribution site the 
next time packets are received 
from the server.    

➤ To assign distribution groups to a site

� After setting the general properties of a distribution site, assign 
the appropriate distribution groups to the site by selecting one 
or more groups and then clicking Add in the Distribution 
Groups tab.

The distribution sites with the assigned group(s) will receive only 
those Company and Individual entries that have that group 
name (or names) in their MaxExchange Distribution system field. 
Distribution for Contacts follows the parent Company or 
Individual MaxExchange Distribution assignment.

� Click Next to continue adding the distribution site and 
proceeding with adding the site’s user distribution.

Assigning Users to Distribution Sites

User distribution is based on user visibility of the following items:

• Knowledge base articles

• Company Library documents

• Maximizer Word Processor Templates 

• Favorite Lists

• Column setups 

For more information about 
the visibility of items and 
security rights, see the 
Maximizer CRM 
Administrator’s Guide.

When a user has visibility of an item, it is synchronized to the current 
remote.

�

�
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➤ To assign a user to a distribution site

If you do not assign at least 
one user to a distribution site, 
column setups, Favorite Lists, 
knowledge base articles, 
Company Library documents/
notes, and document 
templates are distributed only 
if all users have visibility of 
these items. 

� Select one or more users for the site and click the Add button in 
the User Distribution tab. 

Knowledge base articles, Company Library documents, 
Maximizer Word Processor templates, Favorite Lists, and Column 
Setups that are visible to the assigned users, are synchronized to 
the remote.

By default, all users are 
assigned to Address Book 
Mirror distribution sites. To 
change the user distribution 
for Address Book Mirror 
distribution sites, select 
View > Address Book Mirror 
Properties.

� Click Next to continue adding the distribution site and 
proceeding with setting the site’s restrictions.

Initiating Synchronization

In some cases a refresh must be sent to the related user’s distribution 
site in order for the items to be synchronized. From that point on, 
items are synchronized automatically. Refreshes are necessary in the 
following situations:

• When a user is granted the “Modify other users’ private 
entries” security right, all items are synchronized to the 
distribution sites the user is assigned to after a refresh.

• If a user is granted the Knowledge Base Approver security 
right, all knowledge base articles are synchronized to the 
distribution sites the user is assigned to after a refresh.

• When a user is added to a security group, items that are visible 
to that group are synchronized to the distribution sites the user 
is assigned to after a refresh.

�

�
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For information on sending refreshes, see “Sending a Remote 
Refresh” on page 86.

Restricting What Distribution Sites Can Do

You can place restrictions on what kind of modifications a remote 
can redistribute to the other remotes through the server.

For example, if one remote often sends out large bulk mailings from 
the central Address Book, you may not want other remotes cluttered 
with hundreds or thousands of automatic Mail-type notes from that 
remote. You can specify that new Mail notes from this specific 
remote not be distributed elsewhere. Or if you don’t want another 
remote to be able to delete Address Book entries, you can prevent 
that from happening. You can also restrict many types of updates 
from being redistributed during MaxExchange synchronizations.

➤ To restrict redistribution of a remote’s changes

� After assigning distribution groups and users to the remote, set 
the remote’s restrictions by selecting the appropriate checkboxes 
for the restrictions you want

.

Each checkbox works as follows:

• To prevent new information added by this remote from 
being redistributed to other remotes during synchronization, 
select the appropriate Additions. These additions are still 
sent to the server, but they are not redistributed to other 
remotes.

• To prevent deletions made by this remote from causing the 
same information to be deleted at other remotes during 
synchronization, select the appropriate Deletions. Items 

�
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deleted at this remote are not deleted anywhere else in the 
distribution group, including the server.

� Click Next to proceed with setting up distribution preferences 
for the remote.

Setting and Viewing the Distribution Preferences for a Remote

You can set distribution preferences of Company Library documents, 
knowledge base articles, general documents, notes, opportunities, 
and customer service cases based on age and size. You can also apply 
a set of preferences to all existing sites and/or sites you create in the 
future.

➤ To set distribution preferences

� Set the Distribution option for each item in the Distribution 
Preferences dialog box.

Distribution preferences for 
Address Book Mirror sites are 
configured in View > Address 
Book Mirror Properties.

� If you would like to limit the age of the items distributed to this 
site, select the Do not distribute documents/notes/
opportunities/cases older than option and set the time frame 
to which the option applies. For example, if you don’t want to 
synchronize documents older than 1 year, set the counter to 1 
and select year(s) from the drop-down list. 

� If you would like to limit the size of the items distributed to this 
site, select the Do not distribute documents/notes larger 
than option and set the size of the item. For example, if you 
don’t want to synchronize documents larger than 2 MB, set the 
counter to 2. 

� To include Favorite Lists in refreshes, select the Distribute 
Favorite Lists on refresh option.

Note that Favorite Lists are synchronized at all times during a 
regular synchronization session. The Distribute Favorite Lists 
on refresh option allows an administrator to restrict the 
distribution of Favorite Lists during a refresh as a time-saving 
process. If you choose to not distribute Favorite Lists, the 
Favorite Lists on the remotes are preserved.

� To include saved searches in refreshes, select the Distribute 
Saved Searches on refresh option.

Note that saved searches are synchronized at all times during a 
regular synchronization session. The Distribute Saved 
Searches on refresh option allows an administrator to restrict 
the distribution of saved searches during a refresh as a time-
saving process. If you choose to not distribute saved searches, the 
saved searches on the remotes are preserved.
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� To apply the current distribution preferences to all existing 
remotes, select the Apply to all existing sites option. 

For MaxExchange Remote 
Server, the Apply to all 
existing sites and Set as 
default for new sites 
options apply to only its 
remotes. If the parent server 
applies different distribution 
preferences, its settings are 
used. Also, to modify a Remote 
Server’s distribution 
preferences, the changes must 
be done on the server. 

� To apply the current distribution preferences to all remotes you 
create in the future, select the Set as default for new sites 
option.

	 Click Finish to complete the process of creating the remote. See 
“Completing the Remote Setup” on page 85 to complete the 
remote setup.

�

�

�

�

� �
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➤ To view distribution properties in MaxExchange 
Site Manager and MaxExchange Remote

• The distribution preferences can be viewed as part of a 
distribution site’s properties in MaxExchange Site Manager. The 
distribution preferences may also be viewed in MaxExchange 
Remote by clicking the Preferences button while viewing the 
synchronized Address Book properties. 

MaxExchange Remote 
distribution preferences
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➤ To view distribution properties in Maximizer

Note that these Distribution 
attributes (other than the 
default preferences option) 
override the preferences set in 
MaxExchange Site Manager. 

• Distribution preferences appear as part of the properties for 
Company Library documents, knowledge base articles, general 
documents, and notes (right-click on one of these items and 
choose Properties). 

Completing the Remote Setup

➤ To complete the remote setup

� In the main dialog box for Distribution Sites, clear the Show 
Tree View option or click the remote’s Properties button. 

� Make a note of the new remote’s Address Book ID. You need 
this ID later when you receive the initial data packet at the 
remote.

CAUTION: If you later modify a 
remote, be careful not to 
change the Packet Status 
values unless you are 
absolutely sure that the status 
shown is not correct. Setting 
the Packet Status values 
incorrectly can cause you to 
lose data. 

The list view provides you with detailed information about a 
remote such as the warning column (indicates if a remote has 
not synchronized in a specified number of days provided remote 
warnings are enabled in Server Settings), while the tree view 
may be more efficient while you are adding remotes and remote 
servers. You may toggle between the two types of views to suit 
your preference.

MaxExchange creates an initial data packet—called a refresh—
for this remote during the next MaxExchange processing session. 
Its transport depends on the transport method the remote 
employs.

Distribution preferences for a 
general document
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Changing the Active Transport Method for a Remote

You can change the Active Transport Method for a remote after data 
synchronization has been established using another transport 
method. Plan the changeover before beginning the procedure, and 
coordinate the actions with all remotes. 

Before changing the Active 
Transport Method, ensure that 
all relevant system 
requirements are in place and 
the Active Transport Method 
operates successfully on the 
remote and the server.

If you have changed the Active Transport Method in Site Manager, 
the following events occur:

• A dialog appears informing you of the change in transport. 

• Site Manager instructs the server or remote server to send out 
the transport change to the remote in the form of a special data 
packet. This packet is transported using the previous transport 
method.

• The server or remote server continues to check for packets using 
the previous transport method from each remote until it receives 
a packet back from the remote confirming the receipt of the 
transport change. MaxExchange confirms the change of 
transport automatically at the remote with no user involvement.

Sending a Remote Refresh

When you add a new remote, an image of the central Address Book 
is automatically prepared and transported to the remote. All 
subsequent exchanges update the Address Book. You can manually 
send a refresh of the central Address Book at any time. The refresh 
completely overwrites the remote’s image of the Address Book with 
a fresh copy.

Before sending a refresh, contact the remote users to indicate that 
they should send an immediate update of their work. Otherwise, 
they will have to get another refresh after they send their update.

If a remote is restricted from adding items to the central Address 
Book using the Restrict Additions filter, the server stores those added 
items, but does not normally redistribute them to other remotes 
during synchronization. Refreshes are treated differently. When 
sending refreshes to any remote, items that would normally be 
blocked from redistribution are also sent. Refreshed remotes 
therefore receive all items for their images of the central Address 
Book, regardless of whether additions are restricted. (Items marked 
Restrict Deletions are not affected.) This filtering is ignored when a 
selected Address Book entry or opportunity is sent a refresh in the 
Sites tab of the Address Book Diagnostic Tools. 
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➤  To refresh a remote

� Open MaxExchange Site Manager.

� Select the remote that will receive a refresh, and click Refresh 
Site.

� If your remote is not an Address Book Mirror, a dialog box 
appears with 3 options—Refresh all, Refresh system and 
synchronization data, and Reverse Refresh. If your remote is 
an Address Book Mirror, the Refresh system and synchronization 
data option is disabled. Choose one of the options.

The Refresh all command sends data packets, which includes all 
data synchronized in a typical MaxExchange synchronization 
cycle. See “What Data is Synchronized?” on page 30 for more 
information. 

The Refresh system and synchronization data command 
sends data packets, which include the same data types as the 
Refresh all command with the exception of the following:

• Address Book entries, opportunities, customer service cases, 
and traditional campaigns. Also not included in this type of 
refresh are related notes, user-defined field values, 
documents, and OrderDesk orders.

• Examples of data types synchronized using a system refresh 
(Refresh System and Synchronization Data) are as follows:

• User-defined field definitions and related table-type field 
items, user data, column setups, Favorite Lists, knowledge 
base articles, Company Library notes/documents, macros, 
licenses, document templates, Strategy Library templates, 
and traditional campaign templates.

The Reverse Refresh command sends all data inserted during 
the specified date range at the remote to the server. Records 
sent by the remote will only add new records that do not exist on 
the server and will not overwrite or update any records that 
already exist.

�
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The Reverse Refresh option 
must be enabled in Server 
Settings > Other Options 
before it is displayed as an 
option when sending a refresh 
to a remote.

When Remotes or Remote Servers process a refresh packet of any 
type, the associated data types included in packet are removed 
from the Remote or Remote Server and then replaced by the 
data in packet. As a result, if Remotes and/or Remote Servers 
have data that is not synchronized to the Server before a refresh 
is processed, the data is lost. It is strongly recommended that the 
MaxExchange administrator ensures Remotes and Remote 
Servers synchronize their most recent data to the Server before 
processing a refresh.

� Confirm the refresh by clicking Yes.

� Click Close.

Changing a Remote’s Email Address

If the email address of the person responsible for a remote changes, 
you must update the distribution list with the new address.

➤  To change the email address of an existing remote

� Open MaxExchange Site Manager.

� Select the remote for which the email address needs to be 
updated.
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� Click Properties.

� Type the new email address or click Address Book to select it 
from the address list. 

� Click OK.

Suspending Synchronization with a Remote

After a distribution site has been created, you can temporarily 
suspend synchronization with this remote. When synchronization is 
suspended, the server processes all outstanding incoming packets for 
the remote and stops creating its outgoing packets. When the site is 
enabled again, a refresh is created for the remote when the server 
processes. If updates were made on the remote when 
synchronization was suspended, the updates are never synchronized 
with the server. 

This option is meant to be used when a remote is not active. The 
remote should process all packets before the suspension takes place. 

➤ To suspend synchronization with a remote

� In MaxExchange Site Manager, select the remote.

� Click Properties.
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� Select the Suspend synchronization checkbox.

� Click OK.

Synchronization with the remote is suspended.

Removing a Remote

You can remove a remote from the distribution list if it is no longer 
required. 

Before you remove a remote, you should first receive all packets from 
the remote to ensure that no data is lost. 

➤ To remove a remote

� Open Site Manager.

� Select the remote and click Delete.

When synchronization with a 
remote is suspended, an X is 
displayed as part of its icon when 
you are using the tree view. 
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Sales and Marketing Teams
For more information on the 

use of opportunities and 
traditional campaigns, see the 
Maximizer CRM User’s Guide.

Maximizer’s opportunity and traditional campaign management 
helps you pursue sales opportunities and marketing campaigns in a 
team environment. By setting up one or more teams, you can 
delegate opportunity or campaign tasks to individual team members.

You can also set up teams in Site Manager. If you use MaxExchange 
to synchronize data with a remote, you can also use Site Manager to 
ensure that team members receive the entries they need.

The following sections contain information on setting up sales and 
marketing teams for MaxExchange:

• “Adding a Team” on page 91

• “Adding New Team Members” on page 92

• “Renaming a Team” on page 93

• “Removing a Team or a Team Member” on page 94

• “Modifying Information about a Team Member” on page 94

• “Reassigning Opportunity or Campaign Tasks” on page 95

Adding a Team

You can create as many teams as required for the distribution of 
opportunity or traditional campaign information.

➤  To add a new team

� Open MaxExchange Site Manager.

� Click the Teams icon.

� In the Teams pane of the window, click the Add button.

� Enter the team name and choose the team type—Sales or 
Marketing.

Marketing teams are available 
for remotes because 
traditional campaigns may be 
synchronized. However, 
automated campaigns may not 
be synchronized.

� Click OK. 

� Add members to the new team, as described in the following 
procedure.

�

�
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Adding New Team Members

You can add as many members to a sales or marketing team as are 
required. A member can belong to one or more teams.

➤  To add a new member

� With Site Manager open and the Teams window active, select 
the team to which you are adding a member.

� Click the Add button.

� Type the name of the member in the Name field.

� Select the User ID for this member.

� Select the member’s status—Team Leader or Member.

A team can have only one 
Team Leader.

� Select the opportunity/campaign rights for the member. 

Audit – allows a member to view all traditional campaigns and 
opportunities assigned to them.

Edit – allows a member full access to all traditional campaigns 
and opportunities assigned to the team. Members with this type 
of access have full team leader rights and may modify the status 
of an opportunity or campaign and may also reassign tasks.

Standard – allows for basic rights to “work” (apply steps) 
opportunities and traditional campaigns. These rights do not 
allow the member to change a status of an opportunity or 
campaign. 
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� Choose this member’s remote by clicking the Add button and 
selecting from the list. If multiple remotes should receive this 
member’s opportunity information, select additional remotes.

	 Click OK, and OK again to close the Add Member dialog box. 

Renaming a Team

If the name of a team changes, rename the team for the distribution 
of opportunity or traditional campaign information.

➤  To rename a team

� Open Site Manager.

� Click the Teams icon.

� Select the team you want to rename.

� Click the Modify button.

� In the Team field, type the new name for the team.

� Click OK. 
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Removing a Team or a Team Member

You can remove a team or a team member from the distribution list 
if it is no longer required. However, you cannot delete a team if 
opportunities are associated with it, including opportunities that are 
won, lost, or abandoned. You can, however, reassign opportunities 
to another team member. For more information, see “Reassigning 
Opportunity or Campaign Tasks” on page 95.

➤ To remove a team

� Open Site Manager.

� Click the Teams icon.

� Select the team you want to remove.

� If you are removing a member, also select the appropriate 
member.

� Click the Delete button.

Modifying Information about a Team Member

When information about a team member changes, modify the 
member’s information.

➤  To modify information about a team member

� Open Site Manager.

� Click the Teams icon.

� Select the team to which this member belongs.

� Select the name of the member whose information you want to 
modify.

� Click the Modify button.

� In the Modify Member dialog box, change the information as 
required. 

To change the member’s remote:

• Select the remote you wish to remove and click Delete.

• Click Add to select a new remote(s).

� Click OK, and OK again to close the Modify Member dialog box.
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Reassigning Opportunity or Campaign Tasks

If a member is no longer part of the team, you can reassign their 
opportunity or traditional campaign responsibilities to other 
members of the team. Responsibilities include all opportunity or 
campaign activities and the member’s leader role.

➤  To reassign opportunities

� In Site Manager, click the Teams icon.

� Select the team whose opportunity or campaign tasks are to be 
reassigned.

� Select the name of the member whose responsibilities are to be 
reassigned.

� Click the Modify button and then click the Reassign 
Opportunity or Reassign Campaign button. 

� Select one or more activities or the leader role to be reassigned 
to another team member.

� Click on the Reassign Selected Item button. 

� In the Team Members dialog box, select the member of the team 
for reassignment of the task(s).

�

�



MaxExchange Synchronization Server 12
Administrator’s Guide

96
	 Repeat the preceding steps until all required items are 
reassigned, as required.


 When you are finished, click OK, and OK again to close the 
reassignment dialog boxes.

MaxExchange Notifications
MaxExchange enables you to send email notifications to a definable 
list of recipients when specific events occur and to log these events to 
a file. 

You set up Event Notification 
on the Preferences > System 
Options tab in Administrator.

Most often these events are significant error conditions requiring 
human intervention. They may also be notifications of irregularities 
in business process, such as a remote user who has not synchronized 
in a threshold number of days.

Event notification email messages and log files contain the following 
information about events:

• Date and time when the event occurred

• Type of event

• Address Book in which event occurred

• Action resulting from event (for example, activity suspended due 
to fatal error)

• Additional information about the event, such as error codes, 
suggested resolutions, etc. 

The following table describes the events for which notification is 
available, as well as probable causes and suggested resolutions for 
each.

Event description Cause Resolution

Start recovery MaxExchange Synchronization 
Server has halted.

Restart the server. You will be 
prompted to start the recovery 
process.

SQL password policy 
failure

A user has entered a password that 
does not meet the requirements for 
Windows and the password was 
synchronized to a server or remote 
that is running SQL Server 2005 and 
Windows 2003. 

The user must enter a password 
that meets Windows requirements 
and then synchronize again. See 
“Password Expiration Under 
Microsoft SQL Server 2005 or Later” 
on page 135 for more information.
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➤ To enable event notification

� In Site Manager, select File > MaxExchange Notifications.

� Select the Enable event notification checkbox.

� Select an event from the Events list, and click Properties.

On the Event Notification 
Properties dialog box, press F1 
to open online help and read 
descriptions of the available 
notification options.

� Select the notification options to enable for this event.

� If you selected Via email as one of the notification options, click 
Add to specify names and email addresses of notification 
recipients.

Remote not 
synchronized

MaxExchange Site Manager 
includes a threshold setting for the 
maximum number of days between 
remote synchronizations. A remote 
has exceeded that threshold.

Contact the remote and request 
that they synchronize.

Previously processed 
packet received

A packet has arrived that has 
already been processed.

Decide if you want to process the 
packet.

MaxExchange missing 
packet

MaxExchange has received a packet 
that should have been preceded by 
another packet, meaning that a 
packet has been missed.

Process the packet, or request a 
packet resend, or wait for the 
missing packet.

Low hard disk space The amount of available hard drive 
space is less than the required 500 
MB.

Clear some space on the hard drive 
until at least 500 MB is free.

Transaction Journaling 
off

Transaction journaling is turned 
off.

Turn transaction journaling on.

Incoming refresh packet 
received

A remote has received a refresh 
packet.

No action required. The remote has 
processed a refresh.

HTTP password error The HTTP password is incorrect. Enter the correct password in the 
dialog box.

FTP password error The FTP password is incorrect. Enter the correct password in the 
dialog box.

Fatal database error There are multiple causes of this 
error. The email notification will 
contain the specific error code.

Database recovery may be 
required.

Database is in use Another application has an 
exclusive lock on the database and 
MaxExchange cannot access it.

Determine which application has 
locked the database and remove 
the exclusive lock.

Event description Cause Resolution
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� Click OK to close the Event Notification Properties.

� Repeat steps 3 through 6 for each event for which you want to 
enable notification or logging.

	 Complete the SMTP server settings fields as they apply to your 
SMTP server, and click OK.

Event notification is now configured.

➤ To view the Event Notification log file

� In Site Manager, select File > MaxExchange Notifications.

� Click View Log File. 

The EventNotification.log file opens in a text editor.

➤ To open the Windows Event Viewer

� Select Start > Programs > Administrative Tools > Event 
Viewer.

� In the left pane, select Application Log.

Maximizer event notifications appear in the right pane of the 
Event Viewer.

�

� �

�

�
	

�
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Address Book Diagnostic Tools
The Address Book Diagnostic Tools screen is available from the File 
menu in Site Manager. It enables you to run diagnostic tests on 
synchronization of Address Book entries and Opportunities. 

Address Book Entries and Opportunities

These two tabs allow you to check a specific Address Book entry or 
Opportunity to determine which remote(s) it synchronizes with, 
which is useful when an Address Book entry or Opportunity is 
missing from a remote.

Field, Option, or 
Button Purpose and Use

Address Book entry 
ID

Enables you to search by the ID of the Address 
Book entry or Opportunity. Enter part or all of 
the Address Book entry or Opportunity ID for 
which to verify synchronization information.Opportunity ID

Address Book entry 
name

Enables you to search by the name of the 
Address Book entry or Opportunity. Enter part 
or all of the Address Book entry or Opportunity 
name for which to verify synchronization 
information.

Opportunity name
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Search After entering the search criteria in the ID or 
name field, click the Search button. It returns a 
list of matching Address Book entries or 
Opportunities. If you leave the ID and Name 
field blank, it returns all entries.

Select Address 
Book entry

Displays an alphabetical list of all records. 
Select the first letter of the Address Book entry 
or Opportunity name to jump to that section 
of the list. For large Address Books, this 
operation could take quite some time to 
retrieve all entries. 

Select Opportunity

Search result Displays the results of a search by ID or name, 
or displays a complete list of records in 
alphabetical order if you selected the Select 
Address Book entry option.

Distribution site Displays which remote(s) the selected record is 
associated with.

Perform Address 
Book entry 
Distribution Test 
for

Identifies the remote for which to perform a 
distribution test. A distribution test verifies 
that Address Book/Opportunity information is 
being synchronized with a remote. The results 
identify issues such as membership problems or 
corrupt DRB files. The results are displayed in 
the dialog box

Perform 
Opportunity 
Distribution Test 
for

Log test result Saves the results of the distribution test to a 
log file.

View Log Opens the saved log file in a text editor.

Field, Option, or 
Button Purpose and Use
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Sites

This tab enables you to count and view the Address Book entries and 
Opportunities synchronized to each remote.

Field, Option, or 
Button Purpose and Use

Address Book 
records

Identifies which type of records to display.

Opportunity 
records

Select a 
distribution site

Identifies the remote for which to display 
records.

Total number of 
records

Displays the total number of records of the 
selected type for the selected remote.

Name, City, etc. Displays the record details.

Refresh selected 
record

Sends a copy of the server’s version of the 
selected record to the selected remote on the 
next synchronization. If the remote has an 
outdated or incomplete version of the selected 
record, this information will be replaced by the 
correct server version of the selected Address 
Book or opportunity record. 
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Distribution

This tab calculates the number Address Book entries and 
Opportunities that are to be synchronized with remotes that access 
this server directly (i.e., first-tier only).

Field, Option, or 
Button Purpose and Use

Distribution 
Summary

Queries the Address Book for information 
about the Address Book entries and 
Opportunities. The distribution summary 
returns the following details:
• Total Address Book records distributed
• Marked Address Book records

• Unmarked Address Book records
• Address Book distribution caused by marked 

Opportunities
• Address Book distribution caused by roles in 

distributed Opportunities

• Total Opportunity records distributed
• Marked Opportunity records
• Unmarked Opportunity records

Distribution Sites Identifies all distribution sites in the 
distribution tier. 
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MaxExchange Site Manager Reports
MaxExchange Site Manager includes the following reports:

• Server Settings – This report provides an overview of each 
server's settings.

• Distribution sites – This report displays an overview of 
information about remotes, which is useful for troubleshooting. 
You may wish to use this report in conjunction with the 
Transaction Report to determine which remotes are 
synchronizing and which are not.

• Transaction – This report provides information about the 
current synchronization status of remotes. You may wish to use 
this report in conjunction with the Distribution List Report. The 
output of this report depends on the current view in 
MaxExchange Site Manager. If the display is in Tree View, then 
only the selected remote is included in the report. If the display is 
in table view, then any selected remotes are included in the 
report.

• Teams – This report is useful for determining which remote each 
sales and marketing team belongs to. The same report is also 
available from the Reports menu in Administrator.

• Remote Packet Summary – This report displays the packet 
summary log of the selected remote. The log contains the time 
and date that packets were received by the remote.

• Remote Activity – This report displays the activity log of the 
selected remote. The log contains information including the 
number of packets that are sent and received, as well as the 
additions, deletions, and updates to the Address Book.

All of these reports are available for servers and remote servers.

These reports are accessible from the Reports menu. Selecting a 
report from the menu opens the Report Options dialog box, where 
you can specify the report format:

Log distribution 
summary

Saves the results of the distribution summary 
to a text file. The file is saved at the root of the 
MaxExchange program folder on the server 
(typically C:\Program 
Files\Maximizer\MaxExchange). The file is 
called DSTRBLG.TXT.

View Log Displays the DSTRBLG.TXT file in a text editor.

Field, Option, or 
Button Purpose and Use
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• HTML format – Creates the report in HTML format and displays 
it in a browser window.

• CSV format – Saves the report to a .CSV (comma-separated 
values) file, which you can open in a spreadsheet, such as 
Microsoft Excel.

➤ To Print a MaxExchange Site Manager Report

� In MaxExchange Site Manager, click the Reports menu.

� Select a report from the menu.

� In the Report Options dialog box, select either HTML Format or 
CSV Format.

� Click OK.

If you selected HTML Format, the report opens in a browser 
window.

– or –

If you selected CSV Format, the Save As dialog box opens, so you 
can select a folder and filename for the report.
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The Role of MaxExchange Server and Remote Server
As discussed in the introduction chapter, the role of the 
MaxExchange Server is to keep data synchronized between the 
central Address Book, located on the server, with its remotes and 
remote servers. The combination of MaxExchange Server and the 
other MaxExchange programs—MaxExchange Site Manager, Remote 
Server, and Remote—ensures that users always have the most up-to-
date information, no matter where they are located—at the office, 
at home, or on the road. 

A MaxExchange Remote Server serves the same purpose in terms of 
data synchronization with the additional function of synchronizing 
data with the central Address Book on the parent server. All 
functionality described in this chapter pertains to a Remote Server 
when acting in that role. Refer to the Maximizer CRM User’s Guide 
for information about Remote Server acting in the capacity of a 
remote. 

Server Database Rights

You must ensure that the MaxExchange Server user has the proper 
rights for Microsoft SQL Server (dbcreator and securityadmin server 
roles and also the db_owner role for the Address Book) for 
MaxExchange synchronization. This is also true if you are using 
Windows Authentication. 
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Setting Up MaxExchange Server
The MaxExchange server is the top level in the MaxExchange 
hierarchy. The server manages the Distribution List for the entire 
MaxExchange network, and processes and sends data packets to 
remotes and remote servers immediately below it in the structure.

Setting up MaxExchange is a very order-dependent process. 
Although much of the configuration of MaxExchange takes places at 
the server, you must ensure that you perform these steps in the 
correct order. 

You can add additional 
Address Books for 
synchronization in 
MaxExchange Site Manager at 
any time. 

During the installation, you designate a single Address Book as your 
organization’s central synchronization repository. At the server, you 
can then schedule how frequently to synchronize the server with its 
various Distribution Sites in order to keep the central Address Book 
up to date and set other synchronization options. Some tasks are 
performed manually when needed.

Before the Server can be configured to send data packets to 
Distribution Sites, the MaxExchange Site Manager must be installed 
and configured. Please refer to “Configuring Server Settings” on 
page 67 and “Setting Up Distribution Sites” on page 72. 

How MaxExchange Server Works

Distribution Sites run MaxExchange Remote or Remote Server to 
synchronize their Distribution Site changes with those on the Server. 
The changes are then stored on the MaxExchange Server, making the 
Server’s image of the central Address Book the most complete copy 
of the synchronized Address Book. Distribution Sites can either have 
an exact image or a subset of the MaxExchange Server central 
Address Book. For more information about the processes involved in 
MaxExchange data synchronization, see “MaxExchange 
Process Flow” on page 29.

ServerServer

Remote 
Server

Two-tier Configuration N-tier Configuration

Remote

Remote
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Starting and Exiting MaxExchange Server
You can start MaxExchange 

Site Manager by choosing 
Open Site Manager from the 
File menu in MaxExchange 
Server Manager. 

When you install MaxExchange Server as a service, MaxExchange 
Server Manager does not have to be running for synchronization to 
take place. If you install MaxExchange Server as a desktop 
application, the program must be running during synchronization. 

When you start MaxExchange Server, you are prompted for your 
Maximizer user name and password. Note that to log into 
MaxExchange Server, you must have Maximizer Administrator 
privileges.

MaxExchange Server always 
prompts for a user name and 
password, even if you are 
using Windows authentication 
for Maximizer.

➤  To start MaxExchange Server Manager

• If you have installed MaxExchange Server as a desktop 
application, select Programs from the Start menu and from the 
folder in which you installed MaxExchange, select 
MaxExchange Server Manager. By default, MaxExchange 
Server is installed in the Maximizer CRM folder. If you have 
created an icon during the installation of MaxExchange Server, 
you can also double-click on the icon to start the application. 

– or –

• If you have installed MaxExchange Server as a service, the service 
starts automatically when the server is started. You can open 
MaxExchange Server Manager by clicking its icon or choosing it 
from the Start menu as described above. 
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Processing Updates from the Server
You can schedule when to process updates of the central Address 
Book and you can also perform immediate updates. MaxExchange 
Server automatically checks for incoming changes from its remotes 
and then makes changes to the central Address Book. 

MaxExchange will only process 
data packets if there is enough 
free disk space.

After incoming changes have been processed, MaxExchange Server 
prepares and distributes data packets to all designated remotes. 
Once the synchronization is complete, the server and its remotes 
have the most possible up-to-date information. Changes that occur 
after processing has been done at a remote are processed during the 
next synchronization cycle. 

When MaxExchange Server processes updates automatically, it will 
do so for all synchronized Address Books on the server. When the 
server processes updates manually, if there are multiple synchronized 
Address Books, you are prompted to specify if you want to process all 
synchronized Address Books or just a specific Address Book.

The following sections contain additional information on processing 
updates from the server:

• “Processing Immediate Updates” on page 111

• “Setting Automatic Processing Timing Preferences” on page 112

• “Pausing and Resuming Processing Sessions” on page 113

• “Automatic Processing Interruptions” on page 114

• “Importing Data Packets from a Remote or Remote Server” on 
page 115

• “Using the Import List Initial Distribution Functionality” on 
page 116

• “Processing Refreshes Only for Remotes” on page 117

Processing Immediate Updates

You can manually process immediate updates from the server. 
Manual processing allows you, as an administrator, to check for 
processing errors throughout the entire distribution chain. If a 
synchronization problem occurs at a remote, an error message 
appears for that particular site and is visible until the synchronization 
process moves to the next remote. Errors are also written to the 
processing log file (named [AddressBookName]_log.txt on the server 
or Spdmlog.txt on a remote server). As good practice, manual 
processing should be done on a regular basis. 
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For MaxExchange Server to 
process updates using email 
transport, the MaxExchange 
Server and the email program 
must be running (though the 
email program can be 
minimized). 

➤ To process immediate updates

� In MaxExchange Server Manager or MaxExchange Remote 
Server Manager, click the Process Data Packets button or 
select File > Process Data Packets

� If you have installed MaxExchange Server Manager as a desktop 
application rather than a service, you can minimize 
MaxExchange Server Manager while it processes data packets, 
however, the program must remain running.

Setting Automatic Processing Timing Preferences

In addition to regular manually processing of updates, you set your 
automatic processing preferences on the server. These preferences 
set the time and frequency in which the server checks for updates 
from remotes and also set scheduling for transporting updates to the 
remotes. 

➤ To set automatic processing timing preferences

� In MaxExchange Server Manager or MaxExchange Remote 
Server, click the Timing Preferences button or select Edit > 
Timing Preferences.

� Choose the Simultaneously or Independently option. Depending 
on the method of transport you are using, one option is 
preferable to the other. You can choose Manually to always use 
manual processing by clicking the Process Data Packets button. 

Simultaneous processing – this method is the most commonly 
used method for HTTP, FTP, and Network Direct modes of 
transport. Using Network Direct transport, outgoing data 
packets are transported immediately before and after 
processing. Using FTP, incoming data packets are processed 
immediately and outgoing packets are left in the server’s outbox 
awaiting pickup from the remote sites. 

�
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Independently – this method is most commonly used for the 
email mode of transport. You can set processing times and 
transport times independently. Packets can then be processed at 
the server or remote during times when the remote/server is not 
active. 

If you are using HTTP or FTP, 
transport times cannot be 
automatic—remotes initiate 
the transport process; servers 
cannot initiate the process. 

� Set your processing time and the interval at which processing 
takes place. If you have chosen to process and transport data at 
independent times, set the transport time and interval as well.

� Processing automatically takes place when the server or remote 
initiates the action.

Pausing and Resuming Processing Sessions

You can pause a processing session and then later resume the 
session. MaxExchange automatically starts processing the data from 
the point where the session was paused. 

You can also shut down the MaxExchange Service completely in 
Windows Services. In the case of shutting the service down, 
MaxExchange will also start processing data at the point where the 
processing session was interrupted. 

�

�
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➤ To pause and resume a processing session

� In MaxExchange Server Manager, click the Pause button. (The 
Process Data Packets button becomes a Pause button after a 
processing session is initiated.)

� To resume the processing session, click the Resume button. (The 
Pause button becomes a Resume button after a processing 
session is paused.)

Automatic Processing Interruptions

Once timing preferences are set for automatic processing, the server 
processes data packets without user intervention, provided the 
server is running. If for some reason, processing is interrupted at a 
remote site, a messages will appear on the server.

The “hexadecimal” folder is 
actually a folder named with a 
hexadecimal number that 
corresponds to the Address 
Folder ID. This ID is displayed 
in the Distribution List dialog 
box in MaxExchange Site 
Manager.

If the Disk space is insufficient, Missing in Action or Previous Packet 
Processed message appears, the message box remains active on the 
server for approximately two minutes. If no user intervention occurs 
after two minutes has elapsed, the server initiates the action of 
waiting for the packet, then resumes processing, and the message 
box is closed. Use the Site Properties dialog box in MaxExchange Site 
Manager to set the default behavior.

�
�
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Importing Data Packets from a Remote or Remote Server

There may be times when you import update packets from a 
Distribution Site that were saved to disk or a folder using 
MaxExchange Remote or Remote Server. For example, you could use 
this functionality when recovering data from a computer failure or 
when a remote cannot process through its regular transport method. 

➤ To import a Remote packet

� In MaxExchange Server Manager or MaxExchange Remote 
Server Manager, select File > Import Packet.

� Specify the location and filename of the Remote data packet. 
The file must have an .HDR extension. Use the browse button to 
locate the file.

� Click OK.

The data packet is copied to a processing queue (the Inbox 
folder) and will be applied to the central Address Book during 
the next processing session.

�



MaxExchange Synchronization Server 12
Administrator’s Guide

116
Using the Import List Initial Distribution Functionality

The Import List Initial Distribution command provides a fast way to 
synchronize a large amount of data that was created by an import to 
the central Address Book. It uses the Favorite List, which is 
automatically created during the import to filter distribution of only 
the data that was imported. Other information is not processed 
when using this command—you need to process packets.

This feature should be used 
only when all the entries in the 
list are to be distributed to all 
remotes, regardless of the 
assigned Distribution Groups.

➤ To distribute data from an import to all remotes 

� In Maximizer, use a Global Edit to assign the appropriate 
Distribution Groups to all imported Address Book entries. 

� In MaxExchange Server Manager or MaxExchange Remote 
Server Manager, choose File > Import List Initial 
Distribution. A dialog box appears displaying all of your saved 
Favorite Lists. When you import data, a list is automatically 
created. 

� Choose the list for distribution. It is marked with the date and 
time when you imported the list. 

� Click OK. You are prompted with a message verifying the 
distribution of the list. Click OK again.

� The processing status is shown in the main window. Once the 
task is complete, the processing status will show as “ready”. 

�

�
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Processing Refreshes Only for Remotes

MaxExchange Server and Remote Server allow you to temporarily 
disable normal synchronization transactions with Distribution Sites. 
When the "Process Refreshes Only" option is turned on, only 
refreshes of a Distribution Site will be processed. This is a useful tool 
if you need to send a refresh to a Distribution Site and the Server is 
already occupied with many other transactions. You can turn on the 
Process Refreshes Only option, send the refresh to the Distribution 
Site, then turn off the option.

The refresh process sends the 
entire or a partial image of the 
central Address Book to a 
remote. Regular processing 
synchronizes only new 
transactions.

➤ To process refreshes only for remotes

� In MaxExchange Server Manager or MaxExchange Remote 
Server Manager, choose File > Process Refreshes Only. 

� In MaxExchange Site Manager, select the remote you wish to 
send the refresh to and click the Refresh Site button. 
MaxExchange Server ignores all other pending transactions 

�
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while the Process Refreshes Only option is enabled and processes 
only refreshes for the selected remote.

� Repeat step 2 for each remote to which you would like a refresh 
sent. 

�
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Setting Your MaxExchange Server Preferences
The following sections describe how to set preferences for the 
MaxExchange Server.

• “Setting Timing Preferences” on page 119

• “Setting Email Preferences” on page 119

• “Logging Preferences” on page 120

Setting Timing Preferences

Since timing preferences for a MaxExchange Server are part of 
automatic processing, this topic is addressed in the Processing 
Updates from the Server section. See “Setting Automatic Processing 
Timing Preferences” on page 112 for more information. 

Setting Email Preferences

To optimize MaxExchange Server operations when using email for 
data transport, specify the email system you plan to use in the Email 
Preferences dialog box. 

➤ To set your email preferences

� Select Edit > Email Preferences.

� Specify the email system on the server. Note that the email 
system used for data transport must be the same on the server 
and the remote(s).

� Specify the allowable maximum packet size in kilobytes (KB). 
This applies to the outgoing packet size on the server. Email 
packets are then limited to this size. If a packet is larger than this 
limit, the packet is spanned into smaller packets within the limit. 
If the limit is set to 0, the packet size is unlimited.

You can also control packet 
size in MaxExchange Site 
Manager on a per remote 
level. While the setting in 
email preferences applies to 
only email, the setting in Site 
Manager applies to all 
methods of transport. 
Regardless of the setting in 
Site Manager, when you are 
using email transport, packet 
sizes are set at the maximum 
packet size specified in email 
preferences. 

� To ensure that changes in email attachments do not occur 
through transport over the Internet, select the Use 7-bit 
Internet format option.

� Enable the partial packet warning if necessary. This warns you 
if all parts of a packet have not been received. 

For instance, take an example where a system administrator sets 
the limit on packets to 2 MB (or 2000 KB). Assume that the Server 
creates a large data packet that is 3.5 MB or 3500 KB. 
MaxExchange will break this packet into 2 partial packets. If only 
one of these data packets arrives, but the other is still in transit, 
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the data from the first partial data packet cannot be processed 
until the second partial data packet is received as well.

� Enter your email account Email profile/User name and 
password (if required). The available options vary depending 
on what type of email application you are using. 

Logging Preferences

If you are experiencing problems during a MaxExchange 
synchronization session or suspect that MaxExchange Server is not 
sending updates or receiving updates from its remotes you can log 
MaxExchange activity in troubleshooting logs. MaxExchange Server 
creates two types of logs. Both types are text files located in the same 
folder as your MaxExchange programs.

➤ To create logs

� In MaxExchange Server Manager or MaxExchange Remote 
Server, select Edit > Logging Preferences. 

� To log the date and time when data packets are received by the 
server, select Maintain Packet Summary. Log information is 
saved in text files named [AddressBookName]_packlog.txt on 
the MaxExchange Server, MaxExchange Remote Server, and 
MaxExchange Remote.

To view the log, choose View > Packet Summary Log.

� To log detailed information from the server including the 
number of data packets that are sent and received, as well as the 
additions, deletions, and updates to the central Address Book, 

�

�
�

�

�
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select Maintain Server Activity. Log information is saved in 
text files named [AddressBookName]_log.txt on the server or 
Spdmlog.txt on remote servers.

To view the log, choose View > Server Activity Log. 

� Indicate the level of log detail you want to see in the log files by 
selecting one of the following options:

• To log errors only, select Low.

• To log record-level updates (additions, changes, and 
deletions of Maximizer entries), select Medium.

• To log field-level updates (details of changes within 
Maximizer entries), select High.

� Indicate how often you would like a summary of the transaction 
information logged. The Every Packet option is the most 
detailed logging, while Every Processing Session the least 
detailed logging. 

� Click OK.

�
�

�

�
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Maintaining MaxExchange
The following sections explain specific tasks in MaxExchange Server 
that are used to monitor and maintain the MaxExchange system.

• “Viewing Synchronized Address Books” on page 122

• “Changing the HTTP or FTP Password on a Remote Server” on 
page 122

• “Address Book Maintenance” on page 123

• “Verifying and Recovering an Address Book” on page 124

Viewing Synchronized Address Books 

You may view certain transport information for the synchronized 
Address Book on a server such as the number of remotes that are 
synchronizing using the various methods of transportation.

Note that there can be multiple synchronized Address Books on a 
MaxExchange server, while there can be only one synchronized 
Address Book on a remote server. 

➤ To view synchronized Address Books on a server

� In Server Manager, select View > Synchronized Address 
Book.

� If you are synchronizing multiple Address Books on the server, 
you are prompted by a dialog box to choose an Address Book.

� The Address Book name, its DSN, Address Book ID, server 
address, and the number of synchronized remotes are shown. 

� When finished viewing, click OK to exit the dialog.

Changing the HTTP or FTP Password on a Remote Server

If you are using HTTP or FTP transport on a remote server, and the 
administrator changes the HTTP or FTP transport password on the 
server, you must update the password manually on the remote 
server.

➤ To set the HTTP or FTP transport password

� In Remote Server Manager, select View > Remote 
Synchronized Address Book.

The Remote Synchronized Address Book dialog box opens.
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� Select the Address Book.

� Click Properties.

The Properties dialog box opens.

� Enter the HTTP or FTP server Password, and click OK.

� Close the Remote Synchronized Address Book dialog box.

Address Book Maintenance

The Address Book Maintenance feature checks for discrepancies in 
the distribution data set between the server and its remotes. 
Essentially, when this utility is run, a snapshot of the DRB file/table is 
taken, then the DRB file/table is rebuilt, and if discrepancies exist, the 
missing data is sent out to the remote(s). You can, however, use this 
utility to compare and repair discrepancies in the DRB file/table 
without sending any data out to the remote(s). For more information 
on the DRB file/table, see the “Glossary” on page 5. 

You can run Address Book Maintenance immediately, or schedule it 
to run at a specific time. You also have the choice of performing 
maintenance on all of your remotes or only a selected remote. 

➤ To perform Address Book maintenance

� In MaxExchange Server Manager or MaxExchange Remote 
Server, select File > Address Book Maintenance.

� If you are synchronizing multiple Address Books on the server, 
you are prompted by a dialog box to choose an Address Book.

� Set the frequency in which you would like maintenance to run. 
You can choose to perform the maintenance immediately for all 
or just one of your sites. To perform immediate maintenance, 
choose Right Now. Then, select Just this Site and the 
corresponding site to perform maintenance on only the selected 
site. 

It’s good practice to have a regular maintenance program—
running maintenance on the weekend or sometime during your 
company’s downtime reduces chances of synchronization issues 
arising, while not interfering with your routine schedule.

� Choose Do Not Create Maintenance Data Packets if you 
want to ensure the DRB file/table is rebuilt for your remotes, or 
your selected remote, but missing data is not sent. 

� Select Perform Site Maintenance on Refresh option to 
rebuild the DRB file/table when performing a Refresh on a 
remote serving as an integrity check for correct data distribution. 
Note that this option applies only when you have initiated a 
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refresh for a remote using MaxExchange Site Manager; you 
select a remote and click the Refresh button. 

This option works the same way as the Enable Partial Rebuilds 
option in the Server Settings in MaxExchange Site Manager. 

� Click OK to close the dialog box.

Verifying and Recovering an Address Book

You can verify and recover only 
one Address Book at a time.

Address Book verification enables you to quickly identify and resolve 
invalid and orphan items in your Address Book. You should always 
run Address Book Verification and Recovery after upgrading or 
restoring an Address Book. Also, if database views have not been 
created for any user-defined fields and are needed for generating 
reports, use Address Book Verification and Recovery to create the 
missing database views.

Address Book Verification and Recovery identifies the following 
Address Book items.

�

�
�

�

Address Book Item Description

Orphan Contacts Contacts that are not associated with a 
Company record.

Orphan alternate 
addresses

Addresses that are not associated with an 
Address Book record.

Orphan notes Notes that are not associated with an Address 
Book entry, opportunity, campaign, or customer 
service case.

Opportunity records 
with invalid 
Start_Date field 
value

Opportunities whose start date does not match 
the earliest Sales Step start date (applies only to 
opportunities with an assigned strategy).

Notes with 
undefined Entity 
Type

Notes that do not have an entity type value 
(Address Book entry, opportunity, campaign, 
customer service case, or user) assigned to the 
record 
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To see recovered entries, you 
must log in as MASTER or have 
rights to open other users’ 
entries.

When you choose to “recover” the Address Book, Maximizer 
transfers recovered Address Book entries into a single entry called 
“Recovered on [date of recovery]”, and it transfers recovered 
Company Library documents into a single folder called “Recovered 
on [date of recovery]”. You can then view the recovered entries and 
either delete or move them as needed.

Broken Company 
Library links

Company Library links that try to connect to a 
missing document (link exists but the document 
is missing).

Orphan Company 
Library links

Company Library links that link to a missing 
Company Library folder (document exists, link 
exists, but the Company Library folder is 
missing).

Orphan Company 
Library documents

Company Library documents not listed in the 
Company Library folders (document exists but 
the link is missing).

Invalid Opportunity 
records

Opportunities whose start date does not match 
the earliest Sales Step start date (applies only to 
opportunities with an assigned strategy).

Invalid Address book 
records

Company records containing personal 
information about an Individual or Contact.

Invalid Document 
records

Documents whose Owner field contains invalid 
characters or values.

Misplaced 
Document records

Documents whose Owner field contains an 
incorrect value.

User-defined fields 
that do not have 
associated database 
views

User-defined fields for which a database view 
has not been created.

Invalid Table UDF 
Item records

Table user-defined field items that have the 
wrong type (Company, Individual, Contact, etc.).

Invalid/orphan Table 
UDF values

Table user-defined field values that reference 
non-existent table items.

Orphan Link Records Opportunities that do not have a related 
Address Book entry.

Address Book Item Description
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➤ To verify an Address Book

� In MaxExchange Server Manager or MaxExchange Remote 
Server Manager, select File > Address Book Verification.

� If you are synchronizing multiple Address Books on the server, 
you are prompted by a dialog box to choose an Address Book.

� Choose either the Verify Only or Verify and Recover option, 
and click OK.

If you select Verify Only and 
Maximizer detects invalid 
records, it prompts you to 
recover them.

Maximizer runs the Address Book verification process, as well as 
the recovery process if you selected the second option. When it is 
complete, you see the Address Book Verification and Recovery 
Information dialog box, which contains a summary of each 
verification performed and the results of the verification.

� If you selected the Verify and Recover option, open the 
Address Book in Maximizer, and view the Recovered on [date] 
Address Book entry. You can then delete or move the recovered 
entries.

�
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In this chapter... 

“Maximizer Email Transfer Issues” on page 128

“Date and Time” on page 128

“Converting Embedded Documents to Linked Documents” on page 129

“Transport methods” on page 129

“Distribution Groups” on page 130

“SQL Server Database Rights” on page 130

“Transaction Journaling” on page 131

“Removal of Records from Synchronization Cycle” on page 131

“Routine Maintenance” on page 131

“Changes in Employees and Remote Sites” on page 132

“FTP Password Change” on page 132

“FTP Address” on page 133

“Log Files” on page 133

“HTTP Transport and Microsoft IIS” on page 134

“Password Expiration Under Microsoft SQL Server 2005 or Later” on page 135

“Queuing Up for Processing Message” on page 136

“Running Only MaxExchange Server Manager” on page 137
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Maximizer Email Transfer Issues
In Maximizer, you can transfer Address Book information by email 
(click the Maximizer button, and in the Import/Export/Transfer sub-
menu, select Address Book entries from the Transfer section). If you 
are using MaxExchange for data synchronization, the email 
transfer process must never be used—if these processes are used 
in combination, duplicate records are created in the Address Book. 

Date and Time
An important issue that affects synchronization accuracy is the date 
and time setting on the server.

All data that MaxExchange synchronizes is stamped with the date 
and time the changes were made. The date and time is stored in 
Coordinated Universal Time (UTC), so the server processes the 
transactions at the correct time, regardless of the time zone they 
were created in.

Selecting “Synchronize clock with server” uses the server’s UTC time 
settings for the remote. This setting works with FTP only. Note that 
this adjustment does change the time on the affected remote 
computer. If using other transport methods, clock settings on each of 
the computers should be periodically checked for inconsistencies.

You should check the date and time of all computers that are part of 
the synchronization, including the MaxExchange server and the 
database server, before installing the software.
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Converting Embedded Documents to Linked Documents
In a MaxExchange environment, converting embedded documents to 
linked documents with the document conversion utility in 
Administrator (File > Document Administration > Convert Embedded 
Documents) affects the distribution of documents. If the conversion 
is done on the server, documents are removed from all its remotes. If 
the conversion is done on a remote, documents are removed from all 
remotes except the remote that performed the conversion. In either 
case, documents remain on the server.

As an alternative to converting embedded documents to linked 
documents, you can manage the size of remote synchronized 
Address Books by controlling document distribution through a 
remote’s distribution preferences. See “Setting and Viewing the 
Distribution Preferences for a Remote” on page 83 for more 
information.

Transport methods

HTTP

You must have an ISP (Internet Service Provider) to facilitate the 
physical transport of MaxExchange data packets. Also, TCP/IP 
networking must be enabled on all MaxExchange computers.

FTP

A static IP address or a fully qualified domain name is required for 
the MaxExchange Server and MaxExchange Remote Servers.

No other FTP services can be enabled on the MaxExchange Server.

If port 21 does not seem to work with MaxExchange Server, this may 
be changed to any other value with the exception of the values 
within the range of 10035 – 11315; these values are used for 
MaxExchange file transfer

Email

All computers synchronizing using Email must have the same email 
client (version and configuration) as the MaxExchange Server.

The email client on the server and remotes must be installed and 
configured prior to installing MaxExchange.
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Network Direct

Users must always have access to the network when they need to 
synchronize.

The MaxExchange folder on the server must be shared to the 
remotes, and the remote users must have read and write permission 
on the folder. Similarly, the MaxExchange folder on each remote 
must be shared to the server, and the server user must have read and 
write permission on the folder. Read and write permission should 
extend to Sharing and Security.

If the MaxExchange Server is run as a service, the MaxExchange 
Service should run under a user with read and write permission on 
the MaxExchange folder on each remote.

By default, the MaxExchange folder is C:\Program Files\Maximizer\ 
MaxExchange.

Distribution Groups
To keep the synchronization flow simple, you can create a 
distribution group which is assigned to all entries in an Address Book. 
This ensures that all the necessary data is sent to all remote sites. In 
doing so, access to the entire address book folder is provided for all 
remote sites. Keep in mind that the necessary bandwidth and 
hardware infrastructure must be in place to synchronize all the data 
in an Address Book to all remote sites.

SQL Server Database Rights
You must ensure that the MaxExchange Server user has the proper 
rights for Microsoft SQL Server (dbcreator and securityadmin server 
roles and also the db_owner role for the Address Book) for 
MaxExchange synchronization. This is also true if you are using 
Windows Authentication. 
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Database for Packet Processing
A SQL database is created to store the incoming data packets for 
each Address Book you are synchronizing with MaxExchange in 
Microsoft SQL Server. The name of the database corresponds with 
the name of the Maximizer Address Book followed by an underscore 
and MaxExData. For example, if an Address Book has the name 
Escona Tutorial, the database created in SQL Server for the storage of 
MaxExchange packets is called EsconaTutorial_MaxExData.

Transaction Journaling
Do not enable the Transaction Journaling in a new Address Book 
until just before adding your first remote. 

Once this field is enabled, each change to Address Book entries 
marked for distribution (MaxExchange Distribution field) is written 
to the transaction file/table. This could result in a large number of 
necessary transactions that will later be processed.

Removal of Records from Synchronization Cycle
If an Address Book entry is no longer being used by any remote site, 
the record should be unmarked for synchronization. While no 
changes would need to be synchronized to the remote, refreshes to 
remote would cause unnecessary processing time. 

Routine Maintenance
To prevent synchronization issues, regular maintenance should be 
performed. MaxExchange Server Manager and MaxExchange Server 
include a tool called Address Book Maintenance used to perform 
regular maintenance. For more information, see “Address Book 
Maintenance” on page 123. 

You should also do periodic searches for Address Book entries that 
are not marked for synchronization. This ensures that all the entries 
have been properly added to the Address Book. To avoid incorrect 
entries being created, you can set up a default entry including the 
proper distribution group for a user or groups of users. You can also 
perform a global edit on a selected group of Address Book entries or 
default entries to change the distribution group selection. 



MaxExchange Synchronization Server 12
Administrator’s Guide

132
Verifying and Recovering an Address Book
Address Book verification enables you to quickly identify and resolve 
invalid and orphan items in your Address Book. You should always 
run Address Book Verification and Recovery after upgrading or 
restoring an Address Book. Also, if database views have not been 
created for any user-defined fields and are needed for generating 
reports, use Address Book Verification and Recovery to create the 
missing database views. This is an important function to perform 
after upgrading an Address Book. See “Verifying and Recovering an 
Address Book” on page 124 for more information.

Changes in Employees and Remote Sites
The following sections describe issues that come up when there are 
changes in MaxExchange teams and distribution sites.

• “Reassigning of Opportunities” on page 132

• “Removal of a Distribution Site in MaxExchange Site Manager” 
on page 132

Reassigning of Opportunities

If a team member is removed, opportunities should be assigned to 
another team member.

Removal of a Distribution Site in MaxExchange Site Manager

The deletion of a remote site in Site Manager causes synchronization 
with the distribution site to cease. Any packets in transit will not be 
processed by the server. Before deleting a distribution site, packets 
from the distribution site should be processed. 

FTP Password Change
If a change of the FTP password is required, all users are prompted 
with a message. The new password must be distributed to all remote 
sites. 
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FTP Address
If you are using an IP address for the FTP address, ensure it is 
accessible by the remote machines (external IP address that is not 
behind a firewall). Depending on the network security model used, if 
the IP address entered for the MaxExchange Server is an internal IP 
address, it may not be accessible by the remote machines.

Log Files
The following log files should be used as a reference when 
troubleshooting MaxExchange:

• Server Activity Log – [AddressBookName]_log.txt (MaxExchange 
Server) or Spdmlog.txt (MaxExchange Remote Server)

• Distribution List Log – Dstrblog.txt (Address Book Diagnostic 
Tools log - MaxExchange Site Manager)

• Packet Summary Log – [AddressBookName]_packlog.txt 
(MaxExchange Server, MaxExchange Remote Server, and 
MaxExchange Remote)

• Remote Activity Log – [AddressBookName]_log.txt 
(MaxExchange Remote)

• Remote Processing Packets Log - Statlog.txt (MaxExchange 
Remote)
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HTTP Transport and Microsoft IIS
For more information about 

using Microsoft IIS with 
Maximizer CRM, refer to the 
Maximizer CRM 
Administrator’s Guide.

If you are using the HTTP transport method, you must grant the 
following required permissions to the anonymous web access 
account in IIS on all MaxExchange server and remote server 
machines:

• full control permissions to the MaxExchange Inbox and Outbox 
folders, and any subfolders (these folders are located in 
...\Program Files\Maximizer\MaxExchange) 

• full control permissions to the MaxExchange DataSynch registry 
key (HKEY_LOCAL_MACHINE\SOFTWARE\Maximizer 
Software\MaxExchange\CurrentVersion\DataSynch)

By default, the anonymous web access account is 
IUSR_[ComputerName].

Refer to the following procedures for detailed instructions for 
granting these permissions.

➤ To grant full control permissions to MaxExchange 
folders

� Open Windows Explorer.

� Browse to the folder.

� Right-click the folder, and select Properties from the shortcut 
menu.

� Click the Security tab.

� Click Add.

� Select the anonymous web access account, and click Add.

� Click OK.

	 Select the Full Control checkbox in the Allow column, so it is 
checked.


 Click OK to close the Properties dialog box and save your 
changes.

➤ To grant full control permissions to MaxExchange 
DataSynch registry key

Use caution when modifying the Windows registry. Using the 
Windows Registry Editor incorrectly can cause serious problems that 
may require you to reinstall Windows. If you are uncertain about 
using the Registry Editor, please ask your system administrator for 
assistance.
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� Open the Windows registry editor. (Click Start > Run, type 
regedit, and click OK.)

� Navigate to the DataSynch registry key and select it.

HKEY_LOCAL_MACHINE\SOFTWARE\
Maximizer Software\MaxExchange\CurrentVersion\DataSynch

� Select Edit > Permissions from the menu.

� Select the anonymous web access user account.

� Select the Full Control checkbox in the Allow column, so it is 
checked.

� Click OK.

Password Expiration Under Microsoft SQL Server 2005 or 
Later

If your synchronized MaxExchange database is running on a machine 
with Windows Server 2003 or later, with Microsoft SQL Server 2005 
or later, SQL passwords for the “sa” user, or any user with the 
“System Administrators” server role, may expire periodically, 
according to the domain password policy or local password policy.

When you attempt to start MaxExchange Server Manager or Remote 
Server Manager after the system administrator password has expired, 
it will prompt you to log into the database through MaxExchange 
Site Manager. Site Manager then prompts you to provide the old, 
expired password and the new password. 

When you attempt to start MaxExchange Remote after the system 
administrator password has expired, it will prompt you to provide 
the old, expired password and the new password. 

Depending on the password policy configuration, new passwords 
may be required to be of sufficient complexity. For example, it may 
have requirements for minimum length, alphanumeric or special 
characters, etc. 
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Queuing Up for Processing Message
When attempting two or more of the following processes, a lock file 
prevents certain processes from occurring at the same time. Users 
receive a “Queuing up for processing” message because the lock file 
is preventing the following processes from occurring at the same 
time. 

• processing with MaxExchange

• adding a distribution site

You must ensure all users have full security rights to the 
MaxExchange flag file. Otherwise, you will receive the message even 
though two processes are not occurring at the same time. The flag 
file format is dbid.flg (2E076B59.flg). On a MaxExchange server, the 
file is found in the SvrShare folder (...All Users\Application 
Data\Maximizer\SvrShare) and on a MaxExchange remote the file is 
found at the root of the Maximizer program folder. 
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Running Only MaxExchange Server Manager
If you are running MaxExchange Server Manager on a different 
computer than the MaxExchange Server, you must ensure the 
following:

• MaxExchange applications are allowed through the firewall on 
both the computer running MaxExchange Server and the 
computer running MaxExchange Server Manager.

• The user running MaxExchange Server Manager is in either the 
Administrators group or the Distributed Com Users group on the 
computer where MaxExchange Server is installed.

• The anonymous logon user is allowed remote access to 
Component Services on the computer where MaxExchange 
Server is installed.

➤ To grant remote access to the anonymous logon 
user

� Open Component Services. (Click Start > Run, type dcomcnfg, 
and click OK.)

� Select Component Services > Computers > My Computer.

� Right-click and select Properties.

� Select the COM Security tab.

� Under Access Permissions, click Edit Limits.

� Select the anonymous logon user account.

� Under Permissions, select the Remote Access checkbox in the 
Allow column.
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