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CHAPTER

Introducing MaxExchange

In this chapter...

“About MaxExchange” on page 2

“How MaxExchange Programs Work Together” on page 2
“Glossary” on page 5

“Related Information” on page 7
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About MaxExchange

Welcome to MaxExchange—a tool that keeps Maximizer Address
Books synchronized between a server and remote offices or remote
users. MaxExchange allows you to transfer data between the server
and remotes using HTTP, FTP, folder-to-folder network direct
transport, email, or by transferring files on disk. Now your mobile
sales force can keep current with the latest changes to your entire
central Address Book or a subset of the Address Book, and your
home office can benefit from the latest data from the field, quickly,
easily, and automatically.

How MaxExchange Programs Work Together

@ Throughout this document, the
MaxExchange Synchronization
Server is referred to as the
MaxExchange Server or server.
The MaxExchange Remote
Synchronization Server is
referred to as the
MaxExchange Remote Server
or remote server.

MaxExchange consists of the following applications:
e MaxExchange Synchronization Server

e MaxExchange Remote Synchronization Server

e MaxExchange Server Manager

e MaxExchange Remote

e MaxExchange Site Manager

MaxExchange Synchronization Server

One person is usually in charge of setting up and administering the
central Address Book. This MASTER user, or a user with Maximizer
Administrator privileges, acts as an administrator for the
MaxExchange Server, designates a Maximizer Address Book as the
central Address Book—or central Address Books if you are using
multiple databases—and schedules updates.

There is only one server for any given Address Book, but one server
can have many remotes. These sites are either remote servers or
remotes, which can be connected by LAN, WAN, dial-up access, or
through the Internet. The central Address Book is maintained on the
MaxExchange server, while the remote computers have different
replications of the central Address Book.

MaxExchange Server can also be installed as a service on Windows
Server 2003, Windows XP, and Windows Server 2008. The service runs
in the background, as any other Windows service, and typical
processing is done automatically. Manual control of processing or
any other server tasks are then done through the MaxExchange
Server Manager from another machine or on the server.
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MaxExchange Remote Synchronization Server

N-tier Synchronization

@ An n-tier configuration is an
unlimited number of remotes
and/or remote servers.

MaxExchange Remote Synchronization Server acts as a middle tier in
a multi-tiered synchronization tree. Remotes run MaxExchange
Remote Synchronization Server to synchronize their remote changes
with those on the site’s parent server, which is either the
MaxExchange Synchronization Server or a MaxExchange Remote
Synchronization Server.

MaxExchange Remote Synchronization Server has the following two
basic functions:

e It synchronizes changes from its remotes with the server and
receives updates from the server.

e It generates and sends its own updates to its remotes.

MaxExchange Remote Server acts in the capacity of a server and as a
remote. It may be installed as an application and service or as a
service only. For information on server tasks, refer to “MaxExchange
Synchronization Server” on page 105. For information on remote
tasks, refer to the Using MaxExchange Remote chapter in the
Maximizer CRM User’s Guide.

The n-tier configuration distributes much of the processing load to
the remote servers, which dramatically decreases synchronization
time across the entire tree structure. This decentralized approach to
synchronization allows for a much greater total number of remotes
and faster synchronization.

N-tier Configuration

Server

Remote
Server
Remote
Remote
Server
Remote
Remote
Remote
Remote
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MaxExchange Server Manager

MaxExchange Remote

MaxExchange Server Manager is a utility used to access the server
from another computer. When you install MaxExchange Server as a
service, this utility is used to perform manual tasks on the server.

MaxExchange Remote users synchronize the entire image or a subset
image of the central Address Book on their remote computers.
Remote users also update the central Address Book with changes
made on the remotes.

For detailed instructions on using MaxExchange Remote, refer to the
Maximizer CRM User’s Guide.

MaxExchange Site Manager

To determine which portions of the central Address Book go to each
remote, using MaxExchange Site Manager, the MASTER user, or a
user with Maximizer Administrator privileges, defines remotes/
remote servers and the distribution groups to which the remote sites
belong. Other important functions of Site Manager are to perform
Address Book maintenance on remotes, send refreshes to remotes,
set up event notifications, and generate reports. Site Manager is also
used to set up teams for campaign and opportunity synchronization.
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Use this list of terms to help familiarize yourself with the terminology
of MaxExchange.

Central Address Book — A Maximizer Address Book that you specify
for the MaxExchange server to synchronize with its distribution sites.
The server maintains the central, master image of this Address Book
(often at the head office of a company), while the remote computers
maintain either partial or complete images of the same Address Book
on the distribution sites. Note that you can synchronize more than
one central Address Book at a time and multiple Address Books can
be hosted on one server.

Although different images of the Address Book are kept on separate
computers, together, the server and its remotes effectively work on a
single central Address Book, which is periodically updated by the
MaxExchange synchronization process.

Distribution Group — A Distribution Group comprises several
distribution sites that maintain a particular image of the central
Address Book. The MASTER user of the central Address Book, or a
user with Maximizer Administrator privileges, uses the MaxExchange
Site Manager program to determine which distribution sites belong
to each distribution group.

The MaxExchange Distribution user-defined field, which you create
in Administrator, determines which companies and individuals in
your central Address Book are distributed to the various remotes. The
field is created in Administrator’s System Options preferences by
clicking the associated button. This field then appears within your
User-Defined Fields list and you add values for your distribution
groups as necessary.

Distribution Site — A computer where MaxExchange Remote or
Remote Synchronization Server is installed. See the Remote and
Remote Server definitions for more information.

DRB Table - A file table that is used by MaxExchange to track the
distribution list of Address Book entries and opportunities for each
distribution site. This list is created based on the Distribution Group
value associated with an Address Book entry for the MaxExchange
Distribution field.

Remote - A computer where a MaxExchange Remote is installed,
and on which a partial or complete image of the central Address
Book is stored. Remotes are set up and maintained by the MASTER
user, or a user with Maximizer Administrator privileges, using the
MaxExchange Site Manager program.

Typically, several distribution sites belong to a distribution group.
These distribution groups are associated with Address Book entries.
You assign default distribution groups to Address Book entries based
on the creator of the entry; each user can be assigned a set of
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distribution groups and when the user creates an entry, the default
distribution groups are automatically assigned. User setup for
distribution groups is done in the Access Rights tab of user properties
in Administrator (File > Users) or Maximizer (in the Setup tab, select
Manage Users from the User Management group).

Remote Server — A distribution site that also acts as a MaxExchange
server for other distributions sites in an n-tier configuration. The
remote server synchronizes with the server (or with another remote
server) and passes along data packets to other remotes on the
distribution tier below it.

MASTER User - The MASTER user is the owner or the administrator
of a Maximizer Address Book. For MaxExchange, the MASTER user
administers the central Address Book from the server. The MASTER
user grants users access to the Address Book and, if required, restricts
their ability to view, add, or delete data or to perform certain
functions. The MASTER user is also the only user authorized to use
the MaxExchange Site Manager application to set up remotes and
distribution groups or use MaxExchange Server Manager. Note that
you can have users with Maximizer Administrator privileges
equivalent to the MASTER user.

Transaction Journaling - Transaction Journaling is the process by
which Maximizer maintains a record of changes made by users to an
Address Book.

Transaction Journaling is enabled in Administrator in the System
Options preferences. This functionality should not be enabled until
you are ready to process data so that unnecessary transactions do not
occur.

User-defined field — User-defined fields (UDFs) are customizable
fields in Maximizer that you can use to categorize the Address Book
entries and opportunities in your Address Books. You can use UDFs to
group Companies, Individuals, Contacts, and opportunities in many
different ways such as by occupation, hobby, income level, revenue,
or any other criteria you want to use.
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The MaxExchange Administrator’s Guide is part of a suite of
documents (paper and online) for Maximizer products, including the
following:

Online help with indexed and context-sensitive help for
MaxExchange tasks, commands, and dialog boxes. Online help is
available in all MaxExchange applications.

The Maximizer CRM Administrator’s Guide and Administrator
online help include information about setting up and
maintaining Address Books.

The Maximizer CRM User’s Guide and Maximizer CRM online
help include information on managing Address Book entries,
working with sales opportunities and campaigns, and managing
teams and strategies.

Information about the latest product updates and releases can
be obtained by visiting www.maximizer.com. You can also access
our knowledge base by going to www.maximizer.com/
knowledgebase.
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CHAPTER

Installing
MaxExchange

Installing the MaxExchange Components

In this chapter...

“System Requirements” on page 10

“Transport Method Requirements” on page 11

“Installing MaxExchange Synchronization Server” on page 13
“Installing MaxExchange Remote Synchronization Server” on page 19
“Installing MaxExchange Site Manager” on page 25

“Installing MaxExchange Remote” on page 25

“Installing MaxExchange Licenses” on page 25

“Upgrading from Previous Versions of MaxExchange” on page 26
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System Requirements

@To run MaxExchange,
Windows users must be given
the rights of a “Power User”.

Minimum Processor Speed

Available RAM

Available hard disk space

Operating system

Please ensure that you have met the following minimum system
requirements before installing MaxExchange.

Note that the Microsoft SQL Native Client is required by
MaxExchange and is installed with Maximizer on both the server and

the remote.

MaxExchange
Synchronization Server

1.6 GHz (minimum)
3 GHz or faster processor
(recommended)

1 GB (minimum)

2 GB (recommended)

4 to 1 ratio of virtual memory to
physical memory.

4 GB (minimum)
6 to 8 GB (recommended)

Microsoft Windows XP

Microsoft Windows Server 2003
Microsoft Windows Server 2008
(updated to their latest service packs)

MaxExchange Remote

1 GHz (minimum)
2.0 GHz or faster processor
(recommended)

1 GB (minimum)

2 GB (recommended)

4 to 1 ratio of virtual memory to
physical memory.

2 GB (minimum)
4 to 6 GB (recommended)

Microsoft Windows XP

Microsoft Windows Vista

Microsoft Windows 7

Microsoft Windows Server 2003
(updated to their latest service packs)
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Transport Method Requirements

HTTP Transport

FTP Transport

Network Direct Transport

Email Transport

Depending on the selected transport method, both the server and
remote computers must have the required software and hardware
requirements. Following is a description of those requirements for
each available transport method.

An ISP (Internet Service Provider) to facilitate the physical
transport of MaxExchange data packets.

TCP/IP networking must be enabled on all MaxExchange
computers.

A designated web server.

An ISP (Internet Service Provider) to facilitate the physical
transport of MaxExchange data packets.

MaxExchange FTP will also work without the use of the Internet
should remote users want to direct dial to the MaxExchange FTP
server.

TCP/IP networking must be enabled on all MaxExchange
computers.

A 10 MB per second or better Network Interface Card.

A dial-up telephone connection with modem(s) as required.

While a dial-up WAN configuration will work with MaxExchange, we
recommend an ADSL line service.

A MAPI (Messaging Application Programming Interface) email
system for both the server and remote computers. Refer to the
Maximizer website for product and version-specific information.

If you are using Microsoft Outlook, the Collaboration Data
Objects component is installed with the email application on the
computer running MaxExchange Server.

If you are using Outlook 2007, you must download Collaboration
Data Objects from the Microsoft website.
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If you are using a previous version of Outlook, you can install the
component from your email application’s disk.

If you are running MaxExchange as a service, the service is
logged in as the user who is configured for the email client, and
the user has administrator rights.

If you are using Outlook Express for email transport, the
following security option is set: Go to Tools > Options in Outlook
Express, click the Security tab, and clear the “Warn me when
other applications try to send mail as me” option.
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Installing MaxExchange Synchronization Server

@ You must be logged in as an
administrator to install
MaxExchange. After
installation, you will be
prompted to restart the
computer, and then you must
log in as an administrator
again to complete the
installation.

There are two ways to install MaxExchange Synchronization Server—
as a service or as a desktop application. In either case, the
MaxExchange server is always manually controlled and configured
through the MaxExchange Server Manager. If you install
MaxExchange on one computer, it can be controlled by another
computer by installing the MaxExchange Server Manager
application.

You have the option of choosing to use individual MaxExchange
servers for each Address Book or you can host multiple Address
Books on one server. This decision should be made based on some of
the same factors such as performance, scheduling flexibility, and the
complexity of your installation.

An installation wizard steps you through the process of installing the
software on your server. The instructions in this section complement
the wizard to provide additional information.

» To install MaxExchange Synchronization Server

n Close all programs running on the server.

E Insert the MaxExchange Synchronization Server disk in the
server’s disk drive. (The server and remote versions are on
separate disks.). The setup starts automatically.

%% MaxExchange Synchronization Server Setup (D

' Maximizercrm10
\_l_-g MaxExchange Synchronization Server

MaxExchange Synchronization Server

Install MaxExchange Synchronization Server

Install MaxExchange Remote Synchronization Server
View Documentation | View Release Motes
Browse this CD

Maximizer Software —

Simply Successful CRM

Exit

ﬂ Select Install MaxExchange Synchronization Server.

The installation wizard starts.
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ﬂ Click Next to begin the installation.

MaxExchange Synchronization Server 11 [ x]

Welcome to the InstallShicld Wizard for
MaxExchange Synchronization Server 11

The InstallShisld® \wWizard will install MaxE xehange
Synchronization Server 11 on your computer. To
continue, click Mewt

<Back [ HEdS I Cancel

E Read the license agreement and click Next to continue.
E Read the release notes and click Next to continue.

Select a setup type:

e Server and Server Manager installs both MaxExchange
Server and MaxExchange Server Manager. Select this option
if this machine will be used as a MaxExchange Server.

@ For more information on the ¢ Server Manager only installs MaxExchange Server Manager
Server Manager only” setup, only, not MaxExchange Server. Select this option if this
see “Running Only . .
MaxExchange Server machine will not be used as a MaxExchange Server. Note that
Manager” on page 135. for this option to be a valid choice, “Server and Server

Manager” must be installed already on another machine.

ManExchange Synchronization Server 11
Select Options Maximizer.,
CRM

Selact whether you want to instal both MaxExchangs Server and MaxExchangs Server
Manager, or MarErchange Server Manager ony

& Bearver and Server banager

' Server Manager only

IrstalBhield

< Back JUER S I LCancel

If you selected "“Server Manager only”, skip ahead to step 12.



@ I1S Admin Service is Microsoft

Internet Information Services
(11S) administrative service. For
more information about
Microsoft IIS, refer to the
Maximizer CRM
Administrator’s Guide.

@ The user configured to run the

MaxExchange service must
have the proper rights for
Microsoft SQL Server. For more
information, see “Server
Database Rights” on

page 106.
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E’ (This step applies to the “Server and Server Manager” setup type

only.) If the “IIS Admin Service” or “World Wide Web Publishing
Service” are not installed, or if they are disabled, you are
prompted by a message. Take one of the following actions:

e If you will not be using the HTTP transport method, click
Ignore and continue with the rest of the installation.

¢ If you will be using the HTTP transport method, and
Microsoft IIS is already installed on this machine but the IIS
Admin Service or World Wide Web Publishing Service are
currently disabled, go to Windows Services (available
through the Windows Control Panel), and enable both
services. Then, click Retry.

e If you will be using the HTTP transport method, and
Microsoft IIS is not installed, click Abort. Install Microsoft IIS
before installing MaxExchange Server. For more information
about Microsoft IIS in a Maximizer environment, refer to the
Maximizer CRM Administrator’s Guide.

(This step applies to the “Server and Server Manager” setup type
only.) Select Yes to install MaxExchange Synchronization Server
as a Windows service, or select No to install it as an application. If
you are unsure, select Yes.

If you install it as a service, you can use the MaxExchange Server
Manager on the server, or from another machine running
MaxExchange Server Manager, to control processing and other
server tasks.

ManExchange Synchronization Server 11
Select Options Maximizer.,
Do you wart to run MasExchangs Synchionization Server 11 as & service?
& b
Mo

IrstalBhield

< Back Mext > I LCancel

nm(This step applies to installing MaxExchange Server as a

service only.) Specify which type of Windows account to use for
MaxExchange transport:

¢ Select Local system account if you will be using either the
HTTP transport method or FTP transport method for
synchronization.
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¢ Select 1 will specify user account if you will be using either
the network direct transport method or email transport
method for synchronization.

ManExchange Synchronization Server 11

Select Dptions Maximizer
CRM

IF you are gaing to use a netwark share s your MaxE xchange tansport mechanism, the
HavE rehange Service wil need to be able o login using @ user account that has both read
and wiits access permissions for that particular share. If you are not gaing to use a netwark

share or Email as the transport mechanism, then you should seleet the local system aceaunt.

& Local system account

L will spesify user account

IrstalBhield

< Back Mext > I LCancel

nnSeIect the Maximizer Address Book to synchronize, and click
Next.

Select Synchronization Database Maximizgr"‘
CRM

Select the database that you want to spnchronize with MaxE kchange.

To serll the list, use your kepboard arow keys.

Awailable databases from list

dhinard d

Only databases from the global database list are available for spnchionization,

IrstalBhield

<Back |[ Hews |  Caneel
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nE(This step applies to the “Server Manager only” setup type.) If
you selected the “Server Manager only” option in step 7, the
installation wizard prompts you to identify the MaxExchange
Server computer to connect to. Browse to the MaxExchange
Server computer to select it, and then click Next to continue.

ManExchange Synchronization Server 11
MaxExchange Server computer Eaaal. ..,.
Sl MaEsehonge Serve compuer. Mﬂl“&gﬂ
MaxExchangs Server computer name:
[servel Browse..
IristaShield
< Back Mext > LCancel

nﬂMaxExchange Site Manager is also installed with the server
software. Select the corresponding options to create desktop
icons for MaxExchange Site Manager and MaxExchange Server

Manager.
Create Desktop Shartcuts Maximizer-
CRM

Select the deskiop shortcuts you want to create.

IV MasExchange Site Manager

v MasExchange Server Manager

IrstallShield

<Back  [{Hed I Cancel
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nﬂThe installation provides you with a summary of your settings.
Review the settings and click Next to begin installing the

software.
MaxExchange Synchronization Server 11
Stark Copying Files Eaaal. ...
Review settings before copying files. Mﬂl“&gﬁlr

Setup has enough information to stait copying the pragram fss. [f you want to revisw o
change any seltings, click Back, If pou are satisfied with the setings. click Nex! to begin
copying fies.

Curnisnt Settings

Run as service: =]

=
Install somporients
MasExchange Server and MaxEschange Server Manager
ManExchangs Site Manager
S horteuts:
Desklop: MaxExchangs Server Manager
Dieskiop: MaxExchange Site Manager

< ol

IrstalBhield

< Back

When the installation is complete, it prompts you to restart the
computer.

HECIick Finish to close the wizard and restart the computer.

nﬂAfter the computer restarts, log into Windows using an
administrator account. This step is required to complete the
installation.

MaxExchange Synchronization Server is now installed.
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Installing MaxExchange Remote Synchronization Server

The installation of a remote server is similar to a server installation.

An installation wizard steps you through the process of installing the
software on your server. The instructions in this section complement
the wizard to provide additional information.

» To install MaxExchange Remote Synchronization

Server
@You must be logged in as an n Close all programs running on the remote server.
administrator to install
MaxExchange. After B3 insert the MaxExchange Synchronization Server disk in the
installation, you will be 's disk dri h d .
prompted to restart the server’s disk drive. (The server and remote versions are on
computer, and then you must separate disks.). The setup starts automatically.
log in as an administrator
again to complete the
installation. 48 MaxExchange Synchronization Server Setup CD

' Maximizercrm10

MaxExchange Synchronization Server

MaxExchange Synchronization Server

Install MaxExchange Synchronization Server

Install MaxExchange Remote Synchronization Server
View Documentation | View Release Motes
Browse this CD

Maximizer Software —

Simply Successful CRM

Exit

E Select Install MaxExchange Remote Synchronization
Server.

The installation wizard starts.
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@ For more information on the
“Server Manager only” setup,
see “Running Only
MaxExchange Server
Manager” on page 135.

ﬂ Click Next to begin the installation.

MaxExchange Remote Synchronization Server 11 [ x]

‘Welcome to the InstallShield Wizard for
MaxExch emote 5! ization Server
n

The InstallShisld® \wizard will install MaxE rehange
Fiemote Synchronization Server 11 on your computer. To
continue, click Mewt

<Back [ HEdS I Cancel

E Read the license agreement and click Next to continue.
E Read the release notes and click Next to continue.

Select a setup type:

e Server and Server Manager installs both MaxExchange
Server and MaxExchange Remote Server Manager. Select this
option if this machine will be used as a MaxExchange Remote
Server.

e Server Manager only installs MaxExchange Remote Server
Manager only, not MaxExchange Server. Select this option if
this machine will not be used as a MaxExchange Remote
Server. Note that for this option to be a valid choice, “Server
and Server Manager” must be installed already on another

machine.
Select Options Maximizer...
CRM

Select whether you want to install both MaxExchange Server and MaxExchange Fremote
Server Manager, or MarErchanas Remote Server Manager ony

" Server Manager only

IrstalBhield

< Back Mext > I LCancel

If you selected “Server Manager only”, skip ahead to step 12.



@ I1S Admin Service is Microsoft
Internet Information Services
(11S) administrative service. For
more information about
Microsoft IIS, refer to the
Maximizer CRM
Administrator’s Guide.
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E’ (This step applies to the “Server and Server Manager” setup type

only.) If the “IIS Admin Service” or “World Wide Web Publishing
Service” are not installed, or if they are disabled, you will be
prompted by a message. Take one of the following actions:

e If you will not be using the HTTP transport method, click
Ignore and continue with the rest of the installation.

¢ If you will be using the HTTP transport method, and
Microsoft IIS is already installed on this machine but the IIS
Admin Service or World Wide Web Publishing Service are
currently disabled, go to Windows Services (available
through the Windows Control Panel), and enable both
services. Then, click Retry.

e If you will be using the HTTP transport method, and
Microsoft IIS is not installed, click Abort. Install Microsoft IIS
before installing MaxExchange Remote Server. For more
information about Microsoft IIS in a Maximizer environment,
refer to the Maximizer CRM Administrator’s Guide.

(This step applies to the “Server and Server Manager” setup type
only.) Select Yes to install MaxExchange Remote Synchronization
Server as a Windows service, or select No to install it as an
application. If you are unsure, select Yes.

If you install it as a service, you can use the MaxExchange
Remote Server Manager on the server, or from another machine
running MaxExchange Server Manager, to control processing
and other server tasks.

MaxExchange Remote Synchronization Server 11

Select Dptions Maximizer
CRM

Da you want to run MaxExchangs Remote Synchionization Server 11 s & servics?

& e
Mo

IrstalBhield

< Back JUER S I LCancel

nm(This step applies to installing MaxExchange Server as a

service only.) Specify which type of Windows account to use for
MaxExchange transport:

e Select Local system account if you will be using either the
HTTP transport method or FTP transport method for
synchronization.
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¢ Select 1 will specify user account if you will be using either
the network direct transport method or email transport
method for synchronization.

MaxExchange Remote Synchronization Server 11
Select Options Maximizer.,
CRM

IF you are gaing to use a netwark share s your MaxExchange tansport mechanism, the
MavE rchange Service wil need to be able o login using @ user account that has both read
and wits access permissions for that particular share. If you are not gaing to use a netwark

share or Email as the transport mechanism, then you shauld seleet the local system aceaunt.

' Local system account

€ L will spesiy user acoount

IrstalBhield

< Back Mext > I LCancel

nn(SeIect the Maximizer Address Book to synchronize, and click

Next.
MaxExchange Remote Synchronization Server 11
Select Synchronization Database Maximizer.,
Select the database that pou want to synchronize with MaxExchange. CRM

To serll the list, use your kepboard arow keys.
Awailable databases from list
dhnard -

Only databases from the global database list are available for spnchionization,

IrstalBhield

<Back |[ Hew> | Caneel

nE(This step applies to the “Server Manager only” setup
type.) If you selected the “Server Manager only” option in step
7, the installation wizard prompts you to identify the
MaxExchange Server computer to connect to. Browse to the
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MaxExchange Server computer to select it, and then click Next
to continue.

MaxExchange Remote Synchronization Server 11
MaxExchange Server computer ) ™
PSS — Mﬂlﬂégﬂ

MaxExchange Server computer name;

[erved Browse

IrstallShield

<Back |[ Hews | Cancel

nﬂMaxExchange Site Manager is also installed with the remote
server software. Select the corresponding options to create
desktop icons for MaxExchange Site Manager and MaxExchange
Remote Server Manager.

MaxExchange Remote Synchronization Server 11
Create Desktop Shortcuts M ﬂXimIzer
CRM

Select the desktop shorteuts you want to create.

I¥ MaxExchangs Site Manager

I¥ MaxExchangs Remote Server Manager

Irstal B hield

<Back Cancel
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nﬂThe installation provides you with a summary of your settings.
Review the settings and click Next to begin installing the

software.
MaxExchange Remote Synchronization Server 11
Stark Copying Files Eaaal. ...
Review settings before copying files. Mﬂl“&gﬁlr

Setup has enough information to stait copying the pragram fss. [f you want to revisw o
change any seltings, click Back, If pou are satisfied with the setings. click Nex! to begin
copying fies.

Curntsnt Settings

IMaxExchange server name = Server =]
Install companents:

MaxExchangs Server Manager

MaxExchange Site Manager
Shortcuts:

Deskiop: MaxExchange Remote Server Manager

Desktop: MaxExchangs Site Manager

< il

IrstalBhield

< Back

When the installation is complete, it prompts you to restart the
computer.

HECIick Finish to close the wizard and restart the computer.

nﬂAfter the computer restarts, log into Windows using an
administrator account. This step is required to complete the
installation.

MaxExchange Remote Synchronization Server is now installed.
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Installing MaxExchange Site Manager

MaxExchange Site Manager is automatically installed with both
MaxExchange Synchronization Server and MaxExchange Remote
Synchronization Server. When prompted during the installation of
both of these server applications, you can choose to create a desktop
icon for the utility. MaxExchange Site Manager is available through
the icon and also through the Utilities menu in Administrator when
either of the server applications are installed.

Installing MaxExchange Remote

A mobile sales force can use MaxExchange to synchronize their
computers with the central Maximizer Address Book(s). Remote
offices can also keep their Maximizer Address Book up to date with a
central office.

To perform a MaxExchange Remote installation, follow the
instructions in the Maximizer CRM Administrator’s Guide for
Installing Maximizer Workstation making sure you choose “Yes”
when asked if you are using the computer as a Remote Workstation.
To install MaxExchange Remote on a Maximizer server, refer to
Installing Maximizer Server. During the Maximizer server installation
process, select Custom installation and select the MaxExchange
Remote as an installation option.

Installing MaxExchange Licenses

@You must install your For detailed instructions on installing MaxExchange licensing, refer

MaxExchange licensing before  t the Maximizer CRM Administrator’s Guide.
creating your distribution sites

in MaxExchange Site Manager.
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Upgrading from Previous Versions of MaxExchange

@Older versions of When upgrading from a previous version of MaxExchange, take
MaxExchange should be special note of these critical issues:
uninstalled before installing
the new version. *  Process packets in the MaxExchange server before upgrading.

Any transactions remaining from the previous version will not be
processed by the upgraded version.

e The MaxExchange server must be upgraded first, after which the
remotes may be upgraded gradually (mixed-mode environment).
Synchronization will continue operating even though some
remotes are running Maximizer CRM 10 or Maximizer CRM 10.5.
We recommend that the time frame between the upgrade of the
server and all remotes not be longer than 2 weeks. If you do not
upgrade a distribution site immediately, synchronization with
Outlook and Maximizer and synchronization with MaxSync and
Maximizer could cause duplicates.

e The processing in a mixed-mode environment is done by the
server creating packets and saving them in a folder called
Upgrade (under the Outbox>[HEX Address Book ID] folder). Only
updates and deletions from a remote that hasn't upgraded are
processed by the server; additions are discarded. When the
remote upgrades, a packet is sent to the server and the server
detects the upgrade. The server then sends the data packets in
the upgrade folder, which is then deleted from the server, and
also sends a special packet asking for all data that was added
from the time the server (not upgraded yet) last processed a
packet with the distribution site until the time the distribution
site creates its first packet after upgrading. The remote then
sends the added data packets, which is distributed to all other
remotes.

e If you are running multiple servers, you have the option of
migrating all Address Books to one server or keeping the existing
setup. When evaluating what option is most suitable, keep the
following points in mind:

- multiple servers may process faster unless you are using one
server that is equivalent to multiple machines in terms of
hardware.

- you can schedule only one automated processing schedule per
MaxExchange server so if you need different scheduled
processing times, you must have separate MaxExchange servers.

e If you are upgrading from a previous version, the email address
must be re-entered in the Server Settings dialog box in
MaxExchange Site Manager after you install the new version.
Other transport method settings are maintained.

e If you are upgrading Maximizer Enterprise 7.5 or earlier, you
must perform Address Book Maintenance with the “Do not
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create maintenance packets” option enabled (in MaxExchange
Server Manager or MaxExchange Remote Server, select File >
Address Book Maintenance).

Address Book entries with no assigned MaxExchange
distribution groups will not be synchronized between the server
and the remote. After running Address Book Maintenance, and
a remote is sent a refresh, Address Book entries without
distribution groups assigned to them are removed from the
remote. It is recommended that distribution groups are assigned
to all Address Book entries on a server before performing
Address Book Maintenance.

If you are upgrading to Maximizer CRM from Maximizer
Enterprise 6 - Pervasive or earlier, the Upgrade utility in
Maximizer Administrator does not upgrade the MaxExchange
distribution groups. To perform the upgrade, choose File >
Upgrade Distribution Groups in MaxExchange Site Manager.
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How the MaxExchange Process Works

In this chapter...

“Central Address Book” on page 30
“"What Data is Synchronized?” on page 30
“Process Flow” on page 32

“Transport Method Details” on page 37
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Central Address Book

When using MaxExchange, the Address Book has the following basic
forms:

e asingle, master image of the central Address Book(s) on the
server

¢ subset images of the same Address Book(s) stored on computers
at remotes

What Data is Synchronized?

MaxExchange synchronizes all data in an Address Book with the
exception of the following:

e Automated campaigns (traditional campaigns are synchronized)
e Email templates for automated campaigns
e Journals

e Expenses

e Graphs

e Import catalogues

e Linked documents

e  Printer settings

e Window layouts

e  Email settings

e Windows authentication settings

e External third-party tables (non-Maximizer)
e Dashboard settings

¢ Holiday Editor information
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Synchronizing Third-Party Data

@ For both the

Custom_Independent and
Custom_Child tables, the
Custom_ID and
Custom_Number fields
(whether generated
automatically or manually
entered) on the server and
each remote must be unique in
a MaxExchange environment.
This is to prevent duplicate ID
issues from occurring.

There are two custom tables available through the use of the
Maximizer Customization Suite (listed below) that allow you to
integrate third-party data. The data contained in these tables is
synchronized by MaxExchange as follows:

e Custom_Independent is a top-level data storage table, similar
to the Clients table. It is created at database-creation time and
contains a number of pre-defined columns. It is always
synchronized by MaxExchange, and it synchronizes associated
notes, documents, and user-defined fields.

e Custom_Child is a mid-level data storage table and is a child of
a Custom_Independent record, an Address Book entry, an
Opportunity, etc. It is created at database-creation time and
contains a number of pre-defined columns, including Client_ld/
Client_Number of the parent record. It is always synchronized by
MaxExchange, except on a refresh, in which case child records
are synchronized only when the parent record is synchronized. It
also synchronizes associated notes, documents, and user-defined
fields when the parent record is synchronized.

For more information on using custom third-party tables, refer to the
Customization Suite documentation.

Synchronizing Opportunities and Campaigns

Address Book entries with opportunities assigned to sales team
members are synchronized to remotes, even when corresponding
companies are not normally synchronized to those particular remotes
(i.e., the Address Book entries are not assigned to the corresponding
distribution group). Synchronization of Address Book entries also
occurs when a competitor or partner of an opportunity is assigned to
a Address Book entry other than the Address Book entry with which
the opportunity is associated.

When a Contact is assigned to an opportunity (on the Basic
Information tab of an opportunity), the Contact is not synchronized
unless the Contact’s Company or Individual entry is assigned to a
distribution group.

Single-user opportunities are synchronized with only the remotes
that created the opportunities. For example, if Remote A creates a
single-user opportunity, it is synchronized with only Remote A. The
opportunity will not be synchronized with Remote B. Single-user
opportunities created on the server are not synchronized.

This works the same way for traditional campaigns in that traditional
campaigns associated with a member of a marketing team, are also
synchronized. Automated campaigns are not synchronized to any
distribution sites.
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Microsoft Outlook Synchronization and MaxExchange Synchronization

Process Flow

DRB Table

MaxExchange
Server

/
1g{box

E8F01A12

TRNSP

Backup

In a MaxExchange environment with Microsoft Outlook
Synchronization enabled, Maximizer can synchronize with Outlook
on asingle server or remote only. Otherwise, duplication of entries
may occur.

When MaxExchange is installed, and at least one MaxExchange
remote has been added as a distribution site, a MaxExchange
Location button appears at the bottom of the Outlook
Synchronization tab. Clicking this button opens a dialog box
containing a drop-down list of MaxExchange servers and remotes for
the current Address Book. Select the MaxExchange server or remote
where Maximizer will synchronize entries with an Outlook profile for
the selected user.

The following diagram illustrates the basic process flow between a
MaxExchange server and a remote. Note that a MaxExchange
Remote Synchronization Server configuration is very similar. It can
include multiple tiers of remote servers and remotes as well as the
parent server.

Transaction Table

Distribution List
- Toronto MXZREM.BIN

pmmsmmmeeiieees - Vancouver

- Chicago
- New York

Internet

H H
ESFO1A12 [ EsF01A12 [ E8FO1AT2

' '
TRNSP | TRNSP i TRNSP
b
Backup
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MaxExchange Basic Synchronization Cycle

@ You can add a remote or
remote server to the
distribution chain at any time.

The following steps describe the basic process that takes place during
a synchronization cycle between a MaxExchange server and a
remote.

A central Address Book is created on the designated
MaxExchange parent server.

Address Book entries are marked for synchronization by
assigning a Distribution Group value for the MaxExchange
Distribution system field (defined in Administrator preferences).

In MaxExchange Site Manager, remotes and remote servers are
created for the entire distribution chain. During the creation
process, distribution groups are assigned to remotes and remote
servers.

For each remote and remote server created in Site Manager, the
MaxExchange server generates a refresh transaction. When the
server processes, a refresh packet is built for each site. The
refresh includes all data that is marked to be distributed to each
individual site. When using the FTP method of transport, the
remote/remote server pulls the refresh packet from the server.
With email and network direct transport, the server sends the
refresh packet.

After the MaxExchange server processes the data, its transaction
table is cleared and the server is ready for the next
synchronization cycle.

Changes from remotes and remote servers are written to a
transaction file/table. These changes are processed by each site
according to the site’s designated synchronization cycle and
transport method.

The server receives updates from the remotes and remote servers
and the central Address Book is updated with the changes. The
next synchronization cycle is ready to take place.
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Key MaxExchange Files and Folders

Following is a list of the key files and folders on the MaxExchange
Server or Remote Server.

Reference in
documentation | File/folder name File or folder description

DRB file/table  EXCH_DistributionList = Used by MaxExchange to
table track the distribution list of

Address Book entries and
opportunities for each
remote. This list is created
based on the Distribution
Group value associated
with an Address Book entry
for the MaxExchange
Distribution system field.

Transaction EXCH_Transactions Used by MaxExchange to

file track changes to the
central Address Book and
Address Books on the
remotes. There are 5
transaction tables.

Distribution EXCH_Sites A list of assigned transport

list file methods for all remotes.
MaxExchange identifies
each distribution site with
a unique ID.

Inbox Inbox Contains all incoming
packets for remotes.
Packets include all changes
in the form of transactions
and are stored—before
processing—in the TRNSP
folder under the remote’s
folder identified with a
HEX ID number.



Reference in
documentation

Outbox

.HDR file

.ATT file

.MEX file

File/folder name

Outbox

.HDR file

ATT file

.MEX file
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File or folder description

Contains all outgoing
packets for remotes.
Packets include all changes
from the central Address
Book in the form of
transactions and are
stored—after processing
incoming packets—in the
TRNSP folder under the
remote’s folder identified
with a HEX ID number. A
copy of these transactions
are stored in a BACKUP
subfolder for each remote.

.HDR files (ASCII text files)
contain the database ID
and server ID information
for the remote.

.ATT files (compressed
binary files) contain
Address Book entry and
opportunity data. A typical
file name format is
edi0000XX.ATT.

.MEX files are used to lock
the .HDR and .ATT files
when MaxExchange is
processing or performing
specific operations.
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Following is a list of the key files and folders on the MaxExchange
Remote.

Reference in
documentation | SQL file/folder name | File or folder description

REM file MXZREM.BIN Contains information from
incoming .HDR files
including the database ID,
the MaxExchange server’s
address, the transport
method, local database
location, and a reference to
the current packet count.

Inbox Inbox Contains all incoming
packets from the server.
Packets include all changes
from the server in the form
of transactions and are
stored in the TRNSP folder
under the remote’s folder
identified with a HEX ID
number.

Outbox Outbox Contains all outgoing
packets for the server.
Packets include all changes
from the remote’s Address
Book in the form of
transactions and are stored
in the TRNSP folder under
the remote’s folder
identified with a HEX ID
number. A copy of these
transactions are stored in a
BACKUP subfolder for each
remote.



Transport Method Details

Transport
method

HTTP/HTTPS

FTP

Network direct

Email
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MaxExchange works with various types of transport mechanisms—
email, network direct, FTP, and HTTP. Each remote and remote server
can be configured to use any of the transport mechanisms

independently of the other sites.

The following table outlines the basic differences between the
various transport methods.

Server
requirements

Web service

Internet
security router/
firewall server

Dial-up server
or WAN
gateway
server/router

MAPI-
compliant
email program

Remote
requirements

MaxExchange
Remote
connection to
MaxExchange
Server

MaxExchange
Remote
connection to
MaxExchange
Server

WAN gateway
server/router
(office to office
WAN
configuration
only)

MAPI-
compliant
email client

Supported
protocols

TCP/IP

TCP/IP

TCP/IP
IPX

SPX
NetBEUI

Any protocol
supported by

the email
program

Server
identifier

URL of the
MaxExchange
web service

IP address or
fully qualified
domain name
of the
MaxExchange
Server

Name of the
MaxExchange
shared
program folder
in UNC format

Address of the
MaxExchange

Server's email

account

Remote
identifier

Not applicable
—the remote
always initiates
the connection
to the server

Not applicable
—the remote
always initiates
the connection
to the server

UNCor bindery
listing for the
shared
MaxExchange
network folder

Address of the
MaxExchange
Remote’s email
account
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FTP Transport Process Flow Example

@ If remotes and/or remote

servers are connecting to the
server at the same time, you

With FTP, data packets are exchanged through the Internet using File
Transfer Protocol.

The following diagram represents a MaxExchange Internet FTP
configuration using both a security router and a firewall server.

————

Remde

cuthound TOP part 21 {detau)

=] [ MaxExchange
=] | =arver with
! aticIP
gatesnaryirouter firesnal| address
riicund TCP ports 21 |defaui)
J

MaxExchange modem
Remde

ISP

If a firewall or security router is used in a MaxExchange configuration
and the MaxExchange Server is placed inside the firewall or security

need to open a port for each router, a port must remain open for each remote or remote site that

concurrent connection.

is connecting concurrently to the server. The values for inbound and
outbound ports are as follows:

Inbound: 21 is the default value—this may be changed to any other
available value with the exception of the values within the range
of

10035 — 11315; these values are used for MaxExchange file transfer

Outbound: 21 is the default value—this may be changed to any
other available value with the exception of the values within the
range of 10035 - 11315; these values are used for MaxExchange file
transfer

e An alternative to opening ports is to place the MaxExchange
Server on the Internet side of the firewall. This computer could
be a multi-homed system containing two network cards. One
network card would have a static external IP address connecting
to the Internet and the other network card would have an
internal IP address (specified as the primary FTP address and the
secondary FTP address).

When you are using FTP, the connection between the server and
remote is always initiated from the remote computer. This can be
done through a LAN or a dial-up connection. If a remote is not
connected to a LAN, a Windows Dial-up Connection dialog box
appears when a processing session is initiated. This includes when a
processing session is automated.
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Typical FTP Setup and Process

The following diagrams illustrate a typical FTP setup.
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CHAPTER

Setting Up
MaxExchange

Setting Up MaxExchange and Configuring the
Central Address Book

In this chapter...

“Configuring MaxExchange” on page 44

“Enabling Synchronization for an Address Book” on page 46

“Setting Up the Central Address Book” on page 49

“Quick Start — Setting Up a MaxExchange Server and Remote” on page 51
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Configuring MaxExchange

Configuring MaxExchange for the first time is a highly order-
dependent process that can prove to be time-consuming if steps are
not followed in a particular order.

The following section provides a high-level description of the steps
required to configure MaxExchange. Each of these steps is explained
in detail in the references sections.

>

To configure MaxExchange

Prepare the computers. Make sure all computers have
Maximizer and MaxExchange installed. See “Installing
MaxExchange Synchronization Server” on page 13 for more
information.

Enable synchronization options. At the Maximizer
application server, enable the synchronization options and set
up distribution groups in Administrator. See “Enabling
Synchronization for an Address Book” on page 46.

Prepare the Address Book(s). Assign Address Book entries to
distribution groups on any computer with access to the
database. See “Setting Up the Central Address Book” on

page 49. Note that you can synchronize multiple Address Books
on a MaxExchange server.

Set up transport and distribution options. Using
MaxExchange Site Manager, specify your chosen transport
method and distribution options. See “MaxExchange

Site Manager” on page 55. This utility is available in
MaxExchange Server Manager or can be accessed from the
Utilities menu in Administrator on the Maximizer application
server. If you have chosen to create an application icon during
installation, you can also access it through the icon.

Set up remotes. Remotes are set up in MaxExchange Site
Manager. See “Adding Synchronized Address Books” on

page 70. Part of setting up remotes involves setting site
restrictions. See “Restricting What Distribution Sites Can Do" on
page 81.



@ If you are setting up an n-tier
configuration (as described
under “MaxExchange
Synchronization Server” on
page 2), you should repeat
step 8 for each remote server
and step 9 for each remote.

Maximizer Setup Tips
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E Assign groups to remotes. After Address Book entries are
assigned to distribution groups and your remotes are created,
you then need to assign the distribution groups to the remotes.
This controls which entries go to which sites. See “Assigning
Distribution Groups to Distribution Sites” on page 78.

Set the MaxExchange server, remote server, and remote
preferences. You can now set up your MaxExchange server(s)
and remote preferences. These include options for MaxExchange
logging and notification events. See “MaxExchange
Synchronization Server” on page 105 and the Maximizer CRM
User’s Guide for more information.

E Send the initial data packet. To properly configure the
MaxExchange server, you should initiate a processing session
when the data packet will contain the remote’s initialization
information. This completes the configuration of the server and
sends the necessary settings to the remote. At the MaxExchange
server, run MaxExchange Server Manager and process the data
packets. See “Processing Updates from the Server” on page 109.

E Receive the initial data packet. To complete the
configuration between the MaxExchange server and its remotes,
you should receive the initial data packet that was sent in the
above step on one remote. At the remote, run MaxExchange and
receive the initial data packet from the server.

Your next step is to complete the configuration all of your remotes
and remote servers with the server.

e Before you may start synchronization, you need to turn on
transaction journaling in Administrator on the System Options
preferences tab (File > Preferences). Turning on transaction
journaling before you are ready to start synchronizing will result
in unnecessary transactions synchronized with your remotes.

¢ A MaxExchange distribution group should not be confused with
a Maximizer security group. A distribution group is set up using
the “MaxExchange Distribution” system field and represents a
group of Address Book entries that can be sent to a remote.

¢ When you are using Microsoft SQL Express, you are limited to a
4 GB packet size. Typically, SQL Express is used for MaxExchange
Remotes, but the software can be used for a MaxExchange server
in a workgroup environment. If a remote or server is to receive
larger packets, you must upgrade to Microsoft SQL Server.

* You can synchronize multiple Address Books with a single
MaxExchange server. Each Address Book must be added to the
Distribution Sites screen in MaxExchange Site Manager. Each
synchronized Address Book has its own remotes/remote servers.
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Enabling Synchronization for an Address Book

®You must be the MASTER user, When you install MaxExchange Site Manager and MaxExchange

or a user with Maximizer Server, you must choose an Address Book that is accessible from the
Administrator privileges, in . .
order to set it up as the central server to become the central Address Book. The following section
I\A/lddrESShBOOkf(T)L VIASTER outlines the procedures involved in enabling your Address Book for
axcxchange. Ihe H H .
user's default password is synchronization:
control”, e “Creating the MaxExchange Distribution System Field” on
page 46

e  “Creating Distribution Groups” on page 47

Creating the MaxExchange Distribution System Field

® You can make the The MaxExchange Distribution system field determines which
MaxExchange Distribution companies and individuals in your central Address Book are
field mandatory for Companies L - . .
and Individuals. If the field is distributed to the various remotes. Once created in Administrator,
made mandatory, each time a the field then appears within the System Fields preferences tab in

Company or an Individual is o AR
created, the value for Administrator and you add values for your distribution groups as

MaxExchange Distribution necessary.
field must be set.

» To create the MaxExchange distribution field

n In Administrator, select File > Preferences.

E In the MaxExchange section of the System Options tab, click
Create MaxExchange Distribution.

@When you are ready to start Maximizer creates a system field called “MaxExchange
synchronizing, you must go ictri ion”
back to this dialog and select Distribution.
the Enable Transaction The items you create for this system field are your distribution
Journaling checkbox. Selecting
the option before you are groups.

ready to synchronize data
creates unnecessary
transactions.
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B Click OK to save your settings and close the Preferences dialog

box.

X
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Address Bagk | Dashboard | Analytics | Mandatary Fields
SystemOptions | SystemFields | Locations/Resouces | CustomerSewvice | KepFields
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Global server

NOTE: The above selting appliss only ta the lacal machine where this application s accessed.

Addtess Book name: [Escons Tutorisl

Addtess Book 0: [772236163 Short ID: [HO

Caption tegt displayed
for Overview Page:

Msimum nubes of
enties ta retrigve: | 1007 = |
¥ System to assian Addrsss Book sntries' 1D sntiicstion field vluss Event Natfication.

[¥ System to assign Dpporturities' 1D field values

[¥ System to assign Campaians'ID fisld values Live Update..
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|My wiork Day

- MakExct

[~ Enable transaction journaling MarE rehange Distibution
I¥ Set Dpportunity and Campaign status to Updated when modified

and then synchianized by MaxExchanas

0K | cenes | s |

Creating Distribution Groups

Now that you've created the MaxExchange Distribution system field,
you create distribution groups by adding new items to the field.

A Distribution Group is a collection of one or more remotes that are
designated to send and receive updates to specific Address Book
entries. The MaxExchange Distribution system field value determines
which Address Book entries synchronize with a distribution group.

For example, you could have functional groups such as Inside Sales,
Channel Sales, and Marketing. Or, for example, you could have
regional groups such as East Coast, North, South, or Australia.

If an Address Book entry for ABC Wine Shop Inc. is assigned to four
distribution groups—East Coast, North, South, and Australia, the
entry synchronizes with remotes belonging to any of those four
distribution groups.

» To create Distribution Groups

n After you've created the MaxExchange Distribution field (as
outlined in the previous procedure), in Administrator, select
File > Preferences and click on the System Fields tab.

E Select the MaxExchange Distribution system field and click
the Add button.
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@ To ensure Address Book
entries are marked with the
proper distribution group
when entries are created, set
up a default entry for users
with the appropriate

distribution group assignment.

You can also make the
MaxExchange Distribution
field mandatory on the
Mandatory Fields tab in the
Administrator preferences.

E In the Add Item dialog box, type the name of your first
distribution group (e.g., Western) and choose the user who

requested that the distribution group be added if necessary.
Click OK.

X
Oppottunity | Campaian | MS Exchangs Synchionization | Automated Gervices | Diagnostic
Address Book hboard | Analytics | Mandatory Fields
System Options System | Locations/Fesouces | CustomerService | KepFields
~Mots and Document categari
Diocuments Category [Comment Add,
Address Book Notes Categay Response
Campaign Documents Category ;
Campaign Notes Category Urgent iedliy..
Company Library Diocuments Category
Customer Service Documents Category Delete
Chatomer Savice Kotes Cotegany E
Opportunity Documents Category
Dpportunity Motes Categary
-~ Address Book, Dpportunity, Campaign, shd Cust [ LR L] x|
Categories Ttem details

nge Distribution
Products/Services

Trem: |

Creator; [Lou Jones

Reguested by: [Lou Jones =
™ Set ko hidden

ok Cancel Appl

Repeat the procedure for each distribution group you need. You
can always add groups later. The next step is to assign Address
Book entries to the distribution groups.



Chapter4 | 49
Setting Up MaxExchange

Setting Up the Central Address Book

You can maintain your central Address Books on any computer that
has access to the MaxExchange server via MaxExchange Server
Manager. Entries in Address Books are assigned to distribution
groups, which in turn, are assigned to remotes. These steps must be
performed for each synchronized Address Book.

The following sections contain information on setting up the central
Address Book:

e "Assigning Address Book Entries to Distribution Groups” on
page 49
e  "“Enabling Transaction Journaling” on page 51

Assigning Address Book Entries to Distribution Groups

Once you have created the “MaxExchange Distribution” system field,
you need to assign your Address Book entries to the values (items) of
this field, which are distribution groups. This process determines

which Companies, Individuals, and Contacts are sent to each remote.

In the example below, there are three distribution groups—Eastern,
Central, and Western and each of these groups has an assigned
Address Book entry.

Distribution Groups — this example Company A
shows how three Address Book
entries are assigned to different
distribution groups. Each group is an
item for the “MaxExchange | Company B
Distribution” system field.
Contacts Company C
Contacts
Contacts
Eastern
Central Eastern
o I
estern Western Central
Company A will be Company B will be Company C will be
distributed to sites distributed to sites distributed to sites
belonging to the Eastern, belonging to the Eastern belonging to only the
Central, or Western and Western groups. Central group.

groups.
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@ See the Maximizer
documentation for more
information on default entries
and global edits.

@ You can assign distribution
groups to only Companies and
Individuals. Associated
Contacts automatically belong
to the same groups.

There are different ways to assign a distribution group to an Address
Book entry. They are described as follows:

e Distribution groups are assigned to Address Book entries on the
Basic Information tab as the entries are created.

e Default distribution groups are assigned to users as part of the
user security properties (Access Rights tab) so that each time a
particular user creates an Address Book entry, the specified
distribution groups are automatically assigned.

e Default entries can be set up for users specifying distribution
groups.

¢ Global edits can be performed on a selected group of Address
Book entries.

» To assign Address Book entries to groups

n When you are creating a Company or an Individual, select the
Basic Information tab.

E Double-click on the MaxExchange Distribution field in the
Details area of the tab and select the distribution groups to
which you would like this entry to be synchronized.

E Click OK to close the Address Book entry.

The entry is now assigned to the group(s) you selected.

» To assign distribution groups to users

n In Administrator, select File > Users. To create a new user, click
Add. To modify a user’s properties, select the user and click
Properties.

E Select the Access Rights tab and click the Default
MaxExchange Distribution button.

E Choose the groups for the selected user and click OK.

Each time the affected user creates a Company or an Individual,
these distribution groups are assigned to the entry.

The next step is create your remotes in MaxExchange Site Manager.
Refer to “MaxExchange Site Manager” on page 55 for detailed
instructions.
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Enabling Transaction Journaling

You must turn on transaction journaling so that MaxExchange can
track the changes that are made to the central Address Book(s).

Although it doesn’t cause any specific problems, you may want to
turn this option on after you're completely configured MaxExchange
for synchronization. Tracking changes in the database too early
results in an unnecessary backlog of transactions that MaxExchange
will synchronize with your remotes. However, if you are following
the steps in this guide in order, turning this option on now will not
result in any transactions since you have not yet created your
remotes.

» To enable transaction journaling in the Address
Book

n From Administrator, select File > Preferences.

E In the System Options tab, select the Enable Transaction
Journaling checkbox. Click OK to close the Preferences dialog
box.

Quick Start — Setting Up a MaxExchange Server and Remote

Accordingly, the steps outlined below are intended for experienced
Windows users with sufficient knowledge in networking as well as
MaxExchange data transport methods.

The Quick Start steps below set up synchronization using the FTP
transport method. Because of the variety of transport methods
MaxExchange offers, your configuration may vary depending on the
transport method employed.

You can begin your MaxExchange implementation with
synchronizing only two computers—the server and one remote. Once
successful synchronization occurs to and from each of these
computers, you can use the remote machine as a template to set up
additional remotes. Accordingly, the process described below will use
the above-mentioned, two-machine implementation case.
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Step 1 — Prepare the Computers

Before you can install MaxExchange, you need to prepare two
computers.

n Have two computers ready. Prepare a computer for the
MaxExchange server and another machine a remote. Make sure
the computers match or exceed the system requirements.

E Verify the server’s FTP address. Determine if the network/
Internet connection is functioning correctly by choosing File >
FTP Test on the remote or by “pinging” the server (i.e., at the
command prompt, type “ping” followed by the computer’s IP
address or qualified domain name).

@You can quickly test your B Install MaxExchange. Install MaxExchange server on one
server's FTP address by using machine and MaxExchange remote on the other. Note that
the File > FTP Test option on . .. . .
the remote. MaxExchange remote is part of the Maximizer CRM installation.

Step 2 — Prepare the Address Book

Maximizer and MaxExchange are now installed, and the FTP
transport method should be working correctly. In this step, you will
prepare your Maximizer Address Book.

n At the MaxExchange server decide which Address Book will
be designated as the synchronized, central Address Book.

E Open the Address Book in Administrator and enable
Transaction Journaling and create the “MaxExchange
Distribution” system field. These options are available in File >
Preferences > System Options tab.

B Prepare the Address Book (i.e., set up “MaxExchange
Distribution” system field items, group/user security, etc.). See
“Assigning Address Book Entries to Distribution Groups” on
page 49.

Step 3 — Start MaxExchange Server

Now that your Address Book is prepared, you can start MaxExchange
Server for the first time.

n Start MaxExchange Server Manager
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Step 4 — Configure MaxExchange Site Manager

@ Make a note of the remote’s ID
displayed in the remotes list.
You will need it later.

Step 5 — Send Initial Data

@ The "hexadecimal” folder is a
folder labelled by a
hexadecimal number that
corresponds to the Address
Folder ID. This ID is displayed
in the Distribution List dialog
box in MaxExchange Site
Manager.

In this step, you use MaxExchange Site Manager to set up the
transport method and add the remote as a remote.

n At the MaxExchange server, start the MaxExchange Site
Manager. Take note of the Address Book it opens by default. If
the Address Book does not appear in the list, select File > Open
Address Book in Administrator and choose the Address Book you
prepared above.

E Specify the server transport method. Select View > Server
Settings. See “Setting Up Synchronization with MaxExchange
Site Manager” on page 65.

For FTP transport, you must enter a static IP address or a fully
qualified domain name and the port number for the
MaxExchange server.

You must also enter FTP Passwords. FTP remote users will login
using the MAXEXCHANGE password. A secondary GUEST
password is also required.

E Add the remote. Add the second computer as a remote. See
“Setting Up Distribution Sites” on page 71.

When the site has been added correctly, a message is shown
indicating that a refresh will be sent to the Site. Click OK.

Now that your remote is set up as a remote in MaxExchange Site
Manager, you can use MaxExchange server to send the first data
packet.

n At the server, send the first data packet. Start MaxExchange
Server and select File > Process Data Packets.

E Check to see if the data packet was transported. Evidence
of this will vary for each transport Method.

For FTP transport, the data packet files should be in the
“MaxExchange\Outbox\<hexadecimal number>" folder,
awaiting pickup from the remote computer.
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Step 6 — Receive an Initial Refresh Packet at the Remote

@ You can also provide values for
a secondary IP address and
port number.

@ If selecting an existing
Address Book from the drop-
down list, verify that it is not
the central Address Book.

n Start MaxExchange Remote on the second computer.

E Initiate a communication session with the server. Select
File > Connect New FTP Server. Enter the server IP address or fully
qualified domain name, FTP port number, password (the
MAXEXCHANGE password entered at the server), and Address
Book ID for this remote. Click OK when finished.

MaxExchange initiates an FTP session with the server and
transports the refresh data packet from the server.

B Select an Address Book. MaxExchange asks for the Address
Book you want to designate as your synchronized MaxExchange
folder. You may select an existing Address Book from the drop-
down list or create a new Address Book.

n Process the data packet. Select File > Process Packet.
MaxExchange will only process data packets if there is sufficient
disk space remaining on your hard drive.

E Following the previous instructions, the refresh you receive at
the remote should contain no Address Book data.

E Check the Address Book in Maximizer. When packet
processing has ended, open the synchronized Address Book in
Maximizer. No Address Book data should exist. Compare other
data structures such as user-defined fields and document
templates with the server Address Book to verify that the
synchronization was successful.

You have now successfully synchronized a MaxExchange data packet.
The next step will be to associate the MaxExchange Distribution
system field items to the Address Book entries you want to send out
to the remotes and then associate the MaxExchange Distribution
items to remotes in the MaxExchange Site Manager. This will result in
Address Book records being assigned to the next data packet for the
later transport to the remote.

Once you have synchronized all data successfully between both
computers, you can repeat these procedures to roll out other remote
computers using your original MaxExchange server.



CHAPTER

MaxExchange
Site Manager

In this chapter...

“Role of MaxExchange Site Manager” on page 56
“Starting MaxExchange Site Manager” on page 57
“Configuration Settings” on page 58

"Setting Up Synchronization with MaxExchange Site Manager” on page 65
“Configuring Server Settings” on page 67

“Adding Synchronized Address Books” on page 70
“Setting Up Distribution Sites” on page 71

“Sales and Marketing Teams” on page 91
“MaxExchange Notifications” on page 96

" Address Book Diagnostic Tools” on page 99
“MaxExchange Site Manager Reports” on page 103
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Role of MaxExchange Site Manager

MaxExchange Site Manager coordinates the communication
between the server and its remotes. Use MaxExchange Site Manager
for the following tasks:

define and maintain remotes and the transport addresses of
users who are responsible for them

assign remotes to distribution groups

create and maintain sales and marketing teams and their
members (if applicable)

limit a remote’s image of the central Address Book by permitting
the selective distribution (partial image) of specific types of
Address Book entries only

assign users to remotes

set up distribution preferences for each remote
set up remote distribution filters

perform Address Book diagnostics

define server settings

add or remove synchronized Address Books (the central
database)



Chapter5 | 57
MaxExchange Site Manager

Starting MaxExchange Site Manager

@ In order for the MaxExchange
Site Manager menu item to
appear on the Utilities menu,
you must have first installed
MaxExchange Server.

To access MaxExchange Site Manager, you must have installed
MaxExchange Server or Remote Server on the computer where you
are accessing the utility. You must also have access to the central
Address Book as the MASTER user, or a user with Maximizer
Administrator privileges.

Note that if you are using Windows authentication for Maximizer,
you are not prompted for a Maximizer user name and password
when you start MaxExchange Site Manager. You must map the
Maximizer user to your Windows account before starting
MaxExchange Site Manager. For more information on setting up
Windows authentication for Maximizer, see the Maximizer CRM
Administrator’s Guide.

» To start MaxExchange Site Manager

e Double-click the MaxExchange Site Manager icon on the
desktop.

¢ Select MaxExchange Site Manager from the Utilities menu in
Administrator.

The Site Manager window opens. The first view allows you to set
up your remotes. To set up teams and additional server
properties, click the associated icon.

2V ManxExchange Site Manager - [Escona Tutarial] P ] 3
Ele Wew Reports Help

[ Open Address Book
Distribution Sites

Remote Sites [ show Tree View

Escona News [ 1E9E7960)
[ER=54 < cona Tutorial 59)
L= rem (IF315106)

5% Financial { 867FFC33)

add... || Saven.. | etresh ste,. | Dot | Deleie Pertial Packets | Delete LodkFiks | roperties. .|

[Ready [User: MASTER |
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Configuration Settings

The following tables provide an overview of the various
configuration settings available in Site Manager. Step-by-step
configuration instructions are provided in the subsequent section.

@ “Distribution Site” is another
term for a remote.

Distribution Sites Screen

2V ManxExchange Site Manager - [Escona Tutarial] P ] 3
Ele Wew Reports Help
[ Open Address Book

Distribution Sites

Remote Sites [ show Tree View

= rem (1F:
B Financial { 657FFC33)

acd... | save... | Refresh S . | Delete | Delete partial Peckets | elete Lok Files | proparties.. |

[Read:y [User: MASTER [
Field, Option, or
Button Purpose and Use
Show Tree View You can view the remotes either in tree view or

in column view, depending on whether this
checkbox is selected.

@You must be in Tree View to add the first remote to a
server.

Remote Sites Displays the synchronized Address Book(s),
remote server(s), and remote(s).
e Tree view displays the names and Address
Book IDs in a hierarchical format.
e Column view displays additional
configuration information about the
remote.



Field, Option, or
Button

Add

Save

Refresh Site

Delete
Delete Partial

Packets

Delete Lock Files

Properties

Chapter 5
MaxExchange Site Manager

Purpose and Use

Adds a remote or a remote server. See “Setting
Up Distribution Sites” on page 71.

Enables you to save information about remotes
to a tab-delimited text file. The text file
contains the following columns:

¢ Name: Name of the remote
e DBID: Address Book ID of the remote
e LSP: ID of the last packet sent to the remote

e LRP: ID of the last packet received from the
remote

¢ Date: Date when the last packet was
received from the remote

¢ Time: Time when the last packet was
received from the remote

e Last Packet Sent: Date and time when the
last packet was sent to the remote

See “Sending a Remote Refresh” on page 86.

Removes the selected distribution site from the
Remote Sites list. See “Removing a Remote” on
page 90

Deletes incomplete packets (ATT files without
headers) from all remotes in the current
Address Book.

Deletes lock files (MEX files) that are created
during processing sessions for all remotes in
the current Address Book. MaxExchange
typically deletes this file automatically.
However, there may be instances, such as if a
machine is inadvertently shut down, that this
file is not deleted.

Opens the Properties dialog box for the
selected server or remote. You can also open
the Properties dialog box by double-clicking on
the server or remote in the tree or column
view.
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Teams Screen

i MaxExchange Site Manager - [EsconaT utorial] M B3
Fie View Fepots Help
[ Opsn Addhess Bank

Members of selected team

East Coast Marketing  (Marketing) Miranda Carell
East Coast Sales  (5alss)
EE Head Office Sales  (sales)

\West Coast Marketing  (Marketing)
Teams iest Coast Sales  (Sales)

add.. | modfy.. | Deete edd.. | wodfy. | oelie |
Ready [
Field, Option, or
Button Purpose and Use
Teams Displays a list of sales (Opportunities) and

marketing (Campaigns) teams for the current
Address Book. The right column displays the
members of the currently selected team. You
can create new teams and change settings for
existing teams using the Add and Modify
buttons.



Field, Option, or
Button

Members of the
selected team
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Purpose and Use

Displays the members of the sales or marketing
team selected in the Teams column. You can
add new team members or modify settings for
existing members using the Add and Modify
buttons.

Properties for team members include the
following settings:

¢ Name: Team member’s name.

e User ID: Team member’'s Address Book user
ID.

e Status: Indicator whether the member is a
team leader. A team may have only one
leader.

e Campaign/Opportunity rights: Indicates
whether the member has read-only (audit),
read/write (edit), or partial read/write
(standard) rights.

¢ Reassign Campaign/Opportunity (modify
dialog box only): Enables you to assign the
selected member’s Opportunity or
Campaign item(s) to another member of the
team.

¢ Current distribution sites: Identifies the
Name and Address Book ID of the remote(s)
to which the selected team member
belongs.
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Server Settings Screen

i ManExchange Site Manager - [Escona Tutorial]

=i

Ele Wew Reports Help

[ Open Address Book

Server Settings
~Server settings

Brimary FTP address: || Pagsward... | Port: |21
Secondary ETP address:
URL: l— Password...
Network ardress: Browse...
Emall address: l— fddress Baok. .
—Warning:

I Epable remote warnings
Display the warning icon i na packets receivedin | U day(s)

¥ Display the Distribution Site message box warning
Rebuids
I™ Enahle partial rehuilds

Default behavior
Missing packets: [wait = | Previous packets: |Wa.t | Fatalerors: |Rmver =l ‘

Inkerface customization: ‘

|
o

$

Teams

(
(

Mumber of MaxExchange licenses : 1

[V Distribute Interface Customizations to Remotes and Remate Servers

Other Options... |

[User: MASTER

S

[Ready

Field, Option, or

Button Purpose and Use

Primary FTP Contains the FTP address of the server, which

address/ must be a static IP address or a fully qualified

Secondary FTP domain name. If you are using a NAT-enabled

address firewall and an IP address, it must be the
externally assigned IP address. You can specify
a second FTP address if necessary.

Password Sets the FTP passwords. There are two

passwords:

¢ MaxExchange password: Password for
synchronization using FTP transport
method. This password must be entered at
the remote for the FTP connection to occur.
Guest password: Second password that
has the same function as the MaxExchange
password. Use this password when a remote
needs to connect using FTP, but you don't
want to give out the main MaxExchange
password. This password is typically used in
testing and troubleshooting situations.
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Purpose and Use

Displays the server’s listening port used for FTP
transport. You can adjust this setting if
necessary. By default, port 21 is selected. You
must also open other ports equal to the
number of remotes that are connected
concurrently. These additional ports must be
within the range of 10035 - 11315 and are
used for data transfer.

If you are using HTTP, this field displays the
URL of the server. Note the URL must be
entered in one of the following formats:

http://[server name]:[port number]/
MaxExchangeTransport

https:/[server name]:[port number]/
MaxExchangeTransport

Sets the HTTP password.

¢ MaxExchange password: Password for
synchronization using HTTP transport
method. This password must be entered at
the remote for the HTTP connection to
occur.

Use this field for the Network Direct transport
method. The MaxExchange spdm.exe program
folder (e.g., C:\Program
Files\Maximizer\MaxExchange) on the server
must be shared with full access (Full Control/
Change/Read) to use Network Direct. Specify
the UNC address of the MaxExchange program
folder (e.g., \TEST-SERVER\MaxExchange). The
application looks for the presence of the
spdm.exe file and does not allow itself to be
mapped to any other folder.

Enables you to navigate to the shared
MaxExchange program folder on the server.

Email address that the email client on the
server is configured to use.

Opens the list of contacts for the local email
client.

Alerts the server to flag remotes that have not
synchronized over the specified number of
days.
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Field, Option, or
Button

Display the
warning icon if
no packets
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Display the
Distribution Site
message warning

Enable partial
rebuilds

Missing pac