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“Network Configuration” on page 8
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Maximizer System Requirements
The hardware and software requirements for each type of Maximizer 
installation are listed in the following tables. Please refer to the 
Maximizer website at www.maximizer.com for updated information.

These are the minimum system requirements for Maximizer, and 
your operating system may have higher requirements for some 
components, such as processor speed and RAM. 

Because Web Access (part of the Maximizer components for 
Microsoft IIS) may have to handle larger amounts of processing (as 
the number of concurrent Web Access clients increase), we 
recommend that you install Web Access on a server with dual or 
quad processors and more RAM than the minimum requirements. In 
addition, it is recommend that customers that are planning a 
deployment of Web Access on a server machine that potentially will 
have physical memory demands in excess of four gigabytes of 
physical RAM deploy on a 64-bit operating system.

The following sections contain detailed system requirements for 
running Maximizer:

• “Maximizer Group Edition System Requirements” on page 2

• “MaxSync for Microsoft Exchange System Requirements” on 
page 3

• “Workflow Automation Powered by KnowledgeSync System 
Requirements” on page 4

Maximizer Group Edition System Requirements

The following table lists the system requirements for Maximizer CRM 
Group Edition server and workstation. For the latest list of supported 
software, go to www.maximizer.com. 

CRM Server CRM Workstation

Minimum Processor 
Speedb

1.6 GHz (minimum)
3 GHz or faster processor 
(recommended)

1 GHz (minimum)
2 GHz or faster processor 
(recommended)

Available RAMa
1 GB (minimum)

2 GB (recommended)

512 MB (minimum); 
1 GB (minimum for Windows Vista or 
Windows 7)
2 GB or more (recommended)

Available hard disk space 2 GB (minimum)

5 GB or more (recommended)

2 GB (minimum)

5 GB or more (recommended)

Minimum video 
resolution

SVGA (800x600) or higher-resolution 
video adapter and monitor

SVGA (800x600) or higher-resolution 
video adapter and monitor
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MaxSync for Microsoft Exchange System Requirements

The following table lists the system requirements for MaxSync for 
Microsoft Exchange. 

Operating system Microsoft Windows XPb

Microsoft Windows Server 2003/2003 R2
Microsoft Windows Server 2008/2008 R2 
(updated to their latest service packs)

Microsoft Windows XPb

Microsoft Windows Vistab

Microsoft Windows 7 
Microsoft Windows Server 2003 
(updated to their latest service packs)

Email system 32-bit MAPI- or VIM-compliant
SMTP (for Maximizer Email Service)
SMTP and IMAP (for Maximizer Web 
Access)

32-bit MAPI- or VIM-compliant

Internet browser Microsoft Internet Explorer 7.0
Microsoft Internet Explorer 8.0
Mozilla FireFox 3.5, 3.6.x

Microsoft Internet Explorer 7.0
Microsoft Internet Explorer 8.0
Mozilla FireFox 3.5, 3.6.x

Software on the server 
where Maximizer 
components for 
Microsoft IIS are 
installedc

Microsoft Internet Information Server 
6.0 (Microsoft Windows Server 2003)
Microsoft Internet Information Server 
7.0 (Microsoft Windows Server 2008)
MIcrosoft Internet Information Server 
7.5 (Microsoft Windows Web Server 
2008 R2)

n/a

a. Because Web Access (Maximizer components for Microsoft IIS) may have to handle larger amounts of 
processing (as the number of concurrent Web Access clients increase), we recommend that you install Web 
Access on a server with dual or quad processors and more RAM than the minimum requirements. In 
addition, it is recommend that customers that are planning a deployment of Web Access on a server 
machine that potentially will have physical memory demands in excess of four gigabytes of physical RAM 
deploy on a 64-bit operating system.

b. Microsoft Windows XP Home, Microsoft Windows XP Media Center, Microsoft Windows Vista Home or 
Microsoft Windows Vista Home Premium are not supported in a network environment when logging into a 
domain is required. Refer to your Microsoft documentation for details on how to set up networking in a 
workgroup environment.

c. Maximizer components for Microsoft Internet Information Services are not supported on any Windows XP-
based, Windows Vista-based, or Windows 7-based computers.

CRM Server CRM Workstation

Server

Minimum Processor Speed 500 MHz (minimum)

1.6 GHz (recommended)

Available RAM 512 MB (minimum)
1 GB (recommended)

Available hard disk space 500 MB (minimum)
800 MB (recommended)
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Workflow Automation Powered by KnowledgeSync System Requirements

The following table lists the system requirements for Workflow 
Automation Powered by KnowledgeSync.   

Operating systema Microsoft Windows XPb

Microsoft Windows Server 2003
Microsoft Windows Server 2008 
(updated to their latest service packs)

Email system 32-bit MAPI-enabled application, Outlook 
2002 (XP) or higher

a. MaxSync for Microsoft Exchange is not supported in a multi-server 
Microsoft Exchange environment.

b. Microsoft Windows XP Home is not supported in a network environment.

Server

Server

Minimum Processor Speed 1.6 GHz or faster processor

Available RAM 1 GB

Available hard disk space 140 MB for installation,
70 MB for application,
5 KB max per event

Operating system Microsoft Windows XP
Microsoft Windows Vista
Microsoft Windows Server 2003
Microsoft Windows Server 2008
 (updated to their latest service packs)
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Maximizer CRM Modules and Components
• Maximizer CRM is a robust contact, campaign, opportunity, 

and order management tool. It provides invaluable assistance in 
tracking customer interaction and purchase history, planning 
and management of sales opportunities using customizable sales 
strategies and automatically calculating the probability of close 
at every stage. With the creation of meaningful graphs and 
charts, companies benefit from complete, detailed intelligence 
to fully understand their audience and evaluate the 
performance of their business.

• Administrator is used by a system administrator or IT staff to 
configure the entire Maximizer system and manage users and 
security. From Administrator, you can create and manage 
Maximizer databases (called “Address Books”), back up your 
data, import and export Address Book information, produce 
system reports, and perform other administrative tasks.

Modules and Components

• Partner Access is a browser-based application providing two-
way flow of information between your organization and its 
business partners. A multi-tier distribution group can effectively 
distribute sales opportunities and keep all involved parties 
informed about the latest discussion topics and customer service 
cases.

• Customer Access is a browser-based application providing a 
two-way flow of information between your organization and its 
customers. 

• Maximizer Web Access is a browser-based application 
providing your organization’s employees with the functionality 
of Maximizer from anywhere in the world.

• Wireless Access provides access to Maximizer through any 
wireless Internet-enabled device. When users open Wireless 
Access from Start > Programs > Maximizer CRM > Web Access, a 
URL displays. They can enter this URL into a handheld device to 
access the Wireless Access.

• Dashboards are a component of Maximizer and Maximizer 
Web Access that can be used for monitoring activities in your 
company. The information you see in dashboards is generated in 
real-time, so you have an up-to-date view of the activities taking 
place in Sales and Marketing. Information, such as how many 
opportunities are in the funnel and your daily revenue from 
online purchases, are accessible instantaneously.



Maximizer CRM 11
Administrator’s Guide

6

Maximizer Companion Applications

• MaxExchange is a separate application. When installed, it 
enables you to synchronize Maximizer data between a server 
and remote computers. 

• Accounting Link is an add-on application designed for use with 
QuickBooks®, Microsoft Dynamics™ GP, or Sage 50 Accounts. It 
enables you to connect to your accounting database from any 
Maximizer computer and add or update invoices, estimates, or 
purchase orders.

• MaxMobile combines with Maximizer to offer you all of the 
contact management features of Maximizer with the portability 
and convenience of a handheld device. Whether at work or on 
the road, you always have access to current information about 
your clients or customers—names, addresses, appointments, 
tasks, and notes. Simply use MaxMobile to view and modify your 
data, on your mobile device, in real time.

• MaxAlarm automatically monitors appointments for one or 
more people in any number of Address Books. MaxAlarm 
automatically starts when you start the computer and appears as 
an icon in the Windows system tray. You can leave it running 
when Maximizer is closed and still receive notification of 
appointments. 
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Sample Address Books
Maximizer includes sample Address Books to help you learn the 
program.A typical server installation of Maximizer installs a complete 
sample Address Book called “Escona Tutorial”, which is used 
throughout the Maximizer documentation. You can use the Escona 
Tutorial Address Book while you are learning to use Maximizer. 

Maximizer also installs several other sample Address Books for a 
variety of industries. You can use a sample Address Book appropriate 
to your industry as a starter Address Book.

With the exception of Maximizer Web Access, you can access the 
sample Address Book for all components of Maximizer with the 
following user ID: 

User ID: MASTER

Password: control

Use the sample Address Books for learning and testing purposes only, 
and create a new Address Book for your organization’s data. The 
sample Address Books are overwritten if you re-install, so you don’t 
want to store your organization’s data in those Address Books.
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Network Configuration
The network configuration for a Maximizer installation can include 
multiple servers, workstations, firewalls, and Internet connections. 
Workstations at the head office can access the Maximizer database 
over the network, while workstations in remote offices can use 
MaxExchange to access corporate information. Employees, 
customers, and partners can also access information over the 
Internet. Your network setup will depend on the configuration and 
the components you choose to install.
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Related Documentation
This guide is one source of documentation included with Maximizer, 
and the following additional resources are available:

• Contents Help (Help > Local/Online Contents) provides 
additional information about using Maximizer and 
Administrator.

• Context-sensitive help (F1) provides details specific to the 
screen currently active in Maximizer. Press the F1 key to activate 
context-sensitive help for the current screen.

• The Maximizer CRM User’s Guide is your reference guide to 
using Maximizer. This guide is available in PDF format from the 
Help menu in Maximizer and Administrator.

• The MaxExchange Administrator’s Guide is your reference 
guide to configuring and using MaxExchange. This guide is 
available in PDF format from the Maximizer CRM folder in the 
Windows Start menu when MaxExchange Synchronization 
Server is installed.

• The Maximizer CRM Customization Suite includes additional 
guides for integrators. When the Customization Suite is 
installed, these guides are available in PDF format from the 
Maximizer Customization Suite folder in the Windows Start 
menu. The Customization Suite enables customers and business 
partners to customize the Maximizer interface and to integrate 
with other front-office and back-office solutions.

• The Maximizer website (www.maximizer.com) provides the 
latest product information. It also includes a searchable 
Knowledge Base at www.maximizer.com/knowledgebase.
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In this chapter...

“Maximizer Components Requiring Microsoft IIS” on page 12

“Virtual Directories” on page 12

“Web Server Permissions” on page 13

“Changing the Anonymous Web Access Account” on page 13

“Setting Up the Maximizer IIS Production Environment” on page 15

“Microsoft IIS Account Configuration” on page 18

“Microsoft IIS on Windows Server 2008” on page 19

“Microsoft IIS on 64-Bit Operating Systems” on page 20

“Microsoft IIS for Windows Authentication” on page 22

“Setting File and Directory Permissions” on page 24

“Adding Support for File Types” on page 25
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Maximizer Components Requiring Microsoft IIS
Microsoft Internet Information Services (IIS) is required for the 
following Maximizer components:

• Maximizer web access, sites

To support downloading 
emails that were saved to 
Documents from Maximizer 
Web Access, Extended MAPI 
must be installed on the IIS 
server. Installing Microsoft 
Outlook on the IIS server in 
Corporate or Workgroup mode 
satisfies this requirement.

• Dashboards

• Automated campaigns, for statistics in email activities

• MaxExchange Server, when using the HTTP transport method

• MaxMobile Wireless Server

IIS is included with most versions of Windows supported by 
Maximizer CRM.

Virtual Directories
The content and script/executable directories that IIS makes available 
to web clients are known as virtual directories.

When you create a new Address Book, virtual directories are created 
automatically for the various Maximizer components.

Maximizer Components Virtual Directory Name

Maximizer Web Access MaximizerWebAccess

Partner Access MaximizerPartner

Customer Access MaximizerCustomer

Wireless Access MaximizerWireless

Dashboards Dashboard

Automated campaigns Campaigns

MaxExchange web service for the 
HTTP transport method

MaxExchangeTransport

MaxMobile Wireless Server MaxMobileService
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Web Server Permissions
If both Web server and NTFS 

permissions are set, 
permissions that deny access 
take precedence over those 
that grant access. 

Web server permissions affect all users accessing the site, ranging 
from the Anonymous user account to a user who is a member of the 
Administrators or Domain Admins group. Regardless of an account’s 
group membership, all accounts will be denied access equally. 
Therefore, when access to virtual directories is created for 
IUSR_ServerName, the exact same virtual directory restrictions will be 
placed on the IWAM_ServerName account.

Changing the Anonymous Web Access Account
Changing the anonymous web access account involves first creating 
an account, then configuring the account.

If you change the anonymous 
web access account on a 
computer running 
MaxExchange Synchronization 
Server or MaxExchange 
Remote Synchronization 
Server, you must update 
permissions on the 
MaxExchange folders. See the 
MaxExchange Administrator’s 
Guide for details.

➤ To create an anonymous web access account

� Start Windows User Manager.

� Select the local domain by selecting Users > Select Domain.

� Create a new user account.

� Make the account a member of the Guests group.

� Confirm that the Guests group only has the right to log on 
locally by performing the procedure outlined in “Standalone 
Servers” on page 18.

➤ To configure the anonymous web access account in 
Windows Server 2008

� Start Internet Services Manager (available through Windows 
Administrative Tools).

� Select the default website or another website if more than one is 
available.

� Double-click Authentication.

� Select Anonymous Access and click enable.

� Click edit.

The Edit Anonymous Authentication Credentials dialog box 
opens.

� Click Set and type the Username and Password for the 
account you created above. Click OK when you are finished.
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� Select the Basic Authentication option and click Enable.

➤ To configure the anonymous web access account in 
Windows Server 2003

� Start Internet Services Manager (available through Windows 
Administrative Tools).

� Select the default website or another website if more than one is 
available, and open its property sheets by right-clicking and 
selecting Properties.

� Click the Directory Security tab.

� Click the Edit button in the Anonymous Access and 
Authentication Control section.

The Authentication Methods dialog box opens.

� Select the Enable Anonymous access checkbox.

Web browsers enable the 
anonymous access option by 
default. It is recommended 
that you manually enter the 
Anonymous user account 
password, and that you disable 
the “Enable Automatic 
Password Synchronization” 
checkbox. Be sure that the 
password that you enter is 
identical to the existing 
password for the local 
Anonymous user account. 

� Type the Username and Password for the account you created 
above or click the Browse button to select a user from the list.

� Enable the Basic Authentication option.

	 Click OK to close the Anonymous User Account dialog box.


 Click OK to close the remaining dialog boxes.
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Setting Up the Maximizer IIS Production Environment
Maximizer is designed to meet the real-world infrastructure 
requirements of IT departments, including support for load 
balancing and demilitarized zones.

Maximizer uses the IIS Default 
Web Site on port 80. Other 
web sites running on the 
server must use different ports.

Maximizer Web Access makes use of Microsoft’s ASP.NET technology. 
If your company has implemented other web pages or solutions, it is 
strongly recommended that these pages are hosted on a separate IIS 
Server from the Maximizer Web Access sites.

The following sections contain information on IIS production 
environments:

• “Load Balancing” on page 15

• “Demilitarized Zone (DMZ)” on page 17

Load Balancing

In some deployments of Maximizer Web Access with a large number 
of users, more than one IIS server may be needed to handle the load. 
Network load balancing works with Maximizer Web Access to 
achieve this.

It may be advantageous to deploy network load balancing in a 
situation that includes the following:

• A single IIS server is running at high CPU usage levels and 
performance of Maximizer Web Access is poor only when many 
users are using the system.

• The SQL server serving the Maximizer Address Books is not 
running at high CPU usage levels.

• A set of servers of similar capacity are available to deploy 
Maximizer Web Access.

• The available IIS servers are all running Windows Server 2003 or 
later or a hardware load balancer is available.

Configuring Load Balancing

For Maximizer Web Access, network load balancing is configured in 
one of the following ways:

• Install multiple servers with the Maximizer IIS components and 
install the Network Load Balancing service in Windows on each 
server. See the Network Load Balancing documentation for 
information.

• Install and configure a hardware network load balancer in the 
network.
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Network load balancing must be configured with client affinity 
enabled meaning that each client has all IIS requests served by the 
same server and that the client's IP address is used to determine 
which server will serve the requests.

Each Maximizer IIS server must be configured identically and must 
have the same version of the Maximizer IIS components installed. 
When upgrading to a new version of Maximizer Web Access, 
upgrade each server to the new version before the new version goes 
online, and apply any customizations to all servers.

Benefits of Load Balancing

The main benefit of load balancing is that multiple IIS servers can be 
used to divide the IIS load transparently to users with very low 
performance overhead. It may be more economical to install many IIS 
servers of lower capacity than one high-capacity IIS server. If one IIS 
server loses connectivity or is taken offline for maintenance, users 
may experience a session timeout as the load is rebalanced. But users 
will be able to log in again immediately and continue to use the 
system.

Drawbacks of Load Balancing

Network load balancing has the following drawbacks:

• The system is scaled to a larger number of users only if the SQL 
server can handle the load.

• Multiple IIS servers must be maintained with the same settings 
and version of the software. Otherwise, some users may be able 
to use the system while other users are not able to use the 
system. 

In some cases, users may access the system from an Internet service 
provider that frequently changes the client IP address as it appears to 
the server. This may cause frequent session timeouts when logged in 
to Maximizer Web Access.
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Demilitarized Zone (DMZ)

Security is the biggest priority for IT departments in most 
corporations. Demilitarized zone (DMZ) is the term used to describe 
the network area between the external router, which talks to the 
Internet, and the corporate firewall, which protects internal 
computers from Internet security breaches.

Maximizer has been designed to support network DMZs by enabling 
corporations to separate their database servers (usually located 
inside the firewall) from the IIS web machine (located in the DMZ). 
Communication between the database servers and the web server is 
handled by private ports configured by IT administrators. 
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Microsoft IIS Account Configuration
Most Windows servers are installed in network environments in 
which they provide services to client workstations. In such a 
configuration, the security considerations are often built around 
physical access issues. When Microsoft IIS’s World Wide Web 
Publishing Service is enabled, the server is suddenly placed in an 
environment that is accessible by external users who can be located 
virtually anywhere in the world. This situation requires that you 
exercise much more care in ensuring that the server is secure from 
unauthorized access.

The following section contains information on one type of IIS 
configuration:

• “Standalone Servers” on page 18

Standalone Servers

When IIS is installed on a standalone server (a server without 
membership in a Windows domain) the IUSR_ServerName account is 
made a member of the “Guests” local group. In most server 
environments, this configuration works well. 

➤ To configure the Guest local group in Windows Server 
2003 or Windows Server 2008

� Open Local Security Policy (available through Windows 
Administrative Tools).

For further information, refer 
to your Windows operating 
system documentation.

� Expand the Local Policies branch, and select User Rights 
Assignment.

� Right-click Allow log on locally, and select Properties from 
the shortcut menu.

� Add the <server_name>\Guest account to the list of allowed 
users. Click OK.

� Right-click Deny log on locally, and select Properties from the 
shortcut menu.

� Add the <server_name>\Guest account to the list of denied 
users. Click OK.
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Microsoft IIS on Windows Server 2008
If your Microsoft IIS server is a Windows Server 2008 computer, you 
may need to perform the following steps before installing the 
Maximizer components for IIS:

• Enable the .NET framework.

• Install the IIS 6 Management Compatibility role services.

➤ To enable the .NET framework

� From the Control Panel, open Programs and Features.

� Click Turn Windows features on or off.

� Select Features, and select Add Features.

� Select Microsoft .NET Framework.

� Click OK.

➤ To install the IIS 6 Management Compatibility role 
services

� Click Start > All Programs > Administrative Tools > Server 
Manager.

� Click Roles.

� Under Web Server (IIS), select Add Role Services.

The Add Role Services dialog box opens.

� Expand Management Tools, and select IIS 6 Management 
Compatibility and all of its sub-items.

� Click Next.

� If you are prompted, include additional components.

� Click Install.

	 When the installation is finished, click Close to close Server 
Manager.
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Microsoft IIS on 64-Bit Operating Systems
Maximizer requires the 32-bit version of ASP.NET 2.0 in order to run 
on a 64-bit operating system. To run the Maximizer components that 
require Microsoft Internet Information Services (IIS), you must enable 
32-bit applications in IIS. The procedures vary depending on the 
operating system running IIS.

• “Enabling 32-Bit Applications in Windows Server 2008” on 
page 20

• “Enabling 32-Bit Applications in Windows Server 2003” on 
page 21

Enabling 32-Bit Applications in Windows Server 2008

In Windows Server 2008, the Maximizer web applications should run 
under an application pool in Classic mode that has 32-bit applications 
enabled. If you do not need to run other applications on a 64-bit web 
server, you can specify these settings for the default application pool. 

If you need to use a 64-bit web server, you can add a new application 
pool with these settings and run the Maximizer applications under 
this application pool. You can also run the Maximizer applications 
under the “Classic .NET AppPool” application pool.

➤ To run applications in Classic .NET AppPool

� In IIS Manager, select the virtual directory for the Maximizer 
component.

� Select Advanced Settings.

� In the Application Pool field, select Classic .NET AppPool, 
and click OK.

� If necessary, repeat the procedure for other Maximizer virtual 
directories.
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Enabling 32-Bit Applications in Windows Server 2003

In Windows Server 2003, you must enable the 32-bit version of 
ASP.NET 2.0 using the command prompt.

➤ To enable the 32-bit version of ASP.NET 2.0 in 
Windows Server 2003

� Open the Command Prompt (Start > Accessories > Command 
Prompt).

� Type the following command to enable the 32-bit mode:

cscript %SYSTEMDRIVE%\inetpub\adminscripts\
adsutil.vbs SET W3SVC/AppPools/Enable32bitAppOnWin64 1

� Type the following command to install the 32-bit version of 
ASP.NET 2.0, and the script maps at the IIS root:

%SYSTEMROOT%\Microsoft.NET\Framework\v2.0.50727\

aspnet_regiis.exe -i 

� Make sure that the status of ASP.NET version 2.0.50727 (32-bit) is 
set to Allowed in the Web service extension list in Internet 
Information Services Manager.
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Microsoft IIS for Windows Authentication
If you want to use Windows Authentication in the components that 
require Microsoft IIS, you must configure IIS for Windows 
Authentication. The procedure for configuring IIS for Windows 
Authentication varies depending on the version of Windows you are 
using. The following sections contain detailed information on 
configuring IIS for Windows Authentication:

• “IIS for Windows Authentication in Windows Server 2008” on 
page 22

• “IIS for Windows Authentication in Windows Server 2003” on 
page 23

IIS for Windows Authentication in Windows Server 2008

In Windows Server 2008, you must set the authentication method for 
the Maximizer Web Access, Maximizer Web Access Administrator, 
Wireless Access, or Dashboard virtual director or for the Admin 
subfolder of the Customer Access or Partner Access virtual directory. 

➤ To set the authentication method for a virtual 
directory in Windows Server 2008

� In IIS Manager, select the virtual directory for the web access site.

– or –

To set up Windows Authentication for Customer Access or 
Partner Access, select the Admin subfolder of the virtual 
directory.

� Double-click Authentication. 

� Verify that the Windows Authentication and ASP.NET 
Impersonation options are enabled. All other options must be 
disabled.

If the Windows Authentication and ASP.NET Impersonation 
options are not available, go to Control Panel > Programs and 
Features. Select the Turn Windows features on or off option. 
Expand Roles and select Web Server (IIS). Click Add Role Services 
and enable Windows Authentication.
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IIS for Windows Authentication in Windows Server 2003

In Windows Server 2003, you must specify the authentication 
methods for the Maximizer Web Access, Maximizer Web Access 
Administrator, Wireless Access, or Dashboard virtual directories or 
the Admin subfolders of the Customer Access or Partner Access 
virtual directory. The settings differ depending on the type of 
configuration.

➤ To set the authentication method for a virtual 
directory in Windows Server 2003

� In IIS Manager, select the virtual directory that you want to 
modify.

– or –

To set un Windows Authentication for Customer Access or 
Partner Access, select the Admin subfolder of the virtual 
directory.

� Right-click, and select Properties.

� Select the Directory Security tab.

� In the Authentication and access control area, click Edit. 

� Set the field values based on the following scenarios:

Scenario 1: Available only if SQL server is on the same machine 
as IIS, or Delegation is set up between IIS and SQL.

• Only Integrated Windows authentication should be enabled.

• Internet Explorer Browser settings on clients control whether 
or not user is prompted for a password: tools, internet 
options, security, custom, User Authentication (the last 
setting). The setting cannot be set to Anonymous access.

Scenario 2: All configurations.

• Only Basic Authentication should be enabled. In this 
situation, SSL should always be set up in a production 
environment to protect the users' passwords since Basic 
Authentication is not encrypted.

• Realm should be set to describe the location of the server - 
i.e., “Maximizer Software Inc.”.

• The default domain should be set so that users can type 
username instead of domain\username when logging in. 

• For Partner Access and Customer Access, if SQL Server is on a 
different machine, the IUSR_MACHINENAME user should be 
duplicated (exact username and password) on the SQL server.
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Setting File and Directory Permissions
The virtual directory system for IIS comprises only half of the 
directory security system. To complement the virtual directory 
security, file and directory permissions for all of the physical 
directories that virtual directories reference must also be made more 
secure. In a default Windows Server 2003 or Windows Server 2008 
installation, the “Everyone” group is given full Directory and File 
permissions for almost all directories on the server. Although this is a 
convenient feature for a newly installed server, it provides very poor 
security. 

During the installation, the Maximizer setup creates the following 
folders on the server:

• ...\All Users\Application Data\Maximizer\AddrBks

• ...\All Users\Application Data\Maximizer\SvrShare

By default, these folders have full access rights. You may change the 
security rights to provide access to only specific users and/or groups.

➤ To remove the “Everyone” group

� Start Windows Explorer and browse to the ...\Inetpub\scripts 
directory (typically, C:\InetPub\scripts).

� Select the scripts directory, and select File > Properties.

� Select the Security tab.

� Highlight the Everyone group in the Name list box, and click  
Remove. 

The Everyone group is removed from the list.

� Click Add.

The Select Users, Computers, or Groups dialog box opens.

� Select the Guest or Domain Guest group, and click Add.

� Click OK.

	 In the Permissions list box, select the Read checkbox from the 
Allow column.


 Click OK.



Chapter 2
Configuring Microsoft Internet Information Server (IIS)

25
Adding Support for File Types
Some Maximizer features may require you to add support for 
different file types to the Default Web Site on your IIS server. You 
can use IIS Manager to register additional Multipurpose Internet Mail 
Extensions (MIME) types for your server. 

You may be required to register MIME types in the following 
situations:

• To add to the list of supported document types in Maximizer 
Web Access.

• To deploy MaxMobile by a wireless connection.

• To install the Wireless Access Shortcuts application on BlackBerry 
devices.

The procedure for registering MIME types varies depending on the 
version of Windows you are using.

➤ To register MIME types in Windows Server 2008

� On the Maximizer IIS server machine, open the IIS Manager.

� Open the Default Web Site.

� Double-click the MIME Types icon.

� Click Add.

� Enter the file extension and MIME type to be supported.

� Click OK to add the specified MIME type.

➤ To register MIME types in Windows Server 2003

� On the Maximizer IIS server machine, open the IIS Manager.

� Open the Properties dialog box for Default Web Site.

� Click on the HTTP Headers tab.

� Click the MIME Types button.

� Click the New button.

� Enter the file extension and MIME type to be supported.

� Click OK to close the Default Web Site Properties dialog box.

	 Restart the IIS server.
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Pre-installation Checklist
Although the process of installing Maximizer CRM is straightforward, 
a successful installation requires planning and attention to detail. In 
its simplest arrangement, all Maximizer CRM components may be 
installed on a single Windows machine to which one or more 
Maximizer Workstations may connect. However, for large 
installations, it is optimal to designate a single machine for each 
component. 

Depending on the network 
configuration, you may have 
more than one of each 
component machine. However, 
there is only one Maximizer 
Application Server.

The following sections outline the steps for a large installation in 
which each Maximizer component—such as IIS Server, Maximizer 
Server, Maximizer Workstation, and MaxExchange Synchronization 
Server—is isolated on a separate machine.

• “Step 1: Identify the Key Server(s)” on page 28

• “Step 2: Ensure the Servers Meet System Requirements” on 
page 30

• “Step 3: Verify Network Connectivity” on page 30

Step 1: Identify the Key Server(s)

Identify the Maximizer Application Server, IIS Server MaxExchange 
Synchronization Server and Email Server.

• Maximizer Application Server: The Maximizer Application 
Server is the machine where the Maximizer CRM Server 
application is installed, and it acts as a file server. Additionally, 
the Maximizer Server machine contains the Maximizer Email 
Service and Maximizer Print/Fax Service. The Maximizer Server 
machine must be capable of sharing folders. These folders store 
template and configuration information specific for each 
Address Book. It is advisable to back up the Maximizer Server on 
a consistent basis.IIS Server: The IIS Server hosts the web server 
components, including web access sites. To run these 
components, the IIS Server must have SQL connectivity with the 
SQL Server machine. Typically, the web server is separated from 
the rest of the network by a firewall. Even if a firewall exists 
between the IIS Server and SQL Server, SQL connectivity must 
exist to run Maximizer Web Access.

• MaxExchange Synchronization Server: The MaxExchange 
Synchronization Server communicates with Maximizer Remote 
Workstations, keeping their data up to date with the main 
Address Book. If the MaxExchange transfer protocol is FTP, 
ensure this machine is capable of communicating with 
MaxExchange Remotes through the designated port. If the 
transfer protocol is Email, make sure a compatible Email Server is 
available.
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• Email Server: The Email Server supports marketing campaigns, 
appointment reminders, and customer service case notifications. 
It must be capable of sending SMTP. 
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Step 2: Ensure the Servers Meet System Requirements

After the key servers have been identified, you should ensure that 
they meet the minimum system requirements. Also verify that all 
workstations meet minimum system requirements. See “Maximizer 
System Requirements” on page 2.

Step 3: Verify Network Connectivity

Check for network connectivity between the Maximizer Server 
computer and all Maximizer Workstation computers.

➤ To verify network connectivity using the ping 
command

� At the designated Maximizer Server computer, click Start > Run.

� Type command, and press Enter.

A Windows command prompt window opens.

� At the command prompt, type ping <IP address>, and press 
Enter.

<IP address> is the IP address of the computer you are trying to 
connect to over the network.

� Read the messages returned by the ping command and note 
whether the ping was successful.

• “Reply from ...” = success

• “Request timed out” = failure

� View the ping statistics to determine the quality of the network 
connection.

� If the ping command failed, or if the ping statistics reveal a poor 
quality connection, then troubleshoot the network connection 
to correct the problem.

� Repeat these steps to ping the rest of the computers in the 
network.
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➤ To determine a computer’s IP address

� At the computer whose IP address you want to determine, click 
Start > Run.

� Type command, and press Enter.

A Windows command prompt window opens.

� At the command prompt type ipconfig. 

The window displays the computer’s IP address, subnet mask, 
and default gateway, as well as additional network information.

� Write down the computer’s name and IP address for reference.
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Third-party Components Installed with Maximizer CRM
The Maximizer CRM installation includes the following third-party 
products:

• Microsoft SQL Server Express Database Engine

• Microsoft .NET Framework

• Crystal Reports Viewer

• Microsoft Data Access Components (MDAC)

The type of Maximizer installation determines which of these 
components are installed. 

Microsoft SQL Server Express Database Engine

Microsoft SQL Server Express is the database engine Maximizer uses 
to read and write data from the Address Book.

If you will be running in a workgroup environment, designate one 
machine as the Maximizer Application Server, which is the machine 
where the Maximizer Address Book(s) are stored. Keep in mind that 
this computer must always be on. If it is turned off, other machines 
will not be able to access the Address Book files. SQL Server Express 
installs automatically as part of the Maximizer CRM installation.

If you are upgrading the 
Maximizer instance of SQL 
Server 2005 Express 32-bit 
edition to SQL Server 2008 
Express 64-bit edition, you 
must uninstall the Maximizer 
instance of SQL Server 2005 
Express 32-bit edition before 
installing the Maximizer 
instance of SQL Server 2008 
Express 64-bit edition. Refer to 
the Maximizer knowledge 
base for detailed information.

If you are upgrading from Maximizer CRM 10.x, the Maximizer 
instance of SQL Server 2005 Express will be upgraded to SQL Server 
2008 Express.

The following Maximizer operations require the SQL Server Express 
database engine:

• installing MaxExchange Remote

• email transfer

The following Maximizer operations require the Pervasive.SQL 
database engine, which must be installed from the disc of a previous 
version of Maximizer or downloaded from the Pervasive website:

• upgrading an existing Pervasive or Btrieve Address Book

Microsoft SQL Server Management Studio Express

Microsoft SQL Server Management Studio is a tool you use to 
manage your database.

If you require SQL Server Management Studio Express to be installed 
on a drive other than the default Maximizer program folder drive, 
you can run the installation from the Maximizer CRM disc. The setup 
is found in the following location:

MaxCRM\3RDPARTY\SQLExpr
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Microsoft .NET Framework

The Microsoft .NET Framework installs automatically with the “Install 
Maximizer Components for Microsoft IIS” option.

If you install MaxExchange Synchronization Server, you must install 
the Microsoft .NET Framework before installing MaxExchange 
Synchronization Server. For more information, refer to the 
MaxExchange Administrator’s Guide.

Crystal Reports

Maximizer CRM includes a report reader for Crystal Reports. You 
must install the full version of Crystal Reports to create reports for 
Maximizer, but you can view Crystal Reports in Maximizer without 
installing the full version. These reports are accessible through the 
Reports menu in Maximizer. 

The Maximizer CRM Server installation creates the following folder, 
which contains shared reports:

• ...\All Users\Application Data\Maximizer\SvrShare\Reports\
<Address Book name>

All folders and reports within this folder are accessible from the 
Reports > Crystal Reports menu in Maximizer. Maximizer installs 
a set of standard reports, but you can also create your own 
custom, shared reports and save them in this folder.

The Maximizer CRM installations also create the following local 
folder:

• ...\My Documents\MaximizerReports

This local folder is the default location for personal report templates, 
which can be created from the Reports > Crystal Reports > Personal 
Custom Report menu in Maximizer. Users must belong to the Crystal 
Reports Users security group to use this function.

Microsoft Data Access Components (MDAC)

MDAC is required by Maximizer. The Maximizer CRM installation 
determines if MDAC is already installed on the machine and installs it 
if necessary. 

MDAC includes the following components:

• ActiveX Data Objects (ADO)

• OLE DB

• Open Database Connectivity (ODBC)
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Windows Login Account Rights Required for Installation
To install Maximizer CRM Server or Workstation, you must be logged 
into Windows using an account with Windows Administrator 
privileges. During installation, you may be required to reboot the 
computer, and then you must log into Windows using an account 
with Windows Administrator privileges again so the installation can 
continue.
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Shared Folders and Permissions
For information about the 

virtual directories created 
during installation and their 
permissions, refer to 
“Database Views for User-
Defined Fields” on page 387.

When installing Maximizer CRM Server, the following shared folders 
are created in the ...\Documents and Settings\All Users\Application 
Data\Maximizer\ folder on the server:

These folders must be shared on the server before installing 
Maximizer CRM workstation. If the Maximizer CRM Server 
installation did not share the folders, you must share them before 
proceeding with the workstation installations.

No shared folders are created by the Maximizer CRM Workstation 
installation.

Upgrading from a Previous Version of Maximizer
ALWAYS back up the Address 

Book before upgrading 
Maximizer. For instructions on 
backing up, refer to “Backing 
Up and Restoring Address 
Book Data” on page 306. If 
you have customized the 
dictionary and holidays, also 
back up those files separately 
before upgrading.

If you are currently running an earlier version of Maximizer and want 
to upgrade, it is strongly recommended that you uninstall the 
previous version before proceeding with the upgrade.

However, if you absolutely require your Maximizer settings, such as 
Window layout, colors, fonts, etc., to be carried over to the new 
version, you can install the new version without uninstalling the 
previous version. The setup then prompts you to uninstall the 
previous version automatically, but this method does not overwrite 
your Maximizer settings.

➤ To upgrade to the new version of Maximizer

� Back up your Maximizer Address Book. Refer to “Backing Up and 
Restoring Address Book Data” on page 306 for instructions.

� If you have customized the dictionary and holidays, also back up 
those files separately before upgrading. For instructions, refer to 
“Backing Up the Dictionary and Holiday Files” on page 311.

Folder name Shared name Description

AddrBks MxData Contains Address Books and Sample 
Address Books.

Share Permissions of Everyone with 
Change and Read (not Full Control).

SvrShare MxServer Contains Maximizer Workstation 
installation files, Crystal Reports 
templates, and Crystal Reports reports.

Share Permissions of Everyone with 
Change and Read (not Full Control).
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� If you have created custom dashboards, copy them to a safe 
location. The location of the dashboard (.KIN) files depends on 
your computer’s operating system. You can search your hard 
drive for the .KIN file extension to locate and backup the files. 
After upgrading, you can import the .KIN files into Maximizer. 
See the Maximizer CRM User’s Guide for more information on 
importing dashboards.

� Uninstall Maximizer CRM, and any additional Maximizer 
components such as MaxMobile or MaxExchange, on all 
computers.

You can find instructions for uninstalling Maximizer after this 
procedure.

� Install the new version of Maximizer, as described in this chapter.

� Upgrade your Maximizer Address Book database to the new 
version, as described in “Upgrading or Converting an Address 
Book” on page 74.

➤ To uninstall Maximizer

Uninstalling Maximizer does 
not uninstall your Address 
Book data. However, you 
should always back up your 
Address Book before 
uninstalling.

� Click Start > Settings > Control Panel > Add/Remove 
Programs. In Windows Vista, click Start > Control Panel > 
Programs and Features.

� In the list of currently installed programs, select Maximizer 
CRM.

� Click Change/Remove. In Windows Vista, select Uninstall/
Change.

� Click Yes to confirm.

The Remove Programs From Your Computer dialog box displays 
the uninstall progress.

� If the Remove Shared File? dialog box opens, click No To All.

� When the uninstall is complete, click OK to close the dialog box.

� Reboot the computer.
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Installation Order of Maximizer Components
Once the key servers are ready, you should install and configure the 
Maximizer components in the following order:

� Maximizer Server: Refer to “Installing Maximizer CRM Server” 
on page 38. Regardless of whether you are installing a 
Workgroup or Client/Server configuration of Maximizer, it is 
essential that you install the Maximizer Server before installing 
the workstations. During the workstation installation, you are 
prompted to supply a server name. After installing Maximizer on 
the server, open the Escona Tutorial sample database to create a 
server-side DSN, which enables any workstation to connect to 
the databases on the server.

� Maximizer Components for Microsoft IIS: Refer to 
“Installing Maximizer Components for Microsoft IIS” on page 48. 

� Maximizer Workstation: Refer to “Installing Maximizer CRM 
Workstation” on page 51.

� MaxExchange Synchronization Server: Refer to the 
MaxExchange Administrator’s Guide.
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Installing Maximizer CRM Server
You must be logged into 

Windows as an administrator 
to install Maximizer. After 
installation, it prompts you to 
restart the computer, and then 
you must log in as an 
administrator again to 
complete the installation.

An installation wizard steps you through the process of installing the 
software on the server. The instructions in this section complement 
the wizard to provide additional information.

Note that Maximizer Web Access, Customer Access, Partner Access, 
and Wireless Access are installed automatically with Maximizer CRM 
Server when the Maximizer Components for Microsoft IIS option is 
selected. You can enable the sites while installing Maximizer CRM 
Server or later. For information on enabling sites, see “Enabling Web 
Access Sites” on page 197. 

IMPORTANT NOTE FOR CONFIGURATIONS RUNNING THE 
MAXIMIZER APPLICATION SERVER AND MICROSOFT IIS SERVER 
ON THE SAME MACHINE: 

In a typical Maximizer CRM environment, the Maximizer application 
server and Microsoft IIS server are on two separate machines, and 
you must run the Maximizer CRM Server setup once on each 
machine:

• First install Maximizer Server on the Maximizer application 
server machine, using the Maximizer CRM Server disc.

• Then install Maximizer Components for Microsoft IIS on the 
Microsoft IIS server machine, using the Maximizer CRM Server 
disc.

However, if your Maximizer application server and Microsoft IIS 
server are running on the SAME machine, do not attempt to run the 
Maximizer CRM Server installation twice on the same machine. 
Instead, select both options in step 7 of the following procedure.

➤ To install Maximizer

� Close all programs running on the computer.

� Insert the Maximizer CRM Server disc. (The server and 
workstation versions are on separate discs.)

The setup starts automatically.

If the setup doesn’t start 
automatically, you can start it 
manually by running setup.exe 
from the MaxEnt folder of the 
disc (e.g., \MaxEnt\setup.exe).

� Select Install Maximizer CRM Server.

The InstallShield Wizard starts.

� Click Next to begin the installation.

� Read the license agreement, and click Yes to continue.

� Enter your Product Serial Number, First name, and Last 
name into the required fields, and click Next.
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� Select Maximizer Server, and click Next.

NOTE: If you are installing Maximizer Server on the machine that 
is also your IIS Server, you must select both Maximizer Server 
and Maximizer Components for Microsoft IIS now to install 
them both on the machine. 

To install Dashboard components for IIS, select Maximizer 
Server.

Do not change any default 
share names, file names, file 
locations, folder names, or 
folder locations after installing 
Maximizer. If you want to use 
names and locations other 
than the defaults, change 
them during the installation.

	 Click Next to install Maximizer Server components to the default 
location.

– or –

Click Browse, select a destination folder, and click Next.
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 Click Next to use the default folder for shared configuration 
information.

– or –

Click Browse, select a local shared folder, and click Next.

  

Maximizer creates the 
“Maximizer” folder on the 
drive where the Windows 
operating system is installed. If 
your Windows operating 
system is not on the C drive, 
the path will have a different 
drive letter.

By default, Maximizer setup creates the folder ...\All 
Users\Application Data\Maximizer on the server, and it 
creates two shared subfolders called AddrBks and SvrShare. 
These folders must be shared on the network so other PCs can 
access to resources installed to this location. The default Share 
name of AddrBks is “MxData”, and the default Share name of 
SvrShare is “MxServer”.
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��Select a setup type, and click Next.

Typical installs a default set of server software, such as Windows 
services, server-side software, and drivers. It also installs a default 
set of Maximizer user applications on the server. Maximizer 
recommends that you select the Typical installation, unless you 
have a specific reason not to.

Custom enables you to select specific Maximizer modules to 
install. You can select virtually any combination of server 
software and user applications you want. Select this option only 
if you have a specific reason to alter the default Maximizer 
installation provided by the Typical installation. If you would like 
to install additional components, click the + to expand the 
selection. Additional components available through the custom 
installation includes MaxExchange Remote.

To install Dashboard components for IIS, select Custom.

��If you have Microsoft Outlook or Microsoft Word installed on 
this computer, the wizard prompts you to integrate either or 
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both of those applications with Maximizer. Select which 
applications to integrate, and click Next.

��(This step applies to Typical installations only.) Select 
which sample Address Books to install.
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��(This step applies to Custom Installations only.) Select 
which features to install on the server, and click Next.

��(This step applies to the Corel WordPerfect Integration 
option only.) If the setup cannot locate Corel WordPerfect 
Office on the computer, it prompts you to provide the path to 
these files and folders. Click Browse to select the correct paths, 
and click Next.

��(The next 3 steps apply only if you selected Maximizer 
Components for Microsoft IIS in step 7.) The installation 
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prompts you to enter the name of your HTTP Server. Enter the 
name, and click Next.

��Specify the Website for the Maximizer Components for 
Microsoft IIS settings, and click Next.

If you choose to use an existing website, select the website from 
the drop down. Its identities are displayed in the website 
identities area.

If you choose to create a new website, enter the description, TCP 
port, IP address, and Host Header value.
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��Specify the name of the virtual directory for each of the web 
access sites, select Enabled for each site you want to enable, and 
click Next.

�	Specify your SMTP Server settings, and click Next.

The SMTP Server is used by the 
Maximizer Email Service.

If your ISP requires authentication, you must select the 
Outgoing mail server requires authentication checkbox and 
enter the User name and Password of a valid account.

Not all of these checkboxes 
may be available, depending 
on which installation options 
you selected.

�
Select any of the following options, and then click Next:

Create Maximizer desktop shortcut – This option creates an 
icon on the Windows desktop that runs Maximizer when you 
double-click it.

Create Maximizer Start Menu shortcut – This option creates 
a shortcut to Maximizer on the Windows Start menu.
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Create MaxExchange desktop shortcut – This option is 
available only if you selected the Custom installation option and 
then selected the MaxExchange Remote option. It creates a 
shortcut icon for MaxExchange on the Windows desktop.

Creating the Maximizer 
Workstation setup files causes 
the Maximizer Server 
installation to take much 
longer. Select this option only 
if necessary. For more 
information, see “Installing 
Maximizer CRM Workstation 
over the Network” on 
page 51.

Create Maximizer workstation setup files – This option 
creates a set of setup files on the Maximizer Server. If you choose 
to create these setup files, you can install Maximizer Workstation 
on any computer by connecting to the Maximizer Server over the 
network and running this setup—no installation disc is required.

This folder must be shared and 
available to all network users 
who need these files to install 
Maximizer CRM Workstation.

��(This step applies to the Create Maximizer workstation 
setup files option only.) Select a location to install the 
workstation setup files, or use the default location, and click 
Next.
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��Review the installation settings, and click Next.

��Select a location to install the database components or use the 
default location, and click Next.

��The wizard displays an installation progress indicator. After 
the installation is complete, click OK to close the message box.

The installation prompts you to restart your computer. 

��Click Finish to close the wizard and restart the computer.

��After the computer restarts, log into Windows using an 
administrator account. This step is required to complete the 
installation.

Maximizer CRM Server is now installed.

If you are installing Maximizer CRM Server, and your Microsoft 
IIS server is on a different machine, install Maximizer 
Components for Microsoft IIS on your Microsoft IIS machine, 
from the Maximizer CRM Server disc, as described in the 
following section.
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Installing Maximizer Components for Microsoft IIS

You must be logged into 
Windows as an administrator 
to install Maximizer. After 
installation, it prompts you to 
restart the computer, and then 
you must log in as an 
administrator again to 
complete the installation.

The Maximizer Components for Microsoft IIS installation is required 
to install the web access sites. Microsoft IIS must already be installed. 
To install Dashboard components for IIS, you must complete a custom 
installation of the Maximizer server and select the Dashboard 
Components for IIS option in the Select Features screen. For 
information on installing Maximizer server, see “Installing Maximizer 
CRM Server” on page 38.

NOTE: The following procedure is to install Maximizer Components 
for Microsoft IIS only on a machine that is not the Maximizer 
application server. To add the Maximizer Components for Microsoft 
IIS to an existing Maximizer application server, ensure the installation 
media is accessible from the application server. For example, if you 
installed the Maximizer application server from the disc, the disc 
must be in the drive. If you installed the Maximizer application server 
from another machine on the network, the other machine must be 
accessible. Then, modify the Maximizer installation via the Add/
Remove Programs module in the Control Panel, and enable the 
Maximizer Components for Microsoft IIS option.

➤ To install Maximizer Components for Microsoft IIS

� Close all programs running on the server.

� Insert the Maximizer CRM Server disc. (The server and 
workstation versions are on separate discs.)

The setup starts automatically.

If the setup doesn’t start 
automatically, you can start it 
manually by running setup.exe 
in the MaxEnt folder of the disc 
(e.g., D:\MaxEnt\setup.exe).

� Select Install Maximizer CRM Server.

The InstallShield Wizard starts.

� Click Next to begin the installation.

� Read the license agreement, and click Yes to continue.

� Enter your Product Serial Number, First name, and Last 
name into the required fields, and click Next.

� Select Maximizer Components for Microsoft IIS, and click 
Next.

Maximizer Components for Microsoft IIS must be installed on 
one of your network servers. Select only this option if you are 
installing on the IIS Server and the Maximizer Server is on a 
different machine.
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	 Click Next to install to the default location.

– or –

Click Browse, select a destination folder to install Maximizer 
CRM, and click Next.


 Click Browse, and select the same SQL Server that you selected 
for the Maximizer Server installation. 

��Enter the SQL administrator User name and Password, and 
click Next.

If the setup is unable to stop 
the IIS Server, select Start > 
Settings > Control Panel > 
Administrative Tools > 
Services and stop the IIS 
Admin Service.

��Enter the name of the HTTP Server, and click Next.

The IIS Server can be identified to the web by a fully qualified 
domain name (e.g., “www.yourcompany.com”), by its IP address, 
or by its computer name. The most common choice is to use a 
fully qualified domain name. The other choices are provided for 
flexibility in the event that a fully qualified domain name is not 
available at the time of installation.

��Specify the Website for the Maximizer Components for 
Microsoft IIS settings, and click Next. 

If you choose to use an existing website, select the website from 
the drop-down list. Its identities are displayed in the website 
identities area.

If you choose to create a new website, enter the description, TCP 
port, IP address, and Host Header value.

��Specify the name of the virtual directory for each of the web 
access sites, select Enabled for each site you want to enable, and 
click Next.

��Review the installation settings, and click Next to begin 
installing.

The wizard displays an installation progress indicator.

When the installation is complete, the final step of the wizard 
appears, as shown below.

��Click Finish to close the wizard.

��After the computer restarts, log in to Windows using an 
administrator account. This step is required to complete the 
installation.

Maximizer Components for Microsoft IIS are now installed.
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Setting Full Permissions to the Maximizer Web Access Temp Folder

In Windows Server 2003 or Windows Server 2008, after installing 
Maximizer and setting more secure permissions on the Maximizer 
directory (as described in “Setting File and Directory Permissions” on 
page 24), give the IIS/ASP.NET account full permissions to the 
following folder to allow documents to be downloaded from the 
Maximizer Web Access:

...\Program Files\Maximizer\Portals\Employee\Temp

➤ To set full permissions to the Maximizer Web Access 
Temp folder

� On the IIS server, locate the following folder:

...\Program Files Maximizer\Portal\Employee\Temp

� In Windows Server 2003, right-click the Temp folder and select 
Sharing and Security. Click the Security tab.

In Windows Server 2008, right-click the Temp folder and select 
Security. Click Properties, then select the Security tab. Click 
Edit.

� Click Add.

� Click Locations

� Select the local machine.

� In Windows Server 2003, enter IIS_WPG and click OK. 

In Windows Server 2008, enter IIS_USRS and click OK.

� Check Full Control.

	 Click OK.
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Installing Maximizer CRM Workstation 
After installing Maximizer on the server and performing the steps 
listed under “Pre-installation Checklist” on page 28, follow the steps 
in this section to install Maximizer on the workstation computer.

You can install Maximizer Workstation from the Workstation Setup 
files on the server or from the disc.

The following sections explain the methods for installing Maximizer 
Workstation:

• “Installing Maximizer CRM Workstation over the Network” on 
page 51

• “Installing Maximizer CRM Workstation from the Disc” on 
page 52

Installing Maximizer CRM Workstation over the Network

To install Maximizer Workstation over the network using the 
Workstation Setup files on the server, you must have selected the 
Create Maximizer Workstation setup files option during the 
Maximizer Server installation.

➤ To install Maximizer CRM Workstation from the 
Workstation Setup file on the server

You must be logged into 
Windows as an administrator 
to install Maximizer. After 
installation, it prompts you to 
restart the computer, and then 
you must log in as an 
administrator again to 
complete the installation.

� On the workstation, open Windows Explorer and browse to the 
following shared directory on the Maximizer Server:

\\<server_name>\MxServer\MaxCRMWSInstall\

� Double-click setup.exe to run it.

The Installshield Wizard starts.

� Complete the installation as described in the next procedure, 
beginning at step 4.
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Installing Maximizer CRM Workstation from the Disc

You must be logged into 
Windows as an administrator 
to install Maximizer. After 
installation, it prompts you to 
restart the computer, and then 
you must log in as an 
administrator again to 
complete the installation.

➤ To install Maximizer CRM Workstation from the disc

� Close all programs running on the computer.

� Insert the Maximizer CRM Workstation disc.

The setup starts automatically.

If the setup doesn’t start 
automatically, you can start it 
manually by running setup.exe 
in the MaxEnt folder of the disc 
(e.g., D:\MaxEnt\setup.exe).

� Select Install Maximizer CRM Workstation.

The InstallShield Wizard starts.

� Click Next to begin the installation.

� Read the license agreement, and click Yes to continue.

� Enter your Product Serial Number, First name, and Last 
name into the required fields, and click Next.

� Click Next to install to the default location.

– or –

Click Browse, select a destination folder to install Maximizer, 
and click Next.

The Maximizer database files install to the ...\Documents and 
Settings\<localuser>\Application Data\Maximizer\ folder. If other 
users should be able to access these database files, you must 
grant those users permissions to ...\Documents and 
Settings\<localuser>\ folder.
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	 Select a setup type, and click Next.

Typical installs the standard Maximizer CRM components. 
Administrator is not installed by default on workstation 
installations. To install Administrator on a workstation, select 
Custom.

Custom enables you to select additional, optional components 
to install, such as Administrator, and MaxAlarm.


 If this computer will operate as a Remote Workstation, select 
Yes, and click Next.

A Remote Workstation is for 
mobile users who are typically 
not connected to the network, 
but use MaxExchange to 
synchronize with a central 
database. Remote 
Workstations are frequently 
portable computers.

Otherwise, click Next to install the default, local setup.
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��(This step applies to Remote Workstation setups only.) 
Click Next to use the default folder for storing local Address 
Book and configuration information.

– or –

Click Browse, select a different folder, and click Next. 

��(This step applies to Remote Workstation setups only.) 
Select Yes if this Remote Workstation will also connect to the 
Maximizer Server through the LAN, and click Next.

This Remote Workstation 
synchronizes its local database 
with a MaxExchange 
Synchronization Server and 
occasionally connects directly 
to the Maximizer Server when 
docked back to the LAN.

Otherwise, click Next to install the Remote Workstation setup 
without LAN support.

��If Microsoft Outlook or Microsoft Word is installed on this 
computer, the wizard prompts you to integrate either or both of 
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those applications with Maximizer. Select the applications to 
integrate, and click Next.

The Maximizer documentation 
uses Escona Tutorial as its 
sample Address Book.

��(This step applies to Typical installations only.) Select 
any or all of the sample Address Books to install.
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��(This step applies to Custom installations only.) Select 
which features to install on the server, and click Next.

��(This step applies to the Corel WordPerfect Integration 
option only.) If the setup cannot locate Corel WordPerfect on 
the computer, it prompts you to provide the path to these files 
and folders. Click Browse to select the correct paths, and click 
Next.
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��(This step does not apply to Remote Workstation 
installations without LAN connections.) Enter the name of 
the Maximizer Server, and click Next.

��Select any of the following options you want for Maximizer 
and MaxExchange, and click Next.

Not all of these checkboxes 
may be available, depending 
on which installation options 
you selected.

Create Maximizer desktop shortcut – This option creates an 
icon on the Windows desktop that runs Maximizer when you 
double-click it.

Create Maximizer Start Menu shortcut – Creates a shortcut 
to Maximizer on the Windows Start menu (Start > Programs > 
Maximizer CRM).

Create MaxExchange desktop shortcut – This option appears 
only if you selected the MaxExchange Remote installation 
option. It creates a shortcut icon for MaxExchange on the 
Windows desktop.

�	Review the installation settings, and click Next to begin 
installing.

The wizard displays an installation progress indicator. 

�
Click OK to close the message box.

The installation wizard prompts you to restart the computer. 

��Click Finish to close the wizard and restart the computer.

��After the computer restarts, log into Windows using an 
administrator account. This step is required to complete the 
installation.

Maximizer CRM Workstation is now installed.
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Installing Maximizer Companion Applications
The following table explains how to install each of the Maximizer 
companion applications. For information about each of these 
applications, refer to “Maximizer CRM Modules and Components” 
on page 5.

Application Installation Instructions

MaxExchange 
Synchronization Server

Refer to the MaxExchange Administrator’s 
Guide.

MaxExchange Remote 
Synchronization Server

Refer to “Installing Maximizer CRM Server” 
on page 38. During the Maximizer CRM 
Server installation, select Custom, and 
select the MaxExchange Remote option.

MaxExchange Remote 
Workstation

Refer to “Installing Maximizer CRM 
Workstation” on page 51.

Workflow Automation 
Powered by 
KnowledgeSync

On the Maximizer CRM Server Setup disc, 
select Install Workflow Automation 
Powered by KnowledgeSync and follow the 
on-screen instructions.

MaxAlarm MaxAlarm is available in the Custom 
Installation options of the Maximizer CRM 
Setup disc.

MaxMobile Refer to the MaxMobile Getting Started 
Guide.

Accounting Link Refer to the Accounting Link User’s Guide.

MaxSync for Microsoft 
Exchange

Refer to “Installing MaxSync for Microsoft 
Exchange” on page 171.

MaxMobile Wireless 
Server

Refer to the MaxMobile Getting Started 
Guide. 
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Installing Microsoft Office Integration for Maximizer Web Access

You can install Microsoft Word and Microsoft Outlook Integration 
for Maximizer Web Access on server and workstation computers. 
Each integration installs a Maximizer Web Access toolbar menu in 
Word or Outlook. These integrations are different from the 
Microsoft Office integrations that are available while installing 
Maximizer.

You can also install Word and Outlook integration directly in 
Maximizer Web Access. The procedure involves downloading ActiveX 
controls, which may be disallowed on some networks. For more 
information, see the Maximizer CRM User’s Guide.

➤ To install Word or Outlook integration for 
Maximizer Web Access

� Insert the Maximizer CRM Server or Maximizer CRM Workstation 
disc.

The setup starts automatically.

� Select Browse this Disc.

� Open the Office_Integration folder.

� Double-click one of the following files:

• MSWordInt.msi to install Word integration.

• OutlookInt.msi to install Outlook integration

The InstallShield Wizard starts.

� Follow the steps outlined in the wizard to install the files.



Maximizer CRM 11
Administrator’s Guide

60
Adding and Removing Maximizer CRM Components
Maximizer enables you to add and remove specific components of 
the software without having to reinstall Maximizer itself.

➤ To add or remove Maximizer CRM components

� Close all programs running on the computer

� Insert the Maximizer disc.

� On the Setup disc Autorun screen, select Install Maximizer 
CRM Server or Install Maximizer CRM Workstation.

If the setup doesn’t start automatically, you can start it manually 
by running setup.exe from the MaxEnt folder of the disc (e.g., 
\MaxEnt\setup.exe).

� Select Modify, and click Next.

Checkboxes are automatically selected for any currently installed 
components.

Expand the branches to add or 
remove sub-components.

� Select the checkbox beside any components to add.

� Clear the checkbox beside any components to remove.

If a component is already installed, and you want to keep it, do 
not clear the checkbox beside that component.

� Click Next.

Maximizer begins the update.
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Installing Licenses
When you purchase licenses from Maximizer Software, you receive a 
Product License Number (PLN), which includes licenses for a specified 
number of users.

Maximizer licenses are stackable. For example, if you have 14 licenses 
and want to upgrade to 32, you just need a new PLN for 18 users, and 
you can apply it in addition to the original 14-user PLN.

You must install MaxExchange 
licenses before creating 
distribution sites in 
MaxExchange Site Manager.

In a MaxExchange environment, Maximizer and Maximizer Web 
Access licenses are synchronized between sites. (Other types of 
licenses are not synchronized and must be installed locally at each 
site.) The total number of synchronized Maximizer and Maximizer 
Web Access licenses applies to enabled and logged-in users at any 
site. 

Note that the Maximizer system login accounts (EMAILUSER and 
WEBUSER) are always enabled and do not consume any Maximizer 
licenses. Also, the MASTER user account is always enabled, and it 
consumes a license only if you are logged into Maximizer using the 
MASTER user account.

The following sections contain information on installing Maximizer 
licenses:

• “Installing a License” on page 61

• “Applying a License” on page 62

• “Viewing Applied and In-use Licenses” on page 62

Installing a License

After you install Maximizer or purchase additional licenses, you must 
install the PLN(s). You can install PLNs from any machine on the 
network, using Administrator. However, MaxExchange PLNs must be 
installed from an installed MaxExchange Synchronization Server 
using Administrator. The following procedure applies to all 
Maximizer CRM products.

➤ To install a product license number (PLN)

� Run Administrator.

� Select Utilities > Install Multi-User License.

� Enter the PLN.

� Click Install License. 

� Repeat steps 3 and 4 to install any additional licenses.
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� Click Close.

Administrator closes automatically.

The next step is to apply the PLN(s) to the Address Books.

Applying a License

After you have installed a PLN, you must apply it to the Maximizer 
Address Book(s).

➤ To apply a product license number (PLN)

� After installing the license as described above, start 
Administrator.

� Open and close each Address Book that you are applying licenses 
to.

The license has now been applied to the Address Book(s).

Viewing Applied and In-use Licenses

➤ To view the number of applied and in-use licenses

• In Administrator, select Reports > Current Users.
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Where to Go from Here...
• Create a new Address Book or upgrade an existing Address Book 

to the latest version of Maximizer, as described in chapter 4 
“Creating or Upgrading an Address Book” on page 65.

• Create login accounts for Maximizer users and assign users to 
security groups and sales and marketing teams, as described in 
chapter 5 “Setting Up Users, Groups, and Teams” on page 77.

• Configure Address Book preferences, including duplicate 
Address Book entry handling, user-defined fields, key fields, 
customer service and opportunity email notification templates, 
and event notification, as described in chapter 6 “Configuring an 
Address Book” on page 109.

• Configure the Address Book for access through Maximizer Web 
Access

Maximizer Web Access permit users to access the Maximizer 
Address Book data from any Internet-connected computer using 
a browser such as Internet Explorer. You can enable Maximizer 
Web Access by making certain modifications to the Address 
Book. See “Configuring Web Access” on page 193.

• If you are using MaxExchange, configure the central Address 
Book for synchronization.

You can synchronize a Maximizer Address Book between a 
central location and one or more remote computers using 
MaxExchange. Using MaxExchange, a mobile sales force or a 
remote office can keep a local copy of the Maximizer Address 
Book current with the Maximizer Address Book in a central 
office. Updates are made via FTP, a direct network connection, 
or email. 

For information on installing, configuring, and using 
MaxExchange Synchronization Server, refer to the MaxExchange 
Administrator’s Guide. 

To install MaxExchange Remote on a Maximizer Workstation, 
refer to “Installing Maximizer CRM Workstation” on page 51.

To install MaxExchange Remote on a Maximizer Server, refer to 
“Installing Maximizer CRM Server” on page 38. During the 
Maximizer Server installation process, select Custom installation, 
and select the MaxExchange Remote as an installation option.

• For more information on converting a database, please refer to 
chapter 12 “Managing Address Book Data” on page 305.
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In this chapter...

“What is Administrator?” on page 66

“Creating Address Books” on page 67

“Connecting to an Address Book” on page 71

“Maximizer System Login Accounts” on page 72

“Changing the MASTER User Password” on page 73

“Upgrading or Converting an Address Book” on page 74

“Time Zone Alignment” on page 75

“Importing Vertical Templates” on page 76
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What is Administrator?
Administrator is the administrative center of Maximizer. Use it to 
complete the following tasks:

• Manage users, sales/marketing teams, and security groups.

• Create and configure Address Books.

• Manage Maximizer application settings.

• Set up synchronization with remote sites (applies to 
MaxExchange installations only).

Once Administrator is running, you can open any Address Book and 
perform administrative tasks. There will be no database conflicts if 
you open an Address Book while it is in use by another user. 
(However, you should ensure all users have logged out before 
backing up or restoring the Address Book.) Also, changes to the 
user’s settings require the corresponding logged-in user to log into 
the Address Book again before the settings will take effect.

➤ To start Administrator

• Click Start > Programs > Maximizer CRM > Administrator.

➤ To open an Address Book in Administrator

� Start Administrator.

� Select an Address Book, and click Open.

�

�
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The default MASTER user 
password is “control”, unless 
it has already been changed to 
another password in any 
Maximizer Address Book on 
the server.

� Type the Password, and click OK. 

 

The selected Address Book opens in Administrator.

Creating Address Books
Sample Address Books are 

installed with Maximizer and 
demonstrate how a company 
would use Maximizer. Do not 
use the sample Address Book 
for your own data.

Once you have familiarized yourself with Maximizer by using a 
sample Address Book, such as Escona Tutorial, your first 
administrative task is to set up a new Address Book for your company 
or organization.

Administrator makes it easy to create your Address Book in a few 
steps, and even enables you to create it using some of the settings 
from an existing Address Book, such as preferences, templates, user-
defined fields, and macros.

For information about 
transferring Address Book 
information, refer to 
“Importing Address Book Data 
from MXI or XML Files” on 
page 326 and “Transferring 
Entries between Address 
Books” on page 349.

Once you’ve created the Address Book, set up user accounts and 
configure security and preferences. If you need to add entries from 
another Address Book, Maximizer can transfer those entries to the 
new Address Book. Any user can transfer Address Book information, 
provided that they have sufficient security privileges in their account.

When using MaxExchange Remote with a newly created Address 
Book, open the Address Book in Maximizer before attempting 
synchronization. Refer to the MaxExchange Administrator’s Guide 
for more information.

The following sections contain information on creating Address 
Books in Maximizer:

• “Checklist: Setting up a New Address Book” on page 68

• “Global and Local Address Book Lists” on page 69

• “Creating an Address Book” on page 70
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Checklist: Setting up a New Address Book

These steps highlight the 
major tasks involved in 
creating a new Address Book.

Use this list to help you set up a new Maximizer Address Book. 
Perform these steps in the order shown here. 

� Create the new Address Book. Refer to “Creating an Address 
Book” on page 70.

� Change the MASTER user password. Refer to “Changing the 
MASTER User Password” on page 73.

� Enable security for an Address Book. This applies only if 
there are multiple users in your Address Book. To enable 
security, select the Enable security option on the System 
Options tab in Administrator preferences. Refer to “Address 
Book Preferences” on page 110.

� Add users to the Address Book. When you create a new 
Address Book, it contains only the MASTER, EMAILUSER and 
WEBUSER user accounts. Create an account for each Maximizer 
user. Refer to “Adding a User to an Address Book” on page 78.

� Set up security for users and security groups. You may 
want some users to have more access to your Address Book data 
than other users. Administrator lets you restrict access to specific 
users and groups of users. Refer to “User and Group Security” on 
page 84.

� Test the Address Book. In Maximizer, log into the new Address 
Book with one or more of the new user accounts.
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Global and Local Address Book Lists

When users open Address Books from Maximizer workstations, they 
have the option of choosing between a Local or Global Address Book 
list.

• Local: The Address Books in the Local Address Book list reside on 
the local workstation.

• Global: The Address Books in the Global Address Book list reside 
on the server. Use this list to access shared Address Books. When 
creating a global Address Book, it is recommended that you 
create the new Address Book on the Maximizer Server. If you 
create a new global Address Book from the workstation, you 
must have administrative rights to the server.

You cannot create automated campaigns in a local Address Book. 
Therefore, campaign users must create their Address Books in the 
Global List, so automated campaigns can be created on the 
Maximizer Server. You must also use the Global setting to access 
shared Address Books.

➤ To change the Address Book list on a workstation

� In the top-left corner of the window, click the Maximizer 
button, and select Open Address Book.

� Choose Local or Global. This setting affects the listed Address 
Books.
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Creating an Address Book

Use Administrator or Maximizer to create new Address Books. 

The location of this folder may 
be different if you specified a 
different folder during the 
Maximizer installation. 

Maximizer Address Book files are stored in the 
...\Documents and Settings\All Users\Application Data\Maximizer\
AddrBks folder on the server. If other users should be able to access 
these files, you must grant those users access permissions to the 
folder.

After the new Address Book is created and added to the list of 
Address Books in Maximizer, each workstation receives the updated 
Address Book list when logging in.

➤ To create a new Address Book

� Select File > New Address Book.

� Type the name of the new Address Book in the Address Book 
name field, and click OK.

� Click OK.

Maximizer prompts you to copy defaults from an existing 
Address Book to the new Address Book. 

� Click Yes to copy the default settings, or click No to create a 
blank Address Book.

Maximizer creates the new Address Book.
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Connecting to an Address Book
Maximizer allows you to connect to any Address Book on a computer 
running SQL Server Express. The computer can be a Maximizer 
workstation or a server. 

➤ To connect to an Address Book

� From Administrator or Maximizer, select File > Connect to 
Address Book. 

� In the Connect to Address Book dialog box, select the 
computer that hosts the Address Book to which you would like 
to connect.

� Choose an Address Book from the Available Address Books 
list and click Open.

� Choose Local or Global in the Create new Address Book in 
field.

� When you are connected to the Address Book, you are prompted 
with a message saying the connection was successful. Click OK to 
close the message dialog box.

Once the connection to an Address Book is established, it 
appears in the Open Address Book window. You can use the 
Remove button in the Open Address Book dialog to remove it 
from the available Address Book list. 
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Maximizer System Login Accounts
When you create a new Maximizer Address Book, the following login 
accounts are created automatically:

• MASTER is required to log into the Administrator module of 
Maximizer.

• EMAILUSER gives Maximizer access to Address Book data when 
it performs automated email activities such as automated 
campaigns. It is also used by MaxSync for Microsoft Exchange.

• WEBUSER is required for Customer Access and Partner Access. 

• COMPANY is used for the company calendar, which displays 
company events in the Maximizer calendar. Company calendar 
events are created under the COMPANY user account. This user 
account provides read-only access of its calendar to all users.

• maximizer_default is a system login created in the Maximizer 
instance of Microsoft SQL. It is only used by Maximizer and 
MaxExchange and cannot be used to login to Maximizer or 
Microsoft SQL. If this user is missing see “Recreating the 
Maximizer_Default User” on page 360.

It is important to leave these user accounts enabled and with their 
default settings. Maximizer requires these accounts to function 
correctly. Note that the Maximizer system login accounts 
(EMAILUSER and WEBUSER) do not consume any Maximizer licenses. 
Also, the MASTER user account consumes a license only if you are 
logged into Maximizer with the MASTER user account.

It is important to change the password for each of these system login 
accounts from their defaults immediately after creating an Address 
Book. For instructions on changing the account passwords, refer to 
“Changing the MASTER User Password” on page 73.
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Changing the MASTER User Password
If the MASTER password for an 

existing Address Book has 
been changed, and then you 
create a new Address Book, 
the new Address Book will 
have the same password as 
the existing Address Book, and 
not “control”.

The default password for the MASTER user is control. For security 
reasons, you should change this password immediately after creating 
a new Address Book. Maximizer also creates the WEBUSER and 
EMAILUSER system user accounts, and it’s important to change the 
passwords for these accounts as well.

➤ To change the MASTER user password

� Run Administrator and log in to the Address Book as MASTER.

� Select File > Manage Users.

� Select MASTER from the user list and click Password.

� In the Old password field, type control (or the current 
password if you have changed the MASTER password before).

� In the New password and Confirm password fields, type the 
new MASTER user password, and click OK. 

The MASTER user password has now been changed.

� Repeat this procedure to change the passwords for the 
WEBUSER and EMAILUSER accounts as well.

�

�

�
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Upgrading or Converting an Address Book
You can upgrade an Address Book by opening it in Administrator or 
Maximizer. Administrator also has a built-in utility to convert existing 
Maximizer databases from older versions to the current version, and 
to convert Maximizer Pervasive databases to Maximizer SQL 
databases.

You should always back up the Address Book before upgrading. For 
instructions on backing up, refer to “Backing Up and Restoring 
Address Book Data” on page 306. For older databases, refer to the 
User’s Guide for your previous version of the software. If you have 
customized the dictionary and holidays, also back up those files 
separately before upgrading.

If you are upgrading Maximizer from a previous version and you 
have old reports in the Crystal Reports file structure for Maximizer, 
the old reports are archived in a folder named after the Address 
Book with a .BAK file extension, where your other report files for 
Maximizer are stored (e.g., ...\My Documents\MaximizerReports 
folder). You can copy the reports to any of your working folders, 
such as the Sales folder, to access the reports from Maximizer. 

After upgrading a database, you should always perform an Address 
Book validation and recovery. For further information, refer to 
“Verifying and Recovering Address Book Data” on page 314.

If you are upgrading 
Maximizer Pervasive 
databases, do not uninstall 
Pervasive until you have 
successfully upgraded all of 
the Pervasive databases.

➤ To upgrade a Maximizer Address Book

� Ensure Maximizer is closed on all machines before proceeding 
with the upgrade.

� If you have an Address Book open in Administrator, select File > 
Close Address Book.

� Select Utilities > Upgrade Maximizer Address Book. 

� Select Yes when prompted to continue.

Note that the Browse button is 
used to locate Maximizer files 
that are in a Pervasive (Btrieve) 
database format. It is not 
applicable to a SQL Server 
Address Book.

� If the Address Book does not appear in the list, click the Browse 
button to browse to the location of your Pervasive (Btrieve) 
Address Book files and click OK. Then, enter an Address Book 
name and click OK.

� Select the Address Book from the available Address Book list, 
and click Open.

Log in with the MASTER password or as a user with a Maximizer 
Administrator role.The upgrade process begins.
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Time Zone Alignment
After upgrading your database, use the Time Zone Alignment utility 
to align users’ appointment, Hotlist task, and opportunity activity 
times with the time zone in which these records were created. This 
step is necessary only for users that have created appointments, 
Hotlist tasks, or opportunity activities from a time zone that is 
different than the Maximizer CRM Server.

Users can only be aligned 
once.

➤ To align time zones

� Select Utilities > Time Zone Alignment.

� Select all users that belong to a specific time zone.

� Select the time zone the users are in from the Time Zone drop- 
down list.

� Select the Adjust for daylight saving time option if the 
selected users are in a time zone or region that observes daylight 
saving time.

� Click Align.

� Repeat steps 2 to 5, as necessary, for all applicable users and time 
zones.



Maximizer CRM 11
Administrator’s Guide

76
Importing Vertical Templates
Maximizer provides vertical templates for several industries. You can 
import any of these vertical templates into your Address Book. A 
vertical template creates industry-specific user-defined fields, action 
plans, search catalogs, column setups, document templates, etc. in 
your Maximizer Address Book.

➤ To import a vertical template

� Log into the Address Book in Administrator or Maximizer.

You must be logged in as MASTER to import a vertical template.

� Select File > Import > Vertical Templates > [industry]. 

The Import [industry] Vertical Template dialog box opens, 
displaying the items included in the template.

� Click Import. 

Items in the list are highlighted as the import process advances.

When the import process is complete, an Import Summary 
displays the number of items imported with the vertical 
template.
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Adding a User to an Address Book
As the Address Book administrator, you already have a user ID 
(MASTER) set up for you. Log in as the MASTER user in Administrator 
to perform setup or administrative tasks. The default password for 
MASTER is “control”, but it may be different if it has already been 
changed in any Address Book on the server. To use Maximizer, you 
should create a personal user ID for yourself.

Before a user can log into Maximizer, you must assign that person a 
Maximizer user ID. All security in Maximizer is based on user IDs and 
the rights you assign to them. You should also assign a user Display 
Name, which easily identifies the user throughout Maximizer. When 
you fill in the First name and Last name fields in the Add User dialog 
box, the Display name field is completed automatically to include the 
user’s first and last name together. You can change this display 
name.

The user’s name and contact 
information can be inserted as 
merge fields in the word 
processor. 

Use the User Properties dialog box to enter a user’s name and contact 
information, assign user-defined fields, specify access rights, and add 
a user to security groups and sales/marketing teams. Note that you 
can also add users to security groups and sales/marketing teams using 
the Groups/Teams tab. 

➤ To add a new user to the Address Book

� Select File > Manage Users.

The Manage Users dialog box opens.

� Click Add.

The Copy Selected User’s Settings dialog box opens.

�
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� Click Yes to copy the settings from the selected user, or No to 
start with the default settings.

The Add User dialog box opens.

� Fill in the information for this user in the General tab.

The User ID and Last name fields are the only required fields, and 
the User ID is needed to log into the Address Book.

Save time by filling in only the User ID, First name, and Last 
name fields, and let the user fill out the rest of the information. 

The Display name field fills in automatically with the user's first 
and last names. You can change the display name.

� In the User-Defined Fields tab, select the values of any user-
defined fields, as appropriate.

You can set up these custom fields in the File > Set Up User-
Defined Fields dialog box. Refer to “Setting Up User-Defined 
Fields for an Address Book” on page 118 for more information.

�
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� Click the Access Rights tab.

� Click the Modify User Access Settings button.

	 Modify any of these settings as appropriate.

For an explanation of the relationship between user access 
rights, user access settings, and group access settings, refer to 
“User and Group Security” on page 84.

For an explanation of each of the access settings, refer to “User 
Access Rights and User/Group Access Settings” on page 85.


 Click OK to close the Access Settings dialog box.

��In the Groups/Teams tab, select any security groups and sales/
marketing teams to which the user should belong.

(To add groups and teams, use the File > Security Groups and 
Teams dialog box.)

��Click OK.

The default user password is maximizer. Ensure that you or the 
user create a new password from the Manage Users dialog box. 

The new User ID and its associated information now appear in 
the User list.

�

�
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User Administration
In Maximizer and Administrator, you can manage all settings for a 
user from a central location. In Administrator, select File > Manage 
Users, select a user, and click Administer User to open the Administer 
User dialog box. You can change properties, preferences, and other 
default settings for the user. Click the links in the navigation pane on 
the left to display information in the main content pane on the right. 
In the content pane, you can access links to a number of user settings. 

Navigation pane 
option Allows you to...

User Properties View and edit general information, user-
defined fields, access rights, groups/teams, or 
windows authentication for the selected user in 
the Properties dialog box.
For more information, see “User and Group 
Security” on page 84.

User Preferences View and edit preferences for the current user 
in the Preferences dialog box.
For more information, see the Maximizer CRM 
User’s Guide.

Password Change the password for the selected user in 
the Password dialog box.
For more information, see “Changing a User’s 
Password” on page 83.

Default Entries Modify the Address Book, opportunity, and 
customer service default entries for the selected 
user.
For more information on default entries, see the 
Maximizer CRM User’s Guide.

Default Notes Change the Address Book, opportunity, 
customer service, and campaign default note 
for the selected user.
For more information on default notes, see the 
Maximizer CRM User’s Guide.

Security Groups and 
Teams

Configure security groups and sales and 
marketing teams in the Security Groups and 
Teams dialog box.
For more information see “Security Groups” on 
page 92 and “Sales and Marketing Teams” on 
page 99.
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MaxMobile 
Administration

Configure the MaxMobile Wireless Server and 
users for deployment in the MaxMobile 
Administration dialog box.
For more information, see “Configuring 
MaxMobile Wireless Server” on page 181.

MaxExchange Site 
Manager

Configure MaxExchange distribution sites in 
MaxExchange Site Manager.
For more information on MaxExchange Site 
Manager, see the MaxExchange Administrator’s 
Guide.

MaxSync for 
Microsoft Exchange

Configure synchronization between Maximizer 
and Microsoft Exchange in the MS Exchange 
Synchronization tab of the Preferences dialog 
box.
Fore more information, see “Setting Up 
MaxSync for Microsoft Exchange” on page 166.

Navigation pane 
option Allows you to...
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Changing a User’s Password
The following procedure explains how to change user passwords in 
Administrator. However, users can also change their own passwords 
in Maximizer by selecting Manage Users from the User Management 
group on the Setup tab.

➤ To set and change a user’s password in 
Administrator

� In Administrator, select File > Manage Users. 

The Manage Users dialog box opens.

� Select the Maximizer user, and click Password.

The default password for a 
new user is “maximizer”.

The Password dialog box opens.

� Type the new password, then retype it on the next line to 
confirm it.

� Click OK to accept the change of password and close the dialog 
box.

�

�
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User and Group Security
As the Administrator, you can restrict each user’s access rights to 
types of entries, essentially providing per-module security. User 
access rights are accessible by going to the Access Rights tab of a 
user’s properties (see ‘Modifying User Access Settings” on page 90). 
These user access rights consist of the access settings (security 
settings) of the user account as well as the access settings of any 
security groups the user is a member of. For example, if the 
Opportunity Delete permission is not granted in the user’s access 
settings, but is granted in the access settings of a group the user is a 
member of, then the user is granted Delete permissions to 
Opportunity entries.

Each checkbox contains one of the following potential values:

The following table illustrates user access rights derived from user 
and group access settings. 

If the user belongs to more than one group, the conflict illustrated 
below results in the user not being granted the access right.

Checkbox State Access Setting Access Right

 Granted Granted

 Not Granted Not Granted

 Black = Denied
Grey = Disabled

n/a

User Access Setting + Group Access Setting = User Access Right

  
  
  
  
  
  
  
  
  

User or Group 
Access Setting

+ User or Group 
Access Setting

+ User or Group 
Access Setting

= User 
Access Right

   
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User Access Rights and User/Group Access Settings

If a Read permission is denied 
(X), then the Insert, Modify, 
and Delete permissions are 
automatically disabled. A user 
cannot have Insert, Modify, or 
Delete permissions without 
having Read permission.

The following tables describe each of the user access rights and user 
or group access settings. 

Permissions

Permissions
Controls the selected user's or group's right to 
view, add, change, or remove . . .

Address Book Entries in the Address Book window

User-defined fields Values in user-defined fields

User-defined field 
setup

User-defined field definitions

Notes Entries in the Notes following window
Users must have the Delete checkbox selected to 
be able to use the File > Purge > Notes function.

Documents Entries in the Documents following window
Users must have the Delete checkbox selected to 
be able to use the File > Purge > Documents 
function.

Mailing Address Mailing addresses of Address Book entries

Company Library Files and folders in the Company Library

OrderDesk Entries in the OrderDesk window

Opportunities Entries in the Opportunities window

Strategy Library Strategy Library information for opportunities

Campaigns Entries in the Campaigns window

Customer Service Entries in the Customer Service window

Knowledge base Articles in the Knowledge Base window

User/Group setup Users and Security Groups
• If the user does not have any User/Group 

Setup rights, other users' or groups' 
properties are not accessible. 

• If the user has read rights only, the related 
tabs are visible, but information cannot be 
modified.

• Insert, Modify, and Delete rights provide the 
corresponding access rights to all user and 
group properties.
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Privileges

Accounting Accounting Link transactions
Note that the Delete permission is disabled  
because Accounting Link transactions cannot be 
deleted through Maximizer.

Action Plan Library Action plans in the Action Plan Library

Dashboards Dashboard entries

Privilege Grants authorization to . . .

Allow Global Edit Perform global edits of Address Book entries in 
Maximizer (on the Edit tab, select Global Edit 
from the Replace group). Consider advising 
users with this privilege to back up the Address 
Book before making significant changes with 
Global Edit.

Allow private entries Add entries that are not visible to other users. 
The user can use the Owner, Full Access, or Read 
Access fields to create private entries or restrict 
entries to a group or a user.

Allow public entries Add entries that are visible to all other users in 
the Address Book.
Note that the Allow private entries and Allow 
public entries options cannot be denied
at the same time. If both of these options are 
denied in two different groups a user
belongs to (i.e., the checkboxes contain an x), 
the user is granted the Allow private
entries right by default.

Allow transfer Transfer Address Book entries between 
Maximizer Address Books. If you do not select 
this option, the menu items for transferring are 
disabled. 

Allow import Import Address Book entries between 
Maximizer Address Books. If you do not select 
this option, the menu items for importing are 
disabled. 

Allow export Export Address Book entries between 
Maximizer Address Books. If you do not select 
this option, the menu items for exporting are 
disabled.This option also applies to the security 
right to export information to Excel.

Permissions
Controls the selected user's or group's right to 
view, add, change, or remove . . .
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Allow sync contacts 
with external clients

Synchronize Address Book entries and notes 
using Outlook Synchronization. However, users 
can still synchronize calendar appointments or 
Hotlist tasks without this access right. 

Modify note 
properties

Change the values of the date, time, and creator 
fields in notes.

Modify distribution 
field

Change the value of the MaxExchange 
Distribution field of Address Book entries. 

Modify system 
tables

Add, modify, or delete available values (items) 
of system fields such as City and Category on the 
Basic Information tab. See “System Field 
Privileges” on page 89 for more information.

Modify/delete other 
owners’ notes

Change and delete other users’ notes. However, 
to be able to view other users’ private notes, the 
user must have the “Modify other users’ private 
entries” privilege enabled.

Modify other users’ 
private entries

View and modify entries marked as private that 
belong to other users.
If a user has this privilege enabled, the user has 
full read and modify access to all entries, 
regardless of the entry’s Full Access, Read 
Access, or Owner settings. This security privilege 
is very powerful and should be granted with 
caution.

Modify other users’ 
general information

Change information in the General and User-
Defined Fields tabs of the User Properties dialog 
box for another user.
Modifying a user’s general information, such as 
Last Name, First Name, Company, and Phone 
Number, does not have to be restricted to the 
MASTER user. In many cases, an administrative 
assistant or a receptionist can be granted the 
rights to modify user’s general information 
without compromising the security of 
Maximizer. This privilege allows the user to 
have access to all Maximizer users’ general 
information without giving them full security 
rights to the Address Book.

Allow manage 
currencies

Access the Currency Library in Maximizer (In the 
Setup tab, select Template Library > Currency 
Library from the File Management group) and 
add, edit, or delete entry currencies

Privilege Grants authorization to . . .
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User’s Roles

Allow printing to these destinations

Printing to certain destinations, such as files or email, can pose 
security risks for your organization. For example, a user could print 
important data fields to a file. This file would then contain 
information in a format that could easily be transported elsewhere. 
Consider these security risks in balance with the improved business 
processes that can be achieved by using print destinations other than 
Printer.

User Role Grants authorization to . . .

Administrator Log into Administrator and perform tasks based 
on the user’s security settings.

Customer Service 
Manager

Have customer service cases assigned or 
escalated to him/her. It also allows the user to 
change the value of the Case owner field.
If this role is assigned to a user, it is not 
necessary to assign the Customer Service 
Representative role to the user because 
Customer Service Managers can do everything 
Customer Service Representatives can do.

Customer Service 
Representative

Have customer service cases assigned to him/
her.

Knowledge Base 
Approver

Approve Knowledge Base articles. A newly 
created article is assigned a draft status until it is 
opened and assigned a different status by an 
approver. Press F1 in the Knowledge Base 
window for more information.

Sales Manager Belong to the Account Manager field. Sales 
Managers can re-assign the Account Manager 
field to a different user. 

Sales Representative Similar to the Sales Manager role, Sales 
Representatives can be assigned to the Account 
Manager field. A Sales Representative can 
assign the Account Manager field to anyone 
else, but only if the Account Manager field was 
assigned to him/herself or blank and not 
assigned to another user.

Destination Grants authorization to . . .

Printer Print to the default printer.

File
(Rich Text Format)

Print to a .RTF file.
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System Field Privileges

Items (available values) for the following system fields can be added, 
modified, or deleted for users who are granted the Modify system 
tables privilege.

File (PDF Format) Print to a .PDF file.

Email Attach the report to an email message, usually 
in a .RTF file.

HTML Format Print to a .HTM file.

Preview Display a preview of the print output on the 
screen.

Custom Report Open and print reports from the Crystal Reports 
option in the Reports tab in Maximizer. Note 
that the user cannot create custom reports 
unless he or she is also a member of the Crystal 
Reports Users security group.
For more information about security settings 
related to Crystal Reports, refer to “Set the user-
related preferences on each of the tabs.” on 
page 106.

Destination Grants authorization to . . .

Field Description

Address Book Entry Fields Mr/Mrs, Position, Salutation, Company, Department, 
Division, City, St/Prov, Country, Email Description, Phone 
Description, Do Not Solicit By, Category, Lead Source, 
MaxExchange Distribution, and Related Address Book Entry 
Relationship Type

Phone Fields Subject and Phone Call Result

Hotlist Task and Appointment Fields Activity and Priority

Campaign Fields Traditional Campaign Objective, Traditional Campaign 
Activity, Traditional Campaign Template Activity 
Description, Automated Campaign Products/Services, and 
Automated Campaign Categories

Customer Service Fields Products/Services, Categories, and Subject

Opportunity Fields Products/Services, Categories, Objective, and Next Action
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Modifying User Access Settings

For an explanation of the relationship between user access rights, 
user access settings, and group access settings, refer to “User and 
Group Security” on page 84.

For an explanation of each of the access settings, refer to “User 
Access Rights and User/Group Access Settings” on page 85.

➤ To modify access settings of an existing user

� Select File > Manage Users.

� Select the Maximizer user, and click Properties.

� Select the Access Rights tab.

� Click the Modify User Access Settings button.

�

�
�
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� Modify any of these settings as appropriate.

� Click OK to close the Access Settings dialog box.

� Click Apply to save the changes.

�
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Security Groups 
A security group is a group of users, usually belonging to a functional 
group such as a Finance department, who have access to entries 
related to their group and have specific security access settings. A 
user may be a member of more than one security group.

It is important to note that 
groups have access settings, 
but they do not have access 
rights that users do. 

The properties, access settings, and group members are specified in 
the Group dialog box.

Group Name and ID

Every security group has a name and an ID that identify the group. 
Changing the name has no effect on the group functionality. 
However, you cannot change the group ID. If you ever need to 
recreate these security groups, it is imperative that you use the 
correct security group IDs (the group name is irrelevant).

Group Access Settings

A security group has Access Settings that affect the level of access its 
members have within the Address Book. It is important to note that 
granting an Access Setting to a group does not necessarily mean that 
all members of the group will have that Access Right. The level of 
access each individual user has to the Address Book is controlled by 
the Access Settings of the user account and the Access Settings of any 
groups the user belongs to. For more information about user and 
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group Access Settings, refer to “User and Group Security” on 
page 84.

Group Members

You can add or remove users from the group in the Members tab of 
the Group dialog box. 

You can also add or remove a user from any groups on the Groups/
Teams tab of the User dialog box.

Default Security Groups in all New Address Books

Every new Address Book contains several security groups, described 
in the following table. Only the MASTER user belongs to these 
groups by default, but you can add additional users to each group.

Security Group 
Name Group ID Enables group members to...

Accounting ACCTNG Restrict accounting transaction notes 
to members of this group. If an 
Accounting Link user is not a member 
of the Accounting security group, 
notes for any accounting transactions 
created by that user are Public. 
However, notes for transactions 
created by members of the Accounting 
group are restricted to members of 
that group.

Company 
Announcement 
Authors

A_CAA Access the Company Announcements 
folder in Company Library, where 
group members can add 
announcements that appear in the 
Company Announcements box on the 
My Work Day page in Maximizer and 
Maximizer Web Access.

Crystal Reports 
Users

R_CRU Generate new reports from the Crystal 
Reports option in the Reports tab in 
Maximizer. Note that the user must 
also have the Custom Reports access 
right enabled to be able to generate 
reports. For more information about 
security settings related to Crystal 
Reports, refer to “Access Rights 
Required to View or Generate Crystal 
Reports” on page 107.
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Customer Access 
Admin Users

C_ADM Access the News Manager section of 
the Customer Access Administrator.
In Address Books that have been 
upgraded from a previous version, this 
group may be called “Customer Portal 
Administration Users”.

Customer Access 
Config Users

C_CFG Access the Configuration Manager 
section of Customer Access 
Administrator.
In Address Books that have been 
upgraded from a previous version, this 
group may be called “Customer Portal 
Configuration Users”.

Maximizer Web 
Access Admin 
Users

EMPADM Access the Edit section of the 
Maximizer Web Access, where the user 
can update external links.
In Address Books that have been 
upgraded from a previous version, this 
group may be called “Employee Portal 
Administration Users”.

Partner Access 
Admin Users

P_ADM Access the News Manager section of 
the Partner Access Administrator.
In Address Books that have been 
upgraded from a previous version, this 
group may be called “Partner Portal 
Administration Users”.

Partner Access 
Config Users

P_CFG Access the Configuration Manager 
section of Partner Access 
Administrator.
In Address Books that have been 
upgraded from a previous version, this 
group may be called “Partner Portal 
Configuration Users”.

Security Group 
Name Group ID Enables group members to...
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Creating a New Security Group

For an explanation of the relationship between user access rights, 
user access settings, and group access settings, refer to “User and 
Group Security” on page 84.

For an explanation of each of the access settings, refer to “User 
Access Rights and User/Group Access Settings” on page 85.

➤ To create a new security group and assign members

� Select File > Security Groups and Teams.

The Security Groups and 
Teams command is also 
available in Maximizer if the 
logged-in user has Insert rights 
for User/Group setup. On the 
Setup tab, select Security 
Groups or Teams from the User 
Management group.

� Click Add.

� Enter a Group Name. 

� Enter a unique Group ID (up to 6 characters). The first character 
of the Group ID must be a letter.

� Assign Access Settings to the group. 

�
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Access Settings for the group affect the Access Rights of all users 
who are members of the group.

� Click the Members tab.

To remove a user, select the 
user from the Members list, 
and click Remove.

� From the Available Users list, select a user to add to the 
security group, and click Add. Repeat to add additional users.

�

�

�

�
�

	

�
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	 Click OK to close the Add Group dialog box.

The security group has now been created. 

Modifying Group Access Settings

For an explanation of the relationship between user access rights, 
user access settings, and group access settings, refer to “User and 
Group Security” on page 84.

For an explanation of each of the access settings, refer to “User 
Access Rights and User/Group Access Settings” on page 85.

➤ To modify access settings of an existing group

� Select File > Security Groups and Teams

� Select the group name.

� Click Properties.

� Select the appropriate settings for the group, and click OK.

� Click Apply to save the changes.
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Record Ownership
In Maximizer, many entries have an Owner field, or Full Access and 
Read Access fields. These fields control who can view or edit the 
entry. Users can access their own private records, all publicly owned 
records, and private records owned by their group. For example, the 
user “Alice” of the “Finance” group can view all of her own records, 
all records owned by the “Finance” group, and all Public records. See 
the example below as an example.

Sometimes it’s important to allow users to have private entries 
because some entries aren’t meant to be shared with your entire 
organization. In Maximizer, it’s possible to specify Full Access and 
Read Access to specific users or groups for each entry in the Address 
Book. In addition to Address Book entries, you can specify ownership 
of notes, documents, and other types of entries.

When a user creates a new Address Book entry, he or she can 
designate access for that entry. Full Access or Read Access can be 
granted to a specific user, a group, or it can be Public.

To be able to use the Owner, Full Access, or Read Access fields, the 
user must have the “Allow private entries” access right enabled. 

Field Value Description

Owner Public All users can view and modify the entry, 
regardless of their user or group security 
settings. 

User Only the specified users can view or modify the 
entry.

Group Only members of the specified groups can view 
or modify the entry, regardless of their user or 
group security settings.

Full Access Public All users can modify the entry, regardless of 
their user or group security settings. 
Note that the Read Access field becomes 
disabled if Full Access is set to Public.

User Only the specified user can modify the entry.

Group Only members of the specified group can 
modify the entry, regardless of their user or 
group security settings.

Read Access Public All users can view the entry.

User Only the specified user can view the entry.

Group Only members of the specified group can view 
the entry.
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Sales and Marketing Teams 

To learn about using teams 
with MaxExchange, refer to 
the MaxExchange 
Administrator’s Guide. Teams 
may also be set up using 
MaxExchange Site Manager, 
which is accessible through the 
Utilities menu in Administrator 
if MaxExchange is installed. 

If your company or organization is using opportunity or campaign 
management, use the File > Security Groups and Teams dialog box to 
set up sales and marketing teams. Teams are used for sales 
opportunities in Maximizer, and marketing teams are used for 
traditional marketing campaigns.Teams perform two the following 
functions:

• Teams help leaders delegate and manage opportunities and 
traditional campaigns in Maximizer. Team leaders can delegate 
tasks in an opportunity or a traditional campaign to team 
members.

• Teams are used in conjunction with MaxExchange—the program 
you can use to synchronize Address Books between a central 
server and remote sites. You can associate Address Book entries 
with teams to ensure each sales or marketing team always gets 
the Address Book entries they need.

You can set up Teams in both 
Maximizer and Administrator.

A team is composed of a team leader and team members:

• Team Leader: In a team, one person is designated as a team 
leader who has the right to make changes to the opportunity or 
traditional campaign, as well as to the opportunity’s or 
traditional campaign’s team.

• Team Member: A regular team member does not have the right 
to change the traditional campaign/opportunity or the team. 
The member’s role is to perform the tasks the team leader 
assigns.

A team member has either edit, audit, or standard rights, as 
described below. The team leader always has edit rights.

If you have someone in mind 
as a team member with edit 
rights, it saves time to assign 
rights in Administrator rather 
than on a per-campaign or per-
opportunity basis.

• Edit: Allows a member full access to all campaigns and 
opportunities assigned to the team. Members with this type of 
access have full team leader rights and may modify the status of 
an opportunity or campaign and may also reassign tasks.

• Audit: Allows a member to view all campaigns and 
opportunities assigned to him/her.

• Standard: Allows for basic rights to “work” (apply steps) 
opportunities and campaigns. These rights do not allow the 
member to change a status of an opportunity or campaign.

Security, or access rights, cannot be assigned to sales or marketing 
teams. Therefore, to control the security of more than one user, you 
must set up a security group using the File > Security Groups and 
Teams menu. 



Maximizer CRM 11
Administrator’s Guide

100
If you are using MaxExchange, 
you may also set up teams 
using MaxExchange Site 
Manager. (In Administrator, 
select Utilities > MaxExchange 
Site Manager.)

➤ To create a new sales or marketing team

� Select File > Security Groups and Teams.

� Select the Teams tab, and click Add.

� On the General tab, enter a team name.

� Select Sales or Marketing from the Type drop-down list.

� Click the Members tab.

� From the Available Users list, select a user to add to the team, 
and click Add. Repeat to add additional users to the team.

To remove a user, select the user from the Members list, and click 
Remove.

�

�

�



Chapter 5
Setting Up Users, Groups, and Teams

101
� In the Members list, select a member to assign as the Leader, 
and select Leader from the Status drop-down list.

There can be only one leader and the status cannot be changed 
once the team is created.

	 For each member other than the Leader, select the appropriate 
member right from the Rights drop-down list.


 Click OK to close the Add Team dialog box.

�

�

�
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Setting Windows Authentication for Users
Setting up Maximizer users with Windows authentication enables 
them to access Maximizer Address Books without specifying a user 
name and password. This provides a “single sign-on” configuration 
for Maximizer users—they won’t need to log into the network with 
one user name and password and log into Maximizer with another.

If Windows Authentication is specified as the means of user 
authentication during the installation, and users are not mapped in 
the Windows Authentication tab, Maximizer will prompt users for 
their Maximizer user name and password.

➤ To enable Maximizer users to log in to Maximizer 
using Windows Authentication

� Select File > Manage Users.

� Select the Maximizer user, and click Properties.

The Properties dialog box opens.

Each user entered in this 
dialog box must be added as a 
Windows user for SQL on the 
SQL Server. These users must 
also be given database access 
with the database role set to 
CRMGroup. 

� Select the Windows Authentication tab.

� Click Add.

� Enter the qualified name of the user that corresponds to the 
Maximizer user (e.g., DOMAIN-NAME\user_name).

� Select the Enabled checkbox, and click OK.

You can assign multiple network users to a Maximizer user.

�
�

�
�
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➤ To create Maximizer user groups in Windows

This procedure is written for 
network and database 
administrators. For more 
information, refer to the 
Windows operating system 
documentation.

� On the domain server, create a new user group called Maximizer 
Global.

� Add the user accounts of all Maximizer users to the Maximizer 
Global group.

� On the SQL Server computer, create a new user group called 
Maximizer Local.

� Add the Maximizer Global group as a member of the Maximizer 
Local group.

➤ To grant database access to the users

� In SQL Server Management Studio navigate to the Logins 
branch.

� Right-click and select New Login from the shortcut menu.
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� Create a new SQL login account and assign the Maximizer 
Local as the name.

� In the User Mapping page, select the databases that Maximizer 
Local should be able to access. 

� For each database, select the public and CRMGroup database 
roles.
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� For the MaConfig database, select the db_datareader and 
db_datawriter database roles.
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User Preferences
The Address Book administrator is responsible for setting up initial 
user preferences in Administrator. However, users can change many 
of their user preferences in Maximizer.

➤ To set Address Book user preferences

� Select File > Manage Users. 

� Select the Maximizer user, and click Preferences.

See the Maximizer CRM User’s 
Guide for more information on 
user-related preferences 
Preferences.

� Set the user-related preferences on each of the tabs.
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Access Rights Required to View or Generate Crystal Reports 
The following table explains how the Crystal Reports Users security 
group and the Custom Report access right control whether a user can 
view or generate reports in Maximizer (On the Reports tab, select 
Crystal Reports).

While the Crystal Reports Users security group and the Custom 
Report access right control whether a user can view and generate 
reports, the user permissions control the type of information the user 
can access in those reports. If a user does not have rights to view 
information for a Maximizer window/module, and the user creates a 
report related to the window/module, the related information does 
not appear in the report. For example, if the user has Read 
permissions to Address Book entries, but not to Opportunities, any 
reports the user views or creates may contain Address Book 
information but will not contain Opportunity information.

To enable the user to include the data in the report, ensure that the 
user has at least Read permission to the window/module. In 
Administrator, individual user permissions are available through the 
File > Manage User dialog box. See “User Access Rights and User/
Group Access Settings” on page 85.

To grant the permission to all members of a group, go to 
File > Security Groups and Teams > [Group] > Properties.

Is the user a member 
of the Crystal 
Reports Users 
security group?

Does the user 
have the 
Custom Report 
access right?

How much access does the 
user have to the Reports > 
Crystal Reports menu in 
Maximizer?

No No The user can see the menu 
but cannot view or generate 
reports.Yes No

No Yes The user can open existing 
reports but cannot generate 
new reports.

Yes Yes The user can open and 
generate reports.



Maximizer CRM 11
Administrator’s Guide

108



C H A P T E R
66Configuring an
Address Book

In this chapter...

“Address Book Preferences” on page 110

“Preventing Duplicate Address Book Entries” on page 114

“Setting Up User-Defined Fields for an Address Book” on page 118

“Creating Key Fields Lists” on page 140

“Creating Email Notification Templates” on page 144

“Enabling Event Notification” on page 152

“Recording Holidays in the Holiday Editor” on page 155

“MaxExchange Distribution” on page 156
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Address Book Preferences
You can set Address Book preferences by selecting File > Preferences 
in Administrator. The following table outlines the settings available 
on each tab of the Preferences dialog box. For more information 
about any of these preferences, go to File > Preferences, select a tab, 
and press F1.

On this tab... You can set the following preferences...

Address Book • Values available in the Category field for 
Address Book entries.

• Fields to check for duplication of Address 
Book entries (refer to “Preventing Duplicate 
Address Book Entries” on page 114 for more 
information).

Automated Services • Automated email preferences and 
initialization.

If you are using automated campaigns, ensure you have 
the “Activate services for the currently open Address 
Book” checkbox selected in the Automated Services tab.

Campaign • Campaign completion reasons.

The MASTER user is responsible for devising and 
implementing completion reasons in Administrator.

Customer Service • Customizable field values.

• Default case response time.
• Case monitoring and notification.
• Email templates for customer notification 

(refer to “Creating Email Notification 
Templates” on page 144 for more 
information).

• Default case status.
• Settings to disallow direct changes to case 

fields.

Dashboard • Configure dashboards from the server.
• Add or modify SQL metrics for dashboard 

indicators (refer to “Customizing 
Dashboards” on page 297 for more 
information).

Diagnostic • Log file settings for Maximizer modules. 
Note that users can also set Diagnostic 
preferences in Maximizer. Refer to 
“Maximizer Email Service Log Files” on 
page 372 for more information.
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Key Fields • Key user-defined fields available on the 
Basic Information tab of Address Book 
entries, opportunities, campaigns, and 
customer service cases (refer to “Creating 
Key Fields Lists” on page 140 for more 
information).

Location/Resource • Locations available for appointments.

• Resources available for appointments.

Mandatory Fields • Mandatory or optional data entry 
requirements for basic fields in Address 
Book entries, customer service cases, 
campaigns, and opportunities.

MS Exchange 
Synchronization

• MaxSync for Microsoft Exchange (refer to 
“Setting Up MaxSync for Microsoft 
Exchange” on page 166 for more 
information)

Available only if MaxSync for Microsoft Exchange is 
installed.

Opportunity • Opportunity stages and probabilities of 
close.

• Opportunity confidence rating schemes.
• Opportunity completion reasons.
• Opportunity monitoring and notifications.
The MASTER user is responsible for devising and 

implementing ratings schemes and completion reasons in 
Administrator.

System Fields • Add, modify, and delete values of system 
fields, such as note/document categories 
and products/services.

On this tab... You can set the following preferences...



Maximizer CRM 11
Administrator’s Guide

112
System Options • Global server.

• Address Book name and ID.
• System-assigned Address Book entry IDs, 

campaign IDs, and opportunity IDs.
• Overview page caption.

• Default settings for Maximum entries field 
in Maximizer search dialog boxes.

• TAPI phone number format.
• Partner notification of assigned Address 

Book entries or opportunities.

• User/group setting which determines if lists 
of users/groups display only groups to which 
the current user belongs and other users in 
the groups in fields such as Read Access and 
Full Access.

• Event notification (refer to “Enabling Event 
Notification” on page 152 for more 
information).

• Live Update options.

• Multi-currency.
• SQL Reporting Services.
• Start of the fiscal year.

• Create the MaxExchange Distribution field 
(refer to “MaxExchange Distribution” on 
page 156 for more information).

• MaxExchange transaction journaling.
• Opportunity and campaign synchronization.

On this tab... You can set the following preferences...
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➤ To set Address Book preferences

� Select File > Preferences.

� Set the Address Book preferences on each of the tabs.

Using Passwords

If you apply a user password for an Address Book, all Address Books 
on the server hosting the Address Book will use the same password. It 
is not possible to have different passwords for different Address 
Books for the same user on the same server computer. 

Note that is possible to have your local Address Books and global 
Address Books configured for different servers, so in this situation 
the password for local Address Books and global Address Books can 
be different. For more information on local/global Address Books, 
see “Global and Local Address Book Lists” on page 69
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Preventing Duplicate Address Book Entries
When more than one Address Book entry exists for the same person 
or organization, the entries are considered duplicates. These 
duplicates may occur when users create a new Address Book entry 
without determining whether an entry already exists for the person 
or organization. They can also occur when entries are created 
automatically by operations such as importing. Duplicate entries are 
undesirable because information related to the person or 
organization becomes fragmented. You can prevent most duplicate 
entries by using Maximizer’s duplicate Address Book entry checking 
options.

For information about 
preventing duplicates when 
importing data, refer to the 
sections about importing in 
chapter 12 “Managing 
Address Book Data” on page 
305.

You can configure duplicate checking in Administrator (File > 
Preferences > Address Book tab).

Administrator enables you to prevent most duplicate Address Book 
entries by specifying up to three combinations of fields that must be 
unique to each entry. If a user attempts to create a new Address 
Book entry, and the values of any of those field combinations match 
an existing entry, Maximizer does not allow the duplicate entry to be 
created.

A combination of fields that must be unique to each entry is called a 
“duplicate check list”. You can create up to three duplicate check 
lists, using up to three fields in each list. 

Maximizer considers an entry to be a duplicate if the values of all 
fields from List 1, or all fields from List 2, or all fields from List 3 
match an existing entry.
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The default duplicate check lists, described below, effectively prevent 
most duplicate entries:

The “Full Name/Company 
Name” matching field checks 
the Full Name of Individual or 
Contact entries and checks the 
Company field of Company 
entries. The “Company for 
Individual” matching field 
checks the Company field of 
Individual entries.

When a user creates a new Address Book entry in Maximizer, and 
Maximizer detects it as a potential duplicate Address Book entry, the 
user is presented with the following list of options:

• Merge with selected entry: The newly created or modified 
Address Book entry merges with, and overwrites, the existing 
(selected) entry.

• Edit selected entry: The existing (selected) Address Book entry 
opens, allowing it to be edited by the user. Any information 
entered in the newly created entry that was detected as a 
duplicate must be re-entered.

• Add the new entry: This option adds the new entry. It is 
available only under certain circumstances. If a user or group has 
permission to create duplicate entries (“Duplicates may be 
entered by” field in the Address Book tab), he or she has the 
option to create duplicate entries. This option is also available if 
partial matching is enabled and Maximizer finds a partial match.

Check List Fields

Duplicate Check List 1: 1. Full Name/Company Name

2. All Phone Numbers

3. None

Duplicate Check List 2: 1. Full Name/Company Name

2. Zip/Postal

3. None

Duplicate Check List 3: 1. None

2. None

3. None
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Partial Matching

Partial matching identifies an entry as a possible duplicate even if not 
all fields in any of the duplicate check lists are the same in both the 
new entry and an existing entry. 

With partial matching, the order of the fields (1st, 2nd, 3rd) in the 
duplicate check lists is important, as described in the following 
scenarios:

If the first field only is defined 
in the list (the second and third 
fields are set to None), partial 
matching doesn’t apply 
because matching one field is 
a complete match.

• If the first and second fields only are defined in the list (the third 
field is set to None), an entry is considered a possible duplicate if 
only the first field matches.

• If all three fields are defined in the list, an entry is considered a 
possible duplicate if only the first field matches, or if both the 
first and second field match.

If the first field doesn’t match, an entry is never considered a possible 
match, even if the second and/or third field matches. 

Maximizer displays the list of possible duplicates in order of number 
of fields matched.

By default, partial matching is disabled. To turn partial matching on, 
select the “Allow partial match” checkbox.

If the Address Book has been 
upgraded from a previous 
version of Maximizer, and 
duplicate checking was 
enabled, partial matching is 
enabled after upgrading the 
Address Book to the new 
version.

The “Allow partial match” checkbox applies to all Duplicate Check 
Lists. You cannot allow partial matches for some lists and not for 
others.

Partial matching is relevant only if no exact matches exist. If all the 
fields in any of the duplicate check lists match an existing entry, it is 
considered a duplicate entry, and partial matching does not apply. 
However, if Maximizer finds no exact matches, it returns a list of 
entries matching any of the fields from the duplicate check lists.

Permission to Create Duplicate Entries

If some users or groups require the ability to create duplicate Address 
Book entries, you can select a user or group from the “Duplicates 
may be entered by” drop-down list. If more than one user requires 
this ability, add those users to a new security group and then select 
that group from this drop-down list. In Maximizer's Duplicate 
Address Book Entry Found dialog box, the user(s) can then choose 
the “Add the new entry” option.
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Configuring Duplicate Address Book Entry Checking

➤ To configure duplicate Address Book entry checking

� In Administrator, select File > Preferences.

� Click the Address Book tab.

� Select the Check for duplicates when adding Address Book 
entries checkbox.

� From the Duplicate check list field, select one of the Duplicate 
Check Lists.

� In the Fields to match for the selected list box, select the 
first, second, and third field to match. (You can select up to three 
fields, but selecting all three fields is not required.)

� Repeat the previous two steps to configure any of the other 
Duplicate Check Lists.

� To enable partial matching, select the Allow partial match 
checkbox.

	 If you want any users or groups to be able to create duplicate 
entries, select the name of the user or group from the 
Duplicates may be entered by drop-down list.


 Click Apply, and then click OK.

�

�

�

�

�
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Setting Up User-Defined Fields for an Address Book
Refer to “Maximizer XML 

Interface (MXI)” on page 388 
for information about creating 
reports with user-defined 
fields.

Although the information you can record in Maximizer covers the 
basics, you probably want to record additional information, such as 
budgets, income, interests, number of employees, or other data. You 
can record this information in Maximizer with user-defined fields, 
which are custom fields for storing information in any of the 
following categories:

User-defined fields can be 
created and modified in both 
Administrator and Maximizer 
(if users have the necessary 
rights). To setup User-defined 
fields in Maximizer, go to the 
Setup tab, and select the User-
Defined Fields icon.

• Address Book entries: Available in the Address Book window

• Opportunities: Available in the Opportunities window of 
Maximizer

• Campaigns: Available in the Campaigns window of Maximizer

• Customer Service Cases: Available in the Customer Service 
Cases window of Maximizer

• User accounts: Available in the user properties dialog box

Once you have created a user-defined field, users can enter data in 
that field.

Types of User-Defined Fields

There are different types of user-defined fields. Each type has 
different properties and uses.

• Alphanumeric user-defined fields record any alphanumeric 
text (letters and numbers) up to a maximum number of 
characters that you specify. Alphanumeric fields can be 
encrypted for security protection. Note that you cannot disable 
or enable encryption once you have created the field.

Encrypted user-defined fields 
cannot be transferred, 
imported, or exported. They 
are also not searchable. 

• Date user-defined fields can store a specific date or an 
annually recurring date.

• Formula user-defined fields calculate values based on other 
basic or user-defined fields. You can set up these fields with 
formulas that create alphanumeric, date, or numeric values. 
Because they are calculated from values of other fields, values 
for formulas fields can be viewed in entries but cannot be set 
manually.

• Numeric user-defined fields record any numeric value you 
wish to keep for the Address Book entries. If you specify a 
number of decimal places for the user-defined field, you can use 
this field type for monetary amounts. 

• Table user-defined fields enable you to select a value or 
values from a list. This type of field is very useful for multiple 
choice or multiple value fields. If you create a table user-defined 
field with the “single value only” attribute, no more than one 
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value can be selected from the list, which is particularly useful 
for fields where it wouldn't make sense to select more than one 
value.

• Yes/No user-defined fields contain either a yes or no value. 
Since the field always contains a yes or no, the mandatory 
attribute is disabled.

User Access Rights for User-Defined Fields

As the Address Book administrator, you are responsible for creating 
user-defined fields in Administrator for Maximizer users. However, 
you can give any user the ability to create, change, or delete user-
defined fields in Maximizer by enabling the following access rights in 
Administrator (See “Modifying User Access Settings” on page 90):

• The User-defined fields access right enables the user to assign 
values to user-defined fields, but not create fields.

• The User-defined field setup access right enables the user to 
create new user-defined fields.

For information about assigning user access rights, refer to “User and 
Group Security” on page 84.

You can also restrict user access to a specific user-defined field. The 
user-defined field properties has options for Full Access (read and 
write) and Read Access (read-only) permissions.

The Full Access and Read Access fields contain a drop-down list of 
users, groups, and Public. Select which user(s) the Full Access or Read 
Access permission applies to:

• Public assigns the user-defined field access permission to all 
users

Full Access and 
Read Access 
permissions.
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• [user] assigns the user-defined field access permission to an 
individual user

• [security group] assigns the user-defined field access 
permission to all members of a security group

About the Set Up User-Defined Fields Dialog Box

User-defined fields are created and modified through the Set Up 
User-Defined Fields dialog box. In Administrator, the User-Defined 
Fields dialog Box is available by selecting File > Set Up User-Defined 
Fields. In Maximizer, select the Setup tab, and click the User-Defined 
Fields icon.

The dialog box contains tabs for each category of user-defined field. 
The user-defined field structure can also be multi-tiered with 
multiple levels of user-defined field folders, each of which may 
contain other folders or user-defined fields. The folder structure may 
contain a maximum of three folder levels.

Mandatory User-Defined Fields and System Fields

Key fields are specified on the 
Key Fields preferences tab in 
Administrator. (File > 
Preferences > Key Fields)

Some user-defined fields are displayed in bold or with an asterisk:

• Mandatory user-defined fields are denoted with an asterisk 
displayed after the field type. 

• System fields are shown in bold, black text. 
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Sort order

There are two methods of changing the order of fields and folders:

• Drag and drop: You can use the mouse to drag and drop fields 
or folders to a different position in the list. Dragging it onto a 
field places it immediately below that field. Dragging onto a 
folder places it at the top of the list inside that folder. Holding 
the mouse on a folder for about a second expands the folder, 
and then you can continue dragging the item to a specific 
position in that folder.

• Move Up and Move Down buttons: Click the Move Up and 
Move Down buttons to move a field or folder up or down in the 
list. These buttons only move items within their current folder 
level. You cannot use them to move items in or out of folders.

Creating a New Folder for User-Defined Fields

Use the Set Up User-Defined Fields dialog box to create new user-
defined fields and folders for use with Address Book entries, 
opportunities, campaigns, customer service cases, and user accounts. 
This dialog box is available from the File menu in both Administrator 
and Maximizer, although users can create user-defined fields in 
Maximizer only if the User-defined field setup access right is 
granted in their user account.

You can group similar user-defined fields into folders and sub-folders 
to a maximum folder depth of 3 levels. Grouping user-defined fields 
into folders is particularly useful if you have a large number of user-
defined fields. Grouping them makes them easier to find and reduces 
the amount of scrolling needed to find the one you’re looking for.

➤ To create a new folder

� Open the Set Up User-Defined Fields dialog box (File > Set Up 
User-Defined Fields).

� Select the tab for the category of user-defined field to create.

� To create a top-level folder, select the Address Book name at the 
top of the list. 

– or –

To create a folder within an existing folder, select the existing 
folder.
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� Click the Add Folder button.

User-defined field and folder 
names cannot contain forward 
slash or backward slash 
characters ( / \ ).

� Enter a name for the new folder, and click OK.

If you set the folder to hidden, 
it is not displayed on the User-
Defined Fields tab when the 
Show hidden fields option is 
deselected.

The new folder now appears in the Set Up User-Defined Fields 
dialog box.

� If necessary, move the new folder to a different position in the 
list.

Creating a New User-Defined Field

Create user-defined fields for Address Book entries, opportunities, 
campaigns, customer service cases, and user accounts in the Set Up 
User-Defined Fields dialog box. This dialog box is available from the 
File menu in Administrator and on the setup tab in Maximizer. Users 
can create user-defined fields in Maximizer only if the User-defined 
field setup access right is granted in their user account.

➤ To create a new user-defined field

� Open the Set Up User-Defined Fields dialog box (File > Set Up 
User-Defined Fields).

� Select the tab for the category of user-defined field to create.

�

�
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� Select an existing folder, inside which to create a new field.

– or –

Select a user-defined field. The new field will be created at the 
same level as the selected user-defined field.

� Click the Add Field button.

� In the Field Name field, type a name for the user-defined field.

User-defined field and folder 
names cannot contain forward 
slash or backward slash 
characters ( / \ ).

� From the Type drop-down list, select the type of user-defined 
field you want to add.

� If you are adding a formula user-defined field, select the type of 
value the formula should return from the Return type drop-
down list.

	 Specify the properties of the user-defined field. 

For formula user-defined fields, click the ellipsis button next to 
the Formula field to specify the formula. Then, click Insert 
Field to add basic or user-defined fields to the formula.

For detailed information about each of the property fields, click 
inside the dialog box and press F1.

�

� �
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 Click OK.

You have now created a user-defined field.

Adding Items to a Table User-Defined Field

Table user-defined fields contain a list of similar items from which a 
user may select one or more items. As part of the process of creating 
a new user-defined field of this type, you should add the items to the 
table. However, while using the user-defined field in Maximizer, 
users may find a need to add an item to the list. A user can add items 
to a table user-defined field on-the-fly if the user account has 
sufficient privileges. Both procedures are explained below.

�
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➤ To add items to a table user-defined field

� In the Set Up User-Defined Fields dialog box, select the table-
type user-defined field, and click the Items button.

– or –

Double-click the table user-defined field.

� In the Set Up Items dialog box, click Add.

� Type a name for the item.

� �

�
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If you set the item to hidden, 
the user can hide it from the 
Available values list by 
deselecting the Show hidden 
items option. The user must 
also ensure that the item is not 
selected in the list. If it is, the 
item will still be displayed.   

� In the Requested by field, select the name of the user who 
requested the item creation.

� Click OK.

� Repeat these steps to add any additional items to the table user-
defined field.

Transferring User-Defined Fields between Address Books

➤ To transfer user-defined fields between Address 
Books

Encrypted user-defined fields 
cannot be transferred between 
Address Books.

� In Maximizer, select the Maximizer button and select Import/
Export/Transfer > User-Defined Fields.

� In the Transfer User-Defined Fields dialog box, select the user-
defined fields to transfer. 

� Click the Transfer button.

� To copy the data into a target Address Book that is accessible 
from the computer, select the Direct Address Book access 
transfer method. Accessible Address Books are listed in 
Available target Address Books.

– or –

If the target Address Book is not listed, select the Email transfer 
method. The data is compressed into a .MET file and attached to 
an email message.

� If you selected Direct Address Book access, select the target 
Address Book, click OK, and log on to the Address Book. 
Maximizer transfers the user-defined fields and notifies you 
when the transfer is complete.

– or –

If you selected Email, click OK. Maximizer creates an email 
message with the user-defined fields attached in a .MET file. 
Type an email address in the To field, and click Send.

�

�

�
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Formula User-Defined Fields
When you create a new or modify an existing formula user-defined 
field, you can click the ellipsis button next to the Formula field to 
specify the formula for the user-defined field. You can write the 
formula using existing basic and user-defined fields. Click the Insert 
Field button to select fields to add to the formula.

You can add arithmetic expressions to your formulas. You can also 
add functions and conditional expressions to create more complex 
formulas.

Formula user-defined fields can return alphanumeric, date, or 
numeric values. You specify the type of return value while creating 
the user-defined field. The functions available depend on the types 
of fields that you want to manipulate.

Arithmetic Expressions

You can create basic arithmetic expressions for formula user-defined 
fields using the basic arithmetic symbols. Multiple expressions can be 
combined to create complicated arithmetic formulas.

To write arithmetic expressions for formula user-defined fields, you 
can use the following symbols:

• + for addition.

You can add any numeric values to each other, add integers to 
date values, and add alphanumeric fields or strings separated 
with quotation marks to each other.

• - for subtraction.

You can subtract any numeric values from each other, and 
subtract date values from each other. Date values return integers 
representing the number of days between the dates.

• * for multiplication.

You can multiple any numeric values together.
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• / for division.

You can divide any numeric values together

• ( ) for nested operations.

You can use parentheses to create more complex operations on 
several numeric values.

Example: Numeric Values

Formula: ([Numeric field] + [Numeric field]) * [Numeric field]

Return value: Numeric

Example: Date Values

Formula: [Date 1] - [Date 2]

Return value: Numeric, the number of days between the two dates.

Example: Date and Numeric Values

Formula: [Date 1] + [Numeric field]

Return value: Date

Example: Alphanumeric Values

Formula: [FirstName] + “ “ + [LastName]

Return value: Alphanumeric, the two words listed together, separated by a 
space (FirstName LastName).

Alphanumeric Functions

Use alphanumeric functions to manipulate alphanumeric fields. 
When you use alphanumeric functions, you can insert alphanumeric 
fields as the parameters for the function or you can use any text 
strings. When you insert strings into functions, enclose the text of the 
string in quotation marks.

You can add the following functions to formulas using alphanumeric 
user-defined fields.

• Len – Returns the number of characters in a text string.

• Mid – Returns a specific number of characters from the text 
string starting at the position you specify.

• Search – Searches for text in a string and returns the position of 
the text.

• Substitute – Substitutes existing text with specified text.
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• Text – Changes a numeric value to an alphanumeric text string. 
You can manipulate the returned string using any of the other 
alphanumeric functions.

• Value – Converts an alphanumeric value to a numeric value. 
Alphanumeric values beginning with alphabetical characters 
return a value of 0. You can manipulate the string using any of 
the numeric functions.

Len

Returns the length of a string.

Syntax

Len (Alphanumeric)

Parameters

Example

Len ([Company]) 

This example returns the number of characters in the company’s 
name.

Mid

Returns a specific number of characters from a text string starting at 
a specified position.

Syntax

Mid (Alphanumeric, StartInt, LengthInt)

Parameter Data Type Description

Alphanumeric String The string to return the length of.
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Parameters

Example

Mid(“First Last”, 7)

This example returns the text starting at the 7th position in the field. 
In this case, it returns “Last”.

Search

Searches a string for text and returns the position of the text in the 
string.

Syntax

Search (SearchString, Alphanumeric, StartInt)

Parameters

Example

Search (“Wine”, [Company_Name]) 

This example searches for the text “Wine” in the company name and 
returns the place in the name where the text starts as an integer.

Parameter Data Type Description

Alphanumeric String The string that you want to search 
through. Normally, this would be a 
merge field.

StartInt Integer The position of the first character 
in the string you want to return.

LengthInt Integer (Optional) The length of the string 
you want to return.

Parameter Data Type Description

SearchString String The text to search for in the string.

Alphanumeric String The string to search through.

StartInt Integer (Optional) The starting character 
to search.
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Substitute

Substitutes existing text with specified text. This function returns the 
entire string containing the new text.

Syntax

Substitute (Alphanumeric, OldText, NewText)

Parameters

Example

Substitute([Address], “St”, “Street”)

This example returns the address with the abbreviation “St” 
substituted with the text “Street”.

Text

Converts a numeric value to a string. You can then use the other 
alphanumeric functions to manipulate the returned string.

Syntax

Text (Number, DecPlace)

Parameters

Parameter Data Type Description

Alphanumeric String The string containing the text you 
want to change.

OldText String The text you want to change.

NewText String The text substituted into the 
string.

Parameter Data Type Description

Number Decimal The numeric value that you want 
to convert.

DecPlace Integer (Optional) The number of decimal 
places to return.
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Example

Text ([Revenue], 2)

This example returns the revenue as an alphanumeric string with two 
decimal places. If revenue, a numeric field, is 50000, the Text function 
in the above example returns 50000.00 as an alphanumeric value.

Value

Converts an alphanumeric value to a numeric value. If the value 
contains alphabetic characters, it returns 0. You can then manipulate 
the numeric value using any numeric functions.

Syntax

Value (Alphanumeric)

Parameters

Example

Value ([Contract Number])

This example returns the alphanumeric user-defined field, Contract 
Number, as a numeric value. If the field contains an alphabetical 
character, it returns 0.

Date Functions

Use date functions to manipulate date fields. When you use date 
functions, you can use date fields as the parameters for the function 
or you can supply date values for the functions. When you supply 
date values, use the Date function to format the values as dates.

You can add the following functions to formulas using date fields.

• Date – Converts integers to date values.

• Day – Returns the day of the month as an integer from a date 
value.

• Dayofweek – Returns the day of the week expressed as an 
integer.

Parameter Data Type Description

Alphanumeric String The alphanumeric string to 
convert.
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• Month – Returns the month as an integer from a date value.

• Year – Returns the year as an integer from a date value.

Date

Converts integers to date values.

Syntax

Date (Year, Month, Day)

Parameters

Example

Date (2009, 7, 9)

This example returns July 9, 2009 as the date value.

Day

Returns the day of the month as an integer from a date value.

Syntax

Day(Date)

Parameters

Parameter Data Type Description

Year Integer The four-digit year.

Month Integer The one- or two-digit month.

Day Integer The one- or two-digit day.

Parameter Data Type Description

Date Date The date to return the day for.



Maximizer CRM 11
Administrator’s Guide

134
Examples

Day(Date(2009, 7, 9))

This example returns 9 as the day of the month in the date value.

Day([Creation Date])

This example returns the day of the month that an entry was created.

Dayofweek

Returns the day of the week expressed as an integer for a specified 
date value, with 1 = Sunday, 2 = Monday, 3 = Tuesday, and so on.

Syntax

Dayofweek(Date)

Parameters

Examples

Dayofweek(Date(2009, 7, 9)

This example returns 5, for Thursday, as the day of the week for the 
given date.

Dayofweek([Creation Date])

This example returns the day of the week that an entry was created.

Parameter Data Type Description

Date Date The date value for which to return 
the day of the week.
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Month

Returns the month as an integer from a date value.

Syntax

Month(Date)

Parameters

Examples

Month(Date(2009, 7, 9))

This example returns 7, for July, as the month in the date value.

Month([Creation Date])

This example returns the month that an entry was created.

Year

Returns the year as an integer from a date value.

Syntax

Year(Date)

Parameters

Examples

Year(Date(2009, 7, 9))

This example returns 2009 as the year for the date value.

Year([Creation Date])

This example returns the year that an entry was created.

Parameter Data Type Description

Date Date The date from which to return the 
month.

Parameter Data Type Description

Date Date Date value for which to return the 
year.
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Numeric Functions

Use numeric functions to manipulate numeric fields. You can add the 
following functions to formulas using numeric fields.

• Ceiling – Rounds a number up to the nearest integer or up to a 
specified number of decimal points.

• Floor – Rounds a number down to the nearest integer or down 
to a specified number of decimal points.

• Round – Rounds a number to the nearest integer or to a 
specified number of decimal points.

Ceiling

Rounds a number up to the nearest integer or up to a specified 
number of decimal points.

Syntax

Ceiling (Number, DecPlace)

Parameters

Example

Ceiling(2.32, 1)

This example returns 2.4.

Parameter Data Type Description

Number Decimal The numeric value to round.

DecPlace Integer (Optional) The number of decimal 
places to round up to.
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Floor

Rounds a number down to the nearest integer or down to a specified 
number of decimal points.

Syntax

Floor(Number, DecPlace)

Parameters

Example

Floor(2.36, 1)

This example returns 2.3

Round

Rounds a number to the nearest integer or to a specified number of 
decimal points.

Syntax

Round (Number, DecPlace)

Parameters

Example

Round (2.45687, 2)

This example returns 2.46.

Parameter Data Type Description

Number Decimal The numeric value to round.

DecPlace Integer (Optional) The number of decimal 
places to round down to.

Parameter Data Type Description

Number Decimal The numeric value to round.

DecPlace Integer (Optional) The number of decimal 
places to round to.
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Conditional Expressions

You can create conditional expressions in your formula user-defined 
fields. Conditional expressions use the If expression to evaluate 
comparison statements and return values based on the results of the 
statements.

Conditional expressions use the following syntax:

If (Comparison Statement, True Value, False Value)

• Comparison Statement – Uses comparison operators to 
compare two values. It can be combined with logical operators 
(and, or, and not), as well as additional conditional expressions

• True Value – The value of the expression when the comparison 
statement is true. It can also be combined with other 
expressions.

• False Value – The value of the expression when the comparison 
statement is false. You can include other conditional statements 
to supply different answers for different values.

Comparison Statements

You can use symbols to create comparison statements for formula 
user-defined fields. You can compare any values including 
alphanumeric, date, and numeric values. Alphanumeric values are 
compared by checking the alphabetical order of the string.

You can create comparison statements with the following symbols.

• == to check that two values are equal to each other.

• > to check that the first value is greater than the next value.

• < to check that the first value is less than the next value.

• >= to check that the first value is greater than or equal to the 
second value.

• <= to check that the first value is less than or equal to the next 
value.

Comparison statements are often combined with logical operators to 
add multiple statements together. They’re added to conditional 
expressions using If statements.
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Logical Operators

You can use logical operators to help build comparison statements 
for your formula user-defined fields.

• Or – Combines two comparison statements where either one of 
the statements is true.

• And – Combines two comparison statements where both of the 
statements is true.

• Not – Negates a comparison statement.

Examples of Conditional Expressions

The following examples illustrate complex formula user-defined 
fields using conditional expressions.

Example 1

If ([Creation Date] > Date(2009, 7, 9), "New", "Old")

This example compares a date field with a constant date, using the 
Date function to format the date properly. The formula returns an 
alphanumeric value. If the date is later than the supplied date, the 
field has a value of “New”. If the date is earlier than the supplied 
date, the field has a value of “Old”.

Example 2

If (Dayofweek([Creation Date]) == 1, "Sunday",  

If (Dayofweek([Creation Date]) == 2, "Monday",  

If (Dayofweek([Creation Date]) == 3, "Tuesday", 

If (Dayofweek([Creation Date]) == 4, "Wednesday",  

If (Dayofweek([Creation Date]) == 5, "Thursday", 

If (Dayofweek([Creation Date]) == 6, "Friday",  

If (Dayofweek([Creation Date]) == 7, "Saturday", " ")))))))

This example uses the Dayofweek function to get the day of the 
week expressed as an integer value for a date field. It compares the 
value with integer values and outputs a string representing the day 
of the week in. If it does not have a value, it outputs an empty string.
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Creating Key Fields Lists
Assigning a user-defined field 

to a Key Fields list does not 
remove it from the User-
Defined Fields tab. Those fields 
appear in both tabs.

Key Fields are important user-defined fields that are highlighted on 
the Basic Information tab in Maximizer Address Book entries, 
opportunities, campaigns, and customer service cases, making them 
more readily accessible. Which user-defined fields appear as Key 
Fields is up to you. You might select mandatory user-defined fields as 
Key Fields, so users don’t miss them when creating a new record. You 
might also select frequently used user-defined fields, making it easier 
for users to quickly enter these values. And you might select user-
defined fields important to a particular group of users because 
different Key Field lists can be defined for a specific user or group, or 
for all users.

The following sections contain information on creating lists of Key 
Fields:

• “Specifying Key Fields by Entry Type” on page 140

• “Restricting Key Fields to Specific Users” on page 141

• “Creating a Key Fields List” on page 142

Specifying Key Fields by Entry Type

When you create a Key Fields list in Maximizer, you can specify up to 
eight user-defined fields for each entry type. The entry types are 
described in the table below.

The user-defined fields available for each entry type correspond to 
the related type of user-defined field and the related Maximizer 
entries. For example, within a Key Fields list, the Opportunity Key 
Fields entry type may contain only opportunity user-defined fields, 
and these Key Fields will be available only in the Opportunity dialog 
box in Maximizer.

There are six types of Address Book entry key fields: two for 
Companies, two for Individuals, and two for Contacts. Only user-
defined fields for the type of Address Book entry (Company, 
Individual, or Contact) are available for each Key Fields entry type. 
For example, only user-defined fields that are available for Contact 
Address Book entries will be available for Contact Key Fields entry 
types.

Each type of Address Book entry has Lead and Non-Lead versions, 
which determines the type of Address Book entry the Key Field 
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applies to. For example, Individual - Non-Lead Key Fields appear only 
in Individual Address Book entries that are not marked as leads.

Restricting Key Fields to Specific Users

The Key Fields in the Basic Information tab of Maximizer entries are 
visible only to the user or group specified as the owner of the Key 
Fields list. However, other users may still be able to access the fields 
through the User-Defined Fields tab, depending on which users or 
groups have full or read access to the user-defined field. Assigning a 
user-defined field to a Key Fields list does not determine who can 
access the user-defined field. The field is available as a Key Field only 
to users with access to both the user-defined field and to the Key 
Fields list.

Key Fields Entry Type 
Type of 
User-Defined Field

Visible in 
Maximizer Entry Type

Company - Lead Address Book entry 
user-defined fields for 
Companies

Companies that are 
marked as Leads

Company - Non-Lead Address Book entry 
user-defined fields for 
Companies

Companies that are 
not marked as Leads

Individual - Lead Address Book entry 
user-defined fields for 
Individuals

Individuals that are 
marked as Leads

Individual - Non-Lead Address Book entry 
user-defined fields for 
Individuals

Individuals that are 
not marked as Leads

Contact - Lead Address Book entry 
user-defined fields for 
Contacts

Contacts that are 
marked as Leads

Contact - Non-Lead Address Book entry 
user-defined fields for 
Contacts

Contacts that are not 
marked as Leads

Opportunity Opportunity user-
defined fields

Opportunities

Campaign Campaign user-
defined fields

Campaigns

Customer Service Customer Service 
user-defined fields

Customer Service 
cases
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Creating a Key Fields List

Create Key Fields lists in Administrator, as described in the following 
procedure.

➤ To create a Key Fields List

� In Administrator, select File > Preferences.

� Select the Key Fields tab.

� Click Add to open the Add Key Fields dialog box.

� In the List name field, create a name for the Key Fields list.

� From the Owner drop-down list, select the user or security 
group with access to the Key Field list, or leave it as Public.

The Owner field determines 
which users will see these 
fields in their Key Fields list in 
Maximizer.

� From the Entry types drop-down list, select the type of 
Maximizer entry to assign Key Fields to.

The fields for that module appear in the Available Fields list.

� Add up to eight user-defined fields to the Key Fields list by 
selecting each field and clicking Add.

	 Repeat steps 6 and 7 to add Key Fields for other modules.

�

�
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 Click OK to save the list.

�

�

�

�






Maximizer CRM 11
Administrator’s Guide

144
Creating Email Notification Templates
If you are using case or 

opportunity notification in 
Maximizer Web Access, you 
must specify an email address 
for WEBUSER. Go to File > 
Manage Users, select 
WEBUSER from the list of 
users, and click Properties. 
Enter an email address on the 
General tab of the Properties 
dialog box.

Maximizer can automatically email customers, partners, and users 
when the status of customer service cases or opportunities change.

While Maximizer includes default notification email messages, you 
can create your own custom email notification templates through 
Administrator. You can create separate templates for each action 
such as when you create a customer service case or when you win an 
opportunity. Each action can also have separate templates for 
emailing customers/partners and users. 

When writing the email templates, remember that each template 
applies to all customer service cases or opportunities of that 
notification event type. They should be specific to the action they are 
assigned to but generic enough to apply to all cases or opportunities 
with that action. Use merge fields to personalize emails based on 
generic templates.

Notifications for cases and opportunities created by MaxExchange 
Remote users will be sent by the MaxExchange Server. In an n-tier 
environment, the notification is sent by the first parent 
MaxExchange Remote Server or MaxExchange Server that has an 
activated Maximizer Email Service.

Customer Service Email Notification

Maximizer can automatically email customers, partners, and users 
when you create, assign, escalate, or resolve customer service cases. 
You can configure the email notifications by going to File > 
Preferences > Customer Service > Notification.

When configuring customer service case email notifications, select 
the Notify the associated Address Book entry when a case is 
created to send the customer an email when an Customer service 
case is created. Select the Carbon Copy the associated Partner 
when notifying Customers option if you want partners to receive 
the same email notification as their associated customer. User 
notification emails are sent to the user(s) identified in the Owner and 
Assigned To field for the case.

Opportunity Email Notification

Maximizer can automatically email users and partners when 
opportunities are created, abandoned, lost, suspended, or won. You 
can configure the email notifications by going to File > Preferences 
> Opportunity > Notification.

When configuring opportunity email notifications, select the 
Carbon Copy the associated Account Manager when notifying 
Partners checkbox if you want account managers to receive the 
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same email notification as their associated partners. Select the 
Notify the former Sales Leader when leader field is changed 
checkbox to notify the previous sales leaders when they are replaced. 
User notification email is sent to users identified as monitors for the 
opportunities.

Merge Fields in Templates

Merge fields in the email template personalize the message for each 
recipient by replacing the merge field syntax with the actual field 
value for the Address Book entry. For example, including the 
{First_Name?} merge field in an email template replaces the syntax 
with each email recipient’s actual first name.

The question mark in a merge 
field is used to alert users to 
not leave a space if no value is 
assigned to the related 
Address Book entry for the 
merge field.

Commonly used customer service and opportunity merge fields are 
described below. For a complete list of merge fields to include in the 
email templates, see the Insert Merge Field dialog box in the 
Maximizer Word Processor. Press F1 when a field is selected to view 
its description.

You can create templates in either .ETF (Maximizer Word Processor) 
or .HTML format. When you create templates in the Maximizer Word 
Processor, click the Merge Field button and select the merge field to 
insert into your email template. When you create HTML templates in 
an HTML or text editor, you must enter the merge field syntax 
manually or copy the syntax from the Maximizer Word Processor.

Customer Service Case Merge Fields

The following table lists the basic customer service case merge fields 
to include in email templates.

Customer Service
Merge Field Description

{My_Name?} Full name of the logged-in user (first 
name, initial, and last name)

{My_Company?} Name of the logged-in user’s company

{CS.Case_Number?} Case number

{CS.Client_Name?} Name of the associated Address Book 
entry (Company or Individual)

{CS.Contact_Name?} Name of the Contact associated with the 
case
Because this field is not mandatory in 
customer service cases, a value may not 
display in case notification emails

{CS.Subject?} Case subject
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{CS.Assigned_To?} Name of the user who the case is assigned 
to
Applies to case assignment or escalation 
emails only

{CS.Resolved_By?} Name of the user who resolved the case
Applies to case resolution emails only

{CS.Resolved_Date?} Date when the case was resolved
Applies to case resolution emails only

{CS.Resolved_Time?} Time when the case was resolved
Applies to case resolution emails only

{Case_Solution?} Knowledge base article number 
associated with the case resolution
Applies to case resolution emails only

{Case_Solution_Note?} Notes from the Solution Notes field in the 
Solution Information & Billing tab of the 
Case dialog box
Applies to case resolution emails only

Customer Service
Merge Field Description
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Opportunity Merge Fields

The following table lists the basic opportunity merge fields to include 
in email templates.

Opportunity
Merge Field Description

{My_Name?} Full name of the logged-in user (first 
name, initial, and last name)

{My_Company?} Name of the logged-in user’s company

{Opportunity.Client_Name
?}

Name of the associated Address Book 
entry (Company or Individual)

{Opportunity.Opportunity
_Contact_Name?}

Name of the Contact associated with the 
opportunity.
Because this field is not mandatory in 
customer service cases, a value may not 
display in case notification emails.

{Opportunity.Objective?} The objective of the opportunity.

{Opportunity.Categories?} The category of the opportunity.

{Opportunity.
Products_Services?}

The products/services of the opportunity.

{Opportunity.Description?} The opportunity’s description.

{Opportunity.Stage?} The stage the opportunity is at.

{Opportunity.Confidence_
Rating?}

The current confidence rating of the 
opportunity.

{Opportunity.Status?} The current status of the opportunity.

{Opportunity.Start_Date?} The start date of the opportunity.

{Opportunity.Close_Date?} The close date of the opportunity.

{Opportunity.Next_Action
?}

The opportunity’s next action.

{Opportunity.Revenue?} The opportunity’s projected revenue.

{Opportunity.Cost?} The opportunity’s cost.

{Opportunity.Team_Name
?}

The name of the team associated with the 
opportunity.

{Opportunity.Opportunity
_Leader?}

The leader of the opportunity.
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Creating and Assigning Email Notification Templates

➤ To create and assign a customer service case or 
opportunity email notification template

� In Administrator, select File > Preferences.

� If you are creating and assigning a customer service case or 
opportunity email notification template, select the Customer 
Service tab.

If you are creating and assigning an opportunity email 
notification template, select the Opportunity tab.

� Click the Notification button.

� In the Email templates for notification group, select an 
Action Name.

�

�
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� Click Assign. For customer service case email notification, select 
Customer Template or User Template. For opportunity email 
notification, select Partner Template or User Template.

The Email Notification Template Library opens.

� To assign an existing template, select the template from the list 
and click OK. Then skip to step 11 of this procedure.

– or –

To create a new template, click New and select Maximizer 
Message Body (Maximizer Word Processor .ETF template) or 
HTML Message Body (HTML template).

The Message Body Name dialog box opens.

�

�

�
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� Type a name to identify the template and click OK.

It’s a good idea to include the action (Create, Assign, Escalate, or 
Resolve) and the recipient type (Customer or User) in the 
template name, so the template is easier to identify.

	 Create the template, including customer service case or 
opportunity merge fields where appropriate, and then save and 
close the Maximizer Word Processor or HTML editor.

To insert merge fields in the Maximizer Word Processor, click the 
Merge Field button. 

To use merge fields in HTML email templates, you must type the 
merge field syntax manually. To simplify the process, you might 
choose to create the template with its merge field syntax in the 
Maximizer Word Processor, and then copy and paste the text 
into the HTML document.

The template name now appears in the Email Notification 
Template Library.
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 Select the template and click OK.

The template is now associated with the action name for 
customers or users.

��For customer service email notifications, to email the associated 
partner when notifying a customer, select the Carbon Copy the 
associated Partner when notifying Customers checkbox.

For opportunity email notifications, to email the associated 
account manager when notifying a partner, select the Carbon 
Copy the Associated Account Manager when notifying 
the Partner checkbox.

��Repeat steps 4 through 9 to create or assign customer/partner 
or user templates for other actions.

��Click OK to save your changes and close the dialog box.




��
��
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Enabling Event Notification
Maximizer enables you to send email notifications to a definable list 
of recipients when specific Maximizer and MaxExchange events occur 
and to log these events to a file. 

Most often these events are significant error conditions requiring 
human intervention, such as a severe Email Server error during an 
email marketing campaign. They may also be notifications of 
irregularities in business process, such as a remote user who has not 
synchronized in a threshold number of days.

Event notification email messages and log files contain the following 
information about events:

• Date and time when the event occurred

• Type of event

• Address Book in which the event occurred

• Action resulting from the event (for example, activity suspended 
due to fatal error)

• Additional information about the event, such as error codes, 
suggested resolutions, etc. 

For descriptions of the 
MaxExchange events, refer to 
the MaxExchange 
Administrator’s Guide.

The following table describes the events for which notification is 
available, as well as probable causes and suggested resolutions for 
each.

Event description Module Cause Resolution

Email service fatal 
error

AutoEmail The connection to the SMTP 
Email Server has failed or the 
SMTP authentication 
username and/or password is 
incorrect.

Check the SMTP server name, 
check the network 
connection, and check the 
authentication username and 
password on the Automated 
Services tab (available in 
Administrator from the File > 
Preferences menu).
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➤ To enable event notification

� In Administrator, select File > Preferences.

� On the System Options tab, click Event Notification.

� Select the Enable event notification checkbox.

� Select an event from the Events list, and click Properties.

� Select the notification options to enable for this event.

�

�

� �
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On the Event Notification 
Properties dialog box, press F1 
to open online help and read 
descriptions of the available 
notification options.

� If you selected Via email as one of the notification options, click 
Add to specify names and email addresses of notification 
recipients.

� Click OK to close the Event Notification Properties.

	 Repeat steps 4 through 7 for each event for which you want to 
enable notification or logging.


 Complete the SMTP server settings fields as they apply to your 
SMTP server, and click OK.

Event notification is now configured.

➤ To view the Event Notification log file

� In Administrator, select File > Preferences.

� On the System Options tab, click Event Notification.

� On the Events Notification dialog box, click View Log File. 

The EventNotification.log file opens in a text editor.

➤ To open the Windows Event Viewer

� Select Start > Programs > Administrative Tools > Event 
Viewer.

� In the left pane, select Application Log.

Maximizer event notifications appear in the right pane of the 
Event Viewer.

�

�

�
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Recording Holidays in the Holiday Editor
The Holiday Editor is a utility you can use to add or edit holidays in 
the Maximizer calendar. By default, the Holiday Editor contains many 
North American holidays. The holidays listed in the Holiday Editor 
also appear in the Calendar window in Maximizer. You can use 
Administrator to modify or delete existing holidays, or add new 
holidays.

If you wish to add personal holidays or events to your calendar, such 
as “Alice's birthday”, you must create a yearly recurring appointment 
using the Calendar window in Maximizer.

The Holiday Editor's data file—Mxzhol.nam—is inserted in the 
Maximizer program folder when you install Maximizer. In this 
location, you use Administrator’s Holiday Editor to manage one set 
of holidays for your installation of Maximizer.

➤ To add a holiday to your calendar

� In Administrator, select Utilities > Holiday Editor. 

� Click Add.

� Enter the details of the new holiday.

� Click OK to close the Add Holiday dialog box.

➤ To share your holidays with another Maximizer 
workstation

• Copy the Mxzhol.nam file from your Maximizer program folder 
to the program folder on the other computer. 

Note that this replaces any existing holidays on the destination 
computer with your own. 
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MaxExchange Distribution
This information is required for 

MaxExchange installations 
only.

The MaxExchange Distribution field is a system user-defined field. 
The table items within this user-defined field are referred to as 
Distribution Groups. 

If your Maximizer setup includes MaxExchange, you must create the 
MaxExchange Distribution user-defined field as part of the Address 
Book setup. After you create this field, it appears in the User-defined 
fields tab of the Address Book entry in Maximizer. Users assign a 
MaxExchange Distribution value(s) to each Address Book entry, 
which assigns the Address Book entry to a MaxExchange Distribution 
Group(s). 

Refer to the MaxExchange Administrator’s Guide for more 
information about this field.

➤ To create the MaxExchange Distribution field

� Open the Address Book in Administrator.

� Select File > Preferences.

� Click the Create MaxExchange Distribution button.

If this button is disabled, the field has already been created.

�
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� Click OK on the dialog box.

After you click this button, Maximizer creates the MaxExchange 
Distribution user-defined field, and the button becomes disabled 
in Preferences.

� Click OK to close the Preferences window.

The MaxExchange Distribution field now appears on the User-
Defined Fields tab of all Address Book entries.

Adding MaxExchange Distribution Groups

After you have enabled the MaxExchange Distribution field, you 
must create Distribution Groups.

➤ To add a MaxExchange Distribution Group

� In Administrator, select File > Preferences.

� Click the System Fields tab.

� Select MaxExchange Distribution, and click Add.

�

�

�
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� Enter the name of the new Distribution Group, and click OK.

The new MaxExchange Distribution Group has been added to 
the list. 

�

�
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In this chapter...

“Configuring Microsoft Outlook Synchronization” on page 160

“Setting Up MaxSync for Microsoft Exchange” on page 166

“Configuring MaxMobile Wireless Server” on page 181

“Configuring the Maximizer Email Service” on page 183

“Enabling TAPI” on page 186

“Phone Masks” on page 191

“Using Fax Software with Maximizer” on page 192
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Configuring Microsoft Outlook Synchronization
Outlook Synchronization 

works with Microsoft Outlook 
only.

Outlook Synchronization mirrors select appointments, tasks, and 
Address Book entries between Maximizer and Microsoft Outlook to 
ensure the entries exist in both programs and that they both contain 
the same information. 

Outlook Synchronization settings are configured on a per-user basis, 
and each Maximizer user has one set of configuration settings. 
Typically, users configure their own Outlook Synchronization settings 
in Maximizer by going to the Setup tab and selecting Preferences. 
However, you can also configure their settings through 
Administrator’s user preferences.

Outlook Synchronization preferences enable you to select which 
entries will be synchronized:

For information on how 
Maximizer and Outlook fields 
are mapped to each other in 
Outlook Synchronization, refer 
to “Field Mapping” on 
page 331.

• For appointments and tasks, only entries scheduled within the 
specified date ranges will synchronize, with the exception of 
recurring appointments and tasks, as described in the following 
section. These settings apply to appointments and tasks in both 
Maximizer and Outlook.

• For Maximizer Address Book entries, only the entries belonging 
to the selected Favorite List will synchronize with Outlook. Those 
entries will be assigned to the specified Outlook category.

• For Outlook contacts, only the contacts assigned to the specified 
category will synchronize with Maximizer. Those entries will be 
assigned to the selected Favorite List in Maximizer.

• Products/Services and Categories are synchronized to Outlook if 
you are using Microsoft Outlook Synchronization or MaxSync for 
Microsoft Exchange. Attendees, resources, and any notes you 
add to an appointment are also synchronized. These items 
appear as part of the appointment dialog box in Outlook.

Outlook Synchronization preferences also enable you to specify how 
often to synchronize and how to handle conflicts when the same 
entry has been modified in both Outlook and Maximizer.

Maximizer can synchronize only with Outlook profiles on the same 
machine. When configuring a user’s Outlook Synchronization 
settings through Administrator, you must manually enter the 
Outlook profile name, but it cannot be verified until the Outlook 
Synchronization process runs on the user’s machine. If you don’t 
know the Outlook profile name, leave the field blank and the user 
can select it through Maximizer’s user preferences. When Outlook 
Synchronization runs, it checks that the configuration has a valid 
Outlook profile name. If not, Outlook Synchronization logs the error.
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Appointment and Task Synchronization

When Outlook Synchronization is configured, it can synchronize 
select appointments and tasks between the Maximizer Address Book 
and Microsoft Outlook. Only those appointments and tasks 
scheduled within the specified date ranges will synchronize, with the 
following exceptions: 

• if an instance of a recurring appointment occurs within the 
specified date range, all instances of the recurring appointment 
will be synchronized

• if a task is scheduled prior to the specified date range, but the 
“Carry forward unfinished tasks” option is selected, the task will 
be synchronized

You can also specify whether to synchronize private appointments 
and/or tasks.

Recurring Appointments

Recurring appointments in Microsoft Outlook synchronize to 
Maximizer as recurring appointments unless they have no end date. 
If the recurring appointment has no end date, only the first 
occurrence synchronizes with Maximizer, not the recurrences. To 
synchronize recurring appointments with Maximizer, always provide 
an end date.

Note that while it is possible to modify the Private property of a 
single instance of a private appointment in Maximizer, this property 
can be changed only for the entire series of recurring appointments 
in Outlook. Therefore, if you change the Private property of a single 
instance of a recurring appointment in Maximizer, this change will 
not be synchronized to Outlook.

Recurring Tasks

If you synchronize a recurring task from Outlook, and then mark the 
task as complete in Maximizer, Maximizer cannot create the next 
instance of the recurring task. You should mark the task as complete 
in Outlook, which will create the next instance of the task, and then 
re-synchronize with Maximizer.

If you synchronize a recurring task from Outlook, and then delete 
the task in Maximizer, all instances of the recurring tasks are deleted. 
If you want to delete a single instance of a recurring task, you should 
delete the task in Outlook and then re-synchronize with Maximizer.
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Group Appointments

When using Outlook Synchronization, group appointments in 
Maximizer synchronize to Outlook for the current user only. 
However, the synchronized appointment in Outlook includes all the 
locations, resources, and attendees information in the appointment 
notes.

To fully synchronize group appointments between Maximizer and 
Outlook, use MaxSync for Microsoft Exchange.

Microsoft Outlook Synchronization and MaxSync for Microsoft Exchange

Refer to “Setting Up MaxSync 
for Microsoft Exchange” on 
page 166 for more 
information. 

If MaxSync for Microsoft® Exchange is installed and configured for 
the current Address Book, Outlook Synchronization no longer 
synchronizes appointments or tasks. However, Address Book entry 
synchronization can be handled by MaxSync or Outlook 
synchronization based on your settings. If MaxSync for Microsoft 
Exchange is active, the appointment and task synchronization 
sections of the Outlook Synchronization configuration properties are 
disabled.

Microsoft Outlook Synchronization and MaxExchange Synchronization

In a MaxExchange environment with Microsoft Outlook 
Synchronization enabled, Maximizer can synchronize with Outlook 
on a single server or remote only. Otherwise, duplication of entries 
may occur.

When MaxExchange is installed, and at least one MaxExchange 
remote has been added as a distribution site, a MaxExchange 
Location button appears at the bottom of the Outlook 
Synchronization tab. Clicking this button opens a dialog box 
containing a drop-down list of MaxExchange servers and remotes for 
the current Address Book. Select the MaxExchange server or remote 
where Maximizer will synchronize entries with an Outlook profile for 
the selected user.

Synchronization from Outlook to Your PDA

In addition to synchronizing Maximizer data with Outlook, you can 
synchronize information from Outlook to your PDA. There are 
several selections of available software to perform this 
synchronization. Please consult with your PDA manufacturer or 
supplier for more information.
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Configuring Outlook Synchronization

➤ To configure Outlook Synchronization

� In Administrator, select File > Manage Users.

� Select the Maximizer user, and click Preferences.

� Select the Outlook Synchronization tab.

� In the Synchronization frequency group box, specify how 
often Maximizer should synchronize with Outlook.

If you select Never (manual synchronization), the user must 
synchronize manually by selecting the Tools tab and clicking 
Synchronize with Outlook in the Office group.

� In the Conflict resolution group box, select the desired 
method of handling entries that have been changed in both 
Maximizer and Outlook since the last synchronization.

� In the Outlook profile field, enter the name of the user’s 
Outlook profile. This information must be obtained from the 
user’s computer. 

To ignore the computer name when synchronizing, select the 
Ignore computer name checkbox.
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Do not select Ignore computer 
name if the user uses multiple 
computers and synchronizes to 
a different Outlook profile on 
each computer.

� To synchronize appointments, select the Synchronize 
appointments checkbox and specify the date range of 
appointments to synchronize.

Private appointments will not be synchronized unless the 
Include private appointments checkbox is also selected.

	 To synchronize tasks, select the Synchronize tasks checkbox 
and specify the date range of tasks to synchronize. 

Private tasks will not be synchronized unless the Include 
private tasks checkbox is also selected.

To also synchronize incomplete tasks that are scheduled prior to 
the specified date range, select the Carry forward unfinished 
tasks checkbox.


 To synchronize Maximizer Address Book entries and Outlook 
contacts, select the Synchronize Address Book entries 
checkbox. Note that this option is used to synchronize a personal 
Contacts Address Book list. For information on selecting the 
Outlook address list for integration with Maximizer, see the 
Maximizer CRM User’s Guide. 

The Synchronize Address Book 
entries checkbox is disabled if 
the user does not have the 
“Allow sync contacts with 
external clients” access right.

��To specify the mapping between Outlook phone number fields 
and Maximizer phone number fields, click the Phone Mapping 
button, select the Maximizer phone number field to map to each 
Outlook phone number field, and click OK.

Do not map all Outlook phone number fields. Maximizer 
supports only four phone numbers for each Address Book entry. 
If an Outlook contact has more than four phone numbers, and 
more than four types are mapped between Outlook and 
Maximizer, not all the Outlook phone numbers can be 
synchronized with Maximizer.

��In the Synchronize Address Book entries from Favorite 
List drop-down list, select the Maximizer Favorite List to 
synchronize.

��In the Synchronize Contacts from Outlook Category 
drop-down list, select the Outlook category to synchronize.
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��If the selected user is a MaxExchange user, click the 
MaxExchange Location button, select the MaxExchange server 
or remote where this Outlook profile can synchronize with 
Maximizer, and click OK.

��Click OK.

The Maximizer user account is now configured to use MaxSync 
for Microsoft Exchange.
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Setting Up MaxSync for Microsoft Exchange
MaxSync for Microsoft Exchange is a Maximizer add-on that mirrors 
select appointments and tasks between a Maximizer Address Book 
and a Microsoft Exchange Server. This add-on is similar to 
Maximizer’s built-in Outlook Synchronization tool, which 
synchronizes Maximizer directly with Outlook. For more information, 
refer to “Configuring Microsoft Outlook Synchronization” on 
page 160.

MaxSync for Microsoft Exchange synchronizes information between 
the Microsoft Exchange server and Maximizer workstations. The 
Microsoft Exchange server communicates with MAPI-enabled 
applications, like Microsoft Outlook, on workstations. MaxSync 
ensures that information in the email applications matches 
information in Maximizer.

MaxSync for Microsoft 
Exchange is not supported in 
multi-server Microsoft 
Exchange environments.

Select one machine where you will install MaxSync for Microsoft 
Exchange for one or more Address Books. One installation of 
MaxSync for Microsoft Exchange can apply to multiple Address 
Books. Do not activate multiple installations of MaxSync for the same 
Address Book.

You can install MaxSync for Microsoft Exchange on either the 
Maximizer server or on a workstation. However, it must be installed 
on a machine where Maximizer and a MAPI-enabled application, 
such as Microsoft Outlook, are installed. Do not install MaxSync for 
Microsoft Exchange on your Microsoft Exchange Server machine. 

Microsoft Exchange Server

Workstation(s)

Maximizer CRM Workstation

MAPI-enabled application (Microsoft Outlook)

Microsoft Exchange Server

Maximizer CRM

MaxSync for Microsoft Exchange

MAPI-enabled application (Microsoft Outlook)

Synchronization Service Machine
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Appointment and Task Synchronization

Products/Services and 
Categories are synchronized to 
Outlook if you are using 
MaxSync for Microsoft 
Exchange. Attendees, 
resources, and any notes you 
add to an appointment are 
also synchronized. These items 
appear as part of the 
appointment dialog box in 
Outlook.

When MaxSync is installed and configured, it can synchronize select 
appointments and tasks between the Maximizer Address Book and 
Microsoft Exchange. Only those appointments and tasks scheduled 
within the specified date ranges will synchronize, with the following 
exceptions: 

• if an instance of a recurring appointment occurs within the 
specified date range, all instances of the recurring appointment 
will be synchronized

• if a task is scheduled prior to the specified date range, but the 
“Carry forward unfinished tasks” option is selected, the task will 
be synchronized

You can also specify whether to synchronize private appointments 
and/or tasks.

Note that under some circumstances, if a task is assigned to you and 
you assign the task to another user, and the user accepts it, after 
synchronizing with MaxSync the task will be synchronized for one of 
the users only, not both. This situation occurs only if the user 
accepting the task does not open the task and is using the “simple” 
(rather than “detailed”) task view. Otherwise, the task 
synchronization will occur normally.

Recurring Appointments

As with Microsoft Outlook synchronization, recurring appointments 
in Microsoft Exchange synchronize to Maximizer as recurring 
appointments unless they have no end date. If the recurring 
appointment has no end date, only the first occurrence synchronizes 
with Maximizer, not the recurrences. To synchronize recurring 
appointments with Maximizer, always provide an end date.

Note that while it is possible to modify the Private property of a 
single instance of a private appointment in Maximizer, this property 
can be changed only for the entire series of recurring appointments 
in Microsoft Exchange. Therefore, if you change the Private property 
of a single instance of a recurring appointment in Maximizer, this 
change will not be synchronized to Microsoft Exchange.
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Recurring Tasks

If you synchronize a recurring task from Outlook, and then mark the 
task as complete in Maximizer, Maximizer cannot create the next 
instance of the recurring task. You should mark the task as complete 
in Outlook, which will create the next instance of the task, and then 
re-synchronize with Maximizer.

If you synchronize a recurring task from Outlook, and then delete 
the task in Maximizer, all instances of the recurring tasks are deleted. 
If you want to delete a single instance of a recurring task, you should 
delete the task in Outlook and then re-synchronize with Maximizer.

Group Appointments

With MaxSync for Microsoft Exchange, you can also synchronize 
group appointments. However, when changing the attendees for 
individual instances of a recurring appointment, Maximizer cannot 
synchronize that change.
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Using Both MaxSync for Microsoft Exchange and Outlook Synchronization

You can use MaxSync for Microsoft Exchange and Microsoft Outlook 
Synchronization together in the same Address Book. If MaxSync for 
Microsoft Exchange is enabled for the current Address Book, Outlook 
Synchronization no longer synchronizes appointments and tasks, and 
the appointment and task synchronization section of Outlook 
Synchronization configuration properties becomes disabled. 
However, Address Book entry synchronization is handled by Outlook 
synchronization.
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Windows Account for MaxSync for Microsoft Exchange

MaxSync for Microsoft Exchange runs as a service under an account 
that has the necessary permissions to the Microsoft Exchange 
mailbox store. This account must be specified during the MaxSync for 
Microsoft Exchange installation.

The specified service account must have the “Send As”, “Receive As”, 
“Administer Information Store”, and the “View Information Store 
Status” rights on the mailbox store in Microsoft Exchange.

➤ To assign permissions for the mailbox store in 
Microsoft Exchange 2007

� Launch Microsoft Exchange 2007 Power Shell.

� Enter the following script:

Replace [ServerName] with the 
name of the Exchange 2007 
server, and replace 
[UserAccount] with the user 
account that MaxSync for 
Microsoft Exchange will run 
under.

get-mailboxserver [Exchange2007ServerName] | add-
adpermission -user [UserAccount] -extendedrights “Send 
As”, “Receive As”, “Administer Information Store”, “View 
Information Store Status”

➤ To assign permissions for the mailbox store in 
previous versions of Exchange

� Launch Microsoft Exchange System Manager.

� Navigate to the Mailbox Store.

� Right-click and select Properties.

� Click the Security tab.

� Select the user account that MaxSync for Microsoft Exchange will 
run under.

� Allow the following permissions: Administer information 
store, View information store status, Receive As, and Send 
As.

� Click OK.
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Installing MaxSync for Microsoft Exchange

Select one machine where you will install MaxSync for Microsoft 
Exchange for one or more Address Books. While one installation of 
MaxSync for Microsoft Exchange can apply to multiple Address 
Books, do not activate multiple installations of MaxSync for the same 
Address Book.

MaxSync for Microsoft Exchange can be installed on either the 
Maximizer server or on a workstation. However, it must be installed 
on a machine where Maximizer and a MAPI-enabled application, 
such as Microsoft Outlook, are installed. Do not install MaxSync for 
Microsoft Exchange on your Microsoft Exchange Server machine. 

➤ Before installing MaxSync for Microsoft Exchange

� On the machine where MaxSync for Microsoft Exchange will be 
installed, log in using the Windows account identified above.

� Create a Mail profile for that account.

� Open the Mail profile in Outlook to test connectivity.

� Open Maximizer and log into every Address Book that will    
synchronize using MaxSync for Microsoft Exchange.

➤ To install MaxSync for Microsoft Exchange

� Close all programs running on the server.

� Insert the MaxSync for Microsoft Exchange disc. 

The setup starts automatically.

If the setup doesn’t start 
automatically, you can start it 
manually by running 
autorun.exe from the disc.

� Click Install MaxSync for Microsoft Exchange. 

The InstallShield Wizard starts.

� Follow the on-screen installation instructions.

� On the Account Details screen, enter the account details for a 
valid user in the domain where the Microsoft Exchange Server 
resides, and click Next.
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This is the Windows user 
account for MaxSync for 
Microsoft Exchange discussed 
earlier.

Domain: Name of the Windows domain where the Microsoft 
Exchange Server resides.

User: Username of a Windows account with administrative 
rights to the Microsoft Exchange Server. This user must have full 
access to all mailboxes on the Microsoft Exchange Server.

Password: Password for the specified user account.

Confirm password: Same as the previous field.

� Click Next to start the installation.

� When the installation is complete, click Finish.

Once you have installed MaxSync for Microsoft Exchange, you 
must enable it for the Address Book and for each user.

Enabling MaxSync for Microsoft Exchange for the Address Book

MS Exchange Synchronization 
preferences are available 
through Administrator only, 
not Maximizer.

After MaxSync for Microsoft Exchange is installed, configuration 
properties are available through File > Preferences > MS Exchange 
Synchronization in Administrator. These preferences are configured 
on a system-wide basis, rather than per-user as with Outlook 
Synchronization. After you have configured the MaxSync for 
Microsoft Exchange preferences, you must enable it for each user 
through their user properties.

➤ To enable and configure MaxSync for the Address 
Book

� In Administrator, select File > Preferences.

� Click the MS Exchange Synchronization tab.
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This tab is not available until 
after MaxSync for Microsoft 
Exchange is installed.

� Select Activate MaxSync for Microsoft Exchange for 
currently open Address Book.

� In the Synchronization frequency group box, specify how 
often Maximizer should synchronize with Microsoft Exchange.

If you select Never (manual synchronization), a user can 
synchronize data manually by clicking the Synchronize with MS 
Exchange toolbar button or selecting Synchronize with 
Outlook from the Office group on the Setup tab in Maximizer. 
This synchronizes data for this particular user only.

� In the Conflict resolution group box, select the desired 
method of handling entries that have been changed in both 
Maximizer and Outlook since the last synchronization.

� In the Outlook profile field, enter the name of a Microsoft 
Exchange profile. This is the profile of the Microsoft Exchange 
administration user, which was specified during the installation.

This mail profile must exist on the machine where the MaxSync 
service is running.

� To synchronize appointments, select the Synchronize 
appointments checkbox and specify the date range of 
appointments to synchronize.

Private appointments will not be synchronized unless the 
Include private appointments checkbox is also selected.

	 To synchronize tasks, select the Synchronize tasks checkbox 
and specify the date range of tasks to synchronize. 

Private tasks will not be synchronized unless the Include 
private tasks checkbox is also selected.

To also synchronize incomplete tasks that are scheduled prior to 
the specified date range, select the Carry forward unfinished 
tasks checkbox.


 To synchronize Maximizer Address Book entries and Outlook 
contacts, select the Synchronize Address Book entries 
checkbox. 

Note that this option is used to synchronize a contacts folder in 
the Exchange public folders with a Maximizer Favorite List.
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When synchronizing contacts 
from a public folder on 
Exchange, you must show the 
folder as an Email Address 
Book. See “Selecting the 
Outlook Address List to 
Synchronize with Exchange” 
on page 175 for more 
information. Note that only 
public folders in Exchange can 
be used for synchronization. 

��To specify the mapping between Outlook phone number fields 
and Maximizer phone number fields, click the Phone Mapping 
button, select the Maximizer phone number field to map to each 
Outlook phone number field, and click OK.

Do not map all Outlook phone number fields. Maximizer 
supports only four phone numbers for each Address Book entry. 
If an Outlook contact has more than four phone numbers, and 
more than four types are mapped between Outlook and 
Maximizer, not all the Outlook phone numbers can be 
synchronized with Maximizer.

��In the Synchronize Address Book entries from Favorite 
List drop-down list, select the Maximizer Favorite List to 
synchronize.

��In the Synchronize Contacts from Outlook Category 
drop-down list, select the Outlook category to synchronize.

��Click the User Administration button to create disabled 
Maximizer user accounts for Microsoft Exchange users, so you 
can create Maximizer appointments for those users and 
synchronize the appointments with a Microsoft Exchange server.

��Click the Resource Mapping button to map Maximizer 
resources/locations to Exchange Server resources.

��If the selected user is a MaxExchange user, click the 
MaxExchange Location button, select the MaxExchange server 
or remote where this Outlook profile can synchronize with 
Maximizer, and click OK.
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Selecting the Outlook Address List to Synchronize with Exchange

Before you can synchronize your public folder between Exchange 
and Maximizer, you must first specify the Outlook address list (the 
public folder) for synchronization. 

➤ To select an Outlook address list

� In Outlook on the computer running MaxSync, select Tools > 
Address Book from the menu.

� In the Address Book dialog box, select Tools > Options.

� Open the Show this address list first drop-down list, and 
select the public folder you are using for synchronization. In 
order for this folder name to appear in the list, it must be 
specified as an Outlook Address Book.

If the folder you are synchronizing does not appear in the above 
drop-down list, ensure the Show the folder as an Email 
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Address Book option is selected on the Outlook Address 
Book tab of the folder properties.

� Click OK, and then close the dialog box in Outlook.

Enabling MaxSync for Microsoft Exchange for Maximizer Users

Once MaxSync for Microsoft Exchange is installed and configured, 
you must enable it for individual users before they can synchronize 
Maximizer and Outlook appointments and tasks.

➤ To enable MaxSync for Microsoft Exchange for a 
Maximizer user

� Click File > Manage Users.

� Select the Maximizer user, and click Properties.

� Select the Windows Authentication tab.

� Click the MS Exchange User drop-down arrow.

The Choose Profile dialog box opens.

� Select a Microsoft Exchange profile name, and click OK.

The MS Exchange User drop-down list is now populated with a 
list of mail profiles on the Microsoft Exchange Server.

� From the MS Exchange User drop-down list, select the mail 
profile name for the selected user.
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� Click OK to close the user properties dialog box.

The Maximizer user account is now configured to use MaxSync 
for Microsoft Exchange.

Enabling MaxSync for Microsoft Exchange for Other Users

If you are using MaxSync for Microsoft Exchange, and you want to 
create Maximizer appointments with non-Maximizer users, create 
disabled Maximizer user accounts for those users and map them to 
their Microsoft Exchange user accounts. You can then create 
Maximizer appointments with those users and synchronize the 
appointments with Microsoft Exchange. MaxSync User 
Administration in Administrator enables you to automatically create 
disabled Maximizer user accounts for non-Maximizer users and 
automatically map them to their Microsoft Exchange user accounts.

These disabled Maximizer user accounts do not consume any 
Maximizer licenses, and they do not give those users any access to the 
Maximizer Address Book. They simply enable you to add those users 
to Maximizer appointments that synchronize to a Microsoft 
Exchange server.

Do not use MaxSync User Administration to map Microsoft Exchange 
user accounts to existing Maximizer users. Doing so may create 
duplicate disabled Maximizer user accounts for those users. To map 
Microsoft Exchange user accounts to existing Maximizer user 
accounts, use the procedure described in “Enabling MaxSync for 
Microsoft Exchange for Maximizer Users” on page 176.
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➤ To automatically create disabled Maximizer user 
accounts for Microsoft Exchange users

� In Administrator, on the machine where MaxSync is installed, 
select File > Preferences.

� Open the MS Exchange Synchronization tab.

� Click User Administration.

� In the Choose Profile dialog box, select the Microsoft Exchange 
server Profile Name, and click OK.

The dialog box shows available Microsoft Exchange users in the 
list on the left, and it shows Microsoft Exchange users that have 
already been mapped to a Maximizer user account in the list on 
the right. Both lists show the user’s display name from the 
Microsoft Exchange server.

� In the Available Microsoft Exchange users list, select any 
users for whom you want to create disabled Maximizer user 
accounts.

You can select a range of users by selecting the first user in the 
range, holding down the Shift key, and then selecting the last 
user in the range. You can select multiple users by holding down 
the Ctrl key while you click.

� Click Add.

The selected users appear in the Users selected for 
synchronization list.

� Click OK.

Maximizer creates the disabled user accounts. Those users will 
now appear in the Manage Users dialog box (File > Manage 
Users), but their Maximizer login status is disabled.

Once you have created disabled Maximizer user accounts for 
Microsoft Exchange users, you cannot remove them using the 
MaxSync User Administration dialog box. See the procedure 
below for information on removing them.
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Disabling MaxSync for a Maximizer User Account

To disable MaxSync for a Maximizer user account, unmap the 
connection between the user’s Maximizer account and Microsoft 
Exchange account. Perform this procedure on the computer where 
MaxSync is installed in Maximizer or Administrator.

➤ To unmap a Maximizer user account from a 
Microsoft Exchange user account

� In Maximizer, on the Setup tab, select Manage Users from the 
User Management group.

– or –

In Administrator, select File > Manage Users.

� Select the Maximizer user, and click Properties.

� Select the Windows Authentication tab.

� Click the MS Exchange User drop-down arrow.

� Select the Microsoft Exchange server name from the Profile 
Name drop-down list.

� Change the value of the MS Exchange User drop-down list to 
the blank value at the top of the list.

� Click OK.

The Maximizer user account is no longer mapped to a Microsoft 
Exchange user account on that Microsoft Exchange server. If you 
open the MaxSync User Administration dialog box, the user is 
also removed from the column on the right.

Configuring Windows Authentication for MaxSync

To run MaxSync for Microsoft Exchange in a Windows 
Authentication environment, the Windows user account running 
MaxSync must have the db_owner role for the MaConfig database 
and for the Maximizer databases that are synchronizing with 
Microsoft Exchange. For more information on setting up Windows 
Authentication, see “Setting Windows Authentication for Users” on 
page 102.
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Moving MaxSync to a Different Computer

To move MaxSync for Microsoft Exchange to a different computer, 
set up MaxSync on the new computer in the same way as you set up 
MaxSync on the original computer.

To ensure duplicate entries are not created, MaxSync must be set up 
using a Mail profile with the same name and for the same user 
account as on the original computer. To verify the name of the Mail 
profile on the original computer, in Administrator, select File > 
Preferences, and select the MS Exchange Synchronization tab. The 
name of the Mail profile is displayed in the Outlook profile field.

When installing MaxSync, ensure you select the same Windows user 
account to run the MaxSync service as was set up on the original 
computer.

For more information on setting up the Mail profile and installing 
MaxSync, see ‘Installing MaxSync for Microsoft Exchange” on page 
171.
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Configuring MaxMobile Wireless Server
Before users can use MaxMobile, the administrator must configure 
the wireless server in Administrator. The number of users allowed to 
use MaxMobile is controlled through your product license number. 

➤ To configure MaxMobile Wireless Server

� In Administrator, open the Address Book to use with MaxMobile, 
and select File > MaxMobile Administration. Note that you 
can access this dialog box from Maximizer only if you have 
administrative privileges as a Maximizer user.

 

� Enter the URL of the MaxMobile Wireless Server. The URL should 
be in the following format:

http://[server_name]:port/MaxMobileService

https://[server_name]:port/MaxMobileService

� For each users, departments, divisions, security groups, and 
teams who will use MaxMobile, select the name from the 
MaxMobile users list and click Add to move the item to the 
Users selected for deployment list. This enables MaxMobile 
for these users as shown below in the Module Login section of a 
user’s properties. Use the Remove button to remove an item 
from this list.

Note that you can also enable MaxMobile for users in the 
General tab of the Properties dialog box for a user.
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For more information about deploying MaxMobile, see the 
MaxMobile Wireless Server Getting Started Guide.
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Configuring the Maximizer Email Service
The Maximizer Email Service is installed automatically with 
Maximizer, and it works with the following operations in Maximizer:

• automated email campaign activities

• customer service case email notifications

• appointment reminders by email

The Maximizer Email Service must be running for these operations to 
function. 

Note that for Windows XP Professional, the Maximizer Email Service 
must run as an application, not as a service.

By default, Maximizer will delete any email messages queued by the 
email service that are older than 14 days. Messages are queued when 
the email service is stopped. To change the maximum age of unsent 
email messages, modify the value of the EMGR_MSG_AGE_LIMIT key 
in the MaConfig table. To disable email message age limits, set this 
value to 0.

Ensure that users have an email address entered in their user 
properties, so they can receive customer service case email 
notifications and appointment reminders by email. Users should also 
set their email appointment notification option in Maximizer (In the 
Setup tab, select Preferences. In the Preferences dialog, select the 
Calendar/Hotlist tab).

For more information about the properties in the Automated 
Services tab, click inside the tab and press F1.

➤ To configure Maximizer Email Service preferences

� In Administrator, select File > Preferences.

� Select the Automated Services tab.

� Select Email from the Preferences for Activity type drop-
down list.

� Set the Service cycle time check.

The service cycle time check controls how often the Maximizer 
Email Service processes the email activities in automated 
campaigns. By default, this option is set to 1 minute. 

� To send large quantities of email messages, select the Enable 
sending in batch mode option, and set the Batch size.

If you are using an ISP, it’s important to control the email batch 
settings.



Maximizer CRM 11
Administrator’s Guide

184
� Enter a URL in the URL of Campaign Manager Statistics field. 

This URL specifies the URL of the script that redirects the email 
recipients to the Landing page URL (as specified in the Add Email 
Activity dialog box), which is included in automated email 
activities. This option applies to automated email activities only, 
and it is available only if Maximizer Components for Microsoft IIS 
is installed.

� Choose a character set from the Character set used by email 
service drop-down list. This is the friendly name for the 
character set. The actual name of the character set is shown in 
the field on the right of the drop-down list. 

This character set is used for all outgoing email sent by the 
Maximizer Email Service. 

If the character set does not appear in the list, you can enter the 
name of the character set in the field on the right. The field on 
the left is then displayed as a blank value. 

	 Select the Activate services for the currently open Address 
Book option.

This checkbox must be enabled to use automated email 
campaigns, customer service case email notifications, and 
appointment reminders by email.


 Enter the Service computer and SMTP server names and the 
SMTP port number.

The SMTP server is specified 
during the Maximizer 
installation and the port 
number is set to 25 by default.

��If the SMTP server requires authentication, select the 
checkbox and enter the account name and password.
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The authentication settings are 
specified during Maximizer 
installation.

��Click OK.

Maximizer is now configured to use the Maximizer Email Service 
for automated email campaign activities, customer service case 
email notifications, and appointment reminders by email.

�

�
�

	



�
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Enabling TAPI
Maximizer can use TAPI (Telephony Application Programming 
Interface) to detect incoming phone numbers (using caller ID) and 
log the phone conversation for the matching Address Book entry. 

The following requirements must be met to use TAPI with Maximizer:

• Your telephone system must be TAPI-enabled.

• Your phone system’s TAPI driver must be installed.

• Your computer’s modem must be compatible with TAPI. 

You can configure your modem for TAPI through the Windows 
Control Panel (Control Panel > Phone and Modem Options > 
Advanced tab). For more information, refer to your TAPI system 
and Windows documentation.

• Maximizer must be configured for TAPI.

Requirements for Caller ID

Specific requirements are essential to implement caller ID detection:

• Caller ID service from the local telephone company.

• TAPI-compliant hardware that is Caller-ID capable.

• A TSPI component (such as an .INF file driver) for your Caller-ID 
enabled TAPI hardware (e.g., UniModemV)

• Microsoft TAPI software components.

Even if you meet these requirements, caller ID may not operate 
properly, especially if your local telephone company uses a different 
standard for caller ID than your TAPI driver. Call your local phone 
company to obtain more information regarding your caller ID 
standard and compare it to the standard used by the TAPI driver.

Reasons Why Caller ID May Not Work

If you use a TAPI-enabled modem (as opposed to a PBX, H.323, or 
other TAPI hardware), and your telephone company provide MESG-
format caller ID information (rather than SDM, another common 
format), caller ID call detection is unlikely to work. Microsoft’s 
UniModemV TAPI driver and MODEM.INF file, provided with most 
TAPI modems, do not support MESG caller ID format, which means 
your modem (and Maximizer) may never receive caller ID 
information from TAPI. If your modem manufacturer provides its 
own TAPI modem or PBX driver and the appropriate INF file, or you 
are able to obtain SDM-format caller ID, you might have more 
success.
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Phone Number Matching with TAPI

When Maximizer uses TAPI to detect an incoming phone call, it 
matches the phone call to a Maximizer Address Book entry and logs 
the call as a note for the entry. Depending on your TAPI 
configuration in Maximizer, it uses either the “Smart Phone Number 
Matching” or “Exact Phone Number Matching” algorithm to 
determine which Address Book entry matches the incoming phone 
number.

Smart Phone Number Matching

By default, Maximizer uses the Smart Phone Number Matching 
algorithm to determine which Address Book entry matches the 
incoming call.

When a call comes in, Smart Phone Number Matching looks for all 
Address Book entries with phone numbers ending with the incoming 
phone number string and displays those Address Book entries in a list 
so you can select the correct entry.

For example, if the incoming phone number string is four digits, 
Maximizer displays a list of all Address Book entries ending in those 
four digits.

Smart Phone Number Matching matches the digits from right to left. 
The number of matched digits required for matching is equal to the 
shorter length of the two phone numbers.

The following table illustrates Smart Phone Number Matching for 
four-digit and seven-digit incoming phone numbers.

Address Book entry 
phone number

Does the incoming 
four-digit phone 
number (2314) 
match?

Does the incoming 
seven-digit phone 
number (732-2314) 
match?

9-604-732-2314 Yes Yes

1-604-732-2314 Yes Yes

403-732-2314 Yes Yes

732-2314 Yes Yes

497-2314 Yes No

2314 Yes Yes

3514 No No

14 Yes Yes
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Exact Phone Number Matching

If you select the “Enable exact number matching” checkbox in the 
TAPI preferences in Maximizer, it uses the Exact Phone Number 
Matching algorithm instead of Smart Phone Number Matching. Exact 
Phone Number Matching considers an Address Book entry to match 
the incoming call only if both numbers contain exactly the same 
phone number with the specified number of digits.

By default, Exact Number Matching requires both phone numbers to 
be seven digits, but you can change the required number of digits.

The advantage of Exact Phone Number Matching is that when 
Maximizer finds an Address Book entry that matches exactly, you do 
not need to select it from a list of possible matches, as you do with 
Smart Phone Number Matching.

The following table illustrates Exact Phone Number Matching for 
four-digit and seven-digit incoming phone numbers.

Configuring Maximizer to Use TAPI

Before you can configure Maximizer to use TAPI, you must have a 
TAPI-enabled telephone system, and your computer’s modem must 
be configured to use TAPI. You can configure your modem for TAPI 
through the Windows Control Panel (Control Panel > Phone and 
Modem Options > Advanced tab). For more information, refer to 
your TAPI system and Windows documentation.

➤ To configure Maximizer to use TAPI

� Select File > Manage Users.

� Select the Maximizer user, and click Preferences.

Address Book entry 
phone number

Does the incoming 
four-digit phone 
number (2314) 
match?

Does the incoming 
seven-digit phone 
number (732-2314) 
match?

9-604-732-2314 No No

1-604-732-2314 No No

403-732-2314 No No

732-2314 No Yes

497-2314 No No

2314 Yes No

3514 No No

14 No No
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� Select the Dialing tab.

� Under Method, select TAPI.

� Under TAPI, click Properties.

� Fill in your location information, and click OK to return to the 
Dialing Preferences.

� Click Device.

	 From the Line drop-down list, select the TAPI device name, and 
click OK.


 Select the Detect incoming calls option.
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��If desired, select the Enable exact number matching option, 
and specify the number of phone number digits to match.

��Click OK to close the Preferences dialog box.
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Phone Masks
The registry entry (HKEY_CURRENT_USER\Software\Maximizer 
Software\Maximizer\Modules\AMGR\INTL\Phone Mask) overrides the 
default format of a phone number with the phone mask provided as 
a value. The mask uses # to indicate digits and can include any other 
characters (e.g., + - ,). If the Phone Mask registry key does not exist, 
you must create it as a String value.

Exercise caution when working 
in the Windows Registry.

The mask formats from right to left. For example, if the phone mask 
value is ###-####, but a user enters a 10-digit phone number (e.g., 
1234567890), the result would be formatted as 123456-7890. If the 
value has fewer digits than the mask allows, the extra (left-most) 
placeholders are not used.

The following table shows how some examples of how phone 
numbers are displayed using phone masks:

The Phone Mask value affects the display of phone numbers in 
Maximizer program dialog boxes and window lists. The Phone Mask 
value is read during program startup.

Phone Mask Digits Value Typed In Value Displayed

Not specified 7 1234567 123-4567

“ 10 1234567890 123456-7890

###-#### 7 1234567 123-4567

“ 10 1234567890 123456-7890

(###) ###-#### 7 1234567 123-4567

“ 10 1234567890 (123) 456-7890

+1 (###) ###-#### 7 1234567 123-4567

“ 10 1234567890 +1 (123) 456-7890

### ## ####-###### 15 123456789012345 123 45 6789-012345
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Using Fax Software with Maximizer
Visit the Maximizer website at 

www.maximizer.com to obtain 
an updated list of supported 
fax applications.

You can set up Maximizer for faxing anytime after you have installed 
the fax modem and fax application.

To fax any document with Microsoft Fax, simply select the fax driver 
in place of a printer when you print the document. The Maximizer 
Word Processor also supports merging directly to faxing software, 
which enables you to perform broadcast faxing.

For information about setting up Microsoft Fax, refer to your 
Windows operating system documentation.
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Introduction to Web Access
The Maximizer CRM Server 

setup program installs and 
registers several machine-level 
COM DLLs and sets up some 
machine-level registry settings. 
If you are moving Maximizer 
Web Access to a different 
server, ensure you run the 
setup program again.

Maximizer Web Access, Customer Access, Partner Access, and 
Wireless Access are installed automatically with Maximizer CRM 
Server. Maximizer web access sites provide web browser access to a 
Maximizer Address Book from any Internet-connected computer or 
hand-held wireless device.

The Maximizer CRM Server installation provides the option to install 
Start Menu shortcuts to the sites. These links are intended to connect 
to Maximizer Web Access Administrator for the convenience of 
internal users. Only one instance of a Partner Access and one instance 
of a Customer Access can be set up for this quick access for each 
Address Book. To set it up, log into the Address Book you want to set 
up in Maximizer Administrator, select File > Web Access > Shortcuts, 
and enter the URL to be accessed on the relevant line. Both the 
Partner Access URL and the Customer Access URL can be specified 
here.

Maximizer Web Access can be configured in many different ways. 
Refer to the Maximizer knowledge base for information on setting 
up Maximizer Web Access in different environments.

Site Types

There are several site types, each with a different purpose and 
functionality. The site types are described below.

Maximizer Web Access

Maximizer Web Access is a browser-based application providing the 
functionality of Maximizer over the Internet. Employees can work 
with Address Book entry information, notes, calendar appointments, 
Hotlist tasks, user-defined fields, and opportunities, as well as view 
company documents and other pertinent information.

• Local path: C:\Program Files\Maximizer\Portals\Employee

• Virtual folder: http://<server name>/MaximizerWebAccess

• Main login URL: http://<server name>/MaximizerWebAccess/
Default.aspx



Chapter 8
Configuring Web Access

195
Wireless Access

Wireless Access provides access to Maximizer through any wireless 
Internet-enabled device. When users open Wireless Access from the 
Windows Start menu, a URL displays. Users enter this URL into a 
handheld device to access Wireless Access.

• Local path: C:\Program Files\Maximizer\Portals\Wireless

• Virtual folder: http://<server name>/MaximizerWireless

• Main login URL: http://<server name>/MaximizerWireless/

Partner Access

Partner Access is a browser-based application providing a two-way 
flow of information between your organization and its business 
partners. This medium allows for a multi-tier distribution group to 
effectively distribute sales opportunities and keep all involved parties 
informed.

All aspects of the site are administered with a separate web access 
administrator application.

• Local path: C:\Program Files\Maximizer\Portals\Partner

• Virtual folder: http://<server name>/MaximizerPartner

• Main login URL: http://<server name>/MaximizerPartner/
Default.aspx

• Administrator login URL: http://<server name>/
MaximizerPartner/Admin/Default.aspx

The following third-party applications are installed with Customer 
and Partner Access, and are available from the Windows Start menu:

• Excentrics World Components

• Microsoft Internet Explorer WebControls

Customer Access

Customer Access is similar to Partner Access. It’s a browser-based 
application providing a two-way flow of information between your 
organization and its customers. Customers have access to news and 
events.

Like Partner Access, the site is administered with a web access 
administrator application. This is separate from the main site.

• Local path: C:\Program Files\Maximizer\Portals\Customer

• Virtual folder: http://<server name>/MaximizerCustomer
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• Main login URL: http://<server name>/MaximizerCustomer/
Default.aspx

• Administrator login URL: http://<server name>/
MaximizerCustomer/Admin/Default.aspx

The following third-party applications are installed with Customer 
and Partner Access, and are available from the Windows Start menu:

• Excentrics World Components

• Microsoft Internet Explorer WebControls

Supported File Types in Company Library and Documents

The following document types are supported in the Company Library 
and Document window of the web access sites:

• .DOC and .RTF (Microsoft Word)

• .XLS (Microsoft Excel)

• .PPT (Microsoft PowerPoint)

• .HTM and .HTML

• .BMP (bitmaps)

• .TXT (text files and Company Library notes)

• .JPG, .GIF, and .TIF (graphics files)

• .PDF (Adobe Portable Document Format)

You can add support for other file types using Microsoft Internet 
Information Services (IIS) Manager. For more information, see 
“Adding Support for File Types” on page 25.
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Enabling Web Access Sites
By default, all Maximizer web access sites are disabled. Enabling a 
site is a simple process, which must be completed before anybody can 
access them. You can activate them during installation, or modify the 
Web.Config file for each site you want to enable. To enable a site 
during installation, see “Installing Maximizer CRM Server” on 
page 38.

➤ To enable a site via the Web.Config file

� Open the site’s Web.Config file in a text editor, such as 
Notepad. 

The Web.Config file is located on the Maximizer server at the 
following path:

C:\Program Files\Maximizer\Portals\<site>\Web.Config

If Maximizer was installed in a folder other than the default 
location of C:\Program Files\, replace that portion of the path 
with the folder where Maximizer was installed.

� In the appSettings section, locate the Enabled key, which is 
shown below:

<add key=”Enabled” value=”false” />

� Change the value to true, as show below:

<add key=”Enabled” value=”true” />

� Save the Web.Config file.

Note that if you are using Windows 2008, you must also select the 
“Detailed errors” option in IIS. This setting is found under Error 
Pages > Edit Feature Settings.
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Escona Tutorial Sample Sites
The IIS Server must be started 

for the sites to function.
The Escona Tutorial Address Book includes sample web access sites. 
The sample sites, Maximizer Web Access, Customer Access, and 
Partner Access, require no configuration and are accessible from the 
Maximizer folder on the Windows Start menu. These sample sites are 
installed on the Maximizer IIS Server as part of the Maximizer 
Components for Microsoft IIS installation. 

You can access the sample sites using the following user IDs and 
passwords.

This section steps you through the following procedures with the 
Escona Tutorial sample sites:

• “To start the Default Web Site” on page 199

• “To access Escona Tutorial Maximizer Web Access” on page 202

• “To change a site to an application” on page 199

• “To access Escona Tutorial Customer or Partner Access 
Administrator” on page 203

• “To enable Address Book entries to access the site” on page 244

• “To access Escona Tutorial Customer or Partner Access” on 
page 204

Many of these procedures also apply to your own sites.

Sample Site User ID Password

Maximizer Web Access Administrator master control

Maximizer Web Access jnapoli maximizer

Customer Access Administrator jnapoli maximizer

Partner Access Administrator jnapoli maximizer

Customer Access mary password

Partner Access paul password

Wireless Access jnapoli maximizer
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➤ To start the Default Web Site

Before accessing the sample 
sites, ensure that the Default 
Web Site is started.

� On the Maximizer IIS Server, select Start > Programs > Control 
Panel > Administrative Tools > Internet Information 
Services Manager.

� Select Default Web Site, and click the Start item button.

When the Start item button becomes dimmed, the Default Web 
Site is started, and you can access the sites.

➤ To change a site to an application

Do not use this procedure 
unless you received a “Server 
Error in “/” Application” error 
when you opened the site.

� On the Maximizer IIS Server, select Start > Programs > Control 
Panel > Administrative Tools > Internet Information 
Services Manager.

� Open the Default Web Site branch.

�

�
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� Right-click MaximizerWebAccess, and click Properties.

� Click Create.

Maximizer Web Access has now been converted to an 
application.

� Click OK and then close Internet Information Services.

�

�

�
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Escona Tutorial Maximizer Web Access Administrator

➤ To access Escona Tutorial Maximizer Web Access 
Administrator

� Select Start > Programs > Maximizer CRM > Web Access > 
Maximizer Web Access Administrator.

You can access Maximizer 
Web Access Administrator 
from Maximizer Web Access. 
In the left navigation pane, 
hover your mouse over 
Administration and select 
Administrator from the pop-up 
window.

The Maximizer Web Access Administrator login page opens.

� Log into the site using the following login information:

User ID = MASTER

Password = control

�
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Escona Tutorial Maximizer Web Access

➤ To access Escona Tutorial Maximizer Web Access

� Select Start > Programs > Maximizer CRM > Web Access > 
Maximizer Web Access.

The Maximizer Web Access login page opens.

If the Maximizer Web Access 
login page does not open, and 
you see a “Server Error in “/” 
Application” error message, 
then you need to change the 
site to an application. See “To 
change a site to an 
application” on page 199.

� Log into the site using the following login information:

User ID = JNAPOLI

Password = maximizer

Escona Tutorial Wireless Access

➤ To access Escona Tutorial Wireless Access

� On your wireless device, open a web browser.

� In the Address bar, enter the URL of the Wireless Access site:

http://<server name>/MaximizerWireless/

� Log into the site using the following login information:

User ID = JNAPOLI

Password = maximizer
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Escona Tutorial Customer and Partner Access Administrator

➤ To access Escona Tutorial Customer or Partner 
Access Administrator

� On the server, select Start > Programs > Maximizer CRM > 
Web Access > Customer Access or Partner Access. 

The Maximizer Customer or Partner Access Viewer opens.

� Select Escona Tutorial, and click View.

The Customer/Access Partner Administrator login page opens.

� Log into Customer/Partner Access Administrator:

User ID = JNAPOLI

Password = maximizer

Customer/Partner Access Administrator opens, with either or 
both of the News Manager and Configuration Manager links 
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available, depending on which web access security groups you 
belong to. 

The News Manager link is 
available only if you are logged 
in with a User ID belonging to 
the Customer or Partner 
Access Administration Users 
security group. The 
Configuration Manager link is 
available only if you are logged 
in with a User ID belonging to 
the Customer or Partner 
Access Configuration Users 
security group.

For information about web access security groups, refer to “Web 
Access Security Groups” on page 215.

➤ To create a site PIN for the sample sites

• Refer to “Assigning Site Login PINs to Contacts and Individuals” 
on page 246 for an explanation of how to create a site PIN for 
yourself. When you are creating the PIN for the Escona Tutorial 
sample sites, modify the email address and category of one of 
the Address Book entries, so you can use that Individual or 
Contact as your site user account:

• Email Address: When you are creating a customer and/or 
Partner Access login account for the Escona Tutorial sample 
sites, enter your own email address into a sample Contact or 
Individual’s Address Book entry. Then, when you send a site 
PIN email, it sends the PIN to your email address instead of to 
the fictional email address in the sample database. 

• Category: Select both the Customer and Partner categories 
in the Address Book entry.

Escona Tutorial Customer and Partner Access

➤ To access Escona Tutorial Customer or Partner 
Access

� Select Start > Programs > Maximizer CRM > Web Access > 
Customer Access or Partner Access. 

The Maximizer Customer or Partner Access Viewer opens.

� Select Escona Tutorial, and click View.

The login page opens.

� Click the View Customer/Partner Access Site link.
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� Log in to the site.

To log into the sample Partner Access site, use the sample 
Address Book contact, Paul Samson of Samson Consulting:

• User ID = paul

• Password = password

To log into the sample Customer Access site, use the sample 
Address Book contact, Mary Smart of Acme Tool Co.:

• User ID = mary

• Password = password

Customer or Partner Access opens.

�
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Application Settings for Web Access Sites 
The XML-formatted Web.config file, stored in the ...\Program 
Files\Maximizer\Portals\<site> folder, is the key to configuring the 
sites and any other ASP.NET web application.

You can edit this file using Windows Notepad or another text editor. 
For Windows 2003 Server or later, you can also edit the settings in 
Internet Information Services (IIS) Manager on the ASP.NET tab of 
the site’s properties. 

The Partner Access and Customer Access sites are configured to 
connect to a single Address Book each. Which Address Book the site 
connects to is defined in a file called Web.config, which is located in 
the root folder of the Partner and Customer folders (which are 
located in ...\Program Files\Maximizer\Portals\). Initially, the 
Web.config file is configured to connect to the Escona Tutorial 
sample Address Book. Before you deploy Partner Access or Customer 
Access, you must update the Web.config file for your Address Book. 

After you have deployed Web, Wireless, Customer or Partner Access 
for your Address Book, you can make further changes to the 
Web.config file at any time. You are not required to restart the IIS 
service for changes to take effect.

➤ To configure the external site application settings 

� Browse to the Web Access folder where you have installed 
Maximizer Components for Microsoft IIS (...\Program 
Files\Maximizer\Portals\<site>\).

� Open the Web.config file in the Employee, Customer, or Partner 
folder. Note that the following application settings do not apply 
to all web access sites.
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Site Application Settings <appSettings>

It is optional to change these 
application settings with the 
exception of the Enabled 
setting. This value must be set 
to true in order make the site 
accessible.

You can update any of the site application settings values if they 
appear under the appSettings parent node. The settings that appear 
in the Web.config file are dependant on the Web Access application 
that it is associated with.

Child Description

<add key="AddressBook" 
value="name" />

The name is the true name of the 
Address Book. See ‘AddressBook” 
on page 210.

<add key= 
”AddressBookColumnSetup” 
value=”user/Address Book 
window column setup name” />

Specifies a specific column setup 
to be used for the Address Book. 
Only the first two columns of a 
column setup can be displayed 
(from left to right). The user 
specified in this setting is the 
creator of the column setup. This 
setting is optional. 

<add key=“AlarmCheckPeriod_
Seconds” value=“x”>

The site will check for alarms every 
x seconds.

<add key= 
“AlternateRequiredCategory” 
value=“”>

To access the Partner or Customer 
portal, an entry must have a 
category of Partner or Customer, 
respectively. This can be changed. 
See ‘AlternateRequiredCategory” 
on page 210

<add key="CheckWebBrowser" 
value="true" /> 

Verifies if your current web 
browser is Internet Explorer. If you 
are not using Internet Explorer, 
you are prompted with a message. 
This setting is optional.

<add key=“Context” 
value=”MA_PARTNER”>

The only difference between the 
default Partner Access site and the 
default Customer Access site is the 
value in the Context key. See 
‘Context” on page 209.

<add key= 
"CSCaseColumnSetup" 
value="user/Customer Service 
window column setup name" />

Specifies a specific column setup 
to be used for customer service 
cases. Only the first two columns 
of a column setup can be 
displayed (from left to right). The 
user specified in this setting is the 
creator of the column setup. This 
setting is optional.
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<add key= 
“DefaultAddressBook” 
value=“name” />

The name is the true Address Book 
name, rather than the “friendly” 
name, meaning it does not 
contain spaces or special 
characters.

<add key=”Enabled” 
value=“true”>

By default, sites are disabled, and 
you must change the Enabled 
setting to “true” before you can 
use the sites. 
Setting Enabled to “false” 
instantly stops new visitors to the 
site from being allowed to log in, 
while allowing already-logged-in 
visitors to continue with their 
session.

<add key= 
"EnableOutlookIntegration" 
value="true" /> 

The value must be set to true to 
enable Microsoft Outlook 
integration with Maximizer Web 
Access. Note that this integration 
applies to Outlook 2003 and 
higher. 
See ‘EnableWordIntegration/
EnableOutlookIntegration” on 
page 210

<add key= 
"EnableWordIntegration" 
value="true" /> 

The value must be set to true to 
enable Microsoft Word 
integration with Maximizer Web 
Access. Note that this integration 
applies to Word 2003 and higher. 
See ‘EnableWordIntegration/
EnableOutlookIntegration” on 
page 210

<add key= 
NotificationCheckPeriod_ 
Seconds” value=“x”>

The site will check for 
notifications every x seconds.

<add key= 
“OpportunityColumnSetup” 
value=”user/Opportunity 
window column setup name” />

Specifies a specific column setup 
to be used for Opportunities. Only 
the first two columns of a column 
setup can be displayed (from left 
to right). The user specified in this 
setting is the creator of the 
column setup. This setting is 
optional.

Child Description
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Context

The only difference between the default Partner Access site and the 
default Customer Access site is the value in the Context key. The two 
possible values for this key are MA_PARTNER and MA_CUSTOMER. 
This key determines the following settings:

• The default graphic for the main login page can be replaced 
with a custom graphic. For more information, see “Customizing 
the Graphic on the Site Main Page” on page 251. 

• The groups controlling access to the administration-side of the 
sites (Customer Access Administration Users / Partner Access 
Administration Users and Customer Access Configuration Users / 
Partner Access Configuration Users)

• The default name of the site —“Partner Access” and “Customer 
Access”. These names can be overridden with the Name setting 
under General Settings in the Configuration Manager.

• The default name of the type of user accessing the site. For 
example, when logged into Partner Access, Paul Samson could 
expect to see “Partner: Paul Samson” at the top of the screen. 
This name may be overridden with the Name setting under 
General Settings in the Configuration Manager.

SubContext

The SubContext key is provided to implement more than one of a 
certain type (context) of site. Application settings within an external 
site’s Configuration Manager are stored in the Address Book (in the 
ADMN_Config table) referencing the site’s Context and SubContext 
keys.

If you would like two Customer Access sites, each with their own 
application settings, you would give both instances a Context value 
of MA_CUSTOMER, but make sure each instance has a different 
value for SubContext. For example, give one a value of WINE and 

<add key= 
”ShowAllPhoneNumberAndEma
il”value=”false” />

This setting can be set to true and 
it is an optional setting. All phone 
numbers and email addresses are 
displayed in the appointment 
dialog box if this is set to true.

<add key=“SubContext” value= 
“name”>

The SubContext key is provided to 
implement more than one of a 
certain type (context) of site. See 
‘SubContext” on page 209.

Child Description
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one a value of BEER if you were in the business of selling both 
products but wanted a different site for each customer base.

If, however, you were setting up the application across two servers in 
a load-balancing scenario, you would give each version of the 
application the same value for SubContext because you’d want 
each instance to share one set of application settings.

AddressBook

The AddressBook key must be set with the database name of the 
Address Book to use for this site. Note that this is not the friendly 
name for the Address Book set in Administrator to reference the 
Address Book but the actual SQL database name. It makes a specific 
Address Book accessible for customers and partners and it must be 
set to enable the sites for access. 

AlternateRequiredCategory

In Maximizer CRM, membership in a segment of the Address Book is 
specified using an Address Book entry’s Category field. By default, 
Partner Access requires accessing visitors to have a Category of 
Partner, and Customer Access requires accessing visitors to have a 
Category of Customer. These defaults may be overwritten, however, 
by setting a different value in the AlternateRequiredCategory key. 
The company implementing Beer Customer Access and Wine 
Customer Access would add items for each site to the Category field 
in Maximizer, and then reference the required item’s name in the 
AlternateRequiredCategory key for each site.

EnableWordIntegration/EnableOutlookIntegration

If the Word or Outlook integration is enabled, users can set up the 
integration directly from Maximizer Web Access. The setup involves 
downloading Active X controls, which may be disallowed on some 
networks. To disable Word or Outlook integration, change the value 
to “false”.
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Session State Storage Options <sessionState>

By default, the applications are configured to store session identifiers 
in a cookie and to use a timeout value of twenty minutes. The 
sessionState section of the Web.config file can be used to 
alternatively employ a state server facilitating load balancing or a 
variety of other configurations. See Microsoft documentation on 
session state options for more information.

Maximizer ships Wireless, Customer, and Partner Access with the 
following default sessionState section. You may modify it to meet 
your needs. 

Option Description

mode For load balancing two IIS 
machines to handle high traffic 
for an application, give each 
server the same IP address, and 
employ a third server to act as a 
state server. To designate the 
state server, enter this third 
server’s IP address in the 
stateConnectionString key and 
change the mode to StateServer 
and set cookieless to true. For 
performance reasons, it’s not 
recommended to set a local 
machine as the state server, 
unless you want to eliminate the 
need for cookies in a single-IIS 
environment. 

stateConnectionString

cookieless

timeout Change the session timeout 
value by changing the timeout 
element to another specified 
number of minutes. This setting 
is optional.
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Outlook Integration Options <httpRuntime>

The settings that control the Outlook integration options for Web 
Access are located in a Web.config file in the services folder 
(...\Program Files\Maximizer\Portals\Employee\Services\). The 
following is a description of the httpRuntime settings that control 
various aspects of the Web Access Outlook integration.

Option Description

maxRequestLength The value following 
maxRequestLength is the size, in 
kilobytes, of the largest email 
(including the size of all 
attachments) that can be saved. It 
is advisable to set this number to 
twice the desired maximum size, 
since temporary encoding can 
require a larger request size. For 
example, if your email system 
allows attachments up to 20 MB in 
size, set maxRequestLength to 
"40000" to allow the largest 
emails to be saved.

executionTimeout The value following 
executionTimeout is the maximum 
number of seconds a request to 
save an email is allowed to take 
before an error occurs. The 
default is 10 minutes (600 
seconds).
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Setting Up Windows Authentication for Web Access
In addition to specifying Windows Authentication as the means of 
user authentication during the installation, you must follow 
additional steps to set up Windows Authentication for Web Access.

The following sections contain information on setting up Windows 
Authentication for Web Access sites:

• “Setting Up Windows Authentication for Web Access in SQL” on 
page 213

• “Configuring the Web.config files for Windows Authentication 
for Web Access” on page 213

• “Downloading Documents” on page 214

• “Configuring IIS for Windows Authentication for Web Access” 
on page 214

Setting Up Windows Authentication for Web Access in SQL

➤ To set up Windows Authentication for Web Access 
in SQL

� In SQL Server Management Studio, on the Security tab of the 
SQL server properties, select Windows Only as the type of 
authentication. 

� Set the USE_NT_AUTHENTICATION key to YES in the MaConfig 
table for each Address Book.

Configuring the Web.config files for Windows Authentication for Web Access

You must configure the Web.config file in the web access sites to use 
Windows Authentication. The procedure is different depending on 
which web access site you are configuring.

➤ To configure the Maximizer Web Access, Maximizer 
Web Access Administrator, or Wireless Access 
Web.config file for Windows Authentication

• Set the authentication setting to true as follows:

<authentication mode="Windows"/> <identity 
impersonate="true"> 
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➤ To configure the Customer Access or Partner Access 
Web.config file for Windows Authentication

� Set the authentication setting to true as follows:

<identity impersonate="true"> 

� Append the authentication setting with the IUSR machine name 
and password as follows:

<identity impersonate="true" 
userName="IUSR_MachineName" 
password="IUSR_password"> 

The username and password are for a user to run under the 
external site login. This user needs SQL permission equal to 
WEBUSER, and file permissions equal to NETWORK SERVICE. File 
permissions apply to the portal (web access site) folder, and to 
the following folder:

C:\WINDOWS\Microsoft.Net\Framework\v2.0.50727\Temporary 
ASP.NET Files.

Downloading Documents

To allow users to download documents, users must be able to access 
the IIS metabase and other directories used by ASP.NET.

➤ To set up access the IIS metabase and other 
directories used by ASP.NET. 

� Create a group on the IIS machine.

� Add the domain users or domain groups to the group on the IIS 
machine.

� Run the following command in the command line. The command 
is located in the 
c:\Windows\Microsoft.NET\Framework\v2.0.50727\ folder. 
Replace group_name with the name of the group you created.

aspnet_regiis -ga “group_name”

Configuring IIS for Windows Authentication for Web Access

The procedure for configuring Microsoft Internet Information 
Services (IIS) for Windows Authentication is different depending on 
the version of Windows Server you are using. For detailed 
information on configuring Microsoft IIS for Windows 
Authentication, see “Microsoft IIS for Windows Authentication” on 
page 22.
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Web Access Users and Security Groups
The following sections describe how to configure users in Maximizer 
to access web access sites:

• “Web Access Security Groups” on page 215

• “Web Access Users” on page 218

Web Access Security Groups

Every Address Book contains several web-access-related security 
groups, which are described in the following table. The MASTER user 
belongs to these groups by default, but you can add additional users 
to each group as required.

The Company Announcements 
Authors security group does 
not apply to sites.

Every security group has a name and an ID. Changing the name has 
no effect on the group functionality. However, you cannot change 
the group ID. If you ever need to recreate these security groups, it is 
imperative that you use the correct security group IDs (the group 
name is irrelevant).

To be able to access Customer or Partner Access Administrator, a user 
must belong to at least one of the Administration Users or 
Configuration Users security groups for that site. 

Security Group Name Group ID
Enables group members to 
access the...

Customer Access Admin 
Users

C_ADM News Manager section of 
Customer Access 
Administrator

Customer Access Config 
Users

C_CFG Configuration Manager 
section of Customer Access 
Administrator

Maximizer Web Access 
Admin Users

EMPADM Edit section of Maximizer 
Web Access, where the user 
can update external links

Partner Access Admin 
Users

P_ADM News Manager section of 
Partner Access 
Administrator

Partner Access Config 
Users

P_CFG Configuration Manager 
section of Partner Access 
Administrator
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➤ To add a user to a site security group

� In Administrator, select File > Security Groups and Teams.

� Select the security group, and click Properties.

For specific information about 
each of these Access Settings, 
refer to “User and Group 
Security” on page 73.

� Set the appropriate Access Settings for the group members.

� Click the Members tab.
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� Select a member to add to the group, and click Add. Repeat this 
process for all members to add to the group.

– or –

Click Add All to add all users to the group.

� Click OK to close dialog boxes.

� Repeat this procedure to add users to the other site security 
groups.

The selected users can now log into the site and access the 
functions available to their security group(s).
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Web Access Users

Address Book users are enabled to access the web access sites by 
default. However, you can change user access to sites in the user’s 
general properties if required. The “Web Access” access right in User 
Properties applies to all sites.

➤ To set web access rights

� In Administrator, select File > Manage Users.

� Select the Maximizer user, and click Properties. 

� In the Module Login section (bottom right), select Web 
Access.

� From the drop-down list, select Enabled or Disabled. 
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Maximizer Web Access
Maximizer Web Access is functional automatically for all Address 
Books. Anybody with a user account for that Address Book can access 
it immediately, provided that the IIS Server is running and the “Web 
Access Login” right has not been disabled in the user’s account. (For 
more information about the “Web Access Login” right, refer to 
“Web Access Users” on page 218.)

Maximizer Web Access 
settings follow the Maximizer 
Address Book settings in 
Administrator.

On the IIS Server, you can access the sites from the Windows Start 
menu (Start > Programs > Maximizer CRM > Web Access). Other 
computers can access Maximizer Web Access with the following URL 
(unless it has been changed from the default):

http://<IIS_Server_Name>/MaximizerWebAccess/Default.aspx

The following sections contain information specific to Maximizer 
Web Access:

• “Creating External Links in Maximizer Web Access” on page 219

• “Passing a Search String Parameter to the Login Page” on 
page 220

• “ActiveX Controls in Maximizer Web Access” on page 221 

Creating External Links in Maximizer Web Access

To customize external links available on Maximizer Web Access, you 
must log into the site as the MASTER user, or as a user who belongs 
to the Maximizer Web Access Administration Users security group. 
(For information on this security group and how to add users to it, 
refer to “Web Access Security Groups” on page 215.)

➤ To create external links on Maximizer Web Access

� Log into Maximizer Web Access as MASTER or as a user who 
belongs to the Maximizer Web Access Admin Users security 
group.

� In the left navigation pane, hover your mouse over Links, and 
select Edit from the pop-up window.
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In Maximizer Web Access, an 
external link must be a URL.

� Add, edit, or remove any groups or links as desired.

� Click Close to finish.

The External Links section of the Maximizer Web Access main 
page now reflect the changes you just made.

Passing a Search String Parameter to the Login Page

You can pass a search string parameter to the login page to display a 
search after logging in to Maximizer Web Access. The Address Book 
page is opened directly after successfully logging in—the My Work 
Day page and the Choose Address Book List dialog box is bypassed. 

➤ To add a search string parameter to the Login Page

Append the Maximizer Web Access URL with the search string 
parameter. Note that the search string must be URL encoded. 
Following are some examples of the search string that you can use in 
the URL:

• To retrieve a Favorite List from the Address Book

http://[server name]/MaximizerWebAccess/
default.aspx?ss=FLIST%28[Favorite list key]%29

e.g., http://[server name]/MaximizerWebAccess/
default.aspx?ss=FLIST%288cFOcdn15sZIuP9HO7lucIrMRGl892Gp
%29 

The above search retrieves the “All entries in Escona” Favorite 
List in the Escona Tutorial Address Book.

• To retrieve a particular company and its associated 
contacts from the Address Book
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http://[server name]/MaximizerWebAccess/
default.aspx?ss=EQ%28ClientID%2c[Identification]%29

Note that the [Identification] can be found in Properties of the 
ABEntry > Identification.

e.g. http://[server name]/
MaximizerWebAccess?ss=EQ%28ClientID%2c37266200083%29

A simple way to build your search string is by copying the search 
source code from Maximizer Web Access directly following a search 
performed in the Address Book page. 

➤ To use source code from Maximizer Web Access

� Perform a search in Maximizer Web Access.

� Immediately following the search, right-click in Internet 
Explorer, and choose View Source.

� Copy the first line of source code shown at the top of the 
window prefixed by http://[server name]/
MaximizerWebAccess?ss= as shown above in the examples. 

For more information on Maximizer search string language, refer to 
“Search String Language” on page 406.

ActiveX Controls in Maximizer Web Access

Maximizer Web Access uses an ActiveX control for its integrations 
with Microsoft Office products, including Microsoft Word, Microsoft 
Excel, and Microsoft Outlook. These integrations are supported only 
in Microsoft Internet Explorer.

If your web server configuration includes a firewall, you may need to 
configure the firewall to allow the MaThinIEActiveX.ocx file to be 
downloaded from the server. The MaThinIEActiveX.ocx file is an 
ActiveX control used to run the Export to Excel command and to 
install the Word and Outlook integrations in Maximizer Web Access.
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Maximizer Web Access Administrator
For login information, go to 

“Escona Tutorial Maximizer 
Web Access Administrator” on 
page 208.

Use Maximizer Web Access Administrator for the following tasks: 

• Create and configure Address Books

• Manage users, sales/marketing teams, and security groups

• Manage Maximizer application settings

The following sections contain information on using Maximizer Web 
Access Administrator:

• “Database Management in Maximizer Web Access 
Administrator” on page 222

• “User-Defined Fields in Maximizer Web Access Administrator” 
on page 223

• “Address Book Preferences in Maximizer Web Access 
Administrator” on page 228

• “Users in Maximizer Web Access Administrator” on page 232

• “Security Groups in Maximizer Web Access Administrator” on 
page 234

• “Teams in Maximizer Web Access Administrator” on page 236

• “MaxMobile Administration in Maximizer Web Access 
Administrator” on page 237

Database Management in Maximizer Web Access Administrator

Use this module to add a new Address Book, open an existing 
Address Book, or delete an Address Book.

When you create a new Address Book, Administrator sets up a new 
SQL database and the required Data Source Names (DSNs) for the 
Address Book. 

➤ To create a new Address Book

� Click the New Address Book link.

� Enter your SQL Server user ID and password.

�  Click OK. The Add a New Address Book dialog box opens.

� Enter an Address Book name and a Database name.

Both the Address Book name and the Database name must start 
with a letter. After that, you can use letters, numbers, spaces, 
and underscores for the Address Book name. For the Database 
name, you can use letters, numbers, and underscores.
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� If necessary, select a different database collation from the drop- 
down list. 

� Click Save.

➤ To open an Address Book

� Click the Open Address Book link.

� Select the Address Book you want to open from the Address 
Book drop-down list.

� Enter the user ID and password for the Address Book.

� Click Log In.

➤ To delete an Address Book

�  Click the Delete Address Book link.

� Select the Address Book you want to delete from the Address 
Book drop-down list.

� Enter the user ID and password for the Address Book.

� Click Delete.

� Click OK to confirm that you want to delete the Address Book. 
The Address Book is removed from the Address Book list.

User-Defined Fields in Maximizer Web Access Administrator

Use this module to display, add, modify, or delete user-defined fields. 
For information on the categories and types of user-defined fields, 
see “Setting Up User-Defined Fields for an Address Book” on 
page 118.

User Access Rights for User-Defined Fields

You can give any user the ability to add, modify, or delete user-
defined fields by enabling the following access rights: 

These two access rights are set 
on the Access Rights tab in the 
Users module. For more 
information, see “Users” on 
page 231.

• The User-defined fields access right enables the user to assign 
values to user-defined fields. 

• The User-defined field setup access right enables the user to 
create new user-defined fields. 

You can also restrict user access to a specific user-defined field in the 
Full access and Read access fields shown below. For more information 
on these fields, see “User Access Rights for User-Defined Fields” on 
page 119.
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Working in the User-Defined Fields Page

This section shows you how to:

• Select a user-defined field or folder in the tree view

• Move user-defined fields and folders

• Add, modify, and delete user-defined fields and folders

• Create a copy of a user-defined field

• Add items to a table user-defined field

• Delete items from a table user-defined field

To add, modify, or delete a user-defined field or folder, you must 
first click the link for the category of the user-defined field. For 
example, if you are creating a user-defined field for Address Book 
entries, click the Address Book link. 

, 

The User-Defined Fields for Address Book entries page opens. 

The fields and folder are organized in a tree view. There can be 
multiple levels of folders, each containing other folders or user-
defined fields. The folder structure allows a maximum of three folder 
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levels. You can move fields and folders by using the Move To, Move 
Up, and Move Down buttons.

➤ To select a user-defined field or folder in the tree view

• Click to the right of the field or folder name. The field or folder 
is now displayed in bold. 

➤ To move a user-defined field or folder

� Select the field or folder you want to move. 

� Click Move To and select the folder you want to move the field 
or folder to from the Folder drop-down list.

� Click Save.

➤ To reposition a user-defined field or folder 

� To move the field or folder up one position, click Move Up.   

� To move the field or folder down one position, click the Move 
Down. 

� To move the field or folder up one position, click Move Up.   

� To move the field or folder down one position, click the Move 
Down.   

➤ To add a new folder for user-defined fields

� To add a top-level folder, click Add Folder. 

– or –

To add a subfolder to an existing folder, select the existing 
folder and click Add Folder.

� Enter a name for the folder and click Save.
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➤ To add a new user-defined field

� Select the folder you want to add the field to.   

To add a field to the top-level 
folder, you don’t need to select 
the folder.

� Click the link for the type of user-defined field you are adding. 

For example, click Add alphanumeric to add an alphanumeric 
field. 

� Specify the user-defined field properties and click Save.

If you set a user-defined field 
or folder to hidden, you can 
hide the item from certain 
dialog boxes by deselecting 
the Show hidden fields option. 
Mandatory fields cannot be set 
to hidden. 

For more information on user-defined field types, see “Types of 
User-Defined Fields” on page 118. 

➤ To create a copy of a user-defined field

� Select the field you want to copy and click Save As. 

� Edit the field information as required and click Save.av 

➤ To add an item to a table user-defined field

� Select the table field you want to add an item to and click Items. 
The Table Items dialog box opens.
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� Click Add New Value. The Add a Table Item dialog box opens.

� Type a name for the table item.

� In the Requested by field, select the name of the user who 
requested the item creation.

If you set an item to hidden, 
you can hide the item from 
certain dialog boxes by 
deselecting the Show hidden 
fields option. 

� Click Save.

➤ To delete an item from a table user-defined field

� In the Table Items dialog box, select the checkbox beside the 
item you want to delete and click Delete.

� Click Yes to confirm that you want to delete the item.
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Address Book Preferences in Maximizer Web Access Administrator 

Use the Preferences module on the Administrator page to set 
defaults that apply to the entire Address Book.

The following table outlines the settings available for each page in 
the Preferences module:

On this page... You can set the following preferences...

Address Book • Values available in the Category field for 
Address Book entries.

Opportunities • Opportunity stages and probabilities of 
close.

• Opportunity confidence rating.
• Opportunity completion reasons.
• Opportunity monitoring.

Campaigns • Completion reasons.
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Customer Service • Customizable field values.

• Default case response time.
• Case monitoring.
• Default case status.
For additional information, refer to chapter 7 “Providing 

Customer Service” in the Maximizer CRM User’s Guide.

Key Fields • Key user-defined fields available on the 
Basic Information tab of Address Book 
entries, opportunities, campaigns, and 
customer service cases. For more 
information, refer to “Creating Key Fields 
Lists” on page 140.

System Fields • Add, modify, and delete note and document 
categories.

• Add, modify, and delete values of system 
fields, such as “Do not solicit by” and 
Products/Services.

Mandatory Fields • Mandatory or optional data entry 
requirements for basic fields in Address 
Book entries, customer service cases, 
campaigns, and opportunities.

Location/Resource • Locations available for appointments.
• Resources available for appointments.

Email Server Settings • Email server settings for incoming and 
outgoing email (IMAP and SMTP).

• Email address validation when sending an 
email message.

System Options • Determines if lists of groups/users display 
only groups to which the current user 
belongs and other users in the groups.
Use this setting to split a database so that 
users can work on the same address book 
without interfering with each other’s work.

• Fiscal year start month.

On this page... You can set the following preferences...
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Setting Preferences

In the left pane, click the link for the page that you want to work in 
(e.g., System Fields), or click the link on the main Preferences page. 
Once the page opens, you can view, add, modify, or delete items for 
the available fields. You can also perform tasks specific to a 
Preferences page. For example, in Key Fields, you can add, modify, or 
delete key field lists.

➤ To view an item

� In a Preferences page such as System Fields, click the plus sign to 
display the items for a field. 

� Review the current items and make changes if necessary. 

➤ To add a new item 

� With a field such as Address Book Notes Category expanded, 
click Add New Value. The Add Item dialog box opens.

� Fill in the required information and click Save. 

➤ To delete an item or group of items

� Select the checkbox beside each item you want to delete and 
click Delete.

� Click Yes to confirm that you want to delete the selected items. 
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➤ To create a key field list

� Click Add.

Click the Details link to show 
or hide the Description, 
Creator, Owner, and 
Requested by Fields.

� In the List Name field, enter a name for the key fields list. 
Optionally, enter a description.

� From the Owner drop-down list, select a user or security group 
to assign the key field to, or leave it as public.

� If required, select a user from the Requested by drop-down list.

� Select the type of Maximizer entry you want to assign fields to 
by clicking it, and then click the plus sign to display the available 
fields. To add a field to the Assign Fields list, select the 
checkbox beside it. Note that the Assign fields list displays only 
fields that are assigned to the selected entry type. 

Use the Move Up and Move 
Down links to position fields in 
the Assign Fields list. 

� Click Save.

Refer to Maximizer Web Access Administrator Help for information 
on editing and deleting key field lists. 

➤ To change mandatory field entry requirements

� In the Mandatory Fields preferences, select Modify Options.

� Click the plus sign beside the module name to display its 
associated fields.

� Select a field. If the field is optional, select Mandatory to make it 
mandatory on data entry. If the field is mandatory, select 
Optional to make it optional on data entry.
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Users in Maximizer Web Access Administrator

Use this module to manage all Maximizer users and their contact and 
password information. You can modify the properties and password 
of any user in the current Address Book.

 

To see additional user entries, click the page links at the lower-left of 
the main Users page. To search for a specific user, enter the user’s 
name or ID in the Search for box and click the Search button. To 
return all users to the list, click the Retrieve All Users button.

The following procedures show you how to add a user, modify a 
user’s properties, delete a user, change a user password, and set user 
preferences.

➤ To add a user to an Address Book

For more information on 
adding a user, see “Adding a 
User to an Address Book” on 
page 78.

�  Click Add. 

The Copy User’s Properties dialog box opens.

� To copy the properties from another user, select the user from 
the drop-down list. Deselect any properties you don’t want to 
copy. 
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If you don’t want to copy properties from another user, leave 
None selected in the drop-down list.

Click OK. The Add User dialog box opens.

�  On the General tab, enter information about the user.

� On the Access Rights tab, click Modify User Access Settings 
and modify the settings as required.

For information on setting user 
access rights, see “User and 
Group Security” on page 73. 

� On the Groups/Teams tab, add or remove groups and teams the 
user should belong to.

� Click Save. 

➤ To modify a user’s properties

For more information, see 
“User and Group Security” on 
page 84.

� Click the user ID of the user whose properties you want to 
modify. The Modify User dialog box opens.

� Make your changes and click Save.

➤ To delete a user from the Address Book

� Select the checkbox beside the user you want to delete and click 
OK. The Delete User(s) dialog box opens.
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� To transfer notes to another user, select the user from the drop-
down list and click Yes.

� To transfer cases to another user, select the user from the drop-
down list and click Yes.

➤ To change a user password

For more information, see 
““Changing a User’s 
Password” on page 83.

� Select the checkbox beside the user whose password you want to 
change and click Password. The Change Password dialog box 
opens.

� Enter the new password, confirm it, and then click Save.

➤ To set user preferences

For more information, see 
“User Preferences” on 
page 106.

� Select the checkbox beside the user whose preferences you want 
to set and click Preferences. The Users Preferences page opens.

� Set the user-related preferences on each of the tabs and click 
Save.

Security Groups in Maximizer Web Access Administrator

Use this module to create and modify security groups. When you 
create a security group, you assign it a name, select members of the 
group, and specify the security rights and privileges for group 
members. These security settings apply to all members of the group 
and are combined with security settings previously set for each user.
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➤ To create a security group

� Click Add. The Add Group dialog box opens.

� On the General tab, enter a group name and a unique group ID 
(up to nine characters). The first character of the group ID must 
be a letter. 

� Assign access settings to the group.

For more information on 
setting up security groups, 
see““Security Groups” on 
page 92. For information on 
access settings, see “User and 
Group Security” on page 84.

� Click the Members tab. 

� To add a user to the security group, select the checkbox beside 
the user and click Add. The user is added to the Members list.

� When you finish adding members, click Save.

➤ To modify a security group

�  Click the name of the group you want to modify. The Modify 
Group dialog box opens.

� Make your changes and click Save.

➤ To delete a security group

� Select the checkbox beside the security group you want to 
delete.

� Click Delete.
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Teams in Maximizer Web Access Administrator

Use this module to set up and modify sales and marketing teams. 
Note that although security cannot be assigned to sales or marketing 
teams, it can be applied to individual users who are members of the 
sales or marketing team.

➤ To create a new team

For more information on 
setting up teams, see “Sales 
and Marketing Teams” on 
page 99.

� Click Add. The Add Team dialog box opens.

� On the General tab, enter a team name.

� Select Sales or Marketing from the Type drop-down list.

� Click the Members tab.

� To add a user to the team, select the checkbox beside the user 
and click Add. The user is added to the Members list. 

� When you finish adding members, click Save.

➤ To modify a team

� Click the name of the team you want to modify. The Modify 
Team dialog box opens.

� Make your changes and click Save.
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➤ To delete a team

� Select the checkbox beside the team you want to delete.

� Click Delete.

MaxMobile Administration in Maximizer Web Access Administrator

Before users can use MaxMobile, the administrator must configure 
the wireless server in Administrator. The number of users allowed to 
use MaxMobile is controlled through your product license number.

➤ To configure MaxMobile Wireless Server

� Click the MaxMobile Administration link.

� Select Modify Options.

� Enter the URL of the MaxMobile Wireless Server. The URL should 
be in the following format:

http://[server_name]:port/MaxMobileService

https://[server_name]:port/MaxMobileService

� For all users, departments, divisions, security groups, and 
teams who will use MaxMobile, enable the check box beside the 
name from the MaxMobile users list and click Add to move the 
item to the Users selected for deployment list. This enables 
MaxMobile for these users as shown below in the Module Login 
section of a user’s properties. Select the user from the Users 
selected for deployment list and use the Remove button to 
remove an item from this list.

Note that you can also enable MaxMobile for users in the 
General tab of the Properties dialog box for a user.

If you are deploying MaxMobile by a wireless connection, see the 
MaxMobile Wireless Server Getting Started Guide.
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Wireless Access
As with the other sites, Wireless Access is installed automatically 
when you select the Maximizer Components for IIS option in the 
Server Components screen of the Maximizer installation. You must 
then enable the site as described in “Enabling Web Access Sites” on 
page 197. To access the site, enter the URL for the site into your 
browser as follows:

<Server Name>/MaximizerWireless

e.g., http://wirelessweb.maximizer.com/maximizerwireless

The following sections contain information specific to Wireless 
Access:

• “Supported Browsers for Wireless Access” on page 238

• “Browser Configuration for Wireless Access” on page 238

• “Page-Size Limits for Wireless Access” on page 239

• “Configuring Wireless Access Shortcuts” on page 239

Supported Browsers for Wireless Access

Any HTML web browser is compatible with the Wireless Access site 
including the following:

• ReqWireless Web Viewer 3.5 for RIM, Palm, and  J2ME devices

• Go.Web for RIM devices

• Palm Web Pro for Palm devices

• Pocket Internet Explorer for Windows CE devices

• Opera for SmartPhones/PDAs

• Safari for Apple iPhone

Visit Maximizer’s website at www.maximizer.com for the most up to 
date list of supported browsers. 

Browser Configuration for Wireless Access

In order for Wireless Access to display properly on devices, users 
should configure their browsers in the following ways:

• Enable JavaScript.

• Enable HTML tables.
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Page-Size Limits for Wireless Access

Wireless Access page sizes are constrained by the maximum packet 
size allowed by the browser and WAP gateway. Lists of notes, 
Contacts, and other information may be truncated to stay below this 
limit. If you receive a browser overflow error at any time, press the 
Back button on your handheld device and continue.

Configuring Wireless Access Shortcuts

BlackBerry users can install the Wireless Access Shortcuts application 
from the Wireless Access home page. To enable users to install the 
Wireless Access Shortcuts application, ensure the Default Web Site in 
Internet Information Services (IIS) has the following registered MIME 
types:

• Extension: cod

MIME type: application/vnd.rim.cod

• Extension: jad

MIME type: text/vnd.sun.j2me.app-descriptor

For more information on registering MIME types, see “Adding 
Support for File Types” on page 25.
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Customer Access and Partner Access
Unlike Maximizer Web Access, you must enable Customer Access and 
Partner Access yourself. 

➤ To enable and configure Customer Access or Partner 
Access

� Add administrators to the appropriate Security Groups in 
Administrator, as described in “Adding Users to Site Security 
Groups” on page 241.

� Ensure the Web Access Login right is enabled for any users 
who will access the site. (This right is enabled by default. For 
further information, refer to “Web Access Users” on page 218.)

� Customize the Web.config file for the site, as described in 
“Application Settings for Web Access Sites” on page 206.

� Customize the graphic on the main site page. Typically, you 
would replace it with your company’s logo. For instructions on 
changing this graphic, refer to “Customizing the Graphic on the 
Site Main Page” on page 251.

� Assign a URL to the site, as described in “Determining External 
Site URLs” on page 241.

� Enable any site configuration options as desired, as described 
in “Configuring Site Options” on page 243.

� Assign Contacts and/or Individuals the status of Customer or 
Partner in the Category field as part of the entry’s basic 
information, as described in “Setting Up Business Partners and 
Customers” on page 244.

	 Give business partners and customers access using the External 
Site PIN merge field, as described in “Assigning Site Login PINs 
to Contacts and Individuals” on page 246.

Introduction to Customer and Partner Access Administrator

Consisting of both the News Manager and the Configuration 
Manager, Customer/Partner Access Administrator is part of each 
instance of a Partner or Customer Access site and provides a way for 
administrators to complete the following tasks:

• turn site sections on and off

• specify the properties of generated emails

• specify the name of the site
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• add and modify news items

The options available in Customer and Partner Access are primarily 
the same.

The main page of Customer/Partner Access Administrator contains 
one or both of the following links, depending on which site security 
groups you belong to:

• News Manager – This link is available if you are a member of 
the Customer Access Administration Users or Partner Access 
Administration Users security group for the selected site type.

• Configuration Manager – This link is available if you are a 
member of the Customer Access Configuration Users or Partner 
Access Configuration Users security group for the selected site 
type.

You can also click the View Customer/Partner Access Site link in 
the upper-right corner of the screen to view the site itself, rather 
than the administrator.

For more specific information about Customer/Partner Access 
Administrator, open it and click Help.

Adding Users to Site Security Groups

The default configuration for Customer and Partner Access allows 
any Maximizer user to access Customer/Partner Access Administrator 
if they have rights to the section granted through Security Groups. 
Use the File > Security Groups and Teams dialog box in Administrator 
to control user access. Site security groups function in the same way 
as general Maximizer security groups. For more detailed information 
about site security groups, refer to “Web Access Security Groups” on 
page 215.

Determining External Site URLs

You must configure the 
external sites before these 
URLs are enabled for the 
Address Book as described in 
the previous section. 

Once you have configured the database and enabled both Partner 
Access and Customer Access for an Address Book, the sites are 
available for use through the URLs. Maximizer Web Access requires 
no additional configuration for use with an Address Book. 

The default URLs are listed below, although you can change them as 
necessary. To determine the URL for a site, substitute your IIS Server 
name for [YourServerName].

• Maximizer Web Access URL

http://[YourServerName]/MaximizerWebAccess/Default.aspx

• Customer Access URL

http://[YourServerName]/MaximizerCustomer/Default.aspx
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• Partner Access URL

http://[YourServerName]/MaximizerPartner/Default.aspx

• Customer Access Administrator

http://[YourServerName]/MaximizerCustomer/Admin/
Default.aspx

• Partner Access Administrator

http://[YourServerName]/MaximizerPartner/Admin/Default.aspx

Accessing the Sites from the Start Menu

To access your sites through the Maximizer CRM program Start 
menu, enter your URLs in the Sites dialog box in Administrator.

➤ To set up access for the sites from the Windows 
Start menu

� In Administrator, select File > Web Access. 

� Enter the URLs for sites in the corresponding fields. 

For example, for Partner Access Administrator, you would enter 
the following in the Partner Access URL field:

http://[YourServerName]/MaximizerPartner/Admin.aspx

�
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Configuring Site Options

Use the Configuration Manager to set preferences for the sites such 
as Address Book, calendar of events, customer service, forgotten 
credentials recovery, general settings, help, knowledge base, leads, 
links, news, opportunities, personalization, and quick info. 

To access the Configuration Manager, you must be a member of the 
Customer or Partner Access Configuration Users security group. 
When you log into Customer/Partner Access Administrator, you will 
see a Configuration Manager link.

For information about each of the configuration options, open 
Customer/Partner Access Administrator and click Help.
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Setting Up Business Partners and Customers

Start Maximizer and create Address Book entries for all the business 
partners and customers who need to access the sites. Each customer 
and partner must be set up as follows:

• Be a Contact or Individual in Maximizer

• Have an assigned email address in Maximizer

• Have “Partner” and “Customer” as the assigned value in the 
Category field, which is in the Contact Details section of the 
entry’s basic information tab

• Have at least one entry in the Partner Interests or Customer 
Interests user-defined field if you would like only certain new 
items to appear by default

Set up a test account for yourself so you can log into the site as a 
business customer and partner and confirm that everything is 
working correctly. Do this by creating an Individual record with your 
name, email address, and the selected values of Customer and 
Partner for the Category field on the entry’s Basic Information tab.

➤ To enable Address Book entries to access the site

� Run Maximizer and open the Address Book entry for the Contact 
or Individual for whom to create a site login account.

� Ensure that the Contact or Individual’s correct email address is 
entered in the Email address field.
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� Click the button beside the Category field.

� Select the checkbox beside either the Customer or Partner 
category, and click OK.

If you select Customer, the Contact or Individual will be able to 
log into Customer Access. 

If you select Partner, the Contact or Individual will be able to log 
into Partner Access.

The selected category now appears in the Category field of the 
Basic Information tab.

�

�

�



Maximizer CRM 11
Administrator’s Guide

246
� Click OK to close the Address Book entry.

� Repeat this procedure to enable any other Address Book entries 
to access the sites.

After you have completed this procedure, you must provide the 
customer or partner with a site PIN, which enables them to 
register and log into the site.

Assigning Site Login PINs to Contacts and Individuals

You provide each business customer and partner with a PIN. The PIN 
works only once. Each customer or partner can set up only one web 
account. Site PINs and logins are shared for both Partner Access and 
Customer Access.

Login PINs are created by a Maximizer merge field called External 
Site PIN. The values of the External Site PIN merge field are 
generated when you do a merge to print, email, or fax in the 
Maximizer Word Processor or when you generate an automated 
activity for an automated campaign. 

➤ To send Site PINs by mail, email, or fax

� In Maximizer,on the Tools tab, select Maximizer Editor from 
the Other group to open the Maximizer Word Processor.

For more information about 
the Maximizer Word Processor 
and merge fields, refer to the 
Maximizer CRM User’s Guide.

� Create a template for the email message that goes out to 
customers or partners to inform them of their Site PIN, which is 
required to access the sites.

� Click the Merge Field button to enter any merge fields.

You must include the External Site PIN merge field to send it to 
customers or partners, so they can create their login accounts.
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You can include any content in 
the merge document such as 
the URL for the site. If you are 
using email, the URL can be 
formatted as an HTML link.

� Save the document as an email template.

� Select File > Merge > to Printer, to Email, or to Microsoft 
Fax.

You can generate PINs for a 
whole list of entries or just the 
current entry. 

� Specify your desired options, and click OK.

The available merge options depend on which merge 
destination you chose in the previous step.

An assigned PIN appears in each merge document or email you 
create.

�

��
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� Click Send or Print to view each email or document before you 
send or print it.

– or –

Click Send All or Print All to send or print all emails or 
documents at once, without previewing them individually.

�



Chapter 8
Configuring Web Access

249
	 If you are sending by email, the Compose Email Message dialog 
box opens. Enter a subject in the Subject line, and click Send.

– or –

If you are printing documents, the Windows Print dialog box 
opens.

When the Customer or Partner receives the site PIN, he or she 
can go to the site login page, and click Register now to activate 
the login account.

➤ To activate a site login PIN through an automated 
campaign activity

For more information on 
creating automated campaign 
templates, refer to the 
Maximizer CRM User’s Guide 
and online help files. 

• When setting up your automated campaign template, use the 
External Site PIN merge field in one of the automated 
campaign activities. 

➤ To open the main site for Partner Access or 
Customer Access

� Set up a site PIN for yourself and activate a login.

� Log into either Partner Access Administrator or Customer Access 
Administrator.

� Click the View Partner/Customer Access Site link to see the 
main web access sites.
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Activating a Login Account

The following procedure explains the steps for the business customer 
or partner to activate a login account with the provided PIN.

➤ To activate a login account

� Open Customer Access or Partner Access using the provided URL. 

See “Determining External Site 
URLs” on page 241 for more 
information on the site URLs. 

� At the Login screen, click the Register now link. 

The registration page opens.

� Enter your last name, email address, PIN, user ID, and password. 

The Customer or Partner Access page displays.

Removing Web Access

To block access to Customer or Partner Access for a business customer 
or partner who currently has access, start Maximizer, locate the 
Address Book entry, and remove the Customer or Partner value from 
the Category field.

Retrieving a Forgotten Password

For this feature to work, the 
Forgotten Credentials 
Recovery configuration must 
have been set up previously in 
Customer/Partner Access 
Administrator.

A customer or partner who forgets a password can use the 
“Forgotten Login Credentials” link to load a page that asks for an 
email address and last name or user ID. The customer or partner then 
receives the password by email.

Changing a Password

Partners or customers can change their password from inside the site 
any time they want (if you enable that feature through the 
Personalization link in Configuration Manager). All passwords are 
encrypted; your Maximizer users do not have access to passwords.
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Advanced Site Configurations
This section describes the following additional site customizations:

• “Customizing the Graphic on the Site Main Page” on page 251

• “The sections.xml File” on page 252

• “Displaying Custom System Messages” on page 253

• “Adding Custom Actions to the CustomActions.xml File” on 
page 255

• “Creating Custom Links to External Websites” on page 257

• “Specifying the Address Book on the Site Login Screen” on 
page 259

• “Globalization of Sites” on page 261

• “Configuring Multiple IIS Servers to Connect to a Single 
Maximizer CRM Server” on page 262

• “Moving a Site” on page 262

• “Installing Sites to Non-Default Folders” on page 262

• “Setting Up Multiple Customer or Partner Sites” on page 264

• “Creating a Custom Case Wizard for Partner Access” on page 269

Customizing the Graphic on the Site Main Page

With the exception of the 
contents of the 
\CustomGraphics folder, you 
should not modify application 
files, including graphics. 

You can replace the default graphic on the site main page with your 
own custom graphic. This procedure applies to all sites. 

➤ To customize the graphic on the site main page

� Create a graphic that is 280 pixels wide by 130 pixels in height 
and save it as LoginCorporate.gif.

� Copy the graphic file to the appropriate folder:

...\Program Files\Maximizer\Portals\<site>\CustomGraphics\
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The sections.xml File

The sections.xml file contains information on modules that are 
available to users in Maximizer Web Access. By editing the 
sections.xml file, you can add, disable, or change the default order 
that the modules appear.

The sections.xml file is located on the machine where the Maximizer 
Components for IIS are installed, at the following path:

C:\Program Files\Maximizer\Portals\<site>\Config\sections.xml

Disabling Modules in Sites

You can disable specific modules in the web access sites. The 
sections.xml file determines what modules are displayed in the site.

The easiest way to disable a module is to comment out the shortcut 
element for that module in the sections.xml file. The shortcut 
element will remain in the file, but it will be enclosed between XML 
comment tags and ignored by Maximizer.

➤ To disable a module in a site

Always back up the 
sections.xml file before making 
any changes.

� Open the site’s sections.xml file in a text editor such as 
Notepad.

� Locate the shortcut element containing the module.

The name of the module, as it appears in Maximizer, is displayed 
between the title tags in the shortcut element.

�  Add an opening comment tag, <!--, before the shortcut opening 
tag, <shortcut>.

� Add a closing comment tag, --!>, after the shortcut closing tag, 
</shortcut>.

� Save the file.

The following example shows comment tags around the 
opportunities shortcut element. In this example, the opportunities 
module would be disabled on the site.

<!--

<shortcuts>

<id>opp</id>

<title>Opportunities</title>

<image>opportunity</image>

<module_id>0<module_id>

<url>/Content/Opportunities.aspx</url>
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<external>No</external>

<has_grid>Yes</has_grid>

</shortcuts>

-->

Changing the Order of Modules in the Icon Bar

In Maximizer Web Access, you can define the icons and the default 
order that they appear in the icon bar by modifying the sections.xml 
file. Users will only see the icons for the modules that they have the 
rights to view.

The easiest way of doing this is copying the module section of the 
module you want to move (the code surrounded by the <shortcut> 
tags) and pasting it between other module sections.

If the order of the icons has been changed by a user in the Icon Bar 
Properties dialog box (in Maximizer Web Access, from the top right 
corner, select preferences), the new order is saved in the 
ADMN_Config table where the TaskCode = the user’s ID and the 
KeyCode = IconBarButtonOrder. If modules are hidden in the Icon 
Bar Properties, references to the hidden modules are saved in the 
ADMN_Config table where the TaskCode = the user’s ID and the 
KeyCode = IconBarButtonHide. 

Displaying Custom System Messages

You can create custom system messages that are broadcast to all 
Maximizer Web Access users. System messages display across the top 
of web access pages. They can include two lines of text and a 
hyperlink. The properties of a message are specified in the 
SystemMessages.xml file. The file specifies the content of the 
message, the appearance of the message, and the start and end date/
time that the message is displayed.

➤ To display a custom system message

� Open the site’s SystemMessages.xml file in a text editor such 
as Notepad.

The file is located on the Maximizer server at the following path:

C:\Program Files\Maximizer\Portals\Employee\Config\
SystemMessages.xml

� Use the XML tags in the bottom part of the SystemMessages.xml 
file to specify the properties of the system message. The top part 
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of the file explains the role of each set of tags. The bottom part 
of the file contains the actual tags that are used.

For descriptions and examples of each element, see “Elements in 
SystemMessages.xml File” and “Example SystemMessages.xml 
File” below.

� Between the Enabled tags, replace False with True. The line in 
the file should be <Enabled>True</Enabled>.

� Save the file.

Elements in SystemMessages.xml File

The SystemMessages.xml file contains one <SystemMessages> 
element, which in turn contains one <SystemMessage> element. This 
element determines the properties of the message.

The following table describes each of the sub-elements in the 
<SystemMessage> element.  

Element Description

<HeaderLine1> Bolded text at the beginning of the first line

<TextLine1> Plain text placed at the end of the first line.

<TextLine2> Plain text placed at the beginning of the second line.

<Hyperlink
Text>

Text for a hyperlink placed at the end of the second 
line.

<HyperlinkUrl> The URL for the hyperlink.

<Background
Color1>

The background color of the message.

<StartDate> The start date and time in the format yyyy-mm-dd 
hh:mm. If specified, the message is displayed only 
after this date and time.

<EndDate> The end date and time in the format yyyy-mm-dd 
hh:mm. If specified, the message is displayed only 
before this date and time.

<Enabled> True means the system message will display if at 
least one text element has a value and the current 
date/time is within the start and end date/time 
values.
False means the system message will not display 
regardless of the other elements.
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Example SystemMessages.xml File

The following example shows the content of the <SystemMessages> 
element:

<SystemMessages>

  <SystemMessage>

<HeaderLine1>Notice</HeaderLine1>

<TextLine1>Maintenance to phone lines</TextLine1>

<TextLine2>The phone lines will be out of service 
between 4:00 and 5:00 pm this evening.</TextLine2>

<HyperlinkText>More info.</HyperlinkText>

<HyperlinkUrl>http://Server/Maintenance</HyperlinkUrl>

<BackgroundColor1>Yellow</BackgroundColor1>

<StartDate>2010-06-10</StartDate>

<ExpiryDate>2010-06-10 17:30</ExpiryDate>

<Enabled>True</Enabled>

  </SystemMessage>

</SystemMessages>

The example displays a message alerting Maximizer Web Access users 
that phone lines are out of service. The message is displayed only on 
the specified day until 5:30 pm.

Adding Custom Actions to the CustomActions.xml File

The Address Book, Customer Service, and Opportunities screens in 
Maximizer Web Access contain an Actions menu, and you can add 
custom action commands to those menus. Clicking on a custom 
action in the menu will open a custom dialog box created by you, in 
which you can display information about the current record, selected 
records, or all records in the list. You can add as many custom actions 
as you want to the Actions menu.

To enable Maximizer Web Access to register and recognize your 
custom actions, you must add information to the CustomActions.xml 
file. The file identifes which custom actions are enabled and defines 
specifics about the dialog box. The file is located in the 
<portal_root>\Config\ folder.
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If the XML is not well-formed, 
no custom actions will appear, 
and no error messages will 
appear.

The file contains four sections, one for each page (Address Book, 
Campaigns, Customer Service, and Opportunities). Each section 
contains the following XML elements.

The following table describes each of the sub-elements in the 
<CustomAction> element. 

Example of the CustomActions.xml File

<?xml version="1.0" encoding="utf-8" ?> 

<!-- 

 ConfigActions.xml  

===================

This file manages custom actions.

Sample:

Element Tag Description

<id> Identifies which page the custom action is for (ab = Address Book, 
cam = Campaigns, cs = Customer Service, and opp = 
Opportunities). Do not change the value of this element.

<CustomAction> Defines what page should be called when a user clicks a the 
custom action in the Actions menu.

Element Tag Description

<ID> Unique ID of the menu command.
Can be any value, but must be unique within the <Page> element.

<Title> Menu command title as it will appear in the Actions menu.

<Url> Name of the file that will appear in the pop-up dialog box after 
the command is called by a user. This file must reside in 
<portal_root>\Dialogs\CustomDialogs\.

<MergeURL> Custom URL containing a merge field from Maximizer.

<Width> Width of the pop-up dialog box, in pixels.

<Height> Height of the pop-up dialog box, in pixels.

<DisabledIfNo
Records>

Defines whether the custom Action menu command will be 
disabled when there are no entries displayed in the grid on the 
page. Must have a Yes or No value.

<Resizable> Determines if the custom window can be resized. Must have a Yes 
or No value.

<Scrollable> Determines if the custom window can be scrolled. Must have a Yes 
or No value.
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=======

<CustomAction>

<ID>CA_id</ID>  : Must be unique 

<Title>Custom Action...</Title>: As it will 
appear in the Actions menu 

<Url>c.aspx</Url>  : Must exist in 
<EmployeePortalRoot>\Dialogs\CustomDialogs\ folder 

<MergeUrl>No</MergeUrl> : Must be Yes or No

<Width>800</Width>  : Must be a number 
(width in pixels) 

<Height>200</Height> : Must be a number (height 
in pixels) 

<DisabledIfNoRecords>Yes</DisabledIfNoRecords>: 
Must be Yes or No

<Resizable>No</Resizable>: Must be Yes or No

<Scrollable>No</Scrollable>: Must be Yes or No

</CustomAction>

Creating Custom Links to External Websites

You can create custom links in the CustomActions.xml file to external 
websites that include merge fields from Maximizer. The custom URLs 
are then accessible from the Actions menu in Maximizer Web Access. 
This allows a user to link to a web page based on the contents of the 
current record. For example, you could include the “city” merge field 
as part of the external link URL and based on the city contained in 
the record, information related to the associated city would be 
shown in the web page.

Note the URLs must be encoded. Different types of encryption are 
supported for passing parameters to URLs. 

To create a custom link with a merge field, add the custom link 
information to the CustomActions.xml file. See the following 
example of a CustomActions.xml file for more information.

Example of an Integration with a Wikipedia Search

<CustomAction>

    <ID>CA_id</ID>  

    <Title> Wikipedia...</Title>

<Url>http://en.wikipedia.org/wiki/
[EncodingStartSpaceAsUnderscore] [C.CompanyName]  
[EncodingEnd]</Url>  

<MergeUrl>yes</MergeUrl>

<Width>700</Width>  
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<Height>400</Height>

<DisabledIfNoRecords>No</DisabledIfNoRecords>

<Resizable>Yes</Resizable>

<Scrollable>Yes</Scrollable>

</CustomAction>  

Example of an Integration with a Google Search

<CustomAction>

<ID>CA_id2</ID>  

<Title>Google Search...</Title>

<Url>http://www.google.ca/
search?q=[EncodingStartSpaceAsPlus][C.CompanyName][EncodingE
nd]</Url>

<MergeUrl>Yes</MergeUrl>

<Width>700</Width>

<Height>400</Height>

<DisabledIfNoRecords>No</DisabledIfNoRecords>

<Resizable>Yes</Resizable>

<Scrollable>Yes</Scrollable>

</CustomAction>

Example of an Integration with Google Maps

<CustomAction>

<ID>CA_id3</ID>

<Title>Google Map...</Title>

<Url>http://maps.google.ca/
maps?q=[EncodingStartSpaceAsPlus][C.AddressLine1]%2c[C.City]
%2c[C.StateProvince][EncodingEnd]</Url>

<MergeUrl>Yes</MergeUrl>

<Width>1100</Width>

<Height>800</Height>

<DisabledIfNoRecords>Yes</DisabledIfNoRecords>

<Resizable>Yes</Resizable>

<Scrollable>Yes</Scrollable>

</CustomAction>
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Specifying the Address Book on the Site Login Screen

There are several methods of controlling which Address Books are 
available through the login screens of Maximizer Web Access and 
Wireless Access: 

• Users enter the site URL, and the resulting login page displays a 
drop-down list of available Address Books

• Users enter the site URL, appended by the “ab” parameter, and 
the resulting login page displays the specified Address Book 
name as a static field

• You enter a value in the AddressBook key of the site’s 
Web.config file, and when users enter the site URL, the resulting 
login page displays the specified Address Book name as a static 
field

Displaying a Drop-down List of Available Address Books

You can provide access to any Address Book through Maximizer Web 
Access or Wireless Access. By default, when a user enters the site URL 
in a browser, the resulting login screen includes a drop-down list of 
available Address Books.

Specifying the Address Book in the URL

You can also specify the Address Book in the URL. By specifying the 
new parameter called “ab” in the URL, you can provide a direct 
shortcut to the Address Book in Maximizer Web Access or Wireless 
Access.

• Maximizer Web Access: http://SERVERNAME/
MaximizerWebAccess/default.aspx?ab=EsconaTutorial

• Wireless Access: http://SERVERNAME/MaximizerWireless/
default.aspx?ab=EsconaTutorial
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The value of the ab parameter must be the Address Book’s SQL 
database name, not the user-definable Address Book name set in 
Administrator (File > Preferences > System Options tab).

Enabling Access to a Single Address Book Only

You can also restrict an instance of Maximizer Web Access or Wireless 
Access to be able to access a single Address Book only, rather than 
showing the Address Book drop-down list or specifying the Address 
Book in the URL. Specify the “AddressBook” property in the 
appSettings section of the site’s Web.config file, as shown in the 
following example:

<add key=”AddressBook” value=”EsconaTutorial” />

The value of the AddressBook key must be the Address Book’s SQL 
database name, not the user-definable Address Book name set in 
Administrator (File > Preferences > System Options tab). 

If the value of the AddressBook key does not correspond to a valid 
Address Book, the login page displays the Address Book list.

Similarly, you can display a default Address Book. This is also 
specified in the appSettings section of the site’s Web.config file, as 
shown in the following example:

<add key=”DefaultAddressBook” value=”EsconaTutorial” />
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Globalization of Sites

The Globalization element enables you to change the site’s regional 
display settings such as numbers and dates. To change the 
globalization of a site, you must add the section below as a child to 
the system.web element. The regional settings are defined in the 
culture and uiCulture attributes. Because the Globalization 
element is optional, if it or any of its attributes are not added to the 
default Web.config file, US English is used by default.

<globalization 

requestEncoding="utf-8" 

responseEncoding="utf-8"

culture="en-US"

uiCulture="en"

/>

To use display settings other than US English, replace the values of 
the culture and uiCulture attributes in the Globalization element. 
The following list includes some of the possible values:

The country codes are defined in the ISO 3166 standard, which is 
available at the following URL:

http://www.iso.ch/iso/en/prods-services/iso3166ma/02iso-3166-
code-lists/index.html

The concept of combining these country codes with language is 
defined in RFC 3066, which is available at the following URL:

http://www.faqs.org/rfcs/rfc3066.html

More information on globalization settings can be found at the 
following URL:

http://msdn.microsoft.com/en-us/library/hy4kkhe0.aspx

Country, Language culture uiCulture

United States, English en-US en

Britain, English en-GB en

Canada, English en-CA en

France, French fr-FR fr

Canada, French fr-CA fr

Belgium, French fr-BE fr

Germany, German de-DE de

China, Chinese zh-CN zh
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Configuring Multiple IIS Servers to Connect to a Single Maximizer CRM Server

You can use the procedure described below to configure multiple 
Address Books on multiple IIS servers to connect to a single 
Maximizer CRM server.

➤ To configure multiple IIS servers to connect to a 
single Maximizer CRM Server

� On each IIS server, install Maximizer Components for 
Microsoft IIS from the Maximizer CRM Server disc and during 
setup, select your Maximizer CRM Server machine.

� On each IIS server, change the AddressBook key of the 
Web.config file for Customer and Partner Access to point to the 
appropriate Address Book.

Moving a Site

Web access sites are ASP.NET web applications, which implies a level 
of portability. If you choose, you can rename the virtual folder 
holding the application and therefore its URL. You may even change 
the physical path of the application by copying the application 
someplace else on the IIS machine’s hard drive. When doing this, be 
sure to move the entire folder.

Installing Sites to Non-Default Folders

The Maximizer installation creates an XML file called 
PortalLocations.xml (unless the file already exists on the machine, in 
which case it does not overwrite the existing file). The 
PortalLocations.xml file is located in the folder where the sites are 
installed. The default site installation folder is ...\Program 
Files\Maximizer\Portals. There is only one PortalLocations.xml file for 
each Maximizer CRM Server.

The PortalLocations.xml file describes the folder location of each site. 
If you install any sites to a non-default location, you can optionally 
add their location to the PortalLocations.xml file. Any sites identified 
in this file will be updated by the Maximizer installation for any 
upgrades or updates such as service releases. Any sites installed to 
non-default locations will not be updated unless they are added to 
the PortalLocations.xml file.

By default, the PortalLocations.xml file contains location information 
for the four default sites.

<Portals>

<Portal ID="DefCustomerPortal">
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<Location>C:\Program 
Files\Maximizer\Portals\Customer</Location>

<Context>MA_CUSTOMER</Context>

<Description>Maximizer Default Customer Portal</
Description>

</Portal>

<Portal ID="DefPartnerPortal">

<Location>C:\Program 
Files\Maximizer\Portals\Partner</Location>

<Context>MA_PARTNER</Context>

<Description>Maximizer Default Partner Portal</
Description>

</Portal>

<Portal ID="DefEmployeePortal">

<Location>C:\Program 
Files\Maximizer\Portals\Employee</Location>

<Context>MA_EMPLOYEE</Context>

<Description>Maximizer Default Employee Portal</
Description>

</Portal>

<Portal ID="DefWirelessPortal">

<Location>C:\Program 
Files\Maximizer\Portals\Wireless</Location>

<Context>MA_WIRELESS</Context>

<Description>Maximizer Default Wireless Portal</
Description>

</Portal>

</Portals>

The XML file contains a site ID, location, context, and description for 
each site. These elements are described in the following table.

Element Description

<Site/Portal> This element has an ID attribute, which must be 
unique for each site. This ID will not be displayed in 
the site itself.

<Location> Installation location of the site.
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Setting Up Multiple Customer or Partner Sites

If you want the sites to be 
updated by the Maximizer 
installation, refer to “Installing 
Sites to Non-Default Folders” 
on page 262.

To this point, the chapter has explained how to set up a single 
Partner Access site and a single Customer Access site. However, you 
can create additional Partner and Customer Access sites for one or 
more Address Books. For example, you might want to create a Media 
Site for your Address Book, or you might want to create a Customer 
or Partner Access site for a second Address Book. 

The major steps involved in creating additional Partner or Customer 
Access sites is as follows:

• Assign a Category field value to Address Book entries. The 
Category field of an Address Book entry controls which sites(s) 
an Address Book entry can access. Therefore, you must assign a 
Category field value to all Address Book entries that should be 
granted access to the new site. You can create a new field value, 
or you can assign one of the existing field values.

• Create the new site. The process of creating a new site is very 
simple. Essentially, you duplicate an existing Customer or Partner 
Access site folder, rename it, and edit the Web.config file for the 
new site.

• Configure the new site. At this point, the site is functional. The 
only remaining task is to configure the new site using Customer/
Partner Access Administrator and provide access PINs to those 
Individuals and Contacts who you want to be able to log into it.

Each of these procedures are described in detail below.

➤ To create a new Category field value

� Run Maximizer and log into the Address Book.

� Open an Address Book entry to grant access to the new site.

� If the Address Book entry is in View mode, click Edit to switch to 
Edit mode.

<Context> Identifies the type of site. Must be one of the 
following values:

• MA_Employee
• MA_Customer
• MA_Partner

• MA_Wireless

<Description> Description of the site. 

Element Description
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� Click the ellipsis button beside the Category field.

� If a new field value is required, click New Value and add an item 
to the list.

� Select the checkbox beside the field value that enables the 
Address Book entry to access the new site, and click OK.

For example, if you are creating a Media Access site, you would 
probably select Media as the required Category field value. If 
you were creating an Investor Access site, you would create a 
new Category field value of Investor.

�

�

�
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� Repeat this process to assign the Category to any other Address 
Book entries which should have access to the new site.

➤ To create the new site

� Open Windows Explorer, and navigate to the sites directory. (In a 
default installation, this folder is located at 
C:\Program Files\Maximizer\Portals.)

� Create a copy of the Customer or Partner folder inside the 
Portals folder.

Make sure you copy the entire Customer or Partner folder, 
including all subfolders and files.

� Rename the folder with the new site name.

� Right-click the new folder, and select Properties from the 
shortcut menu.

� Select the Web Sharing tab.
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Do not use spaces in the virtual 
folder name.

� Select Default Web Site from the Share on drop-down list, 
and select the Share this folder option.

The Edit Alias dialog box opens.

� Enter an alternate Alias if desired, select the Read access 
permission, select the Scripts application permissions, and click 
OK.

	 Click OK to close the Properties dialog box.
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 In the new folder, select the Web.config file and open it in a 
text editor, such as Windows Notepad.

��Assign a meaningful value to the SubContext key.

The sites have a Context value and a SubContext value. The 
Context value is MA_PARTNER for a Partner Access site and 
MA_CUSTOMER for a Customer Access site. The Context value 
for the new site is already defined because you copied it from an 
existing site, so you just need to assign a SubContext value, 
which differentiates this new site from the original.

For example, if you are creating a Media site, you would 
probably choose to assign a SubContext value of “Media”.

��Enter the Category field value (from the previous procedure) 
as the AlternateRequiredCategory value.

If you used the “Media” Category field value, you would assign 
“Media” as the AlternateRequiredCategory value.

��Save the Web.config file.

Do not change the name or location of this file.
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➤ To configure the new site

� Open a web browser and enter the URL of the new site. The 
default site URL is

http://<web_server_name>/<site_alias>/Admin.aspx

In the case of the example site, the URL is http://test-server/
MaximizerMedia/Admin.aspx.

Customer/Partner Access Administrator opens. The login page 
appears as the Partner Access Administrator or Customer Access 
Administrator login page, depending on which site you copied 
the new one from.

� Log into Customer /Partner Access Administrator.

� Configure the site as desired. Refer to the previous sections of 
this chapter for more information.

Include setting the site name as part of the configuration. You 
can set the name in the General Settings page of the 
Configuration Manager.

� Assign a site PIN to all Individuals and Contacts who should have 
site access, as described in “Assigning Site Login PINs to Contacts 
and Individuals” on page 246.

Creating a Custom Case Wizard for Partner Access

Partner Access includes a wizard for creating new customer service 
cases. It is available from the Edit > Create a Customer Service Case 
menu item on the Customer Service page of the site. You can also 
create your own custom customer service case wizards and make 
them accessible from the Edit menu. 

Create your own case wizards by describing them in an XML file, 
naming the file CustomCSCaseWizards.xml, and placing it in the 
Config folder of Partner Access. The XML elements that your 
CustomCSCaseWizards.xml file may contain are described below, 
along with a sample XML file. When you create multiple case 
wizards, they must all be described in the same XML file, with each 
wizard set apart by the <CSCaseWizard> element.

Note that if the XML is not well-formed, the custom wizards will not 
appear in the Edit menu, and no error messages will appear.
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➤ To create a custom customer service case wizard

� Create an xml file describing the contents of each screen of the 
wizard.

For more information, refer to the custom wizard example and 
the table describing the XML tags, which are provided in this 
section.

� Name the xml file CustomCSCaseWizards.xml.

� Place the xml file in the following folder:

...\Maximizer\Portals\Partner\Config

This folder is typically located in the C:\Program FIles\ folder.

Custom Wizard Example

Below are the contents of an example CustomCSCaseWizards.xml 
file.

<CustomCSCaseWizards>

<CSCaseWizard>

<Id>SuggestionWizard</Id>

<MenuOption>Enter a Suggestion</MenuOption>

<HeaderStep1>Categorize your suggestion</HeaderStep1>

<ShowOrigin>true</ShowOrigin>

<OriginPrompt>Suggestion origin</OriginPrompt>

<DefaultOrigin>Website</DefaultOrigin>

<MandatoryOrigin>true</MandatoryOrigin>

<ShowType>true</ShowType>

<TypePrompt>Suggestion type</TypePrompt>

<DefaultType>Suggestion</DefaultType>

<MandatoryType>true</MandatoryType>

<ShowProduct>true</ShowProduct>

<ProductPrompt>Product or service</ProductPrompt>

<DefaultProduct>Accessories</DefaultProduct>

<MandatoryProduct>true</MandatoryProduct>

<ShowCategory>true</ShowCategory>

<CategoryPrompt>Category</CategoryPrompt>
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<DefaultCategory>Other</DefaultCategory>

<MandatoryCategory>true</MandatoryCategory>

<ShowPriority>true</ShowPriority>

<PriorityPrompt>Priority</PriorityPrompt>

<DefaultPriority>Medium</DefaultPriority>

<ShowSeverity>true</ShowSeverity>

<SeverityPrompt>Severity</SeverityPrompt>

<DefaultSeverity>Medium</DefaultSeverity>

<DefaultAssignedTo>JNAPOLI</DefaultAssignedTo>

<DefaultOwner>JNAPOLI</DefaultOwner>

<DefaultQueue>Standard</DefaultQueue>

<udfPrompt1>Send acknowledgement email</udfPrompt1>

<udfTypeId1>107</udfTypeId1>

<MandatoryUdf1>true</MandatoryUdf1>

<DefaultUdf1>No</DefaultUdf1>

<HeaderStep2>Provide details</HeaderStep2>

<DescriptionPrompt1>Details</DescriptionPrompt1>

<DescriptionPrompt2>More details</DescriptionPrompt2>

<HeaderStep3>Review your suggestion</HeaderStep3>

</CSCaseWizard>

<CSCaseWizard>...(Second custom wizard)...</CSCaseWizard>

<CSCaseWizard>...(Third custom wizard)...</CSCaseWizard>

</CustomCSCaseWizards>

The first screen of the example custom wizard displays the following 
fields: Suggestion origin, Suggestion type, Product or service, 
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Category, Priority, Severity, and Send acknowledgement email. All of 
the fields have default values.

The second screen of the example custom wizard contains three 
fields: Short description, Details, and More details. 
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The third screen in the example custom wizard displays a summary of 
the values entered in the previous screens.
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XML Tags in the CustomCSCaseWizards.xml File

The following table lists each of the XML tags in the 
CustomCSCaseWizards.xml file, as well as their data type and a 
description. 

All XML tags are case-sensitive.

XML Tag Data Type Description

CSCaseWizard Contains all other tags describing 
a single wizard. Each custom case 
wizard must be set apart by its 
own set of CSCaseWizard tags 
inside the file.

Id string Mandatory.
Unique identification of the 
wizard.

MenuOption string Mandatory.
Menu item text as it will appear in 
the Edit menu of the Customer 
Service page.

HeaderStep1 string Header text that appears at the 
top of each page of the wizard. 
Header text is automatically 
prefixed by “Step 1 - “, “Step 2 - “, 
or “Step 3 - “.
If these tags are not included, the 
wizard will use the default header 
text, as it appears in the default 
Customer Service Case Wizard.

HeaderStep2 string

HeaderStep3 string

ShowOrigin boolean Specifies whether to display the 
Case origin, Case type, Products/
Services, Categories, Priority, and 
Severity fields:
• If “true”, the field(s) appear 

on the first page of the 
wizard.

• If “false”, the field(s) do not 
appear in the wizard.

• If you omit the XML tag, all of 
these fields, except “Origin” 
appear in the wizard by 
default.

ShowType boolean

ShowProduct boolean

ShowCategory boolean

ShowPriority boolean

ShowSeverity boolean
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DefaultOrigin string Specifies the default value of the 
Case origin, Case type, Products/
Services, Categories, Priority, and 
Severity fields.
The value of the XML element 
must be a valid value of the 
related field in the Address Book.
The values of the 
DefaultAssignedTo, 
DefaultOwner, and DefaultQueue 
fields are not visible in the wizard 
because there is no related 
“Show...” XML tag. Therefore, site 
users cannot change the value of 
these fields through the wizard.
The DefaultAssignedTo tag does not 

check whether the specified user has the 
“Customer Service Representative” or 
“Customer Service Manager” access 
right. It is up to you to verify that the 
user identified in the DefaultAssignedTo 
tag has the appropriate access rights.

DefaultType string

DefaultProduct string

DefaultCategory string

DefaultPriority string

DefaultSeverity string

DefaultAssignedTo string

DefaultOwner string

DefaultQueue string

OriginPrompt string Specifies the text that appears 
beside the field in the wizard.
If you omit an XML tag, the 
wizard uses the default prompt, as 
it appears in the “Create a 
Customer Service Case” wizard.

TypePrompt string

ProductPrompt string

CategoryPrompt string

PriorityPrompt string

SeverityPrompt string

SubjectPrompt string

DescriptionPrompt1 string Specifies the text that appears 
above the last two fields on the 
second page of the wizard.
If you omit an XML tag, the 
wizard uses the default prompt, as 
it appears in the “Create a 
Customer Service Case” wizard.

DescriptionPrompt2 string

XML Tag Data Type Description
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MandatoryOrigin boolean Specifies whether site user must 
provide a value for the Case 
origin, Case type, Products/
Services, or Categories field in the 
wizard:

• If “true”, the site user must 
select a value for the field 
before proceeding to the next 
page in the wizard.

• If “false”, the site user may 
leave the field blank.

• If you omit the XML tag, the 
fields are not mandatory.

MandatoryType boolean

MandatoryProduct boolean

MandatoryCategory boolean

udfPrompt1 string Specifies the text that appears 
beside the user-defined field in 
the wizard. udfPrompt2 string

udfPrompt3 string

udfTypeId1 integer Specifies the user-defined field to 
include on the first page of the 
wizard. Specify the Type_Id of the 
user-defined field as a value of 
this XML tag. 
The wizard can display only 
customer service table user-
defined fields.

udfTypeId2 integer

udfTypeId3 integer

MandatoryUdf1 boolean Specifies whether the site user 
must provide a value for this user-
defined field in the wizard.MandatoryUdf2 boolean

MandatoryUdf3 boolean

DefaultUdf1 string Specifies the default value of the 
user-defined field in the wizard.

DefaultUdf2 string

DefaultUdf3 string

XML Tag Data Type Description
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“Configuring Live Update Manager” on page 281

“Downloading Updates from Maximizer with Live Update” on page 282
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“Copying the Update and XML Files to the Web Server” on page 285

“Configuring the Maximizer Live Update Service” on page 286

“Updating Maximizer with Live Update” on page 287
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Introduction to Maximizer Live Update
The Live Update service checks for and downloads appropriate 
Maximizer CRM software updates for your local Maximizer CRM 
installation. The Live Update service can be configured to point to 
either the Maximizer Software update server (which is the default 
setting) or to your organization’s own Live Update server. The Live 
Update service is installed and enabled automatically as part of the 
regular Maximizer CRM installation. However, to use your own Live 
Update server, you must install and configure Live Update Manager 
separately, as described in this chapter.

Live Update Manager is an optional component of the Maximizer 
Live Update service and is available on the Maximizer CRM Server 
disc. Live Update Manager is a standalone component that enables 
you to control the timing and distribution of software updates, as 
well as to test them before releasing Maximizer software updates to 
your users. 
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Installing Live Update Manager
Before you install Live Update Manager, you will need to create a 
virtual directory on your web server. The following sections describe 
how to install LIve Update Manager:

• “Creating a Virtual Directory for Live Update on your Web 
Server” on page 279

• “Installing Maximizer Live Update Manager” on page 279

Creating a Virtual Directory for Live Update on your Web Server

For instructions on creating a 
virtual directory, refer to your 
web server software 
documentation.

Designate a machine as your Live Update server, which will serve 
updates to the Live Update service on Maximizer machines in your 
organization. It can be a web server outside the firewall if Internet 
access is required (for example to support remote offices) or a web 
server available locally only. In either case, it must be an IIS server. 

Create a virtual directory for Live Update on your web server. You 
will be prompted for the URL of your Live Update server during the 
Live Update Manager installation.

You will also be prompted for the location to save updates that Live 
Update Manager downloads from Maximizer Software. If possible, 
use the same location as the physical location of the virtual directory 
of your Live Update server. However, in some situations (such as 
when the URL is of a web server outside the firewall) this 
configuration is not the most secure and you should specify a 
different location.

Installing Maximizer Live Update Manager

Live Update Manager is the program that enables you to check for, 
download, and manage updates for Maximizer CRM installations. 
The Live Update Manager installation is available on the Maximizer 
CRM Server disc. Live Update Manager does not need to be co-
located with a Maximizer CRM Server, but it can be if desired. The 
installation location of the Live Update Manager (by default 
C:\Program Files\Maximizer Live Update) must have network access 
to the physical folder that will be used to store Maximizer CRM 
product updates downloaded from the Maximizer Software update 
server.

➤ To install Maximizer Live Update Manager

� Close all programs running on the machine.

� Insert the Maximizer CRM Server disc.
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� On the Autorun screen, click Install Maximizer Live Update 
Manager.

If the setup doesn’t start 
automatically, you can start it 
manually by running setup.exe 
from the disc.

� On the Welcome screen, click Next.

� On the Customer Information screen, enter your User Name, 
Company Name, and select whether to install the application 
for all users of the computer or only for the current user.

� On the Choose Destination Location screen, click Next to install 
the application to the default folder.

– or –

Click Browse, select an alternative location, and click Next.

� On the Corporate Update Server properties screen, enter the 
URL for the Live Update virtual directory you created previously 
(e.g., http://www.escona.com/liveupdate).

You can modify the URL and 
Download settings through 
Live Update Manager after it is 
installed.

– or –

Enter the UNC network path of the Live Update folder on your 
Live Update web server (e.g., \\LiveUpdateServer\liveupdate).

The Download field specifies the folder that updates from 
Maximizer will download to. You can change this path if 
needed.

Click Next.

	 On the Start Copying Files screen, review your installation 
settings and click Next to begin the installation.


 When the installation is complete, click Finish.

Live Update Manager is now accessible from the Start menu. 
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Configuring Live Update Manager
Once you have installed Live Update Manager, configure it and enter 
the PSNs for your Maximizer products.

➤ To configure Live Update Manager

� Run Live Update Manager. It is available from Start > Programs 
> Maximizer Live Update > Live Update Manager.

� Click the Settings tab.

� Ensure that the URL of your corporate update server field 
contains the URL (e.g., www.escona.com/liveupdate) or the UNC 
network path (e.g., \\LiveUpdateServer\liveupdate) of the Live 
Update virtual folder on your Live Update web server.

The Base URL of the update 
server field may already be 
completed if you provided the 
information during the Live 
Update Manager installation.

� In the Product list, ensure the checkboxes are selected for all 
Maximizer Software Inc. products installed in your organization. 
De-select the checkboxes for any products not installed.

� For each installed product, select the product, click Edit, enter 
your PSN(s) for that product, and click OK. If you have more 
than one PSN for a product, separate the PSNs with commas.

� You can optionally change any of the settings on the 
Preferences tab. For information about each of these options, 
select the Preferences tab and press F1.

� Click Apply to save your changes.

� �

�

�

�

�

�
�
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Downloading Updates from Maximizer with Live Update
The Live Update Wizard in the Live Update Manager connects to the 
Maximizer Live Update Server and downloads available updates from 
Maximizer Software Inc.

➤ To start the Live Update Wizard

• If the Enable automatic Maximizer Live Update 
notification option is selected on the Preferences tab, a 
message box notifies you when new updates are available. Click 
OK to start the Live Update Wizard.

– or –

• In Live Update Manager, click the Check for updates button on 
the Updates tab, which opens the Live Update Wizard.

➤ To download software updates from Maximizer

� Start the Live Update Wizard as described above.

If you started the Live Update Wizard from the automatic 
notification message box, it takes you directly to the Available 
Updates screen. Skip to step 3.

� Click Next on the welcome screen.

The Live Update Wizard connects to the Maximizer Live Update 
Server to check for any available updates. 

� Select the update(s) to download.

� Click Next to download the selected updates.

� Click Finish to close the wizard.

The update files are now located in the updates download 
folder. The default location of this folder is C:\Documents and 
Settings\All Users\Application Data\Maximizer\Live 
Update Manager. 

The updates download folder 
path is specified in the 
Preferences tab of Live Update 
Manager.

If your Live Update Manager configuration does not use the 
default location, this folder may be in a different location.
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Approving Updates
Once you have downloaded any available updates with the Live 
Update Wizard, they appear in the Available Updates list of the 
Updates tab in Live Update Manager. You must approve these 
updates before copying them (and the MaxUpdates.xml file) to your 
Live Update server.

Use the Approve button on the Updates tab to approve and 
disapprove updates. Approving an update modifies the 
MaxUpdates.xml file, which keeps track of approved updates. Once 
an update is approved, it is available to any Maximizer CRM servers 
or workstations that check for updates.

The following sections contain more information on approving 
updates for Maximize users:

• “Testing Updates Before Approval” on page 283

• “Approving Updates for Download by Maximizer Users” on 
page 284

Testing Updates Before Approval

Between receiving an update from Maximizer Software and 
releasing it to your organization, you should test the update in a test 
environment and once satisfied should deploy it to all Maximizer 
CRM servers that host Address Books. Assuming that you have 
already deployed a production Live Update Manager deployment, 
the two ways to set up testing are as follows:

• Install a test deployment of Live Update Manager on another 
machine, with its own testing Live Update server URL. The 
download location could be the same as for the production Live 
Update Manager. One Maximizer CRM server and one or more 
Maximizer CRM workstations should be configured for testing 
and to download updates from the test Live Update server. Once 
these updates are verified, you can return to the production Live 
Update Manager and approve the updates. 

• Alternatively, rather than using a test Live Update Manager to 
manage updates, simply copy the downloaded updates to the 
test Maximizer CRM server and workstation(s) and run the 
update(s) manually on the test machines (i.e., distribute the 
updates for testing manually rather than using Live Update 
Manager to distribute the updates). Following testing, return to 
the production Live Update Manager and approve the updates.
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Approving Updates for Download by Maximizer Users

After testing the updates, you can use Live Update Manager to 
approve updates. After approving the updates, you must copy the 
update files and MaxUpdates.xml file to your Live Update server 
before users can download the updates from Administrator or 
Maximizer.

➤ To approve software updates for download by 
workstations

� In the Updates tab of Live Update Manager, select one or more 
downloaded update(s).

� Click the Approve button.

The values of the Approved column changes from “No” to 
“Yes”.

� Click Apply to save your changes.

� Repeat these steps to approve any other updates, as needed.
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Copying the Update and XML Files to the Web Server
After you have downloaded and approved any updates, you must 
copy the files and the MaxUpdates.xml file to the virtual directory on 
your Live Update server. The location of the files on the server must 
match the URL specified in the updates properties.

Once you have copied the files to your Live Update server, you can 
verify the URLs for each update using Live Update Manager. The 
Verify URLs button checks that the approved update file(s) and 
updated MaxUpdates.xml file actually exist at the location specified 
by the Live Update server URL.

➤ To copy the update files to the Live Update server

• Copy the following files to the virtual directory on your Live 
Update server.

➤ To verify update URLs

• On the Updates tab of Live Update Manager, click Verify URLs.

Live Update Manager verifies all approved updates. If the 
verification succeeds, Maximizer users can download the 
updates from your Live Update server.

If the verification fails, ensure that the update files and current 
MaxUpdates.xml file have been copied to the correct location on 
the Live Update server, that the URL defined for the update is 
correct, and that your web server settings are correct.

File(s) to copy Location to copy file(s) from

Downloaded update 
file(s)

Updates download folder, specified on the 
Preferences tab of Live Update Manager.
The default updates download folder is 
C:\Documents and Settings\All 
Users\Application Data\Maximizer\Live 
Update Manager

MaxUpdates.xml Live Update Manager program folder 
(usually C:\Program Files\Maximizer Live 
Update).
This file contains information about 
downloaded updates and gets updated 
every time you download an update. 
You have to copy the most recent version 
of this file to your web server each time 
you approve a new update.
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Configuring the Maximizer Live Update Service
The default configuration for Maximizer CRM servers and 
workstations is with the Live Update service enabled and using the 
URL for the Maximizer Software update server. Change the URL in 
Administrator Preferences to point to your own Live Update server to 
enable all Maximizer CRM workstations and servers that connect to 
global Address Books on that server to use the Live Update service 
through your Live Update server.

➤ To configure the Live Update Service

� In Administrator, select File > Preferences.

� On the System Options tab, click Live Update.

� The Enabled Maximizer Live Update checkbox is selected by 
default. If it has been cleared, make sure to select it.

� By default, the URL of update server field contains the URL of 
the Maximizer Software Live Update server. Change it to the 
URL (e.g., www.escona.com/liveupdate) or the UNC network 
path (e.g., \\LiveUpdateServer\liveupdate) of the Live Update 
folder on your web server.

� By default, Enable automatic Maximizer Live Update 
notification is turned on. When enabled, Live Update displays a 
message on the Maximizer server(s) and workstations when a 
new update becomes available on the Live Update server. If you 
turn automatic notification off, users must manually check for 
updates on each machine.

� By default, Live Update automatically checks for updates every 
14 days. You can optionally change the Interval to check for 
updates.

� Click OK to save your changes and close the dialog box.

�

�
�

�
�
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Updating Maximizer with Live Update
The Maximizer Live Update Service is installed automatically with 
Maximizer CRM server and workstation. It enables users to download 
updates such as hot fixes and service releases, and you can configure 
Live Update to provide automatic notification of available updates.

The Live Update Wizard on Maximizer workstations connects to your 
Live Update Server and downloads any available updates.

After downloading the software updates, the downloaded 
executable file should launch immediately to start the installation. If 
you need to locate the downloaded file, it is in the user’s Application 
Data folder (typically C:\Documents and 
Settings\<CurrentUser>\Application Data\Maximizer\Live Update).

The updates download folder 
path is specified in the 
Preferences tab of Live Update 
Manager.

If the Enable automatic Maximizer Live Update notification option is 
selected in the Live Update options in Administrator, a message box 
you when new updates are available. You can also check for updates 
at any time from Maximizer or Administrator.

Live Update options iare 
accessible through the Live 
Update button on the System 
Options preferences in 
Administrator. (Select File > 
Preferences.)

➤ To download software updates from the server

� If you are notified that new updates are available, click OK in the 
message box to start the Live Update Wizard.

– or –

In the top-left corner of the Maximizer window, click the 
Maximizer button, and select Help. Then, under About 
Maximizer, select Maximizer Live Update.

– or –

In Administrator, select Help > Maximizer Live Update.

� Click Next.

The Live Update Wizard connects to the Live Update Server to 
check for any available updates.

� Select the update(s) to download.

� Click Next to download the selected updates.

� Click Finish to close the wizard.
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In this chapter...

“Introduction to Remote Automated Installation” on page 290

“Requirements for Recording Setup Script Files” on page 290

“Creating the Script Files” on page 292

“Systems Management Server (SMS) Software Distribution” on page 293

“Other Distribution Methods” on page 294
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Introduction to Remote Automated Installation
The setup script files are 

InstallShield response files and 
have an .ISS extension.

Maximizer CRM setup supports remote automated installation and 
uninstallation in environments with multiple workstations. Record 
script files of the installation and uninstallation processes, and then 
use these scripts with automated installation tools, such as Microsoft 
Systems Management Server (Microsoft SMS) to install Maximizer.

Requirements for Recording Setup Script Files
Before recording the setup script for distribution in your system, 
ensure the workstation computer you are using is in the same state 
as workstations where the setup script will run. Otherwise, the 
remote installation may encounter dialog boxes not included in the 
script file. Any unexpected event, such as a message box waiting for 
user input, may cause installation to fail.

This sequence is not required. 
However, creating the scripts 
in this order is most likely to 
produce successful results.

It is beneficial to record the setup scripts in the following sequence to 
ensure the machine is in the same state as a typical workstation when 
recording the installation scripts:

� Ensure Maximizer is installed on the machine.

� Record the uninstallation script, as described on page 292.

� Install Maximizer again. Do not create the installation script at 
this time. 

This installation enables you to run the uninstallation script for 
the first time in the next step.

� Uninstall Maximizer from the workstation computer using the 
uninstall script file. 

You can run the uninstallation script from the Windows 
command line using the commands described on page 294. 
Running the uninstallation script before recording the 
installation script enables you to put the machine into the 
correct state for creating the installation script.

� Record the installation script on the workstation, as described on 
page 292.

This sequence helps ensure that the installation script records the 
dialog boxes and response actions encountered during installation.
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When preparing to create a setup script, take the following 
components of Maximizer installation into consideration:

• MDAC components version

• .NET Framework version (if applicable)

• SQL Server Express engine (if applicable)

• MaxExchange Remote installation (if applicable)

• Maximizer Program installation folders

• Maximizer Data installation folders

• Maximizer Sample Data files

• Microsoft Word installation

• Microsoft Outlook installation

• Corel WordPerfect installation

Record separate setup script files for each variation in setup options. 
For example, to install MaxExchange Remote on some workstations, 
you must either modify the setup script file manually or record a 
separate sample installation to generate a new setup script file for 
that option.
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Creating the Script Files
Use the following procedure to create both the uninstallation and 
the installation script files. If Maximizer is already installed on the 
machine where you create the script, setup.exe removes the 
program, and the resulting script file is an uninstallation script. 
Conversely, if Maximizer is not installed on the machine, setup.exe 
installs the program, creating an installation script file.

Complete this procedure twice—once to create an uninstallation 
script file, and again to create an installation script file. If the 
automated installation will be re-installing Maximizer, it must first 
remove the existing installation.

➤ To create a setup (install or uninstall) script file

� Click Start > Run.

� In the Open field, enter the path to the Maximizer CRM 
setup.exe file (e.g., D:\MaxEnt\setup.exe), followed by /r, which 
tells Windows to record the setup as a script file.

� Click OK.

The Maximizer setup process begins.

� Follow the on-screen setup instructions.

� When setup is complete, reboot the computer if required.

� Locate the setup.iss file in the Windows folder (usually 
C:\WINNT or C:\Windows). 

� Rename the file (e.g., MEInstall.iss or MEUninstall.iss).

You must rename the script file 
from the default name because 
setup.iss will be automatically 
overwritten next time you 
record a setup script file.

You now have the installation or uninstallation script file. 
Repeat the procedure to create the second script file.
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Systems Management Server (SMS) Software Distribution
Once you have recorded the setup script files, you can use Systems 
Management Server (SMS) software to install Maximizer on 
workstations using a “push” method. Set up these distribution 
packages from the SMS administration console. Every package 
consists of three tasks that you must create and manage:

• the package definition

• the program that carries out the package tasks

• the process of distributing the packages to distribution points 
that are accessible by SMS clients that need to run the program 
that is targeted to them

SMS packages contain the files and commands for the user to run the 
programs in the package, in addition to information such as which 
distribution points provide the package source files to client 
computers. For each package, you must specify

• general information about the package, such as the name, 
version number, and vendor of the software

• whether the package includes package source files

• if there are package source files, specify

• the package source folder that contains the package source 
files

• whether SMS should create and store a compressed copy of 
the package source files

• how SMS stores the package source files on distribution 
points

• whether and how often the package source files on 
distribution points must be updated

Refer to your SMS documentation for more information.
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Other Distribution Methods
If you don’t have SMS, you can use other tools to distribute 
Maximizer remotely. The following sections contain information on 
other distribution methods:

• “Windows Scheduler” on page 294

• “Batch Files” on page 295

Windows Scheduler

If you don’t have SMS, you can use Soon.exe for remote distribution. 
Soon.exe is a tool for scheduling Windows Scheduled Tasks on any 
machine in a domain. 

• For installation, Scheduled Tasks should specify the path to the 
Maximizer setup.exe with /s /f1<iss file path> parameters.

There is no space between /f1 
and the .ISS file path.

For example, 
D:\MaxEnt\setup.exe /s /f1C:\Winnt\MEInstall.iss

To bypass the call to the live update server to check for updates, 
add the /z”noupdatecheck” parameter.

• For uninstallation, Scheduled Tasks should specify the path to 
the Maximizer setup.exe with /s /x /f1<iss file path> 
parameters.

For example, 
D:\MaxEnt\setup.exe /s /x /f1C:\Winnt\MEUninstall.iss

As with SMS, using Windows Scheduled Tasks requires the setup 
script file to be created on a sample workstation machine and then 
reused for all other workstations on the network.

For more information about Soon.exe, refer to the Microsoft 
Knowledge Base.
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Batch Files

You can also distribute Maximizer installations using batch files, if 
the user logs into a domain. This method is similar to Windows 
Scheduled Tasks, except that the installation runs when the user logs 
into the domain.

The following example shows the contents of a batch file that runs 
the Maximizer setup program (D:\MaxEnt\setup.exe) and uses the 
setup script file (C:\Winnt\MEInstall.iss):

@echo on

D:\MaxEnt\setup.exe /s /f1C:\Winnt\MEInstall.iss

When creating your own batch file, change the paths and filenames 
from this example to the paths and filenames of the Maximizer CRM 
setup and setup script file on your system.

Refer to your Windows documentation for more information about 
creating batch files.
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Working with Dashboards
Dashboards are graphical display of quantitative Address Book 
information. They includes a variety of indicators that display 
information about Address Book entries, opportunities, campaigns, 
customer service cases, quotas, and activities. Dashboards are 
accessible from the My Work Day window in Maximizer and 
Maximizer Web Access. Users can also view dashboards from mobile 
devices using Wireless Access.

Users must have the rights to be able to view and modify dashboards. 
For more information, see “User Access Rights and User/Group Access 
Settings” on page 85.

In Administrator, you can delete or view the properties of 
dashboards and create SQL metrics for dashboard indicators. In 
Maximizer, you can create and modify dashboards and dashboard 
indicators. For information on setting up dashboards and dashboard 
indicators, see the Maximizer CRM User’s Guide.

Dashboard Indicators

Indicators display the information in dashboards. Each dashboard 
can contain multiple indicators.

You can set up indicators to access information in the Address Books 
in the following ways:

• Searches – Users can link indicators with existing searches in the 
search catalog. The indicator reports either the number of 
entries returned in the search or a calculation based on fields in 
the entries.

• SQL metrics – In Administrator, you can set up SQL queries that 
report on any information in your Address Book. While they are 
defined in Administrator, users can add any of these metrics to 
dashboard indicators in Maximizer and Maximizer Web Access.

Users can choose from a number of indicator controls to display the 
data. These controls format your Address Book data in charts, lists, 
and gauges.
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Configuring Dashboards
You must install the Dashboard Components for Microsoft IIS in 
order to use dashboards. Dashboards should work with the default 
configuration after installation. You can specify a different 
dashboard URL and specify how often to refresh dashboards in the 
Dashboard preferences.

➤ To configure dashboards

�  In Administrator, select File > Preferences.

� Select the Dashboard tab.

� If you are using a different server to host your Dashboard, 
specify the Dashboard URL.

If you are using a different port from the default port (80), enter 
the port number as part of the URL. For example, https://TEST-
SERVER2:8080/Dashboard.

� In the Dashboard refresh time (minutes) field, enter the 
refresh rate for Dashboard.

– or –

Select Manual refresh only to refresh Dashboard only when 
users select Refresh in the Dashboards tab of the My Work Day 
window.
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� Click OK to save the changes.

Configuring Dashboards in a MaxExchange Environment

If you work in a MaxExchange environment, you can configure 
dashboards to run on the main server with data from the central 
Address Book or on the remote or remote server with data from the 
local copy of the central Address Book.

Running Dashboards on Remotes or Remote Servers

To run dashboards on a MaxExchange Remote or Remote Server, the 
remote or remote server must be running on a Maximizer Server 
installation. In this configuration, dashboards displays information 
on the local copy of the central Address Book by default. Any users 
connecting to the Address Book, including MaxExchange remotes 
and Maximizer workstations connected to the Address Book, view 
data from the local copy of the central Address Book in the 
dashboards.

Running Dashboards on MaxExchange Servers

To run dashboards on the main MaxExchange Server, the remote or 
remote server must have the following configuration:

• The local Address Book has the same name as the central 
Address Book.

• The Dashboard URL on the remote points to the URL of the 
Dashboard virtual directory on the server.

You can set the Dashboard 
URL in the Dashboard 
preferences in Administrator.

• The remote is able to access the Dashboard URL through the 
network.

In this configuration, dashboards are run on the main MaxExchange 
Server and reports on information in the central Address Book. The 
data reported in the dashboards may be inconsistent with the data in 
your local Address Book.

Note that the Dashboard URL can also point to any other server in 
the MaxExchange distribution list as long as the Address Book names 
are the same and the server runs on a Maximizer Server installation.
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SQL Metrics for Indicators
Dashboard indicators display numeric values returned by catalog 
searches or by custom SQL queries. You can define your own SQL 
metrics in Administrators to display custom data in dashboard 
indicators. The SQL metrics consist of custom SQL queries and the 
click-through URL for the indicator. 

Users can associate indicators with SQL metrics in Maximizer or 
Maximizer Web Access. Users can also link indicators with catalog 
searches.

The following sections contain information on setting up SQL metrics 
for dashboard indicators:

• “Queries for SQL Metrics” on page 301

• “SQL Queries Across Databases” on page 301

• “Creating or Modifying Custom SQL Metrics” on page 302

Queries for SQL Metrics

A SQL query used in a SQL metric must return a single numeric value 
(real). Otherwise, the indicator will display a 0. You must have a good 
understanding of SQL syntax and the database structure to create 
SQL queries.

SQL queries are run for the current logged in user. A dashboard 
indicator using a SQL metric may display different results to different 
Maximizer users.

SQL queries must select data from database views, and not from 
tables. For example, to query data in AMGR_CSCases_Tbl, you should 
write the query for the AMGR_CSCases view.

SQL Queries Across Databases

SQL queries for dashboard indicators are not restricted to the current 
Maximizer Address Book database. You can define SQL metrics that 
query another database on the same SQL server.

To create a cross-database SQL query, use the following syntax:

Select * from <database name>.<db owner>.<table name>

The following example shows a cross-database SQL query:

Select SUM (Revenue) from Accounting.dbo.Purchases
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Requirements for Cross-Database Queries

To successfully use cross-database SQL queries in dashboard 
indicators, the following conditions must be met:

• Database(s) referenced in the SQL query must all reside on the 
same SQL Server as the Maximizer Address Book where the 
dashboard indicators are being created.

• The Maximizer user running the SQL queries must be granted 
Select access (read access) to the views in database(s) being 
queried.

Alternatively, in the Maximizer Address Book, you can create 
views that reference an external database and grant users access 
to these views. This method may require enabling the “Cross 
database ownership chaining” option on the SQL server, which is 
not recommended for security reasons. 

Creating or Modifying Custom SQL Metrics

Use the procedure below to create a new SQL metric. You can also 
follow these instructions to modify an existing SQL metric. Instead of 
clicking Add, select the indicator to change and click Properties.

➤ To create a custom SQL metric

� In Administrator, select File > Preferences.

� Click the Dashboard tab.

� Click Add.

� Enter a Name and Description for the SQL metric.

� Enter the SQL Query.

SQL metrics query only values 
that the logged in user can 
access.

The SQL query must return a single numeric value (real). 
Otherwise it displays a 0 in the dashboard.

� Click Test Query to test the SQL query.
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� Click OK to save the new SQL metric.

 

�

�
�

�
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Windows Authentication for Dashboards
If you are running dashboards in a Windows Authentication 
environment, you may need to perform additional steps to set up 
Windows Authentication for dashboards.

If you are using Maximizer Web Access to access dashboards, you 
need to configure Windows Authentication for Maximizer Web 
Access. You do not need to specify any additional settings for 
Windows Authentication to work for dashboards. For more 
information, see “Setting Up Windows Authentication for Web 
Access” on page 213.

If you are running dashboards in Maximizer, you must configure the 
Dashboard virtual directory for Windows Authentication in Microsoft 
IIS. For more information, see “Microsoft IIS for Windows 
Authentication” on page 22. As well, you must enable Windows 
Authentication in the Web.Config file for the Dashboard virtual 
directory. 

➤ To enable Windows Authentication in the 
Web.Config file

�  Open the Web.Config file for the Dashboard virtual directory.

By default, the Dashboard web.config file is stored in the 
following location on the server:

...\Maximizer\Portals\DashboardWeb.Config

� In the <system.web> section, locate the <authentication> 
element, and change the setting to true as follows:

<authentication mode="Windows"/> <identity 
impersonate="true">

� Save the Web.Config file.
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Backing Up and Restoring Address Book Data
This section explains how to back up and restore Maximizer Address 
Book database files, which contain the majority of your Maximizer 
data, including Address Book entries, opportunities, customer service 
cases, campaigns, etc. However, if your Address Book uses a custom 
dictionary or holidays, you must back up those files separately.

The following sections contain information on backing up Address 
Book data in Maximizer:

• “Backing Up an Address Book” on page 306

• “Restoring an Address Book from a Backup” on page 309

• “Moving an Address Book to a Different Server” on page 311

• “Backing Up the Dictionary and Holiday Files” on page 311

Backing Up an Address Book

There are two types of backup procedures available:

• Regular Backup. This backup procedure requires the Address 
Book to be closed. Regular backup can be performed only in 
Maximizer.

• Quick Backup. This backup procedure is performed on an open 
Address Book. You can perform a Quick Backup from either or 
Maximizer. If security is enabled, you will need access to the 
MASTER user password.

Regular Backup 

The extension of the backup 
file is .BAK.

A regular backup is saved by default to the folder containing the SQL 
database files for the Address Book. If you don’t want to save the 
backup to this location, you can browse to another one.

➤ To perform a regular backup

� To verify currently logged in users, open the Address Book in 
Administrator and select Reports > Current Users. Ensure that no 
users are logged into the Address Book you want to back up. 

� In Administrator, close the Address Book and select Utilities > 
Back Up Address Book.
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� Select the Address Book to back up, and click OK.

� Enter the MASTER user password, and click OK.

The Backup / Restore Details dialog box opens.

� Select the backup folder:

• If you want to save the backup to the default location, leave 
the Backup Location field blank.

The default location is where 
the SQL database files for the 
Address Book are stored.

• If you want to save the backup file to a different folder, click 
Browse. Select a folder for the backup file and click OK. 

Maximizer starts backing up the files. Depending on the size of 
the Address Book, the backup could take several minutes or 
several hours. A message box confirms that the backup is 
complete. The backup file name is displayed. 

� Click OK.
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Quick Backup

The advantage of using Quick Backup is that you can perform 
frequent backups of any open Address Book.

If you are backing up a global Address Book from a workstation, the 
backup is automatically saved to the default SQL Server Express 
backup folder. You do not have the option to save the backup to a 
different location. By default, the backup is saved to the current 
Address Book folder. If you don’t want to save the backup to this 
location, you can browse to another one. 

If you choose to save the backup to the default location, Quick 
Backup creates a subfolder named Backup in the same folder as the 
Address Book files. 

The backup file name includes the current date as an identifier. For 
example, the following backup file was created from a Quick Backup 
performed on March 23, 2007. (The backup was saved to the 
following default location).

C:\ProgramData\Maximizer\AddrBks\EsconaTutorial\Backup\EsconaT
utorial_20070323_01.BAK

The “_01” is added to the file name to differentiate between 
backups from the same day, so a second backup on the same day 
would be saved as follows:

C:\ProgramData\Maximizer\AddrBks\EsconaTutorial\Backup\EsconaT
utorial_20070323_02.BAK

Quick Backup also lets you determine how many backups are kept. If 
you were to set Quick Backup to retain only five backups, then when 
you create the sixth backup, Quick Backup deletes the oldest backup.

➤ To perform a Quick Backup

� Open the Address Book to back up.

� Select File > Quick Backup.

� Enter the MASTER user password.

If this box is disabled, continue to the next step.
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� Select the backup folder:

If you want to save the backup file to the default location 
(Address Book folder), leave the Backup Location field blank. 

If you want to save the backup file to a different location, click 
Browse. Select a folder in the Browse for Folder dialog box and 
click OK. The location is displayed in the Backup Location field.

� Specify the number of previous backups to retain.

This option is disabled if you are backing up a global database 
on a workstation.

� Click OK to begin backing up.

When the Quick Backup is complete, a message box confirms 
that the backup was successful. The backup file name and 
location are displayed. 

� Click OK.

Restoring an Address Book from a Backup

If you lose or damage your Address Book, you can restore it to a 
previously backed up version. When you perform a restore, existing 
Address Book data is replaced with backup Address Book data. 

➤ To restore an Address Book

� To determine if users are logged in, open the Address Book in 
Administrator and select Reports > Current Users. Ensure that 
the Address Book you want to restore is not currently open by a 
user. 

� In Administrator, close the Address Book and select Utilities > 
Restore Address Book.

� Select the Address Book to restore.

� Click OK.

�

�
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� Enter the MASTER user password, and click OK.

The Backup / Restore Details dialog box opens.

� Click Browse, select the backup file you want to restore, and 
click Open. 

The full path of the backup file is displayed in the Backup 
Location field.

� Click OK. 

Maximizer restores the Address Book from the selected backup 
file. A message box confirms that the restore is successful.
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Moving an Address Book to a Different Server

You can use the backup and restore functionality to move an Address 
Book to a different computer.

➤ To move an Address Book

� Backup up the Address Book. For more information, see 
“Backing Up an Address Book” on page 306.

� Move the backup Address Book (.BAK) file to the new computer.

� Restore the Address Book on the new computer. For more 
information, see “Restoring an Address Book from a Backup” on 
page 309.

Backing Up the Dictionary and Holiday Files 

The Maximizer dictionary and holiday files are not backed up as part 
of the Address Book backup procedure(s) described previously. 
Therefore, if you have customized the dictionary or holidays, you 
need to back up those files separately, especially before upgrading or 
re-installing Maximizer.

To back up the dictionary and holiday files, copy them from the 
following location and paste them to another location, preferably 
the same location where your Address Book is backed up.

The user dictionary file is unique to each Maximizer workstation, so 
you will need to back up this file for each workstation.

By default, the Maximizer 
program folder is C:\Program 
Files\Maximizer. If Maximizer 
was installed in a different 
folder, then change the path 
accordingly.

User Dictionary File Location:

...\Program Files\Maximizer\MaData6\Userdict.lex

Holiday File Location:

...\Program Files\Maximizer\MaData6\Mxzhol.nam
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Converting Embedded Documents to Linked Documents
Maximizer has a built-in utility in Administrator for converting 
embedded documents to linked documents. This allows you to 
manage the size of your Address Book. 

Note that a converted Address 
Book size cannot exceed 4 GB 
(4000 MB). If you are 
upgrading a Pervasive.SQL 
database to SQL Express, and 
the Address Book size exceeds 
4 GB, the upgrade process is 
stopped and the initial state of 
the Pervaisve.SQL is retained.

If necessary, you can move your linked documents from one location 
to another. 

➤ To convert embedded documents to linked 
documents

� In Administrator, select File > Document Administration > 
Convert Embedded Documents.

� Select the Convert embedded documents checkbox.

If you are using MaxExchange, 
converting embedded 
documents to linked 
documents causes documents 
to be removed from the 
remotes. The documents 
remain on the server.

� Specify the document size and age limits. If these values are left 
as zeros, all embedded documents regardless of size/age are 
converted to linked documents.

� Optionally, select the Shrink database when completed 
checkbox. This reduces the size of the Address Book once the 
conversion is complete. If you haven’t chosen to convert your 
embedded documents, this reduces the size of the Address Book 
by removing any unused space. 

� Specify the folder in which linked documents will be stored in 
the Link Folder field. 

You should use the full UNC path as the location. For example, 
enter \\[computer name]\Linked Documents\. To ensure the 
correct UNC path is used, browse to computer and folder where 
the linked documents are to be stored. 
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� Click the Recalculate button after revising the conversion 
settings to estimate the size of the Address Book with the 
revised settings.

➤ To modify the location of linked documents

� In Administrator, select File > Document Administration > 
Move Linked Documents.

� Specify the folder where the linked documents were previously 
stored in the From folder. 

� Specify the new folder where the linked documents will be 
stored in the To folder.

You should use the full UNC path for both folders. 



Maximizer CRM 11
Administrator’s Guide

314
Verifying and Recovering Address Book Data
You can verify and recover only 

one Address Book at a time.
Address Book verification enables you to quickly identify and resolve 
invalid and orphan items in your Address Book. You should always 
run Address Book Verification and Recovery after upgrading or 
restoring an Address Book. Also, if database views have not been 
created for any user-defined fields and are needed for generating 
reports, use Address Book Verification and Recovery to create the 
missing database views.

Address Book Verification and Recovery identifies the following 
Address Book items.

Address Book Item Description

Orphan Contacts Contacts that are not associated with a 
Company record.

Orphan alternate 
addresses

Addresses that are not associated with an 
Address Book record.

Orphan notes Notes that are not associated with an Address 
Book entry, opportunity, campaign, or customer 
service case.

Opportunity records 
with invalid 
Start_Date field 
value

Opportunities whose start date does not match 
the earliest Sales Step start date (applies only to 
opportunities with an assigned strategy).

Notes with 
undefined Entity 
Type

Notes that do not have an entity type value 
(Address Book entry, opportunity, campaign, 
customer service case, or user) assigned to the 
record 

Broken Company 
Library links

Company Library links that try to connect to a 
missing document (link exists but the document 
is missing).

Orphan Company 
Library links

Company Library links that link to a missing 
Company Library folder (document exists, link 
exists, but the Company Library folder is 
missing).

Orphan Company 
Library documents

Company Library documents not listed in the 
Company Library folders (document exists but 
the link is missing).

Invalid Opportunity 
records

Opportunities whose start date does not match 
the earliest Sales Step start date (applies only to 
opportunities with an assigned strategy).

Invalid Address book 
records

Company records containing personal 
information about an Individual or Contact.
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To see recovered entries, you 
must log in as MASTER or have 
rights to open other users’ 
entries.

When you choose to “recover” the Address Book, Maximizer 
transfers recovered Address Book entries into a single entry called 
“Recovered on [date of recovery]”, and it transfers recovered 
Company Library documents into a single folder called “Recovered 
on [date of recovery]”. You can then view the recovered entries and 
either delete or move them as needed.

➤ To verify an Address Book

� In Administrator or MaxExchange Server Manager, open the 
Address Book. 

� Select File > Address Book Verification.

� Choose either the Verify Only or Verify and Recover option, 
and click OK.

If you select Verify Only and 
Maximizer detects invalid 
records, it prompts you to 
recover them.

Maximizer runs the Address Book verification process, as well as 
the recovery process if you selected the second option. When it is 
complete, you see the Address Book Verification and Recovery 

Invalid Document 
records

Documents whose Owner field contains invalid 
characters or values.

Misplaced 
Document records

Documents whose Owner field contains an 
incorrect value.

User-defined fields 
that do not have 
associated database 
views

User-defined fields for which a database view 
has not been created.

Invalid Table UDF 
Item records

Table user-defined field items that have the 
wrong type (Company, Individual, Contact, etc.).

Invalid/orphan Table 
UDF values

Table user-defined field values that reference 
non-existent table items.

Orphan Link Records Opportunities that do not have a related 
Address Book entry.

Address Book Item Description

�
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Information dialog box, which contains a summary of each 
verification performed and the results of the verification.

� If you selected the Verify and Recover option, open the 
Address Book in Maximizer, and view the Recovered on [date] 
Address Book entry. You can then delete or move the recovered 
entries.
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Exporting Data from Maximizer
You can export Address Book entries, customer service cases, and 
Knowledge Base articles from Maximizer only, not Administrator.

Exporting Address Book entries creates a text file or XML file 
containing information from the current Address Book. It exports 
any Companies and Individuals selected in the Address Book list. If no 
Address Book entries are selected, it exports all Companies and 
Individuals currently displayed in the list.

The following sections contain information on exporting data from 
Maximizer:

• “Exporting Address Book Entries in XML Format” on page 317

• “Exporting Address Book Entries in Text Format” on page 320

• “Selecting Fields for Export” on page 322

• “Exporting Customer Service Cases” on page 323

• “Exporting Knowledge Base Articles” on page 325

Exporting Address Book Entries in XML Format

The unique ID is exported with 
each Company or Individual, 
but unique IDs for contacts are 
not exported.

By default, exporting Address Book entries in XML format exports 
name, address, phone number, email address, and company details 
information from the Basic Information tab of the selected 
Companies and Individuals (or all entries in the list if none are 
selected). You can easily import this file into another Address Book.

You can optionally export the following additional information:

These options are available for 
XML export only, not CSV or 
tab-delimited exports.

• Include contacts exports the contacts associated with the 
exported Address Book entries. 

• Include Customer Service Cases exports customer service 
cases associated with the exported Address Book entries. 

• Include Opportunities exports Opportunities associated with 
the exported Address Book entries. 

• Include UDFs exports all Address Book user-defined fields 
associated with the exported Address Book entries, along with 
their attributes, and in the case of table user-defined fields, any 
items they contain. Keep in mind that exporting user-defined 
fields increases the length of time required for the export 
process, and not selecting this option improves speed.

Formula user-defined fields are 
exported as alphanumeric, 
date, or numeric user-defined 
fields. The values are exported, 
but they will not be 
recalculated after export.

• Include notes exports notes associated with the exported 
Address Book entries, including date and time, owner, creator, 
type, and text fields.

• Include documents exports documents associated with the 
exported Address Book entries, including date and time, 
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document type, document name, creator, owner, as well as the 
document data itself.

• Support non-English characters converts the contents of the 
exported XML file to Unicode format, which is required for 
languages using more than one byte per character, such as 
Chinese. If you don’t select this checkbox, characters will be 
exported in ASCII format.

➤ To export Address Book entries in XML format

� In Maximizer, open the Address Book window.

� Select the Companies and Individuals to export. If you don’t 
select any entries, Maximizer will export all entries currently 
displayed in the Address Book list.

� In the top-left corner of the window, click the Maximizer 
button, and select Import/Export/Transfer. Then, under 
Import, select Address Book entries

The Export Address Book Entries dialog box opens.

� From the Format drop-down list, select XML.

� Click the Browse button.

� Specify the destination location and File name for the exported 
file. 

� In the Save as type drop-down list, select either MXI or XML.

�

�
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	 Click Save.


 Select any of the Export options, as needed. Each of the 
options is described before this procedure.

��Click OK.

Maximizer exports the Address Book entries and additional data 
as selected in the options to the specified file.




��

�
�
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Exporting Address Book Entries in Text Format

User-defined fields that 
contain more than one item 
are not supported in a CSV or 
tab-delimited export. Use XML 
export instead.

Exporting to comma-separated values (CSV) format creates a file with 
a .CSV extension, which is readable by spreadsheets such as Microsoft 
Excel and many other programs.

Exporting to tab-delimited format creates a text (.txt) file with tabs 
separating each field value. This file is readable by any program that 
supports .txt files.

Exporting to these formats exports selected Companies and 
Individuals in the Address Book, but you do not have the option of 
exporting Contacts.

Unlike XML Format, exporting to CSV and tab-delimited format 
enables you to specify individual fields to export, including Address 
Book user-defined fields.

You can also export Notes associated with the Companies or 
Individuals. You have the option of exporting all notes or most 
recent notes.

➤ To export Address Book entries in CSV or tab-
delimited format

� In Maximizer, open the Address Book window.

� In the top-left corner of the window, click the Maximizer 
button, and select Import/Export/Transfer. Then, under 
Export, select Address Book entries.

The Export Address Book Entries dialog box opens.

� From the Format drop-down list, select Comma Separated 
Value or tab-delimited.
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� Click the Browse button.

� Specify the destination location and File name for the exported 
file. 

� Verify that the format you selected previously appears in the 
Save as type field.

� Click Save.

	 Select the DOS text checkbox to export data that is in DOS 
standard ASCII. 

If the data is in ANSI ASCII (Windows default), do not select the 
checkbox.


 If you want the field names to be exported as the first record in 
the exported file, similar to a headings row, select the Include 
field names as first record in export file checkbox.

�

�

�

	




��

�

�
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��Click OK.

The Select Fields for Export dialog box opens.

��From the Available Maximizer fields list, select the fields to 
export by selecting each field and clicking Add.

– or –

Click Catalog to retrieve a previously saved export list.

��Click Export to begin the export process.

Selecting Fields for Export

You cannot export encrypted 
user-defined fields.

When exporting to CSV or tab-delimited format, you must select 
which fields to export, and in which order. The Select Fields for 
Export dialog box has two columns: the left column lists the Address 
Book entry basic fields, user-defined fields, and two fields for notes; 
the right column is initially blank. Select the fields to export from the 
left column and add them to the right column.

The order of fields in the right column is the order in which they will 
be exported. If you need to change the order of any fields, select 
each one and click Remove to delete it from the list; then, in the right 
column, select the field after which you want to place another field. 
Fields added to the right column appear directly below the field 
currently selected in the right column.

Once you have established the order of export fields as you would 
like it, you can click the Catalog button to save the export list for 
future exports. In the Export Catalog dialog box, click Add to create a 
new saved export list, or click Save to overwrite an existing export 
list. The Retrieve button opens an existing export list.

��

��
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Exporting Customer Service Cases

You can export customer service cases, their associated Address Book 
entries, as well as any related user-defined fields, notes, or 
documents. Exporting customer service cases exports any cases that 
have been selected in the Customer Service window (or all cases in 
the list if none are selected). The export file can be in either 
Maximizer XML Interface (MXI) or XML format.

You can also export Customer 
Service Cases from the Export 
Address Book Entries dialog 
box, but doing so only exports 
cases associated with the 
exported Address Book entries. 
For more control over which 
cases are exported, use the 
Export Customer Service Cases 
menu item.

MXI and XML files are both in XML format. However, you can import 
into Maximizer with MXI files more easily than XML format. To 
import an MXI file, simply double-click the file and it automatically 
handles the import.

The Export Customer Service Cases dialog box includes the following 
options:

• Include UDFs exports all Customer Service user-defined fields 
associated with the exported cases, along with their attributes, 
and in the case of table user-defined fields, any items they 
contain. Keep in mind that exporting user-defined fields 
increases the length of time to export, and not selecting this 
option improves speed.

Formula user-defined fields are 
exported as alphanumeric, 
date, or numeric user-defined 
fields. The values are exported, 
but they will not be 
recalculated after export.

• Include notes exports notes associated with the exported cases, 
including date and time, owner, creator, type, and text fields.

• Include documents exports documents associated with the 
exported cases, including date and time, document type, 
document name, creator, owner, as well as the document data 
itself.

• Support non-English characters converts the contents of the 
exported MXI or XML file to Unicode format, which is required 
for languages using more than one byte per character, such as 
Chinese. If you don’t select this checkbox, characters will be 
exported in ASCII format.

➤ To export customer service cases

� In Maximizer, open the Customer Service window.

� Select the cases to export. If you don’t select any cases, 
Maximizer will export all cases currently displayed in the 
Customer Service window.
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� In the top-left corner of the window, click the Maximizer 
button, and select Import/Export/Transfer. Then, under 
Export, select Customer Service Cases.

The Export Customer Service Cases dialog box opens.

� Click the Browse button.

The Save As dialog box opens.

� Specify the destination location and File name for the exported 
file. 

�

�

�



Chapter 12
Managing Address Book Data

325
� From the Save as type drop-down list, select either MXI or 
XML, and click Save.

The Save As dialog box closes.

� Select any of the Export options, as needed. Each of the 
options is described before this procedure.

	 Click OK.

Maximizer exports the customer service cases, associated Address 
Book entries, and additional data as selected in the options, to 
the specified file.

Exporting Knowledge Base Articles

As with customer service cases, you can export knowledge base 
articles to either MXI or XML format. The resulting file contains the 
content of the article itself, as well as additional information, such as 
filename, file extension, keywords, product, status, and creator.

➤ To export knowledge base articles

� In Maximizer, open the Knowledge Base window.

� In the top-left corner of the window, click the Maximizer 
button, and select Import/Export/Transfer. Then, under 
Export, select Knowledge Base Articles.

� Specify the destination location and File name for the exported 
file. 

� From the Save as type drop-down list, select either MXI or 
XML.

� Click Save.

Maximizer exports the Knowledge Base articles to the destination 
file.

�
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Importing Address Book Data from MXI or XML Files
You can use Administrator or Maximizer to import Address Book 
entries, customer service cases, knowledge base articles, and other 
data from MXI (Maximizer XML Interface) or XML Files. These MXI 
and XML files may have been created by exporting from Maximizer 
or by exporting the information from another source and converting 
it to XML using the Maximizer XML schema. For more information 
about the Maximizer XML Schema, refer to “Maximizer XML 
Interface (MXI)” on page 388.

After importing Address Book entries into Maximizer, you can 
identify the imported records by selecting the View tab, and 
selecting All Lists from the Favorite List group in the Address Book 
window. A list of imported Address Book entries is stored in a 
favorite list named according to the file format and import date and 
time.

About the MaxExchange Distribution field and XML Import

When importing the MaxExchange Distribution field from an XML 
file, if the destination Address Book hasn't created the field already, 
a version of this field will be created in the Address Book during the 
XML import, but it will NOT be the system MaxExchange Distribution 
field, and therefore will not work with the MaxExchange product.

If your XML file contains the MaxExchange Distribution field, please 
ensure that the destination Address Book has created the field 
already. (For information about creating the MaxExchange 
Distribution field, refer to “MaxExchange Distribution” on 
page 156.) This measure will ensure proper MaxExchange 
distribution in the destination Address Book.

The following sections contain additional information on importing 
data from MXI and XML files:

• “Importing MXI or XML Files Using Advanced Import” on 
page 326

• “Unattended Import of MXI or XML Files” on page 328

Importing MXI or XML Files Using Advanced Import

For more control over importing MXI files, or to import XML files, use 
the Advanced Import method described below, which enables you to 
specify a number of preferences about how to import the file.

Note that customer service cases are always imported as separate 
records and are never merged with existing cases. Formula user-
defined fields are imported as formulas as values.
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➤ To import from an MXI or XML file

Always back up the Address 
Book before importing.

� In Administrator, select File > Import > Advanced Import.

� For the File name field, click Browse and locate the .XML or 
.MXI file to import.

Once you have selected the file to import, Maximizer fills in the 
Log File field automatically.

� To change the default Log File, click Browse and provide an 
alternate log file location and/or name.

� Select a Log Level from the drop-down list.

� Specify any additional import options in the other group boxes, 
or just use the default values.

� Click OK to begin the import.

Maximizer imports the data and then displays the number of 
records inserted, updated, and failed for each record type.

� Click OK to close the message box.

�

�

�
�

�
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Unattended Import of MXI or XML Files

To import an MXI or XML file 
using OLE automation, refer to 
the ImportXMLFile function 
documentation in the 
Customization Suite 
documentation.

An alternative to Advanced Import is an unattended import, which 
you can initiate by double-clicking the MXI or XML file or by passing 
parameters to the Maxwin executable (MaxWin.exe) through a 
command-line interface. When using unattended import, you may 
choose to specify some of the import preferences within the MXI or 
XML file itself. For more information about MXI and XML files, refer 
to “Maximizer XML Interface (MXI)” on page 388.

Importing MXI or XML Files by Double-Clicking

➤ To import an MXI or XML file by double-clicking

� Locate the MXI file on the computer.

� Double-click the file.

� Select the Address Book to import into, and click Open.

� Enter your User ID and Password in the Login dialog box, and 
click OK.

Maximizer imports the data, and then displays a message 
identifying the number of records inserted, updated, and failed 
for each record type.

� Click OK.

Maximizer displays a message with the name of the Favorite List, 
which lists the imported Address Book entries. 

� Click OK to view the Favorite List.

Importing MXI or XML Files from the Command Line

To import an MXI or XML file from a command line, call Maxwin.exe 
with the following command-line syntax:

The command-line syntax 
shown here uses sample 
parameter values.

Maxwin.exe /DATABASE "EsconaTutorial" /USERID "JNAPOLI" 
/PASSWORD "maximizer" /FILE="d:\ABentries051013.mxi"

Keep the following points in mind:

• Only one space is allowed after the DATABASE, USERID, and 
PASSWORD keywords.

• Values must be surrounded by double quotation marks.

• The equal sign (=) after the FILE keywords must NOT have space 
before or after it.

• The FILE parameter must be the last parameter.
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Importing Data from Other File Formats
You can use Administrator to import Address Book information from 
other sources, such as ACT!, GoldMine, or Outlook. 

After importing Address Book entries into Maximizer, you can 
identify the imported records by clicking the View tab, and selecting 
All Lists from the Favorite Lists group, in the Address Book 
window. A list of imported Address Book entries is stored in a 
favorite list named according to the file format and import date and 
time.

Administrator provides the following methods of importing data. 
The best import method depends on the type of data you are 
importing.

• Address Book Entries: This method imports entries from a CSV 
(comma-separated values) or tab-delimited text file that is 
created when you export from Maximizer or another 
application. Outlook, for example, can export its address book to 
a text file. When you import from a text file, you must choose to 
import all the entries as Companies/Individuals or as Contacts, or 
you can do a two-tier import to import Companies/Individuals 
first and then import the associated Contacts. For more 
information, refer to “Two-Tier Import” on page 331.

• ACT! or GoldMine Database: Importing an ACT! or GoldMine 
database is straightforward because Maximizer can detect the 
ACT! or GoldMine database version and map the fields 
automatically. Refer to “Importing Data from ACT! and 
GoldMine” on page 337.

• Other Contact Manager Database: This option enables you to 
import a variety of data file formats, including Organizer, 
Clipper, dBASE, FoxBase, and FoxPro, among others. For more 
information, refer to “Importing from Other Contact Managers” 
on page 334.
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Use the following table to determine which import method to use.

File Type
Import Method(s)
(File > Import > ...)

ACT! 1.x, 2.x, 3.x, 4.x, 2000, 6.x 
(*.dbf)

ACT! 6.0 or 2004 or earlier

ACT! 2005–2010 or ACT! Premium 
for Workgroups 2005–2010

ACT! 2005–2010 and ACT! 
Premium for Workgroups 2005–
2010

GoldMine 2.x, 3.x, 4.x, 5.x, 6.x 
(*.dbf)

GoldMine 6.7 or earlier

GoldMine 6.7 Corporate Edition 
(MSSQL)

GoldMine 6.7 Corporate Edition 
or earlier

GoldMine 8.x Premium Edition 
(Firebird SQL, MSSQL)

GoldMine Premium Edition 8.x

Organizer 1.x (*.org) Other Contact Manager Database

Delimited (*.txt, *.prn) Other Contact Manager Database

Comma Delimited (*.csv) 
Tab Delimited (*.txt)

Address Book Entries

Clipper Summer '87 (*.dbf) Other Contact Manager Database

Clipper 5.x (*.dbf) Other Contact Manager Database

dBase III, III+, IV (*.dbf) Address Book Entries

dBase V (*.dbf) Other Contact Manager Database

Visual dBase 5.x (*.dbf) Other Contact Manager Database

FoxBase/FoxBASE+ (*.dbf) Other Contact Manager Database

FoxPro 1.x, 2.x (*.dbf) Other Contact Manager Database

Visual FoxPro 3.x (*.dbf) Other Contact Manager Database
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Field Mapping

When you import from a 
recognized database type, 
such as GoldMine or ACT!, 
Maximizer automatically maps 
the fields for you.

When importing some types of data files, you need to map (create an 
association between) the fields in the source file and the fields in 
Maximizer. Keep in mind that different applications name their fields 
differently. For example, the field for a company name is called 
“Company” in Outlook and “Company or Individual” in Maximizer.

When you are importing a file type that requires you to map fields 
Field Mapping dialog box opens where you can map Maximizer fields 
to fields in the source file. For each field in the source file, select one 
of the available Maximizer fields, and click Add to map the fields. 
Select a corresponding Maximizer field for every field in the source 
file. If there is no corresponding field, select <Skip Field> from the list 
of Maximizer fields. When you have finished mapping the fields, the 
Order of Import (middle column) displays the corresponding 
Maximizer field beside each field in the Fields from File column.

Two-Tier Import

If you import a Company 
record, and an existing 
Company record in the 
database has an identical 
“Company” field, then the 
records are considered 
duplicates, and Maximizer will 
not import the duplicate 
Company record. However, 
Maximizer will import 
duplicate Individual and 
Contact records.

Many contact management programs keep two types of address 
book entries:

• Companies

• Contacts for Companies

Maximizer keeps its Address Book entries organized in a similar way: 

• Companies/Individuals

• Contacts (associated with a Company or Individual)

The Import Address Book Entries function enables you to perform a 
two-tier import. In a two-tier import, you first import Company 
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entries as Companies/Individuals Address Book entries, and then you 
import the people as Contacts.

Two-tier importing is only applicable to comma-separated value files, 
tab-delimited files, dBase III, III+, or IV, or XML files using the File > 
Import > Address Book Entries command.

➤ To import Address Book entries (two-tier import)

Always back up the Address 
Book before importing.

� From the File menu, select Import > Address Book Entries.

The Import Address Book Entries dialog box opens.

� Click Browse and locate the file to import.

User-defined fields containing 
more than one available item 
are not supported in a CSV 
(comma-separated values) 
import. Use the Advanced 
Import feature or MTI 
(Maximizer Transfer Interface) 
as an alternative.

� Select the Companies / Individuals option to import all records 
in the source file as Company or Individual Address Book entries.

(After you complete this procedure, repeat it a second time to 
import the Contacts. If you choose not to do a two-tier import, 
just select either Companies / Individuals or Contacts.)

� In the Lead handling box, select the appropriate option for 
importing records as lead or non-lead Address Book entries.

� Click OK.

The Select Fields for Import dialog box opens.

� In the Available Maximizer fields column, select the field that 
best corresponds to the first field in the Fields from file 
<filename> column, and click Add. 

Repeat this step until you have mapped all the fields from the 
source file to Maximizer fields.

To exclude a field from being 
imported into Maximizer, add 
<Skip Field> to the middle 
column for that field position.

For example, if the first field in the right column is First Name, 
select First Name from the Available Maximizer fields.

For fields that contain more than one value such as non-single 
valued table user-defined fields, and full/read access fields, each 

�

�
�

�



Chapter 12
Managing Address Book Data

333
value must be its own column in the file and the same field must 
be mapped to each of those items.

The fields listed in the Available Maximizer Fields column is 
slightly different, depending on whether you selected 
Companies / Individuals or Contacts as the Type of Import in step 
3.

� To convert text that is in capital letters (uppercase) into mixed 
case, select the Convert to name case checkbox.

	 Many comma-delimited data files use the first line as a column 
header. To exclude the first line from being imported, select the 
Do not import first record; it is a header checkbox.

You can save the field 
mapping for reuse by clicking 
the Catalog button.


 Click Import.

The data from the source file now imports into Maximizer. 

��Repeat this procedure a second time to import the second tier, 
except select Contacts instead of Companies / Individuals as 
the Type of Import in step 3.

�

� 	 
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Importing from Other Contact Managers

The instructions below describe importing data from a contact 
manager other than ACT! or GoldMine. For information about 
importing from ACT! or GoldMine, refer to “Importing Data from 
ACT! and GoldMine” on page 337.

➤ To Import Contacts from another type of contact 
management database

Always back up the Address 
Book before importing.

� Select File > Import > Other Contact Manager Database.

The Import Databases dialog box opens.

� From the List files of type drop-down list, select the file format 
of the database you are importing.

� Locate the file you are importing. If the file is a network file, click 
the Network button or use the Drives drop-down list to access 
the network drive.

� In the Import Options group box, select the options you want 
to include. Depending on the type of database you are 
importing, some of these options may not be available.

� If you are importing a character delimited text file, you must 
specify a Date Format.

To do so, click the Date Format button, select the date format 
used in the source file, and click OK.

� If you are importing a .txt or .prn file, you must also specify the 
character used as the field Delimiter in the import file. 

Click the Delimiter button, select the delimiter type, and click 
OK.
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� In the Duplicate handling group box, select one of the options 
to specify what Maximizer should do when it encounters 
duplicate Address Book entries, and click OK.

The Select Fields for Import dialog box opens.

	 In the Contact fields or Address Book entries fields lists, 
select the field that best corresponds to the first field in the 
Fields from file <filename> column, and click Add. Repeat 
this step until you have mapped all the fields from the source file 
to Maximizer fields.

To exclude a field from being 
imported into Maximizer, add 
<Skip Field> to the middle 
column for that field position.

For example, if the first field in the right column is First Name, 
select First Name from the Contact fields or Address Book entries 
fields list.

Use Contact fields to create Contacts for Companies or 
Individuals.

Use Address Book entries fields to create Company or 
Individual Address Book entries.

�

�

�
�

�

�
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 Click Import to begin the import process.

Once Maximizer imports the data from the import file, the 
Conversion Completed or Import Completed message box 
displays the number of fields read, imported, skipped, failed, 
merged and the number of records with associated import 
warnings.

The Error Log appears next displaying the location of the import 
error message file. If you want to view this file, make a note of 
where it is located. Unless the import utility reports that all 
records were imported successfully, carefully review the 
ERRORLOG.TXT file to identify and resolve import problems. 

	






Chapter 12
Managing Address Book Data

337
Importing Data from ACT! and GoldMine

Duplicate Contacts are created 
on the second Import of the 
same ACT! or GoldMine 
database.

This section describes the procedure for importing data from ACT! or 
GoldMine, as well as the field mapping for data imported into 
Maximizer.

Importing Contacts from ACT! 6.0, 2004, or Earlier, or from GoldMine 6.5 or Earlier

➤ To import contacts from ACT! 6.0, 2004, or earlier, or 
from GoldMine 6.5 or earlier

Always back up your 
Maximizer Address Book 
before importing data.

� From the File menu, select Import > ACT! 6.0 or 2004 or 
earlier. 

– or –

Select Import > GoldMine 6.5 or earlier.

When importing GoldMine 
Contacts, GoldMine must be 
installed on the same machine 
as Maximizer; the Borland 
database engine is required 
during the import.

The Import Databases dialog box opens. The file type is selected 
for you automatically.

� Locate the file you are importing. If the file is a network file, click 
the Network button or use the Drives field drop-down list to 
access the folder.

� In the Import Options group box, select the Log Errors to File 
checkbox if you want to log any errors that occur during the 
import process to a text file. 

All other options in the Import Options group box are handled 
automatically by Maximizer.

� Specify how you want duplicate records handled, and click OK. 

If duplicate records are found in the data, the option you select 
here determines whether or not duplicate records are combined. 
They will be added to the Address Book.

Maximizer requires that each Address Book entry be assigned a 
unique Address Book entry ID. If the import record contains an 
Address Book entry ID that is the same as an existing Maximizer 
Address Book entry or Contact, the Address Book entry ID of the 
imported entry is automatically changed when that entry is 
added to Maximizer and this action is recorded in the import 
error message file.
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� Click OK to begin the Import process.

During the import process, a status indicator appears on the 
screen. Click Cancel if you want to halt the import process.

The Errorlog.txt file appears in 
the same folder as the import 
file. Unless the import utility 
reports that all records were 
imported successfully, carefully 
review the ERRORLOG.TXT file 
to identify and resolve import 
problems.

� Once the data is imported, the Conversion Completed or Import 
Completed message box displays the number of fields read, 
imported, skipped, failed, or merged, and the number of records 
with associated import warnings. Click OK to close the message 
box.

Importing from ACT! 2005–2010 or ACT! Premium for Workgroups 2005–2010

There are two methods of importing from an ACT! 2005–2010 
database. The first method explains how to import from ACT! when 
both ACT! and Administrator are installed on the same machine. The 
second method explains how to import from ACT! when ACT! and 
Administrator are on separate machines. 

➤ To import from ACT! 2005–2010 or ACT! Premium 
for Workgroups 2005–2010 – Primary Method

� Make sure you are logged into Windows as an administrator on 
the SQL Server machine. Also ensure no users are logged into the 
ACT! database.

� In Administrator, log into the Address Book where you want to 
import the ACT! database.

� In Administrator, select File > Import > ACT! 2005-2010 and 
ACT! Premium for Workgroups 2005-2010.

�

� �

�
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The Reattaching ACT! databases process may take several 
minutes.

� Select the ACT! database to import from the drop-down list, and 
click OK.

Maximizer imports the database. When the import is complete, 
it displays the Import Statistics dialog box.

� Click OK to close the dialog box.

The import is complete.

➤ To import from ACT! 2005–2010 or ACT! Premium 
for Workgroups 2005–2010 – Secondary Method

Always back up your 
Maximizer Address Book 
before importing data.

� Back up your ACT! database in ACT!.

The Backup is typically saved to C:\Documents and Settings\<User 
Name>\My Documents\ACT\ACT for Win 7\Databases\

� In the Backup folder, there should be a zip file. Open this zip file 
and extract the .BAK file that contains the name of your ACT! 
database in the filename.

� The extracted file is a SQL backup. Restore this backup to a 
normal SQL 2005 (or later) server.

See your SQL Server documentation for details on how to restore 
backups.

� Once the backup is restored, create a DSN to point to the 
database on the SQL Server. For instructions on creating a DSN, 
refer to the procedure below.

� Start Administrator.

� Open the Address Book to import the data into.

� Select File > Import > ACT! 2005-2010 and ACT! Premium 
for Workgroups 2005-2010.

	 Click OK on the message box.


 Click the Machine Data Source tab, select the DSN you created 
in step 4, and click OK.

You will be prompted for your sa password.

��Enter the sa password, and click OK.

Maximizer begins importing the data.
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➤ To create a DSN to point to the database on the SQL 
Server

� Open Control Panel > Administrative Tools > Data Sources 
(ODBC).

� Click the System DSN tab, and click the Add button.

� Select SQL Server, and click Finish.

� Give a meaningful name and description, select the SQL server 
where you placed the restored backup, and click Next.

� Select the With SQL Server authentication option, fill in the 
Login ID as sa, enter the sa password, and click Next.

� Select Change the default database to, select the restored 
ACT! database from the drop-down list, and click Next.

� Click Finish.

	 Click the Test Data Source button to make sure the DSN was 
configured correctly. 


 Click OK and then OK again to save the DSN.

Importing from GoldMine 6.7 Corporate Edition (or Earlier) SQL Databases

➤ To import from a GoldMine 6.7 Corporate Edition 
(or earlier) SQL database

Always back up your 
Maximizer Address Book 
before importing data.

� Start Administrator.

� Select File > Import > GoldMine 6.7 Corporate Edition or 
earlier.

� Click OK on the message box.

� Click the Machine Data Source tab, select the GoldMine DSN, 
and click OK.

You will be prompted for your sa password.

� Enter the sa password, and click OK.

Maximizer begins importing the data.

Importing from GoldMine 8.x Premium Edition SQL Databases

Maximizer supports importing data from GoldMine 8.x Premium 
Edition with MSSQL or Firebird SQL.
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➤ To import from a GoldMine 8.x Premium Edition SQL 
database

Always back up your 
Maximizer Address Book 
before importing data.

� If you are importing from GoldMine 8.x with Firebird SQL, 
convert the Firebird SQL database to MSSQL. You can convert 
the database in GoldMine 8.02 or later. (In GoldMine, select 
Tools > Database > New Databases.) For more information, 
see the GoldMine documentation.

� In Administrator, select File > Import > GoldMine Premium 
Edition 8.x.

� Click OK in the message box.

� Click the Machine Data Source tab, and select GoldMine DSN. 
Click OK.

You will be prompted for your sa password.

� Enter the sa password, and click OK.

Maximizer begins importing the data.

Setting User Passwords and Properties After Import

Note that if a user name contains spaces, the spaces are replaced 
with underscores, and the user names are shortened to 9 characters if 
necessary. After importing data, you can set each user’s password, 
preferences, and properties manually.

➤ To set user passwords, preferences, and properties 
after import

� In Administrator, select File > Manage Users.

� Select the Maximizer user, and click Administer User.

The Administer User dialog box opens.

� In the Administer User dialog box, set the user properties, 
preferences, password, and other settings.

For more information on these settings, see “User 
Administration” on page 81.

ACT! Data Conversion

The following table describes field mapping between ACT! and 
Maximizer. Before importing data into Maximizer, export the data 
from ACT! to a DBF file and use the DBF file for the import.
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ACT! 2000 (5.0), 6.0, 
or 2004–2010 Maximizer Imported? Comments

Company Company Yes

Contact First Name & Last 
Name

Yes ACT! Contacts are imported as Contacts in 
Maximizer and the basic information about 
each Contact such as email address are 
imported into the Basic Info tab in the 
Address Book entry dialog box. If any of the 
information associated with the Contact 
cannot be mapped to a Maximizer field in 
this tab, the information is imported as 
user-defined fields. In ACT!, First and Last 
Name belong to the same single field. The 
correct names may not be properly 
imported into Maximizer. For example, a 
Contact ‘Toni Spooner (female)’ in ACT! is 
imported into Maximizer as “Toni 
Spooner” in the First name field and 
“(female)” in the Last name field. 

Title Position Yes

Department Department, 
Position

Yes In Maximizer, Department is populated 
with the Department information of the 
first Contact and the rest in the Position 
field separated by comma.

Phone Phone 1 Yes

Fax Phone 2 Yes Adds FAX to Extension field in Maximizer.

Mobile Phone 4 Yes Adds CELL to Extension field in Maximizer.

Alt Phone No

Ticker UDF Ticker Symbol Yes Adds UDF to Company.

ID/Status UDF ID/Status Yes Adds UDF to Company.

Address Address Yes First address line in ACT! is imported as 
Address 1 in Maximizer. Second line goes to 
Address 2. Address comes from one of the 
Contacts for this Company and if there is no 
address, it may end up empty. Alternate 
addresses are added to Maximizer from 
different Contacts of the Company and 
alternate addresses are named by that 
Contact. The same address is not added but 
renamed by the other Contact. For some 
Contacts, the appropriate alternate address 
may not be selected. 

Address Division Division in Maximizer may be populated by 
the address line in ACT!.
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City City/Town Yes Imported correctly to main and alternate 
addresses.

State St/Co/Prov Yes Imported correctly to main and alternate 
addresses.

Zip Zip/Postcode Yes Imported correctly to main and alternate 
addresses.

Country Country Yes Imported correctly to main and alternate 
addresses.

Referred By UDF Referred By Yes Adds UDF to Company.

Web Site Website Yes Imported into the Company’s website field.

E-mail Address Email Yes Imported into the Contact’s email field.

Last Result Creates Table UDF 
named “Result”

Yes Adds Company Table UDF with 
corresponding items selected for each 
Contact.

Assistant No

Asst. Title No

Asst. Phone No

User fields for 
Contacts and 
Companies
(ACT! 2005–2010 & 
ACT! 2005–2010 
Premium only)

Creates UDFs for 
Contacts and 
Companies with the 
same name as in the 
source database

Yes These fields can be renamed and can be 
changed to different field types. Any fields 
that are of MEMO type or are more than 
120 Characters are converted to Notes in 
Maximizer.

User 1...User 15
(ACT! 2000 (5.0), 6.0, 
or 2004 only)

Creates UDFs named 
“Details Field 1”… 
“Details Field 15”

Yes Adds UDFs to Company. Some UDFs that 
belong to some different Contacts in ACT! 
may be lost.

Users Users Yes ACT! users are imported into Maximizer as 
users. Passwords are set to “maximizer” if 
the import was done using a DBF file. Users 
are displayed in the Administrator’s 
Manage Users dialog box which may be 
accessed by selecting File > Manage Users. 
If a user name contains spaces, the spaces 
are replaced with underscores, and the user 
names are shortened to 9 characters if 
necessary.
By default, passwords for users are set to 
“maximizer”. Passwords can be changed 
manually for each imported user.

Notes Notes Yes

ACT! 2000 (5.0), 6.0, 
or 2004–2010 Maximizer Imported? Comments
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Schedule Call
Schedule To-do

Hotlist Task Yes The Duration information of a task in ACT! 
is imported as “Prior to task” in Maximizer.
The Company name of some conflicting 
tasks may not be preserved. 

Schedule Meeting Appointments Yes Recurring appointments are not imported.

Notes Attachments Notes Attachments No

Document Document No

Groups Groups No

Sales/
Opportunities

Opportunities No

History
(ACT! 2005-2010 & 
ACT! 2005-2010 
Premium only)

Notes Yes Each entry from the History tab in ACT! 
becomes a Note in Maximizer. 

ACT! 2000 (5.0), 6.0, 
or 2004–2010 Maximizer Imported? Comments
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GoldMine Data Conversion

The following table describes field mapping between GoldMine and 
Maximizer.

Note that Action, Call, and Appointment notes in GoldMine 6.x and 
8.x may be in HTML format. When you import these notes into 
Maximizer, they contain HTML tags. 

GoldMine 5.x, 
6.x, & 8.x Maximizer Imported? Comments

Company Company Yes

Contact
First Name Initial 
Last Name

First Name Initial 
Last Name

Yes GoldMine’s Contact field contains (First Name) 
(Initial) (Last Name) separated by spaces. In 
Maximizer, appropriate fields are populated 
accordingly. 

Title Position Yes

Dept Dept. Yes In Maximizer, Dept. is populated with the 
department of the main Company’s Contact.

Asst Assistant (UDF) Yes Adds UDF to Contact record.

Source Contact type (UDF) Yes Adds UDF to Contact record.

Address Address1 & Address2 Yes Address from the main Contact becomes the 
main Company address. The first line in the 
Address field from GoldMine goes to Address1 
in Maximizer. The second line goes to 
Address2. The third line from GoldMine is NOT 
imported.
Alternate Addresses in Maximizer are created 
from the addresses of the Contact from the 
Contacts tab in GoldMine. Appropriate 
Alternate Addresses are selected for imported 
Contacts.

City City/ Town Yes Imported correctly to main and alternate 
addresses.

State St/Co/Prov Yes Imported correctly to main and alternate 
addresses.

Zip Zip Yes Imported correctly to main and alternate 
addresses.

Country Country Yes Imported correctly to main and alternate 
addresses.

Phone 1-3 Phone 1-3 Yes Appropriate extensions are imported.

Fax Phone 4 Yes Adds FAX to Extension field in Maximizer.



Maximizer CRM 11
Administrator’s Guide

346
E-mail Email Yes Email address of the main Contact is imported.
Email addresses of Contacts from the Contacts 
tab in GoldMine are also imported.

Web Site Website Yes Imported to main Contact record.

Contact Type Contact Type Yes Adds UDF to Contact record.

Business Business Yes Adds UDF to Contact record.

Interest Interest Yes Adds UDF to Contact record.

Accnt Mngr Accnt Mngr Yes Adds UDF to Contact record.

Open Open Yes Adds UDF to Contact record.

Summary Note Yes A note containing details from the Summary 
tab is created for the Company.

Role
Status
Account Type
Account Size
No. of Users
Key Interest
Competitor
Platform

User role
Purchase Status
Account Type
Account Size
Users
Key Interest
Competitor
Platform

Yes Appropriate UDFs are created in Maximizer 
and populated with proper values.

Notes Note Yes A note is created for the Contact in Maximizer 
and contains all the notes from the Notes tab in 
GoldMine.

Documents Document No

Users Users Yes GoldMine’s users are imported into Maximizer 
as users. Users are displayed in the 
Administrator’s Manage Users dialog box, 
which is accessible through the 
File > Manage Users menu. 
If spaces are included in a user name, the 
spaces are replaced with underscores, and the 
user names are shortened to 9 characters if 
necessary.
After import, users’ Windows Access, Web 
Access, and Mobile Access are disabled in 
Maximizer and must be enabled by the 
administrator.
By default, passwords for users are set to 
“maximizer”. Passwords can be changed 
manually for each imported user.

GoldMine 5.x, 
6.x, & 8.x Maximizer Imported? Comments
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Field Mapping for Outlook

The following table describes the field mapping that is used in 
Outlook Synchronization. 

 For more information on 
Outlook Synchronization, refer 
to “Configuring Microsoft 
Outlook Synchronization” on 
page 160.

Details Notes Yes For every detail, a note is created. Details are 
referred to as Profiles in the notes.

Pending Hotlist Task Yes Each entry from the Pending tab in GoldMine is 
imported as Hotlist task in Maximizer.

Calendar Hotlist Tasks Yes Calls and Activities from GoldMine’s Calendar 
are imported as Hotlist tasks in Maximizer.

Referrals Notes Yes A note is created for every Referral. Referrals 
are called References.

History Notes Yes Each entry from the History tab in GoldMine 
becomes a Note in Maximizer. 

Members  No

Tracks No

Links No

Opptys No

Projects No

Partner Notes Yes Limited information is imported.

Email text (email) Documents Yes Imports email as documents in the Documents 
window. This feature is supported for 
GoldMine 8 only.

GoldMine 5.x, 
6.x, & 8.x Maximizer Imported? Comments

Microsoft Outlook Maximizer

Appointments

Subject Subject

Start and End time date Date

Start time Start time

End time End time

Reminder Alarm time

Toggle alarm Toggle alarm

Importance Priority
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Private Private

Location Location

Note (text box) Note (text box)

Tasks

Due date Date

Alarm time Time

Subject Activity

End time End time

Reminder set Alarm set

Priority Priority

Private Private

Microsoft Outlook Maximizer
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Transferring Entries between Address Books
Encrypted user-defined fields 

cannot be transferred or 
exported to another Address 
Book.

Importing refers to copying data from an external database into a 
Maximizer Address Book. However, transferring refers to copying 
data between Maximizer Address Books. Transferring data is ideal 
for merging Address Books together and sharing entries and setups.

Entries cannot be transferred using Administrator. You must use 
Maximizer. 

Transfer rights can be set on a per-user basis, although some field 
transfer options apply to all users.

The following sections contain information on transferring entries 
between Address Books:

• “What Happens During a Transfer?” on page 349

• “Transfer Summary Reports and Logging” on page 350

• “Adjusting Address Book Transfer Settings” on page 350

What Happens During a Transfer?

You should never use 
Maximizer Email Transfer 
(MET) between two 
MaxExchange-synchronized 
computers. Using MET and 
MaxExchange in combination 
adds records twice on the 
destination computer—once 
through MET, and again 
through MaxExchange.

Once you start a transfer, Maximizer uses the following rules to 
determine which records to copy from the source Address Book into 
the target Address Book:

• Address Book entry IDs: If an Address Book entry ID number 
from the source Address Book does not exist in the target 
Address Book, the Address Book entry is inserted into the target 
Address Book. 

Note that each Address Book 
entry has a unique ID. 

• Address Book entry names: If the Address Book entry ID 
number from the source exists in the target Address Book, 
Maximizer compares the source and target Address Book entry 
names. 

If the names are different, Maximizer changes the ID number in 
the target Address Book and inserts the entry as a new Address 
Book entry. 

If the Address Book entry names are the same, they are 
considered to be duplicate entries. In this case, Maximizer 
merges duplicate Address Book entries in the target Address 
Book.

• Date and Time: Maximizer also checks the date and time of the 
record. It will not overwrite data in the target Address Book that 
has been modified more recently than the data in the source 
Address Book.
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Transfer Summary Reports and Logging

Each time you transfer Address Book entries, Maximizer displays a 
transfer summary report. The report indicates the number of data 
items inserted, modified, bypassed, and deleted. It also displays the 
transfer setting used and other related information. You can print 
this report for your records.

As well, for each Address Book entry updated in the target Address 
Book, Maximizer can optionally add a note. The note summarizes the 
fields that have been added, changed, and deleted. This feature can 
also be used if you want to find the data that has been added or 
modified. After a transfer, simply do a search by notes. 

Adjusting Address Book Transfer Settings

Only the MASTER user can 
modify protection on fields.

You can set the options for transferring information between the 
open Address Book and other Address Books. Some of these are 
system options, which apply to all users; others are user-specific 
options, which apply to the selected user only.

Regardless of a user's transfer settings, encrypted user-defined fields 
cannot be transferred or exported to another Address Book.

➤ To adjust transfer settings for one user or all users

� Select File > Manage Users.

� Select a Maximizer user, and click Preferences.

� Select the Transfer tab.

� In the Protect fields from update list, double-click any fields 
you don't want included in the transfer.

• System field transfer options apply to all users.

• User specific field options apply to the selected user only.

� In the Transfer options group box, set your transfer 
preferences.

� In the Advanced options group box, set your advanced 
transfer preferences, which are described below:

• The Overwrite duplicates option overwrites the target 
Address Book entry with source Address Book entry 
information when duplicate records are found.

• The Use record modify flag option sets a flag to "on" 
when an Address Book entry is added or modified. Maximizer 
uses it as an internal check to determine if the Address Book 
entry has been modified since the last transfer.
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• The Reset record modify flag option resets the record 
modify flag back to null (not modified) for each transferred 
record.

� If you don't want Maximizer to add a note for every Address 
Book entry that is added or updated in the target Address Book, 
clear the Log transfer results to notes checkbox.

	 Click OK to finish.
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Purging Outdated Notes and Documents
After a long period of activity, you may want to delete outdated 
notes and documents using Administrator’s purge feature.

When you purge notes, you must specify the note types to delete.

The purge command deletes all notes, with the exception of other 
user’s private notes (unless the user purging the notes has rights to 
delete other users’ notes), in the specified date range for all Address 
Book entries in the open Address Book. You should back up the 
Address Book before purging notes.

Note Type Creation Method

Accounting Created by Accounting Link. Applicable only if 
Accounting Link is installed.

Customer 
Service

Notes created in the Address Book window when 
you add a case.

Email Notes created in the Address Book window when 
you send an email to one or more Address Book 
entries. Email notes are also created when you 
launch a campaign.

History Created when opportunities cases, or campaigns are 
added or changed. History notes can be printed or 
searched only from these windows.

Incoming call Created when you receive a phone call.

Mail-out Created when users print labels, envelopes, or letters 
using the Maximizer Word Processor's merge 
feature. Mail-out notes are also created when users 
send an email to more than one Address Book entry.

Manual Added manually to the Notes window.

Opportunity Created in the Address Book window when 
opportunities are added or changed. Opportunity 
notes can be printed or searched only from the 
Address Book window.

Other Third-party or custom notes created by the 
administrator. 

Outgoing call Created when phone an Address Book entry.

Tasks Created when appointments or Hotlist tasks are 
scheduled or completed.

Timed notes Created when the Timer is used while writing a note.

Transfer log Notes logged when Address Book entries are 
transferred between Address Books.
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➤ To purge notes

� In Administrator, open the Address Book you want to clean up.

� Select File > Purge > Notes.

� Specify a date range. 

Maximizer deletes notes dated between the specified dates.

� Select the type(s) of notes to delete, and click OK.

➤ To purge documents

� In Administrator, open the Address Book you want to clean up.

� Select File > Purge > Documents.

� Specify a date range. 

Maximizer deletes documents dated between the specified 
dates.

� If you want to purge private documents belonging to other 
users, select the Delete other users’ private documents 
option.

� Click OK.
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Using Log Files for Diagnosis
One of the most powerful tools in diagnosing a Maximizer 
installation is the automated logging feature. Maximizer supports 
logging for a number of server and client components.

You can control the amount of detail that is logged for various 
modules. The range of logging levels is 0 through 7:

• 0 = logging disabled

• 1 = least detailed

• 7 = most detailed

You can also control the frequency in which the log files are purged 
and if the information is sent to the Windows event log. 

Logs are written into the default folder “\Program 
Files\Maximizer\Logs”. You can define logging preferences in 
Administrator and Maximizer. These preferences control the 
following registry keys.

➤ To set logging preference values

� In Maximizer, click the Setup tab and select Preferences. In 
Administrator, select File > Preferences.

� Select the Diagnostic tab.

If you want logs for all modules saved in one specific location, 
specify a default folder where your log files will be saved. If you 
don’t specify a location in this field or a location per module, 
logs are saved in the Logs folder where Maximizer is installed 
(e.g., Program Files\Maximizer\Logs). 

� Select a module from the Preferences for this module drop-
down list.

Email Service 
(CMGR-
Email)

HKEY_LOCAL_MACHINE\SO
FTWARE\
Maximizer 
Software\Maximizer\
Modules\AutoProgService\E
mail

CMGR-
Email_yyyymmdd.log
CMGR-
Service_yyyymmdd.log

MaAccess 
(MACC)

HKEY_LOCAL_MACHINE\SO
FTWARE\
Maximizer 
Software\Maximizer\
Modules\MACC\EVENTLOGS
ETTINGS

MACC_yyyymmdd.log
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� If you want logs related to a module saved in a specific location, 
specify a folder in the Module log folder field. 

� Select a logging detail level from the Maximizer log level 
drop-down list.

� Set your other logging preference values such as the frequency 
logs are purged. By default, logs are purged after 5 days. 

� Repeat the previous steps to configure logging for any other 
module(s).

	 Click OK.


 If you changed the log settings for either the Email Service 
(CMGR-Email), you must restart the service(s) for the changes to 
take effect.

Restart these services from Windows Control Panel > Services.

For samples and explanations of Maximizer Email Service log files, 
see “Maximizer Email Service Log Files” on page 372.
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System Reports
HTML reports can be opened 

easily in Microsoft Excel, 
where you can edit the data as 
required.

The Reports menu in Administrator enables you to quickly create a 
number of reports about the open Address Book, as described below. 
Use the Reports tab in Maximizer to print other comprehensive 
reports. See the Maximizer CRM User’s Guide for more information.

Report Information Reported

User ID List • Total number of users in the Address 
Book

• Total number of security groups in the 
Address Book

For each user in the Address Book:

• User ID
• Display Name
• First and Last Name

• Phone number
• Email Address
• Maximizer Login Enabled/Disabled status

• User’s Roles (Access Rights)
For each security group in the Address Book:
• Group Name

• Group ID
• Group members

User-Defined Fields • Folder (if applicable) and field name
• Type of entry the field is applicable to 

(Company, Individual, Contact, 
Opportunity, Campaign, Case, or User)

• Full Access and Read Access
• Type (Table, Date, Alphanumeric, 

Numeric, Formula, Yes/No)
• Creator

• Requested by
• Description
• Attributes

• Items in table user-defined fields
• Usage count (only if Show Usage Count 

checkbox selected in Print Report dialog 
box)
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Address Book Summary Total number of each of the following types 
of entries in the current Address Book:

• Users
• Security groups
• Companies and Individuals

• Lowest, highest, average, and total 
number of contacts per Company and 
Individual

• Opportunities (total and per status)
• Automated campaigns (total and per 

status)

• Traditional campaigns (total and per 
status)

• User-defined fields (total and per type)
• User-defined field entries (total and per 

type)

• Notes
• Documents
• Knowledge base articles (total and per 

status)

• Customer service cases (total and per 
status)

Sales/Marketing Teams Details about teams and team members, 
sorted by Team Type (Sales or Marketing)
• Team name
• Member user ID

• Member name
• Member status (member or team leader)
• Distribution sites

Installed Workstations Details about any Maximizer workstation 
that has connected to the current Address 
Book on the current server:

• Name of the Maximizer workstation 
machine

• Module used to connect to the server 
(Administrator, Maximizer, etc.)

• Date and time when the module 
connected to the server

• Maximizer version, series, and build of 
the module

This report displays on-screen rather than printing. To 
print the report, press Alt and Print Screen to capture 
the report window to the Windows clipboard, and then 
paste it into a word processor or graphics program.

Report Information Reported
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Current Users • Number of licenses in use

For each user currently logged into the 
Address Book:
• User name
• Computer name

• Date and time logged in
• Maximizer module connected
Licenses installed:

• Product license number (PLN)
• Computer name
• Product

• User count
• Description
• Total number of applied licenses
This report displays on-screen rather than printing. To 

print the report, press Alt and Print Screen to capture 
the report window to the Windows clipboard, and then 
paste it into a word processor or graphics program.

Report Information Reported
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In this chapter...

“Recreating the Maximizer_Default User” on page 360

“Troubleshooting Issues with Automated Campaigns” on page 361

“Resolving Issues with Microsoft IIS” on page 363

“Troubleshooting Web Access Sites” on page 367

“Resolving Problems with SMTP Email Servers” on page 371

“Maximizer Email Service Log Files” on page 372
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Recreating the Maximizer_Default User
The maximizer_default security login is created during the initial 
installation of Maximizer.

The following are steps to recreate the Maximizer_Default user if it is 
not in the list of security logins in SQL.

➤ To create the maximizer_default security login

• Select Utilities > Repair Database.

Windows Authentication with Maximizer and SQL Server

When Windows Authentication is specified as the means of user 
authentication during the installation, all new Address Books created 
use Windows Authentication. You can modify this setting on a per 
Address Book basis in the MaConfig table. You can also modify the 
global setting for Windows Authentication. In addition, you must 
change the Windows Authentication registry key in the Windows 
Registry on the computer where SQL Server is installed.

➤ To modify the Windows Authentication MaConfig 
setting for an Address Book

� In SQL Server Management Studio, open the MaConfig table.

� For the Address Book, change the USE_NT_AUTHENTICATION 
key to Yes to use Windows Authentication and Null or No if you 
want to use SQL Server Authentication.

➤ To modify the Windows Authentication MaConfig 
setting globally

� In SQL Server Management Studio, open the MaConfig table.

� Change the global USE_NT_AUTHENTICATION key to Yes to use 
Windows Authentication and Null or No if you want to use SQL 
Server Authentication.

➤ To modify the Windows Authentication registry key

� Click Start > Run.

� Type regedit and click OK.

� Navigate to HKEY_LOCAL_MACHINE/SOFTWARE/Maximizer 
Software/Maximizer/Common/Sys.
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� Double-click Windows Authentication.

� Enter 1 to use Windows Authentication, or enter 0 to use SQL 
Server Authentication. Click OK.

� Close the Registry Editor.

Troubleshooting Issues with Automated Campaigns
Use this section to troubleshoot potential issues with automated 
campaigns.

The following sections contain information on troubleshooting 
issues with automated campaigns:

• “SMTP Time-out Error” on page 361

• “Email Messages Use Wrong Character Set” on page 362

• “Campaigns Remain “In Progress” without Activity” on page 362

SMTP Time-out Error

This issue describes SMTP time-out errors in automated campaigns. 

Problem For some subscribers, an automated campaign fails 
due to Time_out, and you are sure the subscriber's 
email address is valid.

Symptom A Time_out message displays in the notes of the 
affected campaign and Address Book entry.

Resolution Verify that the subscriber’s email address is valid. If it 
is valid, then increase the SMTP_TIMEOUT value. You 
can find the SMTP_TIMEOUT value in the MaConfig 
table Global Settings section. The default value for 
SMTP_TIMEOUT is 100 (seconds). You can increase it 
to 500, 1000...n.
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Email Messages Use Wrong Character Set

This issue affects email messages sent by automated campaigns using 
the wrong character set    

Campaigns Remain “In Progress” without Activity

This issue is a problem with campaigns remaining “In Progress” 
without any activity.

➤ To change the EMAILUSER password

� In Administrator, select File > Manage Users.

� Select EMAILUSER, and click Password.

� Type EMAILSYSTEM in the New Password and Confirm 
Password fields, and click OK.

Maximizer prompts you to apply the new password across all 
databases.

� Click Yes to synchronize passwords.

➤ To restart the Maximizer Email

� Select Start > Programs > Administrative Tools > Services to 
open the Services window.

� Double-click Maximizer Email Service.

Problem Email messages sent by Maximizer Email Service use 
the wrong character set, ignoring the regional 
settings on a user’s computer.

Symptom Email messages sent by automated campaigns are 
illegible.

Resolution In Administrator, configure the Maximizer Email 
Service to use the correct character set. For more 
information, see “Configuring the Maximizer Email 
Service” on page 183.

Problem If the password for EMAILUSER is not synchronized, 
automated campaigns do not function properly.

Symptom A campaign’s status is “In Progress” but it is inactive 
and does not send out emails, faxes, or print jobs.

Resolution Change the EMAILUSER password to EMAILSYSTEM 
(which is the default), synchronize passwords, and 
restart the Maximizer Email Service.
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� Click Stop.

� Click Start to restart the service.

� Click OK.

Resolving Issues with Microsoft IIS
The following sections contain information on troubleshooting 
potential issues with Microsoft IIS:

• “Configuring Maximizer Web Access on a 64-bit Operating 
System” on page 363

• “Using Microsoft IIS on Windows 2003 Server” on page 364

• “Maximizer Components for IIS and Windows 2008 Server” on 
page 365

Configuring Maximizer Web Access on a 64-bit Operating System

This issue affects computers running Maximizer Web Access on a 64-
bit Operating System.

Problem Maximizer Web Access requires the 32-bit version of 
ASP.NET 2.0 in order to run on a 64-bit operating 
system.

Symptoms Maximizer Web Access does not work when installed 
on a 64-bit operating system.

Resolution Enable the 32-bit version of IIS on the machine that 
Maximizer Web Access is installed on. For more 
information, see “Microsoft IIS on 64-Bit Operating 
Systems” on page 20.
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Using Microsoft IIS on Windows 2003 Server

This issue affects campaign merge fields and direct insert web forms 
on computers running Microsoft IIS on Windows 2003 Server.  

➤ To create a web service extension

� Open the Internet Services Manager (Control Panel > 
Administrative Tools).

� Select the Web Services Extensions folder.

� In the Extended tab, select the Add a New Web Service 
Extension option.

� Enter the name of the extension.

� Browse to the location of the file and select the file.

� Select the Set Extension Status to Allowed option and click 
OK.

If you are adding a web service extension for a web form, enter the 
name of the folder where the web form is stored as the name of the 
extension and select the winqcgi.exe file stored in the web form 
folder.

When web service extensions are enabled, their status is “Allowed”.

Problem ASP.NET v1.1.4322 (or higher) web service extension 
is not enabled in IIS running on Windows 2003 
Server.

Symptoms campaign tracking merge fields (Campaign Open 
Email Tracking URL, Campaign Redirect URL, and 
Campaign Remove Subscriber URL) do not function.
Direct insert web forms do not function.

Resolution Install and enable the ASP.NET v1.1.4322 (or higher) 
web service extension.
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Maximizer Components for IIS and Windows 2008 Server

If you are using Windows 2008 Server, you may need to perform 
additional steps before installing Maximizer components for IIS. For 
more information, see “Microsoft IIS on Windows Server 2008” on 
page 19. 

If you continue to have problems, you may need to install additional 
roles for Web Server (IIS). The roles should match the default 
settings.
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Resolving Problems with MaxSync
This issue affects group appointments synchronized from Maximizer 
to Microsoft Exchange using MaxSync for Microsoft Exchange.

Problem The Microsoft Exchange user name that has been 
mapped to the Maximizer user can be resolved on 
the Microsoft Exchange Server to more than one 
Microsoft Exchange account.

Symptom After creating a group appointment in Maximizer 
and synchronization to Microsoft Exchange is 
complete, the appointment in Microsoft Exchange 
does not show all the recipients of the appointment. 
The missing recipients do have a copy of the 
appointment.

Resolution Any other accounts on the Microsoft Exchange 
Server that could be resolved to by the name of the 
desired account need to be updated to become 
more unique. The goal of this is to allow the correct 
account to be the only account the name could be 
resolved to. Please see the Microsoft Exchange 
documentation on how to accomplish this.
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Troubleshooting Web Access Sites
The following sections contain information on troubleshooting 
potential issues with web access sites:

• “Maximizer Web Access Templates” on page 367

• “User-Defined Field Visibility” on page 367

• “Site Tree Control” on page 368

• “Retrieving Messages in the Maximizer Web Access Email Page” 
on page 369

• “Blocked Files in Maximizer Web Access” on page 370

Maximizer Web Access Templates

When the Sites (File > Web Access) dialog box is opened in 
Administrator (File > Web Access), a “master list” of templates is 
compared with the template list stored for the Address Book. If any 
of the templates differ, you are prompted to overwrite the Address 
Book templates with the master templates. If you have customized 
any of the templates used for Maximizer Web Access, you may wish 
to keep a backup copy or mark the templates as read-only so the files 
are not inadvertently overwritten. 

The “master list” of templates is the list of files stored under:

\MxServer\Thinclients on the Maximizer application server

The list of templates available for publishing for an Address Book is 
stored under:

\MxData\<Address Book Name>\Html on the application server

If you have problems with an Address Book’s site templates, delete 
the “Html” folder under MxData and open the Sites dialog box in 
Administrator—the Address Book’s templates folder. The template 
files then regenerate from the master template list. Other files in the 
folder—such as the online site Help files—are also regenerated.

User-Defined Field Visibility

Visibility of user-defined fields for Web visitors (external web access 
users) is based on what WEBUSER has security rights to view. To allow 
external visibility for a user-defined field, ensure WEBUSER has access 
to the field; if the user-defined fields belongs to a group, WEBUSER 
must be part of that group.
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Site Tree Control

This issue affects the tree view control in web access sites.

➤ To resolve the site tree control display issue

� Open the IIS Manager.

� Right-click on the Default Web Site, or other web site to which 
you may have moved the sites, and click Properties.

� Click the Home Directory tab.

� Take note of the path in the Local Path field. This is the folder 
that you will copy the C:\INETPUB\wwwroot\webctrl_client 
folder and its contents to.

� Close the Default Web Site Properties dialog box.

� Open Windows Explorer.

Problem The sites use the Microsoft Internet Explorer 
TreeView WebControl to display tree structures. 
Maximizer CRM Server installs the graphical 
components of this tree control in the 
C:\INETPUB\wwwroot folder in a subfolder called 
webctrl_client. Since C:\INETPUB\wwwroot is the 
default location of the Internet Information Services 
(IIS) root folder, the control is assumed to be 
available from the root. However, if the location of 
the root folder (Default Web Site or other web site 
to which you may have moved the sites) has been 
changed, the graphical components of this control 
are no longer available and the control displays as 
simple text.

Symptom The tree view control in Maximizer Web Access, 
Partner Access, and Customer Access may display 
External Links, UDFs when in tree mode, and 
Company Library data as long strings of text rather 
than the expected graphical tree structure 
representation. No interaction is available.

Resolution To correct this issue, copy the 
C:\INETPUB\wwwroot\webctrl_client folder, and all 
its contents, to the new root folder designated as 
the Local Path of the new root under Properties for 
the Default Web Site in the IIS Manager. Detailed 
steps for this procedure are provided below.
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� Copy the C:\INETPUB\wwwroot\webctrl_client folder and its 
contents to the Local Path identified in step 4 above.

The site tree structures should now display correctly.

Retrieving Messages in the Maximizer Web Access Email Page

This issue is a problem retrieving email messages from the Email page 
in the Maximizer Web Access. 

➤ To specify the maximum number of email messages 
to retrieve

� Open the Web.config file.

The Maximizer Web Access Web.config file is located on the 
Maximizer server in the ...Maximizer\Portals\Employee 
folder.

� In the application settings section, add the 
MaximiumNumberofEmailRecordsToRetrieve key and set a 
value for the setting as follows.

<appSettings>

...

<add key="MaximimumNumberofEmailRecordsToRetrieve" 
value="[number]"/>

...

</appSettings>

Replace [number] with the 
maximum number of email 
records.

� Save the Web.config file.

Problem To avoid errors caused by the connection timeout 
limit on the IIS server, Maximizer limits the number 
of email messages retrieved in the Maximizer Web 
Access Email page. If the email filter returns a list 
containing over 1000 email messages, no email 
messages are displayed by default.

Symptom In the Maximizer Web Access Email page, no email 
messages are returned after selecting a value from 
the Filter drop-down list.

Resolution Specify the maximum number of email messages to 
retrieve in the Web.config file to override the 
default behavior.
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Blocked Files in Maximizer Web Access

This issue affects users after first logging in to Maximizer Web Access. 

Problem The web server configuration includes a firewall or 
other software that is blocking the 
MaThinIEActiveX.ocx file.

Symptom When a user logs in to Maximizer Web Access, the 
web browser displays a message that the 
MaThinIEActiveX.ocx file is blocked.

Resolution Configure the firewall to allow this file to be 
downloaded from the server. For more information, 
see “ActiveX Controls in Maximizer Web Access” on 
page 221.
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Resolving Problems with SMTP Email Servers
The following sections contain information on troubleshooting 
issues with SMTP email servers:

• “Unable to Establish Connection to SMTP Server” on page 371

Unable to Establish Connection to SMTP Server

This issue affects SMTP email servers with transport layer security 
(TLS).  

Problem Using SMTP email servers with transport layer 
security (TLS) in Maximizer Web Access.

Symptom Maximizer Web Access is unable to establish an 
SMTP server connection.

Resolution Ensure the following:
• The “Start Basic Authentication works after TLS” 

option in Microsoft Exchange is disabled.

• The SMTP server uses a different port from SSL. 
By default, Maximizer uses port number 25 for 
the SMTP server.

• The ports used by IMAP and SMTP are not 
blocked by a firewall on the email server or the 
IIS server.

• The correct port number for IMAP and SMTP 
servers are saved in the Web Access 
Administrator.

• The correct encryption is selected.
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Maximizer Email Service Log Files
The Maximizer Email Service log files store the following codes:

• 1 = Initialization or database connection problem

• 2 = Not used

• 3 = Exception (other error code)

Samples and explanations of both Maximizer Email Service log files 
are included below. For more information on log files, see “Using 
Log Files for Diagnosis” on page 354.

Sample CMGR-Email_yyyymmdd.log File

Line numbers are not written 
into an actual log and are 
provided here for convenience.

17:50:14  ================ OPENING LOG ================

CURRENT DATE:2010/05/16

1. 17:50:14  INFO    [Line 1506]  [ini] 
COMMON_SERVER_SETTING = 

2. 17:50:14  INFO    [Line 1516]  [ini] COMMON_Address 
BookS = Escona

3. 17:50:14  INFO    [Line 1534]  [***] current Address 
Book = Escona

4. 17:50:14  INFO    [Line 1552]  [ini] AUTO_EMAIL_RUN = 1

5. 17:50:14  INFO    [Line 1570]  [ini] DB_NAME = Escona

6. 17:50:14  INFO    [Line 1579]  [ini] DB_SERVER = 
Servername

7. 17:50:14  INFO    [Line 1588]  [ini] SERVICE_USERID = 
EMAILUSER

8. 17:50:14  INFO    [Line 1607]  [ini] SERVICE_Address 
Book_PATH = DSN:MAP_ESCONA

9. 17:50:14  INFO    [Line 1637]  [ini] 
AUTO_EMAIL_TEMPLATES = C:\Program 
Files\Maximizer\ServerShared\Email Templates\

10. 17:50:14  INFO    [Line 1646]  [ini] 
AUTO_EMAIL_SMTP_SERVER = mail.maximizer.com

11. 17:50:15  WARNING [Line 512]   email to 
'devsupport@maximizer.com' failed (Reason: Load template

    '.etf' failed)

The test environment that 
produced this log had an 
invalid path for the email 
template directory, resulting in 
a detailed error in line 11.

12. 17:50:17  WARNING [Line 396]   0 email messages were 
sent successfully, 1 email messages failed

17:50:17  ================ CLOSING LOG ================
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Description of Sample CMGR-Email_yyyymmdd.log File

The following table describes some of the numbered lines from the 
previous example.

Sample CMGR-Service_yyyymmdd.log File

Line numbers are not written 
into an actual log and are 
provided here for convenience.

CURRENT DATE:2010/05/16

1. 17:49:12  INFO    [Line 64]    email service started

2. 17:49:12  INFO    [Line 402]   [ini] 
AUTO_EMAIL_CYCLE_TIME = 1

3. 17:49:12  INFO    [Line 410]   [ini] 
AUTO_EMAIL_TIME_UNIT = 0

4. 17:50:13  INFO    [Line 402]   [ini] 
AUTO_EMAIL_CYCLE_TIME = 1

5. 17:50:13  INFO    [Line 410]   [ini] 
AUTO_EMAIL_TIME_UNIT = 0

The error code #2 in line 6 
identifies a problem locating 
the email template.

6. 17:50:17  INFO    [Line 256]   email service finished 
cycle with error code 2

Line # Description

1 Confirmation as to whether the Common Server setting 
parameter is enabled in the MaConfig table.
NOTE: This setting controls whether passwords are 
encrypted or not encrypted.

2 A list of all of the Maximizer Address Books—read from the 
MaConfig table.

3 The current Address Book that the service is using.

4 Whether the Email Service is active or not. 
1 = active; 0 = inactive

5 The name of the database that the service is accessing.

6 The name of the server that hosts the database; a generic 
name of servername is listed for demonstration purposes 
only.

7 The name of the server account that will be used to log in to 
the database.

9 The location of the email templates directory.

10 The name of the SMTP Server that the service will send 
email through.

11 Explanation why the email failed.

12 Count of successful and unsuccessful emails sent.



Maximizer CRM 11
Administrator’s Guide

374
The warning in line 7 confirms 
that the email message was 
not sent.

7. 17:50:17  WARNING [Line 396]   0 email messages were 
sent successfully, 1 email messages failed

Description of the Sample CMGR-Service_yyyymmdd.log File

The following table describes some of the numbered lines from the 
previous example. Due to the error in the configuration as stated 
above, the send attempt failed. 

Line # Description

1 Launching of the send application.

2 The setting for the email send cycle; stated in minutes.

6 The status of the last send attempt.

7 Count of successful and unsuccessful emails sent.
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MaConfig Table (Server and Address Book Configuration)
Maximizer uses a special SQL database called MaConfig to store the 
settings for the Address Books, global settings, and some IIS settings. 
During a Workstation installation, the Maximizer Workstation Setup 
program reads from the server’s MaConfig table in the MaConfig 
database to obtain the correct registry settings for the workstation.

The following sections contain information on the MaConfig table:

• “Editing the MaConfig Settings” on page 376

• “Four-letter Module Codes” on page 376

• “MaConfig Table: Entries and their Meanings” on page 377

Editing the MaConfig Settings

If you need to edit the MaConfig table directly, you can access it 
through Microsoft SQL Enterprise Manager.

➤ To edit the Maximizer configuration settings in the 
MaConfig table using Microsoft SQL Enterprise 
Manager

� Open Microsoft SQL Enterprise Manager.

� Browse to the SQL Server, and select the MaConfig database.

� Under Tables locate and select the MaConfig table.

� Right-click the table, and select Open Table > Return All Rows.

Enterprise Manager displays the entire MaConfig table.

� Edit the entries as needed, and close the table.

Four-letter Module Codes

Entries in the MaConfig table often contain a four-letter code to 
identify which component uses that particular entry.

Code Module

ADMN Administrator

AMGR Maximizer

AUTO Maximizer Automated Services

CMGR Campaign Manager

DSGN Portals (not used)
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MaConfig Table: Entries and their Meanings

The MaConfig table contains information about a set of Maximizer 
Address Books. The MaConfig table is stored in the MaConfig 
database in SQL Server. Some of the entries in the table may not 
apply depending on the edition of Maximizer you are using.

The following tables describe the keys in the MaConfig table.          

RPTR Reporter

EMPP Maximizer Web Access

EXTP Partner Access and Customer Access

EXCH MaxExchange

Code Module

Table 1 Address Book Configuration Settings in the MaConfig Table

Section Key Value

<Address Book> AUTO_EMAIL_TEMPLATES Path to the automated campaign email 
template files (*.etf).

<Address Book> DASHBOARD_DISABLED Determines if dashboards are disabled for the 
current Address Book:
yes = Dashboards are disabled
This key is not included by default in the 
MaConfig table. You must manually add a 
new entry to the table with this key for the 
specific Address Book.

<Address Book> Dashboard_URL URL of dashboards.

<Address Book> DB_NAME Actual name of the Maximizer database. It can 
be different from display name.

<Address Book> DB_SERVER Network machine name of the computer that 
hosts the Maximizer configuration table 
(MaConfig table).

<Address Book> DB_SYS_TYPE Type of database used for the Maximizer 
Address Book.

<Address Book> DB_USERFRIENDLY_NAME Display name of Maximizer database in 
Address Book list.

<Address Book> DSGN_ISAPI_CUSTOMER URL of Customer Access.

<Address Book> DSGN_ISAPI_PARTNER URL of Partner Access.

<Address Book> DSGN_SSL_ISAPI

<Address Book> EADV_MASRCH_FILE



Maximizer CRM 11
Administrator’s Guide

378
<Address Book> EADV_MASRCH_Update_URL

<Address Book> HTML_TEMPLATES_PATH Path of the root HTML folder on the 
Maximizer Application Server. 
(Maximizer\Address 
Books\<AddressBook>\Html).

<Address Book> HTML_TEMPLATES_URL

<Address Book> IN_MEMORY_RESPONSE_TABLE

<Address Book> LIST_LIMIT Controls the maximum value of the Maximum 
entries field in the Search dialog boxes that 
can be carried forward to the next session. 
The value of the Maximum entries field in any 
of the Search dialog boxes will always be less 
than or equal to the LIST_LIMIT value the next 
time the Search dialog box is opened. If the 
user selects a value less than LIST_LIMIT, that 
value will be selected automatically the next 
time they open the dialog box. If the user 
selects a value greater than LIST_LIMIT, the 
value will be reset to LIST_LIMIT the next time 
they open the dialog box. This control helps 
avoid overloading the SQL server. 
By default, the value of LIST_LIMIT is 1000. 
Setting LIST_LIMIT to 0 allows the “All” option 
to be saved for the next session.

<Address Book> Refresh ISAPI Details

<Address Book> RPTR_START_FINANCIAL_DAY Day of the month (specified in 
“RPTR_START_FINANCIAL_ MONTH”) in which 
the fiscal year begins.

<Address Book> RPTR_START_FINANCIAL_
MONTH

Month (i.e., 1–12) in which the fiscal year 
begins.

<Address Book> RPTR_URL URL location of the Reporter ASP. If you are 
calling this URL, add the parameter: 
WORKSPACE=<Address Book>.

<Address Book> SERVICE_CMGR_PASSWORD Default email service password for automated 
campaigns (emailsystem).

<Address Book> SERVICE_CMGR_USERID Default User ID for email service login user. 
(EMAILUSER).

<Address Book> SERVICE_DSGN_PASSWORD Default WEBUSER password. (websystem).

<Address Book> SERVICE_DSGN_USERID Default User ID for ISAPI login user. 
(WEBUSER).

Table 1 Address Book Configuration Settings in the MaConfig Table

Section Key Value
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<Address Book> SERVICE_PASSWORD

<Address Book> SERVICE_SMTP_SERVER

<Address Book> SERVICE_USERID

<Address Book> SERVICE_WORKSPACE_PATH DSN of the Address Book.

<Address Book> PUBLISHED_PROJECTS

Table 2 Global Address Book Server Configuration Settings in the MaConfig Table

Section Key Value

Global Settings AcntQB

Global Settings AcntQB0

Global Settings AcntQBDesc0

Global Settings AUTO_EMAIL_BATCH_CYCLE

Global Settings AUTO_EMAIL_BATCH_SIZE Number of emails sent in the specified interval 
of time for the batch.

Global Settings AUTO_EMAIL_CYCLE_TIME Number of polls in the time unit specified under 
“AUTO_EMAIL_TIME_UNIT” in which the SQL 
Server is checked for outgoing automated 
emails.

Global Settings AUTO_EMAIL_JOB_PER_
THREAD

Length of prepared messages sent to queue per 
thread. The default is 20.

Global Settings AUTO_EMAIL_REDIRECT_URL_
BASE

Specifies the URL of the script that redirects the 
email recipients to the Landing page URL in 
automated email campaign activities. 

Global Settings AUTO_EMAIL_REQUIRES_AUTH Specifies if SMTP server requires authentication:
0 = Authentication not required
1 = Authentication required

Global Settings AUTO_EMAIL_SERVICE Default server that hosts the Email Service.

Global Settings AUTO_EMAIL_SMTP_PORT Port number of the SMTP server. The default is 
25.

Global Settings AUTO_EMAIL_THREAD_COUNT Number of email threads. This value cannot be 
higher than 31 and the default is 20.

Table 1 Address Book Configuration Settings in the MaConfig Table

Section Key Value
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Global Settings AUTO_EMAIL_TIME_UNIT Time unit used for AUTO_EMAIL_CYCLE_TIME:
0 = Minutes
1 = Hours
2 = Days
3 = Months

Global Settings AUTO_PRINTFAX_BATCH_CYCLE

Global Settings AUTO_PRINTFAX_BATCH_SIZE Number of print jobs for each batch.

Global Settings AUTO_PRINTFAX_CYCLE_TIME Number of polls in the time unit specified in 
AUTO_PRINTFAX_TIME_UNIT, in which the SQL 
Server is checked for outgoing automated print 
jobs and faxes.

Global Settings AUTO_PRINTFAX_TIME_UNIT Time unit used for 
AUTO_PRINTFAX_CYCLE_TIME:
0 = Minutes
1 = Hours
2 = Days
3 = Months

Global Settings BTI_PATH Defines the UNC location of the 
“Maximizer\Address Books” folder on the 
Maximizer Main Server. The “Address Books” 
folder is usually shared as “EAddress Books”, so 
that in a typical installation the UNC path would 
be “\\<servername>\ EAddress Books”.

Global Settings CAMPAIGN_PRINTFAX_DEVICES List of printers and fax software used by the 
Maximizer Print/Fax Service.

Global Settings COMMON_WORKSPACES Defines the Maximizer Address Books that are 
to appear in the Address Books list when you 
open an Address Book. The Address Book names 
should be separated by a comma, as in 
“COMMON_ Address BookS=Address 
Book1,Address Book2,Address Book3”. Each 
Address Book listed here should have a 
corresponding section in the MaConfig table. 
For example “Address Book1” would have a 
“[Address Book1]” section.

Global Settings Dashboard_URL URL of dashboards.

Global Settings DB_SERVER Name of database server.

Global Settings DB_SYS_TYPE Type of database (SQL).

Global Settings EMPLOYEE_PORTAL_URL URL of Maximizer Web Access.

Table 2 Global Address Book Server Configuration Settings in the MaConfig Table

Section Key Value
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Global Settings ENCRYPTION_TYPE Type of encryption:
0 = Standard
1 = No encyption
2 = BLOWFISH40

Global Settings IIS Name of the IIS Server.

Global Settings IIS External Server Network machine name of the IIS Server that 
you have set up for external Internet access.

Global Settings IIS Internal Server Network machine name of the IIS Server that 
you have set up for internal access.

Global Settings Install Path Local path of the Maximizer program folder on 
the Maximizer Application Server.

Global Settings License_MAXEXCH Number of installed MaxExchange PLNs 
(Product License Numbers).

Global Settings License_MAXEXCH_DESCn Description of nth MaxExchange PLN.

Global Settings License_MAXEXCHn nth MaxExchange PLN.

Global Settings License_MAXIMIZER Number of installed Maximizer PLNs (Product 
License Numbers).

Global Settings License_MAXIMIZER_DESCn Description of nth Maximizer PLN.

Global Settings License_MAXIMIZERn nth Maximizer PLN.

Global Settings License_PORTAL Number of installed Web Access Site PLNs 
(Product License Numbers).

Global Settings License_PORTAL_DESCn Description of nth Web Access Site PLN.

Global Settings License_PORTALn nth Web Access Site PLN.

Global Settings Maximizer Server Network machine name of the Maximizer 
Server.

Global Settings Maximizer Server Setup Maximizer series number installed on the 
Maximizer Application Server. This value is set 
by the installation program.

Global Settings NONTESTED_COLLATION_LIST

Global Settings ONETOONE_REQUIRES_AUTH

Global Settings ONETOONE_SMTP_SERVER

Global Settings ONETOONE_SMTP_SERVER_
PORT

Table 2 Global Address Book Server Configuration Settings in the MaConfig Table

Section Key Value
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Global Settings Server Path UNC Refers to the UNC path of the “Maximizer\ 
ServerShared” folder. The “ServerShared” 
folder is shared as “MaximizerServer” during a 
Maximizer installation. For example, a typical 
installation would have the entry “Server Path 
UNC=\\<servername>\ MaximizerServer”.

Global Settings SMTP Server Specifies the name of the outgoing mail server 
used for automated campaigns.

Global Settings SMTP_TIMEOUT Duration that the email service waits for the 
SMTP server’s response for each email. The unit 
of measurement is in seconds.

Global Settings SQL_SERVER

Global Settings <IIS Server>_Domain Name HTTP server name.

Global Settings TESTED_COLLATION_LIST Comma-delimited list of SQL database collations 
supported by Maximizer.

Global Settings Thin_Clients_Installation

Global Settings USE_UNIFIED_LOGIN “Trusted Connection” login security:
0 = Disabled
1 = Enabled

Global Settings AUTO_TRANSLATE This key must be created manually.
Create this key when a workstation that uses 
non-English regional settings must access a 
database that uses an English database 
collation. It affects the “Perform translation for 
character data” flag in the database DSN.
Set the value of this key to 0 or 1.
0 = Turn “Perform translation for character 
data” flag OFF
1 = Turn “Perform translation for character 
data” flag ON

Table 3 ISS Server Configuration Settings in the MaConfig Table

Section Key Value

IIS_<IIS Server> BASE_HREF

IIS_<IIS Server> IIS_URL Virtual directory path of the “Scrptpub.dll”.

IIS_<IIS Server> WORKSPACE

IIS_<IIS Server> WORKSPACE_PATH Installation path of the Address Books folder.

Table 2 Global Address Book Server Configuration Settings in the MaConfig Table

Section Key Value
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Table 4 Live Update Configuration Settings in the MaConfig Table

Section Key Value

Live Update Enable

Live Update Enable Auto

Live Update Server Base URL

Table 5 Workstation Configuration Settings in the MaConfig Table

Section Key Value

Workstation_
<Server>

Installed_Series

Workstation_
<Server>

Setup_Completion_Date
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Maximizer File Types
The following table lists the extensions of file types created in the 
registry during the Maximizer installation.

The following table lists the extensions of file types used by 
Maximizer. These file types have no association in the registry.

The following table lists the extensions of file types created in the 
registry during the MaxExchange installation.

The following table lists the extensions of file types used by 
MaxExchange. These file types have no association in the registry.

Extension Application Comment

.MDE MaxWin.exe Maximizer Data Exchange file used by 
email transfer (prior to version 7 – now 
.MET)

.MEC ecMecIm.exe OrderDesk’s order data file

.MET MaxWin.exe Maximizer Email Transfer files (version 
7 and higher) 

.MXD MaxWord.ter Maximizer Document extension

.MXI MaxWin.exe Maximizer XML format data file

.MTI MaxWin.exe Maximizer Transfer Interface (CSV 
format data file – elaborate or skip CSV 
altogether; manual says EDI, flags, etc.)

Extension Application Comment

.ETF MaxWord.ter Template files used for automated 
campaigns, customer service emails, 
and by MaxWord

Extension Application Comment

.MEX MaxExchange lock file

Extension Application Comment

.HDR Packet header file

.ATT Data packet file

.MA Internally used by MaxExchange to 
store information about email data 
packets (as in Dld_q.ma)
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Virtual Directories
The following table describes the virtual directories created by the 
Maximizer installation.

By default, [Install Directory] is C:\Program Files\Maximizer\.

Virtual Directory Permissions

The following tables list the default permissions for the virtual 
directories created by the Maximizer installation.

Maximizer Web Access, Partner Access, and Customer Access Virtual Directories

Virtual Directory Description Directory

MaximizerWebAccess Maximizer Web 
Access

[Install Directory]\
Portals\Employee

MaximizerPartner Partner Access [Install Directory]\
Portals\Partner

MaximizerCustomer Customer Access [Install Directory]\
Portals\Customer

Dashboard Dashboards [Install Directory]\
Portals\Dashboard

Campaigns Statistics for email 
campaigns

[Install Directory]\
Campaign Manager\
Statistics

Permission Setting

Read Access True

Write Access False

Script Source Access False

Directory Browsing False

Indexing True

Log Visits True

Default Document Default.aspx

Delete During Uninstall True

Execute Permissions Scripts Only

Application Protection Medium
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Campaigns Virtual Directory

Dashboard Virtual Directory

Application Mappings Default mappings

Session Timeout 20

ASP Script Timeout 90

Authentication Methods Anonymous + Integrated Windows

Permission Setting

Read Access True

Write Access False

Script Source Access False

Directory Browsing False

Indexing True

Log Visits True

Default Document Default.asp

Delete During Uninstall True

Execute Permissions Scripts Only

Application Protection Medium

Application Mappings Default mappings

Session Timeout 20

ASP Script Timeout 90

Authentication Methods Anonymous + Integrated Windows

Permission Setting

Read Access True

Write Access False

Script Source Access False

Directory Browsing False

Indexing True

Log Visits True

Permission Setting
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Database Views for User-Defined Fields    
When you create a user-defined field, a database view for that user-
defined field is also created. You can use these views to report on 
user-defined fields in Crystal Reports. For example, when a new 
Address Book user-defined field called “Salary” is created, a new 
view named “A_Salary” is dynamically created. Based on the type of 
user-defined field, the view name is prefixed by a designated letter. 
The following table identifies the table or view name prefixes for 
each type of user-defined field.

Maximizer uses the Microsoft SQL database driver (MAS_ DSN).

Microsoft SQL View Prefixes

The Microsoft SQL driver creates database views for user-defined 
fields, using the following prefixes.

Default Document Default.asp

Delete During Uninstall True

Execute Permissions Scripts and Executables

Application Protection High

Application Mappings Default mappings

Session Timeout 20

ASP Script Timeout 90

Authentication Methods Anonymous + Integrated Windows

Permission Setting

Prefix Type of user-defined field

A_ Address Book 

BP_ Third-Party Integration 

C_ Campaign 

CS_ Customer Service 

O_ Opportunity 

U_ Users 

S_ System 
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Maximizer XML Interface (MXI)
Maximizer enables you to import Address Book entries, customer 
service cases, and knowledge base articles from Maximizer or other 
applications using XML. If the records were exported from Maximizer 
in MXI (Maximizer XML Interface) or XML format, you can import 
them back into Maximizer directly. However, to import records from 
other applications in XML format, you must ensure that the XML file 
conforms to the Maximizer XML schema. The Maximizer XML schema 
file is named MXISchema.xsd and is installed with Maximizer in the 
..\Program Files\Maximizer directory. The schema describes the XML 
elements and attributes used to identify records and fields for 
importing data into Maximizer.

After you have converted your data to XML format and it has been 
validated against the MXISchema.xsd, you can use the Advanced 
Import feature available in both Maximizer and Administrator to 
import this data into an Address Book. 

The names of and relationships between the elements in the 
Maximizer XML schema correspond to the Maximizer Address Book 
fields, with a few exceptions. Several elements are named “Detail...”. 
These elements correspond to user-defined fields:

• DetailDef = definition of a user-defined field

• DetailDate = date user-defined field

• DetailNumber = numeric user-defined field

• DetailString = alphanumeric user-defined field

• DetailList = single-value table user-defined field

• DetailListMulti = multiple-value table user-defined field

• DetailFormula = formula user-defined field

• DetailBoolean = yes/no user-defined field

The following sections outline the tree-structure hierarchy of 
Maximizer XML elements. The first section outlines just the top-level 
elements, and the following sections outline the elements below the 
top-level. Mandatory elements are shown in bold, and are 
mandatory only if their parent element is used.

For further details about the properties of each of the elements, 
refer to “Element Details” on page 400. 
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Top-Level Elements

The <AllData> element is the root element, which contains the 
following elements, which contain all other elements. For specific 
information about each of the elements, refer to the appropriate 
section.

<AllData>
<ImportOptions>

Refer to “ImportOptions Element” on page 389.
</ImportOptions>
<DetailDef>

Refer to “DetailDef Element” on page 392 for sub-
elements.

</DetailDef>
<Individual>

Refer to “Individual Element” on page 394 for sub-
elements.

</Individual>
<Company>

Refer to “Company Element” on page 395 for sub-
elements.

</Company>
<KnowledgeBaseArticle>

Refer to “KnowledgeBaseArticle Element” on 
page 396 for sub-elements.

</KnowledgeBaseArticle>
<Case>

Refer to “Case Element” on page 396 for sub-
elements.

</Case>
</AllData>

ImportOptions Element

The <ImportOptions> element and its sub-elements describe how 
Address Book entries and customer service cases should be imported. 

<ImportOptions>
<LeadHandling></LeadHandling>
<ClientIdGeneration></ClientIdGeneration>
<LogFile></LogFile>
<LogLevel></LogLevel>
<ClientOptions>

<MatchMode></MatchMode>
<MatchDetail></MatchDetail>

</ClientOptions>
<ContactOptions>

<MatchMode></MatchMode>
<MatchDetail></MatchDetail>

</ContactOptions>
</ImportOptions>

The following table describes the values of each of the 
<ImportOptions> elements. 
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The valid values for each element are listed in the Value column. The Equivalent Field column 
identifies the field in the import dialog boxes that sets the same import option. 

Element Name Valid Values
Equivalent Field(s) 
in Maximizer Description

LeadHandling Lead Import all entries as 
leads

Imports all Address Book entries in the 
import file as sales leads, regardless of 
any sales lead values specified in the file. 

Normal Import all entries as 
non-leads

Imports all Address Book entries in the 
import file as non-sales leads, regardless 
of any sales lead values specified in the 
file.

File Use values from the 
import file

Imports Address Book entries as either 
sales leads or non-sales leads, as 
specified in the values of the import file. 
This is the default option.
If the file was exported from Maximizer, 
the sales lead status of each Address 
Book entry was automatically included 
in the exported file. This option simply 
carries those values forward to the 
imported records.

ClientIdGeneratio
n

Setting Follow system setting If the imported Address Book entry 
contains a Client ID, it uses the Client ID 
of the imported entry.
If the imported Address Book entry does 
not contain a Client ID, and the “System 
to assign Address Book entries’ 
IDentification field values” setting is 
turned ON, it creates a new Client ID for 
the imported Address Book entry.
If the imported Address Book entry does 
not contain a Client ID, and the “System 
to assign Address Book entries’ 
IDentification field values” setting is 
turned OFF, the Address Book entry will 
fail to import.

System Always system 
generated

Creates a new Client ID for each 
imported Address Book entry.

File Use values from the 
import file

Uses the Client IDs of the Address Book 
entries being imported.

LogFile Log File Path and filename where the log file 
should be saved (e.g., c:\folder\file.log).

LogLevel 0 n/a Do not log (leaving this element value 
blank has same result).

1 Errors Log errors only.
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5 Info Log record additions and field changes.

7 Trace Record all details (very large log file 
size).

ClientOptions n/a n/a Client Options apply to Company and 
Individual Address Book entries; Contact 
Options apply to Contact Address Book 
entries. Client Options and Contact 
Options are defined in the nested 
<MatchMode> and <MatchDetail> 
elements.

ContactOptions n/a n/a

MatchMode AlwaysInser
t

Address Book entry 
update options/
Contact update options: 
Always insert

Inserts all Company, Individual, and 
Contact records from the import file and 
does not match imported records to 
existing records. Duplicate entries may 
result.

Id Address Book entry 
update options/
Contact update options: 
Use IDentification field 
to match entries

Uses Address Book identification values 
as the criteria for matching records. For 
Company and Individual records, this 
option uses the Client ID field to match 
entries. For Contact records, this option 
uses the Client ID and Contact Number 
fields to match entries.

Name Address Book entry 
update options/
Contact update options: 
Use Name field to match 
entries

Company records will use the Company 
field, and Individual and Contact records 
will use the Last Name field as the 
criteria for matching records.

Detail Address Book entry 
update options/
Contact update options: 
Use this user-defined 
field to match entries

Specifies an alphanumeric user-defined 
field to use as the criterion for matching 
records. Only Address Book entry user-
defined fields that apply to the 
applicable record type appear in this list.

MatchDetail Address Book entry 
update options/
Contact update options: 
Use this user-defined 
field to match entries

Name of the alphanumeric user-defined 
field to use to match entries when 
MatchMode is set to Detail.

Element Name Valid Values
Equivalent Field(s) 
in Maximizer Description
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DetailDef Element

The <DetailDef> element and its sub-elements describe the user-
defined field definitions. If the user-defined field includes a 
description, it appears in the <Description> element. If it is a table 
user-defined field, the table items each appear in the <ListItem> 
elements.

<DetailDef Name=”” Type=””>
<Description></Description>
<ListItem></ListItem>

</DetailDef>

Much of the information about the user-defined field is stored in the 
element’s attributes, which are described in the following table. 

Attribute
Data 
Type

Valid 
Values Description

Name string Name of the user-defined field.

Type string Multiple
Single
Date
String
Number

Indicates the type of user-defined field:
• Multiple = Table user-defined field that allows selection of 

multiple items.

• Single = Table user-defined field that allows selection of single 
item only.

• Date = Date user-defined field.
• String = Alphanumeric user-defined field.

• Number = Numeric user-defined field.
• Formula = Formula user-defined field.
• Boolean = Yes/No user-defined field.

This attribute also applies to the <Detail> elements within other 
elements.
The maximum length of the Type attribute is 80 characters.

Cases string No
Yes

Indicates whether the user-defined field can be assigned to Cases.

Companies string No
Yes

Indicates whether the user-defined field can be assigned to 
Company, Individual, or Contact Address Book entries.

Individuals string No
Yes

Contacts string No
Yes

DateAnnua
l

string Yes Applies to Date user-defined fields only. 
Yes = Annually recurring event.

RetainYear string Yes Applies to Annually Recurring Date user-defined fields only. 
Yes = Retain year in annually recurring dates.
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Hotlist integer 1 Applies to Date user-defined fields only.
1 = Create Hotlist task.

Length integer Applies to Alphanumeric user-defined fields only. Indicates the 
maximum length of the field value.

Attribute
Data 
Type

Valid 
Values Description
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Individual Element

The <Individual> element describes an Address Book entry for an 
Individual. Mandatory sub-elements are shown in bold. 

<Individual>
<ContactNo></ContactNo>
<FirstName></FirstName>
<LastName></LastName>
<Initial></Initial>
<MrMs></MrMs>
<Title></Title>
<Salutation></Salutation>
<Phone>

<Number></Number>
<Extension></Extension>
<Description></Description>

</Phone>
<Email>

<Address></Address>
<Description></Description>

</Email>
<Department></Department>
<Division></Division>
<ReportsTo></ReportsTo>
<AssignedTo></AssignedTo>
<Category></Category>
<DoNotSolicitBy></DoNotSolicitBy>
<Website></Website>
<Created></Created>
<LastModified></LastModified>
<SalesLead></SalesLead>
<Address>

Refer to “Address Element” on page 399.
</Address>
<DetailDate Name=””></DetailDate>
<DetailNumber Name=””></DetailNumber>
<DetailString Name=””></DetailString>
<DetailList Name=””></DetailList>
<DetailListMulti Name=””>

<Value></Value>
</DetailListMulti>
<Note>

Refer to “Note Element” on page 399.
</Note>
<Document>

Refer to “Document Element” on page 399.
</Document>
<Id></Id>
<Firm></Firm>
<Contact>

Refer to “Contact Element” on page 398.
</Contact>

</Individual>
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Company Element

The <Company> element describes an Address Book entry for a 
Company. Mandatory sub-elements are shown in bold.

<Company>
<Id></Id>
<Name></Name>
<Department></Department>
<Division></Division>
<Phone>

<Number></Number>
<Extension></Extension>
<Description></Description>

</Phone>
<Email>

<Address></Address>
<Description></Description>

</Email>
<Website></Website>
<AssignedTo></AssignedTo>
<Category></Category>
<DoNotSolicitBy></DoNotSolicitBy>
<Created></Created>
<LastModified></LastModified>
<SalesLead></SalesLead>
<Address>

Refer to “Address Element” on page 399.
</Address>
<DetailDate Name=””></DetailDate>
<DetailNumber Name=””></DetailNumber>
<DetailString Name=””></DetailString>
<DetailList Name=””></DetailList>
<DetailListMulti Name=””>

<Value></Value>
</DetailListMulti>
<Note>

Refer to “Note Element” on page 399.
</Note>
<Document>

Refer to “Document Element” on page 399.
</Document>
<Contact>

Refer to “Contact Element” on page 398.
</Contact>

</Company>
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KnowledgeBaseArticle Element

The <KnowledgeBaseArticle> element describes a Knowledge Base 
Article. The contents of the article itself are stored in the <Data> sub-
element. 

Note: To import your own knowledge base articles that were not 
exported from Maximizer, you must encode the text in Base64 for 
the Data field in the MXI/XML file.

<KnowledgeBaseArticle>
<Machine></Machine>
<Sequence></Sequence>
<Status></Status>
<Creator></Creator>
<Owner></Owner>
<LastModified></LastModified>
<Created></Created>
<FileName></FileName>
<FileExt></FileExt>
<Title></Title>
<KeyWords></KeyWords>
<Product></Product>
<Category></Category>
<Data></Data>

</KnowledgeBaseArticle>

Case Element

The <Case> element describes a Customer Service Case. Mandatory 
sub-elements are shown in bold.

<Case>
<CaseNumber></CaseNumber>
<CaseId></CaseId>
<Subject></Subject>
<CaseCompanyIndividual>

<Id></Id>
<ContactNo></ContactNo>

</CaseCompanyIndividual>
<CaseContact>

<Id></Id>
<ContactNo></ContactNo>

</CaseContact>
<Solution>

<Id></Id>
<ContactNo></ContactNo>

</Solution>
<ArticleId></ArticleId>
<Priority></Priority>
<Severity></Severity>
<Fee></Fee>
<BillRate></BillRate>
<BillableTime></BillableTime>
<Owner></Owner>
<AssignedTo></AssignedTo>
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<CreatedBy></CreatedBy>
<ModifiedBy></ModifiedBy>
<ResolvedBy></ResolvedBy>
<CaseOwner></CaseOwner>
<Type></Type>
<Reason></Reason>
<Origin></Origin>
<Category></Category>
<BillingType></BillingType>
<Queue></Queue>
<Status></Status>
<ModifyDate></ModifyDate>
<DeadlineDate></DeadlineDate>
<CreateDate></CreateDate>
<ResolveDate></ResolveDate>
<Description></Description>
<DetailDate Name=””></DetailDate>
<DetailNumber Name=””></DetailNumber>
<DetailString Name=””></DetailString>
<DetailList Name=””></DetailList>
<DetailListMulti Name=””>

<Value></Value>
</DetailListMulti>
<Note>

Refer to “Note Element” on page 399.
</Note>
<Document>

Refer to “Document Element” on page 399.
</Document>

</Case>
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Contact Element

The <Contact> element describes an Address Book entry for a 
Contact. This element is nested within the <Individual> and 
<Company> elements. Mandatory sub-elements are shown in bold.

<Contact>
<ContactNo></ContactNo>
<FirstName></FirstName>
<LastName></LastName>
<Initial></Initial>
<MrMs></MrMs>
<Title></Title>
<Salutation></Salutation>
<Phone>

<Number></Number>
<Extension></Extension>
<Description></Description>

</Phone>
<Email>

<Address></Address>
<Description></Description>

</Email>
<Department></Department>
<Division></Division>
<ReportsTo></ReportsTo>
<AssignedTo></AssignedTo>
<Category></Category>
<DoNotSolicitBy></DoNotSolicitBy>
<Website></Website>
<Created></Created>
<LastModified></LastModified>
<SalesLead></SalesLead>
<Address>

Refer to “Address Element” on page 399.
</Address>
<DetailDate Name=””></DetailDate>
<DetailNumber Name=””></DetailNumber>
<DetailString Name=””></DetailString>
<DetailList Name=””></DetailList>
<DetailListMulti Name=””>

<Value></Value>
</DetailListMulti>
<Note>

Refer to “Note Element” on page 399.
</Note>
<Document>

Refer to “Document Element” on page 399.
</Document>

</Contact>
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Address Element

The <Contact> element describes the address of an Address Book 
entry. This element is nested within the <Individual>, <Company>, 
and <Contact> elements. 

<Address>
<Description></Description>
<AddressLine1></AddressLine1>
<AddressLine2></AddressLine2>
<City></City>
<StateProvince></StateProvince>
<Country></Country>
<ZipCode></ZipCode>

</Address>

Note Element

The <Note> element describes any notes for Address Book entries or 
customer service cases. This element is nested within the 
<Individual>, <Company>, <Contact>, and <Case> elements. 
Mandatory sub-elements are shown in bold. The body of the note is 
stored in the <Text> element.

<Note>
<Date></Date>
<Creator></Creator>
<Owner></Owner>
<Type></Type>
<Text></Text>

</Note>

Document Element

The <Document> element describes any Documents for Address Book 
entries or customer service cases. This element is nested within the 
<Individual>, <Company>, <Contact>, and <Case> elements. 
Mandatory sub-elements are shown in bold. The body of the 
document is stored in the <DocData> element.

<Document>
<DocumentId></DocumentId>
<Name></Name>
<Date></Date>
<Creator></Creator>
<Owner></Owner>
<Extension></Extension>
<DocData></DocData>

</Document>
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Element Details

The following table lists all the elements in the Maximizer XML schema in alphabetical order and 
describes the following properties of each:

• Element Name: The name of the XML element. An element name may be listed more than 
once if it has different properties depending on its parent element. Most of the element names 
correspond to Maximizer field names.

• Parent Element(s): The name of the XML element(s) within which the element is nested. If an 
element with the same name and same properties may exist within more than one parent 
element, all parent elements are listed.

• Min. Occur.: The minimum number of times the element must occur within its parent element. 
A value of 1 indicates that the element is mandatory, and a value of 0 indicates it is not.

• Max. Occur.: The maximum number of times the element may occur within its parent element. 
The infinity symbol indicates that the maximum occurrences are unbounded (unlimited).

• Data Type: The type of data that may be stored in the element.

• Max. Length: The maximum length of the element contents. If this value is blank, there is no 
maximum length. 

Element Name Parent Element(s)
Min. 
Occur.

Max. 
Occur. Data Type

Max. 
Length

Addressa Email 1 1 string 120

Addressa Individual
Company
Contact

0 1 noneb

AddressLine1 Address 0 1 string 80

AddressLine2 Address 0 1 string 80

AllData none 1 1 noneb

ArticleId Case 0 1 string 80

AssignedTo Individual
Company
Contact
Case

0 1 string 11

BillableTime Case 0 1 double

BillingType Case 0 1 string 80

BillRate Case 0 1 double

Case AllData 0 noneb

CaseCompanyIndividual Case 0 1 noneb

CaseContact Case 0 1 noneb

CaseId Case 0 1 string 80
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CaseNumber Case 0 1 string 80

CaseOwner Case 0 1 string 80

Categorya Individual
Company
Contact

0 1 string

Categorya KnowledgeBaseArticle
Case

0 1 string 80

City Address 0 1 string 80

ClientIdGeneration ImportOptions 0 1 string

ClientOptions ImportOptions 0 1 noneb

Company AllData 0 unlimited noneb

Contact Individual
Company

0 unlimited noneb

ContactNoa Individual
Contact

0 1 integer

ContactNoa CaseCompanyIndividual
CaseContact
Solution

1 1 integer

ContactOptions ImportOptions 0 1 noneb

Country Address 0 1 string 80

Created Individual
Company
Contact
KnowledgeBaseArticle

0 1 dateTime

CreateDate Case 0 1 dateTime

CreatedBy Case 0 1 string 80

Creator Note
Document
KnowledgeBaseArticle

0 1 string 80

Datac KnowledgeBaseArticle 0 1 string

Date Note
Document

1 1 dateTime

DeadlineDate Case 0 1 dateTime

Element Name Parent Element(s)
Min. 
Occur.

Max. 
Occur. Data Type

Max. 
Length
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Department Individual
Company
Contact

0 1 string 80

Descriptiona Phone
Email

0 1 string 22

Descriptiona Address 0 1 string 80

Descriptiona DetailDef
Case

0 1 string

DetailDate Individual
Company
Contact
Case

0 unlimited date

DetailDef AllData 0 unlimited noneb

DetailList Individual
Company
Contact
Case

0 unlimited string 80

DetailListMulti Individual
Company
Contact
Case

0 unlimited noneb

DetailNumber Individual
Company
Contact
Case

0 unlimited double

DetailString Individual
Company
Contact
Case

0 unlimited string 120

Division Individual
Contact
Company

0 1 string 80

DocData Document 0 1 string

Document Individual
Company
Contact
Case

0 unlimited noneb

DocumentId Document 0 1 integer

Element Name Parent Element(s)
Min. 
Occur.

Max. 
Occur. Data Type

Max. 
Length
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DoNotSolicitBy Individual
Company
Contact

0 1 string

Email Individual
Company
Contact

0 3 noneb

Extension Phone
Document

0 1 string 22

Fee Case 0 1 double

FileExt KnowledgeBaseArticle 0 1 string 22

FileName KnowledgeBaseArticle 0 1 string 120

Firm Individual 0 1 string 80

FirstName Individual
Contact

0 1 string 80

Id Individual
Company
CaseCompanyIndividual
CaseContact
Solution

1 1 string 23

ImportOptions AllData 0 1 noneb

Individual AllData 0 unlimited noneb

Initial Individual
Contact

0 1 string 80

KeyWords KnowledgeBaseArticle 0 1 string 120

KnowledgeBaseArticle AllData 0 unlimited noneb

LastModified Individual
Company
Contact
KnowledgeBaseArticle

0 1 dateTime

LastName Individual
Contact

1 1 string 80

LeadHandling ImportOptions 0 1 string

ListItem DetailDef 0 unlimited string 80

LogFile ImportOptions 0 1 string

LogLevel ImportOptions 0 1 integer

Element Name Parent Element(s)
Min. 
Occur.

Max. 
Occur. Data Type

Max. 
Length



Maximizer CRM 11
Administrator’s Guide

404
Machine KnowledgeBaseArticle 0 1 integer

MatchDetail ClientOptions
ContactOptions

0 1 string

MatchMode ClientOptions
ContactOptions

1 1 string

ModifiedBy Case 0 1 string 80

ModifyDate Case 0 1 dateTime

MrMs Individual
Contact

0 1 string 80

Name Company
Document

1 1 string 80

Note Individual
Company
Contact
Case

0 unlimited noneb

Number Phone 1 1 string 22

Origin Case 0 1 string 80

Owner Note
Document
KnowledgeBaseArticle
Case

0 1 string 80

Phone Individual
Company
Contact

0 4 noneb

Priority Case 0 1 string 80

Product KnowledgeBaseArticle 0 1 string 80

Queue Case 0 1 string 80

Reason Case 0 1 string 80

ReportsTo Individual
Contact

0 1 string 80

ResolveDate Case 0 1 dateTime

ResolvedBy Case 0 1 string 80

SalesLead Individual
Company
Contact

0 1 boolean

Element Name Parent Element(s)
Min. 
Occur.

Max. 
Occur. Data Type

Max. 
Length
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Salutation Individual
Contact

0 1 string 80

Sequence KnowledgeBaseArticle 0 1 integer

Severity Case 0 1 string 80

Solution Case 0 1 noneb

StateProvince Address 0 1 string 80

Statusa KnowledgeBaseArticle 0 1 integer

Statusa Case 0 1 string 80

Subject Case 0 1 string

Text Note 1 1 string

Titlea Individual
Contact

0 1 string 80

Titlea KnowledgeBaseArticle 0 1 string 120

Type Note
Case

0 1 string 80

Value DetailListMulti 1 unlimited string 80

Website Individual
Company
Contact

0 1 string 120

ZipCode Address 0 1 string 80

a. This element is listed more than once because of differing properties depending on which element is the 
parent element.

b. This element cannot contain a value; it can only contain other elements.
c. To import your own knowledge base articles that were not exported from Maximizer, you must encode the 

text in Base64 for the Data field in the MXI/XML file.

Element Name Parent Element(s)
Min. 
Occur.

Max. 
Occur. Data Type

Max. 
Length
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Search String Language
Each access object in Maximizer.Data has a method called ReadList() 
which returns a .NET collection of the associated objects. This method 
may be called with no parameters to return everything in the 
Address Book or with a search string.

Search Syntax

The syntax for the search string is a functional or prefix operator 
notation. Expressions are of the form 
<Operator>([“]<Parameter1>[“]{,[“]<Parameter>[“]}). This 
syntax was chosen because it would be well suited to a search tree 
interface. Double-quotes are always optional, although, you’d need 
them if a search parameter included commas, spaces, or parentheses. 
In most programming languages, you’ll need to make sure you 
escape double-quote characters when specifying them as a string.

Example

AND(EQ(City,Vancouver), OR(LIKE(Phone1,604%), 
LIKE(Phone2,604%)))

Result

This search string would return all Address Book entries where the 
city is Vancouver and at least one of the first two phone numbers 
starts with 604.

Search Operators

Each object supports a subset of the total search string syntax, and 
each operator supported by the object supports its use on a subset of 
the object’s fields. Deviation from what is supported will result in an 
exception being thrown as described later. As a minimum, the KEY 
operator is supported by every object as a means of selecting a single 
record in the set.

The following tables describe the operators available to the search 
string language.
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Object-level Search Operators

The following search operators apply to the object. The 
documentation of each object lists which search operators are 
available for that object. However, the KEY operator is available for 
all objects.

Operator Description Parameters

AND All sub-expressions must evaluate to 
true to return an object in the result 
set.

Each parameter is a sub-expression to 
be AND/OR together. A minimum of 
one parameter is required.

OR At least one sub-expression must 
evaluate to true to return an object in 
the result set.

KEY An object must have the given key or 
derive from a supported foreign key 
for it to be returned in the result set.

The parameter is a supported key for 
this object. Exactly one parameter is 
required. IMPORTANT NOTE: 
Maximizer.Data keys are encrypted. A 
key may include letters, numbers and 
special printable characters, but will 
NEVER include double quote 
characters. It is recommended that 
when using this operator, you 
surround your key with double quotes.
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The following search operators apply to the AbEntryAccess object 
only.

Operator Description Parameters

WNOTE An object must have an associated 
note as described to be returned in the 
result set.

Up to eight parameters may be 
specified. Only the first is mandatory, 
and those left unspecified will not be 
included in the search. The first 
parameter is the search text. The 
search text may occur anywhere in a 
note. “_” is a single character wildcard. 
The second and third parameters are 
the start and end dates expressed as 
YYYY-MM-DD. The fourth parameter is 
the set of note types to return (e.g. 
“1,2,4”). The fifth parameter is the 
Creator. The sixth parameter is the 
Owner. If you want to return only 
public notes, put “PUBLIC” here. The 
seventh parameter is the note 
category. The eighth parameter is the 
option to use full text search. If you 
want to use the full text search, put 
“FULLTEXT” here. 

NWNOTE An object cannot have an associated 
note as described to be returned in the 
result set.

FLIST An object (generally an Address Book 
entry) must be in the favorite list to be 
returned in the result set.

The only parameter is the FavoriteList 
key. Exactly 1 parameter is supported. 
Ensure to enclose the keys in double 
quotes. 

LIST An object (generally an Address Book 
entry) must be explicitly listed to be 
returned in the result set. 

List the AbEntry keys corresponding to 
the objects you want to return. Any 
number of parameters is supported. 
Ensure to enclose the key in double 
quotes. 
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Field-level Search Operators

The following search operators apply to the fields within each object. 
The documentation of each field lists which operators are available 
for each field.

WDOC An object must have an associated 
document as described to be returned 
in the result set.

Up to eight parameters may be 
specified. Only the first parameter is 
mandatory, and those left unspecified 
will not be included in the search. The 
first parameter is the search text. The 
search text may occur anywhere in a 
document. “_” is a single character 
wildcard. The second and third 
parameters are the start and end dates 
expressed as YYYY-MM-DD. The fourth 
parameter is the document name. The 
fifth parameter is the minimum size of 
the document. The sixth parameter is 
the Creator. The seventh parameter is 
the Owner of the document. The 
eighth parameter is the document 
category.

NWDOC An object cannot have an associated 
document as described to be returned 
in the result set.

Operator Description Parameters

Operator Description Parameters

EQ A given field must be equal to the 
search criteria to return an object in the 
result set.

The first parameter is the field name. 
The second parameter is the search 
criteria. No wildcards are supported. 
See LIKE/NLIKE. Exactly two parameters 
are required.NEQ A given field cannot be equal to the 

search criteria to return an object in the 
result set.

LIKE A given field must be similar to the 
search criteria to return an object in the 
result set.

The first parameter is the field name. 
The second parameter is the search 
criteria. Standard SQL wildcards “_” and 
“%” are supported. Exactly two 
parameters are required.NLIKE A given field cannot be similar to the 

search criteria to return an object in the 
result set.

RANGE A given folder must be in the range 
provided to return an object in the result 
set.

The first parameter is the field name. The 
second and third parameters define the 
range. Exactly 3 parameters are required. 

NRANGE A given field cannot be in the range 
provided to return an object in the 
result set.
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Maximizer and Administrator Terminology
.NET – See Microsoft .NET Framework. 

access rights – Security settings for users. Access rights control each 
user’s permissions to read, insert, modify, or delete various types of 
Maximizer entries. They also control general Maximizer privileges, 
user roles, and allowed printing destinations. Access rights 
determined by the user’s access settings and the access settings of 
any security groups the user belongs to. For more information about 
access rights, refer to “User and Group Security” on page 84.

access settings – There are two types of access settings: user access 
settings and group access settings. Combined user and group access 
settings determine a user’s access rights. For more information about 
access settings, refer to refer to “User and Group Security” on 
page 84.

Accounting Link – A Maximizer add-on that enables users to 
connect to an external accounting database through Maximizer. For 
more information, refer to the Accounting Link User’s Guide or the 
Maximizer web site.

Address Book – A Maximizer database.

Address Book entry – A Company, Individual, or Contact in the 
Maximizer Address Book.

Administrator – A Maximizer module in which the Address Book 
administrator can perform configuration and maintenance of the 
Maximizer system and Address Books.

advanced import – Importing an MXI or XML file into an Address 
Book. For more information about advanced import, refer to 
“Importing Address Book Data from MXI or XML Files” on page 326.

Application Server – See Maximizer Application Server.

automated campaign – A series of automated emails, faxes, or 
printed documents that Maximizer sends on a predefined schedule. 
An automated campaign is based on an automated campaign 
template. 

automated services – Maximizer Email Service. Used for 
automated campaigns, customer service case email notifications, and 
appointment reminders by email.

Calendar – A Maximizer window where you can manage your 
appointments.

Campaign Manager Statistics – A Maximizer component that 
tracks the number of emails opened by the recipients, the number of 
recipients who clicked web links within the email, and the number of 
recipients who chose to unsubscribe from future campaigns.
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campaign template – A pre-defined strategy used by email and 
traditional marketing campaigns. See automated campaign and 
traditional campaign.

catalog – A product listing created using OrderDesk. You build your 
catalog by adding sections and catalog items, and publish the catalog 
on your web server.

Company – An Address Book entry used to record information for a 
company or organization.

Company Library – A shared library of company literature.

COMPANY user – A Maximizer system user account used for the 
company calendar to display company events in the Maximizer 
calendar.

Contact – An Address Book entry used to record information for an 
individual person associated with a Company or Individual type of 
Address Book entry.

Controlling window – A main Maximizer window, such as the 
Address Book window, that determines what tabbed following 
windows are displayed. The contents of the following window 
depend on which entry is selected in the main controlling window.

Crystal Reports – A tool for creating reports. Crystal reports are 
available for viewing and generation through the Reports menu in 
Maximizer.

Customization Suite – A Maximizer add-on enabling you to 
customize Maximizer’s functionality and interface and to integrate it 
with other applications. For more information, refer to the 
Maximizer web site.

Dashboards – Component of Maximizer Web Access that display 
real-time information on your company using dashboard-style 
instrumentation.

default entry – An Address Book entry containing field values that 
are propagated to new Address Book entries by default.

demilitarized zone (DMZ) – A network area between the external 
router, which talks to the Internet, and the corporate firewall, which 
protects internal computers from Internet security breaches

DSN – A Data Source Name providing connectivity to a database 
through an ODBC driver.

EMAILUSER – A Maximizer system user account that gives Maximizer 
access to Address Book data when it performs automated email 
activities such as automated campaigns. It is also used by MaxSync for 
Microsoft Exchange.

Escona Tutorial – The Escona Tutorial Address Book is a sample 
Address Book included with a typical installation of Maximizer. Using 
the example of a fictitious vintner in the Sonoma Valley, this Address 
Book demonstrates many of Maximizer’s possibilities.
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event notification – Automatic email notification and logging 
when specific Maximizer and MaxExchange events occur. For more 
information, refer to “Enabling Event Notification” on page 152.

Following window – A tabbed sub-window of a controlling 
window. The contents of the following window depend on which 
entry is selected in the main controlling window. For example, the 
Contacts window displays only those Contacts that belong to the 
selected entry in the Address Book window.

global Address Book – A shared Address Book residing on the 
server. When creating a global Address Book, it is recommended that 
you create the new Address Book on the Maximizer Server. If you 
create a new global Address Book from the workstation, you must 
have administrative rights to the server.

Global Edit – A Maximizer operation that enables you to apply the 
same change to multiple Maximizer entries simultaneously.

group – See security group.

Holiday Editor – A tool in Administrator for adding holidays to the 
Maximizer Calendar window.

Hotlist – A window in Maximizer used to display tasks and 
appointments in a specific date range.

IIS – See Microsoft Internet Information Server.

IP address – A number used to uniquely identify a specific computer 
on the Internet. Every Internet-connected computer has an IP 
address. In Maximizer, you use the IIS server’s IP address when you 
preview or publish your online catalog.

Java servlet engine – A Java-based portion of the Payment 
Gateway Module that is used for online transaction processing.

Key Fields – Important user-defined fields that are highlighted on 
the Basic Information tab of Maximizer entries. For more 
information, refer to “Creating Key Fields Lists” on page 140.

Knowledge base – A database containing articles pertaining to 
solutions for customer service and/or technical issues.

lead – An Address Book entry (Company, Individual, or Contact) that 
has been flagged as a potential client or customer.

list – A listing of entries in Maximizer. You can create a list using a 
search or by selecting specific entries and reducing the list to the 
selection. Most activities are performed for the current list or the 
current entry.

load balancing – When a web server is running at capacity, new 
connections are to another web server for processing.

local Address Book – An Address Book residing on the local 
workstation.
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Macromedia JRun Java Servlet Engine – A Java servlet engine 
used for online transaction processing. JRun is only one possible Java 
servlet engine that you may use.

mandatory field – Fields in Maximizer entries that must contain a 
value. Mandatory fields are designated through File > Preferences > 
Mandatory Fields in Administrator.

mandatory user-defined field – User-defined fields in Maximizer 
entries that must contain a value. Mandatory user-defined fields are 
designated through File > Set Up User-Defined Fields in 
Administrator or Maximizer.

marketing team – A group of users to support team-based work on 
marketing campaigns in Maximizer.

MASTER user – The Address Book administrator’s user ID. This user 
ID permits access to Administrator.

MaxAlarm – A Maximizer companion application that automatically 
monitors appointments for one or more people in any number of 
Address Books and notifies them of appointments.

MaxExchange – A Maximizer program used to synchronize an 
Address Book between a central server and remote distribution sites 
via FTP, email, or a direct network connection.

MaxExchange Site Manager – A utility for creating and managing 
sales and marketing teams. MaxExchange Site Manager is accessed 
through Administrator.

Maximizer – A Maximizer CRM module in which you can perform 
contact management and sales force automation activities.

Maximizer Application Server – The principal Windows Server 
where Maximizer CRM Server is installed.

Maximizer Email Service – A Maximizer automated service that 
provides automated email campaign activities, customer service case 
email notifications, and appointment reminders by email.

Maximizer XML Interface (MXI) – An XML file format for 
importing entries into a Maximizer Address Book.

MDAC – Microsoft Data Access Components. Provides ActiveX Data 
Objects (ADO), OLE DB, and Open Database Connectivity (ODBC) 
components for Maximizer to integrate information from multiple 
sources.

merge field – Text inserted into a document or template that is 
replaced by Address Book information during a mail merge. For 
example, a merge field can be a Contact’s name, so you can 
customize a letter’s salutation with the recipient’s name.

Microsoft .NET Framework – A Microsoft operating system 
platform required for MaxExchange Synchronization Server, 
Maximizer Web Access, and Maximizer Campaign Manager Statistics.
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MaxSync for Microsoft Exchange – A Maximizer add-on for 
synchronizing some Maximizer entries, such as Address Book entries, 
between Maximizer and a Microsoft Exchange Server.

Microsoft Internet Information Server (IIS) – Microsoft web 
server software. Internet Information Server, or IIS, is used for many 
of the Maximizer components.

Microsoft SQL Server – A database server used by Maximizer for 
the Address Book data.

Microsoft Systems Management Server (SMS) – A set of tools 
from Microsoft for managing computers in a local area network 
(LAN). Maximizer supports automated remote installation using SMS.

MXI – See Maximizer XML Interface.

note – A text document attached to Address Book entries, Contacts, 
opportunities, and campaigns. 

OLE – Object linking and embedding (OLE) is a technology that 
allows you to insert files, portions of files, and links to files into a 
document or application. You can insert files in the Documents 
window and the Company Library. Double-clicking the file opens it in 
the associated (and installed) application.

opportunity – An entry in Maximizer used to record an opportunity 
to make a sale. Opportunities can organize a sales team using a 
structured sales strategy.

OrderDesk – A window in Maximizer used to manage orders and 
inquiries from your online catalog.

Outlook Synchronization – A Maximizer feature for synchronizing 
some Maximizer entries, such as Address Book entries, between 
Maximizer and a Microsoft Outlook. 

PLN – Product License Number. A Maximizer license. For more 
information, refer to “Installing Licenses” on page 61.

preferences – A collection of program options that allow users to 
customize how Maximizer functions. Some preferences are set in 
Administrator

PSN – Product Serial Number. Entered during product installation.

registry key – Configuration information stored in the Windows 
operating system. 

related entries – An entry that records a relationship between two 
Address Book entries. For example, one Address Book entry might be 
an accountant for another Address Book entry, which could be 
recorded as a related entry in Maximizer.

Reporter – A web-based application for reporting on Maximizer 
Address Book data.

sales team – A group of users to support team-based work on sales 
opportunities in Maximizer.



Appendix B
Glossary

417
sites – Web-based interfaces (Maximizer Web Access) for Maximizer 
Address Books. This includes Maximizer Web Access, Customer 
Access, Partner Access, and Wireless Access.

script file – A file containing commands that can be executed 
without user interaction. 

security group – A set of access settings for a subset of Maximizer 
users. For more information, refer to “User and Group Security” on 
page 84.

SMS – See Microsoft Systems Management Server.

SMTP – An SMTP server is a server used for outgoing Internet email.

SQL – See Microsoft SQL Server.

strategy – A structured, team-based approach to pursuing sales 
opportunities. Strategies define the steps, activities, and roles 
involved in successfully completing a sale.

system field – All Maximizer fields that are not user-defined fields 
are system fields. A few system fields have customizable value-
selection lists, which can be defined through File > Preferences > 
System Fields in Administrator. 

system-defined field – User-defined fields created by Maximizer 
rather than by users. Users can modify some properties of these fields 
but cannot delete them. In the Set Up User-Defined Fields dialog box, 
system-defined fields are displayed in bold. 

TAPI – Telephony Application Programming Interface. An interface 
that can connect to telephone services from Maximizer.

team – See sales team or marketing team.

template – A file that outlines the design for a document, email, or 
web page. Maximizer uses templates for word processor documents, 
and for automated activities that belong to automated campaigns. 
Templates can contain merge fields for bulk mailings. Also, see 
campaign template.

thin-client applications – Allow you to remotely access Maximizer 
Address Book data using the web. “Maximizer on the Web” consists 
of Maximizer Web Access, Wireless Access, Partner Access, and 
Customer Access. 

traditional campaign – Used to organize a marketing effort, 
including a marketing team’s steps, activities, and roles.

two-tier import – A procedure for importing Address Book entries 
where Companies are imported first followed by Contacts.

UDF – See user-defined field.

UNC – Universal Naming Convention. A kind of network path used to 
locate files and folders. An example of a UNC path is 
“\\Escona\MxServer\”.
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user ID – A name that uniquely identifies a Maximizer user. Users 
must enter their user ID and password to gain access to a Maximizer 
Address Book.

user-defined field – A custom field used to record additional “user-
defined” information for Address Book entries, opportunities, 
campaigns, and users.

virtual directory – An IIS folder that points to a physical folder on 
the computer. The contents of the physical folder that the virtual 
directory refers to is accessible to the Internet or intranet via the IIS 
server.

web access – Web access allows you to remotely access Maximizer 
Address Book data using the web. “Maximizer on the Web” consists 
of Maximizer Web Access, Wireless Access, Partner Access, and 
Customer Access. 

web.config – A configuration file for .NET applications. Each of the 
applications has its own web.config file.

WEBUSER – A Maximizer system user account required for Customer 
Access and Partner Access.

workflow automation – A tool that monitors your business systems 
and automatically assigns the appropriate people to take action.

XML – Extensible Markup Language. A file format that can be 
displayed is XML-enabled web browsers. 

MaxExchange Terminology
For more information about MaxExchange, refer to the 
MaxExchange Administrator’s Guide.

MaxExchange Distribution – A Maximizer system-defined field for 
defining MaxExchange distribution groups.

MaxExchange – A Maximizer program used to synchronize an 
Address Book between a central server and remote distribution sites 
via FTP, email, or a direct network connection.

Maximizer Remote Workstation (MaxExchange Remote) – A 
computer that has the Maximizer client components installed and 
connects to the Maximizer Application Server.

MaxExchange Site Manager – A utility for creating and managing 
sales and marketing teams. MaxExchange Site Manager is accessible 
through Administrator.
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Symbols

.NET Framework 33

A

access rights 84–85
site security groups 215
sites 218, 241

access settings 84–85
modifying user access settings 90
security groups 92

Accounting Link
Accounting security group 93
installing 58
overview 6
permissions 86

accounts
anonymous web access 13
COMPANY 72
EMAILUSER 72, 362
MASTER 72
Microsoft IIS 18
sites 244–246
system account authentication 102
WEBUSER 72

ACT!, importing from 337, 341
Action Plan Library permissions 86
addition, in user-defined fields 127
AddrBks folder 35
Address Book

adding users 78
backing up 306–309
converting 74
creating 67–71, 222
deleting 222
Escona Tutorial sample 7
exporting data 317–326
holidays 155
ID 112
importing data 326–337
local or global list 69
moving 311
name 112
permissions 85
preferences 110, 228
restoring from backup 309
Short ID 112
summary report 357
updating 74
upgrading 74

verification and recovery 314
Address Book entries

categories 110, 228
duplicate checking 114
exporting 317
importing 326–337
mandatory fields 111
synchronizing with Outlook 117, 160–174
transferring 349–351
verification and recovery 314

Administrator 222
Administrator user role 88
Advanced Import 326–329
Allow Global Edit privilege 86
Allow manage currencies 87
Allow printing to these destinations 88
Allow private entries privilege 86, 98
Allow public entries privilege 86
Allow Sync Contacts with External clients privilege 87
Allow transfer and import/export 86
alphanumeric user-defined fields 118

functions for 128
AND (Maximizer.Data) 407
AND operator in formula user-defined fields 139
anonymous web access account 13
application server 28
application settings for sites 206, 211
appointments

email notification 110
locations and resources 111, 229
with MaxSync for Microsoft Exchange 167
with Outlook Synchronization 161

arithmetic in user-defined fields 127
ASP.NET 364
ATT files 384
authentication, system accounts 102, 360
automated campaigns 110

logging 372
timeout error 361
troubleshooting 361–362
using wrong character set 362

automated remote installation 290

B

backing up
Address Book 306–309
dictionary file 311
holiday file 311

batch files, for installation 295
browsers
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configuration for Wireless Access 238
system requirements 3
Wireless Access 238

business partners, Partner Access 244–246

C

caller ID 186
campaigns 112

automated 110
completion reasons 110
logging automated campaigns 372
permissions 85
timeout error 361
troubleshooting 361–362, 364
troubleshooting campaign tracking 364
using wrong character set 362

categories, Address Book entries 110, 228
Category field 245
ceiling function 136
character set, Maximizer Email Service 362
CMGR-Email_dd.log file 374
commands

ipconfig 31
ping 30

company announcements
security group 93

Company Library
permissions 85
supported file types in Maximizer Web Access 196
verification and recovery 314

COMPANY user account 72
comparing values in formula user-defined fields 138
completion reasons

campaigns 110
opportunities 111, 228

Configuration Manager, external sites 241
Configuring 181
connectivity

testing network 30
converting an Address Book 74
Corel WordPerfect Office Integration 43, 56
Crystal Reports 33

access rights 107
Crystal Reports Users security group 93, 107
when upgrading an Address Book 74

Current Users report 62, 358
Custom Report, printing access rights 89, 107
CustomActions.xml 255
Customer 94
Customer Access 195

activating login account 246
application settings in web.config 206, 211
controlling access 241
customers 244–246

Escona Tutorial 204
overview 5
security groups 215
setting up 240–250
URL 241

Customer Access Administrator 240
configuration manager 241, 243
Escona Tutorial 203
news manager 241
security group 215
URL 241

Customer Access Configuration Users group 215
customer service

case notification email 144–151
case response time 110, 229
Customer Service Manager user role 88
Customer Service Representative user role 88
customizable fields 110, 229
exporting cases 323
importing cases 326–329
permissions 85

D

dashboards
creating custom 302
overview 5
SQL queries 301

database
backing up 306–309
creating an Address Book 67–71
restoring from backup 309
upgrading 74
user-defined field tables and views 387

Database Management 222
Date function 133
date user-defined fields 118

functions for 132
Day function 133
Dayofweek function 134, 139
default password 83
Default Web Site

registering MIME types for 25
Default Web Site, Microsoft IIS 199
deleting Address Books 222
diagnostics 110
dictionary file 311
display name (user) 79
division, in user-defined fields 128
DMZ (demilitarized zone) 17
documents

deleting old 352
permissions 85

drivers
PBX 186
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TAPI 186
duplicate checking for Address Book entries 114

E

email
customer service case notification 144–151
Email Send Service log 373
event notification 152–154
notification 110
server 29
server settings in Web Access 229
service 110
system requirements 3–4

EMAILUSER account 72, 362
encrypted user-defined fields 118, 126
EQ (Maximizer.Data) 409
Escona Tutorial

Customer Access 204
Customer Access Administrator 203
Maximizer Web Access 202
Partner Access 204
Partner Access Administrator 203
sample Address Book 7

ETF files 384
event notification 112, 152–154
Event Viewer 154, 372
exact phone number matching 188
Excentrics World Components 195
Exchange synchronization (Microsoft), see MaxSync for Microsoft
Exchange
exporting

access rights required 86
Address Book entries 317
customer service cases 323
Knowledge Base articles 325

extensions, file extensions 384
external links, in Maximizer Web Access 219
external sites, see Customer Access or Partner Access

F

fax software 192
field mapping, data imports 331
fields

Category field 245
customer service 110, 229
Full Access field 98
Key Fields 140–143
mandatory and optional 111
mapping for import 331, 337
MaxExchange Distribution 112, 156–158, 326
MaxExchange Distribution privileges 87
Owner field 98
Read Access field 98

system 111, 229
user-defined fields 118–126

file and directory permissions 24
file types

adding support in IIS 25
files

dictionary 311
holidays 311
MaxUpdates.xml 285
MXI 388
types in Maximizer 384
types in Maximizer Web Access Company Library 196
web.config 206

fiscal year 112
FLIST (Maximizer.Data) 408
floor function 137
folders, shared 35
formula user-defined fields 127

alphanumeric functions 128
arithmetic expressions in 127
conditional expressions in 138
date functions 132
numeric functions 136

four-letter module codes 376
Full Access field 98

G

global Address Book list 69
global edit, privileges 86
global server 112
globalization, sites 261
glossary 411
GoldMine, importing from 337, 345
graphic on site main page 251
groups

access settings 84–85
Accounting security group 93
Company Annoucement Authors security group 93
creating security groups 95
Crystal Reports Users security group 93, 107
Customer Access Administration Users group 215
Customer Access Configuration Users group 215
external site security groups 241
MaxExchange distribution 157
Maximizer Web Access Administration Users group 215
modifying access settings 97
Partner Access Administration Users group 215
Partner Access Configuration Users group 215
permissions 85
privileges 86
record ownership 98
roles 88
security groups 92–98
security groups for sites 241
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site security groups 215
user and group setup permissions 85
User ID List report 356

H

hard disk space, system requirements 2–4
HDR files 384
Holiday Editor 155, 414
holidays, file 311
Hotlist, locations and resources 111, 229
HTML, links in Maximizer Web Access 219

I

If expressions in formula user-defined fields 138
IIS (Internet Information Services), see Microsoft IIS
importing

access rights required 86
Address Book entries 326–337
customer service cases 326–329
field mapping 331, 337
Knowledge Base articles 326–336
vertical templates 76

installation
batch files 295
Windows Scheduler 294

installing
Accounting Link 58
Live Update Manager 279
MaxAlarm 58
MaxExchange 58
Maximizer 27–63
Maximizer Components for Microsoft IIS 38, 48
Maximizer licenses 61
Maximizer server 38
Maximizer workstation 51
MaxSync for Microsoft Exchange 171
setting up automated remote installation 290
upgrading from a previous version 35
Web Access 38
Workflow Automation Powered by KnowledgeSync 58

Internet browsers
system requirements 3
Wireless Access 238

IP address 31
ipconfig command 31

K

KEY (Maximizer.Data) 407
Key Fields 140–143, 231
Knowledge Base

exporting articles 325
Knowledge Base approver user role 88

permissions 85

L

Len function 129
licenses

installing Maximizer licenses 61
LIKE (Maximizer.Data) 409
links, external in Maximizer Web Access 219
LIST (Maximizer.Data) 408
Live Update 277–287

configuring 286
introduction 278
MaxUpdates.xml 285

Live Update Manager
approving updates 283
configuring 281
downloading updates 282
installing 279
Live Update Wizard 282
testing updates 283

Live Update server
copying files 285
virtual directory 279

Live Update Wizard
Live Update Manager 282

load balancing Microsoft IIS 15
local Address Book list 69
locations, for appointments 111, 229
logging

Address Book transfers 350
automated campaigns 372
Email Send Service 373
event notification 154
import error log file 336
log files 110

logging in
sites 244–246, 250

logo, customizing on site main page 251

M

MA files 384
MaConfig table 376–377
mailing address permissions 85
mandatory

fields 111
user-defined fields 120

mapping fields for import 331, 337
marketing teams 99

report 357
MASTER

password 73
user account 72

MaxAlarm
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installing 58
overview 6

MaxExchange
and Microsoft Outlook synchronization 162
distribution groups 157
event notification 152–154
file types 384
installing 58
MaxExchange Distribution field 87, 112, 156–158, 326
overview 6
preferences 112
remote workstation 53
Synchronization Server 28
teams 99

Maximizer 94
application server 28
installation 27–63
installing components for Microsoft IIS 38, 48
installing server 38
installing workstation 51
licenses 61
Maximizer Components for Microsoft IIS 48

Maximizer Email Service
character set 362

Maximizer Live Update 287
Maximizer Web Access 194

Escona Tutorial 202
external links 219
overview 5
problems with SMTP servers 371
security groups 215
supported file types in Company Library 196
URL 241

Maximizer Web Access Administration Users group 215
Maximizer Web Access Administrator

Address Book preferences 228
database management 222
security groups 234
user-defined fields 223
users 232

MaxMobile
installing 58
synchronization privileges 87

MaxSync for Microsoft Exchange 166–179
and Outlook Synchronization 162, 169
installing 171
system requirements 3
Windows account 170

MaxUpdates.xml file 285
MDAC (Microsoft Data Access Components) 33
MDE files 384
MEC files 384
memory, system requirements 2–4
MESG format

for caller ID 186
MET files 384
MEX files 384
Microsoft .NET Framework 33
Microsoft Exchange synchronization, see MaxSync for Microsoft
Exchange
Microsoft IIS 11–25

account configuration 18
anonymous web access account 13
changing a site to an application 199
Default Web Site 199
DMZ (demilitarized zone) 17
file and directory permissions 24
installing Maximizer components for 38, 48
load balancing 15
Maximizer Components for Microsoft IIS 48
multiple IIS servers 262
on Windows 2003 364
on Windows 2008 365
overview 28
permissions 13
production environment 15
standalone servers 18
virtual directories 12, 385

Microsoft Internet Explorer WebControls 195
Microsoft Outlook integration with Maximizer Web Access 59
Microsoft Outlook Synchronization 160–174

and MaxExchange 162
and MaxSync for Microsoft Exchange 162, 169
privileges 87

Microsoft SMS installation 290
Microsoft SQL Server

Windows Authentication 360
Microsoft TAPI 186
Microsoft Word integration with Maximizer Web Access 59
Mid function 129
MIME types

for Wireless Access Shortcuts 239
registering 25

MODEM.INF file 186
modems

TAPI 186
Modify distribution field privileges 87
Modify note properties privilege 87
Modify other users’ general info only privileges 87
Modify other users’ private entries privileges 87
Modify/delete other owners’ notes privileges 87
modifying

group access settings 97
modules, four-letter module codes 376
monitoring customer service cases 110, 229
Month function 135
moving

Address Book 311
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MTI files 384
multiplication, in user-defined fields 127
MXD files 384
MxData shared folder 35
MXI (Maximizer XML Interface) files 326–329, 384, 388
MxServer shared folder 35
Mxzhol.nam file 311
My Work Day

caption text 112

N

NEQ (Maximizer.Data) 409
network

configuration 8
connectivity test 30

News Manager, external sites 241
NLIKE (Maximizer.Data) 409
NOT operator in formula user-defined fields 139
notes

deleting old 352
permissions 85
privileges 87
types 352

numeric user-defined fields 118
functions for 136

NWNOTE (Maximizer.Data) 408

O

operating system, system requirements 3–4
opportunities

completion reasons 111, 228
confidence ratings 111, 228
IDs 112
permissions 85
probability of close 111, 228
stages 111, 228
synchronization 112
verification and recovery 314

opportunity email notification 144
optional fields 111
options, system 112
OR (Maximizer.Data) 407
OR operator in formula user-defined fields 139
OrderDesk, permissions 85
Outlook Synchronization, see Microsoft Outlook Synchronization
overview page caption text 112
owner field 98

P

page size limits, Wireless Access 239
Partner Access 195

activating login account 246

Admin Users 94
application settings in web.config 206, 211
business partner login 250
business partners 244–246
Config Users 94
controlling access 241
Escona Tutorial 204
overview 5
removing site access 250
security groups 94, 215
setting up 240–250
URL 241

Partner Access Administrator 240
configuration manager 241, 243
Escona Tutorial 203
news manager 241
security group 215
URL 241

Partner Access Configuration Users group 215
passwords

changing 83
default 83
MASTER user 73
synchronization 362

PBX drivers 186
permissions

Crystal Reports 107
file and directory 24
groups 85
users 85
web server 13

phone
TAPI phone number format 112

phone calls
TAPI 186

phone masks 191
phone numbers

matching with TAPI 187
PIN, for site access 204, 246–250
ping command 30
PLNs (product license numbers), see licenses
preferences

Address Book 110
user 110
user preferences 106

prefixes for user-defined field database views 387
printing

access rights 88
Custom Reports 107
system reports 356

private
entries (privileges) 86
records 98

privileges (users and groups) 86
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probabilities of close (opportunities) 111, 228
processor speed, system requirements 2–4
public entries (privileges) 86
public records 98

Q

quick backup of Address Book 308
quotas

fiscal year 112

R

RAM, system requirements 2–4
RANGE (Maximizer.Data) 409
ratings schemes 111, 228
Read Access field 98
record ownership 98
recovering an Address Book 314
remote automated installation 290
remote workstation 53
reports 356–358

Crystal Reports 33
current users 62
Installed Workstations report 357
printing access rights 89
system 356
transfer summary 350
user-defined field tables and views 387

resources, for appointments 111, 229
restoring

Address Book from backup 309
roles (User’s Roles) 88
Round function 137

S

sales
Sales Manager user role 88
Sales Representative user role 88
sales teams report 357
teams 99

sample
Address Book 7
Customer Access Administrator 203
Maximizer Web Access 202
Partner Access Administrator 203
sites 198–205

SDM format 186
Search function 130
search string language, Maximizer.Data 406
search string parameter 220
security

file and directory permissions 24
Microsoft IIS 17

privileges 86
security groups 92–98
users and groups 84–85
web server permissions 13

security groups 92–98
access settings 84–85
Accounting security group 93
Company Annoucement Authors security group 93
creating 95
Crystal Reports Users security group 93, 107
Customer Access Administration Users group 215
Customer Access Configuration Users group 215
external sites 241
Maximizer Web Access Administration Users group 215
Maximizer Web Access Administrator 234
modifying access settings 97
Partner Access Administration Users group 215
Partner Access Configuration Users group 215
permissions 85
privileges 86
record ownership 98
roles 88
security groups for sites 241
showing to/hiding from users in Web Access 229
site security groups 215
user and group setup permissions 85
User ID list report 356

servers
CRM system requirements 2
email 29
email settings in Web Access 229
installing Maximizer 38
MaxExchange Synchronization Server 28
Maximizer application 28
MaxSync system requirements 3
Microsoft IIS 15, 28

services
Maximizer Email Service 110

sessionState in web.config 211
settings in MaConfig table 376
shared folders 35
site application settings 206
sites

accessing from the Start menu 241
Address Book login screen 259
application settings in web.config 206, 211
business partners and customers 244–246
changing to an application 199
Configuration Manager for external sites 241
configuring customer and partner 240–250
creating PINs for access 246–250
Customer Access Administration Users group 215
Customer Access Configuration Users group 215
enabling 197
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Escona Tutorial sample sites 198–205
globalization 261
installing to non-default folders 262
Maximizer Web Access Administration Users group 215
moving 262
multiple Address Books 262, 264
multiple IIS servers 262
multiple sites 264
News Manager for external sites 241
Partner Access Administration Users group 215
Partner Access Configuration Users group 215
PINs 204
removing access 250
security groups 215
timeout value 211
troubleshooting 367
URLs 241
web.config file 206

smart phone number matching 187
SMS installation 290
SMTP

server 29
timeout error 361
troubleshooting 371

sort order of user-defined fields 121
stages (opportunities) 111, 228
standalone IIS servers 18
starting the Default Web Site in Microsoft IIS 199
Strategy Library permissions 85
Substitute function 131
subtraction, in user-defined fields 127
SvrShare folder 35
synchronization

MaxExchange Synchronization Server 28
Microsoft Exchange, see MaxSync for Microsoft Exchange
opportunities and campaigns 112
Outlook Synchronization, see Microsoft Outlook

Synchronization
passwords 362

system
fields 111, 229
login accounts 72
options 112
reports 356
user-defined fields 120

system account authentication 102
System Field Privileges 89
system messages, displaying 253
system requirements 2–4

Maximizer CRM 2
MaxSync for Microsoft Exchange 3
Workflow Automation Powered by KnowledgeSync 4

SystemMessages.xml
elements 254

example 255

T

table user-defined fields 118
adding items 125

tables
MaConfig 376–377
user-defined field table prefixes 387

TAPI 186
called ID 186
configuring 188
exact phone number matching 188
phone number format 112
phone number matching 187
smart phone number matching 187

tasks
with MaxSync for Microsoft Exchange 167
with Outlook Synchronization 161

teams
report 357
sales and marketing 99

templates
customer service email notification 144
troubleshooting web access templates 367

testing
network connectivity 30
updates for Live Update 283

Text function 131
timeout value for sites 211
TLS. See transport layer security
transaction journalling 112
transferring

access rights required 86
Address Book entries 349–351
user-defined fields 126

transport layer security troubleshooting
SMTP servers 371

troubleshooting 359–374
automated campaigns 361
campaign tracking 364
campaigns 362, 364
changing a site to an application 199
Microsoft IIS 364
sites 367
Windows Authentication 360

TSPI 186
two-tier import 331–333
types of files in Maximizer 384

U

UniModemV 186
updating

Maximizer 287
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upgrading
Address Book 74
Maximizer 35

URLs for sites 241
User ID List report 356
user-defined fields 118–126

adding table items 125
customer service 110, 229
database tables and views 387
encrypted 118
folders 121
formula 127
Key Fields 140–143, 223
Maximizer Web Access Administrator 223
permissions 85
report 356
sort order 121
transferring 126
types 118
user access rights 119
verification and recovery 315

userdict.lex file 311
users

access rights and settings 84–85
access rights for sites 218
adding to Address Book 78
changing password 83
Crystal Reports access rights 107
Current Users report 358
current users report 62
Maximizer Web Access Administrator 232
modifying user access settings 90
permissions 85
preferences 106, 110
privileges 86
record ownership 98
security groups for sites 241
site security groups 215
system account authentication 102
system login accounts 72
user and group setup permissions 85
User ID List report 356
User’s Roles 88
user-defined field access 119

V

Value function 132
verify and recover Address Book 314
vertical templates 76
video resolution, system requirements 2

virtual directories in Microsoft IIS 12, 385

W

Web Access
Customer and Partner Access Administrator 240
customize graphic on main page 251
installing 38
overview 5

Web Access site settings 206
web access sites, enabling 197
web browsers

configuration for Wireless Access 238
system requirements 3
Wireless Access PDAs 238

web server
permissions 13

Web.Config 206
web.config 206, 211
WEBUSER account 72, 367
Windows Authentication 102, 360

MaConfig setting 360
users 102
Web Access 213

Windows Event Viewer 154, 372
Windows Registry 191
Windows Scheduler, for installation 294
Wireless 5
Wireless Access 195, 202

browsers 238
page size limits 239

Wireless Access Shortcuts
configuring 239

WNOTE (Maximizer.Data) 408
WordPerfect Office Integration 43, 56
Workflow Automation Powered by KnowledgeSync

installing 58
system requirements 4

workstation
CRM system requirements 2
Installed Workstations report 357
installing Maximizer 51
remote 53

X

XML files 326–329, 388

Y

Year function 135
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