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Welcome to MaxMobile Wireless Server

Introduction

MaxMobile Wireless Server is a MaxMobile add-on that supports
the wireless connectivity of Address Book information.

MaxMobile Wireless Server is installed and configured on a
Microsoft Internet Information Services (lIS) computer.

System Requirements
¢ Maximizer CRM 11 Entrepreneur or Team edition

e Processor Speed - 1.6 GHz (minimum) and 3 GHz
(recommended)

e Available RAM - 1 GB (minimum) and 2 GB (recommended)

e Operating system - Microsoft Windows XP, Vista, Windows 7,
2003, 2003 R2, 2008, 2008 R2 (updated to their latest service

packs) with Microsoft Internet Information Services (lIS).

Installing Microsoft Internet Information Services

Before you install MaxMobile Wireless Server, you need to install
Microsoft Internet Information Services (11S) and Maximizer CRM.

Note that during the following procedures, you may be
prompted for your Windows CD.

> To install 1IS on Windows XP
1. Select Start > Control Panel > Add/Remove Programs.

2. Select Add/Remove Windows Components, and select
Internet Information Services (l1S).

> To install 1IS on Windows Vista or Windows 7
1. Select Start > Control Panel > Programs and Features.

2. Select Turn Windows features on or off, and select
Internet Information Services and its sub-items, excluding
FTP Publishing Services.
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> To install 1IS on Windows 2003

1. Select Start > Control Panel > Add/Remove Programs.
2. Select Add/Remove Windows Components.

3. Select Application Server, and click Details.
4

. Select Internet Information Services (IIS).

Installing MaxMobile Wireless Server

As previously noted, before installing MaxMobile Wireless
Server, you must install Microsoft Internet Information Services
and Maximizer. Refer to the Maximizer CRM Administrator’s
Guide for information on installing Maximizer CRM.

> To install MaxMobile Wireless Server
1. Close any Maximizer applications running on the computer.

2. If you have a previous version of MaxMobile Wireless Server
installed, it is important to uninstall it before proceeding
with the installation.

3. Insert the MaxMobile Wireless Server installation CD into the
computer’s CD drive.

The setup starts automatically. If it doesn’t start, browse to
your CD drive and double-click the Autorun.exe file.

4. Click Install MaxMobile Wireless Server.
5. Follow the installation wizard on-screen instructions.

During the installation, you are prompted to specify the
website for the MaxMobile Wireless Server. You can click
Next to accept the default configuration.

If you choose to use an existing website, select the website
from the drop-down list.

If you choose to create a new website, enter the description,
TCP port, IP address, and Host Header value.
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Applying Licensing

e |In Administrator, choose Utilities > Install Multi-User
License, enter the Product License number, and click the
Install License button. Open the Address Books to which
you are applying licensing.

This applies your licensing for MaxMobile Wireless Server. By
default, a single license is available for use with MaxMobile
Wireless Server, so this step is necessary only if you are enabling
the software for more than one user.

MaxMobile Interface Customizations

You can customize components of MaxMobile such as menu item
names and field labels through a utility in the Maximizer CRM
Customization Suite. Interface customizations can then be
synchronized to the device.

For more information on how to set up customizations for
MaxMobile, refer to the Maximizer CRM Customization Suite
documentation. If you do not have the product, you can find
out more by clicking the Maximizer button and selecting

Help > Other Maximizer Products in Maximizer or by visiting the
Maximizer web site at www.maximizer.com.

Configuring MaxMobile Wireless Server

Once you have installed the software, you must configure your
wireless server.

Note that when specifying the server name in the following
steps, you can alternatively use a local computer name (if you
are using BES or Wi-Fi in an internal domain), a qualified domain
name, or an IP address (e.g., an external static IP). Contact your
Internet Service Provider for more information.

The port number is necessary in the following steps only if you
are using a port other than the default ports of 80 for http or
443 for https. You can also use the IP address in place of the
server name.
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> To configure the wireless server

1.

After installing MaxMobile Wireless Server, if you have

not yet opened the Address Book you will be accessing,

do so in Maximizer or Administrator. Opening the Address
Book creates the Data Source Name (DSN) for accessing the
database on the SQL server by IIS.

If the MaxMobile Wireless Server or the Maximizer database
server is behind a firewall, allow access through the firewall.

On the MaxMobile Wireless Server computer, add an
exception for the MaxMobile Wireless Server port (port 80
for http and 443 for https by default).

If MaxMobile Wireless Server and the Maximizer database
are on different computers, create an exception on the
Maximizer database computer to give the computer running
MaxMobile Wireless Server access to the database computer
through port 1433. Depending on its configuration, you may
need to perform additional steps to configure the firewall:

Open port 1434 to expose the SQL Server Browser service.

Create an exception for sqlservr.exe and sqlbrowser.exe to
allow the MAXIMIZER instance of SQL Server access through
the firewall.

. If the MaxMobile Wireless Server is behind a router,

configure the router to direct to the MaxMobile Wireless
Server computer.

If the server is a Windows 2003/2003 R2 server, ensure .NET
v2.0.xxx is allowed in IIS Web Service Extensions.

Enable the .NET Framework and activate the WCF
(Windows Communication Foundation) component by doing
the following:

In the Control Panel, open Programs and Features and
click on the Turn Windows features on or off option.
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If the server is a Windows 2008/2008 R2 server, click on
Features, click Add Features, select the Microsoft .NET
Framework feature, and select the WCF Activation and
HTTP Activation options.

If the server is running Windows Vista, expand Microsoft
.NET Framework 3.0, and select the Windows
Communication Foundation HTTP Activation option.

If the server is running Windows 7, expand Microsoft
.NET Framework 3.5.1, and select the Windows
Communication Foundation HTTP Activation option.

If the server is running Windows XP or 2003, this step is done
automatically by the installation and you can move to step 6.

Click OK.

. If you are installing MaxMobile on a 64-bit operating system,
you must perform some additional steps. Refer to Enabling
the Server on a 64-Bit Operating System section in this
guide for more information.

. Ensure MaxMobile Wireless Server is configured properly by
going to one of the following URLs depending on if you are
using a secure connection (https) or not:

http://[server_name]/MaxMobileService/mobile.svc
https:/[server_name]/MaxMobileService/mobile.svc

Note that the following message appears at the top of the
web page:

Metadata publishing for this service is disabled.

This message can be ignored—it does not indicate a
configuration error.

If you are running Windows XP and retrieving this URL fails,
it could be because ASP .NET is not registered. To register
ASP .NET, open the command prompt and enter the
following command:

[system drive]\WINDOWS\Microsoft. NET\Framework\
v2.0.50727\aspnet_regiis -i



Getting Started Guide 7

For example, if your system drive is drive C, you would enter:
C\WINDOWS\Microsoft.NET\Framework\v2.0.50727\aspnet_
regiis -i

8. In Administrator open the Address Book to use with
MaxMobile, and select File > MaxMobile Administration.
Note that you can also access this dialog box from Maximizer
if you have administrative privileges as a Maximizer user.

MaxMobile Administration |

VaxMable server
lrmaxMub\Ie server: [| ‘

- Maxtabie

Auwalable users: Users selected For deployment:

All Users User Name: “Wireless Deployment Date
Departments [ @ 308 Hapol

Divisions

5 Security Groups A
9 Teams
< Remove

Vouhave 1008 user lcense(s) for Mobile devices. Thereare — —i..p

TrEiaEe a3 016bie Wireless Deplsyiment
L el e et Hiaxtobie Wreless Desloyment. |

9. Enter the URL of MaxMobile Wireless Server. The URL should
be in the following format:

http://[server_name]:[port_number]l/maxmobileservice
https://[server_name]:[port_numberl/maxmobileservice

If you are deploying MaxMobile by email, the maximum
length of the URL is 64 characters.

If you are using a secure connection, you must also
uncomment the security mode setting in the MaxMobile
Wireless Server's web.config file as follows:

<security mode="Transport"/>
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Note that the web.config file is stored in the following
folder:

...\Maximizer\WebServices\MaxMobileServer

10.For each user, department, division, and security
group who will use MaxMobile, select the name from the
MaxMobile users list and click Add to move the item
to the Users selected for deployment list. This enables
MaxMobile for these users. Use the Remove button to
remove an item from this list.

Note that you can also enable MaxMobile for users in the
General tab of the Properties dialog box for a user.

Properties for Joe Napoli x|
Genersl | L ess Rights | Groups n
~MName and p
User ID: Mritds: st name: Iniial Last namet Salutation:
iaFOL] A E [apol [Dear < >
Display name: PBosition: Reports to:
[0z Hapon [Presire [ =
~Company and main adéress————— ~Phone numbers and phone extensions
Company: | Escona Estate Wines 1: [ (s55) 775-0082
Dept.: [Exective Divison: [ CAN - East 2 (s5%) 775-0000 [Fax
Ackess 1 1344 Eastside Road El| |
ackiress 2: [ | [
Gity[Ton: | Petaluma StiCofPry: [ CA Security
@ Publc  C Private
LD/Pnstde:I 94954 Country: | usA
Module Login
Internet windows Access Enabled
Emaiy [napoi@maxmzsr.com | ||Web Access Disabled
Mobile Enabled
Website: | hktp: ey escona, com
4l {§|
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Configuring MaxMobile for Deployment

Before you deploy MaxMobile, Internet Information Services
(11S) must be configured properly. Although the MaxMobile
Wireless Server installation should do this automatically,
these settings may be verified for installing/downloading
MaxMobile.

> To configure Internet Information Services (lIS)
1. Open lIS.

2. If you are using Windows Server 2003/2003 R2 or Windows
XP, open the properties for the MaxMobile Wireless Server
website (Default Web Site, by default) and on the HTTP
Headers tab, click on the File/MIME Types button.

If you are using Windows Server 2008/2008 R2, Windows
Vista, or Windows 7, open the MaxMobile Wireless Server
website (Default Web Site, by default), double-click on
MIME Types, and click Add.

3. Add the following registered file extension types:

Extension: cod
MIME type: application/vnd.rim.cod

Note that if the cod extension already exists, you must
change the MIME type to the value shown above.

Extension: jad
MIME type: text/vnd.sun.j2me.app-descriptor
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Deploying the MaxMobile Installation
You can deploy MaxMobile by email or through the web.

It is important to note that if a previous version of
MaxMobile was installed on the BlackBerry through a USB
connection, you must uninstall it before installing this
version of the software. Refer to the Uninstalling MaxMobile
section in the MaxMobile Getting Started Guide.

Deploying MaxMobile Through a Web Browser

If you are not deploying MaxMobile through email, users can
install MaxMobile through a web browser. After installing
MaxMobile, MaxMobile users must enter the URL of the
MaxMobile Wireless Server, as specified in the MaxMobile
Administration dialog box, to launch MaxMobile.

The port number is necessary in the following steps only if you
are using a port other than the default ports of 80 for http or
443 for https.

> To deploy MaxMobile through a web browser

1. On the device web browser, browse to one of the following
URLs depending on if you are using a secure connection
(https) or not:

http:/[server_name]:[port_number]/
MaxMobileService/bb.aspx

https://[server_name]:[port_numberl/
MaxMobileService/bb.aspx

2. Select Download and click the trackball.
3. Launch MaxMobile.

You are prompted for the URL of the MaxMobile Wireless
Server.

4. Enter the URL of the MaxMobile Wireless Server. The URL
should be in the following format:

http://[server_name]:[port_number]l/maxmobileservice

https://[server_name]:[port_number]l/maxmobileservice
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5. Grant the necessary permissions for MaxMobile. See the
Granting Permissions for MaxMobile section of this
manual for more information.

Deploying MaxMobile by Email

In order to deploy MaxMobile by email, an email client (for
example, Microsoft Outlook, Microsoft Outlook Express,
Microsoft Windows Mail, or Microsoft Live Mail) must be set up
and running on the computer sending the email message.

> To deploy the MaxMobile installation by email

1. For each MaxMobile user, select the user in the MaxMobile
Administration dialog box in Administrator, enable the
checkbox beside the user’s name, and click the Initiate
MaxMobile Wireless Deployment button.

This sends out an email to each of the selected users that
includes instructions on how to install MaxMobile. You can
send an email to more than one user at a time.

Note that if you use Microsoft Outlook, Outlook should be
running when you send the email message.

To customize the email, you must modify the
MaxMobileOTADeploymentTemplate.txt file found in the
MabDatab6 folder where you installed Maximizer.

2. Ensure users install MaxMobile by following the instructions
sent in the email. After receiving the email, users must
click on the link to the MaxMobile installation, download
the software, and grant the necessary permissions for
MaxMobile. See the Granting Permissions for MaxMobile
section for more information.
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Granting Permissions for MaxMobile

After downloading and installing MaxMobile, users must grant
the necessary permissions for MaxMobile as follows:

e If users are prompted with a Yes/No message when granting
permissions, they should choose Yes. If they receive a
message asking them to view the permission details, they
should click the View button, select the Menu key, and click
Save.

Connecting to the MaxMobile Wireless Server

Depending on the connection methods enabled on the device,
MaxMobile uses Wi-Fi or the Mobile Network to connect to the
MaxMobile Wireless Server. If both connection methods are
enabled and available, MaxMobile uses Wi-Fi.

For Mobile Network connections, MaxMobile first attempts to
connect to BES (BlackBerry Enterprise Server), followed by BIS-B
(BlackBerry Internet Service Browsing), then Direct TCP, and
lastly, WAP2. MaxMobile users may need to specify additional
settings on their devices for Direct TCP. These settings are
specified in Options > Advanced Options > TCP (or TCP/IP).
Contact your BlackBerry service provider for information on
the required settings. Users can also specify a custom order

of the connection type to be used in the Server dialog box in
MaxMobile. See the MaxMobile Getting Started Guide for more
information.

Enabling the Server on a 64-Bit Operating System

MaxMobile Wireless Server requires the 32-bit version of ASP.
NET 2.0 in order to run on a 64-bit operating system so you must
enable the application in IIS. The following procedures vary
depending on the operating system running IIS.

For Windows Server 2008, Windows 7, and Windows Vista

MaxMobile Wireless Server should run under an application pool
in Classic Pipeline mode that has 32-bit applications enabled.
If you do not need to run other applications on a 64-bit web
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server, you can specify these settings for the default application
pool (DefaultAppPool). If you need to use a 64-bit web server,
you can add a new application pool with these settings and run
MaxMobile Wireless Server under this application pool. You
can also run the application under the “Classic .NET AppPool”
application pool.

> To run applications in Classic .NET AppPool

1. In 1IS Manager, select the virtual directory for MaxMobile
Wireless Server.

2. Select Advanced Settings.

3. In the Application Pool field, select DefaultAppPool,
Classic .NET AppPool, or the application pool you created,
and click OK.

For Windows Server 2003 and Windows XP

You must enable the 32-bit version of ASP.NET 2.0 using the
command prompt.

> To enable the 32-bit version of ASP.NET 2.0

1. Open the Command Prompt (Start > Accessories > Command
Prompt).

2. Type the following command to enable the 32-bit mode:

cscript %SYSTEMDRIVE %\inetpub\adminscripts\adsutil.vbs
SET W3SVC/AppPools/Enable32bitAppOnWin64 1

3. Type the following command to install the 32-bit version of
ASP.NET 2.0, and the script maps at the IIS root:

%SYSTEMROOT%\Microsoft.NET\Framework\v2.0.50727\
aspnet_regiis.exe -i

On Windows Server 2003, make sure that the status of
ASP.NET version 2.0.50727 (32-bit) is set to Allowed in the
Web service extension list in Internet Information Services
Manager.
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Application Settings for MaxMobile

After you have deployed MaxMobile Wireless Server, you can
customize your application settings in the web.config file. The
web.config file is stored in the following folder:

...\Maximizer\WebServices\MaxMobileServer
Following is a list of the application settings and their descriptions:

<add key="SessionTimeoutMinutes” value="125" />
determines the length of time each session is available while activity
is idle.

<add key="MaximumRecords” value="2000" /> determines the
maximum number of records a search returns.

<add key="LogFile” value="" /> determines the location and file
name for the log information - i.e., <add key="LogFile” value="c:\
temp\MaxMobile.log” />.

<add key="LogLevel” value="0" /> determines the level of
logging— the value of 0 sets it to no logging and the value of 5 sets
it to full logging.

<add key="culture” value="fr-BE"” /> determines the display
settings for a culture other than English. The example shown above
is for Belgium - French. To use a different cultural setting, replace
the value of the culture.

<webHttpBinding> determines the size of documents that you

can download and upload. The default value is just under 4 MB
(4096000 bytes). To change this value you must modify the following
attributes:

maxBufferSize, maxReceivedMessageSize,
MaxStringContentLength

Additionally, note that in order to use HTTPS, you must uncomment
the following line in this section:

<security mode="Transport"/>
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