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C H A P T E R11Introduction

In this chapter...

“Configuration” on page 2

“Maximizer System Requirements” on page 3
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You cannot use Accounting 
Link with MaxExchange 
Remote Workstations.

Maximizer Accounting Link for Sage 50 Accounts enables you to 
create quotes, invoices, and purchase orders from within Maximizer, 
while simultaneously creating them in the Sage 50 Accounts 
database. Entering Sage 50 Accounts transactions through 
Maximizer also logs notes for the related Address Book entries.

For a current list of supported Sage 50 Accounts versions, refer to the 
Maximizer website at www.maximizer.com. 

This guide explains how to install, configure, and operate 
Accounting Link.

Configuration
Accounting Link for Sage 50 Accounts supports both local and 
remote configurations. The Sage 50 database can be located on any 
computer in the network, and it can be accessed by multiple 
Accounting Link users. Accounting Link must be installed on every 
computer using Accounting Link, and Sage 50 Accounts must be 
installed on at least one computer on the network. All Accounting 
Link users must have access to the Sage 50 Accounts COMPANY file 
and database.

Accounting Link for Sage 50 Accounts is designed so that one 
Maximizer Address Book connects to one Sage 50 database.

Before using Accounting Link, you must ensure that the following 
steps have been completed:

• Maximizer is installed.

• The Maximizer Address Book is configured.

• Sage 50 Accounts is installed.

• The Sage 50 Accounts database is set up.

• Accounting Link is installed. See “Installing Accounting Link” on 
page 6 for details.

• Accounting Link licenses are applied. See “Applying Accounting 
Link Licenses” on page 8 for details.

• Accounting Link users have Accounting Link enabled in their 
Maximizer user properties. See “Enabling Accounting Module 
Access” on page 10 for details.

• Accounting Link users have been added to the Accounting 
security group or have Accounting access rights enabled in their 
Maximizer user properties. See “Adding Users to the Accounting 
Security Group” on page 11 and “Granting Accounting 
Permissions” on page 12 for details.
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• Accounting Link is configured in Maximizer. See “Configuring 
Accounting Link for Sage 50 Accounts” on page 15 for details.

• Sage Data Objects are registered. See “Registering Sage Data 
Objects” on page 17 for details.

Multi-User Environment

If you work in a multi-user environment, you must also ensure the 
following:

• The Sage 50 Accounts COMPANY file is stored in a shared folder 
that is accessible to all computers where Accounting Link is 
installed.

• The Sage 50 Accounts database is accessible to all Accounting 
LInk users, and the database directory is shared.

• The Sage 50 Accounts database is set up using a UNC file path. 
See “Creating Company Entries with UNC File Paths” on page 14 
for details.

Maximizer System Requirements
The hardware and software requirements for Accounting Link 
installation are listed in the following table. Please refer to the 
Maximizer website at www.maximizer.com for updated information.

These are the minimum system requirements for Maximizer, and 
your operating system may have higher requirements for some 
components, such as processor speed and RAM.

Maximizer Version Maximizer CRM 11 (Workstation or Server)

Minimum Processor Speed 800 MHz (minimum)
1.6 GHz (recommended)

Available RAM 512 MB (minimum)
1 GB (recommended)

Operating System Microsoft Windows Vista, XP, or 2003 Server (updated to their latest 
service packs)
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Accounting Link

In this chapter...

“Installing Accounting Link” on page 6

“Applying Accounting Link Licenses” on page 8
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Installing Accounting Link
Maximizer must be installed before you can install Accounting Link. 
Install Accounting Link software on all computers that will connect to 
Sage 50 Accounts through Maximizer.

➤ To install Maximizer Accounting Link for Sage 50 
Accounts

� Insert the Maximizer Accounting Link for Sage 50 Accounts disc.

If the setup doesn’t start 
automatically, you can start it 
manually by running 
autorun.exe from the disc.

The installation wizard runs automatically.

� Select Install Accounting Link for Sage 50 Accounts.

The InstallShield Wizard starts.

� Click Next.

� Read the License Agreement, and click Yes.

� Enter your Name, Company, and Product Serial Number. 
Then, click Next.
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� Select the version of Sage 50 Accounts that you want Accounting 
Link to connect to.

� Click Next to begin the installation.

	 Click Finish.

Maximizer Accounting Link for Sage 50 Accounts is now 
installed. 
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Applying Accounting Link Licenses
After you have installed Accounting Link, install and apply your 
Accounting Link Product License Number (PLN), as described in your 
Maximizer Administrator documentation and online help. 

Note that Accounting Link includes a license for one user in addition 
to the MASTER user.
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Rights to Maximizer

Users

In this chapter...

“Enabling Accounting Module Access” on page 10

“Adding Users to the Accounting Security Group” on page 11

“Granting Accounting Permissions” on page 12
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Enabling Accounting Module Access
After installing Accounting Link licenses, you can set user access in 
the Module Login list in user properties. Users must have Accounting 
module access enabled before they can use Accounting Link in 
Maximizer.

➤ To enable accounting module access for a user

� Log in to the Address Book in Administrator.

� Select File > Manage Users.

� Select the user to grant accounting privileges, and click 
Properties.

� In the Module Login section of the General tab, set the 
Accounting module to Enabled.

� Click OK.

Repeat this procedure for all users who will be using Accounting 
Link.
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Adding Users to the Accounting Security Group

For more information about 
user and group security, refer 
to your Maximizer 
Administrator documentation.

The Accounting security group enables users to restrict accounting 
transaction notes to members of this group. If an Accounting Link 
user is not a member of the Accounting security group, notes for any 
accounting transactions created by that user are Public. However, 
notes for transactions created by members of the Accounting group 
are restricted to members of that group.

You can add multiple users to 
the security group by selecting 
File > Security Groups and 
Teams, selecting the 
Accounting security group and 
clicking Properties, clicking the 
Members tab, and then adding 
users to the group.

➤ To add a user to the Accounting security group

� Log in to the Address Book in Administrator.

� Select File > Manage Users.

� Select the user to grant accounting privileges, and click 
Properties.

� Click the Groups/Teams tab.

� Select the Accounting security group from the Available 
groups and teams list, and click Add. 

The Accounting security group now appears in the Member of 
list.

� Click OK.

Repeat this procedure for all users who will be using Accounting 
Link.
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Granting Accounting Permissions
Accounting permissions control whether users can read, insert, or 
modify accounting transactions. 

For more information about 
user and group security, refer 
to your Maximizer 
Administrator documentation.

➤ To grant accounting permissions to a user

� Log into the Address Book in Administrator.

� Select File > Manage Users.

� Select the user to grant accounting privileges, and click 
Properties.

� Click the Access Rights tab.

� Click the Modify User Access Settings button.

The Delete permission for 
Accounting is disabled 
because Accounting Link 
cannot delete transactions 
from the accounting database.

� In the Permissions group, select any of the Accounting rights, 
as appropriate for the user, and click OK.

� Click OK to close the user properties dialog box.

Repeat this procedure for all users who will be using Accounting 
Link.
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In this chapter...

“Creating Company Entries with UNC File Paths” on page 14

“Configuring Accounting Link for Sage 50 Accounts” on page 15

“Registering Sage Data Objects” on page 17
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Creating Company Entries with UNC File Paths
If you are using Accounting Link in a multi-user environment, you 
must ensure that the Sage 50 Accounts database is set up using the 
UNC file path. You can create a new company list entry in Sage 50 
Accounts pointing to any existing Sage 50 database.

➤ To create a new company entry in Sage 50 Accounts

� Start Sage 50 Accounts.

� When the Select Company dialog box opens, click Add 
Company.

� Enter the UNC file path to the existing Sage 50 Accounts 
COMPANY file.

� Click OK.

When you configure Accounting Link in Maximizer, you must select 
this entry in the Company Selection dialog box. See “Configuring 
Accounting Link for Sage 50 Accounts” on page 15 for details.
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Configuring Accounting Link for Sage 50 Accounts
After installing Accounting Link, the Sage 50 Accounts Integration 
Setup dialog box opens the next time you start Maximizer. You must 
specify the path to the Sage 50 Accounts COMPANY file and the 
login credentials and location of the database. You can also access 
the Accounting Link configuration at any other time from the 
Maximizer Preferences.

➤ To configure Accounting Link

� Open Maximizer.

� On the Setup tab, select Preferences, and click Accounting 
Setup.

The Sage 50 Accounts Integration Setup dialog box opens.

If you are running Maximizer for the first time after installing 
Accounting Link, the Sage 50 Accounts Integration Setup dialog 
box opens when you first start Maximizer.

� Select the Enable Sage 50 Accounts integration checkbox.

The Sage 50 COMPANY file 
must be stored in a folder that 
is accessible to all Accounting 
Link users.

� Click the ellipsis button next to the Path field, browse to and 
select the Sage 50 COMPANY file, and click Open.

� In the Login and Password boxes, specify your login credentials 
for the Sage 50 database.

� Click Database, choose the UNC file path to the Sage 50 
database, and click OK.

The Data Path field displays the path to the database.

� Click Initialize to connect to the database.

The Company Name field displays the Sage 50 company for the 
selected database.
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In Sage 50 Accounts, you can 
find the “Convert quotes to” 
setting in the General tab of 
the Invoice/Order Defaults 
dialog box.

	 In the Convert quotes to drop-down list, select the same 
option that is specified in your Sage 50 Accounts settings.


 Click OK.

�
�

�

�

	

�
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Registering Sage Data Objects
Accounting Link installs and uses Sage Data Objects (SDO) to read the 
Sage 50 Accounts database. To use Accounting Link, all users must 
have the SDO registered on their computers. To register SDO, you 
must first obtain a serial number and an activation key from Sage 
Software.

If Accounting Link is installed on a computer where Sage 50 Accounts 
is installed, you can register SDO from the Sage 50 Accounts 
program. If Accounting Link is running on a computer where Sage 50 
Accounts is not installed, you must register SDO from within 
Maximizer.

➤ To register SDO from Maximizer

� On the Setup tab, select Preferences, and click Accounting 
Setup. Then, in the Sage 50 Accounts Integration Setup dialog 
box, click Register.

– or –

If SDO is expired on the computer, click OK when you are 
prompted to register SDO. You should be prompted to register 
SDO when you start Maximizer.

The Register Sage Data Objects dialog box opens. If you are 
running Accounting Link on a computer where SDO is expired, 
you are taken directly to this dialog box after you are prompted 
to register.

� Enter the Serial number and the Activation key.

� Click Register. 

A message should appear indicating that SDO is registered.
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In this chapter...

“Connecting to Sage 50 Accounts with Maximizer” on page 20

“Linking Address Book Entries” on page 21

“Creating Invoices, Quotes, and Purchase Orders” on page 25

“Viewing Invoices, Quotes, and Purchase Orders” on page 30

“Viewing Accounting Details about a Customer or Supplier” on page 33
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Connecting to Sage 50 Accounts with Maximizer
It’s important that Accounting Link and Maximizer are configured 
correctly before proceeding. Otherwise, the procedures outlined in 
this chapter will not work properly. 

When Accounting Link is successfully installed and configured, you 
can access Accounting Link transactions and commands from the 
Address Book window in the following ways:

• View transactions for the selected Address Book entry in the 
Accounting following window.

• Access accounting commands from the Accounting icon on the 
Edit and View tabs or from the right-click menu in the 
Accounting following window.     
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Linking Address Book Entries  
If you re-link a Company file to 

a different Address Book, all of 
your Address Book entries 
must also be re-linked.

Before you can create any invoices, quotes, or purchase orders in 
Maximizer, you must create a link between each Maximizer Address 
Book entry and Sage 50 Accounts customer or supplier. 

• If the customer or supplier record does not exist in the Sage 50 
database, you can create the Accounting Link record from 
Maximizer using an existing Maximizer Address Book entry. 

• If the customer or supplier record does exist in the Sage 50 
database, Maximizer creates a connection between the records. 

After you have linked an Address Book entry, you can create and 
view Sage 50 invoices, quotes, and purchase orders from within 
Maximizer.

➤ To link an Address Book entry to Sage 50 Accounts

� Open your Maximizer Address Book.

� Select the Company or Individual to link with Sage 50 
Accounts.

� In Maximizer, select the Accounting following window.

� On the Edit tab, select Accounting > Link to Sage 50 
Customer/Supplier. 

Alternatively, you can choose the command by right-clicking in 
the Accounting following window. 

You can expand your search by 
entering only the first few 
letters of the Company or 
Individual name in the Name 
field.

� Click Search to display a list of matching customers and/or 
suppliers. 
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� If a matching entry appears in the list, select the entry and click 
OK to link the Address Book entry with the customer/supplier.

The records are linked, and you can create purchase orders 
(suppliers) or invoices and quotes (customers) for that Company 
or Individual. You may skip the remainder of this procedure. 

– or –

The OK button is disabled until 
you select a Sage 50 Accounts 
record from the list of search 
results.

If a matching entry does not appear in the list, click New. 

The Add Accounting Customer/Supplier dialog box opens. 
Maximizer automatically fills in any existing contact information. 

� Select the Customer option to create the Address Book entry as 
a customer in Sage 50 Accounts. (You can create invoices and 
quotes for customers.)

– or –

Select the Supplier option to create the Address Book entry as a 
supplier in Sage 50 Accounts. (You can create purchase orders for 
suppliers.)
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If you know the entry does not 
exist in your Company 
database, you can select 
Create Sage 50 Customer/
Supplier from the Accounting 
icon on the Edit tab in 
Maximizer while the Address 
Book entry is selected.

	 Enter an A/C Ref and VAT Number such as you would in Sage 50 
and click OK. These identifiers are controlled manually in this 
dialog box.

Maximizer and Sage 50 Accounts now share a connection 
between these records. 
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Creating Address Book Entries from Customers and Suppliers 

You can create new Maximizer Address Book entries from existing 
Sage 50 Accounts customers and suppliers. New entries are 
automatically linked to the customers and suppliers.

➤ To create an Address Book entry from a customer or 
supplier

� Select the Accounting following window.

� On the Edit tab, select Accounting > Create New Address 
Book Entry from Sage 50 Customer/Supplier.

The Create Maximizer Address Book Entry dialog box opens.

� Enter the name of the customer or supplier, or leave the Name 
field empty to view all customers and suppliers. Click Search. 

All matching customers and suppliers are retrieved.

� Select the customer/supplier that you want to create the entry 
for.

� In the Options area, choose the type of Address Book entry that 
you want to create. You can also click Field Mappings to 
choose the Maximizer fields that some of the Sage 50 Accounts 
fields are mapped to.

� Click OK.    

The new Address Book entry is created with the data from the 
Sage 50 Accounts customer or supplier. You can specify 
additional details in the Address Book entry.
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Creating Invoices, Quotes, and Purchase Orders 
You can create invoices, quotes, and purchase orders in Maximizer, 
and they will automatically be created in Sage 50 Accounts as well. 
Before you can create any of these transactions, the Company or 
Individual must be linked to either a customer or supplier record in 
Sage 50 Accounts:

• To create an invoice or quote, the Address Book entry must be 
linked to a customer record.

• To create a purchase order, the Address Book entry must be 
linked to a supplier record.

You can also create new transactions based on existing transactions, 
and create invoices based on quotes. Maximizer copies the 
information from the original transaction into a new transaction and 
enables you to modify the new transaction before saving it. Details 
on these procedures are provided further along in this section.

Each time an invoice, a quote, or a purchase order is created or 
modified, a note is logged in Maximizer. 

➤ To create an invoice, quote, or purchase order

� In Maximizer, open the Address Book and select the Company 
or Individual to create a transaction for.

Ensure that the Address Book entry is linked to a Sage 50 record. 
If it isn’t, refer to “Linking Address Book Entries” on page 21 
before proceeding with this procedure.

These menu items are also 
available from the Accounting 
icon in the Edit tab.

� In the Accounting following window, right-click and select 
Add > Invoice/Quote/Purchase Order.  

The Invoice, Quote, or Purchase Order dialog box opens. 
Maximizer automatically fills in the customer or supplier name 
and address, the date, and any tax information. 

If you are creating an invoice or quote, you have the option of 
creating a product or service transaction. In the Format or Type 
drop-down list, select the type of invoice or quote. 
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� In the Product Code or Details column, click on New.

? For detailed information about 
any of these fields, select the 
dialog box, and press F1.

� In the Add New Item dialog box, select the Product Code for 
the item from the drop-down list, or enter a description of the 
service.

� Add or change any of the other information in the Add New 
Item dialog box. 

You can change the tax code, the quantity, and apply a discount 
to the item: 

• To apply a percentage discount, specify the percentage in the 
Discount % box.

• To apply a fixed discount, specify the amount in the 
Discount box.  

When you are finished, click OK.
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� Repeat the last three steps until all required items have been 
added to the transaction.

You can specify deductions for 
only quotes and invoices.

� To apply a discount to the entire quote or invoice, click the 
ellipsis button next to Deduction. Specify the details of the 
discount, and click OK.

You can specify a percentage or fixed discount:

• To specify a percentage discount, enter the percentage in the 
Discount % box.

• To specify a fixed discount, enter the amount in the Disc. 
box.

	 Specify any remaining details for the transaction.

• Click Order Details to specify a delivery address and notes to 
accompany the transaction.

• Click Footer Details to specify any carriage costs and 
settlement terms for the transaction. 


 Click OK.

The transaction has now been created in both Maximizer and 
Sage 50 Accounts, and Maximizer creates a history note in the 
Notes window of the Address Book entry. You can also view the 
invoice, quote, or purchase order from the Accounting tab of the 
Maximizer Address Book following window, as described on 
page 30.
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Creating a New Transaction Based on an Existing One

Accounting Link enables you to create a new transaction (invoice, 
quote, or purchase order) based on an existing transaction, so the 
newly created transaction automatically contains the information 
from the original transaction, which you can then modify as 
required. This method saves you time because it reduces the amount 
of information you need to enter for similar transactions.

➤ To create a new transaction based on an existing 
transaction

� In Maximizer, open the Address Book and select the Company 
or Individual for whom to create an invoice, quote, or purchase 
order.

� Open the Accounting following window, and select the invoice, 
quote, or purchase order to use as the basis for the new 
transaction.

� On the Edit tab, select Accounting > Create New Sage 50 
Transaction from Selected.

– or –

Right-click in the Accounting following window, and select 
Add > Create New Sage 50 Transaction from Selected.

The Invoice, Quote, or Purchase Order dialog box opens, 
depending on the original transaction. Maximizer automatically 
fills in all the information from the original transaction.

� Change any of the information in the transaction, or add more 
items to the list, as required. 

To remove an item, right-click on it and select Delete from the 
shortcut menu.

� Click OK.

The transaction has now been created in both Maximizer and 
Sage 50 Accounts, and Maximizer creates a history note in the 
Notes window of the Address Book entry. You can also view the 
invoice, quote, or purchase order from the Accounting following 
window, as described on page 30.
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Creating an Invoice from a Quote

Accounting Link enables you to create a new invoice based on an 
existing quote, so the newly created invoice automatically contains 
the information from the original quote, which you can then modify 
as required. Making changes to the invoice does not apply those 
changes to the quote.

➤ To create a new invoice based on an existing quote

� In Maximizer, open the Address Book and select the Company 
or Individual for whom to create an invoice.

� Open the Accounting following window, and select the quote 
to use as the basis for the new transaction.

� On the Edit tab, select Accounting > Create Invoice from 
Selected.

– or –

Right-click in the Accounting following window, and select 
Add > Create Invoice from Selected.

The Invoice dialog box opens. Maximizer automatically fills in all 
the information from the original quote.

� Change any of the information in the transaction, or add more 
items to the list, as required. 

To remove an item, right-click on it and select Delete from the 
shortcut menu.

� Click OK.

The invoice has now been created in both Maximizer and Sage 
50 Accounts, and Maximizer creates a history note in the Notes 
window of the Address Book entry. You can also view the 
invoice from the Accounting following window, as described in 
the following section.
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Viewing Invoices, Quotes, and Purchase Orders 
You can view existing invoices, quotes, and/or purchase orders for a 
customer or supplier from within Maximizer, even if the transaction 
was not created in Maximizer. When you link a Maximizer Address 
Book entry to a customer or supplier, existing invoices, quotes, or 
purchase orders display in Maximizer automatically. 

You can view existing transactions in the Accounting tab of the 
Maximizer Address Book following window.

➤ To view an invoice, quote, or purchase order

� In Maximizer, open the Address Book and select the Company or 
Individual for whom to view a transaction.

� Select the Accounting following window.

� Open the Filter drop-down list, and select Invoices, Quotes, 
Purchase Orders, or All Transactions

The transactions of that type for the selected customer or 
supplier appear. You can double-click any item to view the 
details. 
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Searching for Invoices, Quotes, and Purchase Orders 

You can search your accounting application for invoices, quotes, and 
purchase orders and then view the transactions in Maximizer. If the 
transaction’s customer or supplier is not linked to an Address Book 
entry, you can also create a new Address Book entry at the same 
time.

You can search for all types of transactions by transaction number or 
reference number. 

➤ To search for invoices, quotes, and purchase orders

� Open the Accounting following window.

� On the Edit tab, select Accounting > Search for Transaction.

– or –

Right-click in the Accounting following window, and select 
Add > Search for Transaction.

The Search for a Transaction dialog box opens.

� In the Options area, specify the search criteria for the 
transaction.

The transaction number is the unique identifier for the 
transaction while the reference number is an optional user-
defined number.

� To open the transaction automatically after the search, select the 
Open found transaction checkbox. Otherwise, the search 
returns all transactions for the Address Book entry.

� In the Find matching area, specify the types of transactions that 
you want to search for.  

� Click OK.

If the customer or supplier for the matching transaction is not 
linked to an Address Book entry, you are prompted to create a 
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new Address Book entry from the customer or supplier. See 
“Creating Address Book Entries from Customers and Suppliers” 
on page 24 for details.

� If multiple transactions are found, select the transaction from 
the list of matching transactions.

The Address Book entry that is linked to the transaction is 
selected, and the transaction is listed in the Accounting 
following window.
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Viewing Accounting Details about a Customer or Supplier   
Maximizer enables you to view the following accounting details 
about a customer or supplier from within Maximizer:

• customer balance

• aged analysis (30-, 60-, or 90-day balances)

• credit limit

• remaining available credit

➤ To view Sage 50 accounting details

� In Maximizer, open the Address Book and select the Company or 
Individual for whom you want to view accounting details.

� Select the Accounting following window.

This menu item is also 
available from the shortcut 
menu in the Accounting 
following window.

� On the Edit tab, select Accounting > View Customer/
Supplier Information.

The Customer/Supplier Information dialog box opens. It contains 
the accounting details for the selected Company or Individual.

� View the accounting details in the dialog box.

� Click Close.
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