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C H A P T E R11Introduction

In this chapter...

“Configuration” on page 2

“Maximizer System Requirements” on page 2
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You cannot use Accounting 
Link with MaxExchange 
Remote Workstations.

Maximizer Accounting Link for Microsoft Dynamics™ GP enables you 
to create quotes, invoices, and purchase orders from within 
Maximizer, while simultaneously creating them in the Dynamics GP 
database. Entering Dynamics GP transactions through Maximizer also 
logs a note for the related Address Book entry.

For a current list of supported Dynamics GP versions, refer to the 
Maximizer website at www.maximizer.com. 

This guide explains how to install, configure, and operate 
Accounting Link.

Configuration
In a typical client/server configuration, the client connects to the 
Dynamics GP database on the SQL server. In this environment, 
multiple Maximizer machines can connect to the same Dynamics GP 
server. This configuration requires Dynamics GP to be installed on the 
Dynamics GP application machine. The Installation chapter explains 
how to install this software. 

Maximizer System Requirements
The hardware and software requirements for Accounting Link 
installation are listed in the following table. Please refer to the 
Maximizer website at www.maximizer.com for updated information.

These are the minimum system requirements for Maximizer. Your 
operating system may have higher requirements for some 
components, such as processor speed and RAM.

Maximizer Version Maximizer CRM 11 (Workstation or Server)

Minimum Processor Speed 800 MHz (minimum)
1.6 GHz (recommended)

Available RAM 512 MB (minimum)
1 GB (recommended)

Operating System Microsoft Windows Vista, XP, or 2003 Server (updated to their latest 
service packs)



C H A P T E R22Installing
Accounting Link

In this chapter...

“Pre-Installation Steps for Accounting Link” on page 4

“Installing Accounting Link” on page 8
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Pre-Installation Steps for Accounting Link
Before installing Accounting Link for Microsoft Dynamics GP, the 
following pre-installation steps must be performed:

� Create a COM+ user account.

� Enable Distributed Transaction Coordinator (DTC) and Microsoft 
Message Queueing (MSMQ).

� Set up functional currency.

� Install eConnect Business Objects into company.

The following sections explain each of these steps in greater detail.

Creating a COM+ User Account

Accounting Link uses a COM+ user account to communicate with the 
Microsoft Dynamics GP company file. 

A COM+ user account is a Windows User account that is in the 
Distributed COM Users group. Your network administrator should 
create this account.

If Accounting Link is installed on a computer that is in a domain, the 
COM+ user account must be a domain user account. 

If Accounting Link is installed on a different computer than the 
Dynamics GP server in a workgroup environment, create the COM+ 
user account on the Dynamics GP server.

Accounting Link prompts for the COM+ user account during 
installation.
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Ensuring the COM+ Account is Part of the DynGroup Role

Your SQL Server administrator must ensure that the COM+ user 
account is part of the DynGroup role for the following databases:

• The Microsoft Dynamics GP Company database that Accounting 
Link will connect to.

• The DYNAMICS database.

Enabling DTC and MSMQ

Your network administrator must enable Distributed Transaction 
Coordinator (DTC) and Microsoft Message Queueing (MSMQ) in the 
following places:

• The Microsoft Dynamics GP server.

• Each workstation that Accounting Link is installed on.

You can install eConnect before enabling MSMQ, but the eConnect 
services will not start until MSMQ is available.

DTC requires configuration. For more information about DTC and 
MSMQ, see Microsoft Windows documentation.

Setting Up Functional Currency

Your Microsoft Dynamics GP administrator must set up functional 
currency for each Microsoft Dynamics GP company file that 
Accounting Link will be connecting to. For information on currency 
setup and multicurrency access, see the Microsoft Dynamics GP 
documentation.
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Installing eConnect Business Objects into Company

Your network or SQL Server administrator must install eConnect 
Business Objects in the Dynamics GP company from the SQL Server 
computer where the Microsoft Dynamics company (database) is 
located. This step must be performed only once.

➤ To install eConnect Business Objects into the 
Dynamics GP company

� Insert the Maximizer Accounting Link for Microsoft Dynamics GP 
disc.

The installation wizard runs automatically.

� Select Install eConnect Business Objects (SQL Procedures) 
into Company. 

Follow the general instructions in the InstallShield wizard.

� On the Setup Type screen, select Custom.

� In the Custom Setup screen, ensure the Business Objects, 
COM+ Components, and eConnect Outgoing Service 
features are selected.

� On the Microsoft OLE DB Provider for SQL Server screen, 
click the ellipsis button, then enter the server name. 

� Select Use Windows NT Integrated security to use Windows 
Authentication for your domain.

� Select Select the database on the server and choose the 
Microsoft Dynamics GP company (database). 

Accounting Link will connect to this database.
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	 Click Test Connection to confirm proper eConnection 
communication and click OK.


 Follow the remaining instructions to finish the installation.
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Installing Accounting Link
Maximizer must be installed before you can install Accounting Link. 
Install Accounting Link software on all computers that will connect to 
Dynamics GP through Maximizer.

If you are installing Accounting Link on a computer running 
Microsoft Windows Vista, you should follow some additional steps 
after installing Accounting LInk. See “Installing Accounting Link on 
Windows Vista” on page 10 for details.

➤ To install Maximizer Accounting Link for Microsoft 
Dynamics GP

� Insert the Maximizer Accounting Link for Microsoft Dynamics GP 
disc.

If the setup doesn’t start 
automatically, you can start it 
manually by running 
autorun.exe from the  disc.

The installation wizard runs automatically.

� Select Install Accounting Link for Microsoft Dynamics GP.

The InstallShield Wizard starts.

� Click Next.

� Read the License Agreement, and click Yes.

� Enter your Product Serial Number, First Name, Last Name, 
and Company, and click Next.
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� Enter the Windows login credentials for the domain user to 
connect through eConnect to the Dynamics GP server (SQL 
server).

If you are installing Accounting Link in a workgroup 
environment, leave the Domain field blank.

� Enter the SQL login creditials for Accounting Link to connect to 
the Dynamics GP server.
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	 Click Next to begin the installation.

The wizard displays an installation progress indicator. 

Installing Accounting Link on Windows Vista

After installing Accounting Link for Microsoft Dynamics GP on a 
computer running Windows Vista, you need to follow some 
additional steps:

� Enable Distributed Transaction Coordinator (DTC) access.

� Allow DTC through the Windows firewall.

� Restart DTC service.

� Restart the Microsoft SQL Server computer.

See Microsoft Windows documentation for information on any of 
these steps.



C H A P T E R33Configuring the
Accounting Link for

Remote Operation

In this chapter...

“Setting Accounting Link Preferences” on page 12
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Setting Accounting Link Preferences
After you have installed Accounting Link, the first time you start 
Maximizer, the Integration Setup dialog box appears. Enter the 
information as described in the following steps. 

� In Maximizer, on the Setup tab, select Preferences, and click 
the Accounting Setup button.

� Select the Enable Microsoft Dynamics GP Integration 
checkbox.

� Select the SQL server that is hosting the Dynamics GP database.

� Select the type of Authentication you are using.

� Enter the User name and password for the selected SQL server 
and click the Connect button. This connects to the SQL server 
and a list of available databases appears in the Database name 
field.

� Once you have successfully connected to the SQL server, select 
the database you are using with Accounting Link from the 
Database name field and click the Initialize button. Clicking 
this button verifies you have chosen a valid Dynamics GP 
database for integration with Accounting Link. 

The next time you start Maximizer, Accounting Link will connect 
to the selected Dynamics GP database. If you modify the 
integration information, restart Maximizer to initialize the 
changes. 

For instructions on using Accounting Link, refer to “Using 
Accounting Link” on page 17.



C H A P T E R44Providing Accounting
Rights to Maximizer

Users

In this chapter...

“Enabling Accounting Module Access” on page 14

“Adding Users to the Accounting Security Group” on page 15

“Granting Accounting Permissions” on page 16



Maximizer CRM 11 Accounting Link
User’s Guide

14

Enabling Accounting Module Access
After installing Accounting Link licenses, you can set user access in 
the Module Login list in user properties. Users must have Accounting 
module access enabled before they can use Accounting Link in 
Maximizer.

➤ To enable accounting module access for a user

� Log in to the Address Book in Administrator.

� Select File > Manage Users.

� Select the user to grant accounting privileges, and click 
Properties.

� In the Module Login section of the General tab, set the 
Accounting module to Enabled.   

� Click OK.

Repeat this procedure for all users who will be using Accounting 
Link.
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Adding Users to the Accounting Security Group

For more information about 
user and group security, refer 
to your Maximizer 
Administrator documentation.

The Accounting security group enables users to restrict accounting 
transaction notes to members of this group. If an Accounting Link 
user is not a member of the Accounting security group, notes for any 
accounting transactions created by that user are Public. However, 
notes for transactions created by members of the Accounting group 
are restricted to members of that group.

You can add multiple users to 
the security group by selecting 
File > Security Groups and 
Teams, selecting the 
Accounting security group and 
clicking Properties, clicking the 
Members tab, and then adding 
users to the group.

➤ To add a user to the Accounting security group

� Log in to the Address Book in Administrator.

� Select File > Manage Users.

� Select the user to grant accounting privileges, and click 
Properties.

� Click the Groups/Teams tab.

� Select the Accounting security group from the Available 
groups and teams list, and click Add. 

The Accounting security group now appears in the Member of 
list.

� Click OK.

Repeat this procedure for all users who will be using Accounting 
Link.
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Granting Accounting Permissions
Accounting permissions control whether users can read, insert, or 
modify accounting transactions. 

For more information about 
user and group security, refer 
to your Maximizer 
Administrator documentation.

➤ To grant accounting permissions to a user

� Log into the Address Book in Administrator.

� Select File > Manage Users.

� Select the user to grant accounting privileges, and click 
Properties.

� Click the Access Rights tab.

� Click the Modify User Access Settings button.

The Delete permission for 
Accounting is disabled 
because Accounting Link 
cannot delete transactions 
from the accounting database.

� In the Permissions group, select any of the Accounting rights, 
as appropriate for the user, and click OK.

� Click OK to close the user properties dialog box.

Repeat this procedure for all users who will be using Accounting 
Link.
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In this chapter...

“Connecting to Dynamics GP with Maximizer” on page 18

“Linking Address Book Entries” on page 19

“Creating Invoices, Quotes, and Purchase Orders” on page 23

“Viewing Invoices, Quotes, and Purchase Orders” on page 27

“Viewing Accounting Details about a Customer or Vendor” on page 30
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Connecting to Dynamics GP with Maximizer
It’s important that Accounting Link and Maximizer are configured 
correctly before proceeding. Otherwise, the procedures outlined in 
this chapter will not work properly. 

When Accounting Link is successfully installed and configured, you 
can access Accounting Link transactions and commands from the 
Address Book window in the following ways:

• View transactions for the selected Address Book entry in the 
Accounting following window.

• Access accounting commands from the Accounting icon on the 
Edit and View tabs or from the right-click menu in the 
Accounting following window.   
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Linking Address Book Entries    
If you re-link a Company file to 

a different Address Book, all of 
your Address Book entries 
must also be re-linked.

Before you can create any invoices, quotes, or purchase orders in 
Maximizer, you must create a link between each Maximizer Address 
Book entry and Microsoft Dynamics GP customer or vendor. 

• If the customer or vendor record does not exist in the Dynamics 
GP database, you can create the Accounting Link record from 
Maximizer using an existing Maximizer Address Book entry. 

• If the customer or vendor record does exist in the Dynamics GP 
database, Maximizer creates a connection between the records. 

After you have linked an Address Book entry, you can create and 
view Dynamics GP invoices, quotes, and purchase orders from within 
Maximizer.

➤ To link an Address Book entry to Dynamics GP

� Open your Maximizer Address Book.

� Select the Company or Individual to link with Dynamics GP.

� In Maximizer, select the Accounting following window.

� On the Edit tab, select Accounting > Link to Dynamics GP 
Customer/Vendor. 

Alternatively, you can choose the command by right-clicking in 
the Accounting following window.  

You can expand your search by 
entering only the first few 
letters of the Company or 
Individual name in the Name 
field.

� Click Search to display a list of matching customers and/or 
vendors. 
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� If a matching entry appears in the list, select the entry and click 
OK to link the Address Book entry with the customer/vendor.

The records are linked, and you can create purchase orders 
(vendors) or invoices and quotes (customers) for that Company 
or Individual. You may skip the remainder of this procedure. 

– or –

The OK button is disabled until 
you select a Dynamics GP 
record from the list of search 
results.

If a matching entry does not appear in the list, click New.   

The Add Accounting Customer/Vendor dialog box opens. 
Maximizer automatically fills in any existing contact information.  

� Select the Customer option to create the Address Book entry as 
a customer in Dynamics GP. (You can create invoices and quotes 
for customers.)

– or –

Select the Vendor option to create the Address Book entry as a 
vendor in Dynamics GP. (You can create purchase orders for 
vendors.)
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If you know the entry does not 
exist in your Company 
database, you can select 
Create Dynamics GP Customer/
Vendor from the Accounting 
icon on the Edit tab in 
Maximizer while the Address 
Book entry is selected.

	 Enter a Cust/Vendor ID and Address ID such as you would in 
Dynamics GP and click OK. These identifiers are controlled 
manually in this dialog box.

Maximizer and Dynamics GP now share a connection between 
these records.  
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Creating Address Book Entries from Customers and Vendors 

You can create new Maximizer Address Book entries from existing 
Dynamics GP customers and vendors. New entries are automatically 
linked to the customers and vendors.

➤ To create an Address Book entry from a customer or 
vendor

� Select the Accounting following window.

� On the Edit tab, select Accounting > Create New Address 
Book Entry from Dynamics GP Customer/Vendor.

The Create Maximizer Address Book Entry dialog box opens.

� Enter the name of the customer or vendor, or leave the Name 
field empty to view all customers and vendors. Click Search. 

All matching customers and vendors are retrieved.

� Select the customer/vendor that you want to create the entry 
for.

� In the Options area, choose the type of Address Book entry that 
you want to create. You can also click Field Mappings to 
choose the Maximizer fields that some of the Dynamics GP fields 
are mapped to.

� Click OK.   

The new Address Book entry is created with the data from the 
Dynamics GP customer or vendor. You can specify additional 
details in the Address Book entry.
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Creating Invoices, Quotes, and Purchase Orders 
You can create invoices, quotes, and purchase orders in Maximizer, 
and they will automatically be created in Dynamics GP as well. Before 
you can create any of these transactions, the Company or Individual 
must be linked to either a customer or vendor record in Dynamics GP:

• To create an invoice or quote, the Address Book entry must be 
linked to a customer record.

• To create a purchase order, the Address Book entry must be 
linked to a vendor record.

You can also create new transactions based on existing transactions, 
and create invoices based on quotes. Maximizer copies the 
information from the original transaction into a new transaction and 
enables you to modify the new transaction before saving it. Details 
on these procedures are provided further along in this section.

Each time an invoice, a quote, or a purchase order is created or 
modified, a note is logged in Maximizer. 

➤ To create an invoice, quote, or purchase order

� In Maximizer, open the Address Book and select the Company 
or Individual to create a transaction for.

Ensure that the Address Book entry is linked to a Dynamics GP 
record. If it isn’t, refer to “Linking Address Book Entries” on 
page 19 before proceeding with this procedure.

These menu items are also 
available from the Accounting 
icon in the Edit tab.

� In the Accounting following window, right-click and select 
Add > Invoice/Quote/Purchase Order.  

The Invoice, Quote, or Purchase Order dialog box opens. 
Maximizer automatically fills in the customer or vendor name 
and address, the date, and any tax information. Click on the 
arrow keys to view the details for information such as the tax. 
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You cannot enter a value in the 
Document No., Quote 
Document No., or P.O. Number 
field. When you click OK, the 
number is assigned 
automatically and the value is 
then read-only.

� In the Item column, click on New.  

? For detailed information about 
any of these fields, select the 
dialog box, and press F1.

� In the Add New Item dialog box, select the Item name/number 
for the item from the drop-down list.

� Add or change any of the other information in the Add New 
Item dialog box, as required, and click OK.  

�  Repeat the last three steps until all required items have been 
added to the transaction.

� Complete any remaining fields, as required, and click OK.

The transaction has now been created in both Maximizer and 
Dynamics GP, and Maximizer creates a history note in the Notes 
window of the Address Book entry. You can also view the 
invoice, quote, or purchase order from the Accounting tab of the 
Maximizer Address Book following window, as described on 
page 27.
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Creating a New Transaction Based on an Existing One

Accounting Link enables you to create a new transaction (invoice, 
quote, or purchase order) based on an existing transaction, so the 
newly created transaction automatically contains the information 
from the original transaction, which you can then modify as 
required. This method saves you time because it reduces the amount 
of information you need to enter for similar transactions.

➤ To create a new transaction based on an existing 
transaction

� In Maximizer, open the Address Book and select the Company 
or Individual for whom to create an invoice, quote, or purchase 
order.

� Open the Accounting following window, and select the invoice, 
quote, or purchase order to use as the basis for the new 
transaction.

If the menu item is disabled, 
then you did not select a 
transaction in step 2. Select a 
transaction, and then create 
the new transaction.

� On the Edit tab, select Accounting > Create New Dynamics 
GP Transaction from Selected.

– or –

Right-click in the Accounting following window, and select 
Add > Create New from Selected.

The Invoice, Quote, or Purchase Order dialog box opens, 
depending on the original transaction. Maximizer automatically 
fills in all the information from the original transaction.

You cannot enter a value in the 
Document No., Quote 
Document No., or P.O. Number 
field. When you click OK, the 
number is assigned 
automatically and the value is 
then read-only.

� Change any of the information in the transaction, or add more 
items to the list, as required. 

To remove an item, right-click on it and select Delete from the 
shortcut menu.

� Click OK.

The transaction has now been created in both Maximizer and 
Dynamics GP, and Maximizer creates a history note in the Notes 
window of the Address Book entry. You can also view the 
invoice, quote, or purchase order from the Accounting following 
window, as described on page 27.
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Creating an Invoice from a Quote

Accounting Link enables you to create a new invoice based on an 
existing quote, so the newly created invoice automatically contains 
the information from the original quote, which you can then modify 
as required. Making changes to the invoice does not apply those 
changes to the quote.

➤ To create a new invoice based on an existing quote

� In Maximizer, open the Address Book and select the Company 
or Individual for whom to create an invoice.

� Open the Accounting following window, and select the quote 
to use as the basis for the new transaction.

If the menu item is disabled, 
then you did not select an 
invoice in step 2, or the 
selected transaction is not a 
quote. Select a quote, and then 
create the new invoice.

� On the Edit tab, select Accounting > Create Invoice from 
Selected.

– or –

Right-click in the Accounting following window, and select 
Add > Create Invoice from Selected.

– or –

Open the quote and click the Invoice button.

The Invoice dialog box opens. Maximizer automatically fills in all 
the information from the original quote.

You cannot enter a value in the 
Document No. field. When you 
click OK, the number is 
assigned automatically and the 
value is then read-only.

� Change any of the information in the transaction, or add more 
items to the list, as required. 

To remove an item, right-click on it and select Delete from the 
shortcut menu.

� Click OK.

The invoice has now been created in both Maximizer and 
Dynamics GP, and Maximizer creates a history note in the Notes 
window of the Address Book entry. You can also view the 
invoice from the Accounting following window, as described in 
the following section.
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Viewing Invoices, Quotes, and Purchase Orders 
You can view existing invoices, quotes, and/or purchase orders for a 
customer or vendor from within Maximizer, even if the transaction 
was not created in Maximizer. When you link a Maximizer Address 
Book entry to a customer or vendor, existing invoices, quotes, or 
purchase orders display in Maximizer automatically. 

You can view existing transactions in the Accounting tab of the 
Maximizer Address Book following window.

➤ To view an invoice, quote, or purchase order

� In Maximizer, open the Address Book and select the Company or 
Individual for whom to view a transaction.

� Select the Accounting following window.

� Open the Filter drop-down list, and select Invoices, Quotes, 
Purchase Orders, or All Transactions

The transactions of that type for the selected customer or vendor 
appear. You can double-click any item to view the details. 
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Searching for Invoices, Quotes, and Purchase Orders 

You can search your accounting application for invoices, quotes, and 
purchase orders and then view the transactions in Maximizer. If the 
transaction’s customer or vendor is not linked to an Address Book 
entry, you can also create a new Address Book entry at the same 
time.

You can search for all types of transactions by transaction number. 
You can search for invoices and quotes by P.O. number.

➤ To search for invoices, quotes, and purchase orders

� Open the Accounting following window.

� On the Edit tab, select Accounting > Search for Transaction.

– or –

Right-click in the Accounting following window, and select 
Add > Search for Transaction.

The Search for a Transaction dialog box opens.

� In the Options area, specify the search criteria for the 
transaction.

The transaction number is the unique identifier for the 
transaction while the P.O. number is an optional user-defined 
number.

� To open the transaction automatically after the search, select the 
Open found transaction checkbox. Otherwise, the search 
returns all transactions for the Address Book entry.

� In the Find matching area, specify the types of transactions that 
you want to search for. 

� Click OK.

If the customer or vendor for the matching transaction is not 
linked to an Address Book entry, you are prompted to create a 
new Address Book entry from the customer or vendor. See 
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“Creating Address Book Entries from Customers and Vendors” 
on page 22 for details.

� If multiple transactions are found, select the transaction from 
the list of matching transactions.

The Address Book entry that is linked to the transaction is 
selected, and the transaction is listed in the Accounting 
following window.
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Viewing Accounting Details about a Customer or Vendor    
Maximizer enables you to view the following accounting details 
about a customer or vendor from within Maximizer:

• customer balance

• aged analysis (30-, 60-, or 90-day balances)

• credit limit

• remaining available credit

➤ To view Dynamics GP accounting details

� In Maximizer, open the Address Book and select the Company or 
Individual for whom you want to view accounting details.

� Select the Accounting following window.

This menu item is also 
available from the shortcut 
menu in the Accounting 
following window.

� On the Edit tab, select Accounting > View Customer/Vendor 
Info.

The Customer/Vendor Information dialog box opens. It contains 
the accounting details for the selected Company or Individual.

The Balance details section 
shows the sums of non-posted 
transactions that have 
payment details—the 
transactions visible in the 
Accounting following window.

� View the accounting details in the dialog box.

� Click Close.  
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