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Prerequisites 
 
Microsoft Excel 
Maximizer Connect for Excel Quotes works with Excel 2013 or 2016 desktop versions on Windows OS (Mac OS is not 
supported). It is recommended you install the latest update for Microsoft Office. 
 
Internet Explorer 
Microsoft Internet Explorer 11 or later must be installed, but doesn’t have to be your default browser. Make sure that 
the path for your server URL is NOT set as Compatibility View in Internet Explorer. 
 
The following sites will be added as the trusted sites in Internet Explorer by the add-in installer. Please don’t remove 
them. 
https://ajax.microsoft.com/ 

https://ajax.aspnetcdn.com 

https://appsforoffice.microsoft.com/ 
 
Maximizer API 
On the server where Maximizer CRM is installed, Maximizer web.data API must be enabled.  
 
Setup OAuth 2.0 Settings in Maximizer Administrator 
In Maximizer Administrator > Preferences > System Options > OAuth 2.0 Settings, add a new OAuth 2.0 Client. 
 

 
 
Name: Enter a name for the client, such as Excel Quote Add-in. 
 
Client ID and Client Secret: You need the values from these two fields during the Excel Quote Server Component 
installation. Copy the values to a Notepad for use in the installation later. 
 
Redirect URL: Enter the URL in following format, 
http://[Your Server Name]/MaximizerExcelQuoteAddin/OAuth/AuthorizeRedirect 
 
Add your server name into the URL. 

  

https://ajax.microsoft.com/
https://ajax.aspnetcdn.com/
https://appsforoffice.microsoft.com/


3 
 

Excel Quote Server Component Installation 
 
On your Maximizer Web Server, run MaxExcelQuoteAddinServerSetup.msi to start the installation. Follow the 
instructions in the wizards to complete the process. 
 

Step 1: Select Website that Hosts 
Maximizer 
In this screen, you must select the 
website that hosts Maximizer.  
 
Note: 
If Maximizer is not hosted on the 
Default Web Site, you need to run 
the installation from the CMD 
prompt as a local Administrator and 
select the website that hosts 
Maximizer from the drop-down list. 

 
 

Step 2: Maximizer Web.Data API 
In this screen, you need to enter 
your server name into the URL. 
 

 
 



4 
 

Step 3: OAuth Client ID and Client 
Secret 
In this screen, enter the values for 
Client ID and Client Secret. You 
need to copy the values from 
Maximizer Administrator > 
Preferences > System Options > 
OAuth 2.0 Settings to this screen. 
An OAuth 2.0 client for Excel Quote 
needs to be created in 
Administrator. 
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Quotes Tab 
After the server component is installed, the Quotes Tab will be displayed in the Opportunities module.  
 
Settings for Quotes 

 
 

 

Only the Maximizer Administrator can edit the settings 
for quotes. In the Quotes tab, press the Settings button 
to open the Settings dialog. The following fields are 
available in the dialog: 
 
Quote Status 
The Administrator can add, modify or delete status. The 
status will be available when creating or editing a quote. 
 
Default # of days before expiry 
Default value is 15 days. When creating a quote, the 
expiry date will be calculated automatically based on 
this setting. 
 
Quote ID prefix and # of digits for Quote ID 
These two fields define how the Quote ID will appear.  
 
Download Template and Settings buttons are visible 
only if the login user is the Administrator 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
. 
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Excel Quote Add-in Installation 
 
All users including the Maximizer Administrator will need to install the Maximizer Excel Quote Add-in in order for the 
quoting tool to function.  From within the Quotes tab in Opportunities module, press the Help button, and select 
Download Add-In to begin. The installation file will be downloaded. Run the installation and follow the step by step 
wizard to install the add-in on your computer.  
 

 
 
Run MaxExcelQuoteAddin.exe and follow the instructions in the wizards. During the installation, you need to enter the 
URL for the Excel Quote Server Component. Enter your server name into the URL. 
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Setup Template 
 
Before you can create quotes, your Administrator needs to setup the Quote Template. There are two ways to create the 
template: modify the built-in template or create a brand new template from scratch.  
 
Download the template 
Press the Download Template button in the Quotes tab and the Excel file for the built-in template will be downloaded.  
 

 
 
Open the file in Excel. Since the file is downloaded from the Internet, you may see the warning about the Protected View 
in Excel. Press Enable Editing button. You need to insert the Maximizer Excel Quote add-in into the file and convert it to 
a Quote Template.  
 
Insert Maximizer Excel Quote add-in into the template 
If you install the add-in, go to Excel > Insert Tab in the Ribbon bar > My Apps > Shared Folder tab, select Maximizer CRM, 
and press Insert button.  
 

 

Open the downloaded Excel 

file, edit the template in Excel 

and save it back to Maximizer. 
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In some companies, the IT team will install add-ins on each user’s computer. If someone else installs the Excel add-in on 
your computer, you won’t see the Maximizer Excel Quote add-in App in the Insert Tab of the Ribbon bar > My Apps. You 
need to add the Trusted App Catalog first. 
 
Add Trusted App Catalog 
Open a new Excel file, go to the File menu and select Options. In Excel Options dialog, click Trust Center tab in the panel 
and press Trust Center Settings button. 
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In Trust Center dialog, click Trusted App Catalogs tab. Enter the following URL into the Catalog URL field: 
\\.\C:\MaxConnectOfficeAddins 
 
Press Add Catalog button. Make sure to check Show in Menu option. Press OK button. 

 
 
Close the Excel file. When you open Excel again, the Maximizer Excel Quote add-in will be available in Insert Tab in the 
Ribbon bar > My Apps > Shared Folder tab. Download the template from the Quotes tab, open it in Excel and insert the 
add-in.  
 
 
  

file://///.c:/MaxConnectOfficeAddins
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Convert to Quote Template 
The Maximizer Excel Quote add-in will be displayed in the Excel add-in panel. Press the CONVERT TO TEMPLATE button. 
 
Note: Do not change the name of Quote and Config sheets. 
 

 
 
You will be prompted to save the file to your computer and open the file again. Once you open the file, you will need to 
login to an Address Book. Press the LOGIN button. The Login dialog will be open in Internet Explorer. Select an Address 
Book, enter your user ID and password. Note that you need to have the Administrator role to save the template into the 
Address Book. 
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Edit Quote Template 
After login, the SETUP TEMPLATE tab will be available for 
you to modify the layout of the template. 
 
In this release, the following fields are supported in the 
template: 

 Name and Address 

 Opportunity Objective 

 Quote # 

 Revision # 

 Date 

 Expiry Date 

 Total Amount 

 Opportunity ID 
 
Each field is linked to an Excel cell. If you want to display 
the field in a different cell, select the field from the drop-
down list, enter the Excel cell number in the text field 
below the list and press SET FIELD LOCATION button.  
 
For Name and Address field, you need to specify a range 
of 5 cells in Excel. For example: B8:B12.  
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In the template, enter your company name and contact information. You can set up a product catalog using the built-in 
Products sheet. Enter the information about the products, including SKU, description and unit price in Products sheet. 
After you finish editing the products, you can hide the Products sheet so other users won’t be able to modify the 
product information.   
 

 
 

 
 
Note:  
 
Make sure to press the Enter key or click in another cell after entering or changing value in a cell. 
 
The Quote tab and Config sheet must exist in order for the template to work.  You should never change these sheet 
names.  You should not change anything in the Config sheet as its content is restricted for use by the add-in. You can 
hide the Products and Config sheets so the users will only work in Quote sheet and won’t be able to make changes in 
these two sheets.  
 
Once you finish editing the template, press SAVE TO MAXIMIZER button in the add-in panel to save the template back 
into Maximizer. It will be ready for other users in your company to create quotes. 

Enter your company name 

and contact information 

If you want to display the 

customer’s name and 

address here, select Name 

and Address from the drop-

down list in the panel, enter 

B9:B12 in the field and press 

SET FIELD LOCATION button. 

After you finish editing the 

template, press SAVE TO 

MAXIMIZER button. 

To set these fields, select the respective field from the 

drop-down list, enter the cell number and press SET FIELD 

LOCATION button. 

Edit your products in the Products sheet.  

Your products are listed in the Products 

sheet. When a SKU is selected, other 

product information will be populated. 

Enter quantity, cost will be calculated 

automatically. 
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If you need to modify the template again, download the template from Quotes tab in Maximizer, modify it in Excel and 
save the updated template back into Maximizer. You may make a mistake in your template and accidentally upload it to 
your Maximizer site. If your template doesn’t work anymore, you can re-download the built-in template. From within 
the Quotes tab, press the Help button, and select Re-download Quote Template.  
 

 
 

Using pre-existing Excel Quote templates 
If you are already using Excel to create quotes, you can convert your existing Excel-based quotes file into a Maximizer 
Excel Quote Template.  
 
Open an existing Excel file.  Go to the Ribbon bar > Insert Tab > Add-in > My Apps > Shared Folder tab, select Maximizer 
CRM and press the Insert button. The Maximizer add-in will be displayed in the right-hand side add-in panel. 
 

 
 

 

You need to create two sheets before you can convert 
the Excel file to a Quote Template. 

 Config sheet - It will be filled with configuration 
settings when you press CONVERT TO TEMPLATE 
button. 

 Quote sheet – You will setup your Quote 
Template in this sheet later. 

 
Once you have created these two sheets, press CONVERT 
TO TEMPLATE button. 
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After you convert the Excel file to a template, you will be 
prompted to save the file to your computer and open it 
again. When you open the file, you will be prompted to 
log in to your Address Book. After login, you will be able 
to edit the template the same way as modifying the built-
in template. You need to have Administrator role in order 
to edit the template and save it into Maximizer. 
 
You need to set location for the following fields in your 
template: 

 Name and Address 

 Opportunity Objective 

 Quote # 

 Revision # 

 Date 

 Expiry Date 

 Total Amount 

 Opportunity ID 
 
After you finish editing the template, save it back into 
Maximizer. 
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Quotes Following Tab 
 
The Quotes following tab displays the quotes created for the selected opportunity. You can add or delete quotes, as well 
as modify the properties of the quotes. 
 

 
 
Add 
Press the Add button will download the Excel Quote Template. Open the file in Excel, edit the quote and save it back to 
Maximizer.  
 
Delete 
Press the Delete button will delete the selected quote. 
 
Properties 

 

Pressing the Properties button will open the dialog for 
quickly editing some of the information about the quote, 
including Name, Status, Expiry Date and Comments.  
 
For example, if the customer accepts the quote, you can 
use the Quote Properties dialog to change the status 
from Review to Accepted, without opening the quote in 
Excel. 
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Create a New Quote 
 
To create a new quote, press Add button in Quotes following tab. A new Excel Quote file is generated using the Quote 
Template set up by the Administrator.  This generated file is then downloaded to your browser.  
 

 
 
Open the file in Excel. If it is the first time you try to access the add-in, you will be prompted to login to your Maximizer 

Address Book. If you have logged in before, you can start editing the quote.  

 

Quote Template is download 

after you press the Add button. 

Information about the contact 

associated with the opportunity 

and the opportunity objective 

will be merged into the quote 

automatically. 

The Date, Expiry Date, Quote # and Revision # will be 

populated automatically. 

Enter a name for the 

quote and select a status.  

 Press SAVE TO 

MAXIMIZER button to 

save the quote into 

Maximizer. 

Select a SKU, the product 

information will be 

populated automatically. 

Enter quantity, the cost and 

total amount will be 

calculated automatically. 

Enter tax, discount and 

shipping cost. The total 

amount will be calculated 

automatically. 

Enter your name and 

contact information. 
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When selecting a SKU from the 
drop-down list, if you don’t see any 
item, scroll up to reveal all the 
items. 

 
Note: Make sure to press the Enter key or click in another cell after entering or changing value in a cell. 
 
In the add-in panel, you need to enter a name for the quote and select a status. The expiry date will be calculated 
automatically based on the global “default # of days before expiry” setting. You can change the expiry date manually. 
Once you finish editing the quote, press SAVE TO MAXIMIZER button to save it back into Maximizer. You may need to 
refresh the Quotes tab to see the new quote.   
 
Note that you do not necessarily need to save this file onto your local hard drive because it is already saved into the 
Maximizer database. 
 

  

You may adjust the layout of the quote while you are 
editing the quote. For example, there are many items 
added into the quote, you need to place the Total 
Amount to a new cell. 
 
Scroll to top of the panel and expand MODIFY LAYOUT 
tab, select the field that you want to relocate, enter the 
new cell number, and press SET FIELD LOCATION button. 
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Edit an Existing Quote 
 
To edit an existing quote, click a quote in the Quotes following tab. The Excel file for that quote will be downloaded.  
 
Open the file in Excel and make changes. Once you complete editing, press SAVE TO MAXIMIZER button. You will be 
prompted with two options: 

 Update the existing quote 

 Create a new revision 
 
Select “Update the existing quote” will overwrite the existing quote with the update information. Select “Create a new 
revision” will create a new copy. The new quote has the same Quotation #, but a different Revision #. 

 
 
 
 
 
Note that you do not necessarily need to save this file onto your local hard drive because it is already saved into the 
Maximizer database. 
 

Merge Updated Contact Information into the Quote  
You can get the updated information from Maximizer to 
the quote 
 
If the contact associated with the opportunity or any of 
his information has been changed, press the UPDATE 
button to get the latest information into the quote. 

 
 

 
 

 
 
 

 

If you choose to create a new revision, you 

will see two quotes with the same Quote #, 

but different revision numbers. 
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Save Most Updated Opportunity Revenue Value into 
Maximizer   
You may save the total amount of the quote as the 
Revenue field of the opportunity in Maximizer. 
 
If the customer has accepted the quote, you can press 
the UPDATE OPPORTUNITY button to update the 
opportunity Revenue field with the total amount of the 
quote. 
 

 
 

Sending a Quote 
 
It is recommended that you save the quote as a PDF file to your local computer and send your saved PDF version to your 
customers. It is not recommended that you send  the Excel Quote file to anyone who is not a user of the Maximizer 
database from which the quote originated, as without the add-in and proper credentials, they will not be able to view 
the add-in panel in Excel file properly. 
 
If you have the Maximizer Outlook add-in installed, you can send an email with the quote attached via Outlook, and save 
it into the opportunity. You will save a copy of the email into the Documents tab. 
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